Microcontroller Training

Controller: TC1796

- L]
H_‘-_"' :::::
______________
- AR =

.....
---------
------
ﬂﬂﬂﬂﬂﬂﬂ
ﬁﬁﬁﬁﬁﬁﬁ
*********
=
nnnnn

L]
Hﬁ.-

..........
L )
nnnnnnnnnnn
HHHHH

www.infineon.com/microcontroller

afineon

Never stop thinking



infineon
Agenda i

M Introduction
B Preparation
B Guided Tour
B Exercise 1: hello, world
M Exercise 2: LED
M Exercise 3: Saturation
B Exercise 4: Interrupts
M Exercise 5: ASC
B Exercise 6: Programming the flash
B Exercise 7: Puls Width Modulation
B Exercise 8: Pipeline
M Exercise 9: CAN
Bl Exercise 10: Peripherial Control Processor
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Introduction C/

Training Overview

Intended Audience
Field Application Engineers, Application Engineers

Description

This course provides you with detailed information about

Infineons 32-bit microcontroller architecture. You will be able to explain and
demonstrate the advantages of the TriCore architecture.

Prerequisites

- Basic understanding of microcontroller and C programming
- W2K or XP Notebook w/ CD drive

- 700MB free disk space, 512MB RAM

- 1 parallel port, 1 serial port

- Write access to the BIOS

- Administrator rights

Estimated Learning Time
6 hours
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TC1796 Market & Applications

Target Market #1: Industrial

Applications:

B High-End Drives

B Programmable Logic Controller (PLC)

B Programmable Automation Controller (PAC)
B Industrial Control

Target Market #2: Automotive
Applications:

B Engine control

B Transmission control

B By-wire systems

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-3
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TriCore Architecture

The Infineon TriCore™ architecture combines

the best of three worlds:

RISC, DSP and u-Controller together in a single
core to offers maximum system performance
for embedded real-time applications.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-4
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TriCore Features and Benefits

-~
(Infineon

TriCore Features TriCore Benefits

» High Performance Core with 4-stage pipeline and triple

issue super-scalar implementation. HW supported context

switch in 2 clock cycles

> Optimized chip-size to performance ratio for real-time
critical embedded systems

» Local Memory Bus (LMB) with 64 bits data and separated
busses used for program and data

» Separated instruction and data busses speed up the sys-
tem performance and avoids arbitration conflicts

> Mixed 16-/32-bit instruction format

» Optimized code density for embedded flash memory
usage

» Multi-master interrupt system with HW controlled context

switch, 255 priority levels and fast interrupt response
time

> Sophisticated interrupt system with up to 255 HW arbi-
trated sources and very fast response times is optimized
for real-time sensitive embedded applications

» Powerful MAC unit supports circular buffer; no data over-
flow faults due to saturating arithmetic and bit-reverse
addressing modes for DSP algorithms

» Given scalability approach due to MCU and DSP function
merged in one core. Only one tool set for development

» Single precision IEEE-754 Floating Point Unit (FPU) with
integrated interrupt capability for exception handling

» Balanced data precision and performance requirement

Release 04/2007
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TC1796 Features and Benefits

TC1796 Features TC1796 Benefits

» 195 MIPS at 150MHz » Debug with fast, industry-standard PC interface. Highest flexibility
for gateway or field bus applications
> Peripheral Control Processor (PCP) > Dedicated fast interrupt controller that offloads the CPU
> 2MB FLASH + 208kB SRAM > Large internal memory
> 2 ADC (16 Ch) + > 8/10/12-bit ADCs with 1.25us@10bit conversion time
1 FADC (4 Ch) 10-bit FADC with 280ns conversion time
> 2 General Purpose Timer Arrays (GPTA) > Flexible autonomous module with digital signal filtering and timer
functionality to realize complex I/O management
> External Bus Unit (EBU) > Flexible memory setting with flash, burst flash, EPROM, SRAM
> 4 CAN nodes (CAN) + TTCAN > Field bus to large number of actuator and sensor
> Free DSP library » Take advantage of the inherited DSP capabilities. Save time and
effort and increased time to market without extra cost.
> Real Time Operating Systems » Wide choice of deeply embedded real-time operating system
PXROS, OSE, Euros, uC/0OS-II, ThreadX
» IEC61131.3 Soft-SPS: CoDeSys » The industrial standard compliant system software for automation
and control from the major system vendors

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-6
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TC1796 Block diagram

Release 04/2007

BM SPRAM: Scratch-Pad RAM
PMI ICACHE: Instruction Cache
48 KB SPRAM 56 KB LDRAM LDRAM: Local Data RAM
16 KB ICACHE DPRAM: Dual-Port RAM
8 KB DPREAM BROM: Boot ROM
PFLASH: Program Flash Memory
DFLASH: Data Flash Memaory
SBRAM: Stand-by Data Memory
SEAM: Data Memory
PRAM: PCP Parameter Memory
: CMEM: PCP Code Memary
PhU DMU PLMB: Program Local Memory Bus
16 KB BROM e DLME: Data Local Memory Bus
> MB PFLASH RPE: Remote Peripheral Bus
128 KB DFLASH 64 KB SEAM SPB: System Peripheral Bus
16 KB SBERAM : only available in TCizgeED

Program Local
Memory Bus (PLME)

Data Local
Memaory Bus
(DLMB)

PECL

Emulation
Memaory Interface

QCDS Debug
Interface/ 16 KB PRAM
ITAG

Remote Peripheral Bus (RPE)

Interrupts

FPI-Bus Interface

32 KB CMEM

SCU ‘ PLL | ;EP”
FF

System Peripheral Bus (SPB)

Analog Input Assignment

RBCU

MultiCan
(4 nodes)

MSCao MSC1
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Industrial TriCore Family Overview

RAM[kB]
Flash[MB]
Timers
/Counters
MultiCAN
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ADC channels
Fast Ethernet
Packaging

TC1100 150 (v |- 144 | - 72 |- 3XGPT 7 6|v |2 |2 |- |- |- LBGA-208
TC1115 150 (v |- 144 | - 72 |- 3XGPT 14 12|v |3 |2 |- |V |- LBGA-208
TC1130 150 (v |- 144 | - 72| - 3XGPT 14 12|v |3 |2 |V |V |V LBGA-208
TC1l161 66 | - - 48 | 1 81|36 GPTA+STM 64| 96|- |2 |1 |- |- |- LQFP-176
TC1162 66 | - - 48 | 1 81|36 GPTA+STM 64| 96 /|- |2 |1 |- |V |- LQFP-176
TC1163 80 | - v 64 |1 81|36 GPTA+STM 64| 96 |- |2 |2 |- |- |- LQFP-176
TC1l164 80 | - v 64 |1 81|36 GPTA+STM 64| 96 |- |2 |2 |- |V |- LQFP-176
TC1165 80 | - v 80|1.5 81|36 GPTA+STM 64| 96|- |2 |2 |- |- |- LQFP-176
TC1166 80 | - v 80|1.5 81|36 GPTA+STM 64| 96 |- |2 |2 |- |V |- LQFP-176
TC1796 150 | - v 208 | 2 123 |44 2XGPTA+STM 112 184 \v |2 |2 |- |V |- BGA-416
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Introduction
Web sources

Information

M TriCore Promotion http://www.infineon.com/tricore
Bl Tools and Software http://www.infineon.com/mc-tools

Freely available software
B Altium Tasking Evaluation Version http://www.tasking.com/tricore
B HighTec GNU + PXROS Evaluation Version http://www.hightec-rt.com/tricore.html

B DAVE http://www.infineon.com/dave
B DSP Library http://www.infineon.com/mc-tools > ‘Software Downloads’
B Stack Depth Analyzer http://www.infineon.com/mc-tools > ‘Software Downloads’

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-9
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Introduction

Starter Kit

The Starter Kit has been packaged so that you are productive within 30 min-
utes from unpacking the Kkit.

Content:

B TC1796 Evaluation Board

W Logic Analyzer Extension Board
B Starter Kit CD

B Power plug for EUR/UK/US

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-10
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Starter Kit CD

Documentation

B Getting started

B User Manuals

B Architectural Manuals

B Application Notes

B DSP Optimization Guide

Tools

B Compiler: Tasking, GNU
B Debugger: PLS, Lauterbach, Hitex

Software
B RTOS: OSE, PXROS, Euros
M Libraries: TriLib

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-11
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TriCore is the first combined 32-bit microcontroller/DSP architecture optimized for integrated real-time systems. It com-
bines the outstanding characteristics of three different areas: the signal processing of DSP, real-time microcontroller, and
RISC processing power; and it permits the implementation of RISC load-store architectures. It offers an ideal price/perfor-
mance relationship, because a system requires fewer modules because more functions are integrated on the chip. This
family of controllers is equipped with an optimal range of powerful peripherals for a wide spectrum of applications in power
train, safety, and vehicle dynamics, driver information and entertainment electronics, and for body and convenience appli-
cations.

The instruction set architecture (ISA) supports a global linear 32-bit address space with memory-oriented I/O. The opera-
tion of the core is superscalar, i.e. it can execute simultaneously up to three instructions with up to four operations. Fur-
thermore, the ISA can work in conjunction with different system architectures, also with multi-processing architectures.
This flexibility at the implementation and system level permits different cost/performance combinations to be created

whenever required.

Bit-field, Bit-logical MAC, Saturated Math,
Min/Max Comparison DSP Addressing Modes,
Branch SIMD Packed Arithmetic

Floating =
—

Point

Arithmetic, Logic \

Address Arithmetic
& Comparison,
Load/Store, Context Switch

Load/Store
Arithmetic
Branch

MCAOQ5096
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TriCore contains a mixed 16-bit and 32- bit instruction set. Instructions with different instruction lengths can be used
alongside each other without changing the operating mode. This substantially reduces the volume of code, so that even
faster execution is combined with a reduction in the memory space requirement, system costs and energy consumption.
The real-time capability is essentially determined by the interrupt wait and context switching times. Here, the high-perfor-
mance architecture reduces response times to a minimum by avoiding long multi-cycle instructions and by providing a
flexible hardware-supported interrupt scheme. In addition, the architecture supports rapid context switching.

Detailed information about the TriCore architecture with the complete instruction set is contained in the “TriCore Architec-
ture Manual”.

Overview of the features of TriCore architecture

The list below summarizes the basic features of the TriCore architecture:
e 32-bit architecture,

¢ unified 4-Gbyte data, program, and input/output address space,

e 16-bit/32-bit instructions to reduce code volume,

e low interrupt response times,

e fast, automatic HW context switching,

e multiplication-accumulation unit,

e saturation integer arithmetic,

e bit-operations and bit addressing supported by the architecture and instruction set,
e packed data operations (single instruction multiple data, SIMD),

e zero overhead loop for DSP applications,

e flexible power management,

e byte and bit addressing,

e little endian byte order,

e support for big and little endian byte ordering on the bus interface,

e precise exception states,

e flexible, configurable interrupt management with up to 256 levels.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-13



32-bit TriCore architecture

Program status registers
The TriCore register sets consist of 32 general purpose registers (GPRs), two 32-bit registers with program status informa-
tion (PCXI and PSW) plus one program counter (PC). PCXI, P8W, and PC are core special function registers (CSPRs).
The 32 general purpose registers ate subdivided into sixteen 32-bit data registers (DO to D15) and sixteen 32-bit address
registers (AO to A15). Four GPRs perform special functions: D15 serves as an implicit data register, A10 is the stack
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pointer (SP), Al1 the return address register, and A15 the implicit base address register.

Registers AO and Al in the lower address registers, together with A8 and A9 in the upper address registers, are defined as
system global registers. These registers are not included in any context partition and are not automatically saved or
restored when there is a HW context switch. The operating system uses them, for example, to reduce the system over-
head.

The PCXI and PSW registers contain status flags, information about instructions which have been executed, plus protec-
tion information.

Important: the register database is split into a lower and an upper context, when there is an automatic switch of one half:
saved in a HW-controlled double chained list

Data types

The TriCore instruction set supports boolean operations, bit sequences, characters, fixed point, addresses, signed and
unsigned integers, and single-precision floating point numbers.

Most of the instructions process specific data types, while there are others which are suitable for manipulating various
data types.

Addressing modes

The addressing modes enable load and store instructions to effect efficient access to simple data elements within data
structures such as records, arrays with direct or sequential access, stacks and circular buffers. Simple data elements have
a width of 1,8, 16, 32, or 64 bits.

The addressing modes also ensure the efficient compilation of C, easy access to peripheral registers or the efficient imple-
mentation of standard DSP data structures (DSP addressing modes such as circular buffers for filters, and bit-reverse
addressing for FFT’s). The following seven addressing modes are supported by the TriCore architecture:

- Absolute

- Base + short offset

- Base + long offset

- Pre-increment or pit-decrement

- Post-increment or post-decrement

- Circular

- Bit-reverse

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-15
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Instruction formats

The TriCore architecture supports both 16-bit and 32-bit instruction formats. All instructions have a 32-bit format. The 16-
bit instructions form a subset of them, chosen because of the frequency with which they occur, to reduce the volume of
code. Instructions are selected by the compiler, and can be used in parallel alongside one another with no mode change
etc.

Tasks and contexts

In this book, the term “task” is used for an independent control procedure. Two types of task must be distinguished: soft-
wait-managed user tasks (SMTs) and interrupt service routines (ISRs). Software- managed tasks are produced by the ser-
vices of a real-tine kernel or operating system, and are chosen for processing under the control of scheduling software.
ISRs are chosen for processing by the hardware, as a response to an interrupt. In this architecture, TSR refers only to the
code which is called directly by the hardware. Software managed tasks are sometimes referred to as user tasks, on the
basis that they are executed in user mode.

Each task can be assigned its own authorization level. These individual rights are mainly enabled/disabled by I/O mode
bits in the program status word (PSW). Associated with each task is a set of state elements, known collectively as the
task’s context. The term context is used for everything which the processor requires in order to determine the state of the
corresponding task and to enable its further execution. This includes the CPU general registers used by the task, the task’s
program counter (PC), and its program status information (PCXI and PSW). The TriCore architecture exercises efficient
management of the tasks’ contexts by means of the hardware.

Upper and lower contexts

The context is subdivided into the upper context and the lower context

The upper context comprises the upper address registers A10 - A15 and the upper data registers D8 to D15. These regis-
ters are designated as non-volatile for the purpose of function calls. The upper context also includes the PCXI and PSW
registers.

The lower context comprises the lower address registers A2 to A7, the lower data registers DO to D7 and the PC.

Both the upper and the lower context are associated with a LINK WORD. The contexts are stored in areas with a fixed size,
which are linked together by the link word (see following section).

When an interrupt occurs, the upper context is automatically saved and is restored when the return occurs. If the interrupt
service routine (ISR) needs to use more registers than are available in the upper context, then the lower context will be
explicitly saved and restored by the ISR.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-16
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Contest save areas

The TriCore architecture makes use of linked lists of context save areas (CSAs) with fixed sizes, supporting systems with
multiple, linked control threads. A CSA consists of 16 words of on-chip storage facilities, aligned to a 16-word boundary.
One individual CSA can hold exactly one upper or lower context. CSAs which are not used are linked by an ‘unused’ list.
They are assigned from this unused list as necessary and, when they are no longer required, are returned to the list. The
processor hardware controls their assignment and release. They are transparent to the application code. Only the system
start code and certain of the operating system’s exception handling routines need to explicitly access the CSA lists and the
memory device.

Fast context switching

To increase its performance capability, the TriCore architecture has a uniform context switching mechanism for function
calls, interrupts, and traps. In all cases, the upper context is automatically saved and retrieved by the hardware, with the
saving and retrieval of the lower context being open to the new task as an option. As a result of the unique memory sub-
system design of TriCore, which permits the transfer of up to 16 data words between the processor registers and memory,
so the entire context can be saved in a single operation, fast context switching is speeded up even more.

Interrupt system

A service request can be defined as an interrupt request from a peripheral device, a DMA request or an external interrupt.
For the sake of simplicity, a service request will be described simply as an interruption. The entry code for the ISR consists
of a block within a vector of code blocks. Each code block represents the entry for an interrupt source. A priority number
is assigned to each source. All the priority numbers are programmable. The service program uses the priority number to
determine the memory location for the entry code block. This prioritization of the service programs permits nested inter-
rupts. A service request can interrupt the processing of an interrupt with lower priority. Interrupt sources with the same

priority cannot mutually interrupt each other.

Trap system

A trap is a special form of interrupt for error handling, and is initiated in the event of an exception which falls into one of
the eight classes identified below:

- reset

- internal protection

- instruction errors

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-17
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context management

internal bus and peripheral errors

logically ‘true’ signal state for L signal level

system call

- non-maskable interrupt

The entry code for the trap processing routines comprises a vector of code blocks. Each code block contains the entry
point address for one trap. When a trap is triggered, the trap’s identification number (TIN) is stored in data register D15.
The trap processing routine uses this TIN to identify the precise reason for the trap. During arbitration the trap with the
lowest TIN number takes precedence.

Protection system

The protection system gives the programmer the option to assign access permissions to memory regions, for both data
and code. The ability can be used to protect the core system functionality from bugs that may have slipped through test-
ing and from transient hardware faults. In addition, TriCore’s protection system contains the critical features for isolating
errors, thus facilitating debugging.

Permission levels

TriCore’s embedded architecture allows each task to be assigned the specific permission level it requires to perform its
function. Individual permissions are enabled by means of the I/O mode bits in the program status word (PSW). The three
authorization levels am called User-0, User-1, and Supervisor:

- User-O mode is used for tasks which do not access peripheral devices. Tasks at this level do not have permission to
enable or disable interrupts.

- User-1 mode is used for tasks which access common unprotected peripheral devices. These accesses usually include
read/write accesses to SIO ports and read accesses to timers and most of the I/O status registers. Tasks at this level can
disable interrupts.

- Supervisor mode permits read/write accesses to the system registers and all peripheral devices. Tasks at this level can
disable interrupts.

Protection model

The memory protection model for the TriCore architecture is based on address ranges, with each address range having its
own permission setting. The address ranges and the associated permissions are defined in two to four identical sets of

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-18
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tables, which are stored in the core SFR (CSFR) space. Each set is referred to as a protection register set (PRS). When the
protection system is active, TriCore checks the legality of every load, store, or instruction fetch address before performing
the access. In order to be legal, the address must fall within one of the ranges specified in the currently selected PRS and
permission for that type of access concerned must be available in the matching range.

Reset system

Various events can force a reset of the TriCore device:

- Power-on reset triggered through an external pin when the power supply for the device is switched on (cold start).

- Hard reset: triggered through an external pin during operation (warm start).

- Soft reset triggered by a software write into a reset request register. This register has a special protection mechanism to
prevent unintended accesses. Implementation-specific controls in this register effect either a partial or a complete reset of
the device.

- Watchdog timer reset triggered by an error state recognized by a watchdog timer.

- Wake-up reset triggered through an external pin when the device is reactivated from the energy-saving mode.

The core can check, using a reset status register, which of the various triggers has invoked the reset.

Debugging system
TriCore contains mechanisms and resources to support on-chip debugging. which are used by the Debug Control Unit, a
module which is located outside the core. Most of the functions and details of the Debug Control Unit are implementation-

specific. For this reason, no further description of the unit and its registers is included here. The details will be found in the
documentation for the products concerned.

Programming model

This section discusses the following aspects of the TriCore architecture which are of relevance for the software: the data
types supported, the formats of the data types in registers and memories, the various addressing modes provided by the
architecture, and the memory model.

Data types

The TriCore instruction set supports boolean operations, bit strings, characters, signed fractions, addresses, signed and
unsigned integers, and single-precision floating point numbers. Most of the instructions process specific data types, while
there are others which are suitable for manipulating various data types.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-19
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Boolean expressions

A boolean expression is either TRUE or FALSE. TRUE corresponds to a value of one (1) when it is computed, or non-zero
when it is checked; FALSE corresponds to a value of zero (0). Boolean expressions are generated as the result of compar-
ison and logical instructions, and are used as source operands in logical and conditional jump instructions.

Bit strings
A bit string is a packed bit field. Bit strings are generated and used by logical, shift, and bit field instructions.

Characters

A character is an eight-bit value which corresponds to a very short unsigned integer. It does not assume any specific cod-
ing.

Signed fractions

The TriCore architecture supports signed fractional 16-bit data for DSP arithmetic. Data values in this format have a single
leading sign bit with a value of 0 or -1, followed by an implicit binary point and a fraction. Their values thus lie in the range
[-1,1). When they are saved into registers, 16-bit fractional data occupies the 16 most significant bits, and the 16 least
significant bits are set to zero.

Addresses
An address is a 32-bit unsigned value.

Signed/unsigned integers

Signed and unsigned integers normally comprise 32 bits. When smaller signed and unsigned integers are loaded from
memory into a register they are extended to 32 bits with a sign or zeros. Multiple precision integers are supported by
addition and subtraction with carry. During move and masking operations, integers are regarded as bit strings. Multi-pre-
cision shifts can be done using a combination of single precision shifts and bit field extracts.

Single precision IEEE-754 floating point numbers

Depending on the particular implementation of the core architecture, IEEE-754 floating point numbers are supported by
direct hardware instructions or software emulation.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 0-20
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Data formats

BIT:
All the general purpose registers have a width of 32 bits, 0
and most of the instructions operate on word values (32 S
bits). If data containing less bits than a word are read out of - BYTE. o
memory they must be sign-extended or zero-extended CHARACTER/VERY SHORT INTEGER: |
before any operations can be applied to the whole word. The
required alignments are different for addresses and data. To 15 HALFWORD: 0
permit transfers between address registers and memory, SHORT INTEGER:
addresses (32-bit) must be aligned to a word boundary. For SHORT FRACTION: | ';’ | - |
transfers between data registers and memory, a data item "Binary Point
can be aligned to any arbitrary half-word boundary, regard-
less of its size; bytes can be accessed using any valid byte . WORD: 0
address. The figure shows the data formats which are sup- SR L u
ported. FRACTION: 5
The data memory and the CPU registers save data in ‘little ¥ Ginary Point
endian’ byte order (i.e. the least significant bytes are stored
in the lower addresses). el g
If the TriCore system is connected to an external big endian BIT STRING: — T P .
device, the bus interface carries out the translation between FLOATING.POINT: | 8 CXPONENT CRACTION
the big and little endian formats. As already mentioned,
bytes must be saved on byte boundaries, and half-words, &2 32 DOUBLEWORD: 0
words and double-words on half-word boundaries. Nonen.

The memory model

The TriCore architecture permits up to 4 Gbytes of memory to be accessed. The address width is 32 bits. The address
space is divided into 16 regions or segments (0 to 15). Each segment comprises 256 Mbytes.

The upper four bits of an address are used for selecting a specific segment The first 16 Kbytes of each segment are
accessed using either absolute addressing or absolute bit addressing.

Speculative read accesses are not supported for segments 14 and 15. Accesses to this memory area are only initiated if
the core is sure that the access will be successfully completed. These segments are used for peripheral registers (PSFRSs)
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or for external peripheral devices. FIFOs, peripheral devices with status registers and other devices should be arranged in
this address segment, so that they cannot be the subject of speculative read operations which could result in the deletion
of data. Accesses cannot be made in the User-0 mode.

Segments 0 to 7 are reserved. Any access to them triggers a trap. For segments 8 to 13 there may be further restrictions
in the case of certain products; these are noted in the appropriate product documentation.

Many data accesses are made using addresses which are formed by the addition of an offset value to the contents of a
base address register. In these cases, however, the offset value used must not produce an address beyond the segment
boundary, as this would trigger a trap. This restriction means that the base address can be used at any tine to determine
which segment may be accessed.

The core special function registers (CSFRs) are arranged in one 64-Kbyte area. The base address of this area is product-
specific, and is stated in the appropriate product documentation.

Addressing model
Apart from the addressing modes used in the instruction set, the TriCore architecture allows extended addressing modes
to be realized using short instruction sequences.

Addressing mode Address register used | Offset width
(bits)

Absolute None 18

Base + offset Address register 10/16 (short/long)

Post-op change Address register 10

Pre-op change Address register 10

Circular addressing Address register pair 10

Bit reversed Address register pair -

Built-in addressing modes

These addressing modes allow load and store instructions to efficiently access simple data elements with data structures
such as records, arrays with direct or sequential access, stack memories, and circular buffers. Simple data elements have
a width of 1, 8, 16, 32, or 64 bits. The table gives an overview of the addressing modes which are supported.
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The addressing modes have been chosen to permit the efficient compilation of C, easy access to peripheral registers and

the efficient implementation of typical DSP data structures (circular buffers for filters, and bit-reversed indexing for FFTs).
The instruction formats have been chosen so that they provide the greatest possible space for direct addresses, or offsets
in the case of indirect addressing.

Absolute addressing

Absolute addressing is suitable for addressing peripheral registers or global data. It uses an 18-bit constant for the mem-
ory address, this being specified in the instruction itself. The complete 32-bit address is formed by using the top 4 bits of
the 18-bit constant as the top 4 bits of the 32-hit address, the lower 14 bits being directly copied into the address, and
inserting 14 zero-bits between them.

Base+ offset addressing

Addressing by means of a base + offset is useful for accesses to structural elements, local variables (with the stack pointer
as the base), and static data (with an address register as the base pointer). Here, the final address is the sum of an
address register and an offset value with sign extension. The width of the offset is 10 bits, or for some instructions 16 bits.
This allows any required memory location to be addressed.

Addressing with post-modification

This mode of addressing uses the value of an address register as the final address and, after the access, changes the
address by the addition of a signed 10-bit offset. The sign can be chosen to move the pointer forward or backward. Both
options can be used, for example, for sequential accesses to arrays or to remove (POP) data from a stack memory.

Addressing with pre-modification

This mode of addressing adds a signed 10-bit offset to the value of an address register and uses the result as the final
address. The address register is overwritten with the sum which has been formed. The sign can be chosen to move the
pointer forward or backward. Both options can be used, for example, for sequential accesses to arrays or to store (PUSH)
data into a stack memory.

Circular addressing

The main application of circular addressing is to access data in a circular buffer during filter calculations. In the case of cir-
cular addressing, the current state is stored in an address register pair. The even-numbered register contains the base
address, the upper half of the odd-numbered register contains the buffer size, and the lower half the buffer index. Here,
the final address is the sum of the base address and the index.
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After the access has been made, the index is modified by a signed 10-bit offset (contained in the instruction). Provided
that this offset is less than the buffer size, the index will automatically wrap-round from one end of the buffer to the other.
For example, if the buffer has a size of 50 and the index of 48 is increased by an offset of 4, the index will be given the
value 2 (48 + 4 - 50).

A circular buffer is subject to the following restrictions:

- the start of a circular buffer must be aligned to a 64-bit boundary

- the buffer size must be a multiple of the data size, which is implicitly determined by the access instruction. For example,
when using a “load word” instruction for the access, the buffer size must be a multiple of 4 bytes, and with “load double
word” instructions a multiple of 8 bytes.

Bit-reverse addressing

This mode of addressing is used for FFT algorithms, because with the usual implementations of the FFT the results appear
in bit-reversed sequence. For bit-reversed addressing, an address register pair stores the current status. The even-num-
bered register contains the base address, the lower half of the odd-numbered register contains the array index, and the
upper half the modification value. Here, the final address is the sum of the base address and the index. After each access,
the modification value is added to the reversed index and the result is again reversed. The result of this with a modifica-
tion value of 1024, for example, is the following sequence of indices: 0, 1024, 512, 1536, 256, etc.

As a rule, the modification value represents the reversed value of half the array size.

As bit reversal does not represent a bit field operation, and is therefore only programmed with difficulty, this addressing
mode permits simple programming and rapid processing.

Extended addressing modes

Special addressing modes which are not directly supported by the architecture can be implemented by short instruction
sequences.

Indexed addressing

Using the ADDSC.A instructing, which adds a scaled value to an address register, indexed addressing of byte, half-word,
ward, or double-word arrays can be realized (scaling by 1, 2,4 or 8).

To allow indexed addressing of bit fields the instruction ADDSC.AT determines the word in which the required bit or bit
field is located. Bits are extracted using the EXTR.U instruction, and are stored using the instruction LDMST (load I modify
I store).
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PC-relative addressing

For branching and subroutine calls, it is usual to use PC-relative addressing. However, as this mode of addressing for data
accesses would reduce the performance of the memory system, the TriCore architecture does not directly support such
data access. If PC-relative data access is required, the address of a neighboring label can be loaded into an address regis-
ter and used as the base address.

In the case of code which is loaded dynamically, the current value of the PC can be determined with the instruction IL
(jump and link), which stores the address of the subsequent location in register A11. The return address for the current
routine must be saved beforehand.

Extended absolute addressing

Extended absolute addressing is effected by combining two instructions. The instruction LEA (load effective address) loads
a 32-bit address into an address register. After execution of the instruction MOVH.A (move high word), the data is
addressed using the base address + 16-bit offset.

Core registers

In the TriCore architecture, a set of core special function registers (CSFRs) is defined. These CSFRs control the operation
of the core, and provide status information about the core’s operation. The CSFRs are split into the following groups:

e Program state information

e Stack management

e Context management

e Interrupt and trap control

e System control

e Memory protection

e Debug control
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The sections below present a summary of these registers. The CSFRs are supplemented by a set of general purpose regis-
ten (GPRs). The table includes all the CSFRs and GPRs.

Register name

Description

Register name

Description

SYSCON

System configuration register

DPRx_0 - DPRx_3

Data segment protection register
sets (x=0-3)

CPRx_0 - CPRx_3

Code segment protection register
sets (x=0-3)

DPMx_0 - DPMx_3

Data protection mode sets (x=0-3)

CPMx_0 - CPMx_3

Code protection mode sets (x=0-3)

DO0-D15 Data registers

AO-A15 Address registers

PSW Program status word

PCXI Previous context information

PC Program counter

FCX Pointer to first free location in list

LCX Pointer to last free location in list

ISP Interrupt stack pointer

ICR Interrupt control register

BIV Base address of the interrupt vector
table

BTV Base address of the trap vector table

DBGSR Debug status register

EXEVT External break input specifier
SWEVT Software break input specifier
CREVT CSFR access event specifier
TRNEVT Specifier for trigger event n (n=0,1)

Accessing the core registers

The core uses the two instructions MFCR and MTCR to access the CSFRs. The instruction MFCR (move from core register)
moves the contents of the CSFR which is addressed into a data register MFCR can be executed on any privilege level. The
instruction MTCR (move to core register) moves the contents of a data register into the CSFR which is addressed. To pre-
vent unauthorized write accesses to the CSFRs, the MTCR instruction can only be executed at the Supervisor privilege

level.

The CSFRs are also mapped into the top of the local code segment in the memory address space. This assignment makes
the complete architectural state of the core visible in the address map. This feature ensures efficient support for the
debugger and the emulator.
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purpose.

Gfinesn

Note: the core may not use this mechanism to access the CSFRs, but must use the instructions MFCR and M'TCR for that

There are no instruction which allow bit, bit field, or load-modify-store accesses to the CSFRs. The instruction RSTV (reset
overflow flags) only resets the overflow flags in the P5W, without changing any other P8W bits. This instruction can be

executed at any privilege level.

General purpose registers (GPRs)

The figure shows the general purpose registers. The 32-
bit general purpose registers are split evenly into 16 data
registers or DGPRs (DO to D15) and 16 address registers
or AGPRs (A0 to A15). The separation of data and address
registers facilitates efficient implementations, in which
arithmetic and memory operations are performed in paral-
lel. A range of instructions can be used for the interchange
of information between data and address registers, in
order to generate or derive table indices etc. Two consecu-
tive data registers can be concatenated to form eight
extended size registers (EO, E2, E4, E6, E8, E10, E12 and
E14), in order to support 64-hit values.

Registers A0, A1, A8, and A9 are defined as system global
registers. Their contents are not saved and restored when
calls, traps, or interrupts occur. Register A10 is used as
the stack pointer (SP); Register Al1 is used for saving the
return address (RA) for calls and linked jumps, and for
saving the return program counter (PC) value during
interrupts and traps.

While the 32-bit instructions have unrestricted access to
the GPRs, many of the 16-bit instructions implicitly use

Address GPRs (AGPRs)
31 0

A15 (Implicit Address Register)
A14
A13
A12
A11 (Return Address/RA)
A10 (Stack Pointer/SP)

A9 (Global Address Register)
A8 (Global Address Register
AT
AB
A5
Ad
A3
A2
A1 (Global Address Register)
A0 (Global Address Register)

31

Data GPRs (DGPRs)

D15 (Implicit Data Register

D14

D13

D12

D11

D10

D9
D8

D7

D6

D5

D4

03

D2

D1

D0

A15 as their address register and D15 as their data register. This implicit use facilitates the coding of these instructions in
16 bits. To support 64-bit data, these values are stored in an even/odd register pair. In Assembler syntax, these register
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pairs are designated either as one pair of 32-bit registers (for example D9/D8) or as one extended 64-bit register (thus,
for example, E8 is the concatenation of D9 and D8, where D8 represents the less significant word of E8).

It should be noted that there are no separate floating point registers, but that the data registers are used in performing
floating point operations. The saving and retrieval of floating point data is effected automatically, making use of the fast
context switching. The GPRs represent an important element in the context of a task. When the context for a task is being
saved to or restored from memory, the context is divided into an upper and a lower context. Registers A2 to A7 and DO to
D7 are part of the lower context. Registers A10 to A15 and D8 to D15 belong to the upper context.

Registers for program state information

The PC, PSW, and PCXI registers store and reflect the program state information. When the context for a task is being
saved or restored, the contents of these registers form an important part of the procedure, and are saved/restored or
modified during this process.

The program counter (PC) contains the address of the instruction which is currently being executed.

The five most significant bits of the PSW contain ALU status flags, which are set or cleared by arithmetic instructions. The
remaining bits of the PSW control the permission levels, the protection register sets, and the call depth counter. The PCXI
register contains the link to the previous execution context and supports fast interrupts and automatic context switching.

Context management registers

The context management registers comprise three pointers: FCX, PCX and LCX. These pointers handle context manage-
ment and axe used during the operations to save and restore the context.

Each pointer consists of two fields: a 16- bit offset and a 4-bit segment specifier. A context save area (CSA) is an address
range which contains 16 word locations (64 bytes), which is the memory space required to save one upper or one lower
context. By incrementing the offset value by one, the effective address is always incremented to the address 16 word
locations above the previous address (offset moved 6 bits to the left). The total usable area in each address segment for
CSAs amounts to 4 Mbytes, which gives memory space for 64 K of context save areas.

The effective address must point to memory which exists. Otherwise the system behavior is undefined.

The FCX pointer register contains the pointer to the start of the free locations list which always points to an available CSA.

The previous context pointer (PCX) stores the address of the CSA for the previous task. PCX is part of the PCXI register.

The LCX pointer register contains the pointer to the end of the free locations list, and is used to recognize impending CSA
list range underflows. If the value of FCX resulting after for an interrupt or a CALL corresponds to the limit value then,
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although the context save operation will be completed, the destination address written into the trap vector address will be
forced to that for the emptying of the CSA list.

Stack management register

Stack management in the TriCore architecture supports a user stack and an interrupt stack. The management of the stack
involves the address register A10, the interrupt stack pointer (ISP), and one PSW bit. The general purpose address regis-
ter A10 is used as the stack pointer. The initial contents of this register are usually defined by an operating system when a
task is generated, where individual tasks can be assigned a private stack area. The interrupt stack pointer (ISP) prevents
the interrupt service routines (ISRs) from accessing the private stack areas and possibly interfering with the context of the
software-administered tasks. The TriCore architecture implements an automatic switch to the use of the interrupt stack
pointer instead of the private stack pointer.

Interrupt and trap control registers

Three CSFRs support interrupt and trap handling: the interrupt control register (ICR), the interrupt vector table pointer
(BIV), and the trap vector table pointer (BTV).

The interrupt control register (ICR) contains the current CPU priority number (CCPN), the enable/disable bit for the inter-
rupt system, the pending interrupt priority number (PIPN), and an implementation-specific control for the interrupt arbi-
tration schema. The other two registers contain the base addresses for the interrupt (BIV) and trap vector tables (BTV).
When an interrupt is accepted, or when a trap occurs, the pointer to the address in the interrupt/trap vector table is
formed by shifting the value of the priority number / trap class 5 bits to the left and then ORing it with the value of the
BIV/BTV register. The shift to the left results in a step spacing of 8 words (32 bytes) between the individual entries in the
vector tables. The base addresses must be carefully aligned. On the one hand, the addresses must represent even byte
addresses (half-word addresses) and on the other hand the base addresses must be aligned to a boundary which is a
power of two, because of the simple ORing with the shifted priority values. The appropriate power of two is determined by
the number of entries used. For example, the full extent of 256 interrupt entries requires alignment to an 8-Kbyte bound-
ary. For the 8 trap classes (0 to 7), alignment to a 256 byte boundary is sufficient.

System control registers

Three registers provide system control:
the system configuration control register (SYSCON), the local program memory unit control register (PMUCON), and the
local data memory unit control register (DMUCON).
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Memory protection registers

The TriCore architecture incorporates hardware mechanisms which protect memory areas specified by the user from unau-
thorized accesses by read, write, or call instructions. Furthermore, the protection hardware can be used to generate sig-
nals to the debug unit. TriCore includes register sets in which the address ranges and access rights for a series of memory
areas are specified. There are separate register sets for code and data memory.

The 2-bit PRS field in the PSW allows up to four such register sets to be selected in each case (four for data and four for
code). The number of register sets provided for memory protection is defined specifically for each implementation of the
TriCore architecture.

Data and code segment protection registers

The register pairs DPRx_n/CPRx_n comprise the two-word registers which define the lower and upper boundary addresses
of the corresponding memory area. If the lower boundary is greater than the upper boundary, then no range checks will
be carried out. If the lower boundary is the same as the upper boundary, then the area is considered to be empty.

When debug signals are being generated, the values in DPRx_n/CPRx_n are regarded as individual addresses, instead of
defining a range. Signals are then generated to the debug unit if the address of a memory access corresponds with the
contents of one or more of DPRx_n/CPRx_n. For this purpose, a comparison is made with the contents of the upper
boundary register.

The 8-bit data/code protection mode registers determine the access permissions and debug signal generation for the
data/code protection areas defined by the respective registers.

Debug registers

Seven registers have been implemented to support debugging. These registers define the conditions under which a debug
event is generated, or what actions are to be initiated when a debug event occurs, and they also supply information about
the state of the debug unit. The precise functions of the debug unit depend on the particular implementation. A description
of the functions and the associated registers will be found in the appropriate product descriptions.

Block diagrams of 32-bit microcontrollers
The following figures show block diagrams of three selected 32-bit microcontrollers.
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T OM| SPRAM: Scratch-Pad RAM

PMI ICACHE: Instruction Cache
48 KB SPRAM - 56 KB LDRAM LORAM: Local Data RAM
15 KB ICACHE HILIG DPRAM: Dual-Port RAM

E KB DPRAM BROM: Boot ROM

PFLASH: Program Flash Memory
DFLASH: Data Flash Memaory
SBRAM: Stand-by Data Memony
SEAM: Data Memory
PRAM: PCP Parameter Memory
CMEM: PCP Code Memaory
PLMB: Program Local Memory Bus

Program Local
Memory Bus (PLMBE)

Data Local
Memory Bus
(DLMB)

PMLU

-
& KB BROM DML DLMB: Data Local Memory Bus

;_:.l ME PFLASH RPE:  Remote Peripheral Bus
128 KB DFLASH 64 KB SRAM SPB:  System Peripheral Bus
- : only available in TC17g6ED

Emulation
Memory Interface

QCDS Debug
Interface/ 16 KB PRAM
ITAG

Remote Peripheral Bus (RPE)

Interrupts

FPI-Bus Interface

32 KB CMEM

Ports

System Peripheral Bus (SPB)

PLL | J{:J

Analog Input Assignment

RBCU

Mol CAN
(4 nodes)

rl.l'l IE'- E 0 rlll'l IE" E i

TC1796 functional units
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M DM féiliz:r:\éi:atinns:

Instruction Cache
16 KB SPRAM IriCore <6 KB LDRAM SPRAM: Scratch-Pad RAM
8 KB ICACHE ITIIH'.'{:- : LD REAM: LDEE' Data RAM

cps | OVRAM: Overlay RAM
BROM: Boot ROM
PFlash: Program Flash
Local Memory Bus (LMB) DFlash: Data Flash

PMU

16KBBROM | 5% LBCU
1504 KB PFlash : ]
32 KB DFlash |S = LFI Bridge

B KB OVRAM

B KB PRAM
Interrupt
System

g

OCDS Debug
Interface/
ITAG

d

Interf

PCP2 Core

STM

Interrupts

FPI-Bus

12 KB PCODE

frm
feru

System Peripheral Bus (SPEB)

Analog Input
Assignment

Ext. MultiCAN
Reguest {

Unit

MultiCAN not available in TC1165
TC1166 functional units
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PMI DMI

32 KB SPRAM 28 KB SPRAM
16 KB Cache 4 KB Cache

IriCore’

CPS
Local Memory Bus (LMB)

EBU
SDRAM, BFLASH

DMU

LFI Bridge 64 KB SRAM

Boot ROM

16 KB BROM
Flexible CCUsD

Peripheral

PORTS

GPTU
USB1.1

=
o

i .
} i O/
Ethernet 'Eﬂ'uu_l :Lw
(4 nodes)

TC1130 functional units

OCDS/JTAG
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The 10 exercises of this training are a jump-start to program the Infineon TriCore. The exercises are intended to help you
understand the intrinsics of hardware-based and microcontroller programming and to develop the necessary programming

and debugging skills.
Starting with a basic set-up the exercises cover the main features of the architecture: instruction set, interrupts, peripher-

als, flash, pipeline.

hello, world The classical 'hello, world".

LED Use DAVE to generate the on-board LED blink program.
Saturation How to make use of the instruction set features in C.
Interrupts Set up interrupt routines easily.

ASC Configure an on-chip peripheral.

Flash Program the flash.

PWM Setup the GPTA for a Puls Width Modulation signal.
Pipeline Optimize code for the super-scalar architecture.

CAN Communicate via CAN.

PCP A first step into the Peripheral Control Processor.

Preparation Steps

B Configure the parallel port in the BIOS of the development host
B Check the TriBoard

B Configure the TriBoard

B Connect the TriBoard

M Install the compiler, debugger and DAVE.
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Configure the parallel port
Reboot the notebook and enter the BIOS. Set-up the parallel port mode to Bi-directional (ECP).

Dell Computer Corporation (www.dell.com)

**% Basic Device Configuration *****  Controls whether the computer's
Serial Port: coml parallel port acts as a NORMAL
Infrared Data Port: Disabled port (AT-compatible), a
BI-DIRECTIONAL (PS/2-compatible)
Parallel Mode: BE8gort, or as an ECP port (default).

Keyboard Click: Disabled

Num Lock: Enabled

Enable Keypad: Only By <Fn> Key
External Hot key: Scroll Lock

USB Emulation: Enabled
Pointing Device: Touch Pad-PS/2 Mouse

SmartCard Function: Enabled

Primary Vidio: Dock Vvideo Card

Video Expansion: Enabled

~,¥ change field | «,> change values | ALT+P page | Esc ex
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Configure the TriBoard
M Picture
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B Schematics

P 3B X804 GPTA/NMLI X801 BUS EXPANSION
a 288 |:1 L1
?(Hj 1 o ux:321o o 8301 — P
L i
D: - )Gﬂﬂﬂﬂﬂﬂ I][l["][l[”]l] E% EE
\/ OCDS? 1 8 =X =X
I;—/ S Clock 29 (29
) < > o g2
7 0 %ﬁ} § - _
2 = 55 |£3
Q O o8- | TC1796 T D
% reser O S 3<C
g OlrocaLe o 590
A , L v
. % Burst FLASH | | Burst FLASH
\J Reset O 16Bit 16Bit
0
Power L
|: X803 ADC X802 PERIPHERALS
1 L1

B Connect Pin 1 and 2 of JP501 to use the on-board wiggler.
Note: The shadowed line indicates the defauit sefting

Setting ‘Dn Board Wiggler
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M Set the DIP switch S301[1..8] to {ON,ON,OFF,ON,ON,ON,OFF,OFF} to set HWCFG[3..0] =

c‘f‘

2
& {(E’J

'[:.J

&
9
A @G
Cj
&Qﬁ {(?'ﬁ
& 4:-

=)

H.GH/ﬁﬁyﬁﬁ ==

[BRK_IN |HWCFG[3...0] | Type of Boot PC Start value

1 0000 Serial boot from ASC to PMI OxD4000000
scratchpad, run loaded program

1 0001 Serial boot from CAN to PMI OxD4000000
scratchpad, run loaded program

1 0010 Start from internal flash OxA0000000

1 0011 Alternate Bootmode from internal flash | from Header or

OxD4000000

1 0100 External memory, EBU as master O0xA 1000000

1 0101 Alternate Bootmode from External from Header or
memaory, EBL as master OxD4000000

1 0110 External memory, EBU as slave OxA 1000000

1 0111 Alternate Bootmode from External from Header or
memory, EBU as slave O0xD4000000

1 1XKX reserved; don't use this combination -

0 1000 go to external emulator space OxDEODDDOD

0 0000 put chip in tristate (deep sleep) -

0 all others reserved; don't use this combination -
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Check the TriBoard

B Make sure the TriBoard is equipped with an TC1796.
B Make sure that the MHz oscillator on board is properly connected.
B Connect the serial port ASCO of the TriBoard to your PC using a serial cable.

B Connect a power supply Output connector:
Hollow plug 5.0mm/2.1mm, Polarity +0)-
Output voltage: 5.5V - 60V DC (7.5V, 500mA recommended)
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5V, 3.3V and 1.5V will be generated internally. Three green LEDs indicate the correct status of the internally generated

voltages
B Open the Microsoft HyperTerminal and set-up a COM port connection with 9600, 8, N, 1, None.
B Press the reset button on the Triboard. Every Triboard comes flashed with an *hello, world’ program.

“& 9600-8B-N-1-None - HyperTerminal
File Edit Wiew Call Transfer Help

Hello Yorld!

I'am the TriBoard with TC1796
developed at

INFINEON Technologies AG in Munich
Department AIM MC ATY AE

Thomasiusplatz
D-81541 Hunich
Tel.:+49-89-234-0
Fax.:+49-89-234-811785

If vou have guestions to this board or to TriCore CPU,
see the manuals on the TriBoard CD.
Have fun working with me!

The CPU running at 150000000 Hz
The Peripherals running at 75000000 Hz

running since: B0h:00min:12sec

Connecked 00:04:57 Auko dekeck a&00 5-M-1
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Connect the TriBoard

B Connect the TriBoard to your PC using a parallel cable. The on-board wiggler is used to connect a PC to the TriBoard
OCDS Levell via the LPT port.

Install the Tasking Compiler

B Start the from the Starter Kit CD at <CD>:\tools\altium\setup.exe
B Follow the Instruction on the screen.

Install the PLS debugger

B Start the from the Starter Kit CD at <CD>:\tools\pls\setup.exe p ]_ S
B Follow the Instruction on the screen. " i

Install Infineon DAVE

M Start the from the Starter Kit CD at <CD>:\tools\infineon\dave\setup.exe E‘!Tnil'-li'ﬁ_
M Follow the Instruction on the screen. If your asked to install Acrobat 4 click No. -..'ipr'.l., al -
B Start DAVE and install the TC1130 support by choosing View > Setup Wizard from the Engineer

View menu. Select I want to install products from the Dave’s web site and navigate to

<CD>:\tools\infineon\dave\products s
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Exercise 1: hello, world

hello, world

In the first exercise you make yourself familiar how to build an 'hello, world" application. You will download and run the
application on the TriBoard. The application writes the string 'hello, world' to stdout. Using the Tasking stdio library and
the CrossView Pro debugger these streams are redirected via JTAG to a terminal window inside the debugger. This feature

is very useful during the development and most debugger vendors offer a solution with similar functionality.

The only way to learn a new programming language is by writing programs in it. The first program to write is the

same for all languages:
Print the words

hello, world
Programming in C, Brian W. Kernighan and Dennis M. Ritchie

1. Create a new Tasking project space
Launch Tasking and choose File > New Project Space.... In the Filename field enter c:\infineon\getstart. Click OK.

Create a New Project S5pace

Current Directaony:
C:hinfineon

Filenarne:

|n::"~infine::nn"ugetstart

| Look in same directory for external workspace

-

Browse. . ] | Cancel |

The Project Properties dialog appears.
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Exercise 1: hello, world

2. Create a new Tasking project
In the Project Properties dialog click the New Project icon 1 to add a new project.

Project Properties

£y «<Default Settings> Directories | Members | Tonls | Errars | Filters |

getstart [0 Projects]

Froject Space:  C:\nfineonhaetstart pap

Frojects: §| IE.l

b
r;.hdd new projeckt ko projec

The Add new Project to Project Space dialog appears. In the Filename field enter hello\hello to create the new
project in a subdirectory. Click OK.

Add New Project to Project Space @

Current Directory:
C:Mirfineon

Filerarne:
hellothello

| Look in zame directory for external makefile

-
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Exercise 1: hello, world

3. Add a new source file

In the Project Properties dialog click the New File icon ‘3| to add a new file.

Project Properties

£ <Default Settings> Directories | Members | Toals | Erars | Filters |
%ettat [iEt] Froject: C:hinfineonthellohhello. pit
el U Files] : -
Files: ] el o< |

add riew File to project { Ak

The Add new File to Project dialog appears.
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Exercise 1: hello, world

In the Filename field enter hello.c to create and add a new source file. Click OK.

&3

Add New File to Project

Current Directary:
C:hinfineontshelo

Fileriame:

hella.c

Browsze... |

Ok,

Cancel I Help |

Project Properties

i...% hello [1 File

£y <Default Settings:
getstart [1 Project]

Directories | Members | Tools | Errors | Filters |

Project: C:hinfineonthelohhello. pit

Files: ||i'+| |E|

C:\infineonsheloshello. o

| Hide files already in project 0 of 1 zelected

Esternal kakefile:

LR0ne:

Save and close the Project Properties dialog by clicking OK.
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Exercise 1: hello, world C/

4. Set up the Project Options
Choose Project > Project Options... to open the Project Options dialog.

C:hinfineonhgetstart. psp
getstart [1 Project)

SR=Y hello kot
W s igg IHE‘]E'Wt'FI|E|I=I'|l b
:-D He X150Ng Fles

P Inchude Sub-Project. ..
D Fe Remove from Project Space
|:| aly Project Options. ..

Build
Rebuild

Yersion Conkrol »
Properties. ..

Edit this menu. ..
Choose Processor > Processor Definition from the left tree. Choose Target Processor: TC1796B from the drop down
list.

TriCore ¥X-toolset Project Options [HELLO.PJT]

= Pracessar Proceszor Definition

Proceszar Defintion T arget processor | - |

Bypazzes

: :L?EEHH urafior The FPU and MMLU options are only relevant for uzer defined processors.

S EE 2 &, pozzible FPU AL in the selected CPU will be zupported regardless
1 Azserbler the state of the grayed checkbox.
+- PCP Azzembler [
+|- Linker [
+- Crozz\iew Pro
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Exercise 1: hello, world

Choose CrossView Pro > Execution Environment from the left tree. Choose Execution environment:
TriBoard (TC1796B) via DAS to enable debugging via Infineon's device access server (DAS).

TriCore VX-toolset Project Options [HELLO.PJT]

Processor Esecution Environment

Processor Defirition Execution environment: TriEl oard [TC17IEE] with SPAM wvia DAS j

B
Ypazzes DAS TCPAP Settings (host.port): localhost 23 T
+- Startup

Bus Configuration
C Compiler
Bgzzembler |
FPCP Asgzembler
Linker
CrossWiew Pro
Ewecution Erviranment
+ Sirmulator

Save and close the Project Options dialog by clicking OK. Look at the project window. Your project has 2 source files:
cstart.asm and hello.c. The start-up code cstart.asm is copied automatically to any project from the Tasking installa-
tion directory.

+- [ [F]-[*

C:Ainfineonhgetztart. pzp
getztart [1 Project)

£4
Ela Source Files
E >|__“| cstart. azm
- L[ helloc
>[:| Header Files
>[:| Froject Files
>|:| Resources
L.[27] Other Files
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5. Add the application code
Open the hello.c document window and write the 'hello, world' application code.

#include <stdio.h>
int main (void)

{
printf ("hello, world\n");

return 0O;

}
Choose File > Save to save your work.

6. Build the application

Choose Build > Build. The generated messages from the build process can be inspected in the Build tab of the output
window. If the output window is not shown, choose Window > Output and click on the Build tab. The Build process fin-
ishes successfully generating the hello.elf file and can be downloaded to the target.

= TAZEING program builder w&.3rl Build 078 3N 00000000

Compiling and assembling "hello.c™

* Buid A FileFind 4 Search /& Browse 4 Difference A Shell 4 Symbols /
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Exercise 1: hello, world

Infineon
7. Download the application

Once the files have been compiled, assembled, linked, located and formatted they can be executed by CrossView Pro. To
execute CrossView Pro choose Build > Debug. CrossView Pro will automatically download the compiled file for debug-

ging.

*; CrossView Pro - TriCore (DEMO) - hello.elf
File Target Edit Run Breakpoints Data Tools  Setkings  View  Simolator Window  Help

ElEAl S [l m » I W[Z 6= 22 0% v +E M

[ v Q8 E& & M E
| 4 jl Oxa000000g j|main leDurce lines j|5n:uurn::e line step ﬂ

#include <stdio.hs
int maini)

!
L, oo printf(“hello, world."):
0.000%

il
il

8. Run the application
Choose Run > Run to execute the application. A Terminal window appears, displaying the string ‘hello, world’.

Terminal: FSS 0 Mi=13
L

hello, world.

Choose Run > Reset Application and try stepping through the source code typing F10. Choose File > Exit to exit
CrossView Pro.
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9. Save the project options

Save the project options for next exercise in a file by choosing Project > Save Options.... In the Save to File field,
enter hello and click OK.

Save Options

¢ Save Al Options
" Save Custom Options: Ok,

[] C Campiler Options Cancel
(] MISRA C zettings

[] Azzembler Ophons

[] PCF Azzembler Ophions
[] Linker/Locator Optionz
[] Crozs\iew Pro Ophionz

Save to File:
hello
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Exercise 2: LED blink
virtual Engineer. DAVE is available for free for any Infineon 8-, 16- and 32-bit microcontrol-

LED blink
A 'hello, world' application is often impossible to write on embedded devices because stdio is
not supported. Embedded programers therefore often starts with writing a simple applica-
tion that toggles an led on the board. In this exercise we will use the tool that help you to
configure the initialization code for Infineon microcontroller: DAVE, the Digital Application

ler. DAVE generates an application framework based on the configuration you made. DAVE is

also very helpful in understanding the microcontroller because while you set up the configuration on a higher abstraction
level you are still able to inspect the changes that were made on register level. DAVE has also a powerful link to the users
manual and lets you jump from a configuration dialog directly to the appropriate information in the online manual. In this
exercise DAVE will be used to configure a port pin that is hard wired to an LED on the TriBoard.

Digital
Application
virtual |
Engineer

DAVE
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1. Create a new DAVE project
Launch DAVE and choose TC1796 from the list of 32-bit microcontrollers. Click Create.

% DAvVE - New Project

TC1100 PETC116G
TC1115 W TC1766
TC1130 P TC1796
TC1161 r[%
TC1162

TC1163

TC1164

TC11E5

Create

Caricel

Help

Two new windows, the TC1796 project window and the Project Settings dialog appear.
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Exercise 2: LED blink

The project window presents an overview of the TC1796 architecture. By clicking on each of the items, the properties of
the item can be viewed and modified.

W TC1796

TC1796

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 2-3
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DAVE gives you a complete overview of all registers. Choose View > Register Explorer an browse e.g. to System Con-
trol Unit (SCU) > PLL_CLC.

ter Explorer [ZI[E|

3

7 7

5] System Contral Lnit [SCUY with ' atchdog Tin
[ CHIPID [Chip |dentification Flegister) PLL_CLC (PLL Clock Control Register)
El] EICRO [Extemal Input Channel Fegister Address: 0xF0000040 Reset value: 0x01630480 Actual Value: 0x001D0382
E EICR1 [Estemal lnput Channel Register ©
E EIFR [Esxternal Input Flag Register) Bit Mo. 31 30 20 25 27 26 25 24
E] FME [SCU Flag Modification Register) B PRIM OSCOISC
:;ﬂ IGCRO [Interrupt Gating Reagizter 0 JY— - s
.;.?ﬂ IGCRT [Interupt Gating Reqizter 1] Walue 0 0 0 i i i 0 0
E] MAMID [Manufacturer dentification Regi
S MMISE [MMI Status Register) . . - N . g s - .
E O5C_COM [Dzcillator Contral R egizter) o I I I I , ,
(5l PCP_PSCACTL (PCP SR Control Ars | | oMV | |
E FCP_PSCADIN [PCP SRAM Contral Arre Access —
5] PCP_PSCADOUT (PCP SRAM Control & Yalug 0 0 0 1 1 1 0 1
E] FORR [Pattern Detection Result B eqgizte
B FLL_CLC [FLL Clock Control Fegister) Bit Mo, 15 14 13 12 11 10 g a
[ PMG ES[PDwerManagement Contral ' PO ' ! WDl !
E] H5T_REQ [Reszet Request Regizter) n I I I I I

CCEss

E R5T_SH [Reset Status Register) \alue 0 rEIF 0 0 0 0 P i i
E RTID [Redezign Tracing |dentification B
[T Sl COM ISE Cankoal Panichar]

It's a good practice to keep this Register Explorer window open, so that changes of the register settings can be seen
instantaneously. The bottom left tree shows a list of all registers which has been changed since the last time the Register
Explorer window was opened. Click the Documentation icon or use the context menu on the tree item to go directly
to the online manual explaining the details of the register.

------ . P4 PUDSEL [Part 4 Pull up/down Select Regizter)

""" - F'LL CLC |F'|_|_| lock Cornkrol F||-'|:|| h—-r'
------ [ SSCO_BR (SSC Baudrate Timer Relnz kil User's manual
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Exercise 2: LED blink

2. Set up the Project Settings
In the Project Settings dialog select the Compiler settings Tasking 2.0. If the dialog is not open choose

File > Project Settings.

% Project Settings E|
ksl | ¥
General lS_l,lEtem I:I::u:k] Inkermipt S_I,Istem] FCF 5y3tem] Fad Dri'-.fer] Startup Ennfiguratinn] Nntes]
Controller Tepe
Type | TC1796 |

b ax. systemn clock |1 50 MHz

kain Source File b ain Header File

File name WA, File name (b h

Compiler Settings

T GMU

(" Tazking 1.5

(* Tazking 20

Lt

Most of the dialogs in DAVE have the same style. A multitab dialog where each page is used to configure a specific part.
The dialogs have a small toolbar with a Close icon m|, a Documentation icon - and a Help icon % . The docu-
mentation menu is context sensitive showing only links to information appropriate for the current dialog.
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Exercise 2: LED blink

3. Set up the System Clock.
On the System Clock page

B Set the external clock frequency to 20 MHz, PDIV = 2, NDIV = 60, KDIV = 4,

& Project Settings f'5_<|

™ &La - 7

External Clock Frequency

E sternal clock frequency |2|:| r FLL Bypazz operation [fopu = fosc)
[MHz] [pin BYPASS =1)
Input divider [FDTY) \fp = fosc / 2 = 10.000 MHz R

Yoltage Controlled Oscillator [WCO)
[ WCO Bypass mode WCOBYF)

¥LO range VCOSEL] 1500 mHz - 700 MHz v
Feedhack divider (NDM) [fyco =fose /P <60 = 600000 MHz v po oy, [BO0.00D
Output Disvider
Olutput divider (KD (fopu = fvco / 4 = 150,000 MHz R [EMF'HUE]E":":I‘“ 150.00000000
¢ The ratio fepu / faps is 241 System Clock =5 noonnonn
[MHz]

{7 The ratio fopu A fapzis 1 /1

Click the Close icon @ on the dialog toolbar to close the dialog.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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XTaLt
l I—L I = Clock Generation Unlt {CGLU)
.:.:,2: fos: o Chock
L Chuipy
Circul L "‘Iﬂrm?n
el i P ﬁ ke
*] Divider el Eia ';EJ * Divicle
5 — 'IH . Datact, VGO 4 rfj‘ F F
M-
1 1_ ] l L Dirvidiar
Do PLL .
Run Lock
Diatect, [rapact.
o] o 4| o
L (T} I o
of 8 8 8 2§ 3 B EEER
8 2 & & g8 ¢ 2 SlE| 8l &
—1
BYPASS | L i r
Qscllator Control Registar PLL Clock Conérol and Stakes Flggaslnr
O5C_CON FLL_CLG
: System Contral Uakt (SCU)}
PES S
TEDHA WCBI
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Exercise 2: LED blink

4. Configure the Port.
Click on Port in the project window to open the Parallel Ports properties.

The Parallel Ports properties dialog appears. Click on Configure Port 1.

Configure Port 0

Configure Port 2

Configure Part 1

The Configure Port 1 dialog appears.

5. Configure Port

One of the ports is always connected to an LED on the TC1796 TriBoard. The information can be found in the TriBoard

Manual.

Release 04/2007

Copyright © Infineon Technologies 2007. All rights reserved.
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Exercise 2: LED blink

On the Port 1 page
B Check Functionality Use P1.15 as general IO,
B Select General Direction Out.

& Configure Port 1

£ IR (NI R NI L RN DRI RN NI NN SN SN AN R

™ &L - 7

Fort 1 llnput Eharacteristic] Cukpat Eharacteristic] F'arameters] Nntesl

Functionality:

Jze P1.0 az general 10
dze P1.1 az general 10
lze P1.2 ag general 10
Uze P1.3 az general 10
dze P1.4 az general 10
lze P1.5 ag general 10
ze P1.6 az general 10
ze P1.¥ az general 10
lze P1.8 ag general 10
lze P1.9 az general 10
dze P1.10 as general [0
lze P1.11 az general [0
ze P1.12 az general [0
ze P1.13 as general [0
lze P1.14 az general [0
Uze P1.15 az general [0

General Direction: FPuzh Pull / Open Drain: Cutput Walue:

{+ " [ [
(o [ B [
(+ { BB [
{+ " [ [
(+ I [ [=
(s { [= [
{+ 5 B [
(v I [ [
(s { [ 7
{ I [~ [
(+ { & [
(s { [ [in
{+ " [ =
(+ { [ [=
(+ { — [t
" In iyt [ Open drain | high

X

=)

neon

If the Register Explorer is still open, register P1_IOCR12 is added to the changed register view. See the changes of byte
PC15 in register P1_IOCR12.
Click the Close icon IE| on the dialog toolbar to close the dialog.

Release 04/2007
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6. Enable the source code generation for the Port
On the Functions page check the module initialization function 10 vInit and the I0 vTogglePin function.

& Parallel Ports E|
Kai Zig
Ports  Functions l F'arameters] Hntesl
Initialization Funchion Source File
W {10 _vlnit File: name I0.c

Funchion Libramy [Part 1]

DAVE has the opportunity to generate only the function you need in your application. This keeps you source code clear and
the application code small.

DAVE has a function naming schema: <module> <return value><function>,
where <module> is the module name in capital letters, <return value> is v (void), ub (unsigned byte), uw (unsigned
word), vi (void interrupt) etc. and <function> is the function name.
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Click the Close icon @ on the dialog toolbar to close the dialog.

7. Save the project
Choose File > Save and save the project as c:\infineon\led\led.dav.

8. Generate the application framework
Choose File > Generate Code to start the code generation process. DAVE looks in the project directories for already
existing files, reads these files and copies all lines between the comment lines // USER CODE BEGIN and //

USER CODE END to the newly generated files. This superior feature makes DAVE to be used continuously during the whole

development time.
The generated files can be explored in the new window.

@ Generated Files in "E:\DOCUMENTS AND SETTINGS\SCHRAPEYMY DOCUMENTSMNFINEONYTASKINGYTC1 79 6ALED'

[ ?
@E] Generated Files
= TC1796REGS H sword main(woid)
& MAIN H !
(L) MAIN.C

void MAIN_vinitlvc | ;7 usER CODE EEGIN (Main,z)
woid MAIN_wiwritel

sword swheturn;

S ¢ USEER CODE EMD
swlheturn = 0O;

LED .ASM
EE? switch (REEZET _INDICATOR)

&2 LEDRTF {

EEELEDJ]PT case WATCHDOG RESET: S the last reset was a watchdog triggered
Ff thardware) reset

S USER CODE BEGIN (Main,d)

fSFf USER CODE END

caze EZ0FTWARE REZET: S the last reset was an internally
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To edit the file click the Open icon in the dialog toolbar to open the file with the registered file type viewer of your Win-
dows Explorer. This should be the Tasking EDE. Save and Close the DAVE project.

9. Add a new project to the Tasking Workspace
Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\led\led.pjt.

10. Add the application framework

In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.
Scan Existing Files into Project

Pattern:
|“.n:;“.h

Crirectaony:

|C:tinfineontled

| Include subdirectaries

Ok | Cancel |

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.

Page 2-11



infi
Exercise 2: LED blink Cinfineon

11. Set current project
Use the context menu in the workspace window to make the led project the current project.

x

C:Minfineonhgetstart. pzp

getstart [2 Projects)
% hello [2 Files)
=k
|:| S o h et as Current Projeck
|’_“| He: Remove from Project Space
’D Fiol  properties...
e Res
g Otk Edit this menu. .. "

12. Load the project options

Choose Project > Load Options and load the option file from the previous exercise. Enter
c:\infineon\hello\hello.opt in the Filename field and click OK.

13. Build the application

Click the Build icon on the Build toolbar. The system is issuing a long list of warnings:

DAVE projects and Tasking project uses different register definition files. Tasking automatically includes a special function
register file regtc1796.sfr which is part of the Tasking installation. DAVE projects needs the TC1796Regs.h file that was
created during the code generation process.
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14. Modify the project options

Choose Project > Project Options....
In C Compiler > Preprocessing uncheck Automatic inclusion of ’.sfr’ file (e.g. disable for DAVE projects).

TriCore ¥X-toolset Project Options [LED.PJT]

Freproceszing

+ Processor

=1+ C Compiler | Store the C compiler preprocess autput [<file: . pre)
Freproceszing | dutomatic incluzion of 'zt file [e.q. dizable for DAYE projects)
Language
Mmba v LmFmrme = b

Close and Save the Project Options dialog by clicking OK.

15. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.
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Exercise 2: LED blink

16. Save the project options

Save the project option in a file by choosing Project > Save Options and save the options as
c:\infineon\tcl796 extmem.opt. These options will be used in later exercises again.

Save Options

(¢ Save Al Options

" Save Custom Options: Ok,

[] C Campiler Options Cancel
(] MISRA C zettings
[] Azzembler Ophions
[] PCF Azzembler Ophions
[] Linker/Locator Optionz
[] Crozs\iew Pro Ophionz

Save to File:

||:: hinfineonttc] 796 extrmem. opt

17. Add the user code
Add a delay function implemented as a macro to MAIN.h at (MAIN_Header,3)

// USER CODE BEGIN (MAIN_Header,B)
#define delay( milliseconds ) \

{for (unsigned int i1i=0; ii < ( milliseconds * 150000/2); ii++) { __nop(); _ nop(); }}
// USER CODE END

The two __ nop () ("No operations") are necessary to halt the program during the execution of the delay functions. Some
debugger has problems with too short loops.
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Add the following code to MAIN.c at (Main,9)

// USER CODE BEGIN (Main,9)

for(;;) A
I0 vTogglePin (IO P1 15); // Toggle LED
delay (1000) ; // 1 second delay

}
// USER CODE END

To browse through your source code, e.g. searching for the definition of 10 vTogglePin select the function with the
mouse and click the right mouse button. The context menu offers you a quick way to look for the selected element in all

Project Files or Project Space.
S/ USER CODE BEGIN (Maizn,9)

for(::) £* forever #g
{
I0 ﬂﬂgﬂlEPi“hT'—' 1 1C% « Vot Ml -~ TETI £ )
ﬂEI-EI.}" |: ll:“:“:l :I I Flr"j II|:|_"."Tl:lgglE'Fllnl |r| FIlESIFDldEfS

) Quick Search Documents

44 USER COUDE END Browse For 'O _wTogglePin' (exact maktch) m
Project Space

Browse for 'TO_wTogglePin®' {wildcard match)
return(swEeturn) |

18. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

19. Debug the application
Click the Debug icon @ on the Build toolbar to open the CrossView Pro debugger.

20. Run the application

Click the Run icon p on the CrossView Pro toolbar. See the LED blinking on the TriBoard.
Choose File > Exit. A dialog appears. Confirm Exit.
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Exercise 3: Saturation

Saturation

The TriCore™ Instruction Set Architecture (ISA) combines the real-time capability of a
microcontroller, the computational power of a DSP, and the high-performance/price fea-
ture of a RISC load/store architecture onto a compact, reprogrammable core. One of the
key features is a saturating integer arithmetic. With the Tasking compiler this feature is -
accessible as a C language extensions. This exercise shows how saturating integer arith- Trl CoreTM
metic can be used to dramatically improve execution speed. To learn more about the B e
instruction set, you should read the TriCore™ Architectural Manual.
Infineon also offers a highly optimized DSP library called TriLib for free.
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Paris, 19 July 1996

ARIANE 5
Flight 501 Failure
Report by the Inquiry Board

FOREWORD

On 4 June 1996, the maiden flight of the Ariane 5 launcher
ended in a failure. Only about 40 seconds after initiation of
the flight sequence, at an altitude of about 3700 m, the
launcher veered off its flight path, broke up and exploded.

- -
i el

2. ANALYSIS OF THE FAILURE

B The internal SRI software exception was caused during

execution of a data conversion from 64-bit floating point to
16-bit signed integer value. The floating point number
which was converted had a value greater than what could
be represented by a 16-bit signed integer. This resulted in
an Operand Error. The data conversion instructions (in Ada
code) were not protected from causing an Operand Error,
although other conversions of comparable variables in the
same place in the code were protected.




Exercise 3: Saturation

(Infineon
1. Create a DAVE project

Open the Windows Explorer and create a new directory c:\infineon\sat. Copy the led.dav file from the previous exer-
cise to the new directory and rename the file to sat.dav.

2. Open the System Timer Properties
Start DAVE and open the sat.dav project file. Click on STM in the project window to open the STM properties.

3. Configure the System Timer (STM)

On the Module Clock page
B Uncheck Disable the STM module (DISR)
B Choose Module Run Mode Clock Control System clock / 1.

& System Timer [STM) \ (%]
Kai |
fodule Clock l Resolutions | CMPO | CMP1 | Intermupt Contral | Interupts | Functions | Parameters | Mates |

todule Dizable Bequest

| Dizable the ST module [DISRA]

kodule Run Mode Clock Control

Clack, divider far normal

operation mode [FMC) Syztem clock /1 (= 75,0000 MHz; 13.333 ne | j
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On the Functions page
B Check the initialization function STM vInit and the read timer function STM uwReadSysTmr.

& System Timer (STM) Ed
Kai ¥ B
todule I:I::u:k] Hesnlutinnsl EMF'EI] CHF1 ] Inkermipt I:::untrcull Intermupts FUHC“D”SI F'arameters] Nntes]
Imitialization Function Source File
W ISTH_wlnit File: name I5TH.c

Function Libramy [Part 1)

v |5 TM_uwwReadSysTmr

Click the Close icon IE| on the dialog toolbar to close the dialog.
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4. Generate the application framework
Click the Generate Code icon ﬂ on the application toolbar to start the code generation process.

& Generated Files in "E:\DOCUMENTS AND SETTINGS\SCHRAPE\MY DOCUMENTSAINFINEONYTASKINGYTC1796\SAT M=
[ ?

= @] GEnEratEd FIlEE .lll'.lll".l'1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘*'.l".l‘1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘ﬂ.‘***1.'ﬂ.‘ﬂ.‘*****************t*****t* F.Y
&7 TC1F3EREGS . H £ AMacrao STM uwReadSysTor (TimerName)

&2 MAIN.H £
= MAIN.C /e

£ Ahescription The =ystem timer i=s a Le-hit free rumnming timer. This macro

£§3|D}4 L reads the selected part of the timer. The timer can be read

&7 I0.C L in the following manner:

(5] STH.H I - bits 0..31 by reading the leow word of the timer (TIMO)
STM_uwReadSywsTmr(TimeMame] |77 - bits 3E..EE by reading the high word of the timer

& 5TML i (TIME
&7 SATASM £ Hote:

éEESﬂTJqTF L To read the entire timer walue as one entity, a special
cAT DPT L capture register (CAP) is implemented. Each time the low

=2 ) £ word of the timer iz read, the high word gets latched into

L the capture register. This can then be read with the next

£ word access.

£ Additional parts of the timer cawn bhe read by using

i additional read addresses.

£

£ The following definitions for TimerMName are awailahle:

£ STH_TIMER O bic=s 0 ... 31 :

L - resolution = 0.013 p=s; - range = L7.Z66 =

Save and Close the DAVE project.

5. Add a new project to the Tasking Workspace

Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\sat\sat.pjt.
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6. Add the application framework

In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

7. Set current project
Use the context menu in the workspace window to make the sat project the current project.

8. Load the project options

This exercise uses the internal memory. The appropriate option file can be found in the tc1796.zip package. Copy the
tcl796 intmem.opt to c:\infineon. For a description see Appendix C. Choose Project > Load Options. In the File-
name field enter tc1796 intmem.opt.

9. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

10. Add the user code

Three different solution to handle saturation during an addition are considered.
Solution 1 is an ANSI C, plausibility check.

long x1,x2,y;

y = X1 + x2;

if ((x1 >= 0) && (x2 >= 0) && (y < 0))
y = LONG MAX;

else if ((x1 < 0) && (x2 < 0) && (y >= 0))
y = LONG MIN;
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Solution 2 is ANSI C but uses a 64-bit word width.
long long dummy;

dummy = (long long)xl + (long long)x2;
if (dummy > LONG MAX)
y = LONG MAX;
else if (dummy < LONG MIN)
y = LONG MIN;
else
y = (long) dummy;

Solution 3 uses a Tasking language extension that directly maps to a TriCore™ instruction.

y = (__sat long)xl + (__sat long)x2;
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The execution speed of each solution is measured with the system timer function STM uwReadSysTmr. The result is printed

to a CrossView Pro terminal window. Add the following code to MAIN.c at (Main,9).

// USER CODE BEGIN (Main,9)
unsigned long dt,i;
volatile long x1, x2, y;

const int N = 1000; // Each calculation is done N times
// to measure the execution time precisely
xl = 6; x2 = LONG MAX; // Initialize x1, x2 to numbers so that

// the sum exceeds LONG MAX

// Solution 1: ANSI C, plausibility check
dt = STM uwReadSysTmr (STM TIMER O) ;
for (i=0; 1i<N; 1i++) {
y = x1+x2;
if ((x1>=0) && (x2>=0) && (y<0))
y = LONG MAX;
else if ((x1<0)&&(x2<0)&& (y>=0))
y = LONG MIN;
}
dt = STM uwReadSysTmr (STM TIMER 0) - dt;
printf ("Solution 1: %.1f CPU cycles\n", 2.*dt/N);

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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// Solution 2: ANSI C, increase of word width

long long dummy;
dt = STM uwReadSysTmr (STM TIMER O);
for (1=0;i<N;i++)
dummy = (long long) x1l+ (long long) x2;
if (dummy > LONG MAX)
y = LONG MAX;
else if (dummy < LONG MIN)
y = LONG MIN;
else
y = (long) dummy;
}

dt = STM uwReadSysTmr (STM TIMER 0) - dt;

printf ("Solution 2: %.1f CPU cycles\n",

2.*dt/N) ;

// Solution 3: Language extension, saturation type

dt = STM uwReadSysTmr (STM TIMER O) ;
for (i1i=0;1i<N;i++) {

y = (__sat long)xl + (__sat long)x2;
}

dt = STM uwReadSysTmr (STM TIMER 0) - dt;

printf ("Solution 3: %.1f CPU cycles\n",
// USER CODE END

2.*dt/N) ;

=)

neon

LONG MAX, LONG MIN are macros of the C standard library. Include 1imits.h and stdio.h in MAIN.c at (MAIN_General,2).

11. Build the application

Click the Build icon on the Build toolbar. The Build process finishes successfully.

12. Debug the application

Click the Debug icon @ on the Build toolbar to open the CrossView Pro debugger.
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Exercise 3: Saturation

13. Run the application
Click the Run icon ®|on the CrossView Pro toolbar. The CrossView terminal window will show the result:

Terminal; FSS 0

aolution 1: 20.0 cycles
Ggolution 2: 13.0 cycles
aolution 3: 3.0 cycles

Solution 2 executes only slightly faster than solution 1, but with the language extension used in solution 3 the execution
speed is much faster. The 5 instructions used in solution 3 - two loads, add with saturation, store and loop - take up just

3 cycles because of parallel execution using the 3 pipelines in the TriCore™.

Tr| Core

Integer Plpellne

Loadetore Plpellne

Loop Plpelme

Page 3-10
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Exercise 4: Interrupts

Interrupts

A key feature of the TriCore™ architecture is its powerful and flexible interrupt system. The
interrupt system is built around programmable Service Request Nodes (SRNs). Conventional
architectures handle service requests by loading a new Program Status (PS) from a vector
table in data memory. With the TriCore™ architecture however, service requests jump to vec-
tors in code memory. This procedure reduces response time for service requests. The first
instructions of the Interrupt Service Routine (ISR) execute at least three cycles earlier than
they would otherwise. This exercise shows that programming interrupt services with TriCore™ using DAVE is quite simple.
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Featu res Other Sarvice Provider CPU
B In a TriCore™ system, multiple sources such as peripherals or intemupt Atbitaton Bus - JerpLABIEHOnBUS | yernupt Service
external inputs can generate an interrupt signal to the CPU or e — Provders
another provider to request for service. Control Unit
B Each interrupt or service request from a module connects to a | R 1 FIntA-::k
Service Request Node, containing a Service Request Control Service Service Request BIPN . '
Register (SRC). Interrupt arbitration busses connect the SRNs e Nodes I XCPN
with the interrupt control units of the service providers. These [ sRNs [ M| other
control units handle the interrupt arbitration and communica- Service
tion with the service provider. N a—T provider
B A peripheral can have several service request lines, with each [Module 2] H+— sRNs [ *1|
one of them connecting to its own individual SRN.
B The 8-bit Service Request Priority Number (SRPN) of a service
request, indicates its priority with respect to other sources | [ SRN: | M,
requesting an interrupt to the same service provider, and to the L
priority of the service provider itself. ¢ | SRNs Softwere
B The interrupt arbitration scheme permits up to 255 sources to Moauied | | —w srns [1*|| . o~
be active at one time. cru
B The Interrupt Control Unit (ICU) manages the interrupt system Int.Req -
and arbitrates incoming interrupt requests to find the one with — ) a Int. Ack,
the highest priority and to determine whether or not to inter- odde X T I— | PIPN ™~
. . CCPN
rupt the service provider. |I

B Several conditions could block the CPU from immediately
responding to the interrupt request:
- The interrupt system is globally disabled
- The current CPU priority CCPN, is equal to or higher than the Pending Interrupt Priority Number (PIPN).
- The CPU is in the process of entering an interrupt or trap service routine.
- The CPU is operating on non-interruptible trap services, a multi-cycle instruction.

B The interrupt response time for a system with e.g. 15 interrupts is 9 cycles. 2 arbitration are 1 priority check are done in
parallel to CPU operation. 2 context save, 1 acknowlege to ICU, 3 for fetching and jumping to the first instruction.
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Exercise 4: Interrupts
1. Create a DAVE project

(Infineon

Open the Windows Explorer and create a new directory c:\infineon\isr. Copy the sat.dav file from the previous exer-

cise to the new directory and rename the file to isr.dav.

2. Modify the Project Properties

Start DAVE and open the isr.dav project file. Choose File > Project Settings.

On the Interrupt System page
B Check Enable globally the Interrupt System (IE).

& Project Settings Ps__q

™ &La - 7

General] Syztem Clock  Intermupt System l PCP 5y3tem] Pad Driver] Startup Ennfiguratinn] Nntesl

CPU Global Interrupt Enable

Click the Close icon @ on the dialog toolbar to close the dialog.

3. Open System Timer Properties
Click on STM in the project window to open the STM properties.
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Exercise 4: Interrupts

4. Modify the System Timer (STM) configuration
On the CMPO page
H At Start Bit Location of CMPO enter 24 and type Return,

B At Compare Register Size of CMPO enter 1 and type Return,
B At Compare Register 0 enter 1 and type Return. The free running timer sets bit 24 every 224 timer ticks, thus issuing

a compare event every ~0.223s (=224/fSTM). Decimal numbers entered in the text field are converted automatically to

hexadecimal.

& System Timer (STM) (%]

™ &L - 7

Start Bit Location of CKMPO

Loweszt bit number [0 to 24] of STM which iz compared with the content of register
CMPO bit 0 (M5 TART] 24

Compare Register Size of CRPO

Mumber aof bitz [1 to 32] in regizter CMPO [ztarting from 0], which are used far the Ii
compare operation with ST [MSILED) 1

Compare Register 0

Real compare value 0x00000001

Flequied compare o nnnnanoT N (dependent of MSIZED]

wvalue [CHPO)
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On the Interrupt Control page FCF  GRU
- It o Inte
B Check Enable request on compare match with CMP0O (CMPOEN), Atbitration Bus Aubitrasion Bus
B Check Enable SRCO interrupt (SRE), Senvics Senvics Req. PCP Initermupt Iritermupt
- Ragquestors Modes Ceontrzd Linit Service
B Select Select interrupt output STMIRO. | . — Providars
: MEC0 el maAns ] 2 Int.
& System Timer (STM) x| NN Rz [T i, Ack.
— MSCA Sdul oomne 1] 2 FIPN >
4 r 4 GGPH
9 | 9 4 1z
MLID o 45ANs | | 4,
M odule EI::u:k] Flemlutinm] I:MF'I:I] CrP1  Interrupt Control llnterrupt&] Funn:tin:nn&] Parameter&] Nu:nte&] NEE Service Req.
MLI1 Zelsl 2smns | 2 Hodes Pere
Compare Register CRPO [nterupt Control Compare Register CMPO [nterrupt Dutput Selection [CRMPO05) * ?‘; ! [ P
a + -
: SSC0 #| 35ANs | | 3 5|
v Enable request on compare match (v Select interrupt output STMIRD T3 27 5 ahns |+
. _ o e =
with CMPO [CMPOEN] [ Select interupt output STRIBT 85C4 3ela| 35RNs o 2 5 5
NEER »| 2 SANs |[&—
_ _ _ A5C0 Aelol asmns || 4
Compare Regizter CMP1 Interrupt Control Compare Regigter CMP Interrupt Output Selection [CMP105) 3 T NEAN sofiuare
- e . & Break-
- ASC Lol asmns [T 4 . s
r Enable request on compare match g - point -
with CMPT [CMPTEM] ~ : 15 ML I_-_I.:'Ll Interrupt Intermupt=
Muli AN =1+ 16 SRANs ig Contral Unit
* f Tl CRU
41, T Irit.
Irterrupt Contral of STHIRD [rtermipt Contral of STHMIRT ADEO i g il 4 F:' -
4 S pIpN . Ei CCPN
v Enabie SHE ternt (GHET - At AR [
FaDC 4 *| 4 SRNs -f 4: Service Req. Sarvice
T q Modes Requestors
GPTAD |25 el 23 cANs NES 3] 18R |e L DBECL
NEN AN
aPTal 2l m sAns 1] 2 17| tsAN fe PBCU
16 PR L, 1
LTCAZ =41+ 16 SANs | | 45 3| | 1SRN |« SBCL
2 1
2| - * — K
—1= ? ‘%q_ 1 SAM [ RECL
FPLI LP I 1‘,= g f 3 SANs |2 DA
- PLE N
A 1,
Flash Ll 1smM ] 3. K HEE D R C—
| PELE I
o 2 1,
Ext Int. (<> 28RNs | ] 2. 31| 15AM e sofvare
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5. Set up System Timer Interrupt
On the Interrupts page drag the STM SRN 0 interrupt from the right list to the CPU Interrupt level 5.

& System Timer (STM)
Eai i

b odule I:I::u:k] Hesnlutinns] EMF'EI] ChF1 ] Interrpt Contral — Intermupts l Funn:tin:nns] Parameters] Nu:ntes]

CPU Interrupt [max. 255] |PEPIrﬂenupthnaaEEE] - Level 0 [hon intermupting]
Lewel 15 | e
Level 14
Lewvel 13
Lewvel 12
Level 11
Level 10
Lewvel 3
Level B
Level 7
Level &
Leveld |5TM SHM O
Lewvel 4
Lewvel 3
Level 2
Lewvel 1

-

Mote: To change the level and the group of an interrupt zource, click onit, drag it to itz rew pozition and drop it
To =et an interrupt zource to the non interupting level [Level O] click on it, drag it to the Level 0 izt and drop it

Click the Close icon IE| on the dialog toolbar to close the dialog.
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The maximum number of interrupt sources is 255. Programmable options range from
one priority level with 255 sources, up to 255 priority levels with one source each. Dur-
ing the execution of an interrupt service routine, the system blocks the CPU from taking
further interrupt requests. You can immediately re-enable the system to accept inter-
rupt requests:

__lnterrupt (vector) enable isr( void )

The compiler generates an enable instruction as first instruction in the routine. The
enable instruction sets the interrupt enable bit (ICR.IE) in the interrupt control register.
The function qualifier bisr () also re-enables the system to accept interrupt
requests. In addition, the current CPU priority number (CCPN) in the interrupt control
register is set:

___lnterrupt (vector)

bisr (CCPN) i1isr( void )

The argument CCPN is a number between 0 and 255. The system accepts all interrupt
requests that have a higher pending interrupt priority number (PIPN) than the current
CPU priority number. So, if the CPU priority number is set to 0, the system accepts all
interrupts. If it is set to 255, no interrupts are accepted.

The compiler generates a bisr instruction as first instruction in the routine. The bisr
instruction sets the interrupt enable bit (ICR.IE) and the current CPU priority number
(ICR.CCPN) in the interrupt control register.

[

Priority
Group 2

]

T
Priority
Group 1

<

Interrupt Vector Table

PN = 255
PN = 18
PN = 17
PN = 16
PN = 15
PN = 14
PN = 13
PN = 12
PN = 11
PN = 10

If less priority level are sufficient than the number of arbitration cycles can be reduced which also reduce the interrupt

latency. See the File > Project Settings page Interrupt System.
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6. Generate the application framework

Click on the Generate Code icon ﬂ on the application toolbar to start the code generation process. Save and close the
DAVE project.

7. Add a new project to the Tasking Workspace

Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\isr\isr.pjt.

8. Add the application framework

In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

9. Set current project
Use the context menu in the workspace window to make the isr project the current project.

10. Load the project options
Choose Project > Load Options. In the Filename field enter c:\infineon\tcl1796 extmem.opt.

11. Build the app!ication

Click the Build icon on the Build toolbar. The Build process finishes successfully.
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12. Add the user code

Add an endless loop in MAIN.c at (Main,9) and add the following code to the interrupt routine in sTM. c.

void __ interrupts (STM INTO) STM viSRNO (void)
{

// USER CODE BEGIN (SRNO,2)

// USER CODE END

if (STM ICR CMPOIR == 1) // if compare match of CMPO is pending
{

// USER CODE BEGIN (SRNO,3)

IO vTogglePin (IO P1 15);

// USER CODE END

STM ISRR CMPOIRR = 1; // clear request bit of CMPO

if (STM ICR CMPLlIR == 1) // if compare match of CMPI1 is pending

{
// USER CODE BEGIN (SRNO,4)

// USER CODE END
STM ISRR CMP1IRR = 1; // clear request bit of CMPI

}

// USER CODE BEGIN (SRNO,5)
// USER CODE END

} // End of function STM viSRNO

13. Build the application

Click the Build icon on the Build toolbar. The Build process finishes successfully.
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Exercise 4: Interrupts

14. Debug the application
Click the Debug icon @ on the Build toolbar to open the CrossView Pro debugger.

15. Run the application
Click the Run icon ﬂ on the CrossView Pro toolbar. See the LED blinking. Exit CrossView.
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Exercise 5: ASC
ASC

In this exercise you will develop an application that writes a strings to the serial port.

The Asynchronous/Synchronous Serial Interfaces provide serial communication between
the TC1796 and other microcontrollers, microprocessors, or external peripherals. The ASC
supports full-duplex asynchronous communication and half-duplex synchronous communi-
cation. In Synchronous Mode, data is transmitted or received synchronous to a shift clock
which is generated by the ASC internally. In Asynchronous Mode, 8-bit or 9-bit data trans-
fer, parity generation, and the number of stop bits can be selected. Parity, framing, and
overrun error detection are provided to increase the reliability of data transfers. Transmission and reception of data are
double-buffered. For multiprocessor communication, a mechanism is included to distinguish address bytes from data
bytes. Testing is supported by a loop-back option. A 13-bit baud rate generator provides the ASC with a separate serial
clock signal which can be very accurately adjusted by a prescaler implemented as a fractional divider.

Each ASC module, ASCO and ASC1, communicates with the external world via two I/O lines. The RXD line is the receive
data input signal (in Synchronous Mode also output). TXD is the transmit output signal. In the TC1796, the two I/O lines
of each ASC can be alternatively switched to different pairs of GPIO lines. Clock control, address decoding, and interrupt
service request control are managed outside the ASC module kernel.
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Features

B Full-duplex asynchronous operating modes
— 8-bit or 9-bit data frames, LSB first
— Parity bit generation/checking
— One or two stop bits
— Baud rate: 4.69 MBit/s to 1.12 Bit/s @
75MHz
— Multiprocessor mode for automatic
address/data byte detection
— Loop-back capability

B Half-duplex 8-bit synchronous operating
mode
— Baud rate: 9.38 MBit/s to 763 Bit/s @ 75
MHz

B Double buffered transmitter/receiver

B Interrupt generation
— On a transmit buffer empty condition
— On a transmit last bit of a frame condition
— On a receive buffer full condition
— On an error condition

Release 04/2007

To

Clock Lﬁ-
Coontrol
RXD 10
< _
Address | | ASCO LAl
Decader Module RxD O
(Kernel) B
dEIFE TXD O
TBIR
Interrupt |+ TR
Control |e Py
RIR
=}
ASCO RDR [
o * —
DMA ASCO TDR
RxD 10
< a
ASC1 4RKD—H
Module RXD O
(Kemel) B
) o TXD_O
TBIR
Interrupt |« TR
Control |e -
RIR
4
* ASC1_RDR
DMA ASC1 TDR
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1. Create a DAVE project

g

f

ineon

Open the Windows Explorer and create a new directory c:\infineon\asc. Copy the isr.dav file from the previous exer-

cise to the new directory and rename the file to asc.dav.

2. Open the ASCO properties

Start DAVE and open the asc.dav project file. Click ASCO in the project window to open the ASCO properties.
RS-~ - T LR s (-, e BE

3. Set up the ASCO properties

On the Module Clock page
B Uncheck Disable the ASCO module (DISR),
B Choose Module Run Mode Clock Control System clock / 1.

& Asynchronous Synchronous Serial Interface 0 (ASCO)

™ &ta - ?

todule Clock l Fin Selectinn] Eu:nntrn:nl] Baud Flate] Interrupt&] Funn:tin:nn&] Parameter&] Nu:nte&]

kModule Run Mode Clock, Contral

todule Dizable Regquest Sleep Mode Enable Contral
— Dizable the A5 C0 moduie = Dizable the sleep made for the ASCO module
ADISEL o [EDIS)

Clock. divider for normal
operation mode [RMC)

Spztern clock /1 [= 75,0000 MHz)
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On the Pin Selection page click Configure pins ASCO_RX and ASCO_TX.

& Asynchronous Synchronous Serial Interface 0 (ASCO) ['5__(|
Eai "7
Module Clock,  Fin Selection lEu:nntrn:nI] Baud Flate] Interrupt&] Funn:tin:nn&] Parameter&] Nu:nte&]

General Dperating Mode [M]

{+ Full-duplex asynchronous operating modes " Half-duplex 8-bit spnchronous operating mode

Alternate Pin Selection

Canfigure pins ASCO_RX (= none] and ASC0_TX [= none)
£
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On the ASCO_RX page

H Select Use pin P5.0 as ASCO receive input signal (ASCO_RX).

% Configure Alternate Pin Functions

Kal i
ASCO_RX | 45C0TX |

A5C0_Rx Pin Selection
(" Mo pin as A5C0_R= zelected

s Usze pin P5.0 a3 A5C0 receive input signal [ASCO_Rx]
(_%Jse pin PE.8 az A5C0 receive input signal [A5C0_Fx)

Pull Device Driver Mode
P5.0 pull device Pull up device hd Crriver af PR.O Strong driver, sharp edge |
Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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On the ASCO_TX page

H Select Use pin P5.1 as ASCO output signal (ASCO_TX).

% Configure Alternate Pin Functions

[ "7
ASC0 R f-“«SI:III_TK]

A5C0_Tx Pin Selection
(" Mo pin as ASCO T selected

fﬂ%l ze pin PE.9 az ASCO output zignal [A5C0_Tx]

Fuzh Pull / Open Drain Crriver Mode
[ Activate open drain function for P5.1 Crriver of PR
-

Both pins are needed to enable the module. Click the Close icon IE| on the dialog toolbar to close the dialog.

Strong driver, sharp edge

b
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On the Control page

B Select Mode Control (M) 8-bit data (asynchronous),
B Select Stop Bit Selection (STP) One Stop bit,
B Check Interrupts Enable transmit interrupts (TSRC).

% Asynchronous Synchronous Serial Interface 0 (ASCO)
Kai | 7

b odule I:I::u:k] Pin Selection  Contral l B aud Flate] Interrupts] Funn:tin:nns] Parameters] Nu:ntes]

tode Control (k]

~

(¢ B-hit data [asynchronous)

(" 7-bit data + parity [azpnchronous]

(" 9-bit data [asynchronous)

(" B-bit data + wake up [asvnchronous]

(" B-bit data + panty [azpnchronous]

Error Check
| Enable overun check [OEN]

| Enable framing check [FEM]

-

Receiver Enable Loopback kMode

| Enable receiver [REM] | Enable loopback mode [LE)
Stop Bit Selection [STP) Farity Selection [ODD)

+ One stop bit {+

(" Two stop bits "
[nterrupts

v Enable transmit interrupt [TSRCE

| Enable transmit buffer interrupt [TESRC)

| Enable receive interupt [RSRC)

-

Release 04/2007
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On the Baud Rate page

B Select Baud Rate Generator Run Control (R) Enable baud rate generator,

B At Baud Rate enter 115.000 as Required Baud rate [kbaud].

& Asynchronous Synchronous Serial Interface 0 (ASCO)

™ &L - 7

¢ Additionally reduce senal clock to 2
(" Digable baud rate generator

{" Additionally reduce seral clock ta 3

{# Enable baud rate generatar
| Usze fractional divider as prescaler for baud rate timer [FDE]

Max. baud rate [Mbaud] |E. 344

Baud Rate Selection Bit [BRS] / Fractional Divider [FOE) Baud Rate Generatar Bun Control [R]

Baud Rate
Fequired baud rate [kbaud] W Real baud rate [kbaud] IW
I— Fercentage of dewviation [%] IW
Min. baud rate [baud] IW Reload value [RL) W
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Exercise 5: ASC

On the Interrupts page drag the ASCO transmit SRN interrupt from the right list to the CPU interrupt level 3.

@ Asynchronous Synchronous Serial Interface 0 (ASCO)
Kai s

b odule EI::u:k] Fin Selectinn] Eu:nntrn:nl] Baud Rate Interupts l Funn:tin:nn&] Parameter&] Nu:nte&]

CPU Interupt [max. 255] | PCP Interrupt [max. 255] i Lewel D [non interrupting]
Level 15 | L h e
Level 14
Lewel 13
Level 12
Level 11
Lewvel 10
Lewvel 3
Level B
Level 7
Level &
Leveld |S5TM SHM O
Lewvel 4
Level 3 |ASCO tranzmit SHEM
Level 2
Lewvel 1

-

Mote: To change the level and the group of an interrupt zource, click onit, drag it to itz rew pozition and drop it
To =et an interrupt zource to the non interupting level [Level O] click on it, drag it to the 'Level 0 izt and drop it
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On the Functions page
B Check the ASCO vInit and ASCO vSendData functions.

% Asynchronous Synchronous Serial Interface 0 (ASCO)

[ =[P
bk odule I:I::u:k] Fin Selectinn] Eu:nntrn:nl] Baud Flatel Intermptz  Funchions lParameters] Nntes]
[mitialization Function Source File
W ASCO_vinit File: name \A5C0.c
Function Libramy [Part 1) Function Library [Part 2]
W |ASC0_vSendData |
| |
[ ASCO_wiTx [ |
i i} |
| |
B =]
i) i
| il
| |
i

4. Generate the application framework

Click on the Generate Code icon % | on the application toolbar to start the code generation process. Save and close the
DAVE project.

5. Add a new project to the Tasking Workspace

Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\asc\asc.pjt.
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6. Add the application framework

In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will

select all generated files of the application framework. Select the project directory and click OK.

7. Set current project
Use the context menu in the workspace window to make the asc project the current project.

8. Load the project options

Choose Project > Load Options. In the Filename field enter c:\infineon\tcl1796 extmem.opt.

9. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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g
(Infineon
10. Add the user code

The Asc0 write function in this exercise is implemented using a global pointer to a string send buffer. The ASC0 wWrite
function sets the global pointer and requests an interrupt. The interrupt routine sends on byte of the string and incre-

ments the pointer. Add the following code to AsCO.c.

// USER CODE BEGIN (Tx,1)
static char *ss = ""; // output pointer
// USER CODE END

void _ interrupt (ASCO TINT) ASCO_viTx (void)
{
// USER CODE BEGIN (Tx,Z2)
if (*ss)
ASCO_vSendData (*ss++) ; // send until string end
// USER CODE END
} // End of function ASCO viTx

// USER CODE BEGIN (ASCO General,10)
void ASCO_vWrite (char *s)

{

while (*ss) // wait 1f busy
ss = s;
ASCO TSRC SETR = 1; // Set interrupt request

}
Add a prototype of ASCO vWrite to ASCO.h at (ASCO_Header,8). Add an endless loop in MAIN.c at (Main,9).
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In sTM.c at (SRNO,2) add code to the interrupt routine:

void _ interrupt (STM INTO) STM viSRNO (void)

{

{

}

if (STM ICR CMPOIR == 1) // if compare match of CMPO is pending

// USER CODE BEGIN (SRNO,3)
static unsigned long i = 0;
unsigned long sec;

char s[50];

I0 vTogglePin (IO P1 15);

sec = 1*((1<<24)/75000000.) ;

i++;

sprintf (s, "TriBoard running since:
"$021dh:%021dmin:%021dsec\r",
sec/3600, (sec%3600)/60, sec%60);

ASCO_vWrite (s);

// USER CODE END

STM ISRR CMPOIRR = 1; // clear request bit of CMPO

} // End of function STM viSRNO

11. Build the application

Click the Build icon on the Build toolbar. The Build process finishes successfully.

12. Debug the application
Click the Debug icon @ on the Build toolbar to open the CrossView Pro debugger.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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13. Run the application
Click the Run icon ﬂ on the CrossView Pro toolbar. Open a HyperTerminal window. Set the COM parameter to 115200 8-
N-1-None.

COM1 Properties

Fort Sethings !

Bitz per second:
Drata bitz: |8 w
|
Farty: | Mone w
Stop bitz: |1 w
| Flow contral: | Mone w

See the output. On some system is it required to reset the application once. Choose Run > Reset Target System.

“& Getting started with Infineon TriCore - HyperTerminal |Z E|E|
File Edit View Call Transfer Help

IriBoard running since: B@Bh:1l4min:4&3sec

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 5-14



Infineon

i

Exercise 6: Programming the flash

Programming the flash

The TC1796 TriBoard comes with 2 MByte on-chip flash memory. In this exercise we learn
how to program the flash. We are using UDE Flash/OTP Memory Programming which is an
add-in to the PLS UDE debugger environment. If you prefer to use the Infineon Memtool
read the instructions in the Appendix A. If you prefer to use the Hitex Debugger read the

instructions in the Appendix B. PMU

16 KB BROM
2 MB PFLASH
128 KB DFLASH
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1. Create a DAVE project
Open the Windows Explorer and create a new directory c:\infineon\fls. Copy the asc.dav file from the previous exer-
cise to the new directory and rename the file to £1s.dav.

2. Generate the application framework
Start DAVE and open the f1s.dav project file. Click on the Generate Code icon ﬂ on the application toolbar to start the
code generation process. Save and close the DAVE project.

3. Add a new project to the Tasking Workspace
Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\fls\fls.pJjt.

4. Add the application framework

In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

5. Set current project
Use the context menu in the workspace window to make the fls project the current project.

6. Load the project options
Copy the preconfigured option file tc1796 intflash.opt from the tcl1796.zip archive to c:\infineon. Choose
Project > Load Options. In the Filename field enter c:\infineon\tc1796 intflash.opt.
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7. Add the user code
At (Main,9) in MAIN.c add

// USER CODE BEGIN (Main,9)

ASCO_vWrite ("\n\r\n\r"
"Infineon Technologies AG\n\r"
"www.ilnfineon.com/microcontroller\n\r"
"TriBoard: TC1l796\n\r"
"CPU clock: 150 MHz\n\r"
"System clock: 75 MHz\n\r");

for (;;) // forever

// USER CODE END
Include the stdio.h to STM.c and add in the interrupt routine at (SRNO,3)

// USER CODE BEGIN (SRNO,3)
static unsigned long 1 = 0;
unsigned long sec;

char s[50];

I0 vTogglePin (IO P1 15);

sec = 1*((1<<24)/75000000.) ;

i++;

sprintf (s, "TriBoard running since: "
"%$021dh:%021dmin:%021dsec\r",
sec/3600, (sec%3600)/60, sec%60);

ASCO_vWrite (s);

// USER CODE END
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8. Install the flash programming tool

Start the PLS UDE and create a new workspace file £f1s.wsp with the TC1796 target configuration. If the configuration is
not in the list click New to get the default TriCore > Starter Kit configuration.

Bl Select Target Configuration _ Create or use default |

Last Used Erowse ]

" Create a new target configuration step by step
Folder to browse

E:\Program Fileshplz\udehT argetzh,

J | ¢ Usze a default target configuration

e M IRer ow descriptions B Triboard with TC1 7758 [Starterkit] Gau Sample Cor

Triboard with TC1130 [Starterkit) Gru S ample Configuration A [21 Triboard with TC1775E [Starterkit) pls 5ample Confi

Tril:u:uaru:l with TC1130 [Starterkit] Tazking 5 ample Configuration [ Triboard with TC1775E [Starterkit) Tasking Sample

P!Eﬂf"g W!”}: % 1 E‘E [gta”'ﬂt!t] B Triboard with TC1796 [Starterkit) Gru Sample Confi
pripoarduith T 1 oe ESEEIEEMH B Triboard with TC1796 [Starterkit) pls 5 ample Config

Triboard with TC1164 [Starterkit) =] |Tri|:u:|a,[|:| with TC1 736 [Starterkit] Tazking Sample I:D\r:figuratinn|
Triboard with TC1165 [Starterkit) = Trihn:LE.Mirh Tr1910 iStartarkit Fan Samnls Canfi

Triboard with TC1TER [Starterkit) < >

Triboard with TC17EZ [Starterkit)
Triboard with TCT 764 [Starterkit) : : : : : :
Triboard with TC17EE [Starterkit Triboard with TC1 736 [Starterkit] Tazking 5 ample Configuration
Triboard with TC1 736 [Starterkit]

Triboard with TC1736 [5 'h erkit] Gru Sample Configuration
Triboard with TC1 7396 [Starterkit) T azking 5 ample Configuration

Drefailt | M e | Copy Edit Remove |

ak. Cancel | Help

Finizh Cancel Help
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Choose Config > Add-in Components and load the UDE Flash/OTP Memory Programming Tool.

UDE Add-In Components Load 5tate

UDE &dd-In Component Dezcription

L1 MCDS Trace Support

L] Support of F<ROS

L] UDE C&M Recorder

L] Support of Case Tool: Connection

L] Support of DAVE Wersion 2.4

UDE FLASHAOTP Memory Prograrming Tool

£ | b4

| Delete stored settings after unload Help

ak. Canicel

Page 6-5
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Choose Tool > FLASH Programming... and enable the flash. Click Exit.

. UDE - FLASHIOTP Memory Programming Tool

FLASHAOTPE - Memory Device

& MByte OnChip Program FLASH [Dremo]

RO :
#1:
B
Ha:
B4
g5
BE

OxA0000000 -
OxA0070000 -
O=A0020000 -
O=A0040000° -
O=&0030000 -
OxA0700000 -
OxA07850000 -

* .. Sector iz protected

OA000FFFF
04001 FFFF
0x4003FFFF
04007FFFF
O400FFFFF
0401 7FFFF
001 FFFFF

[E4K]
(64K

(129K
[25EK]
[512K]
[512K]
[512K]

E xit
hd v Enable
Eraze ... About
Help
General ...
S Prot. Frogram Al
[rfa ... Setup .. Wby Al

Release 04/2007
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9. Program to flash

Choose File > Load Program and open fls.elf. Click Program to start programming the flash.

. UDE - FLASH/OTP Memory Programming Tool

FLASHAOTP - Memory Device

& MByte OnChip Program FLASH [Dremo)

HO:

Ot 0000000 - O=5000FFFF  [B4K)

0000000
CxA0000020
CxA000007 4
CxA00000F 3

- O 000007 D
- OxA0000070
- O=A00000F 4
- OxA000064F
- Ox&0004303

et 0004000

(et 007 QD00

Ox&0020000 -
OxA0040000° -
OxA0030000° -
Ox&0700000° -
Ox&0730000 -

* ... Sector iz protected

0x4001 FFFF
0w 003FFFF
0xA007FFFF
0w 00FFFFF
0w 01 7FFFF
001 FFFFF

[B4K]
(126
[256K)
512K)
(512K]
(512K]

E it
hd v Enable
Remove All Eraze ... About
Prograrm Help
Werify General ...
S Prat. Frograrnm Al
Irfa ... Setup ... Wby Al

Release 04/2007
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A process dialog appears. Wait until the operation succeeds and Exit the dialog.

Execute Memtool Command [3_(|

Current FLASHAOTP Device :

O peration ;

|EL.II3I3E!EE

Progress

| E it | Help |
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10. Verify the changed program
Open a HyperTerminal window and setup a COM port connection to 115200 8-N-1-None. Press the reset button on the Tri-
Board and see the changes.

“& petstart - HyperTerminal
File Edit View Call Transfer Help

Infineon Technologies AG

www . 1nfi1neon.com/microcontroller
Triboard: TC1796

CPU clock: 150HHz

Svustem clock: 75MHz

Elapsed time: B000h:00min:16sec

Connected 00:00:22 Auto detect 115200 5-M-1
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PWM

In this exercise you will develop an application that generates a sinusodial complemen-
tary 3-phase PWM (Puls Width Modulation) signal with an update frequency of 20KHz
using the General Purpose Timer Array (GPTA).

The GPTA provides a set of timer, compare and capture functionalities that can be flex-
ibly combined to form signal measurement and signal generation units. They are opti-
mized for tasks typical of engine, gearbox, and electrical motor control applications,
but can also be used to generate simple and complex signal waveforms needed in
other industrial applications.

The TC1796 contains two General Purpose Timer Arrays (GPTAO and GPTA1) with iden-
tical functionality, plus an additional Local Timer Cell Array (LTCAZ2).
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GPTA Features

Each of the General Purpose Timer Arrays (GPTAO and GPTA1) provides a set of
hardware modules required for high-speed digital signal processing:

Clock Generation Unit

B Filter and Prescaler Cells (FPC) support input noise filtering and prescaler opera-
tion.

B Phase Discrimination Logic units (PDL) decode the direction information output
by a rotation tracking system.

B Duty Cycle Measurement Cells (DCM) provide pulse-width measurement capabil-
ities.

B A Digital Phase Locked Loop unit (PLL) generates a programmable number of
GPTA module clock ticks during an input signal’s period.

Signal Generation Unit

B Global Timer units (GT) driven by various clock sources are implemented to
operate as a time base for the associated Global Timer Cells.

B Global Timer Cells (GTC) can be programmed to capture the contents of a Global
Timer on an external or internal event. A GTC may also be used to control an
external port pin depending on the result of an internal compare operation. GTCs
can be logically concatenated to provide a common external port pin with a com-
plex signal waveform.

Bl Local Timer Cells (LTC) operating in Timer, Capture, or Compare Mode may also
be logically tied together to drive a common external port pin with a complex
signal waveform. LTCs, enabled in Timer Mode or Capture Mode, can be clocked
or triggered by various external or internal events.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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GPTAD
Clock Generation Unit
FPCo DCMO FPt
FPC1 | PDLO FPt
FPC2 DCM1 DIGITAL FP(
FPC3 pcve | PLE FP(
FPC4 | PDLA FPt
FPC5 —— FP
Clock Distribution Unit by
,.l 4 Signal [
—] GTO :]] % Generation Unit =
LeT ki | ‘
GTCO00 LTCOO L
GTCO1 LTCO1 |
GTCo2 LTCO2
GTCO3 LTCOD3 |
| | |
| Global | Local !
i Timer Timer I
| Cell Array | Cell Array e
| | |
GTC30 LTC62 I
GTC31 N |1C63
] J T
IO Line Sharing Unit
Interrupt Sharing Unit

Fig.1 GPTA Block Diagram
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LTC Functionality
M Local Timer Cell (LTC)
B 64 independent units
B Three basic operating modes (Timer, Capture and Compare) for 63 units
B Special compare modes for one unit
B 16-bit data width
B /cpra Maximum resolution
B /sp1a/2 Maximum input signal frequency
N I
- i | — LTCPRE
From/To F’relnﬂus LTCk-1 e STES T T ol
v i ” Local Timer Call LTCO0 __= » f'?gf'l?{ﬁl"-l
S| EO TI MOl M1l Y S0 El TI M10 MOO & LTCOOOUT
L4 | | | T e
¥l al L | 11 MOl p*
Y Y v v Local Timer Cell LTCO1 o W
| YO 50 El_TO M10 MoO s LTCO10UT
. :' :' Ta LTCO2
X (16-5it Capcom) > LTCK <1— LTCPRE From LTCEO
! Gcmtlr::rl || ' S T T
Logic » LTCKOUT ¥i Sl EO T Mil Mol e
| Local Timer Cell LTCS1 2 EEJ[E:IH
’a LTCKkIN YO S0 El TO M10 MOOD = LTCa10UT
1] =4 ¥
¥l ;I EQ ?I M1l m'm — X :
* Local Timer Cell LTCE2 ‘_- ﬁ-rﬂgrf;“
| YO 50 El TO M10 MO # LTCE20UT
v Yy v ¥ ! i
1y Yl ED Ti SQTE:
YG ED EI TG MDG M1 9 Lacal Tirmes Cell LTCE3 _-.-1— E-Fgl?.?lﬂ
L — L TCE300UT
To/From Mext LTCk+1 MCAD5959

WCADSsEn

Fig.2 Architecture of Local Timer Cells and Interconnections between LTCs
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ompare Valuej

LTC1 )
LTC2
LT
Nre
—
High Side < dead time < dead time
Low Side
| ,’ |
| |
0 toﬂ‘,L ton,H T/2 toff,H ton,L T me

Fig.3 PWM Generation with Local Timer Cells

Value | Cell Output Control Mode Port
Reset Timer - LTCO |- -
Compare Period T LTC1 | Interrupt: adjust tof H, ton,L -

Compare Mid Period T/2 LTC2 | Interrupt: adjust tyn H, tofr,L -

Compare High side On | t,, |LTC3 | Set output by a local event -

Compare High side Off |t,s |LTC4 |Reset output by a local event or copy the previous cell action P2.8
Compare Low Side Off |t,, LTC5 |Reset output by a local event -
Compare Low Side On | t,, LTC6 |Set output by a local event or copy the previous cell action P2.9
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(Infineon
1. Create a DAVE project

Open the Windows Explorer and create a new directory c:\infineon\pwm. Copy the isr.dav file from the previous exer-
cise to the new directory and rename the file to pwm. dav.

2. Open the GPTA clock properties
Click on GPTA Clock in the project window to open the GPTA Clock properties.
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3. Set up the GPTA clock properties

On the Module Clock page

B Select Select normal divider mode.

H Enter Required module clock [MHz] to fgpta = 75 MHz.

% GPTA Clock
[ i
Module Clock, l Timer Clock Control ]

todule Dizable Request

| Dizable the GPTA module [D15R]

Divider Mode Contral (D]

(" Dizable module clack

f* Select normal divider mode

(“%elec:t fractional divider mode

kModule Clack Cantrol

Required module clock [MHz] |F"5.EIEIEI

Minimal rodule clock [KHz] 73,242

b awimal module clock [MHz]  [75.000

Sleep Mode Enable Control

- Dizable the sleep mode for the GPTA module
[EDIS]

Dizable Clock Contral
- COutput clock becomes inactive after intialization
[DISCLE)

Enable Hardware Clock Control

- Bit DISCLE iz rezet by HW while input zighal
ECEM [CAM_INT_D015] iz a kigh level [EMHW)

Feal module clock [MHz] 75.000
Percentage of deviation [%] 0.00o0
Step walue [STEFR) Ox3FF

%]

Release 04/2007
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On the Timer Clock Control
B Check Enable GPTAO timer clock (GOEN).

x]

& GPTA Clock
[ i

Module Clock — Timer Clock Cortral l

GPTAQ Timer Clock Caontral GPTAT Timer Clock Cantral

v Enable GETAD timer clock [GOEM] | Enable GRTAT timer clock [GTEN]

GPTAQ Global Timer 0 Bun Contral GPTA1 Global Timer O Run Contral

r GTO clock iz gtarted after initialization B
(GTOORLIM]

GPTAD Global Timer 1 Bun Contral GFTAT Global Timer 1 Bun Contral
GT1 clock is started after initialization

B [GTOTRUM] B

LTCAZ Timer Clock Cantral

| Enable LTCAZ timer clock [LZEM]

The GPTA clock is completely configured. Click the Close icon [#| on the dialog toolbar to close the GPTA Clock dialog.
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4. Open the GPTAO properties
Click on GPTAO in the project window to open the GPTAO properties.
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5. Set up the GPTAO properties
On the Clock Generation page click CDU to open the Clock Distribution Unit properties.

& General Purpose Timer Array 0 (GPTAD) [‘S__(|
Kai " 7

Input Pins  Clock Generation l EIDI:uaITimer] Lu:n:aITimer] Cutput F'in&] Funn:tin:nn&] SHM ] F'arameter&] Hu:nte&]

Filter and Prezcaler Cell [FPC]

Frco | Fre | o2 | FrC3 | FrCa | FrC5 |

Phaze Dizcrmination Logic Cell [POL]

FOL O | FDL 1 |

Dty Cycle Measurerment and Limit Checking Cell [DCR)

DCM 0 | DCM 1 | DCM 2 | DCH 3 |

Digital Phaze Locked Loop Cell [PLL]

FLL

Clock Digtribution Uit [COU

......................................
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On the Clock Bus 7-6 page

maximum input frequency of the local timer cells is fgp1a/2-

@& Configure Clock Distribution Unit (CDU)
Kai "7

Clack Bus 76 | Clock Bus 54 | Clock Bus 3:2 | Clock Bus 10

Clock Buz Signal ¥ [DFADT)

[ Clock coming frorm FPC4 [= 75,0000 MHz]
o Divided GPTAD clock,

MU CE I GPTAD clock / 271 [= 37,500 MHz; 0.0267 pi) |
Clock Bus Signal & [DFADE]

o Clock coming from FPCT [= 750000 MHz]

¢ Divided GPTAD clock

The Clock Distribution Unit is completely configured. Click the Close icon [#

Configure Clock Distribution Unit (CDU) dialog.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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H At Clock Bus Signal 7 (DFAO07) select Divided GPTAO clock and choose the Divide factor GPTAO clock / 2”~1. The

on the dialog toolbar to close the
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6. Set up the GPTAO properties. Local Timer
On the Local Timer page click LTCO to open the Local Timer Cell O properties.

@ General Purpose Timer Array 0 (GPTAD) r‘s_<|

™ &3 - 7

[riput F'ins] Clock, Generatinn] Global Timer Local Timer l Cutpuat F'ins] Funn:tin:nns] SHM ] F'arameters] Nu:ntes]

Local Tirer Cell [LTC)

LTCO LTCA LTC Z LTC 3 LTC 4 LTC & LTC & LTC ¥

........................

LTL§E LTCH LTC 10 LTC 1 LTC 12 LTC 13 LTC 14 LTC 15

LTC 16 LTC 17 LTC 18 LTC 13 LTC 20 LTC 21 LTC 22 LTC 23

LTC 24 LTC 25 LTC 26 LTC 27 LTC 28 LTC 24 LTC 20 LTC A

LTC 32 LTC 33 LTC 34 LTC 35 LTC 36 LTC 37 LTC 35 LTC 39

LTC 40 LTC #1 LTC 42 LTC 43 LTC 44 LTC 45 LTC 46 LTC 47

LTC 45 LTC 43 LTC 50 LTC 51 LTC 52 LTC 53 LTC 54 LTC 55

LTC 56 LTC &7 LTC 58 LTC 53 LTC EO LTC &1 LTC B2 LTC B3
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On the LTCO page configure the cell as reset timer:

B Choose Enable LTCO cell after initialization (CEN),
Bl Select Timer with reset from adjacent LTC with higher order number. When the timer value in LTCO matches the

compare value stored in LTC1, the Event Out signal from LTC1 is activated and passed upstream to LTCO as the Event In

signal which then resets the timer to the value of FFFFy..
B Check Connect the input line to LTCO (LIMENO). The cell will be connected to the clock bus line 7 which we config-

ured in step 5.

B Check Enable rising edge of selected input signal (RED).

& Local Timer Cell 0 (LTCO)

™ &ta - ?

FLTCO l Data lnput ] Output Selection ]

LTCO Enable Cantral

tultiplexer Connechion

LTCO Mode Selection (MOLD)

(" Capture last timer [= hone)
(" Compare with last timer [= none]

{" Free running tmer
L%igher arder nurmbier

LTCO Register

LTCO Output Control Mode [OCH]

Tirner with rezet from adjacent LTC with

LTCO register value ] |I:I:-:I:IEIEIEI

|Ena|:||e LTCO cell after intialization [CEMN] j v Connect the input line ta LTCO [LIMEMO]

[nput Line Mode [ILA)

i |nput line is operating in edge sensitive mode

[ |hput line is operating in level sensitive maode
LTCO Mode Contral

v Enable rising edge of selected input signal [RED)]

| Enable faling edge of selected input signal [FED]
Coherent Update Enable / One Shot Mode Enable

| Toggle the logic state of the So output by an Ei event
| Enable 'One Shat Maode' (OS]

Select Qutput Line Control

|H|:|I|:| the LT CO output by an local event only j St shate of select

line output to 1[S00

| Force the selected action after intialization [014)

=)

Release 04/2007
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On the Data Input page of LTCO and select the internal input Clock?7 as data input line for LTCO.

@ Local Timer Cell 0 (LTCO) E|
Eai i
LTeo { Batainput | output Selection |
Drata input line zelection for LTCO [LIMGO and LIKLO)
Fort [nput's: GTC Input's: [rternal lnput's:
{7 Usze GPTAD INO [= none] T Use output of GTCO (" CLOCED
{7 Usze GPTAD INT [= none] [ Use output of GTCT (" CLOCK1
{7 Usze GPTAD IN2 [= none] [ Use output of GTC2 (" CLOCEZ
{7 Usze GPTAD IN3 [= none] [ Use output of GTC3 (" CLOCEZR
{7 Uze GPTAD IN4 [= none] " Usze output of GTC4 (" CLOCEA
{7 Uze GPTAD NG [= none] " Usze output of GTCS (" CLOCES
{7 Uze GPTAD_ING [= nane) T Usze output of GTCE (" CLOCEE
{7 Uze GPTAD IN7 [= none] T Usze output of GTC? (« CLOCEY
{7 Uze GPTAD IN32 [= none] Hote: JL-.E“'
O Uze GPTAD_INZ3 [= none] CLOCEY = GPTAD clack / 271 [= 37.500 MHz: 0.02E7 psz)
{7 Uze GPTAD IN34 [= none] (" PDLT fonward signal
{7 Uze GPTAD IN35 [= none] (" PDL1 backward signal
{7 Use GPTAD_INZE [= none] {7 CAMN_INT_0O15
(" Uze GPTAD_INS? [= none] " SCU_1ouUT
(" Uze GPTAD_IN3S [= none] O SCU_ouT2
™ Use GPTAD_IN3D [= none) ¢ SCU_IOUT3

The LTCO is completely configured as reset timer running at fgpta/2 = 37.5MHz. Click the Close icon [# on the dialog tool-
bar to close the Local Timer Cell 0 (LTCO) dialog.
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Click LTC1 on the Local Timer page. On the LTC1 page configure the cell to compare mode:

B Choose Enable LTC1 cell after initialization (CEN),

H Select Compare with last timer (=LTCO),

B Check Enable low level of 'Select Line input' Si (SOL) and Enable high level of 'Select Line input' Si (SOH) to
enable Compare mode in all cases,

H Set the LTC1 register value (X) to the period value. Since the timer LTCO resets to -1 (FFFF) and then counts
through 0 up to (and including) the compare value, the compare value used to generate a periodic interval is somewhat
different than what might be expected. To generate a periodic interval of P clocks, the compare value must be set to (P-
2). To get a symmetric PWM P must be even. P = 37.5MHz/20KHz = 1875. The period P will be choosen as the next
higher even value 1876. The register is set to 1874 = 752,,. Enter 0x0752 in the text field and type Return.

@ Local Timer Cell 1 (LTC1)

™ &3 - 7

LTC1 Enable Contral tultiplexer Connechion
Enable LTC1 cell after initislization (CEM) = | | [

LTC1 Mode Selection [MOD] [rput Line kode [ILA)
(" Capture |last timer [= LTCO) -
~

¢ Compare with last timer [= LTCO)
LTCT Maode Caontrol

Timer with reset from adjacent LTC with v Enable low level of 'Select Ling input' Si [SOL]
O ¥ Enable high level of 'Select Ling input' Si [SOH]

(" Free running tmer

LTC1 Register Coherent Llpdate Enable / One Shot Mode Enable

-
LTCT reqizter value [ |IZI:-:EI.'-"52 %

| Enable 'One Shat Made' (OS]
The LTC1 is completely configured. Click the Close icon [# on the dialog toolbar to close the LTC1 dialog.
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Click LTC2 on the Local Timer page. On the LTC2 page and configure the cell to compare mode:

B Choose Enable LTC2 cell after initialization (CEN),

H Select Compare with last timer (=LTCO),
B Check Enable low level of 'Select Line input' Si (SOL) and Enable high level of 'Select Line input' Si (SOH) to

enable Compare mode in all cases,
B Set the LTC2 register value to the mid period value -1+1876/2 = 937 = 3A9,. Enter 0OXx03A9 in the text field and type

Return.

@ Local Timer Cell 2 (LTC2)

™ &3 - 7

LTCZ Enable Contral tultiplexer Connechion

Enable LTC2 cell after initislization (CEM) w| | [

LTCZ Mode Selection [MOD] [rput Line kode [ILA)
(" Capture |last timer [= LTCO) -
~

¢ Compare with last timer [= LTCO)
LTCZ Maode Control

v Enable low level of 'Select Line input’ Si[SOL)

(" Free running tmer

T_imer with reset from adjacent LTC with
O ¥ Enable high level of 'Select Ling input' Si [SOH]

LTCZ Reqgister Coherent Llpdate Enable / One Shot Mode Enable
[

| Enable 'One Shat Made' (OS]

LTCZ reqgizter value [] |IZI:-:EIE'..-5'-.H %

The LTC2 is completely configured. Click the Close icon [ on the dialog toolbar to close the LTC2 dialog.
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To configure the phase U using LTC3/LTC4 and LTC5/LTC6 click LTC3 on the Local Timer page.

On the LTC3 page configure the cell

to compare mode:

B Choose Enable LTC3 cell after initialization (CEN),
B Select Compare with last timer (=LTCO),
B Check Enable low level of 'Select Line input’ Si (SOL) and Enable high level of 'Select Line input’ Si (SOH) to

enable Compare mode in all cases,

=)

neon

B Choose Set the LTC3 output by an local event only as the Output Control Mode to set the output to high on a

compare match. The LTC3 register value will be calculated in the mid period interrupt routine.

& Local Timer Cell 3 [LTC3)

® &L - ¥

LTC3 Enable Caontral
Enable LTC3 cell after initialization [CEM) |

LTC3 Mode Selection [MOD]

" Capture last timer [= LTCO)
(+ Compare with last tmer [= LTCO]

(" Free running bmer

Timer with rezet from adjacent LTC with
higher order nurmber

LTC3 Reqizter

LTC3 register value [] |EI:-:EIEIEIEI

LTC3 Output Contral Mode [QCH)

M ultiplexer Connection

-

[rput Line Mode [IL)
[+

~

LTC3 Mode Cortrol
v Enable low level of 'Select Line input’ Si[SOL)

v Enable high level of 'Select Line input’ S5i [S0H]

Coherent Update Enable # One Shot Mode Enable
[

| Enable 'One Shot Mode' [O5HM)]

Bypazs Control

|Set the LTC3 output by an local event anly

| Force the selected action after intiahization [014)

The LTC3 is completely configured. Click the Close icon @| on the dialog toolbar to close the LTC3 dialog.
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Open the LTC4 to LTC6 and configure them also in compare mode
B LTC4: Choose Reset the LTC4 output by an local event or copy the previous cell action to set the output to pas-
sive on a compare match.

LTC4 Output Control Mode [OCHM] Bypazz Control

Enable bypazz

|Fleset the LTC4 output by an local event or copy the previous cell action %j
functionality [BF)

[ Force the zelected achion after initialization [014)

To configure the low side of phase U using LTC5/LTC6 configure the Output Control Mode:
B LTC5: Choose Reset the LTC5 output by an local event to set the output to low on a compare match,

LTCS Output Control bMode [OCk) Bypazs Contral
|Fhaset the LTCS output by an lozal event anly j
—
| Force the selected action after initialization [E[ﬁ'l]

B LTC6: Choose Set the LTC6 output by an local event or copy the previous cell action to set the output to high on
a compare match.

LTCE Output Contral Mode [OCH) Bypazs Control

Enable bypazz

|SEt the LTCE output by an local event ar copy the previous cell action ﬂ
% funchionality [BY'F)

| Force the selected action after initialization [014)

The high side and the low side of phase U are configured. Close the LTC3 to LTC6 dialogs.
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For phase V open cell LTC7 to LTC10 and configure them also in compare mode:

B LTC7: Choose Set the LTC7 output by an local event,

LTCY Output Control Mode [OCH)

|SEt the LTCY output by an local event anly j
[%lﬁ]

| Farce the zelected action after initialization

Bypaszs Control

-

LTCE Output Control Mode [OCH)

|F|eset the LTC8 output by an local event or copy the previous cell action %j

| Force the selected action after intialization [014)

B LTC8: Choose Reset the LTCS8 output by an local event or copy the previous cell action,

Bypazz Control

Enable bypazz
functionality [BF)

LTCS Output Control Mode [OCK)

|F|eset the LTC3 output by an local event anly j

| Force the zelected action after initialization [Dl.ﬂ%

B LTC9: Choose Reset the LTC9 output by an local event

Bypazz Control

-

LTCT0 Output Control Mode [OCK)

|SEt the LTCT0 output by an local event or copy the previous cell action ﬂ

| Force the selected action after initialization [014)

B LTC10: Choose Set the LTC10 output by an local event or copy the previous cell action.

Bypazs Control

Enable bypazs
functionality [BYF)

Release 04/2007
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The high side (LTC7/LTC8) and the low side (LTC9/LTC10) of phase V are configured. Close the LTC7 to LTC10 dialogs.
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For phase W open cell LTC11 to LTC14 and configure them also in compare mode:

B LTC11: Choose Set the LTC11 output by an local event,

LTC11 Output Control Mode [OCk) Bypazz Control

|SEt the LTC11 autput by an local event only j
-

| Force the selected action after intialization [014)

B LTC12: Choose Reset the LTC12 output by an local event or copy the previous cell action,

LTC12 Output Contral Mode [OCK] Bypaszs Control

|Heset the LTCTZ output by an local event or copy the previous cell action j Enable bypass

functionality [BYF
[ Force the zelected action after initialization [014) unctionality [BF)

B LTC13: Choose Reset the LTC13 output by an local event,

LTC13 Output Contral Mode [OCK] Bypaszs Control

|Heset the LTCT3 output by an local event only j
-

| Force the selected action after initialization [014)

B LTC14: Choose Set the LTC14 output by an local event or copy the previous cell action.

LTC14 Output Control Mode [OCK)

|SEt the LTC14 autput by an local event or copy the previous cell action

| Force the selected action after intialization [014)

%ﬂ

Bypazz Control

Enable bypazz
functionality [BF)

The high side (LTC11/LTC12) and the low side (LTC13/LTC10) of phase W are configured. Close the LTC11 to LTC14 dia-

logs.

To connect the data out of the cells to the port the Output Pins has to be configured.

Release 04/2007
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On the Output Pins page open the OUTO, OUT1, OUTS8, OUT9, OUT10, OUT11 properties.

@ General Purpose Timer Array 0 (GPTAD)

™ &3 - 7

Configure GPTAD Input Finz
I:ILIThEI [= none) OUTT [= none) OUTZ [= none) QUT3 [= none| OUT4 [= none)
EILHJ@[= nione) OUTE [= hone| QUTY [= none) QUTE [= none) OUTa [= none|
OUTT0 [= none) OUT11 [= none) OUTTZ [= none) OUT13 [= none) OUT14 [= none)
OUT15 [= none] OUT1E [= none] OUTIY [= none) OUT18 [= none] OUT13 [= none|
OUT20 [= none) OUTZ21 [= none) OUTZZ [= none) OUT 23 [= none) OUT24 [= none)
OUT 25 [= none) OUT 26 [= none) OUTZY [= none) OUT 28 [= none) OUT 29 [= none)
OUT 30 [= none) OUT31 [= none) OUT3Z [= none) OUT 33 [= none) OUT 34 [= none)
OUT 35 [= none) OUT 36 [= none) OUT3? [= none) OUT 38 [= none) OUT 39 [= none)
OUT 40 [= none) OUTH [= none) OUT4Z [= none) OUT 43 [= none) OUT 44 [= none)
OUT 45 [= none) OUT 46 [= none) OUT4Y [= none) OUT 48 [= none) OUT 49 [= none)
OUTED [= none] auTE [= none| OUTEZ [= none) OUTEZ [= none] OUTHS [= none]
OUTES [= none)

Configure the OUTO pin to P2.8:

GPTAD_OUTO Pin Selection
(" Mo pin as GPTAD_OUTO zelected
(¢ Usze pin P2 8 as GPTAD output signal 0 [GPTAD OUTO)

[ PR =l Y| B oy Y R S FPrivctoome bd — =
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Configure the OUT1 pin to P2.9:

GPTAD_OUTT Pin Selection
(" Mo pin as GPTAD_OUTT zelected
(¢ Usze pin P29 as GPTAD output signal 1 [GPTAD OUTT)

M
Configure the OUT8 pin to P3.0:

GPTAD _OUTE Pin Selection
(" Mo pin as GPTAD_OUTS zelected

(¢ Usze pin P3.0 as GPTAD output signal 8 [GPTAD OUTS)
[
Configure the OUT9 pin to P3.1:

GPTAD_OUTA Pin Selechion
(" Mo pinas GPTAD_OUTY zelected
(¢ Usze pin P3.1 as GPTAD output signal 9 [GPTAD_OUTY)

Configure the OUT10 pin to P3.2:

GPTAD_OUTT0 Pin Selection
(" MNopinas GPTAD_ OUT10 selected
(¢ Usze pin P3.2 as GPTAD output signal 10 [GPTAD_OUT10)
[

Configure the OUT11 pin to P3.3:

GPTAD_OUTTT Pin Selection
(" Mo pinas GPTAD_ OUT11 selected
T“;UEE pin F3.3 az GPTAD output signal 11 [GPTAD_OUT11)

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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Close the 6 Configure Alternate Pin Functions dialogs.
The Output Pins page displays the complete configuration of the output pins.

& General Purpose Timer Array 0 (GPTAD) E|
Eai | ?
Input Pl ] Clack Generation ] Global Tirner ] Local Tirmer DUtPUtPIHEI Functions ] 5RHM ] Farameters ] Motes ]
Configure GPTAD Input Pinz
OuTO [= PZ.8] ouTt [=P2.9] OUT2 [= none) OUT3 [= none) OuUT4 [= none
I:IUTE[:l’&nne] OUTE [= none] OUT? [= hone) auTa (= P30 ouTa[=P31]
ouT10=P32] ouT1t [=P33) OUTI2 [= none) OUT13 [= none) OuUT14 [= none)
OUTT5 [= none) OUT1E [= none) OUTTY [= none) OUTT18 [= none) OUT19 [= none)
OUT 20 [= none) OUTZ1 [= none) OUTZ2Z [= none) OUT 23 [= none) OUT 24 [= none)
OUT 25 [= none) OUT2E [= none) OUTZY [= none) OUT 28 [= none) OUT 29 [= none)
OUT 30 [= none) OUT 31 [= none) OUT 32 [= none) OUT 33 [= none) OUT 34 [= none)
OUT35 [= none] OUT36 [= none] OUTEY [= none) OUT38 [= none] OUT39 [= none]
OUT 40 [= none) OUTH [= none) OUT 42 [= none) OUT 43 [= none) OUT 44 [= none)
OUT45 [= none] OUTAE [= none] OUTAY [= none) OUTA48 [= none] OUTA43 [= none]
OUTHO [= none) OUTET [= none) OUTEZ [= none) OUTHZ [= none) OUTHY [= none)
OUTES [= none)

Release 04/2007
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Select the Local Timer page again and click LTC4, LTC6, LTCS, LTC10, LTC12, LTC14.
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On the Output Selection page of each dialog
B Check Connect output to GPTA_OUTO (=2.8) on dialog Local Timer Cell 4 for the high side of phase U.

& Local Timer Cell 4 (LTC4) Ed
Kai i
LTC4 ] Data lnput  Output Selection l
Output Pin Selection tSC Dutput Selection
W Connect output bo GPTAD OUTO[= P2 8f [ Connect ouput to OUTE4 [MSCO_ALTING.S)
onnect output to GRPTAD_OUTT [= P2.9] | Connect ouput to OUTES [MSCO_ALTING.9)
| Connect output ta GPTAD_OUT 2 [= nane] | Connect ouput to OUTEE [MSCO_ALTING. 0]
| Connect output to GPTAD_OUT 3 [= nane] | Connect ouput to OUTE? [MSCO_ALTING.11]
| Connect output to GPTAD OUT 4 [= none] | Connect ouput to OUTES [MSCO_ALTING12]
| Connect output ta GPTAD_OUTS [= nane) | Connect ouput to OUTES [MSCO_ALTING.13)

B Check Connect output to GPTA_OUT1 (=2.9) on dialog Local Timer Cell 6 for the low side of phase U.

@ Local Timer Cell 6 (LTC#)

Eai i

LTCE ] Data Input  Output Selection l
Output Pin Selection FSC Dutput Selection
[ | Connect ouput to OUTE4 [MSCO_ALTIMNG.B)
I&Ei':':'{.-'-'r'{Hé'E:'E'E-Ii'iiii[iic"ic'&-"ij'if"T'ié;'lj:EiU'T'T"['!"ﬁi'éi [ Connect ouput to OUTES [MSCO_ALTING.9)

Connect output to GPTAD_OUTZ [= none) | Connect ouput to OUTEE [MSCO_ALTING.10]

| Connect output ta GPTAD_OUT 3 [= nane) | Connect ouput to OUTEF [MSCO_ALTING.11]
| Connect output to GPTAD_OUT 4 (= none] | Connect ouput to OUTES [MSCO_ALTING.12)
| Connect output to GPTAD OUTS [= none] | Connect ouput to OUTES [MSCO_ALTING.13]

Close the Local Timer Cell 4 (LTC4) and Local Timer Cell 6 (LTC6) dialogs.
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B Check Connect output to GPTA_OUTS8 (=3.0) on dialog Local Timer Cell 8 for the high side of phase V.

@ Local Timer Cell B (LTCB) El
ai | 9
LTI:E] Data lnput Output Selection l

tSC Dutput Selection

| Connect ouput to OUT72 [MSCO_ALTINT.O)
| Connect ouput bo OUT73 [MSCO_ALTINT. )

Output Pin Selection

Connect output bo GPTAD_OUTS (= P3.1)

| Connect output ta GPTAD_OUT10[=P3.2)
| Connect output to GPTAD_ OUTT1 [=P3.3)
| Connect output to GPTAD OUT12 [= none)
| Connect output ta GPTAD_OUT13 [= none)

| Connect ouput to OUT74 [MSCO_ALTING.2)
| Connect ouput to OUT7S [MSCO_ALTING.3)
| Connect ouput bo OUT7E [MSCO_ALTINT . 4
| Connect ouput to OUTFF [MSCO_ALTINT.G)

B Check Connect output to GPTA_OUT9 (=3.1) on dialog Local Timer Cell 10 for the low side of phase V.

@ Local Timer Cell 10 {(LTC10)
[ "7

LTC10| Datalnput  Output Selection |

Output Pin Selection FSC Dutput Selection

[ | Connect ouput to OUT72 [MSCO_ALTINT.O)

................................................................................................... ~ Connect auput to OLIT73 (MSCO_ALTINT 1)
| Connect ouput to OUT74 [MSCO_ALTING.2)
| Connect ouput to OUT7S [MSCO_ALTINT.3)
| Connect output to GPTAD OUT12 [= none) | Connect ouput to OUTFE [MSCO_ALTINT. 4
| Connect output to GPTAD OUT13 [= none) | Connect ouput to OUTFF [MSCO_ALTINT.G)

Close the Local Timer Cell 8 (LTC8) and Local Timer Cell 10 (LTC10) dialogs.

Connect output to GPTAD_OUTI0[=F3.2)
| Connect output ta GPTAD_OUT11 [=P3.3)
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B Check Connect output to GPTA_OUT10 (=3.2) on dialog Local Timer Cell 12 for the high side of phase W.

@ Local Timer Cell 12 (LTC12)
[ P

LTC12 | Datalnput  Output Selection |

Output Pin Selection tSC Dutput Selection

-
-

Connect output bo GPTAD_OUTI1 [=F3.3]
| Connect output to GPTAD OUT12 [= none)
| Connect output ta GPTAD_OUT13 [= none)

| Connect ouput to OUT72 [MSCO_ALTINT.O)
| Connect ouput bo OUT73 [MSCO_ALTINT. )
| Connect ouput to OUT74 [MSCO_ALTING.2)
| Connect ouput to OUT7S [MSCO_ALTING.3)
| Connect ouput bo OUT7E [MSCO_ALTINT . 4
| Connect ouput to OUTFF [MSCO_ALTINT.G)

B Check Connect output to GPTA_OUT11 (=3.3) on dialog Local Timer Cell 14 for the low side of phase W.

@ Local Timer Cell 14 (LTC14)
[ "7

LTC14 | Datalnput  Output Selection |

Release 04/2007

Output Pin Selection

-
-
-

Connect output bo GPTAD_OUT12 [= none]
| Connect output to GPTAD OUT13 [= none)

FSC Dutput Selection

| Connect ouput to OUT72 [MSCO_ALTINT.O)
| Connect ouput to OUT73 [MSCO_ALTINT.T)
| Connect ouput to OUT74 [MSCO_ALTING.2)
| Connect ouput to OUT7S [MSCO_ALTINT.3)
| Connect ouput to OUTFE [MSCO_ALTINT. 4
| Connect ouput to OUTFF [MSCO_ALTINT.G)

Close the Local Timer Cell 12 (LTC12) and Local Timer Cell 14 (LTC14) dialogs.

Copyright © Infineon Technologies 2007. All rights reserved.
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7. Set up the GPTAO properties. Service Request Node.

LTC1 and LTC2 are configured in period and mid period compare mode. To generate an interrupt on a compare match, the
appropriate Service Request Node (SRN) has to be configured.

On the SRN page click Service Request Node 22-23 (LTCO-7).

& General Purpose Timer Array 0 (GPTAD) E|
Eai i
[FpLat F'ins] Clock, Generatinn] EI:::I::aITimer] Lu:n::aITimer] Clutpat F'ins] Functions SRM ]F‘arameters] Hu:ntes]

Service Aequest Hodes

Service Request Mode O -1 [DCMO - 1]

Service Request Mode 2 - 3 [DCMZ - 3)

Service Request Mode 4 [PLL)

Semrvice Request Mode & [GTO - 1]

Service Hequest Node B - 3 [GTCO - 7)

Service Aequest Node 10 - 13 [GTCA - 15]

Service Hequest Node 14 - 17 [GTCTE - 23)

Service Request Mode 18- 21 [GTC24 - 31

......................................................................................................................

...................................................................................................................

Service Request NuI:u:Ie 22-Z23[LTCO - 7]

Service Request Mode 24 - 25 [LTCS - 18]

Hg

Service Aequest Node 26 - 27 [LTC1E - 23]

Service Hequest Mode 23 - 29 [LTC24 - 31]

Service Aequest Mode 30 - 31 [LTC32 - 39)

Service Hequest Mode 22 - 33 [LTC40 - 47)

Service Request Node 234 - 35 [LTC43 - Bh)

Service Hequest Mode 36 - 37 [LTCRE - B3]

Release 04/2007
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On the SRNs page enable the interrupt generation on the period and on the mid period compare match.
B Check Enable service request on LTC1 event (=compare with last timer),

B Check Enable service request on LTC2 event (=compare with last timer),

B Check Enable service request node 22 (SRE22).

@ Service Request Node 22 - 23 E|
Eai i
SHHEI [Ftermipts ] Functions ]
GPTAD Service Request Mode 22 Trgger Contral GPTAD Service Request Mode 23 Trgger Contral
B Enable zervice request on LTCO event - Enable zervice request on LTCS event
[= tirmer with reset] [= compare with [azt timer]
Enable zervice request on LTCT event Enable zervice request on LTCS event
[= compare with lagt timer) [= cormpare with lagt timer)
v Enable zervice request on LTCZ event - Enable zervice request on LTCE event
[= compare with [azt timer] [= compare with [azt timer]
- Enable zervice request on LTC3 event - Enable zervice request on LTCY event
[= compare with lagt timer) [= cormpare with lagt timer)
[ [
GPTAD Service Request Mode 22 Enable Contral GPTAD Service Request Mode &3 Enable Contral
v Enable service request node 22 [SREZ2Z] [

s
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On the Interrupts page and drag GPTAO SRN 22 from Level 0 to the CPU Interrupt level 3.

@ Service Request Node 22 - 23 El
Ea | 9

SRNs Intemupts | Functions |

CPU Interrupt [max. 255) |PEPIrﬂenupthnaa255] - Lewvel O [hon intermupting]

Level 15
Level 14
Level 13
Level 12
Lewel 11
Level 10
Lewvel 9
Lewvel B
Lewel ¥
Level B
Leveld |5TM SRAMO
Lewvel 4
Level 3 FGPTADSHM 22
Lewvel 2 %EE
Lewel 1

-

Mate: To change the level and the group of an interrupt zource, click onit, drag it to it new position and drop it
To et an interrupt source to the non interrupting lesel [Level O) click onit, drag it ta the 'Lewvel 0 ligt and drop it

Close the Service Request Node 22-23 dialog.
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On the Functions page

B Check the GPTAO vInit function.

& General Purpose Timer Array 0 (GPTAD)

™ &ta - ?

[rutialization Funchion

Source File

W GPTAD winit

Funchion Library [Part 1]

File name

GPTale

Funchion Librany [Part £)

\

ineon

The GPTA is completely configured to generate a complementary 3-phase PWM signal. Click the Close icon @ on the dia-

log toolbar to close the General Purpose Timer Array 0 (GPTAO) dialog.
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8. Modify the STM properties.

Open the System timer properties and select the CMPO page
B Change the Start Bit Location of CMPO to 20

& System Timer [STM)

® &L - ¥

Start Bit Location of CkPO

Loweszt bit number [0 ta 24) of STM which 1z compared with the content of register
CRPO kit 0 [MSTART) |2”%

Murnber of bitz [1 to 32] in regizter CMPO [ztarting frorm 0], which are used for the Ii
compare operation with ST [MSIZED) 1

Compare Register Size of CMPO

Compare Register 0

Required compare Real compare walue
value [CMPD) 000000001 (dependent of MSIZED) 000000007

The system timer interrupt is used to update the PWM values.

9. Generate the application framework

x]

-~
(Infineon

Click on the Generate Code icon ﬂ on the application toolbar to start the code generation process. Save and close the

DAVE project.

10. Add a new project to the Tasking Workspace

Open the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project

c:\infineon\pwm\pwm.pJjt.

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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11. Add the application framework
In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

12. Set current project

Use the context menu in the workspace window to make the pwm project the current project.

13. Load the project options

Choose Project > Load Options. In the Filename field enter c:\infineon\tcl1796 intmem.opt.

14. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

15. Add the user code

Add the following code to cpPTA0.c. Include the standard math library at (GPTAO_General,2).

// USER CODE BEGIN (GPTAO General,Z2)
#include <math.h>

// USER

CODE END

Define the following constants at (GPTAO_General,4).

// USER
#define
#define
#define

#define
#define

// USER

CODE BEGIN (GPTAO General,b4)

LTC_FREQ
PWM_FREQ
DEADTIME

DEADTIME CNTS

37500000 // = 37.5MHz
20000 // = 20.0kHz
1E-6 // = 1lus

((short) (LTC FREQ * DEADTIME))

PWM_ PERIOD CENTER CNTS ((short) ((LTC FREQ / PWM FREQ) / 2)) // same as GPTAO LTCXR0Z2

CODE END

Release 04/2007
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Declare the following global variables at (GPTAO_General,7). For the sinus a look up table is used to save time. Three cir-
cular buffers pointers are used to step through the elements of the array. Incrementing a circular buffer pointer that points
to the last element results in a pointer to the first element.

// USER CODE BEGIN (GPTAO General,?7)

#define SINE STEPS 360

short  near  circ duty[SINE STEPS]; // duty lookup table in a circular buffer
short _ near _ circ *dutyU, *dutyV, *dutyW;

const float pi = 3.14159;

// USER CODE END

In the GPTA vInit function disable the interrupt for LTC1 and LTC2 at (Init, 3). The PWM will be started by the first STM
interrupt.

// USER CODE BEGIN (Init,3)

GPTAO LTCCTRO1l REN = 0; // disable period interrupt
GPTAO LTCCTRO02 REN = 0; // disable mid period interrupt
// USER CODE END

Fill the duty lookup table and initialize the circular buffer pointer at (Init, 4)

// USER CODE BEGIN (Init,4)
for (int 1=0;i<SINE STEPS;i++)

duty[i] = (PWM PERIOD CENTER CNTS + 1) * 0.5*%*(sinf(i * 2*pi/SINE STEPS) + 1);
dutyU = &duty[0]; // set to sin(0°)
dutyV = &duty[SINE STEPS/3]; // set to sin(120°)
dutyW = &duty[-SINE STEPS/3]1; // set to sin(240°)

// USER CODE END
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Configure the period and mid period interrupts at GPTA0 visRN22 in file GPTA.c. Add the code for the period and mid
period interrupt at (SRN22, 2). At zero percent duty the low side must be set to active, i.e. ty, | should be ignored. This is
done by setting t,, | to -2 (=FFFEL), a value that is never reached.

// USER CODE BEGIN (SRN22,2)

unsigned int n;

if (GPTAO LTCCTRO1 REN)

{
GPTAO LTCCTRO1 REN = 0; // disable period interrupt
STM ICR CMPOEN = 1; // enable the stm interrupt

// update duty U

n = PWM PERIOD CENTER CNTS + *dutyU;
GPTAO0 LTCXR04 = n;

GPTAO_LTCXRO6 = n + DEADTIME CNTS;
//update duty V

n = PWM PERIOD CENTER CNTS + *dutyV;
GPTAO_LTCXRO8 = ny;

GPTAO_LTCXRIO = n + DEADTIME CNTS;
//update duty W

n = PWM PERIOD CENTER CNTS + *dutyW;
GPTAO_LTCXR]_Z = n;

GPTAO_LTCXR14 = n + DEADTIME CNTS;
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else

{
GPTAO LTCCTRO2 REN = 0;
GPTAO LTCCTRO1l REN = 1;

// update duty U

n = PWM PERIOD CENTER CNTS - *dutyU;

GPTAO_LTCXRO3 = ny;

GPTAO LTCXR05 = (n == PWM PERIOD CENTER CNTS)
((n < DEADTIME_CNTS)

// update duty V

n = PWM PERIOD CENTER CNTS - *dutyV;

GPTAO LTCXR07 = nj;

GPTAO_LTCXRO9 = (n == PWM_PERIOD_CENTER_CNTS)
((n < DEADTIME_CNTS)

// update duty W

n = PWM PERIOD CENTER CNTS -

GPTAO_LTCXRll = n;

GPTAO_LTCXR13 = (n == PWM_PERIOD_CENTER_CNTS)
((n < DEADTIME_CNTS)

*dutyW;

}
// USER CODE END

Release 04/2007

// disable mid period interrupt
// enable period interrupt

Oxfffe
Oxffff

Oxfffe
Oxffff

Oxfffe
Oxffff

n - DEADTIME CNTS) ;

n - DEADTIME CNTS) ;

n - DEADTIME CNTS) ;
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Enable the mid period interrupt in file MAIN. c before the forever loop at (Main,9):

// USER CODE BEGIN (Main,9)
STM_ICR CMPOEN = 1; // enable the stm interrupt

for(;;) // forever

// USER CODE END
In file STM.c define the *dutyuU, *dutyVv, *dutyW as extern and add to function sTM visSRNO (SRNO,3):

// USER CODE BEGIN (SRNO,3)

STM ICR CMPOEN = O; // disable the stm interrupt

GPTAO LTCCTRO2 REN = 1; // enable mid period interrupt

dutyU++; dutyV++; dutyW++; // circular step through the sinus lookup table
// USER CODE END
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At 0% duty LTC3 and LTC4 have the same compare value and the output is following the action request of the higher cell
LTC4, e.g. the high side is set to passive. LTC5S is -2 and therefor ignored, so that the low side is set to active.

At 100% duty LTC5 has a compare value of -1 and is set immediately. LTC6 is larger than the period in LTC1, so that a
reset is never happen. I.e. The low side is set to passive.

LTC1 e .
= LT3
= LTC4
= LTCE
LTCE = LTC1 « LTCH
o "-..,q_\\\ ,/-_
100%duty 0% duty
LTiC2 B

LTCE = -2

0 45 = 135 1580 225 270 315 360
Angle
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16. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

17. Debug the application
Click the Debug icon @ on the Build toolbar to open the CrossView Pro debugger.

18. Connect an Oscilloscope
Connect the pins P2.8, P2.9, P3.0, P3.1, P3.2, P3.3 to a logic analyzer. Connect P2.10 to the trigger input.
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19. Run the appli
Click the Run icon &

Cinfineon

PWM

cation
on the CrossView Pro toolbar and see the logic analyzer output.

The cursor is adjusted to measure the dead time.

k|
‘W aveforms l State Ligtl Nntegl =[O S W E B BT | 5k 3 ':'i'{ '&l 'Te:f.}. % | Buffer Position:
Sample A ate j| A0mMHz j | Sample Period j| 20n5 j | Fre-Trigger Buffer j| A% | M eazurement & Source jl 01 |-
A . I LA R _ 1 B I
. Wire -40u= -30us= -10u= +10u= +20us= +a0u= +400=
Slgnal |D 1 | 1 1 1 1 | 1 1 1 1 | 1 1 1 1 | 1 1 1 1 * 1 1 1 1 | 1 1 1 1 | 1 1 1 1 | 1 1 1 1 | 1
TRG Db
- PWM 1001106 b 1001106 g 000k o 1001106 L 100110k .
DO
D1
D2
D5

Kl

[

Prefil complete, W aiting for tigger. .

Acguizition: 104K, Samples: 264K, D1 Freq: 19.930Hz 03 Penod: G0us [nterval T-»C: B00ns 01 Transitions A-xB: 0
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PWM with coherent update

The exercise above uses 2 interrupts to set-up the t,, and t,¢ values of the low and high side. This system setup might be
critical when a interrupt is delayed by more than half a period and the interrupt routine set the new values in the deadtime
period. Then only one side will be set to a new value and this might cause a short.

Therefor in systems with heavy interrupt load another configuration is needed. Instead of using shadow registers which
are not available within the LTC a second set of LTCs can be set-up and the reset timer switches by HW from on set to the
other. This is called coherent update (CUD). The exercise solutions contains a project pwm_cud which implements such a
solution. This solution uses twice as much LTCs for each PWM, so that for a complementary 3-phase PWM 26 cells are used

instead of 15.
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ompare Valuej
LTC1

-~
Infineon

Hred/tes

HHeg/bfe?
—
High Side < dead time < dead time
Low Side | |
i .
|
0 toﬂ“,L ton,H toff,H ton,L T me
Cell SOL |SOH | Output Control Mode Port
Reset Timer LTCO - Toggle select line (SL) by HW on reset, Interrupt on reset to -
set-up ton,H,toff,Hston,Lston, L
Compare Period LTC1 |1 1 - -
Compare High SideOn | LTC2 |1 0 Set output by a local event -
Compare High Side Off LTC3 |1 0 Reset output by a local event or copy the previous cell action -
Compare High SideOn |LTC4 |0 1 Set output by a local event or copy the previous cell action -
Compare High Side Off [LTC5 |0 1 Reset output by a local event or copy the previous cell action P2.8
Compare Low Side Off [LTC6 |1 0 Reset output by a local event -
Compare Low Side On |LTC7 |1 0 Set output by a local event or copy the previous cell action -
Compare Low Side Off |[LTC4 |0 1 Reset output by a local event or copy the previous cell action -
Compare Low SideOn |LTC5 |0 1 Set output by a local event or copy the previous cell action P3.0
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Infineon
Pipelining

In this exercise you will develop an application that uses efficiently the super-scalar pipeline TriCore™ architecture. The
implementation is done in assembler, so that the user learns to write and optimize a small routine in assembler. The exer-
cise shows that with a basic understanding of the TriCore™ architecture and the TriCore™ instruction set algorithm execu-

tion speed can be considerable increased.

TnCore

Integer P|pel|ne

Load/Store P|pel|ne

Loop Plpelme
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Software pipelining means starting an equation before the previous equation has finished. This is achieved with knowledge
of the TriCore pipelining rules.

Example: Calculate the sum of an array with N+1 elements.

N
sum = ZXi
i=0

C Implementation

int sumO (int* X, int N)

{

int sum = 0;

for (int 1=0;1<=N;i++)
sum += X [1];

return sum;
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Generated assembler output by the C compiler.

sumO : .type func ; Set symbol type in the ELF symbol table
; main.c 107 {
; main.c 108 long 1i;
; main.c 109 long sum = 0;
movl6ée d2, #0 ; Initialize the sum saved in dZ2 to 0. d2 is the return register
; main.c 110 for (i=0,;i<N;i++)
movlé dl15,d2 ; Intialize the loop counter 1 to 0. dl15 form the upper context 1s used
j L 2 ; Jump to L 2
L 3:
; main.c 111 {
; main.c 112 sum += X[1];
1d16.w d0O, [a4d+] ; a4 is the 1st pointer argument. Load X[i] to register d0 and increment
; the pointer to the X array
addle d2,do ; Add X[1i] to the sum
addleée di15,#1 ; Add 1 to the loop counter 1
L 2:
jge d4,d15,L 3 ; d4 1s the 1st data argument. Jump to L 3 1if N >= 1
; main.c 113 }
; main.c 114 return sum;
; main.c 115 }
retl6 ; return sum in d2

The generated code does not take use of the super-scalar pipeline architecture of the TriCore™ and the usage of a jump
great equal jge is time consuming because it takes two cycles to execute.

Cyclel Cycle2 Cycle3 Cycled4 Cycle5
Integer Pipeline - add add jge jge
Load/Store Pipeline 1d . - - -
Loop Pipeline - - - - -

The code can be improved by using the loop instruction which is executed in the loop pipeline.
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Assembler Implementation

.define Xptr 'a4d' ; 1st address arg
.define N 'd4'! ; 1st data arg
.define sum 'd2" ; return value
.define X 'dl2' , upper context register
.define LC 'alb' , register used for loop counter
suml :
mov sum, #0 ; Initialize the sum saved to 0.
mov.a LC,N ; Intialize the loop counter LC to N
sumlloop:
ld.w x, [Xptr+] ; Load X[i1] to x and increment the pointer to the X array
add sum, X ; Add x to the sum
loop LC,sumlloop ; Jump to sumlloop 1if the loop counter 1s greater
; zero, decrement the counter
ret ; return sum 1in dZ2

Cyclel Cycle 2
Integer Pipeline - add
Load/Store Pipeline 1d -
Loop Pipeline - loop

Comparing the C and the ASM implementation, introducting the loop instruction replaces two instructions. The zero over-
head loop saves 3 CPU cycles, because it is executed in parallel. But still the pipelines are not optimal filled. The add
instruction has to wait for the load instruction.
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Optimized Assembler Implementation
An optimized implementation decouples the add and load instruction in the loop.

.define Xptr 'a4d'
.define N 'd4'!
.define sum 'd2"!
.define X 'dl2'
.define LC 'alb'
sum? :

mov sum, #0

mov.a LC,N

ld.w x, [Xptr+]4;
sum21lo0op:

add sum, X

ld.w x, [Xptr+]4

loop LC,sum2loop

ret

/7

Ist address arg

Ist data arg

return value

upper context register
register used for loop counter

Initialize the sum saved in d2Z to 0
Intialize the loop counter LC to 0
Load X[0] to x and increment the pointer to the X array

Add x to the sum

Load X[i] to x and increment the pointer to the X array
Jump to sumZloop i1f the loop counter 1s greater

zero, decrement the counter

return sum 1in dZ2

Integer Pipeline

Load/Store Pipeline

Loop Pipeline

The optimized ASM solution completely fills the three pipelines and doubles the execution speed.
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1. Create a DAVE project
Open the Windows Explorer and create a new directory c:\infineon\pipe. Copy the sat.dav file from the previous exer-
cise to the new directory and rename the file to pipe.dav.

2. Generate the application framework
Start DAVE and open the pipe.dav project file. Click on the Generate Code icon ﬂ on the application toolbar to start the
code generation process. Save and close the DAVE project.

3. Add a new project to the Tasking Workspace
Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\pipe\pipe.pjt.

4. Add the application framework

In the Project Properties dialog click the Scan icon [[#]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

5. Set current project
Use the context menu in the workspace window to make the pipe project the current project.

6. Load the project options
Choose Project > Load Options. In the Filename field enter c:\infineon\tcl1796 intmem.opt.

7. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.
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8. Add the user code
Right click on the project and choose Add New file. Add a new file named pipe.asm to the project.

2 R —
- EHA5C add Existing Files b

[ Include Sub-Project.,.. il
E Remove from Project Space ::
|__“| Project Oplions, .. e
 EE@H g
P Rebuid
g E; Yersion Control b

Add the following code at the beginning of the pipe.asn file.

.global suml

.global sum?

.sdecl ".text.pipe", CODE
.sect ".text.pipe"

and implement the different solution described on page 10-2, 10-5 and 10-6.
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Measure the execution time like it is done in the saturation exercise using the STM uwReadSysTmr function.

// USER CODE BEGIN (Main,9)
unsigned long dt;
long X[100];

for (int i1=0; 1<100; i++) // fill the array
X[1]=1;
isync () ; // this clears the pipeline

dt = STM uwReadSysTmr (STM TIMER 0) ;
s = sum0 (X, 99) ;
dt = STM uwReadSysTmr (STM TIMER 0) - dt;

printf ("sum solution 1: %$.1f cycles %$1d\n", 2.*dt, s);

9. Run the application
Click the Run icon ﬂ on the CrossView Pro toolbar to run the application.

Terminal: FSS 0 M=1Ed
Y

sum solution l: 524.0 cycles
sum solution 2: Z2Z.0 cycles
sum solution 3: 124.0 cycles

As expected the execution time of solution 3 is twice as fast as solution 2. The C Implementation is much slower. It uses 3
more cycles than solution 2 because of an additional add and an jump greater equal instruction which in this case is a 2

cycle instruction.
Due to the tripple issue architecture a 150MHz device can execute up to 450MIPS and taking the PCP into account the

TC1796 has more than 500MIPS.
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10. Single-handed exercise (20min): Implement and optimize a squarediff algorithm.
N

sum = Z (Xi_Y,-)z
i=1

Hint: Start with a C implementation. Analyze the assembler output and then write an optimized ASM implementation.
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Exercise 9: CAN
CAN

This exercise develops an application that sends messages between two CAN nodes. The
TC1796 MultiCAN module has 4 independent CAN nodes to connect the microcontroller to
different, separated CAN networks which might operate at different baurate and might run
different higher level protocols.

This exercise uses the internal CAN bus so that no cabling is necessary to connect the two
nodes, but the exercise can easily modified to send messages between two TriBoards.
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CAN Features

B CAN V2.0 B conform (compliant to ISO
11898)

B 4 CAN nodes

B 128 message objects

B Dedicated control registers for each CAN
node

B Data transfer rate up to 1MBit/s

B Flexible and powerful message transfer
control and error handling capabilities

B Message objects can be individually
— Assigned to one of the four CAN nodes
— Configured as transmit or receive object
— Configured as message buffer
— Configured to handle 11-bit or 29-bit
identifiers
- Provided with programmable filter mask
— Monitored via a frame counter
— Configured for Remote Monitoring Mode

B Automatic Gateway Mode support

B 16 programmable interrupt nodes

B CAN bus analyzer mode

B Time-Triggered Extension (TTCAN)

Release 04/2007

Clock
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DMA Control CAN TXDC1 1 control ,
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INT O Objects Node 1 =
4= .
Interrupt [3:0] TXDCO
Control INT O CAN RXDCO '
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15:4
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INT_ —
LTCA2 I“‘ma CAN Control | i
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GPFTA1 IC—- i v
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GPTAD | ECTT3 ¢ < ECTT1
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ECTT4 — < @
sScU - acheduleTiming DataMemory I
Ext.Req.
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FE.15/
TXDCAN3I
PB.14 ]/
RXDCAN3

P8.13/
TXDCANZ

PE12]
RXDCANZ

PE.11/
TXDCAN1

F6.10 /
RXDCAN1T

P89/
TADCANO

PE.8 /
RXDCANO

P13/
REQ3

P7.51
REQ7

MCADSE6
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Remote request
CAN Node O CAN Node 1
(Requester + Consumer) (Producer)

Local Local
Intelligence Intelligence
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Infineon
1. Create a DAVE project

Open the Windows Explorer and create a new directory c:\infineon\can. Copy the isr.dav file from the previous exer-
cise to the new directory and rename the file to can.dav.

2. Open the MultiCAN properties
Click on MultiCAN in the project window to open the MultiCAN properties.
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3. Set up the MultiCAN properties: Module Clock
Enable the CAN module and select Select normal divider mode, so that the CAN module is running at 75MHz.

@ MultiCAN Controller (X
[ il
Module Clock l Modes ] Lizts ] [ ] SRMNz ] [Fkerrpts ] Functions ] Funchions2 ] Farameters ] Motes ]
todule Dizable Request Sleep Mode Enable Contral
[~ Disable the C&N madule [DISF) - [DEiEelnEI]e the zleep mode far the CAM rmodule
Divider Mode Contral (D] Dizable Clock Contral
-~ Disable module clock - [I:IIZJLIJtSpIEJIt_El]DEk becomes inactive after initialization

¢ Select normal divider mode: Enable Hardware Clock Control

(" % elect fractional divider mode B

Maodule Clack. Control
Reguired module clock [MHz] W Real module clock [MHz] 7EO000
tdirimal module clock [F.Hz] EEF - Percentage of dewiation [%] oooo
Maximal module clock [MHz] — [75.000 Step value [STEP) Ow3FF
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4. Set up the MultiCAN properties: CAN node 0
In this exercise, CAN node 0 is used to transmit a remote frame to node 1 and receives a data frame from node 1.

Both nodes are connected to the internal CAN bus, as to avoid cabling (Loop Back Mode).
On the Nodes page click Node 0 to configure the CAN Node 0.

@ MultiCAN Controller Ed
Kai il
Madule Clock  Modes | Lists | MOs | SRNs | Interrupts | Functions | Functions? | Parameters | Notes |
CAN MNodes
o ModeD Node 1 | Node 2 | Node 3 |

Although we are connecting the CAN nodes internally using the Loop-Back-Mode (LBM) input and output pins has to be

configured.
Click Alternate Pin Selection Configure pins.

@ Configure CAN Node 0 (%]

™ & - 7

Control l Baud Flate] Frame Eu:nunter] TTCAM Eu:nntn:nll TTCAM Ennfiguratinn] TTCAM Interrupt]

Alternate Pin Selection

23
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On the RXDCANO page select Use pin P6.8 as CAN node 0 input signal (RXDCANO).

@ Configure Alternate Pin Functions r‘s_<|

| @ta - 2 -

RHDCAMD Pin Selection
(" Ma pin as B=DCAND selected
¢ sze pin PE.8 as CAMN node O input signal [REDCARD]

f-%_lse pin PE.10 as CAM node O input zignal [REDCARND)

On the TXDCANO page select Use pin P6.9 as CAN node 0 output signal (TXDCANO).

% Configure Alternate Pin Functions f'5__<|
Kai " P
FXDCAND  TADCAND |

THDCAMD Pin Selection
{7 Mo pin as T=DCAMND zelected

[
Click the Close icon @ on the dialog toolbar to close the Configure Alternate Pin Functions dialog.
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On the Control page
B Check Initialize the CAN node 0 (INIT),
B Check Enable the Loop-Back mode (LBM) to connect the node to the internal CAN bus.

@ Configure CAN Node 0 (%]
[ 7
Cantral l Eaud Fiate] Frame Enunter] TTCAM Eu:nntrn:nl] TTCAM Ennfiguratinnl TTCAM Interrupt]

Alternate Pin Selection

Configure ping R=DCAMND [= PE.8] and T=DCARND [= PE.9) |

[nitialization Analyzer Mode

v Iritizlize the CAMN node O [IMIT) Enable the CAN analyzer mode; monitaring CaM bus traffic
without participating in the CAM bus protocol itzelf [CALRM]

[Frtermpt Contral [rtermapt Mode Pointer

E nable interrupt generation when a
meszage transfer 1z completed [TRIE]

B Enable interrupt upon a changes/set of
BEOFF.EWARM, LLE. LOE or IMIT [ALIE]

E nable interrupt generation upon each
update of the bit field LEC [LECIE]

Loop Back Mode Errar \Warning Lewvel

v Enable the Loop-Back maode [LEIME Error warning threshold walue [EXRHLWL] |EIE

X

Node 0 is configured.
Click the Close icon @ on the dialog toolbar to close the Configure CAN Node 0 dialog and return to the MultiCAN

page.
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5. Set up the MultiCAN properties: CAN node 1
CAN node 1 is used to receive remote frames and to transmit data frames.

On the Nodes page and click Node 1.

@ MultiCAN Controller Ed

™ &ta - ?

Module Clock  Modes lLiStS ] & [ ] SHNEI Interrupt&] Funn:tin:nn&] Funn:tin:un&E] Parameter&] Nu:nte&]

CAM Modes

......................................................

NI:”:IE |:| | _. ................... N DdE'I NI:":IE 2 | NI:":IE 3 |

Click Alternate Pin Selection Configure pins.

x]

& Configure CAN Node 1

Kai | ?
Caontrol l Eaud Flate] Frame Eu:nunter]

Alternate Pin Selechion

Configure ping R=DCANT [= none] and THDCAMT [= none)

e e LT T TP PP P PR POLE

b
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On the RXDCANO page select Use pin P6.10 as CAN node 1 input signal (RXDCAN1).

@ Configure Alternate Pin Functions r‘s_<|

[* - P
FXDCANT | TXDCANT |

H=DCAMT Pin Selection
(" Mo pin as B=DCANT zelected

f%.lse pin PE.12 as CAM node 1 input zignal [REDCARNT)

On the RXDCANO page select Use pin P6.11 as CAN node 1 output signal (TXCAN1).

% Configure Alternate Pin Functions f'5__<|
Kai " P
FKDCANT  TADCANT |

THDCAMT Pin Selection
{7 Mo pin as T<DCANT zelected

Click the Close icon @ on the dialog toolbar to close the Configure Alternate Pin Functions dialog.
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Exercise 9: CAN

On the Control page
B Check Initialize the CAN node 1 (INIT),
B Check Enable the Loop-Back mode (LBM) to connect the node to the internal CAN bus.

@ Configure CAN Node 1 (%]
Ka | 7
Contral l B aud Fiate] Frame Enunter]

Alternate Pin Selection

[nitialization Analyzer Mode

v Iritizlize the CAMN node 1 [IMIT) Enable the CAN analyzer mode; monitaring CaM bus traffic
without participating in the CAM bus protocol itzelf [CALRM]

[Frtermpt Contral [rtermapt Mode Pointer

E nable interrupt generation when a
meszage transfer 1z completed [TRIE]

B Enable interrupt upon a changes/set of
BEOFF.EWARM, LLE. LOE or IMIT [ALIE]

E nable interrupt generation upon each
update of the bit field LEC [LECIE]

Loop Back Mode Errar \Warning Lewvel
v Enable the Loop-Back maode [LEM] Error warning threshold wvalue [E\WHRMLWL] |E|E

R

Node 1 is configured.
Click the Close icon @ on the dialog toolbar to close the Configure CAN Node 1 dialog and return to the MultiCAN

page.
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6. Set up the MultiCAN properties: Message objects

The next step is the configuration of two message objects. The MultiCAN module includes a total of 128 message objects.
Each message object can be allocated to one (and only one) CAN node and handles messages with a certain ID. This
means on the other hand, that each CAN node has a list of message objects (between 0 and 128). The order of each list
may be used for prioritizing messages.

In this exercise, node 0 sends a message to node 1 and receives an answer from node 1.

On the Lists page

B Drag MO100 from List 0 (unallocated MOs) to List 1 (Node 0) level 1,

B Drag MO101 from List O (unallocated MOs) to List 2 (Node 1) level 1.

@ MultiCAN Controller Ed
Eai i
M odule EI::u:k] Modes Lists IMDS ] SHNEI Interrupt&] Funn:tin:nn&] Funn:tin:un&E] Parameter&] Nu:nte&]
Ligt1 [Mode 0 [List 2 (Mode 1) [Lit3ne)] [Listd4(ne) o] | List0(unallocated MOs]
Level 15 MO A
Level 14 s
Lewvel 13 k0102
Level 12 MO103
Level 11 mglgg
Lewel 10 MO 08
Lewel 9 MO107
Level B MO103
Lewvel 7 bO7109
bO11
Level B MO110
Level b WMO111
Lewvel 4 MO112
Lewel 3 tMO113
Lewvel 2 k407114
Level1 | MO100 MO101 . [ HSHE
hg v IR[YGHE: v
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On the MOs page click MO100 to configure the message object attached to node 0.

& MultiCAN Controller (X
[ - P

M odule I:I::u:k] Nu:u:les] Ligtz MOz ISHNEI Interrupts] Funn:tin:nns] FunctinnsE] F'arameters] Nntes]
CAMN Meszzage Objects (MO)

00 0 1 MO 2 MO 3 0O 4 MO & MO E MO 7 0 8 t0O 3
MO 10 PO 11 MO12 | MO13 MO14 | MO15 | MOE MO/ | MOT18 | MO13
MO 20 MO A1 MO 22 | MO 23 MO 24 | MOZ5 | MOZE MO 27 | MO25 | MOZ3
0O 30 tO 3 MO 32 | MO0 33 MO 34 | MO3E | MO3E MO 37 | MO33 | MO23
MO 40 MO 41 MO 42 | MO 43 MO 44 | MO 45 | MO 46 MO 47 | MO45 | MO 43
k0O 50 MO 51 MO 52 | MO 53 MOS4 | MOS5 | MOBSE MOS7 | MOS5 | MOS53
MO B0 tO B MO B2 | MO E3 MOB4 | MOER | MOEE MOEF | MOES | MOE3
MO 70 MO 71 MO 72 | MO 73 MO 74 | MO7E | MOFE MO | MO7E | MO ¥3
t0O 20 MO 51 MO E2 | MO 83 MO&E4 | MOSBS | MOSE MOS7 | MOBS | MOB=3
0O 30 t0O 31 MO 32 | MO 33 MO34 | MOS95 | MOSE MO 37 | MOS93 | MO33

MOLOE[ MO101) MO702) MO703) MO1047 MO05] MOT06] MO107) MO105] MO 103
MokSo| MO111| MO112| MO113| MO114] MO115| MO116| MO117| MO118| MO 119
MO120( MOT21| MO122] MO123| MO124 | MO125 ) MO126| MO127

Release 04/2007
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On the Object page
B Check Enable message object 100 (MSGVAL),
B Select Message Direction (DIR) Receive data frames, transmit remote frames,

B Choose 1 data bytes as Data length.

@ Configure CAN Message Object (MO100) §|

™ @ta - 2 -

|dentifier Selection [IDE) Lizt Allocation [LIST]

{# Standard 17-bit identifier
(" Extended 29-bit identifier

Meszzage Valid

v Enable meszage object 100

¥ MSGVAL) List 1 [node 0)

teszzage Direction [DIR)

Recewve data frames. transmit
remote frames

Tranzmit data frames, receive
and anzwer remote frames

Drata Length Code [DLE)

Data length |'I data bytes ﬂ

Data Fields [MODATAL, MODATAH]

—
—
—
—

CEEE

Arbitration Register

[dentifier 11-hit D000

(1ID25-16)
|

Aoceptance Mazk

&ccept reception of standard
and extended frames

Only recerve frames with
matching IDE bit

[07FF
|

Mask 11-bit
[B428-15)

Remote Monitaring

-

Frianty Clazs [FRI)
Fricrity | lizt order ﬂ

Single Data Transfer Mode

Dizable the object auta-

| matically after a successful
data transfer [SDT)

Single Tranzmizzion Tnal

B Enable zingle fransmizzion
trial [STT]

Release 04/2007
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On the Interrupt page
B Check Enable receive interrupt; bit RXPND is set after successful reception of a frame (RXIE).

& Configure CAN Message Object (MO100) Ed
[ | 7
Object | FIFD/Gateway Intermupt |

[Rtermapt Contral

v Enable receive interrupt; bit B=PMD iz zet after successful reception of a frame [F=IE

I_[%E fiable tranzrt intermupt; bit TEPRD 1z 2et after successbul tranzmizzion of a frame [TEIE)

MO0100 is configured.
Click the Close icon @ on the dialog toolbar to close the Configure CAN Message Object (MO100) dialog.
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On the MOs page click M0101 to configure the message object attached to node 1.

On the Object page

B Check Enable message object 101 (MSGVAL),
B Select Message Direction (DIR) Transmit data frames, receive and answer remote frames,

B Choose 1 data bytes as Data length.

@ Configure CAN Message Object (MO101)

N &ta - ¥

M ezzage Walid

[M5GYAL]

tezzage Direction [DIR)

remote frames

Drata Length Code [DILC)

Receive data frames,

v Enable meszage object 101

tranzmit

= Transmit data frames. receive
and anzwer remote frames

DED {000
—
—
—

Diata length |'I data bytes ‘%

Data Fields MODATAL, MODATAH]

LEEE

[dentifier Selection [[DE]

f* Standard 11-bit identifier
(" Extended 29-bit identifier

Arbitration Begister

[dentifier 171-bit ||:|:,:|:||:||:|

1D 28-18)
|

Acceptance Mazk

Accept reception of standard
and extended frames

Only recere frames with
matching IDE bt

Mask 11-bit
[ 28-18) |0 7FF

Lizt Allocation [LIST]

|Li3t 2 [node 1)

Remote konitaring

Copy the identifier, DLC and
|IDE code of a remate frame
with matching identifier ko
thiz trangzmit object (R kM)

Friarty Clazs [PRI)
Fricrity | lizt order ﬂ

Single Data Transfer Mode

Dizable the object auto-
| matically after a successhul
data transfer [SOT)

Single Transmizzion Tnal

- Enable zingle transmizzion
trial [STT]

Release 04/2007
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On the Interrupt page
B Check Enable receive interrupt; bit RXPND is set after successful reception of a frame (RXIE).

@ Configure CAN Message Object (MO101)
[ P

Object | FIFD/Gateway Intermupt |

[Rtermapt Contral

v Enable receive interrupt; bit B=PMD iz zet after successful reception of a frame [F=IE

| %nable tranzmit inkerrapt; bit TEPMD iz 2et after succeszful ransmizzion of a frame [THIE]

MO0101 is configured.
Click the Close icon |ﬂ| on the dialog toolbar to close the Configure CAN Message Object (MO101) dialog.
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On the SRN page
B Check Enable the MultiCAN service request node 0 (SRE).

x]

& MultiCAN Controller
Eai i
M odule EI::u:k] Nu:u:le&] Lizts ] MOz SEMs l Interrupt&] Funn:tin:nn&] Funn:tin:un&E] Parameter&] Nu:nte&]
buliCAM Service Request Mode Enable Control

I_%Enal:-le thie MuliCAM zervice request node 1 [SRE]
| Enable the MultiCAMN service request node 2 [SRE]

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved. Page 9-18



\

. Infineon
Exercise 9: CAN

On the Interrupts page drag the CAN SRN 0 from the Level 0 list to CPU Interrupt Level 4.

& MultiCAN Controller (X
[ - P

Module I:I::u:k] Nu:u:les] Lizts ] [ TE ] SAMz Intermupts l Funn:tin:nns] FunctinnsE] F'arameters] Nntes]

CPU Interrupt [masx. 255) |PEPIrﬂenupthnaa255] - Lewvel O [hon intermupting]

Level 15
Level 14
Level 13
Level 12
Lewel 11
Lewvel 10
Lewvel 9
Lewel B
Lewel ¥
Level B
Leveld |5TM SRAMO
Level 4 |CAMSHM O
Lewvel 3 [%
Lewvel 2
Lewvel 1
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On the Functions page
B Check the CAN vInit, CAN vGetMsgObj, CAN vTransmit and CAN vLoadData functions.

X

& MultiCAN Controller

™ &ta - ?

[rutialization Funchion

Source File

v |I:-i‘-.N_h-'I ik

Funchion Library [Part 1]

File narne |D‘-‘-.N.|::

Funchion Librany [Part £)

W |CAM_vGethsgObi |
| |
| |
v ||:.-'1'-.H_vTrar|3mit B |
|

v |E&N_VLDadD ata

The MultiCAN is configured.
Click the Close icon @ on the dialog toolbar to close the MultiCAN Controller dialog.

7. Generate the application framework

Click the Generate code icon ﬂ on the application toolbar to start the code generation process. Save and close the DAVE
project.
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8. Add a new project to the Tasking Workspace

Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\can\can.pjt.

9. Add the application framework

In the Project Properties dialog click the Scan icon [[]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

10. Set current project
Use the context menu in the workspace window to make the can project the current project.

11. Load the project options
Choose Project > Load Options. In the Filename field enter tc1796 extmem.opt.

12. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

13. Add the user code
Add an endless loop which transmits message object 100 every 2 seconds to file MAIN.c at (Main,9).

// USER CODE BEGIN (Main,9)

for (;;){
printf ("Node 0: transmit remote frame\n");
CAN vTransmit (100); // Transmit message object 100 of node 0

delay (2000) ;

}
// USER CODE END
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In file caAN.c, add the following code to the interrupt routine caNn visSRrRNO at (SRNO_OBJ100,2), which is called upon suc-
cessful reception of a CAN data frame on node 0.

// USER CODE BEGIN (SRNO OBJ100,2)

CAN SWObj msg;

CAN vGetMsgObj (100, &msgqg);

printf ("Node 0: receive data frame, data = %d\n\n", (int)msg.ubData[0]):;
// USER CODE END

In the file caN. c, add the following code to the interrupt routine can visSrRNO at (SRNO_OBJ101,4), which is called upon
successful reception of a CAN remote frame on node 1.

// USER CODE BEGIN (SRNO OBJ101,4)

CAN SWObj msg;

CAN vGetMsgObj (101, &msgq);

printf ("Node 1: receive remote frame, transmit data frame, data = %d\n",

(int)msg.ubDatal[0]) ;
// USER CODE END
In the file STM. c, add the following code to the interrupt routine sT™M viSRNO at (SRNO,3). The STM interrupt is called
every second and modifies the data value of message object 101.

// USER CODE BEGIN (SRNO,3)

static ubyte ¢ = 5;

CAN vLoadData (101, &c); // Load new data to message object 101
c++;

// USER CODE END

14. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

15. Debug the application
Click the Debug icon @ on the Build toolbar to open the CrossView Pro debugger.
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16. Run the application
Click the Run icon ﬂ on the CrossView Pro toolbar and see terminal output.

Terminal: FSS 0 =13
.

Mode O: transmit remote frame

Node 1: receiwe remote frame, transmit data frame, data = 9
MNode 0: receiwve data frame, data = 9

MNode 0: Transmit remote frame

Node 1: receiwe remote frame, transmit data frame, data = 16
MNode 0: receiwe data frame, data = 16

MNode 0: Transmit remote frame

Node 1: receiwe remote frame, transmit data frame, data = 22

MNode 0: receiwe data frame, data = Z2
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Peripheral Control Processor
The PCP2 is a freely programmable, single cycle, 32-bit RISC processing unit with its
Y P19 I P I 16 KB PRAM

own code and data memory unit used as an interrupt service providerd.

PCP Benefits

B PCP provides programmable improved peripheral intelligence instead of static imple-
mentation

B Off-loads TriCore™ from interrupt tasks and allows a parallel execution

M PCP fits best for real-time critical tasks due to very fast interrupt response.

B Handles fast, interrupt-driven routines for peripheral control Intelligent data pre-con-
ditioning e.g. building up mean value of several concurrently sampled ADC values

B DMA data transportation like queued memory or FIFO structures e.g. coming from
serial communication interfaces like CAN, SPI or ASC off-loads TriCore™ and realizes
partially peripheral functionality in SW

B Complex state machines can easily be code

\

Interrupts

¥
o
4o
e
L
-+
B
L
=
a8/
I
(=
L
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Full Context Small Context
31 0 h|
PRAM PRAM
Memaory Mermory
| Context |
B #n1 B
nix8,, =SFHF'N =n1 i
1 ] : Context
[CRO ] | #n2 ]
[CR1 ] [l L SRPN = n2
[CR2 | gl N
CR3 i i
= " Context  —
CR4 2o _ [
[CRS5 _ |
CRE _ |
10 CRH7Y _SAPMN =2
HICRO ) |
[CR1 _] | Context
[CR2 | B #3 ]
CR3 SRPMN =3
=~ Context  — *
[CR4 a4y | 0Cy |CR4
[CRE ] | CRE Context
[CRE | [CRe  #2 |
CR7 _SRAPN =1 CR7 _SRPN =2
08, - o8, =T
B _ [CR5 Context
_ CRs  #1 _
| &Words | 04 CR7 _SRPN =1
not used H N
[ ] 4 Words
B B B not used
0o, 00,

Fig.1 Context Storage in PRAM

Release 04/2007

Minimum Context

3 0
PRAM
Memaory
| Context |
#n3 =
nax2,, LSRPN = n2
08y, Context |
08 #3 _SRPN =3
H[CRE Context _|
04 CRY #2 _SRPN =2
H[CRE Context |
02 CR7  #1 _ SHPN =1
Hl  2words |
not used
00,

10: Peripheral Control Processor

Channel Restart Mode

16 0

Code Memory
CMEM

Channel #2
Main Code

Channel #n1
Main Code

Channel #3
Main Code

Channel #1
Main Code

| Channel Instruction #2 |
#1 Instruction #1

_SRPN =n

1

nix=2,,

06

| Channel Instruction #2 |
#3 Instruction #1

_SRPN=23

A

Channel
» Entry
Table

x

04

| Channel 2 |
#2 Instruction #1

Instruction #2|

_SRPN =2

x

| Channel
#1 Instruction #1

Instruction #2 |~

02

2 Half-words
not used

00

_SRPN = 1
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Channel Resume Mode

0

Code Memory
CMEM

Channel #2
Main Code

Channel #n1
Main Code

Channel #3
Main Code

Channel #1
Main Code

MCACSETS

Fig.2 CMEM organization in rest
resume mode (right)
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1. Create a DAVE project
Launch DAVE and choose TC1796 from the list of 32-bit microcontrollers. Click Create.

% DAvVE - New Project

TC1100 PETC116G
TC1115 W TC1766
TC1130 P TC1796
TC1161 r[%
TC1162

TC1163

TC1164

TC11E5

Create

Caricel

Help

Two new windows, the TC1796 project window and the Project Settings dialog appears.

2. Set up the Project Settings

In the Project Settings dialog select the Compiler settings Tasking 2.0. If the dialog is not open choose File > Project
Settings.
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On the System Clock page set the external clock frequency to 20 MHz, PDIV = 2, NDIV = 60, KDIV = 4,

& Project Settings ['5_(|

™ @ta -| 2 -

Esternal Clock Freguency

E=ternal clock frequency |2|:| B FLL Bypazz operation [fopu = fozsc)
[MHz] [pin BYPASS = 1]
Input divider [FDIV] \fp = fosc / 2 = 10.000 MHz |

YYoltage Controlled Qzcillator (O]
| %CO Bypass mode [VCOBYP)

WLU range VLOSEL]  1e00 MHz - 700 MHz -

Feedback divider (NDV) [fyco=fosc /P *60=6G00000MHz v poo oy, [BOCOD
Cutput Disider

Output divider (KDY (fopu = fvca / 4 = 150,000 MHz -] [I:MPI-ITIE]E'DEk 150.00000000

{* The ratio fcpu # fayz iz 2 /1 System Clock 75. 00000000

(" The ratio fepu A fspsis 1 41 [t4Hz]
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Exercise 10: Peripheral Control Processor
On the Interrupt System page check Enable globally the Interrupt System (IE).

& Project Settings [5__(|
[ | 7
General] System Clock  Interrupt System l PCP SPStEFﬂ] Pad Driver] Starbup Eu:nnfiguratin:un] Nu:nte&]

CPU Global Interrupt Enable

Click the Close icon @ on the dialog toolbar to close the dialog.

3. Open the ASCO properties
Click on ASCO in the project window to open the ASCO properties.
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4. Set up the ASCO properties

On the Module Clock page
B Uncheck Disable the ASCO module (DISR),
B Choose Module Run Mode Clock Control System clock / 1.

@ Asynchronous Synchronous Serial Interface 0 (ASCO)

™ &L - 7

tadule Clock l Fir SE|EEtiDr'|l Eu:nntrn:nl] Baud Hate] Interrupts] Functinns] F'arameters] Nntes]

todule Bun Mode Clock Control

todule Dizable Request Sleep Mode Enable Contral
— Dizable the ASCO module = Dizable the sleep made for the ASCO module
ADISEL o [EDI3]

Clack divider far normal

operation mode [FRC) Syztem clock /1 [= 75,0000 MHz)

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.
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On the Pin Selection page click Configure pins.

& Asynchronous Synchronous Serial Interface 0 (ASCO) ['5__(|
Eai "7
Module Clock,  Fin Selection lEu:nntrn:nI] Baud Flate] Interrupt&] Funn:tin:nn&] Parameter&] Nu:nte&]

General Dperating Mode [M]

{+ Full-duplex asynchronous operating modes " Half-duplex 8-bit spnchronous operating mode

Alternate Pin Selection

Configure pinz &5 I?[E_H}i [= none] and ASCO_TH [= none]

£
On the ASCO_RX page select Use pin P5.0 as ASCO receive input signal (ASCO_RX).

% Configure Alternate Pin Functions

Kal i
ASCO_RX | 45C0TX |

A5C0_Rx Pin Selection
(" Mo pin as A5C0_R= zelected

s Usze pin P5.0 a3 A5C0 receive input signal [ASCO_Rx]
(_%Jse pin PE.8 az A5C0 receive input signal [A5C0_Fx)
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On ASCO_TX page select Use pin P5.1 as ASCO output signal (ASCO0_TX).

% Configure Alternate Pin Functions

Eai "7
ASC0 R ﬁSED_TK]

A5C0_Te Pin Selection
(" MNopinasASCO TH selected

{ "l ze pin PE.9 as ASCO autput gsignal [ASC0_Ti]
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On the Control page

B Select Mode Control (M) 8-bit data (asynchronous),
B Select Stop Bit Selection (STP) One Stop bit,
B Check Interrupts Enable receive interrupts (TSRC).

@ Asynchronous Synchronous Serial Interface 0 (ASCO)

® &L - ¥

Mode Contral [#)]

~

{+ B-bit data [asynchronous)

(" 9-bit data [asynchronous)

Error Check
| Enable averun check [OEN]

| Enable framing check [FEM]

-

" 7-bit data + parity [asynchranous)

(" B-bit data + wake up [aspnchronous)

(" B-bit data + parity [asynchronous)

Receiver Enable Loopback Mode

v Enable receiver [FEM] | Enable loopback mode [LE]
Stop Bit Selection [STF) Farity Selection [ODD)

{* One ztop bit (s

(" Twa stop bitz ("
[Fkermipts

| Enable transmit interrupt [TSRC)

| Enable transmit buffer interrupt [TESRC)

v Enable receive interupt [RSRC)

-

Release 04/2007
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On the Baud Rate page

B Select Baud Rate Generator Run Control (R) Enable baud rate generator,

B Enter as Required baud rate: 115.200 . Type Return.

& Asynchronous Synchronous Serial Interface 0 (ASCO)

™ &L - 7

¢ Additionally reduce senal clock to 2
(" Digable baud rate generator

{" Additionally reduce seral clock ta 3

{# Enable baud rate generatar
| Usze fractional divider as prescaler for baud rate timer [FDE]

Max. baud rate [Mbaud] |E. 344

Baud Rate Selection Bit [BRS] / Fractional Divider [FOE) Baud Rate Generatar Bun Control [R]

Baud Rate
Fequired baud rate [kbaud] W Real baud rate [kbaud] IW
I— Fercentage of dewviation [%] IW
Min. baud rate [baud] IW Reload value [RL) W

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.

=)

neon

Page 10-10



-~
Infineon

Exercise 10: Peripheral Control Processor
On the Interrupts page drag the ASCO transmit SRN interrupt from the right list to the CPU interrupt level 3.

% Asynchronous Synchronous Serial Interface 0 (ASCO)
Kai il

b odule I:I::u:k] Fin Selectinn] Eu:nntrn:nl] Baud Rate Interupts l Funn:tin:nns] Parameters] Nu:ntes]

CPU Interrupt [max. 255] |PEPIrﬂenupthnaaEEE] - Level 0 [hon intermupting]

Level 15
Level 14
Lewvel 13
Lewvel 12
Level 11
Level 10
Lewvel 3
Level B
Level 7
Level &
Level b
Lewvel 4

el 3 ','é;'é'ii'lj"i’é’&;’é’iﬁé"éﬁ'ﬂ"'{% .........................

Lewvel 2 g
Level 1

-

Mote: To change the level and the group of an interrupt zource, click onit, drag it to itz rew pozition and drop it
To =et an interrupt zource to the non interupting level [Level O] click on it, drag it to the Level 0 izt and drop it
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On the Functions page
B Check the ASCO vInit, ASCO vSendData and ASCO vGetData functions.

@ Asynchronous Synchronous Serial Interface 0 {ASCO) [‘S__<|
Eai 7
Module I:I::u:k] Fin Selectinn] Enntrnll EBaud Flate] Interripts FUHCtIDﬂS] Parameters] Nntesl
Imitialization Function Source File
W ASCOvinit File name ASC0.C
Function Library [Part 1) Function Libramy [Part 2)
W |ASCO_vSendData |
W |ASCO_usGetData |
™| ™|
7 |ASCO_viRx |
™ | ™ |
| ™|
| |
| |
| |
™ |

Click the Close icon @ on the dialog toolbar to close the dialog.

5. Save the project
Choose File > Save and save the project as c:\infineon\pcp\pcp.dav.

6. Generate the application framework
Choose File > Generate Code to start the code generation.
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7. Add a new project to the Tasking Workspace

Switch to the Tasking EDE. Choose File > Configure Project Space... > Add new project and add a new project
c:\infineon\pcp\pcp.pjt.

8. Add the application framework

In the Project Properties dialog click the Scan icon [[]. A dialog appears. In the Pattern field, enter *.c; *.h. This will
select all generated files of the application framework. Select the project directory and click OK.

9. Set current project
Use the context menu in the workspace window to make the pcp project the current project.

10. Load the project options

Choose Project > Load Options. In the Filename field enter the c:\infineon\tc1796 intmem.opt. The option file can
be found in the tc1796.zip package.

11. Add the user code
Add an endless loop to MAIN.c at (Main,9)

// USER CODE BEGIN (Main,9)
for (;;) // forever
// USER CODE END

Modify the interrupt routine in ASCO.c

void _interrupt (ASCO RINT) ASCO_viRx (void)
{
// USER CODE BEGIN (Rx, 2)
ASCO_vSendData (ASCO usGetData()); // echo any character received
// USER CODE END
} // End of function ASCO ViRx
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12. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.

13. Run the application
Click the Run icon ﬂ on the CrossView Pro toolbar. Open a HyperTerminal window. Set the COM parameter to 115200 8-
N-1-None.

COM1 Properties

i Fort Settings !
|

Bitz per second: | gREEIL

Drata bitz: | 8 W

Farity: | Mone W

Stop bitz: |1 w
|
|
|

Flow contral: | Mone W

See the output. (On some system is it required to reset the application once. Choose Run > Reset Target System.)

‘& 115200-8-N-1-None - HyperTerminal =13
File Edit Wiew Call Transfer Help

[F

Hallo TriCore echo_
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Exercise 10: Peripheral Control Processor

14. Modify the DAVE project.
Switch to DAVE to modify the project and choose File > Project Settings.

On the PCP System page
B Check Enable globally the PCP system. This also automatically enables the PCP module.

% Project Settings [5__<|

™ &L - 7

General] Spztern I:I::u:k] Interupt System  FCF Spatem lF'au:I Driver] Startup Ennfiguratinn] Nntes]

FPCP Enable Caontral
v Enable globally the PCP system [EM}

I

15. Open the PCP properties
Click on PCP in the project window to open the PCP properties.

‘l PCP2 I s

Page 10-15

Release 04/2007 Copyright © Infineon Technologies 2007. All rights reserved.



Exercise 10: Peripheral Control Processor

16. Set up the PCP properties
On the Control page

@ Peripheral Control Processor (PCP2)

™ &3 - 7

Module Clock  Cantral l Interrupts] FCF Interrupts]

Enable Cantral

v Enable PCP for operation after initialization [EM]

Context Size [C5]
(" Usze Full Context zave area (R[0] - R[]

I Usge Minimum Contest zave area [R[E] - R[F])

Chanrnel \watchdog
| Enable channel watchdog [CWE)

Errar Service Request Mode

| Enable PCP emror CPL SBM

| [

B Check Enable PCP for operation after initialization (EN),

B Select Context Size Use Small Context save area (R[4]-R[7]),
B Select Channel Start Mode Control (RCB) Start program counter at the appropriate channel entry point.

X

Enable ENDIMIT

- [f EMDINIT = true then dizallaw FPI writes to
the PCP_C5 reqgizter [EIE)

Channel Start Mode Contral [RCE]

(" Start progam counter ag left by lazt invocation
= Start prograrn counter at the appropriate charnnel

%entr_l,l point

t axirmum Channel Checking

| Enable maximum channel number checking [FPE]

[

=)

Release 04/2007

Click the Close icon IE| on the dialog toolbar to close the dialog.
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17. Modify the ASCO properties
Open the ASCO properties. On the Interrupts page drag the interrupt from the CPU column to the PCP column.

@ Asynchronous Synchronous Serial Interface 0 (ASCO) §|

™ &3 - 7

kModule I:I::u:k] Fin SEIectiDn] Enntrnll Baud Rate Intermupts l Funn:tin:uns] F'arameters] Nntesl

CPU Interrupt [masx. 255) |PEPIrﬂenupthnaa255] - Lewvel O [hon intermupting]

Level 15
Level 14
Level 13
Level 12
Lewel 11
Lewvel 10
Lewvel 9
Lewel B
Lewel ¥
Level B
Level B
Lewvel 4
Lewvel 3 ASCO receive SHM

Lewvel 2 %

Lewvel 1

18. Save the project
Choose File > Save and save the project.

19. Generate the application framework
Choose File > Generate Code to start the code generation.
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20. Modify the Tasking project
Add a new file pcp.pcp to the Tasking project.

; PCP Context Save Area

.org 3*4, DATA, INIT ;3 channels (0,1,2) not used. 4 words for small context
ch3 context:

.word 0x00000040 ;R[7] CEN=1 channel enable set, DPTR=0

.word 0x03000000 ;R[6] current priority CPPN=3

.word ASCO TBUF ;R[5] intitialize to ASCO TBUF

.word ASCO_RBUF ;JR[4] intitialize to ASCO_RBUF

» Entry table for the PCP vector Mode start of channel 3 (SPRN 3)

4

.org 3*2, CODE, INIT ;3 channels (0,1,2) not used. 2 words for each vector
ch3:

jc.a ch3 start, cc UC
ch3 start:

ld.£f R1, [R4], SIZE=S8 ;load receive buffer from FPI bus address to RI

st.f R1, [R5], SIZE=S8 ;Sstore RI1 to transmit buffer at FPI bus address

exit EC=0, ST=0, INT=0, EP=0, cc UC ,exit w/ no counter action, not channel stop,
;no interrupt, set PC to channel start

21. Build the application
Click the Build icon on the Build toolbar. The Build process finishes successfully.
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(Infineon
22. Run the application

Click the Run icon ﬂ on the CrossView Pro toolbar. Open a HyperTerminal window. Set the COM parameter to 115200 8-
N-1-None and try out the terminal

“& 115200-8-N-1-None - Hyper Terminal |: E g'

File Edit View Call Transfer Help

(3

Hallo PCP echo_
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