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Overview - PMAfob Software (nfineon

B Features

O Five buttons (Handling of five external wake-ups)

O Button stuck detection

O Debounce buttons

O Secure communication
- Advanced Encryption Standard (AES) or
- eXtended Tiny Encryption Algorithm (XTEA) encryption
- Rolling code generation

O Battery voltage measurement

O Energy saving by using Power Down Mode

O Configurable software by long button presses

m Note: An Application Note describing the PMAfob Software can
be found here:
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PMAfob Software _
Reset Setting (Infineon

B After reset (change of battery) the following configuration is
used:

O Baudrate: 9600 bps
O RF Framing: AES
O Encryption: ON

O Unique Key Number: User defined unique id
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PMAfob Software

Configuration by long button presses

PMAfob Button Software Configuration

m If buttons are
pressed longer
then ~ 3 s, the
software
configuration is
changed as shown
in the table.

H Note: If the
Framing is
changed the
Receiver has to be
reconfigured!

The PC Application
only accepts
encrypted frames!

Choose AES Framing.

Choose 4 bytes of PMA
unique id.

Choose XTEA Framing.

Choose user defined unique
id.

Switch encryption on / off:
ON => baudrate: 9600 bps
OFF=> baudrate: 4800 bps

(iﬁneon
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Overview - PMAfob Hardware (nfineon.

B Settings
O 5 buttons enclosure
0 434MHz band

0 9.6kbaud Manchester code

@ cem
5
3

y =

s =S
=
L J
»

O FSK modulation
Keyfob enclosure Top view Bottom view

0 5dBm output power

O Frequency deviation of approx. 50kHz

O Duty cycle setting of 34%

Page 10



PMAfob RKE Demo User Guide (lnfineon

H Overview
O PMAfob Software
O PMAfob Hardware
O Receiver Software
O Receiver Hardware
B Setup of the PMAfob RKE Demo
O Step 1: Installation of the PC-Application
O Step 2: Installation of the PMAfob Software
O Step 3: Configuration of the PMAfob
O Step 4: Connection of the Receiver Board

O Step 5: Handling of the PC-Application

Page 11



. . infineon
Overview — Receiver Software (lnfineon

B Features

O Configure TDA5230

O Read out data from TDA5230

0O Decrypt AES or XTEA encrypted RF-Frame

O Calculate rolling code for every PMAfob

O Illustrate the received command

O Illustrate signal strength (measured by TDA5230)
m NOTE:

O The UWLink is flashed by Infineon with the appropriate
firmware.

O The firmware installer
“"PMAfob_DEMO_UWLink_Firmware_Vx.y.msi” is included in
“PMAfob_RKE_DEMO_SW_Vx.y.zip” available at
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. . infineon
Overview — Receiver Hardware (lnfineon

M Features

O SmartLEWIS RX — TDA5230 UWLink Stick used as Receiver
Board

0O USB communication done with FTDI chip
0 Matching Network for 434MHz

B Note

O More information about the UWLink can be found on

O More information about TDA523x can be found on
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B Setup of the PMAfob RKE Demo
[0 Step 1: Installation of the PC-Application
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Setup of the PMAfob RKE Demo

B Step 1: Installation of the PC-Application

0 Double click PMAfob_RKE _DEMO_Rx_Vx.y.msi and follow the
onscreen installation instructions.

This will run the PMAfob RKE Demo setup.

i'é“ Infineon PMAfob RKE Demo

Welcome to the Infineon PMAfob RKE
Demo Setup Wizard

Infineon

=10l

=1o=]
Infineon

i"w!;“ Infineon PMAfob RKE Demo

License Agreement

infineon

=10
Infineon

i"% Infineon PMAfob RKE Demo

Select Installation Folder

The installer will guide pou through the steps required to instal Infineon PMAfob RKE Demo on pour
COMMpUtEr.

WARMING: This computer program is protected by copyright law and international treaties.
Unauthorized duplication or distribution of this program, or any partion of it, may result in severe civil
ol criminal penalties, and will be prozecuted to the maximum extent possible under the law.

Fleaze take a moment to read the license agreement now. If you accept the terms below, click "
Agree", then "Mext". Otherwise click "Cancel”.

Impartant Note and Terms of Use —

Please read the following important note as well as the following terms and
conditions carefully. The extraction of the downloaded documents as well as
the installation of the downloaded software is only possible if you agree to

such terms and conditions. By clicking the acceptance button "l agree”

below, you agree to have read the impartant note set forth below and to be
bound by the following terms of use. If you do not agree to the terms and
conditions below, click the button "l do not agree” and the installation ;I

| Do Mot Agree

The installer will install Infineon PMAfob RKE Demo to the following folder.

Toinstallin this folder, click "Mest". To install to a different folder. enter it below or click "Browse"

Folder:

C:\Program Files\Infineon Technologiesnfineon Piatob RKE Demo Browse... |
Dizk Cost... |

Install Infineon PMAfob RKE Demao for vourself, or for anyone who uzes this computer

% Everyone
© Just me

Cancel < Back i Neat >

Cancel ¢ Back

| Mext > I

Cancel < Back

Page 16




Setup of the PMAfob RKE Demo (nfineon

B Step 1: Installation of the PC-Application

0 Double click PMAfob_RKE _DEMO_Rx_Vx.y.msi and follow the
onscreen installation instructions.

This will run the PMAfob RKE Demo setup.

i'é“ Infineon PMafob RKE Demo

o ] | i Infineon PMafob RKE Demo i [l | {i# Infineon PMAfob RKE Demo i ] |
Confirm Installation T Installing Infineon PMAfob RKE Demo . Installation Complete )
(Infineon (infineon (Infineon

The installer is ready to install Infineon PMAlab RKE Dema on your computer. Infinean PMafab RKE Demo is being installed. Infineon PMatob RKE Demo has been successfully installed.

Click "Nest" to start the installation. Click. "Close" to exit.

Plzaze wait...
Flease uze Windows Update to check for any critical updates to the MET Frameworl k.
Ci | Back Next C. | Back Hexzt Cancel < Back
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B Setup of the PMAfob RKE Demo

O Step 2: Installation of the PMAfob Software
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Setup of the PMAfob RKE Demo

B Step 2: Installation of the PMAfob Software

infineon

O Double click PMAfob_DEMO_Tx_Sources_Vx.y.msi and follow
the onscreen installation instructions.
This will run the PMAfob Software Example setup.

=121l

Infineon

i'é‘- Infineon PMAfob Software Example 1.0

Welcome to the Infineon PMAfob Software
Example 1.0 Setup Wizard

=lol=

Infineon

i"w!;" Infineon PMAfob Software Example 1.0

License Agreement

=lol=

Infineon

i';“ Infineon PMafob Software Example 1.0

Select Installation Folder

The inztaller will guide pou through the steps required ta install Infinean PMAfab Software Example
1.0 on your computer.

WARMING: Thiz computer pragram iz protected by copyright law and international treaties.
Unauthorized duplication or distribution of thiz program, or any portion of it, may result in severe civil
ar criminal penalties, and will be prosecuted to the maximum extent possible under the: law.

Pleaze take a moment ta read the license agreement now. If you aceept the terms below, click "'l
Agree", then "Mext". Otherwise click "Cancel".

Impaortant Note and Terms of Use 2

Pleage read the following important note as well as the following terms and
conditions carefully. The extraction of the downloaded documents as well as
the installation of the downloaded software is only possible if you agree to

such terms and conditions. By clicking the acceptance button "l agree”

below, you agree to have read the impartant note set forth below and to be
bound by the following terms of use. If you do not agree to the terms and
conditions below, click the button "l do not agree” and the installation =

| Do Mot Agree

The installer will install Infineon PMAfob Software Example 1.0 ta the following folder.

Toinstallin this folder, click "Mest". To install to a different folder. enter it below or click "Browse"

Folder:

C:\KeiMC5T4E xamplest nfineon PMasPMAfob_S oftware_E xample’ Browse... |
Disk Cost... |

Install Infineon Pafob Software Example 1.0 for yourself, or for anyone who uses this computer;

% Everyone

 Just me

Cancel < Back

| Mext > I

Cancel < Back

Cancel < Back
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B Step 2: Installation of the PMAfob Software

O Double click PMAfob_DEMO_Tx_Sources_Vx.y.msi and follow
the onscreen installation instructions.
This will run the PMAfob Software Example setup.

i'é“ Infineon PMAfob Software Example 1.0 = Ellil i"w!;“ Infineon PMAfob Software Example 1.0 = | Ellﬂ i'é“ Infineon PMAfob Software Example 1.0 ;Iglzl

i ] p— . ] pu— i G
Confirm Installation I I:' Installing Infineon PMAfob Software I I:‘ Installation Complete I I:'
nrineon Exzmple 1.0 nrineon nrineon
The installer is ready to install Infineon PMAfob Software Example 1.0 on your computer. Infineon PMAfob Software Example 1.0 is being installed. Infineon Pk&fob Saftware Example 1.0 has been successfully installed
Click "Me=t" to start the installation. Click "Close" to exit.
Please wai t
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B Setup of the PMAfob RKE Demo

O Step 3: Configuration of the PMAfob
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Infineon

;

Setup of the PMAfob RKE Demo

B Step 3: Configuration of the PMAfob
O Delivery status
- PMAfobs are delivered with PMAfob Software programmed on it.
- AES Framing is the default selection.

O Programming Connector

O Note:

- The PMAfobs can be

reprogrammed using the
PMA Starter Kit or PMA
Evaluation Kit.

M

\

GND bR - The PMAfob needs to be
(xReset [ENENE self-powered during
programming (e.g.: battery)
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B Setup of the PMAfob RKE Demo

O Step 4: Connection of the Receiver Board
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Setup of the PMAfob RKE Demo (nfineon.

Hm Step 4: Connection of the Receiver Board

0O Connect the Receiver Board via USB
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Setup of the PMAfob RKE Demo

Hm Step 4: Connection of the Receiver Board

(infineon

O After startup the PC-Application will look like the figure below

. Infineon PMAfob RKE Demo
File  Help

. Mo Cammar d Received

0 Receiver Board N
is not configured

3

Input Signal Strength [dEm]
T T T

~loj x|

Received Frame
Encrupted Data

Decrypted Data

Fioliing Code

Feceived Roling Code Calculated Rolling Code

B attery Status

0 USB connection =\

is inactive if no
Receiver Board
is connected

OUSB In-Active |» (O Nat Canfigured
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B Setup of the PMAfob RKE Demo

O Step 5: Handling of the PC-Application
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B Step 5: Handling of the PC-Application

(infineon

O After connecting the Receiver Board(s) the PC-Application will
look like the figure below

. Infineon PMAfob RKE Demo

O All connected
Receiver Boards
are listed. One
is selectable

O Receiver Board
is not configured

File  Help

. No Comman d Received Received Frame
Encrypted Data
g E Decypted Data
Foliing Code
Feceived Roling Code Calculated Ralling Code:
Input Signal Strength [dBm]
45 T T
=T
.85 ...................................................................................................................
.?5 ...................................................................................................................
= PR 6 ) 3 ) B B8 B 06 0 8 B 616816 3 6 0 613 0 690 0138 3686 6 o 0 B 0@ 0 86063606 0E0a000a0% 600000000 a0
P Dannan. AN S, O - anaane Baacoaanoans 2 panmanacoas T S - 2 enasacsaal
v  TDA5230-FTROYHIZ | ......... ........... ............ ........... ............ ............ ........... ............
TDASZ350 - x=RIBMOT ; ; ; ; A ; ;

O UsB Active - (O Mok Configured

=101 %]

Battery Status

0 m
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Setup of the PMAfob RKE Demo (nfineon.

M Step 5: Handling of the PC-Application
O Select File -> Configure TDA5230

neon RKE Den =101
Fil Hel
| #]  Configure TDWSZ30 | Feceived Frame
ul  Reset PMAfob Encrypted Data

O Choose the TDA5230
configuration file for
AES or XTEA framing o £
according to the configuration
of your PMAfob (Default
configuration of PMAfob is
AES)

O For SmartLEWIS RX -
TDA5230 UWLink Stick | _ _
use con f| g ﬂ | es Sta rt| n g W | th e :::::::pe :TTEE:::SQ:ET_DPM_FSK_Pan_9.5kB.t_s|a j ;Ila:ir; | |
"UWLINK_...”




Setup of the PMAfob RKE Demo

(infineon

B Step 5: Handling of the PC-Application

O After successful configuration of the Receiver Board the PC-
Application looks like the figure below

O Configuration LED is
green and Config File
is shown.

O Note:
If the Receiver Board
is unplugged and
reconnected again it
will be automatically
configured with the
selected Config File

File  Help

».. Infineon PMAfob RKE Demo

@ Mo Comman d Recsived Received Frame
Encrypted D ata
M
g E Decrpted Data
Fioling Code
Received Rolling Code Calculated Ralling Cade
= =
Inpuit Sigral Strength [dBm]
45 T T
EEE .. e L D e B RS e
o ............ ........... ........... ............ ........... ............ ............ ........... ............
FEE ............ ........... ........... ............ ........... ............ ............ ........... ............
BEEN e S L RPN . . c .. R OO SR L]
AR F R ........... ........... ........... ., ........... ........... ., ........... ............
asiE N oo b S S T T L T S
s : : : : : : : : :

(D USE Active -

t t
1D Canfig File: C:iProgram FilesiInf

ineon TechnaologiesiPMAfob RKE Demo\XTEA_Config434_OPM_FSK_Pat1_9.6kEit_slave IFEE+-Z50.txt

] 3

Battery Status
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B Step 5: Handling of the PC-Application

O After successful configuration of the Receiver Board pressing
any button on the PMAfob will show the received data

O Depending on the encryption you use (must be equal for
PMAfob and PC-Application) the appropriate RF-Framing is

displayed XTEA-Framing AES-Framing

. Infineon PMafob RKE Demo =lOl = . Infineon PMafob RKE Deno =10l x|
File  Help File  Help
@ Open Trunk Received Frame Q) Close Doors Receive d Frame
KTEA Enciypted Data AES Enciypted Data
||1 2096ebd9aa99bc 3352844 IbBZSZSBUIET ca83dbebBE080CA54tef0
E E ATEA Decrypted .Dala ~ E E ‘ AES Decrppted D.ala
— Command ~ Roling Code  Keynumber — Battery CRC — Command  Rolling Code  Keynumber  Battery Button Presses
04 IUUUDUUU5 12000101 [5c |44 03 ele33853 12090101 |Sbbh2 0000002
Ralling Code: Roling Code
Received Roling Cade Calculated Roling Code Received Roling Code Calculated Roling Code

Il
\

E =7 E_ |UDUDDUDE '\ —7 : @ e0e33853
Rolling Code Rolling Code
matched matched

Battery Status Battery Status

Input Signal Strength [dBm] Input Signal Strength [dBm]
T T T T T

45

-45

X ~ : 5 : : : : : : e

115 : . : . : : : . : 2844 115 t ; ; ; + t t t t 234 v
O USE Active - b Config File: C:\Program FilesiInfineon Technologies\PrMAfob RKE DemolXTEA_Config434_OPM_FSK_Pat1_9.6kBit_slave_IFBB+-250.kxt it QUSE Active b Config File: C:YProgram FilestInfineon TechnologiesiPMAFob RKE DemolAES_Configd34_OPM_FSK_Pat1_9.6kBit_slave IFBE+-250.txt
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Setup of the PMAfob RKE Demo

B Step 5: Handling of the PC-Application
O Select File -> Reset PMAfob

il - . Infineon PMAfob RKE Demo -0l x|
File | Help
gl Configure TDASZ30 Feceived Frame
| | wl  Reset PMAfob | HTEA Encrypted D ata
Evit 12036ebd32a39bc 3352844
- r - ®TEA Decrypted Data

Cormrnar d FRoling Code  Keynumber  Battery CRC

Let 00000005 1209010 [Se 44

O Reset the Rolling Code

counter (Reset Button) for

|
- a” PMAfObS by CheCkIng @ Pleaze enter the PMafob Mumber
__Cocel |

“"Reset All PMAfobs” or e
- a special PMAfob, ™ Fieset All PMAfchs

by entering the [1200101

Keynumber
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Setup of the PMAfob RKE Demo (nfineon

B Step 5: Handling of the PC-Application
O Select Help -> About

» .. Infineon PMAfob RKE Demo =10l x|

. oy About Received Frame
HTEA Encrypted Data
1 203EebdYaa99bc3352544

mmmmm d FRolingCode FKepnumber  Battery CRC

‘ |04 00000005 12090101 [5e |44

O This dialog shows the U ——
currently used version Infineon

Infineon PRaAfob REE Demo 2009
Werzion 2.0

= |nfineon Technologies AG 2005-2009
All rightz reserved

k. I Systeminfo

O Press Systeminfo to get
information about your
PC system
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