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Overview - PMAfob Software (nfineon

B Features

O Five buttons (Handling of five external wake-ups)

O Button stuck detection

O Debounce buttons

O Secure communication
- Advanced Encryption Standard (AES) or
- eXtended Tiny Encryption Algorithm (XTEA) encryption
- Rolling code generation

O Battery voltage measurement

O Energy saving by using Power Down Mode

O Configurable software by long button presses

m Note: An Application Note describing the PMAfob Software can
be found here:
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PMAfob Software _
Reset Setting (Infineon

B After reset (change of battery) the following configuration is
used:

O Baudrate: 9600 bps
O RF Framing: AES
O Encryption: ON

O Unique Key Number: User defined unique id

Page 7



PMAfob Software

Configuration by long button presses

PMAfob Button Software Configuration

m If buttons are
pressed longer
then ~ 3 s, the
software
configuration is
changed as shown
in the table.

H Note: If the
Framing is
changed the
Receiver has to be
reconfigured!

The PC Application
only accepts
encrypted frames!

Choose AES Framing.

Choose 4 bytes of PMA
unique id.

Choose XTEA Framing.

Choose user defined unique
id.

Switch encryption on / off:
ON => baudrate: 9600 bps
OFF=> baudrate: 4800 bps

(iﬁneon
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Overview - PMAfob Hardware (nfineon.

B Settings
O 5 buttons enclosure
0 434MHz band

0 9.6kbaud Manchester code
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O FSK modulation
Keyfob enclosure Top view Bottom view

0 5dBm output power

O Frequency deviation of approx. 50kHz

O Duty cycle setting of 34%
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B Qverview

0 Receiver Software
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. . infineon
Overview — Receiver Software (lnfineon

B Features

O Configure TDA5230

O Read out data from TDA5230

0O Decrypt AES or XTEA encrypted RF-Frame

O Calculate rolling code for every PMAfob

O Illustrate the received command

O Illustrate signal strength (measured by TDA5230)
m NOTE:

O The UWLink is flashed by Infineon with the appropriate
firmware.

O The firmware installer
“"PMAfob_DEMO_UWLink_Firmware_Vx.y.msi” is included in
“"PMAfob_ HOME_DEMO_SW_Vx.y.zip"” available at
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. . infineon
Overview — Receiver Hardware (lnfineon

M Features

O SmartLEWIS RX — TDA5230 UWLink Stick used as Receiver
Board

0O USB communication done with FTDI chip
0 Matching Network for 434MHz

B Note

O More information about the UWLink can be found on

O More information about TDA523x can be found on
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B Setup of the PMAfob Home Automation Demo
[0 Step 1: Installation of the PC-Application
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Setup of the PMAfob Home Automation Demo

B Step 1: Installation of the PC-Application

O Double click PMAfob_ HOME _DEMO_Rx_Vx.y.msi and follow the
onscreen installation instructions.
This will run the PMAfob Home Automation Demo setup.

infineon

,
15! Infineon PMAfob Home Automation Demo 1.0 m;‘@lﬂﬂ 1) Infineon PMafob Home Automation Demo 1.0, m-lgl_lg 15! Infineon PMAfob Home Automation mmmm-Eug

-
Welcome to the Infineon PMAfob Home (' -
Automation Demo 1.0 Setup I n I:l I'IEOI'I .

The installer will guide you through the steps required to install Infineon PMAfob Home Automation
Demo 1.0 on your computer.

WARNIMG: This computer program is protected by copyright law and international treaties.
Unauthorized duplication or distribution of this program, or any portion of it, may result in severe
civil or criminal penalties, and will be prosecuted to the maximum extent possible under the law.

License Agreement ‘ Tn I:i neon :

Flease take a moment to read the license agreement now. If you accept the terms below, dick "I
Accept”, then Mext”, Otherwise dick "Cancel”.

Important Note and Terms of Use -

Please read the following important note as well as the following terms and
conditions carefully. The extraction of the downloaded documents as well as
the installation of the downloaded software is only possible if you agree to
such terms and conditions. By clicking the acceptance button *| agree™
below, you agree to have read the important note set forth below and to be
bound by the following terms of use. If you do not agree to the terms and
conditions below, click the button °| do not agree” and the installation

nrnradura will nat ha etartad

[#]1 accept the terms in the License Agreement

Print ] [ Cancel ] [ < Back ][ Next = ]

O
.
Select Installation Folder ‘ In fl neon
The installer will install Infineon PMAfob Home Automation Demo 1.0 to the following folder.
To install in this folder, didk ™ext”. To install to a different folder, enter it below or dick "Browse™.

Folder:
|C:‘Prugrarn Files\Infineon Technologies PMAfob Home Automation Demo',

Browse...
Disk Cost...

Cancel ] [ < Back ][ Next = ]
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Setup of the PMAfob Home Automation Demo

B Step 1: Installation of the PC-Application

O Double click PMAfob_ HOME _DEMO_Rx_Vx.y.msi and follow the
onscreen installation instructions.
This will run the PMAfob Home Automation Demo setup.

M
ﬁ Infineon PMAfob Home Automation Demao 1.0 &m‘glﬂg

(infineon

f
ﬁ Infineon PMAfob Home Automation Demo 1.0 &m‘_@lﬂ‘g

o
.

Confirm Installation ‘ |n|:| neon

Click "Install” to begin the installation. Click "Back™ to review or change any of your installation

settings. Click "Cancel” to exit the wizard.

Cancel ] [ < Back ][ @'Install]

- My
ﬁ Infineon PMAfob Home Automation Dema 1.0 W‘E‘E‘g

Installing Infineon PMAfob Home
Automation Demo 1.0

Please wait while the Setup installs Infineon PMAfob Home Automation Demo 1.0,

Status:

Installation Complete

Click "Close” to exit.

Infineon PMAfob Home Automation Demo 1.0 Setup Wizard has successfully finished.

(infineon
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B Setup of the PMAfob Home Automation Demo

O Step 2: Installation of the PMAfob Software
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Setup of the PMAfob Home Automation Demo

B Step 2: Installation of the PMAfob Software

O Double click PMAfob_DEMO_Tx_Sources_Vx.y.msi and follow
the onscreen installation instructions.
This will run the PMAfob Software Example setup.

15/ Infineon PMAfob Software Example 1._@@ 15! Infineon PMAfob Software Example 1.0-E|ﬂﬂ ﬁ! Infineon PMAfob Software ample_l__lgj’glg

Welcome to the Infineon PMAfob Software "—f-: License Agreement .T Select Installation Folder .T
Example 1.0 Setup Wizard Infineon Infineon Infineon

The installer will guide you through the steps required to install Infineon FtdAfab Flease take a moment to read the license agreement now. lfvou accept the terms The installer will install Infineon PhAfol Software Example 1.0 ta the fallowing
Software Example 1.0 on your computer. below, click "l Agree", then "Next". Otherwise click "Cancel". folder.

Toinstall in this folder, click "MNext”. Toinstall to a different folder, enter it below ..
Important Note and Terms of Use i Eolder

L -
Please read the following important note as well as the following terms and |C\Kew|\uV|sw0n4\CE1\Examples\\nfmeon PIALPMATDE [M

conditions carefully. The extraction of the downloaded documents as well as Disk Caost..

the installation of the downloaded software is only possible if you agree to
such terms and conditions. By clicking the acceptance button *| agree™

WARMNING: This computer program is protected by copyright law and below, you agree to have read the important note set forth below and to be
intarnational treaties. Unautharized duplication ar distribution of this program, or bound by the following terms of use. If you do not agree to the terms and
any portion of it may resultin severe civil or criminal penalties, and will be conditions below. click the button *| do not agree” and the installation i
prosecuted to the maximum extent possible under the law. ) ' D

1 Do Not Agree @ | Agree

< Back Cancel ][ < Back ][ INext » Cancel ][ < Back H INext >
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Setup of the PMAfob Home Automation Demo (lnfineon.

B Step 2: Installation of the PMAfob Software

O Double click PMAfob_DEMO_Tx_Sources_Vx.y.msi and follow
the onscreen installation instructions.
This will run the PMAfob Software Example setup.

. -
) Infineon PMAfob Software Example S s §5) Infineon PMAfob Software Example o=l [ nfineon PMAfob Software Example 1.0 (ol
-, L N L

’ Confirm Installation (inﬁneon ’ :gl)(s;:::]i:leg:-r;]ﬁneun PMAfob Software (inﬁneon Installation Complete (inl.'ineon

The installer is ready to install Infineon PhAfob Software Example 1.0 on yvour Infineon PhdAfok Software Example 1.0 being installed Infinean PhAfok Sotftware Example 1.0 has been successfully installed.
computer.

. Click "Cloze" to exit.
Click "Next" to start the installation. Pleasa wait..

Cancel ][ < Back ][ e >
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B Setup of the PMAfob Home Automation Demo

O Step 3: Configuration of the PMAfob

Page 21



Setup of the PMAfob Home Automation Demo (infineon

B Step 3: Configuration of the PMAfob
O Delivery status
- PMAfobs are delivered with PMAfob Software programmed on it.
- AES Framing is the default selection.

O Programming Connector

O Note:

- The PMAfobs can be

reprogrammed using the
PMA Starter Kit or PMA
Evaluation Kit.

i

’ (GND b ’® - The PMAfob needs to be
self-powered during
programming (e.g.: battery)
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B Setup of the PMAfob Home Automation Demo

O Step 4: Connection of the Receiver Board
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Setup of the PMAfob Home Automation Demo (lnfineon.

Hm Step 4: Connection of the Receiver Board

0O Connect the Receiver Board via USB
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Hm Step 4: Connection of the Receiver Board

O After startup the PC-Application will look like the flgure below

u Infineon PMAfob Home Automation Demo
File Help

. . No Command Received
Infineon

eceiv

O Receiver Board
is not configured

0 USB connection
is inactive if no
Receiver Board
is connected
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B Setup of the PMAfob Home Automation Demo

O Step 5: Handling of the PC-Application
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Setup of the PMAfob Home Automation Demo

M Step 5: Handling of the PC-Application

(infineon

O After connecting the Receiver Board(s) the PC-Application will

look like the figure be_\Iﬁow

O All connected
Receiver Boards
are listed. One
is selectable

-45
55 ¥
-85 +

85 ¥

lome Automation Demoa
ile €l
S @ o Command Received
(Inflneon Encrypted Data

Received RF Frame

. Decrypted Data

Roliing Code
Received Rolling Code Calculated Rolling Code

v TDAS5230 - FTPOYH12

TDAS5230 - FTP1ALFQ

Battery Status

O Receiver Board
is not configured

€ v|(O Not Configured
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M Step 5: Handling of the PC-Application
O Select File -> Conﬁgure TDA5230

'8 Infineon PMAfob Home Automa

File | Help
| 2]  Configure TDA5230 Lnand Received Received RF Frame
Gl Reset PMAfob Encrypted Data

) Refresh Device List

. Decrypted Data

O Choose the TDA5230
configuration file for
AES or XTEA framing
according to the configuration j ™ ===
of your PMAfob (Default i ot o e 5

. . . I . .
CO n fl g u ra t | O n Of P M Afo b | S || XTEA_Config34_OPM_FSK_Patl_9.6kBit_slave IFEB-+-250.56¢
AES)

O For SmartLEWIS RX -
TDA5230 UWLink Stick
use config files starting with e PR conteBRonE ’[Tf:j“ﬁ] o ]'
“UWLINK ...” ~ —

Organize « Mew folder 2 O '@'
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M Step 5: Handling of the PC-Application

O After successful configuration of the Receiver Board the PC-
Application looks like the figure below

88 Infineon PMAfob Home. Automation

O Configuration LED is L e
. . Infineon Encrypted Data

green and Config File Ll |
is shown. - a

} Ifothee Receiver Board . /f%//// J

is unplugged and o
reconnected again it = N TR NSO TR BSOSV B P “

will be automatically B
COI’]fIgUI‘Ed W|th the 195 .......... ............. ............. ............. .............. .............. ............. ............
S e I e Cte d C O n fi g Fi I e Q USB Active ~+ O Coiufig File: C:\Pro;ram Files\]nfinescm Technologi:s\PMAfob Honie Automatio...\;TEA_Conﬁ94341_0PM_FSK_Patil_Q.ﬁkBit_slave_IiFBB+-250.txt
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M Step 5: Handling of the PC-Application

O After successful configuration of the Receiver Board pressing
any button on the PMAfob will show the received data

O Depending on the encryption you use (must be equal for
PMAfob and PC-Application) the appropriate RF-Framing is

displayed XTEA-Framing AES-Framing

(= —— - oM Al atic 9
88 Infincon PMAfob Home Automation Demo TRV v, o
File Help H File Help
o~ . . Switch On Floor Lamp Received RF Frame | . . Switch On Ceiling Light Recaive d RF Frame
(Inflneon XTEA Encypted Data (Inflneon AES Encrypted Data '
| [120906b 72298978283 1faa 81d2b0dc4343603b3e81091a295¢c Tbed
|
. XTEA Decrypted Data AES Decrypted Data
Command Roling Code Keynumber Battery CRC Command Rolling Code Keynumber Battery  Button Presses
08 00000004 12030101 66 02 dbS8dc11 00000001  5e22 00000070

Rolling Code
Received Rolling Code Calculated Rolling Code

db98dc1 [db98dc1l |
Rolling Code
matched

b o I Rolling Code g

|
< 7 . // Received Rolling Code Calculated Rolling Code
_ Rolling Code

matched
Battery Status Battery Status

-45 -45

55 & -56 ¥

65+ 5+

5E 51

-85 + -85 +

95 & -95

105+ 105

115 i ; ; ; i i H ; H 264 mV 15 ; ; ; ; ; ; ; ; ; 3012mV

O USB Active ~ | Config File: C:\Program Files\Infineon Technologies\PMAfob Home Automatio..\XTEA_Configd34_OPM_FSK_Patl_9.6kBit_slave IFBB+-250 : © USB Active ~ @ Config File: C:\Program Files\Infineon Technologies\PMAfob Home ion Demo\AES_Configd34_OPM_FSK_Patl_9.6kBit slave IFBB+-250.6¢ .:
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M Step 5: Handling of the PC-Application
O Select File -> Reset PMAfob

y Infineon PMAfob Home stomation

File | Help ‘
| ] Configure TDA5230 On Floor Lamp Received RF Frame |
| [& Reset PMAfob XTEA Encrypted Data

) Refresh Device List 1209b6b72a98578a83 faa l

e

Exit

. XTEA Decrypted Data

Command Rolling Code Keynumber Battery CRC
= 08 00000004 12090101 66 aa
] A S N

O Reset the Rolling Code

counter (Reset Button) for Tretrveoe NN =
| a” PMAfObS by ChECklng ® Flease enterthe FMAfob Mumber Reset !

“Reset All PMAfobs” or \* |
—~ a special PMAfob, [0 Reset a1 PHtsdobs

by entering the 12090101

Keynumber
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Setup of the PMAfob Home Automation

M Step 5: Handling of the PC-Application
O Select Help -> About

\Fyﬂ Infineon PMAfob Home Automation Dem
"\Eﬂi Help
": witch On Floor Lamp Received RF Frame

N L XTEA Encrypted Data

12096 6b 7229857883 Ifaal
= XTEA Decrypted Data
Command Roling Code Keynumber Battery CRC
5 08 00000004 12090101 66
1 I il

R —
About Infineon PMAfob Home Automation Demo (S
e —

O This dialog shows the —.
currently used version (Infineon

Irfineon PMAfob Home Automation Demo 2005
Wersion 1.0

2 |rfinean Technologies AG 2005-20059
All ights reserved
| oKk | | Systeminfo

O Press Systeminfo to get
information about your

PC system
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