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iMOTION™ Solution Designer (iSD)

.. supports in-app updates for SD packs (FW / GUI definition, board database…) and 

configuration files

.. is an integrated GUI-based tool for iMOTION™ motor control solutions entire 

development process to replace MCEWizard and MCEDesigner

.. includes configuration, customization, programming, and tuning for users during 

the development phase

.. simplifies the use and design of inverterized drives through catalog files 

iMOTION™ Solution Designer 

.. contains an oscilloscope tool to debug/tune motors and is not an IDE like Keil, IAR, or a multi-platform 

development tool with GitHub-hosted firmware libraries like Modus Toolbox
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‒ Infineon Developer Center Launcher (to manage Infineon tools)

‒ https://www.infineon.com/cms/en/tools/landing/infineontoolbox.html

‒ Please register here at myInfineon for exclusive information and tips for projects

‒ iMOTIONTM Solution Designer installation executable.

‒ https://softwaretools.infineon.com/tools/com.ifx.tb.tool.imotionsolutiondesigner

‒ Follow installation directions and unzip software package
‒ It is recommended users shall enable local administrator rights to ensure smooth installation process.

‒ Installation tool will automatically install the driver for J-link and Microsoft Visual C++ during the installation process.

Installing iMOTION™ Solution Designer

https://www.infineon.com/cms/en/tools/landing/infineontoolbox.html
https://www.infineon.com/cms/en/myInfineon/registration/
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Installing SD pack

‒ Open the iMOTIONTM Solution Designer, then press the Package Manager.

‒ Check and update the necessary SD pack(s).

① Select the latest package from Available Package

② Press Install button to install the package

①

↑

②
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iMOTION™ Solution Designer Workflow

1. Define your setup 
by 

Application/Board/...

2. Configure the 
System

3. Develop a Script 
(optional) 

4. Load the Firmware 
to the Target

5. Tune the Control 
Loop

Poles, 

R, L,…
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Create new Project

‒ Create a new project based on the installed SD pack 

and enter the following information

① Select Create Project under New Project

② Select SDpack to be used in the project

③ Input File name / Location / Project name

‒ File name: File name of the new project

‒ Location: Folder where the project to be created

‒ Project name: Project name

④ Press Create button

‒ (Optional) Check Create self contained project, 

allowing easier distribution of the project files to other 

iSD users.

‒ Self contained project includes system files, so 

project size becomes larger than the ordinary 

project.  

① ②

③

④
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Initial project configuration

Overview

1. Board catalog files

‒ MADK boards

‒ Reference design boards

‒ Customer’s boards

2. Function selection

‒ Communication interface

‒ Parameter selection method

‒ GPIO / analog input requirement

‒ Sensorless /  analog Hall / digital Hall

‒ Current sense type

‒ PFC frontend

‒ Scripting

3. Device selection

‒ iMOTION™ Controller 

‒ iMOTION™ Driver

‒ iMOTION™ IPM

3 ways to start a new project
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Initial project configuration 

Board Catalog Files

Select board icon to create the project based on board catalog files

Select board file and press Apply, 

then press Close

If you would like to see the detail of board 

parameters, check Show board parameters

If OK, press next to create the new project.

If you would like to change board file, press back.
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Initial project configuration 

Function selection

① Select the required functions from Available functions.

② Select proper device from the list in Available devices.

Devices that do not support required functions are grayed 

out and cannot be selected.

①

②
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Initial project configuration 

Device selection

Select proper device from the list in Available devices.
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iMOTION™ Solution Designer 

Parameter Configuration Wizard

Different parameter sets 

based on the same set 

of global configurations

Menu BarTitle Bar Parameter Configuration:

White background box -> can be changed

Green background box -> just updated

Gray background box -> read only

Detailed Help Doc is 

available by clicking the 

green question mark

Shortcut Key

Mode Switch
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Normal Mode

Shows the most commonly used and 

required parameters only

Expert Mode

Opens up the full parameter tree for more 

detailed settings

Parameter Configuration Wizard 

Normal vs. Expert Mode

Mode Switch
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Parameter Configuration Wizard in Explorer View 

Motor Control

1. IC Configuration
‒ General IC configuration

‒ ADC, UART, Class B, Clock compensation, 

Control input method

2. GPIO & analog input resource configuration for scripting
‒ Scripting related settings

3. System hardware configuration
‒ System (inverter/board related settings)

‒ Input supply, DC bus sensing, Inverter and feedback, Motor, Load

4. Motor control configuration
‒ Motor specifics

‒ Motor control configuration, Control regulators, FOC and inverter, 

Application (start-up method…), Angle feedback

5. PFC Control Configuration (only shown for limited devices)

‒ PFC control parameters

‒ PFC control configuration

6. Protection
‒ Motor and system protection

‒ UART Link Break, CPU Execution Fault, Parameter load fault

6 top level parameter groups

‒ Hierarchical configuration tree with 

logical parameter grouping

‒ Integrated parameter help
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Parameter Set Configuration

1. IC Configuration

Specify IC 

configuration

- Communication

- Functional 

options

- Gatekill source

- Class-B safety

- Standby mode
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Parameter Set Configuration 

2. User Pin Configuration

Specify user pin 

configuration used 

in scripting
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Parameter Set Configuration 

3. System Hardware Configuration

Go through all

categories of the 

System Hardware 

Configuration step 

by step
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Parameter Set Configuration 

4. Motor Control configuration

Go through all

categories of the 

Motor Control 

Configuration step 

by step



23Infineon ProprietaryCopyright © Infineon Technologies AG 2024. All rights reserved.10 Jan 2024

Parameter Set Configuration 

5. PFC Control Configuration

Go through all

categories of the 

PFC Control 

Configuration step 

by step

※This section is shown for specific devices only which have PFC function
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Parameter Set Configuration 

6. Protection

Go through all

categories of the 

Protection 

Configuration step 

by step

※PFC protection is shown for specific devices only which have PFC function
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Parameter Verification

‒ Verification results are shown in the 

following color code:

‒ Success

‒ Warning

‒ Error (must be corrected before 

proceeding and turns dark orange when 

selected)

‒ Guidelines are shown for why the error or 

warning occurred

‒ Visually directs you to the parameter in 

question

Parameter Verification
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Parameter Set Manager

‒ Select Project in the menu bar and then select Parameter Set 

Manager, then Parameter Set Manager will open.

‒ User can configure parameter sets, and import or export parameter set 

data from/to external file.
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Configure Parameter Set

1. Add new parameter set

① Press New

② Enter parameter set name in Enter new parameter set name

③ Press Apply

2. Rename parameter set

① Press Rename

② Select parameter set that you would like to rename in 

Current Parameter Set name

③ Enter new parameter set name in Enter new Parameter Set name

④ Press Apply

3. Delete parameter set

① Press Delete

② Select parameter set that you would like to delete in 

Select Parameter Set to be deleted

③ Press Apply

Note: It is highly recommended to build the project after parameter set is configured

①

②

③

①

②
③

④

①

②

③
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Import Parameter Data from External File

① Select parameter set in the list box

② Press Import

③ Select *.sddata file from explorer window

④Window with Calculation in progress appears.

⑤When import process is finished, Successful Import

windows appears. Press OK to close the window.

①

②

③

④

⑤
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Export Parameter Data to External File

① Select parameter set in the list box

② Press Export

③ Select folder to save parameter data in explorer 

window

①

②

③
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Parameter Set Selection in Configuration Wizard

User can select parameter set to be edited in 

Configuration Wizard by selecting parameter set 

in the list box.
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Script Editor 

Graphical User Interface

‒ Script editor

‒ Runtime syntax checking

‒ Project management

‒ Keyword highlighting and auto completion

‒ Online help system

‒ Script translator

‒ Integrated script code compilation

‒ Optimized byte code generation to reduce 

code size and execution time

‒ Enhanced  data memory usage, supports  8, 

16 and 32 bit integer variable type

‒ 256 Byte memory allocated for global 

variables and 128byte data memory for local 

variables 

‒ Script debugger

‒ Support for break points, variable watch 

window, and execution control

Script Editor and Debugger

Editor Area
Project Explorer

Property Window
Menu Bar

Tool Bar

Tool Version

Switch view between
‒ Output Window (Build Summary)

‒ Search Result

‒ Error Window (Compiler and Syntax error)

‒ Variable Watch Window (in Debug Mode only)
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‒ After opening the Script Editor, a new Script Project must be created.

‒ The Script development process 

consists of defining the Global 

parameters, Task0, and Task1.

‒ User needs to assure that the script is selected in the Project Build settings.

Script Editor 

Step by step
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‒ After opening or creating a project, select Dashboard via menu or toolbar.

‒ The Build, Connect, and Program steps will be done as required (through popups).

‒ Steps (Build, Connect, Programer) can be done individually and are explained on the next slides.

Build, Connect and Program

Dashboard

or
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Build the Program

Choose your 

script (optional)

Choose desired parameter 

set to be loaded at device 

startup (optional)

Select Project → Build Project

If necessary, select the parameter set to be 

loaded at startup, and a script. (optional)

Then press Build

After build process done, log is shown in log window.

In order to open log window, select Project → Show 

Log View.
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Connect with Target

‒ It is necessary to connect to the target device for program or debug.

Select Target → Connect

‒ Select COM port that target device is connected

‒ If the desired COM port cannot be found in the list, press Rescan COM ports to 

refresh the port list, and then select the desired COM port.

‒ Press Connect
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Connect and Program

‒ By using Programmer tool, user can program built project to the target device.

OR

Press Programmer icon 

Select Tools → Programmer

Press Connect button to connect 

the target device, as shown in the 

previous page 

If connection is successful, device 

information is shown in the window.

Then press Program.

If programming is successfully 

done, press Close to close 

Programmer window.



39Infineon ProprietaryCopyright © Infineon Technologies AG 2024. All rights reserved.10 Jan 2024

In case of problems connecting to the secure loader (SBSL) 

the following connection sequence can be used.

‒ Plug-in device, open 'Programmer' window, 

‒ Press 'Connect’ to open the connection window

‒ Select the COM port and press 'Connect’ 
(this will fail, but it will set the correct COM port)

‒ Close 'Programmer', unplug and re-plug the device

‒ Open 'Programmer', press 'Connect'

‒ In the connection window press 'Close’ 

(there is no need to select the COM port here)

‒ Success

Connecting to Secure loader
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Run Motors with Dashboard

‒ This tool gives users an interactive

environment for motor tuning work

‒ Parameter tree is updated in real time

‒ Pre-configured motor tuning use cases
‒ Current sensing

‒ Current loop tuning

‒ Speed loop tuning

‒ And more

‒ Motor / PFC operation control and indicators
‒ Start / stop motor control

‒ Target speed configuration

‒ Rotation direction configuration

‒ Motor speed estimation

‒ CPU load

‒ Fault status

Dashboard
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Dashboard Overview (w/o PFC)

Parameter 

tree

Parameter 

Control

Loaded 

parameter set

Pre-configured

tuning cases

Parameter for the 

selected tuning 

case

Parameter update

Open oscilloscope

Motor start/

stop control

CPU load 

indicator

Motor speed & 

direction control

Realtime system / 

motor fault 

condition
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Dashboard Overview (w/ PFC)

Parameter 

tree

Parameters 

control

Pre-configured 

tuning cases

(Motor & PFC)

Loaded 

parameter set

Motor & PFC control 

& status indicator

CPU load 

indicator

Motor speed & 

direction control

Parameter for the 

selected tuning 

case

Parameter update

Open oscilloscope

Realtime system / 

motor / PFC fault 

condition
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Register Read/Write

‒ If Refresh check box is checked, the register value is updated 

automatically. 

‒ It is recommended to execute Get parameter (see next 

page) the 1st time when the Dashboard is opened after 

programming.

‒ User can configure register values. 

‒ By double clicking Value, user can edit register value in 

the text box.

‒ Read only or STATIC registers cannot be edited. 

The text box does not open after double clicking.
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Parameters Control

Button Function

Get parameter

Download all parameters from the target device

It is recommended to execute this the 1st time the 

Dashboard is opened after programming.

Save parameter
Save parameter data to local PC in csv format

Clear refresh
Uncheck all check box in Refresh

Find parameter
Search register

Expand
Expand all register list in Dashboard
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Parameter Tuning for Use Cases

‒ iSD provides some parameter tuning use 

cases for easy parameter tuning.

‒ User can change or undo parameters. 

Button Function

Sync from Config 

Wizard

Import parameter values from Config 

Wizard.

Update Target
Upload input parameters to target 

device in the RAM.

Update Config 

Wizard

Update parameter values in Config 

Wizard to the input values

Open Oscilloscope

Open oscilloscope

Oscilloscope configuration meets 

tuning use cases.
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‒ The target speed can be configured by either entering 

desired speed value in RPM or by sliding the bar to the 

left or right.

‒ The rotation of the motor can be changed and will be 

shown with a positive (clockwise) or negative (counter 

clockwise) speed value.

Change Speed and Direction of the Motor Rotation

Counter clockwise 

rotation
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‒ Up to 8 Channels of Real-Time 

Tracing

‒ Sampling has three options

‒ Synchronized with motor PWM

‒ Synchronized with PFC PWM

‒ Advanced trigger methods available 

(Edge, Slope, Comparison)

‒ Autoscaling

‒ Cursor function

Debugging and Tuning Motors with Oscilloscope

Oscilloscope

Channel trace 

settings

Run/Stop and 

trigger settings

Cursor settings

Horizontal time 

settings
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Channel Configuration

# Function Description

① Add signal
Add channel to Oscilloscope. Maximum 

8 channels can be displayed.

② Autoscale all signals Auto scale for all channels

③ Clear and reset chart Clear oscilloscope display

④ Settings Open channel configuration window

⑤ Autoscale Auto scale for selected channel

⑥ Remove channel Remove the channel from Oscilloscope

⑦ Show/hide channel
Show or hide selected channel on 

Oscilloscope display

⑧ Gain and Offset
Change gain and offset of the selected 

channel on Oscilloscope display

① ② ③

⑥

⑤

④

⑦
⑧
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Channel Setting

1. Press Settings icon  

2. Select signal by pressing Signal

Select signal from parameter 

tree

Color of the channel is also 

configured here.
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Event Trigger

Event Trigger Configuration window opens when pressing Settings: T; button.

# Function Description

① Trigger Position
Set trigger position by slider 

bar

② Trigger Event Settings

Select signals used for 

triggering function, trigger 

level and timeout

③ Trigger Type Select trigger type

①

②

③
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Configuration of Horizontal Axis

Horizontal range can be configured via slider.

‒ Whole horizontal range is shown in the upper display.

‒ It is possible to use zoom and change zoom range by two dials.
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Oscilloscope Control

# Function Description

① Run/Stop Run/Stop Oscilloscope function

② Single Acquire single capture

③ Set the trigger mode
Select Auto if trigger function is not necessary

Select Normal to use trigger function

① ②

③
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Using catalog files (1/3)

‒ Catalog files contain the default parameters for the evaluation/reference design boards. 

Users can use the default parameters to run the motor after selecting 

Boards, Motors, and Loads.

‒ Click Boards to load the default parameters from the boards catalog (iMOTION2Go).
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Using catalog files (2/3)

‒ Click Motors to load the default parameters from the motors catalog (USB motor).
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Using catalog files (3/3) 

‒ Click Loads to load the default parameters from the loads catalog 

(iMOTION2Go Load).
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Upgrade FW to Release #5.x

‒ By using the Programmer tool, user can upgrade firmware from FW version 1.3.7.

OR

Press Programmer icon 

Select Tools → Programmer

Press Connect button to connect 

the target device, as shown in the 

previous page 

If connection is successful, device 

information is shown in the window.

Then press Program.

If programming is successfully 

done, press Close to close 

Programmer window.
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Step 1:

Change the BootMode from “Application” to “Configure” in the Solution Designer when connected with board. 

Users will then find Target Connected indicator changes from green to red.

Downgrade to FW1.3.7
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Step 2:

Ignore the warning information after opening the MCEDesigner.

Use the MCE Designer to download the firmware (FW1.3.7) and the respective parameter file. 

The firmware will be successfully downgraded to FW1.3.7.

Downgrade to FW1.3.7



62


