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Kit Overview (1/2)

> XMC1400 Boot Kit

— Consists of an XMC1400 CPU Card

— Supported Application Cards examples: Colour LED Card,
White LED Card

(Application Card is orderable separately or as part of another Application Kit)

Colour LED Card

XMC1400 CPU Card White LED Card



Kit Overview (2/2)

On-board COM
and Segger
J-Link debugger

Micro USB

XMC1400 CPU Card
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XMC1400 Edge connector for
Application cards
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Hardware Overview (1/2)

> Connect XMC1400 CPU Card to PC via USB cable
> CPU Card is powered up (as indicated by LED on the card)

CPU Card powered
via USB cable

|

> Note: Supported Application Card may be additionally connected to

the CPU card
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Hardware Overview (2/2)

> Kit information

mm Kit Description | Order Number

KIT_XMC14_BOOT_001 Boot Kit XMC1400 KIT_XMC14_BOOT_001

> Infineon parts utilized on Kit Nr. 1:

Infineon Parts Order Number

XMC1400 Microcontroller XMC1404-Q064X0200

XMC4200 Microcontroller XMC4200-Q48F256
3V3 regulator IFX25001MEV33
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Tooling Overview -
Boot Modes

> Boot Modes available

— CAN Bootstrap-Loader Mode

— UART Bootstrap-Loader Mode

— User Mode (Halt After Reset)

— User Mode (Debug) Default Mode of device on Boot Kit
— User Mode (Productive)

> Boot Modes can be configured via:

— DAVE™
-~ Download DAVE™

DAVE™ v4.1.4 download
- MemTool

— Download MemTool
MemTool v4.65.exe download

> For more information on how to configure the BMI value, please refer to the

XMC1000 Tooling Guide.
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http://infineon-community.com/LP=400
http://www.infineon.com/cms/en/product/promopages/aim-mc/DAVE_3_Download.html
http://www.infineon.com/cms/services/dgdl?fileId=5546d4624a56eed8014a57c3ced01a80

Tooling Overview -
DAVE™ (1/5)

> DAVE™ download package is available at:
http://infineon-community.com/LP=400
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http://infineon-community.com/LP=400

Tooling Overview -
DAVE™ (2/5)

> After registration, download and unzip the installer package

> Run DAVE-4.1.4-Setup.exe to install
DAVE™ IDE and SEGGER J-Link drivers

> Open DAVE™

> Update DAVE™ and DAVE™ libraries

- Help > Check for Updates
— Help > Check for DAVE APP Updates




Tooling Overview -
DAVE™ (3/5)

> Install DAVE™ APPs libraries and Device Description
- Help - Install DAVE APP/Example/Device Library

> Note: You may skip the above step if you are not using DAVE™
APPs



Tooling Overview -
DAVE™ (4/5)

> Select DAVE Apps Library Manager in the drop-down menu

> Select DEVICE_PACK, Library_DAVEDeviceDescriptions
(XMC1400 Device) and DAVE APPs

- [¥] DEVICE_PACK
- |] Library_DAVEDeviceDescriptions
- [¥] DAVE APPs



Tooling Overview -
DAVE™ (5/5)

> Accept terms of the license agreements and click Finish

> DAVE™ APPs libraries and Device Description are installed

~ Home
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Getting Started - Example -
Blinky based on XMC Lib (1/8)

1. Open DAVE™

2. Create a new "Simple Main”
project:

- File > New > DAVE Project

— Enter project name e.q.
"XMC1400_BlinkyMCAN”

— Select "Simple Main Project” as
Project Type 3.
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Getting Started - Example -
Blinky based on XMC Lib (2/8)

> For this project, we will use

- System clock frequency of 8MHz

— LED on Port pin

- System timer, SysTick, as the time base for interrupt
— P4.9 for CAN Tx and P4.8 for CAN Rx

> Next, we will show you how to

1. Set up the System or Main Clock (MCLK)

Configure Port pin

Configure SysTick and define its exception service routine
Configure 2 CAN message objects

Configure P4.9 for CAN Tx and P4.8 for CAN Rx

o o W N



Getting Started - Example -
Blinky based on XMC Lib (3/8)

1. Set up System or Main Clock (MCLK) and include the required
header files.

#include "xmc _can.h"
#include "xmc_gpio.h

— MCLK configured via IDIV and FDIV bit fields in
XMC_SCU_CLOCK_CONFIG data structure

XMC_SCU_CLOCK_CONFIG_t clock_config =

{
.dclk_src = XMC_SCU_CLOCK_DCLKSRC_DCO1,
.oschp_mode = XMC_SCU CLOCK OSCHP_MODE 0SC,
.enable_automatic dcol calibration = true,
.clock_sync = XMC_SCU CLOCK_SYNC_CLKSRC OSCHP, //XMC_SCU CLOCK_SYNC_CLK_OSCLP,
.pclk_src = XMC_SCU CLOCK PCLKSRC DOUBLE MCLK,
fdiv = @, //Fractional divider
Jidiv = 1 //MCLK = A8MHz
¥

— Initializes clock generators ad clock tree in Main.c to set MCLK
= 48MHz and PCLK = 96MHz

XMC_SCU CLOCK Init(&clock config);
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Getting Started - Example -
Blinky based on XMC Lib (4/8)

2. Configure Port pin

— GPIO to toggle the LED is configured via mode and output_level of
XMC_GPIOC_CONFIG structure. P4.0 will toggle at regular interval.
P4.1 will toggle when CAN message transmit and P4.3 toggle when

CAN message received.

#define LED P4 B
#define LED TX P4 1 //CAN TX indication
#define LED RX P4 3 //CAN _RX indication

led config.mode = XMC GPIQ MODE OUTPUT _PUSH PULL;

XMC _GPIO Init(LED, &led config);

led TX config.mode = XMC_GPIO MODE OUTPUT PUSH PULL:

led TX config.output level = XMC GPIO OUTPUT [EVEL HIGH;
XMC_GPIO Init(LED TX, &led TX config);

led RX config.mode = XMC_GPIO MODE OUTPUT PUSH PULL:

led RX config.output level = XMC GPIO OUTPUT [EVEL HIGH;
XMC _GPIO Init(LED RX, &led RX config);

— Configure P4.9 as CAN Tx pin and P4.8 as CAN Rx pin.

XMC_GPIO _CONFIG_t CAN1_TXD config;

XMC_GPTO_CONFIG_t CAN1 RXD_config: #define CAN1_TXD P4_9 //ALTS

CAN1_TXD config.mode = XMC GPIO MODE OUTPUT PUSH PULL_ALT9; #define CAN1_RXD P4_8
CAN1_RXD config.mode = XMC_GPIO MODE INPUT TRISTATE;

XMC_GPIO Init(CAM1_TXD, &CAN1_TXD config):

XMC_GPIO Init(CAM1_RXD, &CAN1_RXD config):
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Getting Started - Example -
Blinky based on XMC Lib (5/8)

3. Configure SysTick and define its exception service routine

— SysTick exception handler is defined in startup_XMC1300.s by using

the MACrO. .macro Insert InterruptVeener Interrupt
.globl ‘\Interrupt\() Veener
\Interrupt\()_Veener:
LDR R®, =\Interrupth() Handler
BX R@&
.endm

— Initialize the SysTlck in Main.c
/* System timer configuration */
SySTlck_Canlg(SyStemCDPetlﬂck / TICKS_PER_SECOND);

#define TICKS_PER_SECOND 1060
#define TICKS_WAIT 508

- Define the SysTick exception handler routine. Every 0.5s, toggle
P4.0 and transmit the CAN message, followed by toggle P4.1.

void SysTick_Handler(void)

{
static uint32_t ticks = @;

ticks++;

if (ticks == TICKS_WAIT)

{
XMC_GPIO ToggleOutput(LED);
XMC_CAN MO Transmit(&MCAN messagel);
XMC_GPIO ToggleOutput(LED TX};
ticks = @;

}

}
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Getting Started - Example -
Blinky based on XMC Lib (6/8)

4. Configure CAN node 1 baudrate and CAN message object
/*CAN Bit time*/
XMC_CAN_NODE_NOMINAL BIT TIME CONFIG_ t baud = {
.can_frequency=11000000,
.baudrate=5600000,
.sample_point =6000,
.5jw=3,

};
— Configure Tx message object and its data bytes

/*CAN message= CAN_MO4 */
XMC_CAN_MO_t MCAM _messagel = {
.can_mo_ptr = CAN_MO4,
.can_priority = XMC_CAN_ARBITRATION MODE_IDE DIR _BASED PRIO 2,
.can_identifier = @x3ff,
.can_id_mask= @x7ff,
.can_id_mode = XMC_CAN_FRAME TYPE STANDARD 11BITS,
.can_ide mask = 1,
.can_data_length = 8,
.can_data = {@x12345555, 0x12345556},

.can_mo_type= XMC_CAN_MO_TYPE_TRANSMSGOBJ _— R
/*CAN message= CAN_MO2 */

3 . . XMC_CAN_MO_t MCAN_message? =
— Configure Rx message object ;
.can_mo_ptr = CAN _MO2Z,
.can_priority = XMC_CAN_ARBITRATION MODE_IDE DIR_BASED PRIO 2,
.can_identifier = @x2ff,
.can_id mask = @x2ff,
.can_id mode = XMC CAN FRAME TYPE STANDARD 11BITS,
.can_ide_mask = 1,
.can_data_length = §,
.can_mo_type = XMC_CAN_MO_TYPE_RECMSGOBJ
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Getting Started - Example -
Blinky based on XMC Lib (7/8)

5. Set CAN Rx interrupt service request number and allocate the
message objects to CAN node 1.

/* Set receive interrupt Service request number®/

XMC_SCU_SetInterruptControl(7, XMC_SCU IRQCTRL 7 CAN® SR3);
XMC_CAN_MO_SetEventNodePointer (&MCAN_message2, XMC_CAN_MO_POINTER_EVENT _RECEIVE,3);
MVIC SetPriority(IRQ7 IRQn,1);

NVIC EnableIRQ(IRQ7 IROn);

/* Allocate MO in Node List*/

XMC_CAN_AllocateMOtoNodelist(CAN,1,4);
XMC_CAN_AllocateMOtoNodelist(CAN,1,2);
XMC_CAN_NODE_ResetInitBit(CAN_NODE1);

— Define the interrupt event handler for CAN node

/*This function is the Interrupt Event Handler for the CAN Node*/
void IRQ7_Handler(void)

{
/* Toggle LED Pin 4.3 +to indicate that the requested message is received*/
XMC_CAN MO Receive(&MCAN message?);
XMC _GPIO ToggleOutput(LED RX);
NVIC ClearPendingIRQ(IRQ7 IRQn};

¥
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Getting Started - Example -
Blinky based on XMC Lib (8/8)

1 . Invoking: ARM-GCC Print Size'
> BUIId prOJeCt "C:\DAVEv4\DAVE-4.1.4\eclipse\ARM-GCC-49/bin/arm-none-eabi-size" --format=berkeley "XMC1400 BlinkyMCAN.elf"
text data bss dec hex filename
. 3316 96 1068 44860 1180 XMC1400_BlinkyMCAN.elf
1 . Cl ICk } 'Finished building: XMC148@_BlinkyMCAN.siz'

2. Wait for Build to finish

> Download code

1. Click %%
2. Switch to Debug perspective @ oaepe g pavece # pinapping
3. Click & to run code

> LED LEDs P40, P41 blinks every 0.5s
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Getting Started - Example -
Blinky based on DAVE™ APPs (1/13)

1. Open DAVE™

2. Create a new "DAVE CE” project:
- File > New > DAVE Project

— Enter project name e.q.
"XMC1400_BlinkyMCAN_withApps”

— Select "DAVE CE Project” as
Project Type
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Getting Started - Example -
Blinky based on DAVE™ APPs (2/13)

> For this project, we will use

- System clock frequency of 48MHz
— LED on Port pin
— System timer as the time base for interrupt

> Next, we will show you how to

1. Set up the System or Main Clock (MCLK)
2. Configure Port pin

3. Configure System Timer and define its exception service
routine

. Configure CAN Node
5. Configure CAN Message Objects, CAN Tx/Rx pin and ISR



Getting Started - Example -
Blinky based on DAVE™ APPs (3/13)

1. Set up System or Main Clock (MCLK)

— Click * to add new APP

— Double-click CLOCK_XMC1 APP and
close window

— Open APP configuration editor

- In APP Dependency view, double-click
CLOCK_XMC1

4

— Configure APP instance

— In APP configuration window, set Main
clock (MCLK) to 48MHz



Getting Started - Example -
Blinky based on DAVE™ APPs (4/13)

2. Configure Port pin

~ Click * to add new APP

— Double-click DIGITAL_IO APP and
close window

— Open APP configuration editor

- In APP Dependency view, double-
click DIGITAL_IO

— Configure APP instance

— In APP configuration window, set Pin — Assign pin to P4.0
direction to Input/Output and set —Click #§ to open Manual Pin Allocator
Initial output level to High —Set Pin Number (Port) to #59 (P4.0)

—Save and closed
— P4.0 will toggle output at 0.5s interval

DIGITAL IO 0 53

Pin direction: | Input/Output =

Input Settings

Output Settings
Mode: Push Pull

Initial output level: | High



Getting Started - Example -
Blinky based on DAVE™ APPs (5/13)

3. Configure Port pin P4.1 and P4.3 using steps described in 2.

- P4.1 will toggle output when CAN message transmitted
- P4.3 will toggle output when CAN message received



Getting Started - Example -
Blinky based on DAVE™ APPs (6/13)

3. Configure System Timer and define its
exception service routine
- Click ® to add new APP
— Double-click SYSTIMER APP and close window

— Open APP configuration editor
- In APP Dependency view, double-click SYSTIMER
— Configure APP instance

— In APP configuration window, under General
Settings tab, set System timer tick interval to
100000us (0.1s)



Getting Started - Example -
Blinky based on DAVE™ APPs (7/13)

— Create software timer using SYSTIMER Apps.

uint32_t TimerId = SYSTIMER CreateTimer(Point5SEC,SYSTIMER MODE PERIODIC, (void*)LED Toggle EveryPoint5Sec,NULL}Y;
if(TimerId != @U)

{

f/Timer 1is created successfull

// Start/Run Software Timer

status = SYSTIMER StartTimer(TimerId);
¥

— Define exception handler routine in Main.c
- Define the toggle interval (in usec)

#define Point5SEC 500006U

void LED_Toggle_EveryPoint5Sec(void)

{
DIGITAL_TO ToggleOutput(&DIGITAL_IO _0); // Toggle LED Pin 4.8 every 8.5s interval
CAM_NODE_MO_Transmit(CAMN_NODE_@.1mobj_ptr[@]); // Transmit the data of message object
DIGITAL IO ToggleOQutput(&DIGITAL I0 1); /{ Toggle LED Pin 4.1 to indicating transmission of data frames is done
}
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Getting Started - Example -
Blinky based on DAVE™ APPs (8/13)

4. Configure CAN node

— Click *; to add new APP
— Double-click CAN_NODE APP and close window

— Open APP configuration editor

- In APP Dependency view, double-click
GLOBAL_CAN

— Configure APP instance

— In APP configuration window, under General
Settings tab, set Desired CAN frequency
(MHz) to 11



Getting Started - Example -
Blinky based on DAVE™ APPs (9/13)

5. Configure CAN Message Objects

Open APP configuration editor —

In APP Dependency view, double-click
CAN_NODE

Configure APP instance

In APP configuration window, under General
Settings tab, set Number of message objects
in the list to 2

Under Event Settings, enable Enable node alert

Under MO Settings_Pagel, setup a TX message
object with 8 data bytes,Identifier value = Ox3FF

Under MO Settings_Pagel, setup a RX message
object with Identifier value = 0x2FF.



Getting Started - Example -
Blinky based on DAVE™ APPs (10/13)

- Click * to add new APP

— Double-click INTERRUPT APP and close
window

— Open APP configuration editor

- In APP Dependency view, double-click
INTERRUPT

— Configure APP instance

— In APP configuration window, configure ISR for
CAN_NODE_O0 as “"EventHandler_CanNode_0"



Getting Started - Example -
Blinky based on DAVE™ APPs (11/13)

— Right click on the CAN_NODE_O0 APP and select
HW signal connection

— Select MO transmit event and link it to NVIC
node. Then, click 4@ and link MO received
event to NVIC node.

— Assign CAN TX pin to P4.9 and CAN RX pin to P4.8

- Click ## to open Manual Pin Allocator
— Set the desired pins as shown on the right
- Save and closed



Getting Started - Example -
Blinky based on DAVE™ APPs (12/13)

— Add the Interrupt Service Routine for
CAN_Node_0 to main.c

// This ISR is the event handler for the CAN_NODE_@
void EventHandler_CanNode_@()
{
volatile uint32 t status = 6x00;
status = CAN_NODE_MO GetStatus((void*)CAN NODE_@.1Imobj ptr[1]);
// Check receive pending status in LMO 82
if ( status & XMC_CAN MO _STATUS RX PENDING) //XMC_CAN_MO_STATUS NEW DATA
{
// Clear the flag
CAN_NODE_MO_ClearStatus((void*)CAN_NODE_@.lmobj ptr[1],XMC_CAN MO RESET STATUS RX PENDING);
// Read the received Message object and stores the received data in the MO structure.
CAN_MODE_MO_Receive((void*)CAN_NODE_@.1mobj_ptr[1]);
DIGITAL_IO ToggleOutput(&DIGITAL_IO 2); // Toggle LED Pin 4.3 to indicating reception of data frames is done.
¥
// Check transmit pending status in LMO_01
status = CAN_NODE_MQ GetStatus((void*)CAN _NODE_@.lmobj ptr[0]);
if (status & XMC_CAN MO _STATUS TX_PENDING)
{
// Clear the flag
CAN_NODE_MO_ClearStatus((void*)CAN_NODE_@.lmobj_ptr[@],XMC CAN MO_RESET STATUS_ TX PENDING);
}
}
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Getting Started - Example -
Blinky based on DAVE™ APPs (13/13)

> Generate code
1. Click [#

> Build project

1. Click 2
2. Wait for Build to finish

> Download code

1. Click %
2. Switch to Debug perspective T DAVEIDE g DAVECE 4§ PinMapping

3. Click ! to run code

> LEDs P40, P41 blinks every 0.5s
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References -
Where to find XMC Lib documentation?

1. Go to DAVE™ Version 4 website

http://www.infineon.com/dave/v4

]
2. Download XMC Lib and unzip file

XMC™ Lib Ready to use APls for peripherals which are tested for GMU-, ARM-, 1AR- und TASKING- compiler,
and released for Altium, ARM/KEIL, Atolliz, AR Systems und Rowley compiler IDEs.
Low level driver libraries for XMC™ peripherals (4Pls), CMSIS 7/ MISRA 2004 compliant including
documentation. XMC™ Lib — Release Mote

System: Timer/PWM: Analog- Communication: Application Examples:
mixed specific: —
Signal:

m DMA m CCU4 m ACMP m CAM m BCCU m Examples

= ERU m CCUS m ADG m [2C m LEDTS for all

m FCE n HREPWM m DAC m 5P| u MATH periperhals 4

= FLASH = POSIF = DSD = UART = POSIF drivers and

m GPIO m USE u HRPW ARM,

u MATH m UEIC GCC, AR,

m PAL m Ethernet and

m PRNG Tasking

3. Open XMC1_Peripheral_Library
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http://www.infineon.com/dave/v4

Resource Listing

> Kit documentation:
— Boot Kit XMC1400
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http://www.infineon.com/cms/en/product/evaluation-boards/KIT_XMC14_BOOT_001/productType.html?productType=5546d46250cc1fdf015144a2102e1191

References -
Where to find App Documentation?

1. In DAVE™, go to Help > Help Contents

2. Expand DAVE Apps - Click on CLOCK_XMC1 -> Overview
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References -
Where to download Example Projects?

1. Example Project library within DAVE™
2. DAVE™ website
3. Example from XMC Lib package
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References -
How to load Example Project in DAVE™? (1/4)

_ _ o 3. Select Examples in the Libraries
> Example Project library within window = Click Next

DAVE™

1. Help > Install DAVE
APP/Example/Device Library

4. Accept terms of the license
agreements - Click Finish

2. Select DAVE Project Library
Manager
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References -
How to load Example Project in DAVE™? (2/4)

> DAVE™ website 5. Select Archive File & Browse to
_ downloaded project zip file
1. Go to DAVE™ Version 4
website

http://www.infineon.com/dave/v4

2. Download DAVE™ EXAMPLES

3. In DAVE™, go to File >

Import
6. Click Finish

4. Select DAVE Project > Next

Copyright © Infineon Technologies AG 2015. All rights reserved.


http://www.infineon.com/dave/v4

References —
How to load Example Project in DAVE™? (3/4)

3. Example code (main.c) can be
> Example from XMC Lib found within XMC Lib package

package

1. Go to DAVE™ Version 4
website L]

http://www.infineon.com/dave/v4

2. 1I:D”(()ewnload XMC Lib and unzip 4. Create new “Simple Main Project”

in DAVE™

XMC Lib Low level driver libraries for XMC peripherals (APlg), CMSIS f MISRA 2004 compliant including

documentafion

System: Timer/PWM: Analog- Communication: Application Examples:
mixed specific:
signal: g
= DA = CCU4 u ACMP m CAN = BCCU = Examples
= ERU u CCUS m ADC m2C m LEDTS for all
m FCE m HRPWM m DAC m 5Pl ® MATH periperhals
m FLASH m POSIF = UART m POSIF drivers and
u GPIO = USB n HRPWM ARM
= MATH = USIC GCC, IAR,
u PAL and
m PRNG Tasking
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http://www.infineon.com/dave/v4

References -
How to load Example Project in DAVE™? (4/4)

5. Select target device of 8. Click /" to Build project

selected main.c example
9. Click %# to download and run

project on target board

6. Delete main.c in the newly
created DAVE project

7. Copy main.c from XMC Lib
example into DAVE project

Copyright © Infineon Technologies AG 2015. All rights reserved.



Support material:

Collaterals and
Brochures

Technical Material

Videos

Contact

Copyright © Infineon Technologies AG 2015. All rights reserved.


http://www.infineon.com/XMC
http://www.infineon.com/XMC
http://www.infineon.com/cms/en/product/microcontroller/32-bit-industrial-microcontroller-based-on-arm-registered-cortex-registered-m/32-bit-xmc1000-industrial-microcontroller-arm-registered-cortex-registered-m0/xmc-development-tools-kits-and-boards/channel.html?channel=db3a30433d5e5530013d64397b0c2043
http://www.infineon.com/cms/en/product/microcontroller/32-bit-industrial-microcontroller-based-on-arm-registered-cortex-registered-m/32-bit-xmc1000-industrial-microcontroller-arm-registered-cortex-registered-m0/dave-version-4-free-development-platform-for-code-generation/channel.html?channel=5546d46145f1f3a4014619e925171bcc
http://www.infineon.com/cms/en/product/microcontroller/32-bit-industrial-microcontroller-based-on-arm-registered-cortex-registered-m/32-bit-xmc1000-industrial-microcontroller-arm-registered-cortex-registered-m0/xmc-development-tools-software-tools-and-partner/channel.html?channel=5546d46145f1f3a4014619e9bcfa1bcd
http://www.infineon.com/mediacenter
http://www.infineon.com/cms/media/Applications/microcontrollers/XMC/Mediathek.html
http://www.infineonforums.com/
http://www.infineon.com/cms/en/about-infineon/company/contacts/product-support-form/

Glossary abbreviations

> ADC Analog Digital Converter
> DAVE™ Free development IDE for XMC
> MO Message Object

> PWM Pulse Width Modulation



Disclaimer

The information given in this training materials is given as a hint for
the implementation of the Infineon Technologies component only and
shall not be regarded as any description or warranty of a certain

functionality, condition or quality of the Infineon Technologies
component.

Infineon Technologies hereby disclaims any and all warranties and
liabilities of any kind (including without limitation warranties of non-
infringement of intellectual property rights of any third party) with
respect to any and all information given in this training material.
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