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Objective of this tutorial 

1. Download provided example application to your board 

› Using DAVETM 4 integrated debugger 

› Using XMCTM Flasher tool 

2. Control and monitor your application using the Micrium® uC/ProbeTM 
XMCTM dash board 

3. Monitor variables using the Micrium® uC/ProbeTM XMCTM oscilloscope 
control 
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What we need to follow this tutorial? 

Software 

› To download to the target the provided example application, use either:  

– DAVETM version 4 

Development Platform for XMCTM microcontrollers 

Go to www.infineon.com/DAVE and download DAVETM version 4 

– XMCTM Flasher 

Free of charge programming tool 

Go to XMC™ Software Download and download XMCTM Flasher 

 

› Micrium uC/ProbeTM XMCTM version 4 

Go to www.infineon.com/ucProbeXMC and download the latest version 
of Micrium® uC/ProbeTM XMCTM 

 

› Example application project for DAVETM version 4 accompanying this document 
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http://www.infineon.com/DAVE
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What we need to follow this tutorial? 

Hardware 

› Any Infineon XMCTM board 

› In this document XMC4700 Relax Kit is used 
featuring: 

 

 

 

 

 

 

› On board debugger is used 

› Connect the board to your PC using a micro USB 
cable 

 

 

 

– XMC4700-F144 microcontroller based on 
ARM® Cortex®-M4 at 144 MHz, 2 MB Flash 
and 352 KB RAM 

– On-board debugger (Segger J-Link) 

– Power over USB 

– ESD and reverse current protection  

– 2 x user button and 2 x user LED  

– Arduino hardware compatible 3.3 V pinout 
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Introduction to Micrium® uC/ProbeTM XMCTM 

What is Micrium® uC/ProbeTM XMCTM? 

› uC/ProbeTM XMCTM is a Windows® based application that let’s you 
control and monitor a running embedded system 

› Allows easy visual access to the internals of your application using the 
oscilloscope control, gauges, spreadsheets, LEDs and other widgets 

› Create rich visually appealing user interfaces for your applications 

› Can be used with any toolchain that can generate an ELF fileCan 
connect to the embedded system using SWD/JTAG, UART, Ethernet or 
USB 

– SWD communication does not need any target firmware to set or 
retrieve the values of variables 

– Other communication interfaces need adding a C library to your 
application to respond to the requests from μC/ProbeTM running on the 
Windows® PC. Library can be obtained at µC/Probe Embedded Target 
Code 
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Introduction to Micrium® uC/ProbeTM XMCTM 

uC/ProbeTM XMCTM example for XMCTM Digital Power Explorer Kit  

Dash board 

Oscilloscope 
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Introduction to Micrium® uC/ProbeTM XMCTM 
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How it works? 

› uC/ProbeTM XMCTM obtains the address 
of the variables from the ELF file 

› Design your dash board by dragging 
and dropping widgets 

› Associate a variable to each of the 
widgets 

› Configure the communication interface 

› Start uC/ProbeTM XMCTM 

› uC/ProbeTM make requests to read the 
value of all variables used in the 
dashboard 

 



Download the application to your target 
using XMCTM Flasher 

1. Connect your board to the PC using a micro USB cable 

2. Start XMCTM Flasher 

3. Select the hex file 

 › Click on File in the menu bar 

› Browse to the location of your file 
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Download the application to your target 
using XMCTM Flasher 

4. Connect to your device 

› Click on Connect… 

› Select your device 

13 Copyright © Infineon Technologies AG 2016. All rights reserved. 



Download the application to your target 
using XMCTM Flasher 

5. Click on Program… 
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1. Start DAVETM version 4 

2. Import the example project 

› Click on File > Import... 

› Select Infineon > DAVE Project  

› Click on Next 

› Select Archive File 

› Click on Browse 

› Browse to the location of the example project and select the zip file 

› Click on Finish 

3. Compile the project 

› Click on Rebuild Active Project button in the tool bar 

Download the application to your target 
using DAVETM version 4 
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Download the application to your target 
using DAVETM version 4 

4. Start debugger 

› Click on Debug button in the toolbar 

› Double click on GDB SEGGER J-Link Debugging 

› Click on Debug 

 

 

 

 

 

› The debugger will program your board. In the debugger view click on 
Resume button in the toolbar to start your application 
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

› This section shows you how to monitor and control your application 
using the dash board 

› By having a dashboard for your C code, you will gain a firm 
understanding of what the embedded system is doing at any given time 

› Use xmc4700_relaxkit_ucprobe_ex1.zip example project 

1. Start Micrium® uC/ProbeTM XMCTM 

› Click on         in your desktop 

 

2. Setup communication to board 

› Click on Settings button in the toolbar  

 

 

› Select Debug Interfaces > J-Link 

› Click Ok 
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

3. Load an ELF file 

› Click on ELF button in Symbol Browser window 

› Browse to the location of the ELF file in the Debug folder of the 
example project 

› Select the file. Click Open 

› Now you are ready to start designing your graphical UI 
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

4. Drag and drop controls to build your user interface 

› In this example we will monitor and control a global variable of our 
application 

› Add a Textbox from the Writable Controls. We will use this control to 
change the value of the variable 

› In the Properties Editor you could apply scaling to the read value of the 
form y = scale*x + offset. You can also adjust the Decimal Places. These 
settings are available for almost all controls 

 

mouse click 
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

› Add a Radial 1 from the Angular Gauges. We will use this control to 
monitor the value of the variable. 

In the Range and Colors of the control select maximum value 255 

 

 

 

 
 

 

› Add a Cylinder 1 from the Linear Gauges. We will use this control to 
monitor the value of the variable. 

– In the Range and Colors of the control select maximum value 255 
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

› Your dash board should look like as shown below 

› You can always save your workspace by Ctrl-S or File > Save 
for later use or for sharing   
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

› Search for the g_var symbol in the Symbol Browser: 

– Either use the search function if you know the name of the variable  

– Or unfold the ELF file and navigate through the modules 

› Drag the g_var variable and drop it over the Textbox control 

– Do the same for all the other controls 

 

 

 
Alternatively you can 
associate a variable to 
a control by double 
clicking on the variable 
if previously the 
control was selected by 
clicking on it. 

5. Associate variables to controls 
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Using Micrium® uC/ProbeTM XMCTM 

Dashboard 

6. Since we are connecting to a XMC4700 board, select XMC4000 in 
the Infineon XMCTM Family window 

7. Before the next step ensure your board is running,  

      i.e. not halted by debugger 

 

 
6. Click on Run button in toolbar 

› The controls visualization will get updated periodically according to the 
value of the variable g_var 

› In this case the application increments the variable g_var in a loop 

› You can also modify the value of the variable in run time 

 No programming is required! 
No need to instrument your embedded code nor need to write any single line 

of code in the PC to get insight of your application. 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

In this section will explore the capabilities of the oscilloscope control of 
Micrium® uC/ProbeTM XMCTM 

› Use xmc4700_relaxkit_ucprobe_ex2.zip example project 

1. In this section you will open an existing Workspace (.wspx) 

› Simply double click on the provided .wspx file in the example project. 

› Micrium® uC/ProbeTM XMCTM will start, showing the panel control for a 
software “signal generator” 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

› To use the oscilloscope control, it requires adding to your 
application the Scope library which is part of the Target Code 
included in the µC/ProbeTM XMCTM download package or can  be 
downloaded from µC/Probe Embedded Target Code 

– Add folder and adjust the compiler settings, i.e. Include Paths 

– Include probe_scope.h into your application code 

› The library provide two functions: 

– ProbeScope_Init() 
Initializes the internals of the Oscilloscope module. It sets the 
time base indicated as a parameter to the function, i.e. the 
frequency of calling the sampling function 

 

 

 

2. Add uC/ProbeTM Embedded Target code 
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– ProbeScope_Sampling() 

Take a sample of each active oscilloscope channel. This function should be called in 
periodic function, i.e. control loop or timer ISR like in the example 

› The library can be configured adapting the defines in probe_scope_cfg.h 
– Number of channels 
– Number of sample per channel 

– It determines the length of the waveform, i.e. T = sampling period X number of 
samples per channel 

https://www.micrium.com/download/ucprobe-target-code/
https://www.micrium.com/download/ucprobe-target-code/
https://www.micrium.com/download/ucprobe-target-code/


Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

3. Create an oscilloscope 

› Click on Project > Add Oscilloscope 

› A new tab is created in the workspace containing the 
oscilloscope control 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

4. Associate variables to the oscilloscope channels 

› Using the symbol browser drag and drop the variables 
channel_0.value and channel_1.value to the oscilloscope 
channels 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

5. Change the layout of the workspace 

› To easily access the controls of the dashboard and 
simultaneously observe the oscilloscope, right click on the tab 
Oscilloscope and select Floating.  The oscilloscope window will 
be detached from the main window of Micrium® uC/ProbeTM 
XMCTM 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

6. Ensure target is running.  

7. Click on Run button in toolbar.  

8. Adjust the oscilloscope channel scale. 

› Click on Set Multiple Scales (1) in Tools to adjust the vertical scale. 

› Set the Sampling Clock Divider (2) to adjust the time base scale.  

(1) 

(2) 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

9. Use the dash board to control your application and observe the 
effect on the oscilloscope 

› For example, change frequency of the waveform generator channel 0 
Hz to 5 Hz. You should observe something similar to the picture below 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

10.Oscilloscope trigger options 

› One of the main features of the Oscilloscope control is the capability 
of triggering with the following options: 

– Trigger channel selection (1) 

– Trigger level (2) 

– Rising or falling edge (3) 

– Pre trigger (4) 

– Single trigger or continuous trigger (5)   

(1) 

(2) 

(3) 

(4) 

(5) 
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Using Micrium® uC/ProbeTM XMCTM 

Oscilloscope control 

11.Oscilloscope other features 

› Time axis zoom 

– Use the scroll bars in the top area of the Oscilloscope window (1) 

› Individual Y vertical channel scale (2) 

› Offset and gain of channels (3) 

 
(1) 

(3) 

(2) 

(2) 

(1) 

34 Copyright © Infineon Technologies AG 2016. All rights reserved. 



Agenda 

Objective of this tutorial 

What we need to follow this tutorial? 

Introduction to Micrium® uC/ProbeTM XMCTM 

Using the dashboard 

Using the oscilloscope 

Other features 

References 

Support material 

1 

2 

3 

4 

5 

6 

7 

8 

35 Copyright © Infineon Technologies AG 2016. All rights reserved. 



Micrium® uC/ProbeTM XMCTM 

Other features 

› Data logging control 

Log the values of any variable(s) in your symbols browser to a 
CSV file 

› Microsoft ® Excel® Bridge 

Map an embedded target's symbol to a cell in Microsoft® Excel® 

› uC/OS Kernel Awareness 

The µC/OS Kernel Awareness in µC/Probe™ is a series of pre-
built screens that allows you to see the run time behavior of all 
the µC/OS-II kernel objects used in your embedded application 

› Terminal Window 

Interact with your embedded target in a shell-like fashion 
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References 

› Micrium® uC/ProbeTM XMCTM documentation 

– Accessible in the Start menu of Windows® 

– Or in the File tab 

 

› Micrium® uC/ProbeTM XMCTM features 

https://www.micrium.com/tools/ucprobe/features/ 

 

› uC/ProbeTM Oscilloscope Feature: BLDC Design Case Study 

https://www.micrium.com/new-%C2%B5cprobe-features-
simplify-bldc-design/ 
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Support material 

› Product Briefs  

› Selection Guides 

› Application Brochures 

› Presentations 

› Press Releases, Ads 

› Application Notes 

› Technical Articles 

› Simulation Models  

› Datasheets, MCDS Files 

› PCB Design Data 

 

› Technical Videos 

› Product Information 

 Videos 

 

 › Forums 

› Product Support 

 

 

Collaterals and  

Brochures 

Technical Material 

Videos 

Contact 

› www.infineon.com/XMC 

 

 

› www.infineon.com/XMC 

› Kits and Boards 

› DAVETM 

› Software and Tool Ecosystem 

 

 

› Infineon Media Center 

› XMCTM Mediathek 

 

 

 › Infineon Forums 

› Technical Assistance Center (TAC) 
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The information given in this training materials is given as a hint for 
the implementation of the Infineon Technologies component only and 
shall not be regarded as any description or warranty of a certain 
functionality, condition or quality of the Infineon Technologies 
component. 

 

Infineon Technologies hereby disclaims any and all warranties and 
liabilities of any kind (including without limitation warranties of non-
infringement of intellectual property rights of any third party) with 
respect to any and all information given in this training material.  

Disclaimer 




