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PREFACE

The Programmable System on Chip (PSoC) has evolved over the last few years.
However, no change has been as significant as the transition from PSoC 1 to
PSoC 3. Moving from a simple M8C core to a more powerful and efficient 8051
core, the PSoC is set to take embedded systems to a new high.

Although fundamentally the process of designing any application is the same,
there are several new aspects to the PSoC 3. Additional flexibility for hardware
configurations and the ever expanding set of peripherals make the PSoC 3 ideal
for powerful applications on chip.

The introduction of PSoC Creator over the earlier used PSoC Designer/ PSoC
Express brings an additional dimension in terms of challenges for a novice
seeking to explore and master the PSoC 3.

Though Cypress Semiconductors has come out with an extensive and thorough
Technical Reference Manual for the PSoC 3, a starting point is needed for a
novice to grasp this technology.

This manual was written keeping in mind the needs of a student starting from
the grass root level. Attempts were made to cover every small step that would
make life easier and hassle free for anyone attempting to learn the PSoC 3 with
fundamental knowledge of Microprocessors, Analog and Digital Electronics.

With the advent of the PSoC 5 with a lethal ARM core not too far away, this
manual serves as the perfect bridge for anyone seeking to keep pace with the
changing environment of PSoC.
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GETTING STARTED
GETTING STARTED

OBJECTIVE

For those of you who've used PSoC 1 and are familiar with the PSoC Express/PSoC
Designer environments, the PSoC creator is not hard to grasp at all. It has the versatility
of the PSoC Designer coupled with the easy usability of the PSoC Express. Additionally,

interconnecting modules is far easier than before.

For all those of you getting started with PSoC, you could not have an easier software

interface than the PSoC Creator.

The objective of this exercise is to get the user familiar with rudimentary aspects of PSoC
Creator. All the exercises in this lab book have been designed, built and tested using
PSoC Creator 1, and programmed using PSoC Programmer 3.12.3.

CREATING A NEW PROJECT

File Edit \iew Debug Project Build Tools Window Help
AR - W TP W SR
=
- ¥

WorkspaceEiglorer  w & X! start Page |

k] . -
o = B <
. PSoC® Creator ;}CYPRESS

>4k X

i

-
5
8
o M Welcome to PSoC® Creator™
g
3
§ ° PSaoC Creator provides a unigue and powerful PSaC hardware/software co-design enwironment. with:
] ‘Examples and Tutorials
- Quick: Start Guide « State-ot-the-art software development IDE
= Find Example Project ..
£ N Kits or Salutions Found ) « Revolutionary graphical design editor
7 PSaC Creater Training -
depﬁ-;m;:a‘sps‘)c 3 Desi Cypress provides training material via our web site. located at PSoC Creator Training. There are also tutorials and walkthroughs provided in the
" — PSoC Creator Help, accessidle from the Help menu. Plus, you can install various PSeC Kits, which contain tutorials and walkthroughs as well.
Start Page Topics The following section provides a general overview of creating an embedded design using PSoC Creator. The main steps are: Configure,
Wi to PSoC. £ Develop, Debug. and Reuse. Click on each tad below to learn more about each step.
Intro to PSaC - E 2 A
Configure Unlike fixed function microcontrollers. PSoC allows you to choose the on-chip peripherals you need Instead of
settling for a part that has most of what you need and a lot of what you don't. with PSoC you simply configure the
Web Sites. device with your chosen functionality. No mare, no less
e And the configuration process couldnt be easier. You choose peripherals from a catalog of pre-defined and pre-
My PSoC. tested components and simply drag them into your design schematic. The companents range from simple
PSoCDe gates for glue logic, through complete implementations of digital and analog peripheral functions, up to
veloper.com saphisticated communications and applications solulions like USB and CapSense. Then chaose your clock
3] Support frequencies, connedt peripheral ¥O fo pins, and you're done. The built-in configuration tools map your design
- inta the device and calculate the clock setup and routing automatically. -
Output X
Show output from: All =
‘Log file For this session is located at: C:\Users\aswath\AppData)Locall\Temp\PScC Creator-000.log
a
= | Output | Notice List

Ready

» The PSoC Creator Start Page has a link that enables one to create a new project as

shown in the figure above.
> Alternatively, a new project can also be created by going to File > New>Project.



NAMING THE PROJECT

> Once the new project is created, a window appears like the one shown above.
> Select Empty PSoC 3 Design and Assign your project a name.



LICENSING KEIL

> Before beginning with the design, it is necessary to license Keil without which you
will be unable to compile your project.
> Go to Help>Register>Keil as shown below

B psoC Creator 1.0

File Edit ‘iew Debug Project Buld Tools  ‘Window | Help |
wfn.l-:ﬁl—%-:ij = PN W - @ Topics - e 2 n:s r\ =
WolpaeEgloret v AR statpage| | "oCCresoTsnng
,'% ﬁ Documentation +
— Reqister L] PSaC Creatar...
PSoC® Creatd |
" Feedback Keil...
E B&tﬂ about
o Receint Projects H Welcome to PSoC® Creator™
E] A S rnaarke

» Select “Get LIC via Internet” as shown below

# Keil Licence Registration

Step 1: Get LIC
Computer 1D [CID] - | CXR7A-CLTSD

[ et LIC wia Intermet. . ]

Step 2: Enter LIC
New License D CadefLIC} |

Add LIC

Step 3 Werfy LIC [Suceszfully added LIC will be showr in the table below]

Product Licenze D Code(LIC] Support Period
PKA1 Praof. Developers Kit for PSolC | " REQUIRES ACTMATION = | Operation Expires: 1:

< i | ¥

Cloze |




> Fill in all the necessary fields in the Product Licensing form from ARM
> You should see a confirmation page as shown below.

KEIL 1
ARM Product Licensing DZl Taols by ARM
Home Products Videos Events Support Searc - [
Product Licensing Thanks for Licensing Your Product
Overview
Single-User License We have sent your product registration infarmation including the License 1D J Quick Links
Single-User License Uninstall Code (LIC) via e-mail to adiy@cypress.com.
Floating-User License = Licensing User's Guide
When you receive this e-mail, copy the License ID Code (LIC) and paste it into
the New License ID Code input field in the pvision License Manager Dialog —
Single-User License Tab (available from the File Menu). — 1
ib Knowledgebase
If you have multiple Keil products you may Register Another Product at this
time. = RE-LICENSING ISSUES
= UNABLE TO REGISTER
PRODUCT SERTAL
HUMBER (PSN)
= MOVING f LICENSE TO A
WEW WORKSTATION
Top 3 License Issues
Contact Site Map Press Privacy Copyright © 2011 ARM Ltd and ARM Germany GmbH. Aall rights re :

» Check your email for the License file. Copy the License ID Code (LIC) to the window.

# Keil Licence Regijstration

Step 1 : Get LIC
Computer D [CID] - | CHR7ALCLTSD
[ Get LIC wia Intemet. .

Step 2 Enter LIC
Mew Licenge 1D Code[LIC]: |14FEHU-SLEDFE-EIdGH3-N8D53-HM?35-GP9TJ|

Add LIC

Step 3 Wenty LIC [Sucessfully added LIC will be shown in the table below)

Froduct Licenze |0 Code(LIC) Support Peniod
PEST Prof. Developers Kitfor PSoC | **REQUIRES ACTIVATION ** | Operation Expires: 1:

< | &

Cloze




THE SCHEMATIC PAGE

> The schematic page as shown below is the first element of the project. This is where
modules of the PSoC are added and interconnected just like drawing a schematic.
» This can be accessed by double clicking TopDesign.cysch in the workspace explorer.

THE PIN ASSIGNMENT PAGE

> The pin assignment page as shown below enables the user to assign physical device
pins to the project, configure clocks, interrupts etc.
> It can be accessed by double clicking Project_ Name.cydwr

_ StartPags | TopDesign.cysch.” Project Name.cydwr |
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WRITING FIRMWARE

Y VYV

defined functions for each module.

» This window as shown below can be accessed by double clicking the filename in the

workspace for example “main.c”

Most PSoC 3 kits come with an inbuilt flash memory which can be used to store data.
Writing firmware enables the user to activate modules and use a variety of pre

StartPage | TopDesign.cysch | Project_ Mame.cydwr / *main.c | v d b X

P e W e e —

| » i

3 # Copyright YOUR COMPANY, THE YEAR

4 * 211 Righrs Ressrved

5 * UNPUBLISHED, LICENSED SOFTWARE.

& *

7 % CONFIDENTILL AND PRCPRIETARY INFORMATION

B * WHICH IS THE PROPERTY OF AUTHOR'S NAME/COMEANY

] =

10 *

a3 &S

12! #include <device.h>

13

14 void main ()

i5; i

16 /* Place your initialization/startup code here (e.g. MyInst_Start(})

17

18I /% CYBlobalTntEnable; #/ /¥ TUncomment this line te enable global interrupts. %/

19 forirs)

20 i

2L /* Place your application code here. #*/

22 }

23 ]

24

253 /* {1 END OF FILE %/

Z6
J « »
Output > K}
Show output from: Al - =N

Log file for this session is located at: C:\Usersi\aswath\ZppData'\Local\Temp\PS5ol Creater-000.log

At the end of this exercise you should be able to

> Create a New Project
> License Keil

> Access the schematic page, pin assignment page and the firmware page.




CPU EXERCISE
CPU EXERCISE

OBJECTIVE

Perform a CPU exercise that will help you understand the 8051 core of the PSoC 3

REQUIRED MATERIALS

1. PSoC 3 (001) board.

OVERVIEW

The new enhanced feature of the PSoC 3 that makes it better than the PSoC 1 is the fact
that a new 8051 core is used. In order to understand the brain of the PSoC 3 we perform
the following CPU exercise where we use #pragma statements.



HARDWARE CONFIGURATIONS

» Open a new project and name is LAB1A

» Make sure that the window “TopDesign.cysch ” is open
» From Component Catalog->Ports and Pins, select Digital Output Pin. Drag and

Drop it in the grid.
kX

EY

0] Pin_1

Component Cakalog (34 com,.. - 1 X

F i B W@
43 3

Cypress ] q [

@ Cypress Component Catalog

e Analog

55 CapSenze

{8 Communications

&g Digital

B Dizplay

& Filters

=g Ports and Pins
@ Analog Fin [+1.50]
@ Digital Bidirectional Pin [+1.5
@ Digital Input Pin [+1.50]

@ Digital Dutput Pin [+ HI>

B Swstem

» Double Click (or right click and select Configure) on Pin_1. Uncheck the HW
Connection Box. Select Number of Pins: 4.

“““ 4 Cut el

=85 Copy Chrl+iC

e

7 Delete D=l
Zoom »
Shape 3

: Configure. .. j

217 Open Data Sheet ...
Find Example Praject. ..




Configure ‘'cy_pins’

i ame: |F'in_1 |

Pins Kr\’lapping I/Reset ]/Eiuilt-in ] q I
Mumber of Pins: |4 I S S

Type }/General }/Input }/Output ]

g Fin_1_0 [] Analog Presiew:

[ Pin_1_1

B F _1_2 [ ] Digital Input —l'—m
n_ 1 .

E Fin 1 3 Hw' Connection

Digital Output
[ ] Ouput Enable
[] Bidirectional

Data Sheet |_ Ok J Apply Cancel

» The change in number of pins will be reflected in the schematic as shown below.




ASSIGNING PINS AND SETTING CLOCK

> Go to LablA.cydwr->Pins from the Workspace Explorer. On the right hand side
of the window in front of Pin_1[3:0], select P2[3:0]. (P2[3:0] correspond to 4 LED’s
on the PSoC3-003 Kit). A screenshot of the same is shown below.

Alizs MName Fin Lock
Pin_1([3:0] | P2[3:0] h

» Go to Lab1A.cydwr->Clocks. Double Click Bus_Clk. Set the Bus Clock to 1kHz as
shown below. This will be the CPU_Clk.

M/ LabiAcydur vi|

'Mdﬂﬁmwmmu A Dl Desyan-Wide Clock (o B Clock.,
3 o

.- . Desed  Nomweal  Accuracy Toleance .. Sarton
‘TYH ulm D}mm FMW me ('J(I} (\1/.) DMIII HQIEI ' MCM

Gebm USBCK  DGTAL s 2w 4 : B
System | Digiel Sgnal [ DIGMAL| 70| M| & S
|§mm ST KHE | DIGTAL | 52760 o) 20| & S
System | XTAL DIGTAL | 33000 Wa|  2Ma| &0 € 9 [
<<Sgafe (B CLK(CPRY) | DIGTAL 1.000757090 e d)  cjum) WK - —
System | L0 DGTAL| 7| L.000 k& ? - 1
Sysen MO DIGTAL| 3.000 M| 3.000 M| &1 € 0 [
System |MASTER CLK | DIGTAL|  » ma{2e.000 0| & < 4] [0 [ALOUr
|3ysbm ALOUT  |DIGIAL | z4.000 Mhz|24.000 M| &1 <8 Mo
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b
Yy VY

I ‘Master Clack

| PLL_OUT [24.000 MHz) v|
) Freq (%) Divider

1 |

|'_ Bus Clock
) Freqg () Divider
1 [kHz |~
y v w
IMO ILO HXTAL3ZkH= ETAL FLL_oUT MASTEE CLE BUS_CLE (CFII)
[ oK } | cea |
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WRITING FIRMWARE

» Open main.c from Workspace Explorer
> Insert the following code in main()

SFRPRT2SEL | = 0xFF; / / enables the control of the port
#pragma asm

loop:

mov A, SFRPRT2PS ; 1 Clock Reads the value of port2

inc A ;1 Clock Adds 1

mov SFRPRT2DR, A ; 1 Clock Writes to port2

REPT 992 ; delay for 992 clock cycles

NOP ; 17992=992 Clock Cycles

ENDM

jmp loop ; 5 clock

#pragma endasm

/* the clock frequency is set to 1kHz. The above code is an infinite loop. Every
cycle takes 1000 cpu clocks to complete i.e 1sec

The initial value of PRT2 is 0. The LED’s are Sinking on PSoC3-003 kit, therefore
the state of LED will be NOT of the value of the Pin.*/

> Allow in-line assembly code in main.c
> Right click main.c and select build settings.
> Under Compiler select Inline Assembly as True

The figures below illustrate the same.

12



Workspace Explorer (L pr..» & X

Start Page
o | 17l
B Workspace ‘Lab1A (1 Proj » 181 &
=1 3] Project Lab1A'[CY | =
18" TopDesigr.cysch E f‘:'
P LablA cydwr s &
=) Hezder Files o =4
i H A |
_5] device b 153 sull
=) Source Files g - |
L o] = 3|
=4 Gererg Open
B0 PS | CompileFile  Ctrl+F6
=T
- Y Cut Chrl+ X
|53 Copy Cirl=C
| 3| Delete Del
Exclude
Rename F2
| Build Settings..
L.;‘—:I Properties...

Build Settings

Configuration: Debug “ Toolchain: DP2051 Keil .16 w |
= main.c A
- General i True )
=8 Campiler Integer Prormation ~ Fake
General E General
Optimization Additional Include Directories
- Cammand Line Browse Infarmation Falze E
Float Fuzzy 3
Generate Debugging Information True
Preprocessor Definitions
WWarning Level 2 —
E Listing File
Azzembly Code Listing True w

Inline Assembly
Enables inline azzembly [SRC). This should only be done oh a file by file basis.

MO LARGE MODDP2 OMF2 VB[] PRI$40utputDirt/$4CompileFils}.lst) CO DB MOIP
SRC OT(0, Size) IMCDIR[Generated_Source/PSoC3)
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PROGRAMMING THE PSoC

» Connect the PSoC3-003 kit to the computer using the USB cable. Burn the code

by pressing Ctrl+F5 or the Program button. "
» Reconnect the PSoC3-003 kit to the computer or connect to battery separately.

Pass | LED4(P2.3)| LED3(P2.2)| LED2(P2.1)| LED1(P2.0)
Start 0 0 0 0
Tst 0 0 0 1
2nd 0 0 1 0
3rd 0 0 1 1
4th 0 1 0 0
5th 0 1 0 1
6th 0 1 1 0
7th 0 1 1 1
8th 1 0 0 0
9th 1 0 0 1
10th 1 0 1 0
11th 1 0 1 1
12th 1 1 0 0
13th 1 1 0 1
14th 1 1 1 0
15th 1 1 1 1
16th 0 0 0 0
17th 0 0 0 1
18th 0 0 1 0
19th 0 0 1 1
20th 0 1 0 0
TESTING YOUR DESIGN

» You can adjust the output frequency at pins by adjusting the CPU_Clk and the
number of NOP commands.



GPIO DRIVE MODES
GPIO DRIVE MODE-ANALOG

OBJECTIVE

To get familiar with the general purpose I/O analog drive mode.

REQUIRED MATERIALS

1. PSoC 3 (001) board
2. Cathode Ray Oscilloscope (CRO).

RELATED REFERENCE MATERIAL

1. Schematic of the 001 board

OVERVIEW

Input -output pins commonly known as I/O are the doors by which the PSoC sends
and receives information from the external world. I/O can be of many types but the
PSoC 3 uses General Purpose I/ O or GPIO which can be used for all purposes. These
GPIOs have different drive modes. In this exercise we examine the analog drive mode
where we use an accelerometer to provide the analog input.

15



HARDWARE CONFIGURATIONS

» Open PSoC Creator and start “Create new project”.

> Select “Empty PSoC3 Design”. Name the Project “Lab_DM_Analog”
» Make sure that the window “TopDesign.cysch ” is open.
» From Component Catalog->Ports and Pins, select Analog Pin. Drag and Drop it
in the grid. Make a copy of it. Connect them using the Wire Tool. Name them as
o acc_input
o acc_output

Analog.cydwr | v d b X

i

;
§
g

acc_input o — ﬂ e

E ...... iﬂ Digital Inpt Pin [v1.20]
m Iﬂ Digital Cutput Pin [w1.20]

acc output o —

16



ASSIGNING PINS

» Go to Lab_DM_Analog.cydwr->Pins from the Workspace Explorer. On the right
hand side of the window in front of
o acc_input, select P3[5]. (P3[5] is x-input from the accelerometer on PSoC3-
003 kit)
o acc_output, select P6[0]. (P6[0] is a free pin on PSoC3-003 kit.)

Alias Name Fin L
acc_input P3[5] il
acc_output | P&[0] il

» Press Shift+F6 or the Build Button to Build the hex file for the project.

PROGRAMMING THE PSoC

» Connect the PSoC3-003 kit to the computer using the USB cable. Burn the code
by pressing Ctrl+F5 or the Program button. "

TESTING YOUR DESIGN

» Reconnect the PSoC3-003 kit to the computer or connect to battery separately.
» Connect the CRO to P3[5].

> Rotate the kit along the x-axis and observe the output on the CRO.
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GPIO DRIVE MODES
GPIO DRIVE MODE-STRONG

OBJECTIVE

To get familiar with the general purpose I/O strong drive mode.

REQUIRED MATERIALS

1. PSoC 3 (001) board

RELATED REFERENCE MATERIAL

1. Schematic of the 001 board

OVERVIEW

Input -output pins commonly known as I/O are the doors by which the PSoC sends
and receives information from the external world. I/O can be of many types but the
PSoC 3 uses General Purpose I/ O or GPIO which can be used for all purposes. These
GPIOs have different drive modes. In this exercise we examine the strong drive mode
where we use I/O’s to drive LEDs. The strong mode is asserted through software.
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HARDWARE CONFIGURATIONS

» Open PSoC Creator and start “Create new project”.

> Name the Project “Lab_DM_Strong”

» Make sure that the window “TopDesign.cysch ” is open.

» From Component Catalog->Ports and Pins, select Digital Output Pin. Drag and
Drop it in the grid. Replicate it 4 times.

> Double Click each pin unselect the HW Connection Box.

+ 4 b x  Component Catalog (f4 c.. v B X/
el IR

[ . 4 3

" Cypress | L

ﬂ Cypress Component Catalog
|+| ﬂ Analog

|+| ﬁ Fitters

—>—0] Pin_1
—>8] Pin_2
—>a] Pin_3
—0/Pin_4

m

ASSIGNING PINS

> Go to Lab_DM_Strong.cydwr->Pins from the Workspace Explorer.
> Assign pins as shown in the screenshot below.

Alias . MName Fin L
Pin_1 | P2[D] .
Pin_2Z | P2[2] .
Din 3 | BE[3] i
Din_ 4 | Ba[0] i

20



WRITING FIRMWARE

» Open main.c from the workspace explorer. Paste the following code
2

Copyright PSoC 3 LABBOOK

All Rights Reserved

UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

K e _____

*/

ok X X X X %

#include <device.h>

void main ()

{

//

SFRPRT4SEL |= 0x01; //enable SFR access for P4[0]

Pin 1 SetDriveMode (Pin 1 DM STRONG);//Change DM of P2[0] to Strong
Pin 2 SetDriveMode (Pin 2 DM STRONG);//Change DM of P2[2] to Strong

CyPins SetPinDriveMode (Pin 3 0,PIN DM STRONG); //Change DM of P2[3] to
Strong//

CyPins SetPinDriveMode (Pin 4 0,PIN DM STRONG); //Change DM of P4[0] to
Strong

//

for(;;)

{

/*

There are 3 ways to access GPIO's in Creator

a:Using Per-Pin API i.e. CyPins ///Slowest///

b:Using Component APIs i.e Pin x (Using Pin x DR or Pin x Write)
c:Using SFR register space i.e SFRPRT ///Fastest///

In the following code each pin is toggled.

*/

CyDelay (500); //500ms delay

if (!CyPins ReadPin(Pin 1 0)) CyPins SetPin(Pin 1 0);
else CyPins ClearPin(Pin_ 1 0);

CyDelay (500) ;

Pin 2 Write (! (Pin 2 Read()));

CyDelay (500) ;

if (Pin 3 PS==Pin 3 MASK) Pin 3 DR &= ~Pin 3 MASK;

else Pin 3 DR |= Pin 3 MASK;
CyDelay (500) ;
SFRPRT4DR = (! (SFRPRT4PS)) ;

21



PROGRAMMING THE PSoC

» Press Shift+F6 or the Build Button to Build the hex file for the project. -

» Connect the PSoC3-003 kit to the computer using the USB cable. Burn the code by pressing
Ctrl+F5 or the Program button. £

TESTING YOUR DESIGN

» Reconnect the PSoC3-003 kit to the computer or connect to battery separately and observe
the LEDs.

22



INTERRUPTS
INTERRUPT EXERCISE
OBJECTIVE

To become familiar with the interrupts of PSoC 3 and learn how to use them.

REQUIRED MATERIALS

1. PSoC 3 (001) board

RELATED REFERENCE MATERIAL

1. Control Register Component Data Sheet
2. Sleep Timer Component Data Sheet.

OVERVIEW

Polling may not be the most efficient technique of performing various operations on a
PSoC 3. Interrupts come in handy when one doesn’t know when an event is likely to
occur. This exercise focuses on interrupts and how to use them on a PSoc 3. We use a
sleep timer to generate the interrupts.

23



HARDWARE CONFIGURATIONS

» Open PSoC Creator and start “Create new project”.

» Name the Project “lab_interrupt”.
> Make sure that the window “TopDesign.cysch ” is open.
» From Component Catalog->Ports and Pins, select two Digital Output Pin.blocks.

Drag and Drop them in the grid. Name them Port2 and Port4.
» Insert a NOT gate from Digital->Logic. Make its width 8.
» Insert a Control Register block from Digital->Register. Name it LED.
o Step(4-7): Follow steps as given in http:/ /www.planetpsoc.com/psoc3-

videos-how-to-videos/78-connecting-a-multiple-wired-bus-in-psoc-

creator.html

LED
Control B

contral O
control 1
control 2
conirol_3
control 4
control_5
conirol_E
control 7

—[ﬁh?ll:'nrti

[7:0) &c (7:01

r.n--mLA-:i
1

Wh?‘lﬁ:ﬂ#

'T-FL
i -

> Insert a SleepTimer from System>Sleep Timer. Name the sleep timer as
“SleepTimer” and let the isr be “isr_1”. Double click on the component and set
the WakeUplInterval to 512ms.

SleapnTirmer
Elaap%m
intamuptf——f | iz 1

128 ms

24



Wake up interval me /| Enable Slesp Timer intamupt

This component is not responsible for device's low power modes entry. Refer
to “System Reference Guide” for proper usage of power manager APls, these f
ones are responsiole for switching device to the low power modes. E

The firstinterval can range from 1to (selected interval + 1) milliseconds.
Additional intervals occur at the nominal period.

e Insert a Digital Input Pin. Set the Drive Mode as Resistive PullUp/Down. Set

Interrupt as Rising Edge as shown in the two screenshots below.

Hame: Fi'[_‘||

Pins | Mapping | Reset | Buitin |
NumberofPinz 1 | B + 4| I |
[&l Pins] - Type General | Input | Output |
- [ Bl Dvive Mods nitial Stats:
[ Resistive Pull Up,/Down
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Pins | Mapping = Reset | Builtin |
NumberofPinz 1 | % B + & | ¢
Al Pins] z‘Tml/m/hput}"oumutl
[m ﬁ‘.r] | Hysteresis

mmm

LB Pn_i_D

["] Hot Swap
[¥] Input Buffer Enabled
[] Input Synchronized

> Insert a interrupt block from System>Interrupt and name it as “isr_2”. Connect it
to Pin_1 as follows.

Pin_1
Pins
Do
irg | ~ lisr 2
» The complete schematic should look as shown in the screenshot below.
Pin_1
[ Pins |
o=y
g | —==]isr_2

1 —w—v{z] Pin_2
[0
[7:0] [7:0]
[5] —W';i‘—‘ {1 Pin_4
" - E’  §
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ASSIGNING PINS

> Open lab_interrupt.cydwr->Pins.

> Set the pin configurations as shown in the figure below

Alias Mame Fin
Din_4[3:0] | P4[3:0]
Pin_2[3:0] | P2[3:0]

Din 1 P15 [3]

» Open lab_interrupt.cydwr->Interrupts.

> Set the isr priorities as shown in the figure below.

Start Page ]/"'I'npDesjgn.cysﬁ ]/main.c/V lab_interrupt.cydwr |

isr_2

Instance Mame Prionty

EINE

ESZ Patch = Vector
|13

1sr_1

ONE

GINE=
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WRITING FIRMWARE

» Open main.c from Workspace Explorer

A\

Insert the following code in main.c

~
*

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

D T T .

*

*
~

#include <device.h>
uint8 i=0;

CY ISR(sleep)

{
LED7Write(i++);
SleepTimer GetStatus();

}

CY ISR(button)

{
1i=0x05;
LED Write(i);
Pin 1 ClearInterrupt();

void main ()

{
CYGlobalIntDisable;

isr 1 Start();
isr 1 SetVector (sleep);
isr 2 Start();
isr 2 SetVector (button);
SleepTimer EnablelInt();

CYGlobalIntEnable;

SleepTimer Start();
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PROGRAMMING THE PSoC

» Press Shift+F6 or the Build Button to Build the hex file for the project.
» Connect the PSoC3-003 kit to the computer using the USB cable. Burn the code by

pressing Ctrl+F5 or the Program button. £l

TESTING YOUR DESIGN

> Reset the kit. The LED’s will show the current status of “I”. If the button is pressed
then I will be set to 0x05 and the count will begin from there.
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LCD
DISPLAY USING AN LCD

OBJECTIVE
To learn interfacing an LCD with PSoC 3 and display on it.
REQUIRED MATERIALS

1. PSoC 3 (001) board, character LCD (14 pin).

RELATED REFERENCE MATERIAL

1. Character LCD Component Data Sheet

OVERVIEW

LCD’s are fundamentally the easiest form of character and bar-graph display. LCDs
come in many forms but the most common ones continue to be the DOT MATRIX
LCDs. Here, we learn how to interface an LCD with a PSoC 3 and display text on it. The
LCD we use is a 16 pin LCD from Hitachi which comes along with an eval(3210) kit or a
DVK board(003).
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HARDWARE CONFIGURATIONS

» Open PSoC Creator and start “Create new project”.

Y

Name the Project “LAB_LCD”.

> Make sure that the window “TopDesign.cysch ” is open.

» From Component Catalog->Display, select Character LCD. Drag and Drop it in

the grid.

LCD Char 1

T ———
I RV

4 3
Cypress q P
itwﬂmmiﬂﬁﬂhﬂ
+- 48 Analog
+-g§ CapSense
+-168 Communications
+-ig Digital
=% Display
 <S] Crarcter LCONIIDD |
------ o] Segment LCD - Static [v1
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ASSIGNING PINS

» Go to LAB_ LCD.cydwr->Pins from the Workspace Explorer. On the right hand
side of the window in front of LCD_CHAR_1[6:0], select P6[6:0]. (P6[6:0]

correspond to 7 GPIO pins on the PSoC3-003 Kit).

» Connect the Hitachi LCD to the kit according to the following pin out.

Port Pin LCD Component Pin Description
P6_0 DB4 Data Bit 0
P6_1 DB5 Data Bit 1
P6_2 DB6 Data Bit 2
P6_3 DB7 Data Bit 3
P6_4 E LCD Enable
P6_5 RS Register Select
P6_6 R/'W Read/not Write

+5V
o
Hitachi
Compatable
LCD
M -1. VVss
-2. Vecec
-3. Vee
10k
. -4. RS
— -5. R/IW
-6. E
Coeteor Z ™-11. DB4
-12. DB5
-13. DB6
-14. DB7Y
Alias Name Fin Lox
AWLCD Char 1:LCDPorth [€:0] | Pele:z0] hd E
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WRITING FIRMWARE

Y

~
*

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

ADITYA YADAV
ASHWATH KRISHNAN

o S T S

*

*
~

#include <device.h>
#include "LCD Char 1.h"

uint8 i=0;

void main ()
{
LCD Char 1 Start();
LCD Char 1 Position(0, 0);
LCD Char 1 PrintString("Hello World");

for(;:)

{
CyDelay (1000) ;
LCD Char 1 Position(1l, 0);
LCD Char 1 PrintNumber (i) ;
it+; -

Open main.c from Workspace Explorer. Insert the following code.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO

//Positions the cursor
/*Prints the null terminated
string Hello World at (0,0)*/

//1 sec Delay

//Prints the value of i
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PROGRAMMING THE PSoC

» Press Shift+F6 or the Build Button to Build the hex file for the project. L
» Connect the PSoC3-003 kit to the computer using the USB cable. Burn the code by

pressing Ctrl+F5 or the Program button. £

TESTING YOUR DESIGN

» Reconnect the PSoC3-003 kit to the computer or connect to battery or power supply
separately and observe the LCD.

» If you are using the kit at 3.3V then short the resistor R7 on the LCD.
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BASIC DIGITAL
GETTING FAMILIAR WITH COUNTERS
OBJECTIVE

To familiarize with counters and use them to drive LEDs

REQUIRED MATERIALS
1. PSoC 3 (001) board.

RELATED REFERENCE MATERIAL

1. Counter Component Data Sheet
2. Clock Component Data Sheet

OVERVIEW

A counter is a digital device that increments/ decrements in count from an initial
value specified by the user. The counter can be reset on 4 occasions as required by
the user, namely capture, terminal count, on compare and on reset.

Here we use the counter to blink LEDs based on its period and its compare value.
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HARDWARE CONFIGURATIONS

» Open a new project is PSoC creator 3 BETA

> Select Empty PSoC 3 design and name it bdig.

» Drag and drop 2 counters. By default they are named Counter_1 and Counter_2
Respectively. Double click on them and configure them as shown in the 2
screenshots below.

/" Configure | Advanced | Built-n | 4 b
Resolution: @ 8Bt ) 16Bt (O 24Bt () 328t —3
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@ 8-Bit ) 16-Bit () 24Bt () 32Bit
() Fixed Function @ UDB

Input Frequency Based Calculations:
Period- = 128ns

Max. Period- = 256ms
Bit Resolution: = Ims

e BB

| Up Counter

» From System>Clock, drag and drop a clock component. Double click on it and
configure it to 1 kHz.




» From Ports and Pins>Digital Output Pin drag and drop 2 digital output pins and
rename them as LED1 and LED2.

» Connect the Clock to the Count inputs of both the counters and the LEDs to the
comp output.

> NEVER LEAVE THE RESET OF A COUNTER FLOATING. From the Digital
Logic >Logic 0 drag and drop 2 logic 0 components and tie them to the reset pins.

> Your final schematic should look something like this.

Counter_1

comp +{] LED1
= count
-~———{»clock
[0} —resel interrupt=

8 bit (UDB)

Clock_1 [l _E_Ci_‘“_‘"i‘F’—"‘-'

1 iz

comp 7] LED2

[ count
> clock
reset interruptf-

&bit (UDB)

:

ASSIGNING PINS

> Double click on basic_digital.cydwr and assign pins as shown in the screenshot
below.

Alias  Mame Pin Lock
LED1 | BZ[0] h
LEDZ | PZ2[2] ¥
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WRITING YOUR FIRMWARE

Once this is done double click on main.c and write the following code.

P R T . S

*

*/

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

#include <device.h>

void main ()

{

Clock 1 Start ();

Counter 1 Start ()
Counter 2 Start ()

}

’
’

PROGRAMMING THE PSOC

>

>

Build your project and ensure it is error free.

Plug in the USB Connector and click on the program option. o

TESTING YOUR DESIGN

>

After programming, remove the cable and reconnect it or connect a battery
SEPERATELY.

The 2 LEDs will blink at different frequencies.

Change the Period and Compare Value of the Counter in order to change the rate
of blinking.
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BASIC ANALOG
OPAMPS, ADCs and DACs
OBJECTIVE

Use Data converters to convert analog data to digital and vice versa

REQUIRED MATERIALS

1. PSoC 3 (001) board, LCD.
2. Cathode Ray Oscilloscope (CRO)

RELATED REFERENCE MATERIAL

1. VDACS8 Component Data Sheet
2. Delta Sigma ADC Component Data Sheet
3. Opamp Data Sheet

OVERVIEW

Most real life signals are analog. However, processing them in the analog domain
may not be easy. So data converters are used to change data from analog form to
digital and vice versa.

Operational amplifiers are fundamental building blocks of most analog devices. So
familiarizing with them will also be useful. In this exercise we use opamps in a
voltage buffer configuration.
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HARDWARE CONFIGURATIONS

» Open a new project is PSoC creator 3

> Name the project as basic_analog.

» From the Analog components-> ADC-> Delta Sigma ADC has to be dragged and
dropped. Double click on it and configure it as shown in the following
screenshots. (Continuous mode, 16 bit resolution and internal clock)

Mame:  ADC_DelSig 1

Configure | Built-n |
Corfig 1 | Config 2 | Corfig 3 | Config 4 | Common|
Sampling
Conwersion Mode  |2-Conlinuous  v|  #Corfige 4 3
ot [B__] e
Conwversion Rate 10000 %+ SPS Range [ 2000 - 48000 5P5 ]
Clock Frequency  640.000 .H-h
Input Options
input Mode @ Differertisl ' Single
Input Range | +/-1.024V {nput +/- Viei } v
BfferGain (1 w| Buffer Mode [Raito Ral -
Reference
Vref | Intemal 1.024 Volis »] [10240 | Vohs
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Configure | Builtin |

| Config 1 | Config 2 | Corfig 3 | Config 4| Common |

Hardware SOC [Start of Canversion]

Clack Source

| Low Power Charge Pump

Enable_Wref_Vssa
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> From the Analog components-> DAC-> VDACS has to be dragged and dropped.
Double click on it and configure it as follows.

Name: VDACE 1

Configure | Buitin 4 b
VDAC &
OutPut Range Speed
@ 0-1.020V@mV /bit) -
@ Slow () Fast
() D-4.080V(16EmV / bit)
E
Value [iataSource
400 = mivoks ~ CPUorDMA Data E »
- S bytes ®
StrobaMode
H‘?W’me Register Write d -

» From Ports and Pins>Analog Pin and rename it DAC_Out.

» Add a character LCD from Display>Character LCD.

» From Analog> Opamp add an opamp and connect it in the non inverting voltage

buffer configuration.
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» From Analog>VRef add a VRef and configure it as follows.

Mame:  TREM

/ Wasic | Advanced | it |

VRef Name: |Vssa (GND)

> Make the necessary connections. Your final Schematic should look like this.

VDACS 1

VDACS

__

LCD=Char4

——[x] DAC_Out Character LCD
ADC_DelSig 1
Opamp 1 ~u -
Opamp ADC_DaISig_

eoc-

=

16-bit

~[Vref|Vssa (GND)
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ASSIGNING PINS

> Double click on basic_analog.cydwr and assign pins as shown in the screenshot

below.
Alias MName Fin Lock
A\ICD Char 1:LCDPorty[€:-0] | PO[&-0] -
DAC Out P4[0] v

WRITING YOUR FIRMWARE

> Once this is done double click on main.c and write the following code.

~

N . S S S S S I S

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

*

#include <device.h>
byte ADC Result=0
void main ()
{
LCD Char 1 Start();
VDAC8 1 Start();
Opamp_1 Start();
ADC Delsig 1 Start();
VDAC8 SetValue (100);// This is the value you are feeding into the DAC.
ADC Delsig StartConvert();
while (ADC Delsig IsEnfConversion (ADC WAIT FOR RESULT) !=0)
{
ADC Result=ADC Delsig GetResult();
LCD_Char_1_Position(0, 0);
LCD_Char_1_PrintNumber(ADC_Result);
}

// ADC_Result contains the value after analog to digital conversion.

45



PROGRAMMING THE PSOC

» Build your project and ensure that it is error free.

» Plug in the USB Connector and click on the program option. £

TESTING YOUR DESIGN

» Monitor the value from the ADC using an LCD and compare it with the value fed
into the DAC. Ideally, they should be the same.

» The output of a DAC can also be monitored on the LED at Pin 4[0] or probed
onto a CRO.

» Use a “for” loop to continuously increment the value fed into the DAC. Does the
ADC return the correct value?

» If there is a difference in the value fed into the DAC and the value returned by
the ADC, what might the possible reason be?

» Change the resolution of the ADC and retest your design.
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ANALOG AND DIGITAL INTERFACING
THE ADC AND PWM INTERFACE

OBJECTIVE

To develop a servo motor controller driven by a potentiometer by interfacing the ADC
component with a PWM.

REQUIRED MATERIALS

1. PSoC 3 (001) board along with a character LCD
2. A servo motor
3. A potentiometer

REQUIRED EQUIPMENT

1. Cathode Ray Oscilloscope(CRO)

RELATED REFERENCE MATERIAL

1. Delta Sigma ADC Component Data Sheet
2. PWM Component Data Sheet
3. Clock Component Data Sheet

OVERVIEW

Most real world signals are analog. However, since they are continuously changing it is
difficult to perform complex operations with them. The digital domain is easier to
operate on and storing signals is easier.

This experiment elaborates on taking a real world analog signal (from the
potentiometer), transforming it into digital and driving a servo motor using the
converted signal (using a PWM).

It also illustrates the ease of interfacing the analog and digital Components on a PSoC 3.
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HARDWARE CONFIGURATIONS

» Start a New Project. Open PSoC Creator and start “Create new project”.

» Name the Project “ADC_PWM”.

» Add a ADC Delta Sigma Component

ADC

ADC DelSig _

8-bit
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» Configure it as follows

Mame-
Configure | Built-n 4 b
Modes Start of Conversion -
Power | Hiah Paer v © Software
Conversion Mods | Simaus - " Herdwars
Reshbon (8. v Clock Source
Conwersion Rate | 10000 k| SPS @ Intemal
Clock Frequency 160000 kHz  Bdemdl =
Input
Input Rangs | 33342 33 Singls Ended) -
Reference | intemal Vief 1
| input Buffer Gain | 1 ~| _
| VotageReference [SS000 i3 Vols Veda) -1
| Datashest | 0K Reply Cancel

» Connect an Analog Output Pin to the ADC Input. Name it pot.

pot (o]

|HLJ"L.-L

» Add a PWM Component to the project. Name it PWM
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g% Analog

%% CapSense

%% Communications
=-&g Digial

=% Functions

----- Counter [v1.20]
----- CRC [v1.20]
----- PriSM [w1.20]
----- PRS [v1.20]
< %] PWM[v1.10] B
----- %] Guadrature Decoder
----- [#] Shift Register [v1.20—
----- @ Timer [v1.20]

- Logic

. Zm Ranictars

m

Name:
Configure | Advanced | Builtn |
perod | #1833

» The Clock and the Period are set such that the Period of the PWM O/ P should be

20ms.
» Connect the following peripherals to the PWM block Configure each as shown
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o Clock - from System> Clock to be connected to PWM clock
o Configure it as shown in the screenshot below

Cypress |

...... PWM [v2.0]

i[#] Quadrature Decod
..... [#] Shift Register [v1.¢

© |2} Timer v2.01

@ Logic

%% Registers

- Control Register [v

Lg% Display
[+-f3g Filters

[#-& Ports and Fins
@8 System

Clock [w1.500
..... [#| Die Temperature [v1.5
..... [¢] DMA [w1.50]

..... [¢] EEPROM [w1.50]

..... El Intemupt [w1.50]

..... [<] RTC [w1.60]
..... |2} SleepTimer [v1.60]
..... El Sync
..... [¢] UDBCEn
-

Name-

Source: =l

Configure Clock | Advanced | Buitin |

Specify: @ Freguency 10

PWM reset
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o Digital Output pin to PWM output which is renamed as pulse.

» Add an LCD_Char Component and name it as LCD.
» The final schematic should look as shown in the screenshot below.

Clock

Py

Cypress ]

..... [¢] PWM [v2.0]
----- |£| Quadrature Decod

..... [¢] And

----- [¢] Bufoe [v1.10]
----- [#] D Aip Aop [v1.20]
----- [#] De-Multiplexer

----- i Qg High "1"

----- Lookup Table [v1.
----- [¢] Multiplexer

----- [¢] Nand

----- [#] Mor

..... [¢] Mot

..... [¢] or

----- [¢] Wirtual Mue

..... [#] *nor

..... [¢] ¥or

.[%] Control Redister [v

1|

T | ;

> elock

prvm |

bt

_——[F] pulse

LCD

Character LCD]

pot [T]
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WRITING YOUR FIRMWARE

» Double click on main.c and write the following code.
A

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

%k ok o X X X %

*

*/

#include <device.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

uint8 get width(uint8 wvolt);

void main ()

{
uint8 Potential,Width,LCD OutputString;

Clock Enable();

PWM Start();
ADC Start();
LCD Start();
LCD_Position(0,0);
LCD_PrintString("Servo Pos:");
for(;;)

ADC StartConvert () ;
ADC IsEndConversion (ADC _WAIT FOR RESULT) ;
Potential=ADC GetResult8();
Width=get width (Potential);

if ((Width >9) & ( wWwidth <20)) LCD OutputString= Width +6;
else if (Width >19) LCD OutputString= Width +12;
else LCD OutputString= Width;

LCD Position(0,10);

LCD PrintInt8 (LCD OutputString);
PWM WriteCompare (Width) ;

uint8 get width (uint8 wvolt)

if (volt<0x0C) return 5; //12 0x0C
else if (volt<0x19) return 6; //25 0x19
else if (volt<0x26) return 7; //38 0x26
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else if (volt<0x32) return 8; //50 0x32
else if (volt<0x3e) return 9; //62 0x3e
else if (volt<0x4B) return 10; //75 0x4b
else if (volt<0x57) return 11; //87 0x57
else if (volt<0x64) return 12; //100 0x64
else if (volt<0x70) return 13; //112 0x70
else if (volt<0x7D) return 14; //125 0x7d
else if (volt<0x89) return 15; //137 0x89
else if (volt<0x96) return 16; //150 0x96
else if (volt<0xA2) return 17; //162 0xA2
else if (volt<0xAF) return 18; //175 OxAF
else if (volt<0xBB) return 19; //187 0xBB
else if (volt<0xC8) return 20; //200 0xC8
else 1if (volt<0xD4) return 21; //212 0xD4
else if (volt<0xEl) return 22; //225 0xEl
else if (volt<0xED) return 23; //237 0xED
else if (volt<0xFA) return 24; //250 OxFA
else if (volt>0xFA) return 25; //250 OxFA

}

/* [] END OF FILE */

ASSIGNING PINS

> Configure the PinOuts as shown in the screenshot below.

i R

Alias M armne Fin Lock,
pulse POLY] bt

pot PE[7] v

W LCD: LCDParty [6:0] | PZ[6:0] v

PROGRAMMING THE PSOC

» Build the code and ensure it error free.

» Plug in the USB Connector and click on the program option. o



TESTING YOUR DESIGN

» Connect the potentiometer to Pin2_7 and the output of the PWM i.e. Pin0_7 to an
LED, the control pin of the servo motor and to the input of a CRO.

» The motor should move depending on the position of the potentiometer.

» On the CRO the duty cycle of the PWM should vary as the position of the
potentiometer is varied.

55



UART
THE UART INTERFACE

OBJECTIVE

To use the UART interface on the PSoC 3 to switch an electric lamp using a computer.

REQUIRED MATERIALS
1. PSoC 3 (001) board.
2. A5Vrelay
3. An electric lamp(or any other switch controlled appliance)
4. A computer with a serial port and a terminal

RELATED REFERENCE MATERIAL

1. UART Component Data Sheet
2. Internal diagram of the 5V relay used.

OVERVIEW

UART short for Universal Asynchronous Receiver Transmitter is a hardware which can
interchange serial and parallel data. Its operation is essentially 2 step. At the transmitter
end, data is broken into individual bits and transmitted. At the receiver end, the data is

reassembled. Error correction is taken care of at the receiver end.

The UART can easily be interfaced with other standard communication devices. This
experiment will demonstrate the above idea by using a computer command to drive a
relay. The relay in turn will toggle a switch controlled appliance.
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HARDWARE CONFIGURATIONS

» Start a New Project. Open PSoC Creator and start “Create new project”.

> Name the Project “Lab_UART”.

> Make sure that the window “TopDesign.cysch” is open.

» From Component Catalog->Communications, select UART. Drag and Drop it in

the grid.

m

q P

mEwe

na

'-'IHHHI

4k

_ Cypress Component Catalog

+ %8 Anabg
—-%% Communications
..... [#] CAN [w1.300

..... [&] [2C w120
..... [ 125

...... o] USBFS [v1.30]
i+ Digttal

-4 Display
- Fiters

[+-4% Pors and Pins
- System

----- ] SPI Master [v1.20)
------ ¢| 5Pl Slave [v1.20]

ator-001.log

L,

[iata Shest
UART v1 20pdf

Universal Asynchronous Heceiver

Transmitter
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» Configure the UART component with the following properties.

Mame: UART

- Configure '~ Advanced | Builtin |
Clack Selection:
@ Intemal Clock 7 Bdemal Clack

Intemupts
Intemial B Intemupt 1SR iz disabled

Intemal TX Intemupt 1SR iz disabled

[¥] BX-On Byte Received
R - On Parity Emor
["] RX-On Stop Emor

R - On Break

RX - On Ovemun Emor

7] T%-On TX Complete
] TX - On FIFQ Empty
["] TX-On FIFO Full

[] TX - On FIFO Mat Ful

= P R T
1

| Datasheat |
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» Add the following components to the UART

UART
UART
rx ofe—rx te—+{o] tx
tx_interrupt=]
rx_interrupt isr 1
[0 }reset

o A Digital I/P pin to the tx Input

o A Digital O/P pin to the tx output

o The interrupt generated by the UART should be received by “isr_1".
» Add two Digital O/P pins to the TopDesign. Name them Pin_1 and Pin_2

1 Pin

a! Pin_

1
2

o Pin_1 is the Output pin to the Electric Lamp which is connected via a 5V

relay
o Pin_2 is connected to

LED.

» Add a character LCD component from Display> Character LCD and rename it as

LCD Char 1.
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WRITING YOUR FIRMWARE

» Open main.c and insert the following code.

2 B —————

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

b . S R

*

*
~

#include <device.h>
#include "LCD Char 1.h"

uint8 i, confirmed;
CY ISR(routinel)

{
uint8 status;
uint8 buffer;
L1777 777777777777777777
Pin 1 Write(! ((Pin_1 Read()&0x01)==0x01));
Pin 2 Write (! ((Pin_2 Read() &0x01)==0x01));
[17777777777777777777777
UART GetChar();
buffer=UART GetChar () ;
UART ClearRxbuffer();

if (! ((Pin_1 Read()&0x01)==0x01))
UART PutString("Press any key to turn off the Lamp");
else

UART PutString("Press any key to to turn on the Lamp");

UART_PutCRLF();

UART_PutCRLF();

LCD Char 1 Position(1l, 0);

LCD Char 1 PrintString(&buffer);

LCD Char 1 Position(l, 10);
LCD _Char 1 PrintInt8(buffer);

i4++;
LCD Char 1 Position(0, 10);
LCD Char 1 PrintInt8(i);

isr 1 ClearPending();
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void main ()
{
uint8 i = 0;
LCD Char 1 Start();
LCD Char 1 Position(0, 0);
LCD Char 1 PrintString("Name:");
//UART EnableRxInt ();

UART Start();
isr 1 Start();
isr 1 SetVector (routinel);
CYGlobalIntEnable ;
UART PutString("Press Enter to turn off the Lamp");
while (1)
{
}

ASSIGNING PINS

» Assign the Pins as shown in the screenshot below after opening Lab_UART.cydwr.

Alias M arne Fir Lok,
“LCD_Char 1:LCDPorth [6:0]  PO[E:0] b
tx P1z[3] v
EX PZ[7] W
Pin_1 Pz[0] v
Pin_Z Plz[2] v
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PROGRAMMING THE PSOC

>

>

Build the design and make sure it is error free.

Plug in the USB Connector and click on the program option. "

TESTING YOUR DESIGN

>

>

Connect the Computer’s serial port to the PSoC. Connect the Pin Pin_2_0 to the
Relay which is then connected to the lamp.

Ensure that the connections for the relay are correct. Refer the internal diagram if
doubtful. Reversing the connections may blow up the lamp!!!

Turn on the terminal interface. Press a key to toggle the electric lamp with your
computer!!.
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THE WIRELESS INTERFACE
THE WIRELESS INTERFACE

OBJECTIVE

To develop a wireless switch using the PSoC 3

REQUIRED MATERIALS

1. PSoC 3 (001) board.
2. Artaflex wireless modules (CYRF 7936)

RELATED REFERENCE MATERIAL
1. SPI Component Data Sheet.

OVERVIEW

Wireless applications have become an integral part of appliances today. The need is for
low power long range wireless components. This experiment focuses on developing a
wireless switch with a range of about 20m.
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HARDWARE CONFIGURATIONS

» Start a New Project. Open PSoC Creator and start “Create new project”.
> Name the Project “Wireless_Transmit”.

» Add an SPIM component to the Project from Communications>SPI Master.

TITT
Cypress q I
' Cypress Component Catalog
#-%@ Analog ¥
= 68 Communicaions

¥.

----- #] EZ12C Slave [v1.20]
..... £| 12C pel.200
..... [#] 125

m

----- [#| SPISlave [v1.200
----- (®| UART [v1.20]

..... ;£| ISBFS [v1.300
- Digital

98 Display -

(|

» Configure the SPIM Block as shown in the screenshot below.




» Connect the following peripherals to the SPIM Block.
e Two Digital O/P pins (RST and SS)
e Two Digital O/P pins (MISO and SCK) each connected to MISO and SCK of
the SPIM block
e A Digital I/P pin as MOSI to the MOSI /P of the SPIM block
e Connect Logic 0 to the Reset I/P.

—{ii| RST

—{E] 55

» For each Pin Unselect Output Sync box.

Cra )

Mame: ack

W | Magging | Remet | Bt |

NumberofPins: 1 | % & ¢ &[5 o |

fianPnsl . Tye | General | input) Output |

s o i

Do Lo
Cument  [4mA source, 8mA sink -

<] Output Synchronized —>
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» Save this as “Transmit” and another of the same project as “Receive”. Continue with

the “Transmit” project.

HARDWARE CONFIGURATIONS (TRANSMITTER)

» Add a Digital O/P and Digital I/P to the project and name them as butt_in and

butt_out.

Bt e [0 ——

—+{1] butt_out

» Add a character LCD Component from Display>Character LCD.

WRITING YOUR FIRMWARE (TRANSMITTER)

> Write the following code in the main.c

P . . S

*

*
~

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

#include <device.h>
#include <lpregs.h>
#include <radio.h>
#include <radio fn.h>

void main ()

{

unsigned char Status = 0;

uint8 buff, out;

LCD Start();

SPIM Start();

MyRadioHWReset (); //MyRadioWrite (0x1D,0x00); //Reset in SW

CyDelay (100) ;
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[/ 77777 7777777777777 77777777777777777777

//Write data=0x45 to Tx buffer

WritePayloadToRadio (0x01) ;

MyRadioWrite (TX CTRL ADR,TX GO);//TX CTRL ADR,TX GO

CyDelay (100);//wait

//Setting To idle mode

MyRadioWrite (TX_CTRL_ADR,TX CLR);//TX_CTRL ADR,clear TX BUFFER
CyDelay (100);//wait

JIT707 0707777777777 777777777777 777777777

MyRadioInit (DATMODE 64SDR) ;
//Transmit length
MyRadioWrite (TX LENGTH_ ADR, 0x01) ;

LCD Position(0,0);LCD PrintString("CH:");LCD Position (0, 3);
LCD PrintInt8 (MyRadioGetChannel()) ;

for(;:)
{
CyDelay (100) ;

if ((butt_in Read() &0x01)==0x01) buff=0x0a;
else buff=0;

out= butt out Read();
if (buff==0x0a) butt out Write (! (out));

MyRadioWrite (TX CTRL ADR,TX CLR);//TX CTRL ADR,clear TX BUFFER
CyDelay (100);//wait

LCD Position(1l,13); LCD PrintInt8 (buff);

WritePayloadToRadio (buff) ; //set to i later
MyRadioWrite (TX CTRL_ADR,TX GO);//TX CTRL_ADR,TX GO

CyDelay (100);//wait

//Setting To idle mode

while (! (( Status = MyRadioRead(TX IRQ STATUS ADR)) & TXC_ IRQ));

» Add the following files to the project
e |pregs.h
e radio.h
e radio_fn.h
e radio.c
e radio_fn.c
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ASSIGNING PINS (TRANSMITTER)

» Assign the PinOuts as shown in the screenshot below.

Alias MName Fin Loc
\LCD:LCDPort\ [6:0] | PO[&:0] *| ¥
55 P5[3] [~ ] i
mosi P12 [0] | i
sck DS[0] v ¥
miszo P1[4] [~ ] v
RST PS[2] ] i
butt_in P15[3] ] i
butt out PZ[0] = i
PROGRAMMING THE PSOC

» Build the design and ensure it is error free

» Plug in the USB Connector and click on the program option. £

» Now Continue with the “Receive” Project we had saved earlier.



HARDWARE CONFIGURATIONS (RECEIVER)

» Add two Digital O/P Pins to the project. Name them as Lamp and Check.

——n] check

—c= 1] [Bmp

» Add a character LCD from Display>LCD and name it as LCD.

WRITING YOUR FIRMWARE (RECEIVER)

> Write the following code in the main.c

/% ======

Ok X X X X X %

*

*
~

#include
#include
#include
#include

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

<device.h>
<lpregs.h>
<radio.h>
<radio_ fn.h>

void main ()

{

uint8 Payload, out;

LCD Start();
SPIM Start();

MyRadioHWReset (); //MyRadioWrite (0x1D,0x00); //Reset in SW
CyDelay (100) ;

MyRadiOInit(DATMODE_64SDR);
//Receive length
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MyRadioWrite (RX LENGTH ADR, 0x01);

[177777777777777777777777777777/77777777777
MyRadioStartReceive () ;

CyDelay (100);//wait

//Setting To idle mode

Payload = MyRadioRead (RX BUFFER _ADR) ;
//MyRadioWrite (RX CTRL ADR,RX CLR);//TX CTRL ADR,clear TX BUFFER
CyDelay (100);//wait

[17777777777777777777777777777777777777777

LCD _Position(0,0);LCD PrintString("CH:");LCD Position(0, 3);
LCD PrintInt8 (MyRadioGetChannel());

for (;;)
{
CyDelay (100) ;
MyRadioStartReceive () ;
CyDelay (100);//wait
//Setting To idle mode
Payload = MyRadioRead (RX BUFFER ADR) ;
//MyRadioWrite (RX_CTRL_ADR,RX CLR);//TX_CTRL_ADR,clear TX_ BUFFER
CyDelay (100);//wait
out= check Read();
if (Payload==0x0a)
{
check Write (! (out));
lamp Write (! (out));

LCD_Position(1l,0);LCD PrintInt8 (Payload);

» Add the following files to the project
e |pregs.h
e radio.h
e radio_fn.h
e radio.c
e radio_fn.c
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ASSIGNING PINS (RECEIVER)

» Assign the PinOuts as follows

Alias MName Fin Loc
\ILCD: LCDPort\ [6:0] | PO[&:0] | ¥
55 DS[3] ] [
mosi P12 [0] [~ ] i
2ok PS[0] [+ ] i
mi=zo P1[4] T E
RST PS[2] [+ ] [
check BZ[0] T E
lamp P12 [2] ] i

PROGRAMMING THE PSOC

» Build the design and ensure it is error free

» Plug in the USB Connector and click on the program option. £

TESTING YOUR DESIGN

» Connect the Artaflex Module to the 12 Pin port.

» Connect the relay which is connected to the lamp to the FT kit

» Now power up both the FT Kkits.

» When the button is pressed on the Tx kit should toggle the LED on the Rx kit and
lamp. The range of the wireless module is approx 20m in Line of Sight.
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CAPSENSE
WIRELESS TOUCH CONTROL FOR APPLIANCES

OBJECTIVE

To understand capsense and use it to develop a wireless touch control for a servo motor.

REQUIRED MATERIALS

1. PSoC 3 (001) boards
2. Servo motor
3. Artaflex wireless modules (CYRF7936).

RELATED REFERENCE MATERIAL

1. SPI Component Data Sheet
2. Capsense Component Data Sheet

OVERVIEW

Touch controlled appliances are becoming an everyday phenomenon. Touch screen phones,
computers and tablets are capturing the markets. The principle behind most of them is capsense, a
technology which will be the focus of this experiment.

Previous experiments dealt with the wireless interface. The wireless interface will be used to
convert a human touch on one PSoC 3 kit to control a servo motor interfaced with another PSoC 3
kit.
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HARDWARE CONFIGURATIONS

» Start a New Project. Open PSoC Creator and start “Create new project”.
> Name the Project “Cap_Transmit”.

HARDWARE CONFIGURATIONS (TRANSMITTER)

» Configure the SPIM Block as follows.

Mame: SPImM
" Configure | Advanced | Builtn |

ss—|
R N op S op
:I:DT = B :I:DJ{
1 hooi §

|

Mode:  [ode §EPOL = 0. CPHA-T)
Diata Bits: E '"3“‘

j os ) os | oe } os |
hos | os | o4 |} o3 |
|

|

Shift Direction: | MSB First -
Bit Rate:

Dats Shest |

» Connect the following peripherals to the SPIM Block as shown below.
Two Digital O/P pins (RST and SS)

Two Digital O/P pins (MISO and SCK) each connected to MISO and SCK of the SPIM block
A Digital I/P pin as MOSI to the MOSI 1/ P of the SPIM block
Connect Logic 0 to the the Reset I/P.

(@]

(@]

(@]
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—[E] S8

» For each Pin Unselect Output Sync box.

T'g:-c Iz.ﬁﬂ'ﬂﬂ | 'Input/w]

sewPate
et

Current: [M Bmé sink -

T O o>

» Save this as “Transmit” and another copy also as “Capsense_Receive”. Continue with the

“Capsense _Transmit” project.
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» Add a Capsense component from Capsense>Capsense

- CapSenseSlider

CapSense

Zaarial

I e i it |

--ﬁ Anzlog

£ CapSense
f#-%§ Communications
- Digital

(-8 Display

-3 Fiters

Elﬁ Ports and Pins

- {8 Analog Pin [v1.20]

» Configure the Capsense component as shown in the screenshots below.

= 5} Digtal Bidirectional Pin [
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» Add 8 LEDs and connect them to the pins as shown.

LED

(7.0

Ec .I'-'ﬂ

» Add a LCD component from Display>Character LCD.
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» The final schematic for the transmitter should look as shown in the screenshot below.

g0 [0~ —{mi

@

LCD

Character LCD)

Ca l.iauanﬁr.Iur

‘_ImiL J7Pin_2

4 (7

» Add the following files to the project

Ipregs.h
radio.h
radio_fn.h
radio.c

radio_fn.c

Ebo [

Imr-f»;mn 4
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WRITING FIRMWARE (TRANSMITTER)

» DPaste the following code in main.c

~
*

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

P T R

*

*
~

#include <device.h>
#include <lpregs.h>
#include <radio.h>
#include <radio fn.h>

#define NUM_LED (3)

uint8 CentroidPosition=0xFF;
uint8 LedData=0;

uint8 TempVar=0;

void hardware init (void);
void wireless init (void);
void wireless send data(uint8 payload);
uint8 slider data(void);

uint8 get width (uint8 wvolt);

void main ()

{

uint8 payload;
uint8 adc_pot=0;

hardware init();
wireless init();

CYGlobalIntEnable;
CapSenseSlider Start();
CapSenseSlider CSHL InitializeAllBaselines();

LCD _Position(0,0);LCD PrintString("CH:");LCD Position (0, 3);
LCD PrintInt8 (MyRadioGetChannel());

for(;;)

{

adc_pot=slider data();
payload=get width (adc_pot);

LED Write (payload);
wireless send data (payload);

//LCD Position(1,13); LCD PrintInt8(adc pot);



//wireless send data(adc_pot);
}
}

uint8 get width (uint8 wvolt)
{

if (volt<0x03) return 5; //03 0x0C
else if (volt<0x06) return 6; //06 0x19
else if (volt<0x09) return 7; //09 0x26
else 1f (volt<0x0C) return 8; //12 0x32

else if (volt<0x0F) return 9; //15 0x3e
else if (volt<0xl1l2) return 10; //18 0x4b
else if (volt<0x15) return 11; //21 0x57
else if (volt<0x18) return 12; //24 0x64
else if (volt<0x1B) return 13; //27 0x70
else if (volt<0xlE) return 14; //30 0x7d
else if (volt<0x21l) return 15; //33 0x89
else if (volt<0x24) return 16; //36 0x96
else if (volt<0x27) return 17; //39 0xA2
else if (volt<0x2A) return 18; //42 OxAF
else if (volt<0x2D) return 19; //45 0xBB
else if (volt<0x30) return 20; //48 0xCS8
else if (volt<0x33) return 21; //51 0xD4
else if (volt<0x36) return 22; //54 0xEL
else if (volt<0x39) return 23; //57 0xED
else if (volt<0x3C) return 24; //60 OxFA
else if (volt>=0x3C) return 25; //60 OxFA

}

uint8 slider data(void)

{

CapSenseSlider CSD ScanAllSlots();
CapSenseSlider CSHL UpdateAllBaselines();

/* Get Centroid position of the finger on the slider */
CentroidPosition =
(uint8)CapSenseSlider CSHL GetCentroidPos (CapSenseSlider CSHL LS SLIDER);

/* If a finger is detected on the slider then turn on the associated LED*/

LedData = 0;

if (CentroidPosition != OxFF)

{

/* Find the finger position on slider based on 8 LEDs of the total resolution of 64
counts */

LedData = 1 << (CentroidPosition >> NUM LED);

}

/* Write to the LED control register and update LED status*/
// LED Control Reg Write (LedData);
return CentroidPosition;

}

void hardware init (void)
{

LCD Start();

}



void wireless init (void)

{

SPIM Start();

MyRadioHWReset (); //MyRadioWrite (0x1D,0x00); //Reset in SW
CyDelay (100) ;

JIT1707 0777777777777 777777777777 777777777

//Write data=0x45 to Tx buffer
WritePayloadToRadio (0x01) ;

MyRadioWrite (TX CTRL ADR,TX GO);//TX CTRL ADR,TX GO
CyDelay (100);//wait

//Setting To idle mode

MyRadioWrite (TX CTRL ADR,TX CLR);//TX CTRL ADR,clear TX BUFFER
CyDelay (100);//wait

L1777 7777777770777 77777777 777777777777777
MyRadioInit (DATMODE_64SDR) ;

//Transmit length

MyRadioWrite (TX LENGTH ADR,0x01);

}

void wireless send data(uint8 payload)

{

unsigned char Status = 0;

MyRadioWrite (TX CTRL ADR,TX CLR);//TX CTRL ADR,clear TX BUFFER
CyDelay (100);//wait

WritePayloadToRadio (payload) ; //set to i later
MyRadioWrite (TX_CTRL_ADR,TX GO) ; //TX_CTRL_ADR, TX GO
CyDelay (100);//wait

while (! (( Status = MyRadioRead(TX IRQ STATUS ADR)) & TXC IRQ));
CyDelay (100);//wait
}
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ASSIGNING PINS (TRANSMITTER)

» Assign the Pinouts as shown.

Alias Mame Fin
\LCD - LCDPorty [&:0] pO[&:-0]
= P5[3]
mosi P1Z[0]
sck BS[0]
miso Bl1[4]
RST P5[2]
Pin_ 2[3:0] DZ[3:0]
Pin_4[3:0] p4ar3:0]

sCmod \CapSenseSlider:sbCSD:cCmod DS[4]
sRb0 \CapSenseSlider:shCSD:cRbOY P1[&]
LS slider_ed | wCapSenzseSlider:sbCSh:cPorth [4] | D3[4]
LS slider €3 | wCapSenseSlider:sbCSD-cPorth [3] | P3[3]
L5_slider_e? | wCapSenseSlider:sbCSD-cPorth [2] | P3[Z]
LS slider_el | wCapSenseSlider:sbCSh:cPorth [1] | B3[1]
LS slider ell | wCapSenseSlider:sbCSh-cPorthy [0] | P3[0]

PROGRAMMING THE PSOC

» Build the design and ensure it is error free.

» Plug in the USB Connector and click on the program option. -

> Now continue with the “Receive” Project we had saved earlier.



HARDWARE CONFIGURATIONS (RECEIVER)

» Add 8 LEDs and connect them to the pins as shown connected to a control register.

LED
i
w__: = >:
k| S L (701 (7]
control_§ f—L1- gy P
L eontal 7}

» Add a LCD component from Display>Character LCD.
» Add a PWM Component and assign pins and clock as shown (same as the PWM_ADC Project)

Cypress | q [
=g Functions -
s I | |¢| Counter [v1.20]
B SN ¢| CRC[v1.20]
e e e (¢ PriSM [v1.20]
pwmi—{v]pulse | @B || PP E (¢ PRS v1.30] T
o BN EEE I o] PWM[v1.10]
Clock pelock || Bl ;¢ i | Quadrature Decoder
- %:rmt interupties - | W] 0 ¢ Shift Register [v1.20
CECEEE RN [ .- (2} Timer [v1.20)
[+ Logic
[+-%§ Registers

[+ H& Nienlaws

m

m
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» Configure the PWM Component as shown.

Mame: BT

Configure | Advanced | Built-in |
period | #1858 O-+4- 135

» Connect the following peripherals to the PWM block Configure each as shown

o Clock - from System> Clock to be connected to PWM clock and configured as shown below.
o Logic 0 to be connected to reset
o Digital output pin to be named as pulse.
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» Your final receiver schematic should look as shown in the screenshot below.

control_4 4
control 5§ ——14
control_6 — r{%}
e m

> Add the following files to the project
Ipregs.h

radio.h

radio_fn.h

radio.c

radio_fn.c

[7:0]
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WRITING YOUR FIRMWARE (RECEIVER)

> Paste the following code in main.c

~
*

Copyright PSoC 3 LABBOOK
All Rights Reserved
UNPUBLISHED, LICENSED SOFTWARE.

CONFIDENTIAL AND PROPRIETARY INFORMATION BELONGING TO
ADITYA YADAV
ASHWATH KRISHNAN

Xk ok o o X X X

*

*
~

#include <device.h>
#include <lpregs.h>
#include <radio.h>
#include <radio fn.h>

void hardware init (void);

void wireless init (void);

uint8 clear payload(uint8 wvolt);
uint8 wireless get data(void);
uint8 old buffer;

void main ()

{

uint8 Payload;

uint8 buffer,old buffer;
hardware init();
wireless init();
wireless get data();

LCD Position(0,0);LCD PrintString("CH:");LCD Position (0, 3);
LCD PrintInt8 (MyRadioGetChannel());

old buffer=5;

for(;+)

{

Payload = wireless get data();
buffer=clear payload(Payload);
if (buffer==0) buffer=old buffer;
LED Write (buffer);

PWM WriteCompare (buffer);

old buffer=buffer;

}

}

uint8 clear payload(uint8 volt)
{

if (volt==5) return 5; //03 0x0C
else if (volt==6) return 6; //06 0x19
else if (volt==7) return 7; //09 0x26
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else 1f (volt==8) r
else 1if (volt==
else 1if (volt==10)
else if (volt==
else 1f (volt==12)
else 1if (volt==

else 1f (volt==14)
else 1if (volt==15)

else if (volt==
else 1f (volt==17)
else 1if (volt==
else 1f (volt==19)
else if (volt==
else 1f (volt==21)
else 1if (volt==
else 1f (volt==23)
else 1if (volt==

else 1if (volt==25)
else return old buf

}

eturn 8; //12
) return 9;
return 10; //18
11) return 11;
return 12; //24
13) return 13;
return 14; //30
return 15; //33
16) return 16;
return 17; //39
18) return 18;
return 19; //45
20) return 20;
return 21; //51
22) return 22;
return 23; //57
24) return 24;
return 25;
fer;

void hardware init (void)

{

LCD Start();
SPIM Start();
PWM Start () ;
}

void wireless init (void)

{

0x32
//15
0x4b
//21
0x64
//27
0x7d
0x89
//36
0xA2
//42
0xBB
//48
0xD4
//54
O0xXED
//60

0x3e

0x57

0x70

0x96

0xAF

0xC8

OxE1

OxFA

MyRadioHWReset (); //MyRadioWrite (0x1D, 0x00) ;

CyDelay (100) ;
MyRadioInit (DATMODE
//Receive length
MyRadioWrite (RX_LEN
}

uint8 wireless get

{

uint8 Payload;
MyRadioStartReceive
CyDelay (100);//wait
//Setting To idle m

_64SDR) ;

GTH_ADR, 0x01) ;

data (void)

07

ode

Payload = MyRadioRead (RX BUFFER ADR) ;

//MyRadioWrite (RX_CTRL_ADR,RX CLR);//TX_CTRL ADR,clear TX BUFFER

CyDelay (100);//wait
return Payload;

}

//Reset 1in SW
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ASSIGNING PINS (RECEIVER)

» Assign the PinOuts as shown in the screenshot below.

Alias MName Fin Loc
ZWLCD:LCDPort\ [6:0] | POL&:0] =
S5 PS[2] [
mosi P12 [0] =
sck BS[O] E
miso P1[4] E
RST PS[Z] [
Pin Z[3:0] PZ[3:-0] [
Pin_4[32:0] P4[3:0] [
pulse P12 [2] [

PROGRAMMING THE PSOC

» Build the design and ensure it is error free.

» Plug in the USB Connector and click on the program option. o

TESTING YOUR DESIGN

YV V V VY

on both the kits.

Connect the Artaflex Module to the 12 Pin port to both Kkits.
Connect the servo motor to the PSoC programmed with Capsense_Receive.
Power both the kits. The motor kit should be powered using 5V.

Slide the finger on the Controller Kit and the motor position will change and so will the LEDs
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