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DAVE™ Software Development Kit overview

The DAVE™ SDK project provides the tool used to develop DAVE™ 4 software components or applications called "DAVE™ APPs". It provides facilities to
create user interface configurations, edit template files, create a signal designer view and create documentation for the APPs. In this help contents are described
the procedures/steps to develop DAVE™ 4 applications.

The audience for this help contents are:

» Experienced professionals with DAVE™ 4
¢ Professionals who want to develop DAVE™ 4 applications using the available application libraries

Prerequisites:

Working knowledge of DAVE™ 4 Code Engine (DAVE™ CE) and its associated features

Usage of XMC microcontrollers and knowledge of the hardware capabilities (available in the reference manual)
Basic programming skills

Basic object oriented programming skills (OOPS)

Basic JAVA/Groovy programming skills

v You do not have OOPS/JAVA/Groovy programming skills?
— Follow the procedure as recommended in this basic tutorial.

Preparing the workbench

This tutorial will get you started using the DAVE™ Software Development Kit (SDK) in the Workbench.
First, you have to verify the workbench is properly configured for APP development. It is assumed that:

¢ Your Workbench has its default settings. To reset the current perspective to its original layout, from menu bar select Window > Reset Perspective... >
Yes
¢ You are familiar with the "DAVE™ APP" concept and its applications

Creating a simple APP

In this tutorial, you will use DAVE™ SDK to create a simple "Hello World" application (APP). This tutorial describes the process of creating a new APP project
where the build is automatically managed by DAVE™ SDK, and running the APP in DAVE™ 4.

To create a simple "Hello World" APP using DAVE™ SDK, perform the following steps:

. Create a new APP project

UI Design

. Write a template for code generation
Update the APP manifest

. Create an Update Site

. Import the APP into DAVE™

. Template Debugging

. Explore by yourself!

Step 1: Create a new APP project

1. Select File > New > Project...
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Mew Alt+Shift+N » | [  DAVE SDK Project...
Open File... Fﬁ Project... I
Close Ctrl+W n App Template...
Close All Ctrl+ Shift+W App Document Section...
Save Ctrl+S [ Example...

L | SR =i Other.. Ctrl+N
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2. Select the type of project to create. For this tutorial, select DAVE SDK Project... and click Next.
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Wizards:
type filter text

|E DAVE SDK Project...|
T Groowvy Project

> = General

b= O/C+

[ (= Groovy

> = Java

[ [= JavaScript

[» [ Plug-in Development

I = Web

> = WindowBuilder

> (= Other

[ [= Examples

@ < Back Next > Finish

. The DAVE SDK Project wizard opens.
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Expand DAVE Projects list and select APP Project. After that click Next.

4. The DAVE APP Project view appears.
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DAVE App Project —
Create a DAVE APP Project

Project name:  HelloWeorld

App name: HELLOWORLD

Use default location

C:/Workspaces/DAVE_SDK_4.0.0/W5_2015 02 09 Browse...

® Next » [ Einish ] ’ Cancel

y

a. In the Project name field, type a name for the project, such as HelloWorld.
b. In the APP name field, type a name for the APP, such as HELLOWORLD.

APP name must be always written in UPPERCASE.

c. Click Finish.

5. In the left-up part of the screen you could see the APP project folder (HelloWorld), expand it and you will see some additional folders.
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£ DAVE Apps .. &2 C/C++ Pro = B | [J] HELLOWORLD.manifest i3
=] Q:D - /{ Import statements
4 & HelloWarld ® import ifx.davex.app.manifest.*[]

class HELLOWORLD extends HELLOWORLD GUI {
> [ MANIFEST -

(&= doc // Note : Following App properties are mandatory and important
> (= docgen // Begin : App property section
» (= Templates
> = Uimodel

App version
Format: a string with three digit separated by a dot.

* 7

def version = 'l.8.8"

MANIFEST folder
= Groovy code used for User Interface logic

b. doc folder

= Location of generated APP documentation
c. docgen folder

= Source files required for APP documentation generation
d. Templates folder

= Code generation templates and files to be copied during code generation
e. Uimodel folder
= User Interface configuration files

o

Step 2: UI Design

1. At the APP project explorer (HelloWorld), expand the Uimodel folder and double click HELLOWORLD.ui.
A new tab called HELLOWORLD.ui should appear at the right.
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4 [ Helloworld
[+ [ MANIFEST
= doc
[» (= docgen
[» [= Templates
a (= Uimodel
o HELLOWORLD.=d
HELLOWORLD.ui
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2. Drop a GInteger widget into the APP UL

[J] HELLOWORLD.manifest

[J] HELLOWORLD.manifest
4 — Structure

HELLOWORLD.ui &3

= BRI CS[£E B X|
% Compenents « —— Palette ——
a [ pl:Tab = Layouts |
4[] pliTabFolder ii i Absalute lay... Iﬁ:GridLayout ml—
4 (] pl:GTab = Dave |
(1 pl:Tab [1GTab %Glmage
[T]G5Group
i GLabel 1.0 GFloat
[ 1 GString Glnteger
4] GCombe V] GCheck
%2 Glink (@ GlnterruptPrio
] Properties 4e| :=:€> &) B GMessage
+ || = Advanced
GIndexGroup E GIndexCombo
<MNo Properties»
|X] XML Sourcel Design Pleview| |

*HELLOWORLD.ui 22

1 —— Structure ——
%3 Components ] Falette ——
a4 [ pliTab = Layouts |
4[] pliTabFolder it i Absalute lay... j:': GridLayout New Tab
4 [] pl:GTab = Dave |
« (1 pl:Tab [1GTab %Glmage
pliGinteger GRTF [7] GGroup
& GLabel 1.0 GFloat
[ Gstring | Glnteger | q> ® Enter Integer Value... Idec vi
GCombo [v] GCheck = = =
1% GLink (@ GlnterruptPrio
1 Properties /”@| & | o ED | | B GMessage
Style [1 = Advanced
description ) GIndexGroup [ GlndexCombo
enabled [ltrue
format DEC
formatVisible [ltrue =
mandatory FALSE
manifestObj []true
maxWValue MAX_VALUE =
minValue MIN_VALUE [==]
toolTipText [
wrabia [ane]
|%| XML Source I Design Preview| |

3. Select a default value for the widget, such as "0".
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Style 0 .
description [=]
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format DEC

formatVisible [¥ltrue
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manifestObj []true

maxValue MAX_VALUE [=]
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4. Now it is time to save the Ul and generate the Ul interface.
a. You can save the UI and generate the Ul interface in two ways:

= Pressing the diskette icon under the menu bar

File Edit MNavigate Search Project Run  Window Help

HrE-Eeol v - S -wiBitt-0-idiiY

£ DAVE Apps ... 52 C/C++ Proj = 0 [J] HELLOWORLD.manifest *HELLOWORLD.ui &35
= %5 v | 4 —— Structure
4 5 Helloworld %y Components =Nl

= Pressing the button combination CTRL+S

b. By saving, DAVE™ SDK automatically generates the HELLOWORD _GUIL manifest file.
This file is the interface between Ul and the user defined manifest HELLOWORLD.manifest.
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4 & HelloWorld
4 = MAMIFEST
L% HELLOWORLD_GULmanifest|
) HELLOWORLD.manifest
(= doc
» (= docgen
> (= Templates
4 (= Uimodel
s HELLOWORLD.sd
HELLOWORLD.ui

Step 3: Write a template for code generation

1. By default, DAVE™ SDK will add a file here called like your APP name but in lowercase, in this case helloworld.tmpl.
We are going to remove it and then we are going to create a new one so you can learn how to do it.
Just expand the Templates folder and right click on helloworld.tmpl > Delete > OK.



a (& HelloWaorld

a [ MANIFEST
i [£) HELLOWORLD_GULmanifest
b [€] HELLOWORLD.manifest
(= doc

[+ [ docgen

a (= Templates

|[4] hellowerld.tmpll

a (= Uimodel Mew 3
s HELLOWOR
HELLOWOR Open F3
Open With 3
ShowIn Alt+Shift+W »
Copy Ctrl+C
52 Copy Qualified Name
[[5 Paste Ctrl+Y
H  Delete Delete

2. We are going to add a new template to Templates folder, so right click in Templates folder > New > APP Template...
4 [ HelloWorld
4 [ MANIFEST
1 [£] HELLOWORLD_GULmanifest
i [£] HELLOWORLD.manifest

= doc
[» [ docgen
1> |2 Templates|
4 (= Uimode New v |B) DAVE SDK Project...
HEL Go Into ™ Project...
HEL|
Open in New Window D App Template...
Show In Alt+Shift+W » App Document Section...
Copy Ctrl+C | Example..
E=  Copy Qualified Name I Other Cirl+N
|15 Paste Ctrl+V T
3. This should open the New Groovy Template wizard.
i New File o [E@] = ]
New Groovy Template .
Creates a new Groovy Template

Enter or select the parent folder:

HelloWorld/Templates

T

4 [ HelloWorld
= bin
= doc

[» [ docgen

(= MANIFEST
= META-INF
(= Templates
= Uimodel

IFiIe name:  HelloWerld.tmpl

@ [ Finsh || cancel

L% A

In the File name field, change the default name for other, such as HelloWorld.tmpl and click Finish.

4. A new tab called HelloWorld.tmpl will open automatically.
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[ DAVE Apps .. 52 C/Ce+ Pro = B | [J] HELLOWORLD.manifest  [52] HELLOWORLD.ui | [4] HelloWorld tmpl 52 =g
e ~ |B g
4 & HelloWorld
4 (3 MANIFEST

» [£) HELLOWORLD_GULmanifest
» [£) HELLOWORLD.manifest
& doc
» = docgen
4 (= Templates
[d) HelloWerld.tmpl
4 (= Uimodel
&% HELLOWORLD.sd
HELLOWORLD.ui

[

& Tasks 52 Problems v =g
Litems
“ 1 Description Resource Path Location Type
TODO: Initialize manifest variables here HELLOWORL... /HelloWorld/MANL... line 89 Java Task
Writable Smartlnsert | 1:1

5. Copy the following code into HelloWorld.tmpl and Save the template.

1 | for (HELLOWORLD app in appInstancesList) {

2 // Create a macro for each instance of the APP

3 out.print("""

4 #define ${app.getInstanceLabel()} MYINTEGER ${app.ginteger_1.value}
50

6|}

%l GUI values can be read directly from the UI bypassing the APP manifest.

Step 4: Update the APP manifest

1. Open HELLOWORLD.manifest file

a (& HelloWorld
a4 [ MANIFEST
> HELLOWORLD GULmanifest
I> [£] HELLOWORLD.manifest I
= doc
> = docgen
4 (= Templates
HelloWorld.trmpl
4 = Uimodel
o HELLOWORLD.=d
HELLOWORLD. ui

2. Define the devices that are compatible with this APP by modifying the softwareIDs APP property as in the code below:

def softwareIDs = [
"XMC4.5.00.F144 ALL":"
"XMC4.4.00.F100.*":"
"XMC1.3.01.Q024 . *":"

1.0.0",
2@:0" 5
.0.0

uuh wWNBR

3. At the end of the manifest file, look for the method called generateFiles(). This method is executed on code generation event, and you can call some
special methods inside generateFiles() to execute code generation based on the templates.

Replace the content of the method generateFiles() with the one below and Save:

1 | def generateFiles(){
generate("HelloWorld.tmpl", "HELLOWORLD.h")

N

311}

Step S: Create an Update Site



1. Update Sites are used to distribute a set of APPs and install them in DAVE™.
Add a new update site project by File > New > DAVE SDK Project...

Edit Source Refactor Mavigate Search Project Run  Window Help

New Alt+Shift+N » | ] DAVE SDK Project...

Open File... ™ Project..

Close Chrl+W ﬂ App Template...

Close All Ctrl+Shift+W App Document Section...

Save Ctl+S | Example...
G SaveAs. I Other.. Ctrl+N
e Am Fea. el o

2. Select Update Site Project and click Next.

& DAVE SDK | @] %
Select a wizard """f-:
Creates new DAVE App update site project ‘n !neon
_—/

4 =2 DAVE Projects
2% Update Site Project
2% App Project

@ < Back Next > Finish

L% A

3. In the Project Name field introduce a name for the project, such as myUpdateSite.
You must select at least one APP from the list below, in this case we only have one possible APP, so select HelloWorld APP.
Click Finish.

F ™y
. DAVE SDK [E=EER

DAVE App Update Site
Creates new DAVE App update site project

| Project Mame mylpdateSite

Use default location
Lacation: | C:/Workspaces/DAVE_SDK_4.0.0/W5_2015_02_09/myUpdateSite Browse...

| HelloWorld |
| |

@ et | [ Finish ][ Cancel

%

4. If you have more APPs available in the workspace and you want to add them to the Update Site, you can do it later by right click in myUpdateSite folder
> DAVE Update Site > Add APPs.



= doc New 'P
> [ docgen
4 (= Templat Ealinio
Hellg Open in New Window
“ & L;I:m:Edl_ell_ Open Type Hierarchy F4
Wil Showln Alt+Shift+W b
=l -
4 |2 myUpdateSi 2 Copy Ctil+C
[ MANIFES _ .
. = HelloWo 55 Copy Qualified Name
[¥] daveSite| [ Paste Ctrl+V
. Delete Delete
Build Path »
Source Alt+Shift+5 »
Refactor Alt+Shift+T »
by Import..
g Export..
Build Project
«#  Refresh F5
Close Project
Close Unrelated Projects
Assign Working Sets..
Profile As 3
Debug As 3
Run As 3
Validate
Team >
Compare With 3
Restore from Local History...
EJ DAVE Update Site * | um Remove Apps
Configure *| g AddApps
Step 6: Import the APP into DAVE™
1. Open DAVE™ 4 and select a workspace.
% DAVEIDE - DAVE™ - C:\Workspaces\DAVE-4.0.0\WS_2015 02 18 [2e =
File Edit Source Refactor Navigste Search Project Run DAVE Window Help
A AR et aE RO S s Quick Access ;| 55 | [ DAVEIDE
T C/C+ Projects 52 | 7 Project Explorer =g =
2les ~

2. Importing APPs into DAVE™ workspace is possible using the Update Site folder stored in DAVE™ SDK workspace.

B Console 13

Mo consoles to display at this time.

“B-m-=0

Go to Help > Install DAVE APP/Example/Device Library...



File Edit Source Refactor Mavigate Search Project Run  DAVE  Window | Help
0 = P O A ST o o (S 4 O [ Welcome
I C/C++ Projects 52 | [ Project Explorer = O (@ Help Contents

&7 Search
~R|BR T 3 _
Dynamic Help

Key Assist... Ctrl+Shift+L
Tips and Tricks...

DAVE™ Forum

DAVE™ Mews

Send Feedback Mail

Cheat Sheets...

Install DAVE APP/Exarmple/Device Library...
Check for DAVE APP Updates

Uninstall DAVE APP/Example/Device Library...
Check for Updates

Install New Software...

F$

@ 8 &

Installation Details

About DAVE™

3. This will show up the Library Manager Wizard window, and we need to add the Device Library, so click Add... button.

i Library Manager Wiza

Download Libraries Page
This wizard page helps in downloading the libraries of type example projects or apps library

Dave Site

Work with : hd | Add... |

Find more library by working with the Library Update Sites preferences

Libraries

Enter the keywords to filter :

MName Version Path

Description

Filters

Hide items that are already downloaded
[ Show only latest version

@ < Back Next > Finish

4. Click Local and select your DAVE™ SDK Update Site folder, in this case myUpdateSite. After that click OK.

% Add Dave site [ & |

|Location filey// T/ Workspaces/DAVE_SDK_4.0.0/W5_2015_02_09/my Local |

@ ok |[ conca |

5. Select the HelloWorld checkbox and click Next.



W Library Manager Wizard ‘ SRR

Download Libraries Page

This wizard page helps in downloading the libraries of type example projects or apps library

Dave Site

Work with :  file://C:/Workspaces/DAVE_SDK_4.0.0/W5_2015_02_09/myUpdateSite/ -
Find more library by working with the Library Update Sites preferences

Libraries

Enter the keywords to filter :

Mame Wersion Path
2 HelleWerld
2 Category
HelloWorld 1.00 file://C:/Workspaces/DAVE_SDK_4.0.0/W5_2015_02_09/myUpdateSite/HelloWerld/LibraryManifestxml

Description

Filters

Hide items that are already downloaded
[] Show only latest version

@ < Back Next > Finish

6. Accept the terms of the license agreements and click Fini

W Library Manager Wizard ‘ SRR

License Review Page

This wizard page helps to review the license of a selected library before download

< [B|ExeARBILBRARY, IMPORTANT DOWNLOAD NOTICE B
HelloWorld The software you have requested for download is protected by national and international

copyright laws and may be protected by other intellectual property rights.

You shall use the software only in accordance with the applicable licensing terms and

conditions which may be different from the terms and conditions of the DAVE Software

License Agreement. For copyright infermation, licensing terms and additional information

(e.g. on how to obtain the source code of such Open Source Software), please check the

"Help Function”, Section "Copyright and Licensing Information” of the software.

By downloading the software, you acknowledge that you have read and understood this

download notice.

T accept the terms of the license agreements I

Ido not accept the terms of the license agreements

@ Next > |[ Finish ]l[ Cancel

7. Restart DAVE™ for the installation changes take effect clicking OK button.

W Library Download Manager Y

Please restart the DAVE for the installation changes to take effect

8. Create a DAVE™ CE project going to File > New > DAVE Project... and select Infineon Projects > ARM-GCC Application > DAVE CE Project.
In the Project Name field enter a name for the project, such as HelloWorld.
Click Next.




& New DAVE Project EEI

DAVE Project

Create a new C/C++ project for Infineon tool chains

Project Name:  HelloWorld

Use default location
Location: | C:/Workspaces/DAVE-4.0.0/W5_2015_02 09 Browse...

Project Type: Tool Chain:

4 (= Infineon Projects
4 [= ARM-GCC Application
Easy Start Project

=] Empty Project
4 [= ARM-GCC Library
Empty Project

Show project types and tool chains only if they are supported on the platform

@ < Back Next > Finish

. <

It is supposed you have installed de proper device description libraries in DAVE™ 4, otherwise you can not continue and you must install this libraries
before, for more information please refer to DAVE™ 4 help contents.

9. Select a Target, such as XMC4500-F144x1024 and click Finish.
Remember you have to select a device which you have declared in the softwarelDs variable in your APP manifest.
def softwareIDs = [
"XMC4.5.00.F144 .ALL":" NORP

1.0
"XMC4.4.00.F100.*":"1.0.0",
"XMC1.3.01.Q024.*":"1.0.0"

uuh wNneER



& New DAVE Project [S=] =

Target Selection Page
Select the controller for which the project has to be created

»

a Processorsnfo
4 XMC4000

a [J] KMC4500 Series
XMC4500-F144:1024
[] XMC4500-F100:1024
[] XMC4500-E144:1024
[] XMC4500-F144x768 ]
[] XMC4500-F100:768
[] XMIC4502-F100x768
[] XMC4504-F100x512
[] XMIC4504-F144:512

> [C] KMIC4400 Series -

m

Device Features

Package= LQFP144

ROM= 1 ME Flash

RAM= 160 KB RAM

InQut= 91 digital /'O

ADC= 26 ADC Channels, 12-bit, Delta Sigma Demodulator

»

[

Linker Option
Remove unused sections

Runtime Library
Library Mewlib-nano -

[] Add floating point support for printf
[] Add floating peint suppert for scanf

@ net> | [ Fnish ][ Cancel

Step 7: Template Debugging

1. Now we are able to debug the template we have created before. First we need to add our HELLOWORLD APP, so click Add New APP button

e DAVE CE - DAVE™ - C:\Workspaces\DAVE-4.0.00W5_2015_02_18
File Edit Source Refactor Mavigate Search Project Run DAVE Window Help
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2. Select HELLOWORLD APP and click Add, then click Close.



& Add New App T 2N

Search filter [ Show hidden categories

4 (= Category
4 (= 5Sub Category
»a HELLOWORLD [1.0.0]

Double-Click on the app to add it to the active project.
Show Latest Versions Only

Here the app description. Please add appropriate app description -

©) appinfo | [ Add ][ Close

. A

3. You can observe how our HELLOWORLD APP have been added successfully, and you can expand Dave > Model > APPS > HELLOWORLD >
v1_0_0> Templates to find our HelloWorld.tmpl template, the one which we are going to debug.

H@ C/C++ Projects 52 Praject Explorer = g
P RIBS Y
4 (5 HelloWorld [ Active - Debug | ~
b [l Includes F
[2 = Dave
I [= Generated
4 (= Model
4 (= APPS
4 = HELLOWORLD =
4 w100

a [ Templates
[€] HelloWorld.tmpl
[€] HELLOWORLD_GULmanifest
[€ HELLOWORLD.manifest
= common L
|Z| projectData.bin

[ [ Libraries
[ (2= Startup i
App Dependency Tree &3 *® = | = B8
L1}
Search filter Clear

[ ss HELLOWORLDO |

wa App Dependency 23
HELLOWORLD
HELLOWOR

4. Before debugging, we need to enable the Template Debug.

Go to DAVE > Advanced > Template Debugging and click Enabled.
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@ B i Upgrade to DAVE CE project >
Add Mew APP...
Save Application Model

€ | = Report...

Manual Pin Allocator...

Manual Resource Assignment...
HW Signal Connections...
Global Interrupt Editor...

Solver

Validate APPs Configuration

Generate Code

tHREOONESIE:

anifest Change Required APP Instance...
st Disconnect (BMI)
Advanced 3 Template Debugging »| @ Enabled

D Disabled

In DAVE™ it is possible to easily debug templates execution. Enabling template debugging will make visible the template debug profile.
As a side effect, some Java/Groovy context menu items are activated, user shall ignore them.

5. We are going to create a template debug configuration.
Right click on Debug Arrow, click Debug Configurations...

@etuEouore ]y - -

Debug Configurations... I

=0 I

6. Double click APP Code Generation Debug, then close the window clicking Close button.

Mame: Mew_configuration

Lype filter text E Environment [T} Common}

4 wa App Code Generation Debug Environment variables to set:
w»a New_configuration
e | GUB SEGGER J-Link Uebugging

Variable

7. Now double click HELLOWORLD_0 APP in the APP Dependency Tree, this will show you the APP UI we had programmed before in DAVE™ SDK.

i B e E et E DO S T
@ C/C++ Projects 23 Proj = B HELLOWORLD 0 2%
GBS 7 | [NewTan
4 (= HelloWorld [ Active - Debug | A
4 (= Dave
[» = Generated
4 (= Model
4 (= APPS
4 (= HELLOWORLD 0 --dec -
4 (=100

m

a = Templates
[€] HelloWorld.trpl
[€] HELLOWOQRLD_GULmanifest
[€] HELLOWORLD.manifest
> = Common
[» (= Libraries
[+ [= Startup
|=| linker_script.ld
[@ main.c -

s APP Dependency Tree £F = |I:I i

Search filter Clear

I oa HELLOWORLD 0 I

aas APP Dependency #2 , HW

HELLOWORLD
HELLOWORLD_0

8. Enter a value such as 123 and close the tab.



HELLOWORLD_U@

Mew Tab

| 123 [dec v]|

9. Now open HelloWorld.tmpl by clicking it twice and add a breakpoint at line 8.

B C/C++ Projects &% [ Project Explorer = B [J] HelloWorld.tmpl 52
ER= " | <‘:==»=> - ; package Model.APPS.HELLOWORLD.v1 @ @.Templates;
4 {¥ HelloWorld [ Active - Debug] e 3# import Model.APPS.HELLOWORLD.v1_@_@.HELLOWORLD]]

b ) Includes 5= for (HELLOWORLD app in appInstanceslist) {
4 (= Dave 6 //Create a macro for each instances of the app
4 (= Model out.print("""
4 (= APPS #define ${app.getInstancelabel()} MYINTEGER %{app.ginteger_l.value}"""
4 (= HELLOWORLD } )
4 (=100

m

4 = Templates

[£] HelloWorld.trpl

€] HELLOWORLD_GULmanifest
[€] HELLOWORLD.manifest
[ = Common

=| projectData.bin

10. Time to debug! Click on Debug HelloWorld button.

File Edit Source Refactor Mavigate Search Project Run DAVE Window Help
OrErL e Bl PE et uESTOE#T]

H@ C/C++ Projects 3% ([ Project Explorer = O

[I] HelloWorld.trpl 5%

. The Debug Configurations window will appear, select the New_configuration we have created before and click on Debug button.

& Debug Corfigurations = 9 e T

Create, manage, and run configurations

% [{= —+,
OE %X | i Mame:  Mew_configuration
|t}rpefilter text | E Environment “_ [ Common\l
4 jay App Code Generation Debug Environment variables to set:
_
[© | GDB SEGGER J-Link Debugging Variable Value New..
[ Edit. |
| Remaove |
(@ Append environment to native environment
Replace native environment with specified environment
Apply Revert
Filter matched 3 of 19 items | PPy | | |

@

L

12. A new window ask you about a perspective switch, click Yes.



% Confirm Perspective Switch &=

This kind of launch is configured to open the Debug perspective when it suspends.

This Debug perspective is designed to support application debugging. It
incorporates views for displaying the debug stack, vanables and breakpoint
management.

Do you want to open this perspective now?

[] Rernember my decision

Yes MNo

13. Congratulations, you are now able to debug your template!

% Debug -+ HELLOWORLD/_0_0/ Templates/t Pl DAVE™ - C\Workspaces\DAVE-4 0.0WS 2015 02,09 B
File Edit Source Refactor MNavigate Search Window Help
= 0> Ho ook sw[d @ QuickAccess | [ | 5 DAEIDE i DAVECE
4 Debug 2 )i ¥ = B (=Variables 57 O Breskpoints % Peripherals 5B & X%t *= 08 |§
4 L New_configuration [App Code Generation Debug] Name Value
4 {2 Model.Common MainClass at localhost65292 > o ths HellWorld (d=20)
4 o Thead [main (Suspendd (reakpoint i’ n HeloWoric) > © app HELLOWORLD (d=21) L
= HelloWorld.run( line: 8
HelloWorldsSrun.call(Object, Object(]) line: not availsble |
= MainClass.main(Stiing..) ine: 26 r
J CADAVE-IDE-4.0 0\DAVE_4.0.0\eclipse\jre\binjavaw.exe (1202.2015 1109:50) Nl
‘ » [
[3] HelloWorld.tmpl 52 = O s Disasembly % = Outline =a |
; package Model.APPS.HELLOWORLD.v1 @ _6.Templates; - e s ‘ A @‘ 04
3% import Model.APPS.HELLOKORLD.v1_8_0. HELLOWORLD]] = F
55 for (HELLOWORLD app in appInstancesList) { No debug context
6 //Create a macro for each instances of the app "l |
7 autpring(™
8 #define S{app.getInstancelabel()} HYINTEGER ${app.ginteger 1.value)""" |
9 )
10 3 L
. » [ »
B Console 37 0 Tasks . . |BEEEE #E-H-=8 0§ Mmy: G - ve=R
New_configuration [App Code Generation Debug] C:\DAVE-IDE-4.00\DAVE 4.0.0\eclpsejre\birijavawexe (12.02.2015 1:08:50) Moritors
< b
Launching New_configuration: (9%)  w | /&1

Running this debug profile has the same effect like pressing the Generate Code button, but DAVE™ will show the debug perspective on first breakpoint.

File Edit Source Refactor Mawvigate Search Project Run DAVE Window Help
|lrB e humEHRNETO e

Hg C/C++ Projects &2 Pr plorer = B8 HelloWorld.tmpl 22

14. Now you can see the generated code based on the template.
Go to Dave > Generated > HELLOWORLD and open HELLOWORLD.h

File Edit Source Refactor MNavigate Project Search Run DAVE Window Help
7B De e tuEGHOR® 5>

& C/C++ Projects &2 Proj

ct Explorer = 8 HelloWorld.trpl [ HELLOWORLD.h &2
e BEs v

DAVE 40l
This file is generated by DAVE, User modification to this file will be
en at the next code generation.

»

4 15 HelloWorld [ Active - Debug |
. #% Binaries
> [ Includes
a4 (= Dave
4 [= Generated

#define HELLOWORLD @ MYINTEGER 123

m

> [h] DAVEh -
%] Configaxml
4 (= Model

Step 8: Explore by yourself!

. You have learned the basic steps through an APP development process, keep exploring a little bit more HELLOWORLD APP!
. Try to add another instance of the same APP.

. Play with the Glnteger values.

. Try to generate the code with and without debugging.

. Look at the generated code results.
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6. Enjoy!
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