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Copyrights

© Cypress Semiconductor Corporation, 2007—2012. The information contained herein is subject to change without notice.
Cypress Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a
Cypress product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted
nor intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an
express written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical
components in life-support systems where a malfunction or failure may reasonably be expected to result in significant injury
to the user. The inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all
risk of such use and in doing so indemnifies Cypress against all charges.

Trademarks

PSoC Designer™ and Programmable System-on-Chip™ are trademarks and PSoC®is a registered trademark of Cypress
Semiconductor Corp. All other trademarks or registered trademarks referenced herein are property of the respective
corporations.

Source Code

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected
by and subject to worldwide patent protection (United States and foreign), United States copyright laws and international
treaty provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use,
modify, create derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of
creating custom software and or firmware in support of licensee product to be used only in conjunction with a Cypress
integrated circuit as specified in the applicable agreement. Any reproduction, modification, translation, compilation, or
representation of this Source Code except as specified above is prohibited without the express written permission of
Cypress.

Disclaimer

CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATERIAL,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein.
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support
systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against
all charges.

Use may be limited by and subject to the applicable Cypress software license agreement.
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1.1 Introduction to PSoC Programmer

PSoC Programmer is a flexible, stand-alone utility for programming PSoC devices. Used with both PSoC Designer and
PSoC Creator, PSoC Programmer offers you a simple GUI that connects to programming hardware. Also included is a
COM layer that you can use to create custom applications.

If you are new to PSoC Programmer, you must first install it and then set the options you want to use. You then use PSoC
programmer to:

L Open a hex file

L Select a communication port
u Select a device

L] Set programming parameters
] Program a device

L] Verify programming

1.2 Installing PSoC Programmer

You can download PSoC Programmer directly from the Cypress web site. You can then install it on your PC.
1. Go to http://www.cypress.com/go/psocprogrammer.
2. Find the PSoC Programmer.exe file in the table and download the file.
3. Click PSoCProgrammersetup.exe to start the setup wizard.
4. Follow the on-screen prompts to install PSoC Programmer.

If you have PSoC Programmer version 3.06 on your computer, use Add/Remove Programs to remove it before you begin
this installation procedure. If you installed a previous version of PSoC Programmer using the Cylinstaller, navigate to the
Update Manager to update to the latest version of PSoC Programmer or to uninstall it.

PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H
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Figure 1. Cypress Update Manager

* Cypress Update Manager

Cypress Lipdate Manager detected the following installed software
*Psxﬁagrammeta,léﬁddnm Rekass Note
Updates Avalable
[Check for updates J [Preferencos e ]
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2.1 Starting PSoC Programmer

You can start PSoC Programmer from the Windows desktop or through PSoC Designer. Set up all hardware, including the
device to program, before you start PSoC Programmer.

To start PSoC Programmer from the desktop

Click Windows Start > Programs > Cypress > PSoC Programmer > PSoC Programmer.
The PSoC Programmer main window appears.

<w» PSoC Programmer

File  Yiew Options Help
. N
1~ AR MR NE N RN
| Port Selection 4Ip | Programmer | Utilities | JTAG
@) MiniProg3/1150DD000102 Programming Parameters
File Path: D:wWorkiWiewsllira_pp_3_16_walvobsips1_switools\SourcelUti
< | >
Programmer: MiniProg3/1150DD000102
Programming Mode: & Reset O Power Cycle  Power Detect
Verification: O on ® off Connector: O 5p @10 ® 10p
AutoDetecti
Devics Family AutoDetection: ® on O off Clock Speed: \1 5 MHz V\
Programmer Characteristics Status
Protocol: O JTAG ® swp O ISSP  j2c | ExecutionTime: 7.7 seconds
Device : Power Status: ON
Voltage: O 5pv ® 33v O 25v O18v o
Os. @3 O2 O Voltage: 5000 mYy
Actions Results A
Program Finished at
172292 53
Prograrming Succeeded
Doing Checksum
Doing Protect
Programming of Flash Succeeded...
Prograrring of Flash Starting...
Erase Succeeded
Device set to
CYSCS888AXI-LPO61 at 262144 FLASH bytes
17:29:46
Device Familwy set to v
For Help, press F1

To start PSoC Programmer from PSoC Designer
1. Load the target project that contains the hex file and the device you want to program.

2. Click Program.

PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H
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2.2 Loading a File

You must load a hex file into PSoC Programmer before programming a device. PSoC Programmer only programs devices
using hexadecimal files (*.hex). If your project is not yet compiled into hexadecimal format, use PSoC Designer or
PSoC Creator to prepare your project for programming before you continue.

1. Select File > File Load or press [F4].
2. Inthe Open dialog box, browse to the folder containing the file, then click the file name.

3. Click Open.

2.2.1 Recent Files

PSoC Programmer maintains a list of last five used hex files. You can access the recent used hex files from the File >

Recent Files menu or from the |7 next to File Open button in the toolbar. You would either see a complete or truncated file
path with the hex file name. When you mouse over the displayed hex file a tooltip provides full file path with the last
modified date. Click on a hex file to load it.

Note: If you move or delete a hex file, when PSoC Programmer starts its reference will be removed from the Recent Files
list.

Here are two screens that illustrate the different ways to access recent files.

Access recently used hex files from the toolbar

. PSoC Programmer

File  View Options Help

D:iWork\TTHE Projects\CY8C451 TMA-60FNL.hex
- Di\workiviewsilira_pp_3_16_walvobsips1_swt...\PS0oC3_ES0.hex

D:A\Workiviewsilira_pp_3_16_walvobs).. \CY9077_DFF_‘Write.hex cts\CYBC451 TMA-B0FNI. hex
D:\Workiviewsllira_pp_3_16_waivobsips1_swtoolsiSource|Utilities\PSoCProgrammer\PSoCProgrammerCOM_YS2005\CypressHexFilel Test\HexFiles\CY9077_DFF_Write.hex
30.05.2012 17:45:15
Programming Mode: Reset Power Cycle Power Detect
Verification: On Off Connector: Sp 10p
S AutoDetection: 2
P,e\{ig? Ea,']",'[;"' | SutoUetection: On Off Clock Speed:
[ 29486 v H Programmer Characteristics Status
seie | Protocol: JTAG WD 135P 12C Execution Time:
i Power Status: —
Hovics || voltsqe: sov OlavCiasy Oiey (e ==
| CYBC29466-24PXI v Voltage: A

Access recently used hex files from the “File” menu

& PSoC Programmer E]@
File | View Options Help
7 FileLoad F4
pgrammer | Utilities | JTAG
rogramming Parameters
ile Path: D:WorkiTTHE Projects\CY8C451 TMA-B0FNLhex
Programrmetr:
- Programming Mode: Reset Power Cycle Power Detect
Save Log Text As... Verification: On Off Connector: Sp 10p
Recent Files » I ‘ D:iWork\TTHE Projects|CY8C451 TMA-60FNL hex
@\‘ Exit | Di\WorkiViewsllira_pp_3_16_walvobsips1_swt...\PSoC3_ESO.hex
Devie ] D:\wWork\Views\lira_pp_3_16_walvobs...\CY9077_DFF_Write.hex
r — — | X b T T 5 ‘
| CYBC23466-24PX1 V3 [D:\workiviewstira_pp_3_16_walvobslps1_swtools|Source|Uilties\PSoCProgrammer|PSoCProgrammer COM_Y52005\CypressHexFile| Test|HexFiles\CY9077_DFF _Write.hex
130.05.2012 17:45:15
Actions Results | I
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2.3 Documentation

You can open any documentation file from within PSoC Programmer by using the Help menu. When you select
Documentation from Help menu a dialog box opens and you can open any file you in which you have an interest.

The default path is [INSTALL PATH]\Cypress\Programmer\x.y.z\Documents\
Note: x.y.z is the PSoC Programmer release number.

Open Documentation @

Look in: ‘V_’)Documents V‘ <) 5 il -

-’; Clock Programmer User Guide.pdf

= Miniprog3 User Guide.pdf

My Recent -,";Programmer User Guide.pdf

Documents @PSOC Programmer Example Code ReadMe
-ipsoc _programmer_cli.pdf

':psoc _programmer_com.pdf

o

© I8
» g
=)

My Documents

=

~=
o (|

- o
f I E

=

(=

T

" File name: “ v ‘ Open
MyNetwok  Filesoftype: [ Allfles () v [cancel |

2.4 Selecting a Port

The following table shows the devices that are supported.

Devices Protocols Power Power Type
ICE Cube ISSP 3.3,5.0 Internal/External
FirstTouch ISSP 5.0 Internal
FirstTouchRF ISSP 5.0 Internal
MiniProgl ISSP 5.0 Internal
MiniProg3 ISSP/SWD/ITAG 1.8,25,3.3,5.0 Internal/External
TrueTouch Bridge ISSP/SWD UCOM: 1.8 -5.0 Internal/External
VAUX: 1.8 - 5.0
FTK3 SWD 3.3 External
DVKProg3 SWD 3.3 External
FTK5 SWD 3.3 External
DVKProg5 SWD 3.3 External

To select a port, select it from the Port Selection list on the left side of the PSoC Programmer window.

Fart Selection H‘

MINIProgl /06AFE48F1 COS
& MINIProgl /844795CE0511

USB ports are added to the port list automatically when a programming device is connected and removed from the list when
disconnected. When changing ports, PSoC Programmer attempts to connect to the selected port, and then displays the port
status in the lower-right corner of the window along with a status message in the main window.

PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H 9



Using PSoC Programmer

The following list describes the current port options.

] USB/yywwDnnn — The "D" signifies a USB adapter. Programming goes through the selected USB port to an ICE
Cube or ICE-4000. yy = production year, ww = production work week, and nnn = serial number.

] USB/yywwXnnn — The "X" can be any letter other than "D". "X" signifies an ICE-Cube USB port. Programming
goes through the USB port to an ICE Cube or ICE-4000. yy = production year, ww = production work week, and
nnn = serial number.

] MiniProg — XXXXXXX. This version supports Miniprogl and MiniProg3.
u First Touch — XXXXXXXXX

When changing ports, PSoC Programmer attempts to connect to the selected port and displays the port status in the lower
right corner of the window. If you were previously connected to a device on another port, PSoC Programmer will disconnect
from the original device before connecting to the new device.

USB ports are added to the port list automatically when a programming device is connected. They are removed from the list
when a device is disconnected.

Setting a base and a part device allows the programming operations to perform actions based upon the characteristics of
the PSoC device. For example, CY8C24794 parts require Power Cycle programming mode because the reset pin is not
available for Reset programming mode. Flash sizes, which are important when the verify operation is performed, are
determined by selecting a PSoC device. Changing the device enables or disables programming mode options and displays
Flash size information in the status window.

2.5 Selecting a Device

By default, PSoC Programmer is set to automatically detect the device. PSoC Programmer queries the device and then
sets the device based on the result. Setting a base and part device allows the programming operations to perform actions
based on the characteristics of the device. Flash sizes, which are important when the verify operation is performed, are also
determined by device. Changing the device enables or disables programming mode options and displays Flash size
information in the status window.

Devices are grouped by family with the last five digits of the device code signifying the family. For example: Device Family
29X66 contains CY8C29466, CY8C29566, CY8C29666, and CY8C29866.

To select a device
Click the Program button when you are ready to program. The correct device is automatically selected.
To select a device with AutoDetection off

1. Click the Device Family drop-down list and select the target device family.

2. Click the Device drop-down list and select the target device associated with the target device family.

10 PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H
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2.6 Selecting Programmer Options

Select Options > Programmer Options to bring up the following dialog box for setting PSoC Programmer options.

~» Programmer, 0 ptions

Auto-Update of Firmware Partial Program
PSal Programmer will automatically update Aceelerated pragramming option will read
the Firrnware af the connected Prograrmmer the target PSoC3/4/5 device and write

only the changes to the flazh space

() Enable  (¥) Disable

() Enable (%) Disable

Show Popup if Firmware iz out-of-date

Auto-Bezet of Chip Clear EEPROM

PSoC Programmer will initiate a toggle of Clear EEPROM data after pragramming
the ®RES line after Reszet Programming [uze anly far PSoC345 devices)

(&) Enable () Disable O Enable (5 Disable

Chip Lock

Enable programming of *rite Once Latch
for PSoC3/5 device

() Enable (%) Disable

Show warning before programming when
[w] 2
option enabled oK. ] I Cancel

Here are the options you can choose:

2.6.1 Auto-Update of Firmware

You can enable automatic firmware upgrades for programmer hardware. These auto updates apply to all programmers that
support the in-field upgrade of firmware. You can change this setting at any time, even when PSoC Programmer is not
connected. Your selection is retained after the application is closed.

2.6.2 Auto-Reset of Chip

You can enable or disable toggling of the XRES line after any programmer operation (Program, Checksum, Read, and so
on) is finished. This option is applicable only if the chip is acquired in Reset mode.

2.6.3 Chip Lock

You can enable or disable programming of Write Once Latch (WOL) for PSoC 3 and PSoC 5 devices. This option is
disabled by default.

Select the check box beneath this option if you want to receive a popup warning before programming, as shown in the
following figure.

Chip Lock option is enabled

After programming of PSuI:3J'5 device lhe acquired purt
can get locked thy for

The result depends on the content of hex-file.

Check Wiite Once Latch option for PSoC3/5 device in
your PSoC Creator’s project.

[7] Do not show this message a0ain

Your selection is retained after the application is closed.

PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H 11
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The following occurs when the WOL option is enabled:

] After you click the Program button, the warning shown in the previous figure appears. You can click OK to
continue or Cancel to stop the operation.

] If the "Do not show this- message again” check box is selected, the popup warning does not appear the next
time you attempt to program the device using this Chip Lock option.

u When SWD protocol is selected and the Chip Lock option is enabled, the Log window displays, in red text: “Chip
Lock option is enabled, the target device can be locked if programmed.”
2.6.4 Partial Program

If you enable the Partial Program option, PSoC Programmer uses partial programming methodology to program the PSoC 3
/ PSoC 4 / PSoC 5 chips. This allows writing nonzero blocks from the hex image to the chip's area flash, which reduces the
programming time, most notably on the FTK3/5 programmers.

2.6.5 Clear EEPROM

When enabled, this option allows you to clear EEPROM data after programming on PSoC 3 and PSoC 5 chips. This action
will write zero values in all EEPROM locations. This option is disabled by default.

PSoC Programmer does not support EEPROM programming from the GUI. For more information, see EEPROM
Programming.

2.7 Setting Programming Parameters

Before you program or use any other PSoC Programmer functions, you must set the correct programming parameters:
u Programming mode
u Clock speed (MiniProg3 when using JTAG protocol only)
u Protocol
] Pin connector (MiniProg3 only)

You can set these options from the Programmer tab in the PSoC Programmer window,

2.7.1 Programming Mode
Programming mode determines how PSoC Programmer acquires the device for programming. There are three modes:

L] Reset — Used for ISSP header programming on a self-powered target application board. In this case, the target
board supplies the power and the programmer uses the reset pin to acquire. You cannot use Reset mode with 8-
pin devices
Select the Power Device check box with Reset mode if your target board is not self-powered

L] Power Cycle — Used for programming when the programmer requires power. The programmer cycles power to
acquire. You can use Power Cycle mode only with devices that have an XRES pin.
Select the Power Device check box with Reset mode if your target board is not self-powered

] Power Detect — Used for programming when the programmer detects the power applied to the board. This is
available for Miniprog3 and CY3207ISSP hardware.

2.7.2 Clock Speed (MiniProg3 only)

Clock speed for Miniprog3 is selectable if you use JTAG programming protocol. The selectable clock speeds are 48 Mhz,
24 Mhz,16 Mhz,12 Mhz, 8 Mhz, 6 Mhz, 3.2 Mhz, 3.0 Mhz, 1.6 Mhz, and 1.5 Mhz.

2.7.3 Protocol

PSoC Programmer supports the ISSP, SWD, and JTAG protocols. It is important to set the protocol for the device before
programming.
The table in Selecting a Port shows the supported devices with protocols.

12 PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H
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2.7.4 Pin Connector (MiniProg3 only)

This option is supported only for MiniProg3 devices. For more information, see Selecting a Pin Connector (MiniProg3 Only).

2.8 Selecting a Pin Connector (MiniProg3 Only)

The Connector option is available in the Programmer tab of PSoC Programmer. It is applicable only for the MiniProg3
device. For all other programmers, it is disabled.

The MiniProg3 communicates with PSoC devices through the 5-pin or 10-pin headers, as shown in the following figure.

g W] —
- :

10-pin header

L The 5-pin ISSP connector is used for ISSP, I°C, and SWD programming.
L The 10-pin connector is used for SWD and JTAG programming.

Before you perform any actions with PSoC devices, set the correct connector using the radio buttons, as shown in the
following figure.

Connector: O EI:I_‘E} 10p

2.9 Programming a Device

PSoC Programmer programs devices using hexadecimal files (*.hex). You must load the file into PSoC Programmer before
the programming a device.

To program a device

1. Click the Connect button. pid

2. Click Program or press [F5].

The programming operation erases, programs, verifies, protects, and performs a checksum. Because the verify action is
performed before the protect action, all blocks are verified.

2.9.1 To turn verification off

When you are debugging your program, you may be making changes, rebuilding, and reprogramming a device very
frequently. To save some time during this process, you can select to turn the Verification stage off. This saves roughly 30
percent of the total programming time. You should not turn verification off for production programming.

2.10 Stopping a Process

You can stop programming and other long processes.

The Abort Process button is enabled only during the busy state of PSoC Programmer. The busy state means that the
programmer is executing a long-lasting action such as Program, Verify, Checksum, Read, or Upgrade Firmware. You can
click the Abort Process button at any time during a busy state to stop the current operation.

This is particularly useful if you click Program when a PSoC device is not connected to the programmer or when attempting
to acquire a device using the Reset mode when the device is not powered. The Acquire operation takes about 20 seconds
to time out. If you stop the process, you do not have to wait for the timeout period to finish.

PSoC Programmer User Guide, Doc. No. 001-16213 Rev. *H 13
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2.11 Error Messages

This topic shows some common error messages displayed when using PSoC Programmer, along with possible solutions.

Cannot open port
Problem Solution
The USB cable is detached from either the USB adapter | Plug in the cable, wait a few seconds, and then press the Connect ICE
or the computer. icon in the Debugger subsystem.
Programming step failed

Problem Solution
A step within the programming algorithm (Erase, Verify, Update Miniprog1l to the latest firmware.
Program, Protect, and so on) failed. Click the Erase button to start the Erase function, and then try to program
the device again.
Check connections; SDATA/SCLK lines may be disconnected.
Project is incompatible with the pod/chip

Problem Solution
The wrong project is selected for the pod. Verify that the project matches the pod type.

Could not configure ICE

Problem Solution
Port setting incorrect. Select the correct port from the Port Selection list.
Power disconnected. Check power cord connections.
USB cable disconnected. Check USB cable connections.

Cannot acquire device

Problem Solution
Cannot acquire the device. Verify that the programmer is plugged in, check for broken wiring, confirm
that the connection is secure, and determine that the PSoC chip is working
correctly.

Make sure the programming mode is correct. Setting the mode to Power
Cycle when the chip already has external power, results in a "Can't Acquire
Device" error. Similarly, setting the mode to Reset if there is no external
power, also results in this error.

Make sure the adapter is correctly used, and that pin 1 is properly aligned.

The MiniProgl may have two capacitors connected to the SDATA and
SCLK lines. Contact Cypress Technical Support for directions on how to
remove the capacitors.

Device not supported

Problem Solution
Programmer generates the error message, "This device These parts can only be programmed by an ICE-4000:
is not supported by this programmer/port". CY8C26233
CY8C26433
CY8C26633

PSoC Programmer has expired or will expire

Problem Solution
During launch, PSoC Programmer displays a warning When the warning message appears, click Yes to go to the PSoC
message that says it is expired. Programmer website and download the latest version of PSoC Programmer.
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MiniProg is listed as MINIProg1/1 in the port list or MiniProgrammer not programmed
Problem Solution
If the MiniProg firmware is corrupted, the MiniProg is listed in the Port menu as If the firmware is corrupted, PSoC Programmer will
MINIProg1/1, and a message in the Results pane says, "MiniProgrammer not update the firmware automatically (indicated by the
programmed. Downloading Firmware." A follow-on message will state, "Can't green, blinking LED on the MiniProg). After the

open MINIProg1/1 port, check connections."

| Results

Can't open MINIProgl/l port, check connections
Please unplug HiniProgrammer from USB and reconnect
Update firmware using Utilities/Upgrade Firmware
MINI version Expecting 1.73 got 0.0

Done

Starting

MiniProgrammer not programmed, Downloading Firmware

2.12 Reading a Device

Click Read or press [F7] to read the contents of a device.

in the following example.

Read Finished at 11:20:25 AM

Protected data is displayed as "xx".

0000: xxX XX XX XX XX XX XX XX XX XX XX XX XX XX
0010: xxX XX XX XX XX XX XX XX XX XX XX XX XX XX
0020: XX XX XX XX XX XX XX XX XX XX XX XX XX XX
0030: xX XX XX XX XX XX XX XX XX XX XX XX XX XX
0040: xX XX XX XX XX XX XX XX XX XX XX XX XX XX
0050: xxX XX XX XX XX XX XX XX XX XX XX XX XX XX
0060: XX XX XX XX XX XX XX XX XX XX XX XX XX XX
0070: xxX XX XX XX XX XX XX XX XX XX XX XX XX XX
0080: XX XX XX XX XX XX XX XX XX XX XX XX XX XX
0090: xxX XX XX XX XX XX XX XX XX XX XX XX XX XX
00al: xx XX XX XX XX XX XX XX XX XX XX XX XX XX
00b0: xxX XX XX XX XX XX XX XX XX XX XX XX XX XX
00c0O0: 00 28 4b 51 32 80 04 75 09 00 62 e3 00 08
00d0: d5 74 a0 4b 18 75 09 00 08 28 53 32 18 75
00e0: 08 28 a0 1c 53 31 18 75 09 00 08 28 3f 32
00£f0: ff b0 06 5d d5 74 60 d5 18 7a 31 bf eb 8f

firmware is updated (usually less than one minute),
you must unplug the MiniProg from the USB and
plug it back in before you can select the MiniProg
from the Port list.

Device contents are displayed in hexadecimal format, as shown

XX XX
XX XX
XX XX
XX XX

XX XX
XX XX
XX XX
XX XX
XX XX
XX XX
28 60
09 00
47 32
c9 18

Flash Security data is displayed along with the “read” values.

--- Flash Security Data ---

0000: WF RUUUUUUUUUUUUTU
0400: UUUUUUUUUUUUUUUTU
0800: UUUUUUUUUUUUUUUU
0cO0: UUUUUUUUUUUUUUUU
1000: UUUUUUUUUUUUUUUU
1400: UUUUUUUUUUUUUUUU
1800: UUUUUUUUUUUUUUUU
1c00: UUUUUUUUUUUUUUUTU
2000 UUUUUUUUUUUUUUUU
2400: UUUUUUUUUUUUUUUU
2800: UUUUUUUUUUUUUUUU
2c00: UUUUUUUUUUUUUUUU
3000: UUUUUUUUUUUUUUUU
3400: UUUUUUUUUUUUUUUU
3800: UUUUUUUUUUUUUUUU
3c00: UUUUUUUUUUUUUUUU
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2.12.1 Protected Block Modes

In PSoC Programmer Description Settings
U = Unprotected Unprotected IR ER EW IW
F = Factory upgrade Read protect IR ER EW IW
R = Field upgrade Disable external write IR ER EW IW
W = Full protection Disable internal write IR ER EW IW

E/l - External/Internal; R/W - Read/Write

2.13 EEPROM Programming

Because the PSoC 3 and PSoC 5 hex files do not describe EEPROM data; PSoC Programmer does not support EEPROM
programming from the GUI. PSoC Programmer allows you to clear EEPROM data after programming PSoC 3 and PSoC 5
chips, as described in Selecting Programmer Options.

The PSoC Programmer COM does support EEPROM actions at the API level, which allows you to create scripts or utilities
that perform EEPROM actions. These examples are detailed in the Examples folder in the root installation directory of
PSoC Programmer:

[INSTALL PATH]\Cypress\Programmer\x.y.z\Examples\Programming\PSoC3 5\SWD\C Sharp EEPROM

2.14 Using Checksum

Click Checksum or press [F6] to perform a checksum operation on a device.

If a hex file is loaded, device values are compared to the loaded file. Read and Checksum operations can be completed
without a loaded hex file.

2.15 Erasing Flash Memory

The flash memory on the device attached to PSoC Programmer can be erased completely, or block by block.

2.15.1 Erasing a Block

To erase a block, the flash security for the block must be set to U—unprotected. Refer to the PSoC Designer IDE Guide for
information about protecting flash.

To erase a block of flash:

1. Select Utilities > Erase Block.
The Erase Block dialog box appears.

2. Enter the Block ID and Bank ID of the block you want to erase.
3. Click Erase Block.

% Erase Block

E raze Block Specification

T hiz block must be UINPROTECTED
S elect which Black!D in vahich BankID needs to be
erazed. Devices with one bank must set BanklD to 0

Block 10; | 00|

Bank I0: (0 Eraze Block
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If the operation succeeds, you will see the message "EraseBlock Succeeded” in the Results area. Otherwise, you will see
an error message.

2.15.2 Erasing the Entire Flash Contents

To erase all flash content, select File > Erase All or press [F9]. The Erase All function calls the EraseAll supervisory
function which performs a series of steps that destroys the user data in the Flash banks. This function also resets the
protection block in each Flash bank to unprotected.

2.16 JTAG Programming Protocol

The JTAG window shows the number of JTAG devices connected in serial. It also displays a diagram of these
devicesl, as shown in the following figure.

Lag n
‘ Part Selection 4ip | Programmer | Utilities | JTAG |
THS
TCH
) (i
= TH: OE028069 TH: OE023069
TCH TR#: 4 TEK TR#: 4
7 7 ' TO1 DE#: 35 DE.#: 35
Device Farily . S— OO 70l TOO
; TOO _I
Device
L_Sc;m Bus _l ’ Load Setup ] [ Save Setup ]

] When a Cypress device is connected, the shaded square is populated with appropriate information.

u A non-Cypress device allows you to place the critical IR and DR device information. The Device Properties
window is displayed if you click the device within the JTAG display window. You can enter the critical IR and DR
identification information and the device name. The IR and DR values are in the range of 1 to 128.

] Each device icon is selectable. You can program the selected target device using the Program button.

When JTAG deducts PSoC 5LP, two devices are shown in the JTAG tab. The first device is shown with TC's ID and second
with Cortex-M3 core ID. The detected devices are circled in red rectangle and Cortex-M3 device is switched automatically
to program PSoC 5LP silicon correctly.

| Port Selection 4p | Programmer Utilities | JTAG 7
TMS
(>
TCK
P— e 1 R i R :
L 2E13D069 TS 4BA0047T |i
'TIZH IR#: 4 TCH IR#: 4 :
_ _ {1e ] DR#: 35 DR#: 35 |!
Device Family | S Y TOO TOI T Too
: LS eerrrrrrrrrrA B rrrrrrrrrrro .T]
Device ‘
[ Scan Bus ] [ Load Setup l [ Save Setup ]
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2.16.1 Serial Programming Features

] Scan Bus — You can use MiniProg3 to scan the available device connections. The display window updates the
current configuration.

] Load Setup — You can load the display information from a .jtc file.

] Save Setup — You can save the display information into a .jtc file. This file captures all setup information, which
enables you to perform additional work and retain the setting.

2.17 Using the Patch Image Option

To use the Patch Image option, select File > Patch Image or press [F12].

You can load a hex file and connect the Miniprog1 to the target devices. PSoC Programmer reads the Flash content on the
target device and compares it with the selected hex file. Then, the PSoC Programmer replaces the Flash blocks that differ.
This feature is useful to replace calibration data or a manufacturing number. See the PSoC Programmer COM User Guide
and code examples in the root installation folder for more information on writing unique applications to complete specific
tasks.

2.18 Verify Programming

To verify device programming, select Utilities > Verify or press [F8].

Protected blocks are not verified. If the device is read-protected, the verify operation will fail. Upon completion, PSoC Programmer specifies
the number of protected blocks.

The results of the verify procedure fills the text window, flowing up from the initial operation command. To save or copy the results, right-
click the text window and then select Copy or Save As from the drop-down menu.

2.19 Upgrading Firmware
Firmware for programmers must be updated to support new and updated PSoC devices and to apply all of the latest bug
fixes.

When PSoC Programmer starts, or when a different port is selected, Programmer checks the connected programming
device firmware. If your device firmware is outdated, you will receive a warning similar to the following.

. WARNING!

This programrmer is currently out of date.

To update the Fi please g to the
Utilities Tab and press the Update Firmware
button

[] Do not show this message again

2.19.1 ICE Cube

The ICE Cube updates automatically when PSoC Programmer starts.

2.19.2 MiniProgl

When PSoC Programmer starts, or when a different port is selected, PSoC Programmer checks the connected
programming device firmware. If your device firmware is outdated, you will receive a warning similar to the following:

Port Opened with Warnings at 3:13:27 PM MINI version Expecting 1.73 got 1.67

To upgrade the firmware, select
Utilities > Upgrade Firmware.
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2.19.3 MiniProg3

Automatically upgrades FPGA and FX2LP chips when connected to the Programmer GUI. MiniProg3 requires Firmware
Upgrade for the PSoC 1 chip. To upgrade the firmware, select Utilities > Upgrade Firmware.

2.19.4 TrueTouch Bridge

Upgrades firmware using a bootloader mechanism. TrueTouch Bridge can be in two different states: Normal and Damaged.

To upgrade TrueTouch Bridge firmware in the Normal state, select
Utilities > Upgrade Firmware.

There are cases when TrueTouch Bridge is in the Damaged state. This means that the Bridge is passed in the Bootloader
mode. In this mode, it will not appear in the Port Selection list. To recover the Bridge from this state, you must upgrade it
using the same procedure used in the Normal state,

2.19.5 FirstTouch, FirstTouchRF
Upgrade not supported.

2.19.6 FTK3/5, DVKProg3/5

Automatically when connected to Programmer GUI.
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3.1 Online and Telephone Support

Free support for PSoC Programmer is available online at www.cypress.com/psoc. Resources include training seminars,
discussion forums, application notes, knowledge base articles, and code examples.

Technical Support may also be contacted by phone at 1-800-541-4736.

Before using Cypress support services, know the version of PSoC Programmer installed on your system.

3.2 Product Upgrades

Cypress provides scheduled upgrades and version enhancements for PSoC Programmer free of charge. You can order the
upgrades from your distributor on CD-ROM or download them directly from http://www.cypress.com under Software.
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