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1. Introduction

Use the PSoC Designer™ In-Circuit Emulator (ICE) guide to install and troubleshoot connection
problems with the ICE Cube. The ICE Cube provides significant debugging functionality that requires
full two-way communication between the ICE and your computer to operate. There are several steps
in the connection process, including setting up the hardware and making the communications con-
nection in the software. The ICE Cube is supported by PSoC Designer version 4.2 and later.

1.1 Support

Free technical support for PSoC Designer is available online at www.cypress.com. Resources
include training seminars, discussion forums, application notes, PSoC consultants, TightLink techni-
cal support email and knowledge base, and application support technicians.

You can also contact technical support by phone at 1-800-541-4736.

Before using Cypress support services, know the version of PSoC Designer installed on your sys-
tem. To determine the version, build, or service pack, click Help > About PSoC Designer.

Cypress provides scheduled upgrades and version enhancements for PSoC® software free of
charge. You can order upgrades from your distributor on a CD-ROM or download them directly from
www.cypress.com under Software Downloads > Software and Drivers. Critical updates to system
documentation are also available on the Cypress website.

1.2 Conventions
The following table lists the document conventions used throughout this user guide.

Table 1-1. Documentation Conventions

Convention Usage

Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

Represents menu paths:

Courier New

Italics

[Bracketed, Bold]

File > Open File > Open > New Project

Bold Digplays cqmmands, menu pgths, and icon names in procedures:
Click the File icon and then click Open.

Text in gray boxes Presents cautions or unique functionality of the product.

In-Circuit Emulator Guide, Document # 001-44612 Rev. *B 5
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1.3 Acronyms

The following acronyms are used throughout this user guide.

Table 1-2. Acronyms

Acronym Description

BIOS basic input output system.

CAT5 category 5 cable

ECP extended capabilities port

EPP enhanced parallel port

HAL hardware abstraction layer

ICE in-circuit emulator

IDE integrated development environment

LPT line printer terminal (parallel port)

OHCI open host connection interface

UHCI universal host connection interface

USB universal serial bus
6 In-Circuit Emulator Guide, Document # 001-44612 Rev. *B
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Physically connecting the ICE Cube to a Windows® compatible computer requires a few procedures
and software configuration.

Software Requirements

You need PSoC Designer 4.2 or later, or PSoC Programmer 1.22 or later, to use the ICE Cube
development hardware. The most current version of either program is available for download on the
Cypress website at www.cypress.com or on a CD-ROM from your distributor.

Install the software prior to physically connecting the hardware to your computer. Refer to the
installed software to determine system requirements.

Connecting the ICE Cube

PSoC Designer v. 4.2 and later supports the ICE Cube. This in-circuit emulator replaced the ICE-
4000 and the USB Adapter for seamless USB connection, debugging, and programming.

Figure 2-1. The ICE Cube

)
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The ICE Cube connects to any computer using a standard USB 2.0 cable, included in Cypress

Connecting to the ICE
development kits. Complete the following steps to connect the ICE Cube to your computer:
Install PSoC Designer v. 4.2 or later, and PSoC Programmer v. 1.22 or later on your computer.

2. Plug the USB cable into your computer and then attach the other end to the ICE Cube.
The ICE Cube is a plug and play device and should be recognized automatically by any computer

with PSoC Designer or PSoC Programmer installed. If USB connection problems occur, refer to

1.
Microsoft® Windows Help for troubleshooting Windows connectivity issues.

Configuring the Software

After the physical connection is made, you can configure the internal connection from the computer
To connect to the ICE from inside PSoC Designer, perform the following steps:

to the ICE. The ICE enables communication and debugging between PSoC Designer and the pod.

2.3

Confirm that the Flex-Pod is attached to the ICE Cube.
2. Confirm that the USB connection is secure from the ICE to the PC.

1.
3. Confirm that the ICE is powered from the power adapter.

4. Open a project. (Example projects are available.)
5. Click Project > Settings > Debugger.
6. Select the correct port from the drop-down window.
Upon successful connection, the Output window will report that the ICE is connected and the PSoC

7. Click Connect.
Designer status bar will show the connection status as well.

In-Circuit Emulator Guide, Document # 001-44612 Rev. *B
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Troubleshooting the ICE Cube is provided for Windows and ICE error messages. For additional
support, refer to “Support” on page 5.

Windows Errors

A common Microsoft Windows error message that may occur when installing an ICE Cube is
described in the following section. For more information on solving specific Windows problems, con-
sult Microsoft.

Cannot Install This Hardware

In Windows Me/2000/XP, if you plug in the USB Adapter before you install PSoC Designer you will
be prompted by the Found New Hardware Wizard to install an unknown USB device.

Exit the wizard, unplug the USB Adapter and then install PSoC Designer. After installing PSoC
Designer, you may need to manually install the PSoC adapter drivers. You can do this via the Device
Manager.

ICE Error Messages

Use the table listed below each error message to determine how to solve the error.

Could Not Configure ICE

Problem Solution

The system needs to reboot. System reboot may be required after installation.

Verify that no printers or other devices are assigned to the paral-
lel port used by the ICE. If a conflict is found, reassign the printer
or device to a different port or to print to a file.

There are conflicts with other software or
hardware.

Although all hardware is tested by Cypress before being shipped,
it is possible to have a faulty parallel cable, CAT5 cable, or pod.
Try swapping parallel cables or pods if possible. Swapping the
CATS5 cable is not advised. The ICE requires CAT5 cables 1 foot
or less in length with all 8 wires connected. Some patch cables

A hardware failure has occurred.

may contain only 4 wires.

In-Circuit Emulator Guide, Document # 001-44612 Rev. *B 9
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This Project is Incompatible with the Pod/Chip

Problem

Solution

An obsolete pod is connected to the ICE.

Upgrade to a current revision pod.

The wrong project is selected for the pod.

Verify that the project matches the pod type.

Invalid Memory Reference

Problem

Solution

The internal states of the ICE-base station
and pod are corrupted.

Read Application Note AN2021 "What is an Invalid Memory Ref-
erence" on www.cypress.com for a complete analysis of these
problems and their solutions.

The Selected ICE Port Cannot be Found

Problem

Solution

The USB cable is detached from either the
USB Adapter or the computer.

Plug the cable in and wait a few seconds, then press the Connect
ICE icon in the Debugger subsystem.

Could Not Configure ICE

Problem

Solution

The port settings are incorrect.

Configure the port settings in software to the correct port.

The power is disconnected.

Check the power cord connections.

The USB cable is disconnected.

Check the USB cable connections.

An ICE Port is Enumerating Please Try Again

Problem

Solution

The port is busy.

Wait a few seconds and try the connection again.

USB Hub Power Exceeded

Problem

Solution

There is not enough power available for

the device.

Attach the device to a direct power supply.

Attach the device closer to the primary USB port.

In-Circuit Emulator Guide, Document # 001-44612 Rev. *B
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When the CPU is stopped at the breakpoint, the Internal Main and Low Speed Oscillators

Specific ICE Usage Cases
Follow the steps when you debug firmware using ICE Cube.
continue to run. The analog and digital blocks, which do not need CPU intervention will continue
running. This means that components such as ADCs, Counters, and UARTs will also continue to

1.
In the debug mode the supervisory system call instructions (SSC) are executed in a special way.

2.
PSoC executes different SSC commands over different intervals —from the tens of microseconds
(for reading) to the tens of milliseconds (for writing). In the debug mode these commands are

run.
executed much longer - all commands are executed for up to 1.5 seconds.
Whenever any SSC operation is called, the USB SIE is disabled. Therefore the USB Bootloader
user modules have the "ICE_Debug_Flash_Disable" property. In the debug mode this property
must be set to "Flash Write DISABLE". When the flash write is disabled, then any application can

be completely tested, but no code is actually written to flash.

In-Circuit Emulator Guide, Document # 001-44612 Rev. *B
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4. Accessing the Computer BIOS

Methods for accessing computer BIOS setup utilities vary depending on the BIOS and computer
manufacturer. Table 4-1 lists most common BIOS providers and the typical hotkey commands used
to access their BIOS utilities. Contact the computer manufacturer for information on accessing the
BIOS of a specific computer.

Table 4-1. BIOS Hotkey Commands

BIOS Manufacturer Key Command(s)
ALR Advanced Logic Research, Inc. ® PC / PCI [F2]
ALR PC non / PCI [Ctri+Alt+Esc]
AMD (Advanced Micro Devices) BIOS [F1]
AMI (American Megatrends, Inc.) BIOS [Delete]
Award BIOS [Delete]
DTK (Datatech Enterprises Co.) BIOS [Esc]
Phoenix BIOS [Ctri+Alt+Esc]
Phoenix BIOS [CtrI+Alt+S]
Phoenix BIOS [Ctri+Alt+Insert]

4.1 Changing Parallel Port Mode

To change parallel port mode, complete the following steps:

1. Locate the parallel port mode setting in your computer BIOS or system configuration setup. The
parallel port mode settings may be located in the Advanced Settings section, Peripherals, Com-
munication, or Input/Output sections.

2. Parallel port modes set to Normal or Uni-directional will not work. Change the setting to a differ-
ent mode.

3. Exit the BIOS making sure you save the changes.

Compag computers with Compaq BIOS do not allow you to change the parallel port settings. You
must disable the DMA channel, which causes the parallel port to change to EPP mode. To do this,
turn off the DMA channel assigned to the port and use the same hardware configuration that the cur-
rent port is assigned. This will change the mode from ECP to EPP. For example; Change 0378-037F,
IRQ 7 DMA2 to 0378-037F, IRQ7. On some older Compaq computers it may not be possible to
assign the parallel port settings without a DMA setting. If this is the case, contact Compagq for a pos-
sible BIOS upgrade.

Track all changes made to the BIOS. Incorrect BIOS settings will prevent a PC from working.

In Circuit Emulator Guide, Document # 001-44612 Rev. *B 13
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5. Alternate Parallel Port Cards

If you cannot get your existing parallel port to work with the Cypress PSoC ICE-4000, you should
add a parallel port card that is known to be compatible with the ICE-4000. Cypress has tested the
parallel port cards in Table 5-1 with systems that have not connected using their existing parallel
port. One of these solutions is compatible with PCl bus-based PCs and the second uses the
PCMCIA port available on many portable computers.

Table 5-1. Alternate Parallel Port Cards

PC Type Port Parallel Port Option
Desktop PCI SIIG, In“c.® Cyberparallel PCI Model 101839, Part# JJ-P00112
www.siig.com
Notebook PCMCIA Quatech SPP-100 EPP Parallel PCMCIA Card.
www.quatech.com/catalog/parallel_pcmcia.php

Follow the manufacturer instructions to install and configure these parallel ports. These cards
include drivers that support Windows 98, 98SE, Me, NT, 2000, and XP.

5.1 Selecting an Alternate Parallel Port

If the new parallel port card is installed as LPT2, PSoC Designer must be configured to use LPT2. To
select an alternate parallel port:

1. Click Project > Settings.

2. Inside the dialog box, select Debugger.
3. Click the drop-down menu box, select LPT2, and then click OK.
4. Verify the connection by clicking the Connect icon.

If the ICE-4000 still does not connect, make sure it is connected to the correct parallel port. Also, ver-
ify that the parallel port is installed correctly according to the manufacturer’s instructions. The PC
may need to be restarted after installing the new parallel port. If the PC is restarted, verify that the
correct parallel port is still selected when re-entering PSoC Designer.

In Circuit Emulator Guide, Document # 001-44612 Rev. *B 15
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Appendix A Build an Emulator

Al

Most of us agree that being able to emulate the circuit before going to volume production will greatly
improve engineering efficiency and avoid budget overrun. However, due to mechanical limitations
(packages with small footprint such as TSSOP or MLF/QFN) or electrical limitations (inductance
generated from long cable), standard emulations are sometimes inadequate. Often the best solution
is to add emulation capability with ICE connection onto your own board. AN2323 outlines how to
include emulation circuitry on your board and get you emulating your design in no time.

Critical Components

To build your own on-board emulation circuitry, you need the following components:

Table 6-1. Build of Materials List for PSoC Emulator Circuit

Quantity Description Notes
1 RJ45 connector ﬁg/ﬁ/;';/f:’\cl)[)lilectromcs 5557785-1 DigiKey Part Number
1 PSoC OCD part
4 56-ohm resistor 1/16W 5%
4 1 kQ resistor 1/16W 1%
1 330 pF capacitor 5.0 V Ceramic NPO
3 0.1 yF capacitor 5.0 V Ceramic Y5V

All series resistors are used as termination, for impedance matching on the signal lines. Bypass
capacitors are included to filter out AC noise from the circuit.

Figure A-1 details the mechanical drawing information for the AMP/Tyco CAT5 connector that con-
nects with the CY3215-DK ICE-Cube debugger. For more information on the CY3215-DK, visit
www.cypress.com/go/CY3215-DK.

Figure A-2 details the schematic layout for the emulation circuit. Table 6-1 details information regard-
ing the components needed to complete the PSoC Emulation Circuit.

For board layout, restrict your trace length to less than 4 inches and match length on OCDHC,
OCDCC, OCDDO, and OCDDE (48 MHz, square wave).

AMP5557785-1 has two configurations. AN2323 uses CAT5 jack configuration, others might use tra-
ditional jack configuration.

In Circuit Emulator Guide, Document # 001-44612 Rev. *B 17
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Figure A-1. Mechanical Drawing for AMP/Tyco 5557785-1(CAT5)
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A.2

Device Family Information

For every PSoC device family, there is only one on-chip debugger (OCD) package. Note that the
OCD package may or may not be available for production volumes.

Cypress does not recommend shipping product with OCD devices on board.

The following table lists the available PSoC 1 device families, the OCD part number, Package Infor-

mation and a link to the Datasheet or Technical Reference Manual (TRM). The Datasheet or TRM
provides detailed information on OCD pin out and package information. This information is critical for
PCB layout and system development. Do refer to Datasheet and TRM for latest device information.

If the table lists 'N/A' then the device family does not offer OCD devices that can be ordered.

Table 6-2. Device OCD Part Summary

PSoC Device OCD Part Number OCD Package Datasheet/TRM Web Link
CY8C20x34 CY8C20000 48 QFN CY8C20x34
CY8C20xx6A CY8C20066 48 QFN CYB8C20xx6A
CY8C21x23 CY8C21001 56 SSOP CY8C21x23
CY8C21x34 CY8C21001 56 SSOP CY8C21x34
CY8C22x45 CY8C22045 56 SSOP CY8C22x45
CY8C21x45 CY8C22045 56 SSOP CY8C21x45
CY8C23x33A N/A N/A N/A
CY8C24x23A CY8C24000A 56 SSOP CY8C24x23A
CY8C24x33A CY8C24033A 56 SSOP CY8C24x33A
CY8C24x94 CY8C24094 100 TQFP CY8C24x94
CY8C27x43 CY8C27002 56 SSOP CY8C27x43
CY8C28xxx CY8C28000 56 SSOP CY8C28xxx
CY8C29xxx CY8C29000 100 TQFP CYBC29xxx
CY8CLEDO02 N/A N/A N/A
CY8CLEDO0O4 N/A N/A N/A
CY8CLEDOx0x CY8CLEDOx0OCD1 56 QFN CY8CLEDOx0x
CY8CLEDO08 N/A N/A
CY8CLED16 N/A N/A N/A
CY8CLED16P0x CY8CLED16P01 56 QFN CY8CLED16P0x

In Circuit Emulator Guide, Document # 001-44612 Rev. *B
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Document Revision History

Document Title: PSoC Designer™ In-Circuit Emulator Guide
Document #: 001-44612

Revisi Origin of

on ECN # | Issue Date Change Description of Change
> 2503614 | 05/18/2008 |WBZ New document to be released with PSoC Designer 5
*A 3271510 |06/03/2011 |WBZ Section 3.3 added - specific ICE usage cases..
*B 3728804 | 08/30/2012 |WBZ Updates and new screenshots.

Updates for PSoC Designer 4.2, including name change.

Updates for PSoC Designer 4.2, including name change. This guide encom-
passes the old PSoC ICE Connection and Troubleshooting Guide and the
old PSoC ICE USB Adapter guide

Added a chapter Appendix A - content from AN2323.
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