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Cypress product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted 
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Trademarks 

All trademarks or registered trademarks referenced herein are property of the respective corporations.  

Source Code 
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by and subject to worldwide patent protection (United States and foreign), United States copyright laws and international 
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representation of this Source Code except as specified above is prohibited without the express written permission of 
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Disclaimer 

CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATERIAL, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described 
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein. 
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure 
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support 
systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against 
all charges.  

Use may be limited by and subject to the applicable Cypress software license agreement.  
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1.   Introduction 

 

This document describes the Graphics Authoring Tool for the S6E2Dx Series (GAT-D). With this software, users without 
programming experience can design a human machine interface (HMI) and generate the source code for graphics firmware. 
Figure 1-1 shows a system summary for the tool. 

Figure 1-1. System Summary 

 

1.1   System Requirements 

Hardware  

 CPU: 1 GHz or more 

 Memory: 512 MB or more 

 Hard disk: More than 1 GB of free space 

Operating system  

 Windows 7 (32-bit or 64-bit) 

 Administrative privileges for software installation.  
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1.2   Glossary of Terms 

Table 1-1. Glossary of Terms 

Term Meaning 

Alpha blending The semitransparent effect which is to blend overlaid two image data according to a specific alpha value of 
each pixel. 

CLUT The color lookup table that stores the colors and index for its color. 

The index value in the CLUT is used for the pixel display of the object.  

The maximum number of CLUTs differs depending on the graphics display controller (GDC). 

Drawing frame The drawing area. 

Folder Place where files are stored, which include the page and the flow design table in the project. 

Layer The basic element forming a page. A layer can contain a number of windows. 

Object The two type objects that are vector graphics and sprite. 

Page The basic element forming the GAT-D project. The page has two layers, and can draw the overlapped them. 

Palette Stores the color value for pixels forming the object (such as a bitmap). 

Project Stores all the resources and management information. 

RGB The three primary colors: red, green, and blue. In RGB format, colors are combinations of red, green, and 
blue. 

Sprite object A bitmap image object. 

Vector graphics object A vector object such as line, rectangle, and circle. 

Window The display area on a layer. An object is displayed only if it is inside a window, so all objects must be added 
to a window. 

Z-order The order of the layers on the same page. 

1.3   Restrictions 

In GAT-D V01 SP1, only the functions related to the sprite and vector graphics (line, rectangle, and circle) are supported.  
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2.   Installing and Uninstalling GAT-D 

 

2.1   Installing the Tool 

The GAT-D software is easy to install.  

1. Run the installation program. The setup wizard appears, as shown in Figure 2-1.  

2. Click Next; the License Agreement dialog appears, as shown in Figure 2-2.  

Figure 2-1. Setup Wizard Dialog 
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Figure 2-2. License Agreement Dialog 

 

 

3. If you accept the terms of the license agreement, select I Agree, and then click Next to go to the next installation dialog 
as shown in Figure 2-3. 

Figure 2-3. Customer Information Dialog 

 

 

  



 Installing and Uninstalling GAT-D 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 9 

4. The installation folder represents the installation path of the software. The install path is set the default path. Click 
Browse to select the installation path and then click Next to go to the last dialog as shown in Figure 2-4. 

Figure 2-4. Confirm Installation 

 

 

5. Click Back to return to the previous dialog, or click Next to continue. After you click Next, the Installation Complete 
dialogs appears, as shown in Figure 2-5. 

Figure 2-5. Installation Complete Dialog 
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6. Click Finish. The overall installation is finished, and the software is installed on your computer. You can run it with 
Start  > Programs > Cypress > GAT-D V01 > GAT-D V01.  

Notes:  

1. This software must be installed by someone with system administrator privileges.  

2. Uninstall any previous version of the software before you start the installation. If the system has an existing 
installation of an earlier version, the new installation will fail. 

2.2   Uninstalling the Tool 

This software includes an uninstall shortcut in the Start menu.  

Run Start > Programs > Cypress > GAT-D V01 > Uninstall to uninstall the software from your computer. 

You may also uninstall it using the Add/Delete Programs option in the Control Panel. 

  



 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 11 

3.   Quick Start 

 

This chapter explains a series of operations from making the project to generating the code of the application for the 
S6E2Dx Series. A typical workflow is shown in Figure 3-1. 

Figure 3-1. Typical Workflow 
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3.1   GAT-D Startup 

When GAT-D is launched, the startup screen appears as shown in Figure 3-2. 

Figure 3-2. Startup Screen 
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3.2   Creating a New Project 

To create a new project, choose Project > New. The New Project dialog appears as shown in Figure 3-3. Enter the 
Project Name and select the Saving Location. Select the LCD Size. 

Figure 3-3. New Project Dialog 
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3.3   Creating a New Page 

To create a new page, right-click on the Project Explorer and select New Page as shown in Figure 3-4. The new page 
opens in GAT-D as shown in Figure 3-5. 

Figure 3-4. New Page 

 

Figure 3-5. New Page Open 

 

  



 Quick Start 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 15 

3.4   Adding an Image to the Image Library 

To add an image to the Image Library, select the Image Library tab as shown in Figure 3-6. Right-click on the Image 
Library, select Add New Image from the context menu, and select the image to add when the file dialog box opens. 

The image is added to the image library as shown in Figure 3-7. 

Figure 3-6. Add New Image 

    

 

Figure 3-7. Image Library 
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3.5   Adding a Window 

To add a window, select the Window icon in the drawing bar and drag it to the working area as shown in Figure 3-8, where 

① is the window drawing button, ② is the window top-left point, and ③ is the window bottom-right point.  

An empty window is added to the current layer (see Figure 3-9). 

Figure 3-8. Creating a Window 

 

 

Figure 3-9. Created Window 
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3.6   Creating an Image Sprite Object 

To create an image sprite object, select the window for adding a sprite object on the Page. Then drag and drop the image 
from the Image Library to the Page, as shown in Figure 3-10. 

Figure 3-10. Dragging Image to Sprite Object 

 

 

3.7   Setting a Sprite Object 

A sprite object is set as a basic sprite by default. Properties of a sprite object can be changed in the Properties dialog. Its 

dialog can be called by selecting Properties in the context menu of a sprite object. It can be called by double-clicking a 
sprite object on the working area too. 

See Sprite Object for details on each tab in the GUI. 
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3.8   Flow Design and Simulation 

Flow design provides definitions for displaying a page and is composed of an “action” and an “event”. See Flow Design for 
details. 

To create a new Flow Design Table, select the New Flow Design in the context menu (Figure 3-11). Flow Design dialog 
appears. Then, click the Action Table tab on the dialog. Add one action to the list in the upper part of the dialog, as shown 

in Figure 3-12 ①. Then, the name of the action can be set in the Action column, as shown in Figure 3-13 ②. Select the 

targeted Page in the Page column as shown in Figure 3-13 ③. 

Figure 3-11. New Flow Design 

 

 

Figure 3-12. Action Table for Adding an Action 

.  

① 
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Figure 3-13. Action Table 

 

 

When you click the Object Timeline Editor in the Action Table tab as shown in Figure 3-13 ④, the Timeline Editor dialog 

appears as shown in Figure 3-14. In this dialog, the display definition of each object is set by frame unit. See Object 
Timeline Editor for details. 

Figure 3-14. Timeline Editor 

  

② 

 

③ 

 

④ 
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3.9   Code Generation 

Choose Compile > Resource to open the Operation Code and Data Library Generation dialog box. Keep the default 
settings and click OK. The code will be generated and the information box displaying Code Generation Completed will 
appear as shown in Figure 3-15. 

Figure 3-15. Code Generation 
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4.   Operation Interface 

 

4.1   Project Main Picture 

Figure 4-1 shows the main picture of the GAT-D application. Its framework is divided into eight parts: menu, toolbar, draw 
bar, Project Explorer, Image Library, Layer Window, status bar, and working area. In addition, it has three auxiliary dialogs: 
Object Browser, Preview Window, and Memory Information. 

GAT-D will select the default display language based on the language used in the Windows system. This will be set at initial 
startup only. GAT-D supports English and Japanese. If the Windows system uses a language other than English or 
Japanese, GAT-D will select English as the default language. In addition, you need to restart GAT-D after changing the 
display language at View > Language. 

Figure 4-1. Main Picture 
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4.2   Project Menu Bar 

The menu bar of the GAT-D application includes Project, Edit, View, Design, Option, Compile, and Help. 

Figure 4-2. GAT-D Menu Bar 

 

4.2.1   Project 

The Project menu includes New, Open, Recent Project Opened, Close, Close Project, Save, Save As, Save a Copy As, 
and Exit.  

Figure 4-3. Project Menu 

 

4.2.2   Edit 

The Edit menu includes Undo, Redo, Copy, Cut, Paste, Delete, Select All, Clear Selection, and More Selection, which 
contains Select All Sprites. 

Figure 4-4. Edit Menu 
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4.2.3   View 

Status Bar, Toolbar, Draw Bar, Project Explorer, Image Library, and Layer Window in the View menu are flags for displaying 
/ not displaying on the main picture. 

Figure 4-5. View Menu 

 

 

Object Browser calls the dialog for the Object Browser. See Object Browser. 

Preview Window calls the dialog for previewing each page. See Preview Window. 

Resource Count calls the dialog for memory information. See Memory Information. 

Grid > Visible indicates whether the grid line is displayed in the working area as shown in the left-hand side of Figure 4-6. 

Grid > Grid Setting calls the dialog for setting the spacing of grids in the working area as shown in the right-hand side of 
Figure 4-6. 

Ruler > Visible indicates whether the ruler is displayed in the working area as shown in Figure 4-7. 

Zoom is used to select the zooming factor of the display as shown in Figure 4-8.  

Pixels Aspect Ratio enables you to manage the aspect ratio in the working area as shown in Figure 4-9.  

 New 

Create a new pixels aspect ratio (PAR) with the setting name and factor, which is the aspect ratio.  

 Delete 

Delete the existing PAR. 

 Edit 

Edit the parameters of the existing PAR.  

Note: The PAR selection will be applied to the whole project. The selected PAR will be marked with a checkmark (√). 

Language is used to select the display language of the GAT-D interface. 

Note: Restart GAT-D after changing the display language. 
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Figure 4-6. Grid 

  

 

Figure 4-7. Ruler 

  

 

Figure 4-8. Zoom 

 

Figure 4-9. Pixels Aspect Ratio 

 

  

Ruler 
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4.2.4   Design 

The Design menu includes New, Copy Page, Paste Page, Copy Layer, Paste Layer, Copy Window, Paste Window, Import, 
Lock/Unlock, Common Color Setting, and Project Properties. 

In addition, the New menu contains Page and Flow Design.  

Note that Palette, Font, and String Table are disabled in GAT-D V0.1 SP1. 

Figure 4-10. Design 

 

 

Copy Page and Paste Page are operations for copying and pasting a page. See Page for details. 

Copy Layer and Paste Layer are operations for copying and pasting a layer. See Layer for details. 

Copy Window and Paste Window are operations for copying and pasting a window. See Window for details. 

Import > Page (Figure 4-11) is used to import a PSD file image to the Image Library of the project. See Page for details. 

Common Color Setting is used to set the global color setting used in the project. See Common Color Setting for details. 

Project Properties… contains the project parameters. See Project Property for details. 

Figure 4-11. Import > Page 
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4.2.5   Option 

The Option menu includes Path and Setting. Options. The Path > External Graphic Editor option sets the external 
editor tool for editing the image(s) in the Image Library. See Image List for details.  

Note: External editor tool is the image editing software such as Microsoft Paint software of Windows.  

Path > Compiler… is disabled.  

Setting calls the dialog for setting auto save and the frame on the work area. See Setting Window for details. 

Figure 4-12. Option 

 

4.2.6   Compile 

The Compile menu includes only Resources. It is used to generate the operation code. See Code Generation for details. 

Figure 4-13. Compile 

 

 

 

4.2.7   Help 

The Help menu includes About GAT-D V01…. It calls the dialog for the GAT-D information, which is the version number and 
copyright notice of GAT-D.  

Figure 4-14. Help 

 

Figure 4-15. About GAT-D information 

 

4.3   Project Toolbar 

The toolbar includes shortcuts for common functions in the GAT-D, including New Project, Open Project, Save Project, 
Undo, Redo, Cut, Copy, Paste, and Help. 

Figure 4-16. Toolbar 
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4.4   Project Draw Bar 

The draw bar includes shortcuts for selection tool and line, rectangle, circle, sprite, polygon(*), freehand-line(*) and window 
drawing tools. See Object for details. 

Note: GAT-D V01 SP1 does not support polygon and freehand-line. 

Figure 4-17. Draw Bar 

 

4.5   Working Area 

Figure 4-18 shows the working area, which is a preview of the current layer. You can design the layout of the layer in the 
working area. It contains three parts: edit area, display setting area, and object status area. You can edit layers in the edit 
area; for example, add or delete a window and object, change layer properties, and so on. You can set the display setting 
by using three options: Show Display Frame, Show Layer Area, and Show Window. You can select one or more of them at 
the same time. The object status area shows the coordinate position, the name of the current selected object, and the RGB 
value of the current position for the mouse. 

 Display Setting 

Show Display Frame: Displays the display frame 

Show Layer Area: Displays (= coloring) the layer area 

Show Window: Displays the window frame 

Notes: 

1. The working area enables you to design only one layer. It cannot show the real appearance, which is integrated into 
the multiple layers. To view the real appearance, use the Preview Window or run the Simulation. 

When the window’s Blend Operator option is not selected, the position of a Sprite object that is located on its window is 
changed to top-left on its window. Note that this position change is made when the Preview Window is called or when 
Simulation starts.  

Figure 4-18. Working Area 

 

Figure 4-19 shows an example of the two options selected. The red and white dotted line represents the display area, and 
the green area is the layer area. The preview color for Display Frame can be changed via Option > Setting. 

Edit area 

Display setting area 

Object status area 



 Operation Interface 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 28 

Figure 4-19. Display Area and Layer Area 

 

4.6   Project Explorer 

The Project Explorer is similar to Windows Explorer. You can use it to explore and manage the folders of the current project 
and all resource files. The right-click menu of the Project Explorer enables editing folders and resource files. 

Five folders are automatically created as shown in Figure 4-20. Their folders cannot be renamed or deleted. Note that Color 
Palette, Font, and StringTable folders are disabled in GAT-D V01 SP1.  

Figure 4-20. Project Explorer 

 

The subfolder of each folder and the files of each folder (subfolder) within the Project Explorer can be sorted in 
alphabetically ascending or descending order. 

Figure 4-21. Sorting in the Project Explorer 
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4.7   Image Library 

The Image Library menu enables you to add image files to the project. It lets you preview the image and view its properties, 
and group the loaded image files to edit the image file/folder with the right-click menu. See Image Library Setting for details. 

Figure 4-22. Image Library 
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4.8   Layer Window 

Figure 4-23 shows the Layer Window. It is used to select the displayed layer in the working area of the Page. See Layer for 
details. 

Figure 4-23. Layer Window 
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4.9   Object Browser 

Figure 4-24 shows the Object Browser dialog which can be called via View > Object Browser. This dialog lists objects with 
accompanying information. Listed objects are enabled to filter by the associated page, layer, and window. Moreover, the 
objects can be sorted by clicking title row of the list.  

Note: See Object to learn the Lock column of list. 

Figure 4-24. Object Browser 

 

 

See Context Menu to learn the context menu as shown in Figure 4-25. 

Figure 4-25. Context Menu 
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The viewing options for filtering are four radio buttons at the bottom-left of Figure 4-25: 

 Current Project 

Lists all objects in the project 

 Current Page 

Lists all objects in the selected page 

 Current Layer 

Lists all objects in the selected (displayed) layer 

 Current Window 

Lists all objects in the selected window. The viewing options for selected objects are three buttons at the bottom-right of 
Figure 4-25:  

 Highlight the selected object of the window 

The selected object column in the working area will be highlighted in the Object Browser. 

 Select current object in the window 

The selected objects in the Object Browser will be selected in the working area. 

 Delete 

The selected objects in the Object Browser will be deleted from the working area. 

4.10   Preview Window 

Figure 4-26 shows the Preview Window for pages. This dialog integrates multiple layers and enables you to zoom from 1% 
to 400%. 

When you double-click on the Preview Window, it is adjusted to the LCD size. However, when the LCD width exceeds 800 
or the height exceeds 600, the Preview Window cannot be automatically adjusted. 

To view the Preview Window, choose View > Preview Window or press F7. 

Figure 4-26. Preview Window 
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4.11   Memory Information 

The Memory Information dialog contains three parts: the bar chart of usage, the concrete data, and the page list. The 
concrete data includes three items: 

 Capacity 

Maximum VRAM capacity that the hardware can offer 

 Used Space 

VRAM consumption in the current page 

 Free Space 

Free VRAM space in the current hardware 

Note: GAT-D V01 SP1 offers memory information for the internal VRAM on the S6E2Dx series only. Thus, it does not 
display correctly when user expands VRAM with the using Hyper-RAM etc. 

Select a different page from the page list to see the VRAM usage of a different page. 

To view the Memory Information dialog, choose View > Resource Count. 

Figure 4-27. Memory Information Dialog 
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4.12   Default Settings 

The Page background color, Window transparent color, and Window alpha blending color are the default settings in a 
project. To select the default settings in a project, use the Common Color Setting dialog and Setting dialog. 

4.12.1   Common Color Setting 

The Common Color Setting dialog can be used to select the color value and color conversion method in the project. To view 
the Common Color Setting dialog, choose Design > Common Color Setting. 

Figure 4-28. Common Color Setting Dialog 
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4.12.2   Setting Window 

The options in the Setting dialog are Auto Save, Display Frame Color, and Window Area Color. To view the Setting window, 
choose Option > Setting. 

Figure 4-29. Setting Window 
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5.   Design and Use 

 

This chapter describes the GAT-D functions in detail. 

5.1   Introduction 

GAT-D includes the following functions: 

 Project 
 Image Library Setting 
 Page Design 
 Flow Design 
 Simulation 
 Code Generation 
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5.2   Project 

This supports operations to create/open/close/save/save as a project and to set the project properties. 

5.2.1   New Project 

You can create a new project via Project > New or the shortcut ( ) in the toolbar. 

Figure 5-1. New Project Dialog 

 

Note: Selection of the Template affects the Memory Information displayed on GAT-D. Template lists only the S6E2DH 
series. When using the S6E2D3/5/F series, use the template for the S6E2DH series.  

 Project Name 

This is name of a new project and is required 

 Saving Location 

Saving a path for the new project is required. You can select it from Windows Explorer by clicking the Browse button. 

 Template 

This is the template used by the new project. The current template is used as the default. 

 Mode 

This is screen mode at startup. Only window mode is supported. 

 LCD Size 

This is the display size of the Page. Select the size from the pull-down list. If you select the custom item, you may enter the 
free size for LCD in Width and Height boxes. 

 Description 

This is the information for a current GDC. 
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5.2.2   Open 

You can open an existing project via Project > Open or the shortcut ( ) in the toolbar.  

Figure 5-2. Open Dialog 

 

 

5.2.3   Close Page 

You can close the current page in a project via Project > Close. 

5.2.4   Close Project 

You can close the current project via Project > Close project. 

Note: If the project is not saved, GAT-D provides an alert. 

5.2.5   Save 

You can save the current project via Project > Save or the shortcut ( ) in the toolbar. 

5.2.6   Save As 

You can save the current project to another location via Project > Save As. 



 Design and Use 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 39 

Figure 5-3. Save As the Project 

 

Select the path, name the project, and click Save. 

Note: The path for Save As should not be the folder of the current project or its subfolder. If it is, the project cannot be 
saved. 

5.2.7   Save a Copy As 

You can save the current project as another project folder via Project > Save a Copy As. 

Figure 5-4. Select Folder Dialog 

 

Select the path and click Save to finish in Windows Explorer. 

Note: The path for Save a Copy As should not be the folder of the current project or its subfolder. If it is, the project cannot 
be saved. 

5.2.8   Project Property 

You can display the Project Property dialog by choosing Design > Project Property or selecting Properties … from the 
context menu when you right-click on the project name in the Project Explorer. The Project Property dialog has three tabs: 
General, Page Summary, and Display Frame. 
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5.2.8.1 General 

Figure 5-5. Project Property, General Tab 

  

 Project Path 

This displays the saving path for the current project files and is read-only. 

 LCD Size 

This displays the current LCD size and enables you to change it. 

 GDC Information 

This displays the information of the current GDC. 
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5.2.8.2 Page Summary 

The Page Summary tab displays all the pages information in the current project. The information is read-only. 

Figure 5-6. Page Summary Tab 

  

 

5.2.8.3 Display Frame 

The Display Frame tab displays the width and height of the display area. The information is read-only. 

Figure 5-7. Display Frame Tab 
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5.3   Image Library Setting 

This function supports loading, editing, and filtering image(s). The Image Library contains four parts: Image preview 
window, image information, image list, and filter. See Figure 5-8. 

Figure 5-8 Image Library 

 

 

5.3.1   Image Preview Window 

This part previews the selected image in the image list. You can drag and drop the image from the image preview window 
into the working area. 

Note: When the selected image is too large to display, it will automatically be scaled down to fit the preview window. 

5.3.2   Image Information 

This part displays the information of the selected image in the image list. Its information includes Width, Height, Color 
Depth, Color Used, and Number of Frames. 
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5.3.3   Image List 

This part displays the list of images loaded into the project. It includes a thumbnail, file name, and size and enables you to 
load an image file into the project. In addition, the list switches to ascending/descending order when you click the name 
column in the list. 

The following are the instructions on how to manipulate the image list. When you right-click here, a menu as shown in 
Figure 5-9 is displayed. 

Figure 5-9. Manipulation of Images 

 

Notes: 

1. When you select the folder icon in the image list, Add New Image and Create New Group options are available.  

2. When you select the image file icon, Send To..., Rotate..., Create Invert Bitmap, Convert To Bitmap, Edit, Edit As New, 
Cut, Copy, Paste, and Rename options are available. 

3. Extract Color Palette is always disabled. 

 Add New Image 

Load the image file into the image list. When you select this menu item, the dialog box for adding image files is displayed. 
The supported image types are BMP, JPG, GIF, PNG, and PSD. 

Note:  

1. The imported image file must be smaller than 2048 x 2048 pixels in order to convert to sprite object. See Sprite Object. 
2. If loading a GIF file, each frame image in the file is stored as the independent file. If loading a PSD file, a composite 

image of all layers in the file is stored as BMP file, and each layer in the file is stored as independent file. 
 

 Delete 

Delete one or more image(s) or the folder. 

Note: The used image(s) and the folder containing the used image(s) cannot be deleted. 

 Create New Group 

Create a new folder for grouping image(s) in the list. 
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 Send To... 

Send one or more image(s) to another group folder. It may be <New Group>, No Group, or an existing group. See Figure 
5-10. 

Figure 5-10. Send To 

 

 

 Rotate... 

Rotate the image by 90 degrees based on the selected image. The direction of rotation enables you to select the options 
shown in Figure 5-11. 

Figure 5-11. Rotate 

 

 Create Invert Bitmap 

Generate an inverted image of the selected image and add it to the list. 

 Convert To Bitmap 

Convert the selected image into the BMP format, and add it to the list. 

Note: This option is not available for BMP images or multi-frame GIF images. 

 Edit 

Edit an image by calling an external image editor tool, since GAT-D does not implement the edit function.  

Note: The default editor tool can be selected via Option > Path > External Graphic Editor.... If you do not set a default 
editor tool, GAT-D will request you to select the editor tool every time. 

 Edit As New 

After copying the selected image, edit the copied image by calling an external image editor tool. 

 Extract Color Palette 

This UI is disabled. 

 Cut/Copy/Paste 

These commands relating to existing image(s) can be used within or between projects. 

 Rename 

Rename the image and the group folder. 

Note: The name must be a combination “a-zA-Z_”. However, first character must not use “0-9_”. Max number of characters 
is 30. 

  



 Design and Use 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 45 

5.3.4   Filter 

The filter settings filter the images displayed in the Image Library. There are five types of filtering (radio button): 

 All Images 

No filtering 

 All Images Used 

Displaying only the used image(s) in the project 

 All Images Used on Current Page 

Displaying only the used image(s) on the selected page 

 All Images Used in Current Layer 

Displaying only the used image(s) in the selected layer 

 Others… 

This customizes the filter. Customizing setting can be set in the Filter Setting dialog as shown in Figure 5-12, which is 
called when pushing Configure button. 

Figure 5-12. Filter Setting 
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 Name 
Enter the name or type of image for filtering. 

 Dimension 

 Any dimension: The dimension does not use filtering. 

 Custom: Set the dimension for filtering. 

 Status 

This sets the rough filter. 

 All Images: Does not use the rough filter. 

 All Images Used: Unused images are filtered out. 

 All Unused Images: Used images are filtered out. 

Note: When you select All Images Used, the Page and Layer parts are available to set. 

 Page 

This sets the page-level filter. 

 All pages: All image files used in any page file are extracted. 

 Current page: All image files used in the current page are extracted. 

 Custom: All image files used in the selected pages are extracted. 

 Layer 

This sets the layer-level filter. 

 All layers: All image files used in any layer are extracted. 

 Current layer: All image files used in the current layer are extracted. 

 Custom: All image files used in the selected layers are extracted. 

5.3.5   Supported Image Formats 

GAT-D supports the image formats listed in Table 5-1. 

Table 5-1. Image Formats 

Image Format 

BMP 

JPEG 

GIF 

PNG 

PSD 
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5.4   Page Design 

This function supports create/set Page, Layer, Window, Sprite, and Vector graphics. 

5.4.1   Page 
The Page is handled from the menu that appears when you right-click on the Project Explorer or choose Design > New 
Page in the menu bar, as shown in Figure 5-13. 

Figure 5-13. Menu for Page 

  

 

 New Page 

When you select New Page or choose Design > New > Page, the new page is created in the Page folder on the Project 
Explorer. 

 Delete 

When you select Delete, the selected page is deleted from the project. 

 Rename 

When you select Rename, the selected page can be renamed. 

 Note: The name must be a combination “a-zA-Z_”. However, first character must not use “0-9_”. Max number of characters 
is 30. 

 Lock 

When you select Lock, the configuration of the selected page is locked. Locking the page also locks the Layer, Window, 
and Object on it at the same time. 

 Unlock 

When you select Unlock, the configuration of the selected page is unlocked. However, the Layer, Window, and Object 
which belong the selected page are held the locked status.  

 Copy 

When you select Copy, the selected page is copied. 

 Cut 

When you select Cut, the selected page is cut. 

 Paste 

After you execute Copy or Cut, the Paste command is enabled.  

Note: A resource file can be pasted only to a folder of its own type. Thus, a page file can be pasted only to a page folder or 
its subfolder. The Paste command in the context menu of other folders will be disabled. 
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 Properties 

When you select Properties…, the Properties dialog of the selected page is displayed. The Page Properties dialog 
contains one tab: General. 

5.4.1.1 Properties 

 Figure 5-14 shows the Page Properties dialog.  

Figure 5-14. Page Properties Dialog 

 

 

 Name 

The name of the current page is editable. 

 Page ID 

The page ID of the current page is not editable. 

 Layer Summary 

This is basic information that pertains to all layers in the current page. 

 Background Color 

This is the background color of the current page. 

 Memory Usage 

This displays the memory usage of the current page. 

 Lock 

This option locks the page. Nothing on the page can be changed until the page is unlocked. 
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5.4.2   Layer 
The Layer Window has six columns: visible status, edit status, lock status, layer name, current Z-order, and layer preview 

color. The parameters of each layer are set in Properties of the context (right-click) menu. Moreover, double-clicking on 
the layer name or layer color enables you to change them.  

Figure 5-15. Layer Window 

  

 Visual status 

Double-click the icon ( ) in the Layer Window to show or hide the layer of the current page. 

 : The layer is shown. 

 : The layer is hidden. 

Note: A layer cannot be hidden while it is being edited. 

 Edit status 

Double click the icon ( ) to edit the layer. 

 : The layer can be edited. 

 : The layer cannot be edited. 

 Lock status 

The layer cannot be edited when it is locked. Double-click the lock icon in the Layer Window. The layer will toggle between 
locked and not locked. 

 : The layer is locked. It cannot be edited. 

 : The layer is not locked. It can be edited. 

 

Edit status 

Lock status 

Visual status 

Layer name 

Z-order 

Layer preview color 

Context menu 
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 Layer name 

Double-click the layer name column in the Layer Window to rename it. 

Note: The name must be a combination “a-zA-Z_”. However, first character must not use “0-9_”. Max number of characters 
is 30. 

 Z-order 

This displays the Z-order of the layer. You can change it by dragging and dropping the layer. 

 Color 

Double-click the Color area to select the preview color for the layer, as shown in Figure 5-16. 

Figure 5-16. Color 

 
 

Note: The preview color is used to display layers only in GAT-D; it does not exist in the generated code.  

 Right-click menu 

Copy: This UI is disabled. 

Paste: This UI is disabled. 

Property: Display the Layer Properties dialog. See the next section. 

5.4.2.1 Layer Properties 

When you double-click a selected layer in the working area or select Properties…” from the context menu in the Layer 
Window, the Layer Properties dialog is displayed. 

Layer Properties has two tabs: General and Object Order. 
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Figure 5-17. General Tab 

 

 

 Name 

The name of the layer is alterable. 

 Multi-Window 

When you select this option, the window is displayed in multi-window mode. 

Multi-window mode enables you to allocate up to eight windows per the layer. 

Non-multi-window mode enables you to allocate only one window to the layer. 

Note: Only one of the two layers can be set as a multi-window layer. 

 Drawing Frame Dimension 

This is the display size of the drawing frame. The information is read-only. 

 Layer Order 

This shows the layer order. 

 Priority Order 

This parameter is fixed. 
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Figure 5-18. Object Order Tab 

 

 List of object type 

This is a list of the types of object. Note that it is fixed to the Window type at the Layer Properties dialog. 

 Object list 

This is a list of the objects in the current layer that match the selected object type. 

A larger index value appears at the top of the working area. 

5.4.3   Window 

Before you add the object, the window must be added to the layer. The window is handled as follows: 

5.4.3.1 Basic Operations 

 Add 

Select the window icon from the draw bar. Then click on the working area. A window with the default size (100 x 100) is 
added. You can resize the window by controlling the fill handle or setting the property of the Window.  
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Figure 5-19. Add Window 

 

 

 Lock 

Locks the state of both the window and the object that belongs to the locked window. Select the window. Then either right-
click or select Lock in the context menu or choose Design > Lock in the menu bar. See Context Menu. 

 Unlock 

Unlocks the window that is in the locked state. Note that the object that belongs to the unlocked window is not unlocked. 
Select the locked window. Then either right-click and select Unlock in the context menu or choose Design > Unlock in the 
menu bar. See Context Menu. 

 Copy 

Copies the window. When you copy a window, the object that belongs to it is copied too. Select the window. Then either 
right-click and select Copy in the context menu or choose Edit > Copy in the menu bar. See Context Menu. 

 Cut 

Cuts the window. When you cut a window, the object that belongs to it is cut too. Select the window. Then either right-click 
and select Cut in the context menu or choose Edit > Cut in the menu bar. See Context Menu. 

 

 Paste 

Pastes the object that has been cut or copied by either right-clicking and selecting Paste in the context menu or choosing 
Edit > Paste in the menu bar in the targeted layer. See Context Menu. 

 Delete 

Deletes the window. When you delete a window, the object that belongs to it is deleted too. Select the window. Then either 
right-click and select Delete in the context menu or choose Edit > Delete in the menu bar. See Context Menu. 

 Select All 

Selects all windows and objects on the current layer. When you perform this operation, all objects are selected on the 
targeted layer as shown Figure 5-20. Choose Edit > Select All in the menu bar. 
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Figure 5-20. Sample of Select All 

 

5.4.3.2 Context Menu 

The context menu of Window is shown in Figure 5-21. 

Figure 5-21. Context Menu 

 

 Lock/Unlock 

Locks/unlocks the selected window. If a window is locked, it cannot be edited, moved, and so on. 

 Copy/Cut/Paste 

Copies/cuts/pastes the selected window. This supports operations between layers, pages, and projects. 

 Delete 

Deletes the selected window. 

 Send To  

This UI is disabled. 

 Order 

Changes the order of the windows in the current layer. 

Figure 5-22. Set Order of Window 
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 Next/Previous Item Index() 

This UI is disabled. 

 Properties… 

Displays the dialog box for the properties of the selected window. This dialog box also can be opened by double-clicking the 
selected window. 

 Edit Display Frame 

This UI is disabled. 

5.4.3.3 Window Properties 

The Window Properties dialog has four tabs: General, Appearance, Object Order, and Color Conversion. 

General 

Figure 5-23. General Tab 

 

 Name 

The name of the window is alterable. 

 Window ID 

The ID of the window. 

 Blend Operator 

Select this option when blending the window. When adding several objects to one window, this option must be selected. 

If this option is selected, the objects on the window are blended with one another. There is no limit to the number of objects 
for the blend operation. GAT-D uses VRAM memory for display. 

If this option is not selected, the window enables you to have only one sprite object, which does not include vector graphics. 
(See Object for details). GAT-D does not use VRAM memory for display. 
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Figure 5-24 shows the difference between images in windows that are set and not set to Blend Operator. 

Figure 5-24. Blend Operator 

 

 Type 

Selects the color format type of the window. The color format can be RGB_888a, RGB_565, RGB_555a, or RGB_444a. 
The color depth of RGB_888a is 4 bytes, and the others formats are 2 bytes. Thus, when using RGB_888a, the VRAM 
memory embedded in the device will use double size for Blend Operator. 

When you disable Blend Operator, Type is also disabled. 

 Location 

Displays the location of the window 

 Dimension 

Displays the size of the window 

 Window Order 

Displays the index for the order of the window. Its number is read-only.  

If windows overlap on the same layer, only the window with the higher order index in the overlapped part will be drawn. 

 Priority Order 

This is fixed for the Fixed Mode. 

 Alpha-blending 

These settings affect blending with objects, windows, and the background layer. See Alpha Blend for details. 
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 Appearance 

Figure 5-25. Appearance Tab 

 

When Override Common Color Setting is selected, the color setting of the window can be set individually. This means 
that the color setting of the project is ignored on the current window. 

 Transparency 

This sets the disabled color on the window. When it is set, the set color parts on the window are displayed by the 
background color of the layer. This function is enabled when you select the Transparent option. 

An example of enabling this function is shown in Figure 5-26, where the background of the layer is yellow and the 
transparency is green. 

Figure 5-26. Example of Transparency 

 

 Alpha Blending 

This sets the alpha blending color in the window. It is used when enabling Alpha-blend and setting Blend Value Select to 
Blend Value or Blend Value Multiplication, and setting Blend Color Select to Alpha Blending in the properties of the 
sprite object.  
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 Object Order 

Figure 5-27. Object Order Tab 

 

 List of Object Type 

Lists the type of the object 

 Object List 

Lists all the objects on the current window 

The larger index value appears on the topside of the window. 

 Color Conversion 

This UI is disabled. 

Figure 5-28. Color Conversion Tab 
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5.4.4   Object 

An object has two types: vector graphics and sprite.  

5.4.4.1 Basic Operations 

 Add 

Select the sample object from the draw bar, and click in the working area. The sprite object also enables you to add an 
image from the Image Library via the pull-down menu. (See Figure 5-29)  

Figure 5-29. Add Object to Window 

 

 

 Lock:  

Locks the state of an object. Select the object. Then either select Lock in the context menu or choose Design > Lock in the 
menu bar. 

 Unlock:  

Unlocks an object in a lock state. Select the locked object. Then click either select Unlock in the context menu or choose 
Design > Unlock in the menu bar. 

 Copy:  

Copies the object. Select the object. Then either select Copy in the context menu or choose Edit > Copy in the menu bar. 

 Cut:  

Cuts the object. Select the object. Then either select Cut in the context menu or choose Edit > Cut in the menu bar. 

 Paste:  

Pastes an object that has been cut or copied. Either select Paste in the context menu or choose Edit > Paste in the menu 
bar on the targeted window. 

 Delete:  

Deletes the object. Select the object. Then either select Delete in the context menu or choose Edit > Delete in the menu 
bar. 
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5.4.4.2 Context Menu 

The context (right-click) menu for Object is shown in Figure 5-30. 

Figure 5-30. Context Menu for Object 

 

 Lock/Unlock 

Locks/unlocks the selected object. If the object is locked, it cannot be edited, moved, and so on. 

 Copy/Cut/Paste 

Copies/cuts/pastes the selected object. This supports operations between layers, pages, and projects. 

 Delete 

Deletes the selected object. 

 Send To 

Sends the selected object to another window. 

 Order 

Change the order of the selected object on the current window as shown Figure 5-31. 

Figure 5-31. Set the Order of an Object 

 

 Next/Previous Item Index() 

This UI is disabled. 

 Properties… 

Display the Properties dialog box of the selected object. It also can be opened by double-clicking on the object. 

 Edit Display Frame 

This UI is disabled. 
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5.4.4.3 Sprite Object 

The sprite object has two types: basic sprite and special sprite. See Figure 5-32 and Figure 5-33 for adding a basic sprite. 

Note: If the image file is larger than 2048 x 2048 pixels, it cannot be converted into sprite object. After resizing it by the 
external editor tool, convert it. 

Figure 5-32. Basic Sprite from Draw Bar 

 

Figure 5-33. Basic Sprite from Image Data 
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5.4.4.3.1 Properties of Sprite Object 

The Sprite Properties dialog has three tabs: General, Color, and Special Sprite (Blink). 

General Tab 

Figure 5-34. Sprite Properties, General Tab 

 

 Sprite Name 

Displays and changes the name of the sprite object. 

 Color Information 

Displays the color format of the sprite object. 

 Sprite Number 

Displays the unique number of the sprite object. 

 Button 

This Button is a parameter to use the displayed sprite object on the touch panel as UI. Its name is used as the ID in source 
code. It enables checkbox in order to edit the Button name. Refer to GETTING STARTED FOR FM4 S6E2DH (GAT-D).pdf. 
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 Priority 

Changes the order of the selected sprite objects on the current window. 

When you click the Priority button, the Sprite Priority dialog box is displayed. See Figure 5-35. 

Figure 5-35. Sprite Priority 

 

  

Move the selected sprite object up/down by one line.  

The arrangement result is reflected in the working area. 

Note: A sprite object with a large value in the Priority column has a high priority. A high-priority object is displayed 
in front of a low-priority object. 

 Palette Preview 
When you click the Palette Preview button, the Palette Preview dialog will be displayed. This dialog enables you to watch 
the RGB value on an image when you select the Pick up from image option and click on the image. 
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Figure 5-36. Pick Up from Image 

 

 Text 

This UI is disabled. 

 Dimension 

 Width/Height 

This displays the size of the sprite object. It enables you to resize the sprite object by changing the dimensions. 

 Original Size 

This button changes the Width/Height items to the original size of the sprite object. 

 Location 

This displays the location of the sprite object. Upper left is (0, 0). 

 Rotate 

This enables or disables the rotation of the sprite object. If enabled, you can set the radian of clockwise rotation. 

The range is 0–6.2831 radian. 

 Reverse 

This enables you to reverse the sprite object in two ways: Horizontal and Vertical. 
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 Special Sprite 

 Effect Mode 

Set the effect on the sprite object. See Table 5-2. 

Table 5-2. Effect Mode 

Selection Item Settings 

None The object is displayed with no effect. 

Blink The object is drawn by special sprite (blink). 

The advanced setting can be set in the Special Sprite (Blink) tab.* 

 

* The Special Sprite (Blink) tab can be opened only when you set Effect Mode to Blink. 

 Special Sprite Number 

Displays a unique number for the sprite object. 

 Used/Remain/Total 

Displays Number of used Special Sprite Object, Number of unused Special Sprite Object, and Number of Special 
Sprite Object information on the current window. 

 
 Alpha Blend 

When you select this option, the alpha blend function is enabled. 

 Blend Value Select 

Set the type of blend value. See Table 5-3. 

Table 5-3. Blend Value Select 

Selection Item Settings 

Alpha Table Use the alpha value of each pixel in the sprite object. 

Blend Value Use the set alpha value (global alpha blend value) against all pixels of the sprite object. 

Blend Value Multiplication Use the multiplied value that is the each pixel’s alpha value and the global alpha blend value. 

For example, if the alpha value of a pixel is 128: 

 Blend Value: 128 

 Blend Value Multiplication = (128/255 x 128/255) x255 

 Blend Value 

Set the alpha blend value. 

 Blend Color Select 

Set the RGB value to use in the alpha blend.  

The method of the alpha blend is set. See Table 5-4. 

Table 5-4. Blend Color Select 

Selection Item Settings 

Alpha Blending Use the window color. 

Drawn Window Use the pixel color of the sprite object. 
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Color Tab 

Figure 5-37. Sprite Properties, Color Tab 

 

 Type 

Sets the color format type of an object. The format can be RGB_888a, RGB_565, RGB_555a, or RGB_444a. 

 Color Palette ID 

This UI is disabled. 

 Color Palette Preview Area 

This UI is disabled. 

 Theme 

This UI is disabled. 
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Special Sprite (Blink) 

Figure 5-38. Special Sprite (Blink) 

 

 Display Period 

Sets the display period of the special sprite (blink). 

 Non-Display Period 

Sets the non-display period of the special sprite (blink). 

 Repeat Number 

Sets the number of blinks. 

If the repeat number is "0", it always blinks. 

  



 Design and Use 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 68 

5.4.4.4 Vector Graphics Object 

The vector graphics object is used to show the image data as primitive. There are three types: line, rectangle, and circle. 

To create a vector graphics object, click the vector graphics buttons on the draw bar and then draw the object in the working 

area, as shown in Figure 5-39, where ①is the line object drawing button, ② is the object start point, ③ is the object end 

point, ④is the rectangle object drawing button, and ⑤is the circle object drawing button. See Figure 5-40, Figure 5-41, and 

Figure 5-42. 

Note: If you use a vector graphics object, you must select Blend Operator in the Properties of Window. See Window for 
details on Blend Operator. 

Figure 5-39. Draw Shape 

 

Figure 5-40. Draw Line 
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Figure 5-41. Draw Rectangle 

 

Figure 5-42. Draw Circle 

 

  



 Design and Use 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 70 

5.4.4.4.1 Properties of Vector Graphics Object 

The Vector Graphics Properties dialog has only one tab: General. Parameters of properties are different for vector graphics. 

General (Line) 

Figure 5-43. General (Line) Tab 

 

 Name 

Displays and changes the name of the vector graphics object 

 Lock 

Locks the vector graphics object to protect the object from change 

 Button 

Selects whether you use the object area as a button interface for the touch panel. With the name input, the button area can 
be accessed by an API on the embedded side. 

 Type 

Displays the type of the vector graphics object 

 Dimension 

Displays and changes the size of the vector graphics object 

 Location inside Drawing Frame 

Displays and changes the location of the vector graphics object 

 Alpha Value 

Displays and changes the alpha value of the vector graphics object 

 Line Weight 

Displays and changes the point size of the line weight 

 Foreground Color 

Displays and changes the filling color of the vector graphics object 
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General (Rectangle) 

Figure 5-44. General (Rectangle) Tab 

 

 Name 

Displays and changes the name of the vector graphics object 

 Lock 

Locks the vector graphics object to protect the object from change 

 Button 

Selects whether you use the object area as a button interface for the touch panel.  With the name input, the button area can 
be accessed by an API on the embedded side. 

 Type 

Displays the type of the vector graphics object 

 Dimension 

Displays and changes the size of the vector graphics object 

 Location inside Drawing Frame 

Displays and changes the location of the vector graphics object 

 Alpha Value 

Displays and changes the alpha value of the vector graphics object 

 Rotate Degree 

Displays and changes the rotate degree of the vector graphics object 

 Radius Size 

Displays and changes the radius size of the corner of the vector graphics object 

 Foreground Color 

Displays and changes the fill color of the vector graphics object 
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General (Circle)  

Figure 5-45. General (Circle) Tab 

 

 Name 

Displays and changes the name of the vector graphics object 

 Lock 

Locks the vector graphics object to protect the object from change. 

 Button 

Selects whether you use the object area as a button interface for the touch panel.  With the name input, the button area can 
be accessed by an API on the embedded side. 

 Type 

Displays the type of the vector graphics object 

 Dimension 

Displays and changes the size of the vector graphics object 

 Location inside Drawing Frame 

Displays and changes the location of the vector graphics object 

 Alpha Value 

Displays and changes the alpha value of the vector graphics object 

 Foreground Color 

Displays and changes the fill color of the vector graphics object 
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5.4.5   Alpha Blend 

5.4.5.1 Alpha Blend of Sprite Object 

Figure 5-46 shows the effect of alpha blend setting.  

 

Figure 5-46. Alpha Blend Illustrations 

 

 

Illustration A: Result of disabling Alpha Blend 

  

 

Illustration B: Result of enabling Alpha Blend with Alpha Table 

 

  

Used image for operating the alpha blend 



 Design and Use 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 74 

Illustration C: Result of enabling Alpha Blend with Blend Value (= 0) and Drawn Window mode 

   

 
Illustration D: Result of enabling Alpha Blend with Blend Value (= 128) and Drawn Window mode 

   

 

Illustration E: Result of enabling Alpha Blend with Blend Value (= 255) and Drawn Window mode 

   

 

Illustration F: Result of enabling Alpha Blend with Blend Value (= 0) and Alpha Blending mode 

Note: Alpha Blending mode is influenced by the alpha blending color of the window. See Common Color Setting and 
Window Properties. 
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Illustration G: Result of enabling Alpha Blend with Blend Value (= 136) and Alpha Blending mode 

 

 
Illustration H: Result of enabling Alpha Blend with Blend Value (= 255) and Alpha Blending mode 

 

 

Illustration I: Result of enabling Alpha Blend with Blend Value Multiplication (= 0) and Drawn Window mode 

   

 
Illustration J: Result of enabling Alpha Blend with Blend Value Multiplication (= 136) and Drawn Window mode 
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Illustration K: Result of enabling Alpha Blend with Blend Value Multiplication (= 255) and Drawn Window mode 

   

 
Illustration L: Result of enabling Alpha Blend with Blend Value Multiplication (= 0) and Alpha Blending mode 

 

 

Illustration M: Result of enabling Alpha Blend with Blend Value Multiplication (=126) and Alpha Blending mode 

   

 
Illustration N: Result of enabling Alpha Blend with Blend Value Multiplication (= 255) and Alpha Blending mode 
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5.4.5.2 Alpha Blending of Window 

The effect of alpha blending setting of window (global alpha blending, per-pixel source alpha blending, and source alpha 
multiplication) can be described according to the following formula: 

int As = 1; 

if ( Global Alpha Blending == True ) 

As = As * Global Alpha; 

int Ad = As; 

if ( Per Pixel Source Alpha Blending == True ) 

Ad = Ad * Asrc; 

if (Source Alpha Multiplication == True) 

As = As * Asrc; 

 

Cout = Csrc * As + Cdst * (1 - Ad); 

Where: Csrc is the source color. 

 Asrc is the source alpha value divided by 255. 

 Cdst is the (blend) destination color. 

Cout is the output color from the layer blend unit. 

 

Note: The source is the current layer’s window image, and the destination is the lower layer’s window image (or 
background color). 

Figure 5-47 shows a picture of Csrc, which is on the setting window, and Cdst, which is the blend background of the setting 
layer. 

Figure 5-47. Csrc and Cdst 

 

Note: The alpha blend setting of sprite object is set as alpha table. 
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If Csrc window enables only the global alpha blending, the Csrc window is blended with the Cdst window by set the global 
alpha value.  See Figure 5-48 as a preview of global alpha blending. The alpha blending value is 128. 

Figure 5-48. Preview Window with Global Alpha Blending 128 

 

If the Csrc window enables only the per-pixel source alpha blending, the Csrc window is blended with the Cdst window by 
alpha value of each pixel it owns.  See Figure 5-49 as a preview of enable per-pixel source alpha blending. 

Figure 5-49. Preview Window with Per-Pixel Source Alpha Blending 

 

 

If the Csrc window enables only the source alpha multiplication, the alpha value of Cdst is zero, and only the alpha value of 
the Csrc window is enabled. See Figure 5-50 as a preview of enable source alpha multiplication. 
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Figure 5-50. Preview Window with Source Alpha Multiplication 

 

 

5.5   Palette Management 

This UI is disabled. 

5.6   Font Management 

This UI is disabled. 

5.7   Font Editing 

This UI is disabled. 
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5.8   Flow Design 

The Flow Design manages the Event Table and the Action Table. 

Action Table manages action, the sequence of drawing for object by page unit. 

Event Table manages the combination with Action and Event, which indicates an external event such as an input from the 
touch interface or the hard button. 

 

5.8.1   Basic Operations 
 New 

Select the FlowDesignTable folder and right-click. Then select New Flow Design in the context menu, as shown in Figure 
5-51. Alternatively, choose Design > New > Flow Design in the menu bar. 

Figure 5-51. Add a New Flow Design Table 

 

 Rename 

Select Rename in the context menu. See Figure 5-52. 

Note: The name must be a combination “a-zA-Z_”. However, the first character must not use “0-9_”. The maximum number 
of characters is 30. 

 Copy 

Select Copy in the context menu. See Figure 5-52. 

 Cut 

Select Cut in the context menu. See Figure 5-52. 

 Paste 

Select Paste in the context menu after doing a Copy or Cut. See Figure 5-52. 

 Delete 

Select Delete in the context menu. See Figure 5-52. 

 
 Set As Default 

Set the default FlowDesignTable, which is used for compiling the project. 

It becomes enabled by selecting Set As Default in the context menu. See Figure 5-52. 

Note: The default FlowDesignTable is displayed in bold type. 
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 Properties… 

Display the Flow Design dialog by selecting Properties… in the context menu. See Figure 5-52. 

Figure 5-52. Flow Design Table Context Menu 

 

5.8.2   Design Action Table 

An action defines how to display each object on a page. 

Figure 5-53. Design Action Table 
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 Action List 

This defines the combination with Action and Page. Action is defined in Timeline Editor. 

   icon: Adds / deletes the row for Action List 

   icon: Moves up / down the selected row 

 Action column：Displays the action name 

 Page column：Selects the action for combining with a Page 

 Startup Action 

Action to start up as the default when initiating the graphics application 

 Filter 

Filters out the action entry of the unselected page in the Action list 

 Simulator 

Opens the Design Flow Simulator dialog. See Simulation for details. 

 Object Timeline Editor 

Opens the Object Simulator dialog. See Object Timeline Editor for details. 

 Action Definition - XXXXX 

   icon: Adds / deletes the row for Definition-XXXXX. There should be a one-row definition 

   icon: Moves up / down the selected row 

 Flush:  Indicates whether to refresh the screen after this action is executed. It must be set “Yes” always. 

 Delay: Delay time (ms) prior to the execution of this Action 

 Command: It is fixed to Play SpriteList. This means that runs the definition in Object Timeline Editor. 

 Layer: Unused column 

 Object: Unused column 

 Parameter 1: Unused column 

 Parameter 2: Unused column 

  icon: Sets the command state of a row to be disabled. See Figure 5-54. 

  icon: Sets the command state of a row as a breakpoint. See Figure 5-55. 

 

Figure 5-54. Set a Disabled State 
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Figure 5-55. Set a Breakpoint 

 

Note: The state of the command line cannot be set as disabled and breakpoint at the same time. 

 

5.8.2.1 Object Timeline Editor 

This is the flow design dialog for an action. You can design the drawing timing of each object by using the Timeline Editor. 
In addition, the design issue in this dialog is simulated by clicking the Display Window Control Panel button. 

Figure 5-56. Timeline Editor 
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 Timeline Editor 

  icon: Disables the operation of the specified object. For a disabled object, the comment row changes to yellow 
as shown in Figure 5-57. Click again to cancel the disabled state. 

  icon: Sets the breakpoint to the specified frame. For the frame to which the breakpoint is set, the column 
changes to yellow, as shown in Figure 5-58. Click again to cancel the breakpoint. 

  icon: Increases the width of the frame of the Timeline Window. The width of the frame can be set according 
to 10 levels. 

  icon: Decreases the width of the frame of the Timeline Window. The width of the frame can be set 
according to 10 levels. 

 Object Name: The name of the object specified in the Timeline Window, shown in Figure 5-64, is displayed.  The 
object name displayed here becomes the target of the simulation in the object control. 

 Object Type: This is set in the object property.  

 Frame Operator Field: Frame operator is designed in this area as shown Figure 5-64.To edit the frame, right-click 
in the Timeline Window and operate the frame from the context menu as shown Figure 5-61 and Figure 5-62. 

Figure 5-57. Timeline Dialog 

 

Figure 5-58. Breakpoint 

 

Figure 5-59. Zoom Up 

 

Figure 5-60. Zoom Down 
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Figure 5-61. Frame Operator (Basic Sprite) 

 
 

Figure 5-62. Frame Operator (Special Sprite) 

 
 

 Select Action 

Select the action definition name. The action name defined in Design Action Table is displayed in the list. 

 Simulator Layout Setting 

N/A 

 Display is Clear in Final Frame 

Selects whether to clear the object display after the final frame of each object is drawn. 

 Frame Rate 

Adjust the display speed before executing the simulation. 

The frame rate is not always accurate, so use this setting to adjust the simulation speed. 

Note: The frame rate is for simulation only; the actual system (S6E2Dx device) is always 60 fps. 

 Display Window Control Panel 

Control the simulation that includes all objects located in the Timeline Window. The simulation result is displayed in the 
Display Window. 

 Object Window Control Panel 

Control the simulation of the object specified in the Timeline Window. The simulation result is displayed in the Object 
Window. 

The selection of the object as shown Figure 5-63; set by double-clicking in an active column. Click again to cancel the 
simulation object. 
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Figure 5-63. Selection for Object  

 

 

Figure 5-64. Timeline Dialog 

 

 
 Display Window 

The simulation result targeted for all objects is displayed. 

 Object Window 

The simulation result targeted for the selected object is displayed. 

5.8.3   Design Event Table 

Figure 5-65. Design Event Table 
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 Event List 

   icon: Adds / deletes a row 

   icon: Moves up / down the selected row 

 Page: Selects and sets the page on which the event is effective. 

 Event: Selects and sets the name of the event 

 Action: Selects and sets the action corresponding to the event 

 User code: Double-click the cell to open the User Code dialog box. You can input standard C source code here. 

 Sequence: Generates the sequence of user code and event code in code generation. When the Sequence 
selected is Code > Action, the code will be implemented before the action display. If you want to implement it 
after the action display, select Action > Code as shown in Figure 5-68 

 

Figure 5-66. User Code Dialog Box 
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Figure 5-67. Edited Code View 

 
 

Figure 5-68. User’s Code Order 
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 Filter 

Filters out the page defined in the event list to be the event entry of the selected page. Lists all page names in the project 
and All Pages. 

 Define Event 

Defines the event. See Define Event for details. 

 Simulator 

Opens the Design Flow Simulator window; see Simulation  for details. 

Note: One action can be shared by more events, and one event can be shared by many pages. If all pages share one 
event, then this event is not allowed to be assigned to specific pages. 

 

5.8.3.1 Define Event 

Figure 5-69. Define Event 

 

 

     

Adds, deletes, moves up, and moves down. 

 Event Type 

Event Type includes System, Hardware, and Object. But this parameter is a label only. Setting it has no effect. 

 Event Name 

Name of the event 

 Parameter 1 

This must not set parameter. 

 Parameter 2 

This must not set parameter. 
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5.9   Simulation  

The created Flow Design Table enables you to display a simulation on the simulator. You can open the Flow Design 
Simulator dialog by clicking the Simulator button on both the Event Table and Action Table tabs. 

Figure 5-70. Flow Design Simulator Dialog 

  

If run this simulation, the startup action is started. Then, enable to run the event action on the display by clicking the Send 
button with selecting Event in the System Event. 

 Control Panel 

 Play 

Click  to conduct the simulation. 

 Suspend 

Click  to suspend the simulation. 

 Stop 

Click  to stop the simulation. 

 

 Simulator Layout Setting 

This UI is disabled. 

 Debug Window 

Open the Debug Window for the command. You can trace the current action line by line. 
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Figure 5-71. Debug Window 

 

 

 System Event 

All the system events defined in the Event Table will appear in the System Event area. You can select an event and click 
Send to send the event. 

 Hardware Key Setting 

This UI is disabled. 
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5.10   Code Generation 

GAT-D converts its own projects into the embedded source codes for the S6E2Dx series via the Operation Code and Data 
Library Generation dialog. To display this dialog, choose Compile > Resource in the menu bar. 

Figure 5-72. Operation Code and Data Library Generation Dialog 

 

 

 Save Path 

Sets the path for saving the generated code. The C source file and the library will be saved in the GenCode folder under the 
path of the GAT-D project as a default. When you click the Browse button, the dialog box for setting the path is displayed. 

 Target Library 

This UI is disabled. 

 Flow Design 

Selects the Flow Design Table used. 
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 Image Format 

Select the image data format. If you select RLE (compressed), the image data of objects is compressed according to Table 
5-5. 

Table 5-5. Image Data Compression Decision 

Condition on GAT-D 
Compression 

Decision Multi-Window 
(Layer) 

Blend-Operator 
(Window) 

Rotation/Reverse 
(Object) 

✓ ✓ ✓ – 

✓ – ✓ – 

– ✓ ✓ – 

– – ✓ – 

✓ ✓ – ✓ 

✓ – – – 

– ✓ – ✓ 

– – – ✓* 

 

* In this condition, only the maximum-size object is compressed. It is restricted by hardware. Note that this condition 
enables to locate one object into each layer (Sum is two objects).  

 

 Generate Option 

 Generate SourceFile 

When you select this option, the generate source files are output. Thus, do not change it from the default. 

 Compiler 

This pull-down list has no impact.  

 Convert into BinaryFile 

When you select this option, the image data of objects are converted to a binary file. The other parts are converted 
to the embedded source files. If enabling it, the offset address of binary must be set. The default address is 
0xC0000000. 

 Image Data Offset (HEX) 

Set the offset address of binary. The default is 0xC0000000. 

 Generate CommandList 

This UI is disabled. 

 

 Optimization 

 Pattern Data 

This UI is disabled. 

 In Frame 

This UI is disabled. 

 Between Frames 

This UI is disabled. 

 Start Factor 

 This UI is disabled.  



 Design and Use 

Graphics Authoring Tool for S6E2Dx Series Guide, 002-04385 Rev. *A 94 

 Unit 

 This UI is disabled. 

 Layer Select 

 The source files of the selected layer are output. 

 Compile Option 

 This UI is disabled. 

 

 Note: If layers selected in the Action Table (see Design Action Table) are not selected here, the source files will not be 
generated. 
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Appendix A 

 

GAT-D V01 supports the following color modes. 

RGB888a (ARGB8888) 

31 30 29 28 27 26 25 24 23 22 21 20 19 18 17 16 

A A A A A A A A R R R R R R R R 

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 

G G G G G G G G B B B B B B B B 

 

RGB565 (RGB565) 

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 

R R R R R G G G G G G B B B B B 

 

RGB555a (ARGB1555) 

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 

A R R R R R G G G G G B B B B B 

 

RGB444a (ARGB4444) 

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 

A A A A R R R R G G G G B B B B 

 

Note: A – Alpha, R – Red, G – Green, B – Blue, Index – Index value, B/W only – Black/white only 
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