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1.   General Overview 

 
 

Thank you for your interest in the EZ-PD™ Protocol Analyzer Utility User Guide. This is a cross platform utility that works in 
conjunction with the CY4500 EZ-PD Protocol Analyzer to capture the Power Delivery (PD) traffic occurring on the 
Configuration Channel (CC) lines of a Type-C connection. This is a very handy debugging tool for developers. 

Note that the EZ-PD Protocol Analyzer Utility User Guide supports decoding of PD packets as per USB PD Specification 
Revision 3.0, V2.0 dated August 29, 2019. 

1.1   Getting Started 
This user guide describes the features of the EZ-PD Protocol Analyzer Utility and how to use it.  

1.2   Additional Learning Resources 
Visit the CCG web page at www.cypress.com/CCG for the list of Type-C products from Cypress and additional learning 
resources including datasheets and application notes. 

1.3   Technical Support 
For assistance, go to www.cypress.com/go/support . 

1.4   Document Conventions  
Convention Usage 

Courier New Displays file locations, user-entered text, and source code: 

C:\ ...cd\icc\ 

Italics Displays file names and reference documentation: 

The “Configuration Options” section of the HX3 datasheet gives more details about the use of pinstripes 

File > Open Represents menu paths: File > Open > New Project 

Bold Displays commands, menu paths, and icon names in procedures: Click the File icon and then click Open. 

Times New Roman Displays an equation: 

2 + 2 = 4 

Text in gray boxes Describes Cautions or unique functionality of the product. 

   

1.5   Abbreviations 
Abbreviation Meaning 

GUI Graphical User Interface 

PD Power Delivery 

SOP Start of Packet 

Msg ID Message Identification 

CC Configuration Channel 

PC Personal computer 

Obj Count Object Count 

USB Universal Serial Bus 

 

http://www.cypress.com/CCG
http://www.cypress.com/go/support
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2.   EZ-PD Protocol Analyzer Utility 

 
 

 

2.1   EZ-PD Protocol Analyzer Utility GUI 
Do the following to run the CY4500 EZ-PD Protocol Analyzer and capture the Power Delivery Packets on the CC bus: 

1. Using a USB Micro-B cable, connect the USB Micro-B receptacle (Connector J7) of the Protocol Analyzer board to the 
host PC. LED1 of the board starts blinking in white color. 

2. Connect the USB Type-C plug (Connector J3) of the Protocol Analyzer board to the Type-C host device. In this user 
guide, the CY4531 EZ-PD CCG3 Evaluation Kit (EVK; not provided with this analyzer) is used as a Type-C host device 
as an example.  

3. Verify that your setup looks similar to the image shown below: 

Figure 1. Setup for Operating CY4500 EZ-PD Protocol Analyzer 

 

4. Connect a USB Type-C power adapter (not provided with the analyzer) to the USB Type-C receptacle (Connector 
J2) of the Protocol Analyzer board. Verify that your setup looks similar to the image shown in Figure 2. The USB 
Type-C power adapter mentioned here is just an example. Any USB Type-C device can be used in its place.  

To Host PC Running 

EZ-PD Analyzer Utility

http://www.cypress.com/documentation/development-kitsboards/cy4531-ez-pd-ccg3-evaluation-kit?source=search&cat=software_tools
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Figure 2. Completing the Setup for Operating the Protocol Analyzer 

 

2.1.1   Windows 

To start the Protocol Analyzer Utility tool, go to Start > All Programs > Cypress > EZ-PD Protocol Analyzer Utility 

> CY4500 EZ-PD Protocol Analyzer Utility.exe.  

Figure 3. GUI Layout of EZ-PD Analyzer Utility 
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2.1.2   macOS 
Extract CY4500EZ-PD_Protocol_Analyzer_Macosx.zip. Open CY4500_EZ_PD_Protocol_Analyzer_Utility to start the 
Protocol Analyzer Utility tool.  

Figure 4. GUI Layout of the Utility in MacOS 

 

2.1.3   Linux  
In 64-bit system, use CY4500EZ-PD_Protocol_Analyzer_Linux_x64.zip; in 32-bit systems, use CY4500EZ-
PD_Protocol_Analyzer_Linux_x86.zip. Extract the zip file and launch the terminal inside extracted folder.  

Run one-time commands:   

export SWT_GTK3=0 

chmod a+x CY4500_EZ_PD_Protocol_Analyzer_Utility 

To launch EZ-PD™ Protocol Analyzer Utility tool, run  

sudo ./CY4500_EZ_PD_Protocol_Analyzer_Utility 
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Figure 5. GUI Layout of the Utility in Ubuntu 

 

2.1.4   Show View 

To open View, click Window > Show View on the menu bar and select respective view from the menu items. 

Figure 6. Show View  

 

2.1.5   Reset Perspective 
To rearrange the views to the default layout, select Window > Reset Perspective. 
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Figure 7. Reset Perspective menu of the Analyzer Utility 

 

2.1.6   Go to Packets 
To select PD message based on column value, select Actions > Find Message as shown in Figure 8 and Figure 9. 

 Figure 8. Find Message Menu  

 

Figure 9. Find Message Dialog Box 
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2.1.7   Graphical View 
Select Window > Show View > Graphical. 

Figure 10. Graphical View 

 

2.1.7.1 Zoom In  

To zoom into the graph, select the area of interest by dragging the cursor from top left corner to bottom right corner which 
highlights the selected region in blue as shown in Figure 11. 

Figure 11. Graph zoom-in  

 

You can also zoom-in and zoom-out of the graph using the pinch-to-zoom technique. 
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2.1.7.2 Navigation 

To navigate towards left or right of the graph over the Time axis, use the left and right arrow buttons respectively on the top 
right corner of the Graphical view window. 

Figure 12. Graph navigating 

 

 

2.1.8   Help View 
You can access the User Guide of EZ-PD™ Protocol Analyzer Utility and get details about version of the tool from Help 
menu on menu bar as in Figure 13. 

Figure 13. Help View 
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2.2   Capturing and Viewing PD Packets 

Before capturing PD Packets, ensure that the CY4500 EZ-PD Protocol Analyzer hardware is connected and ready to use. 
Make sure that the message displayed on the status bar at the bottom shows “EZ-PD Analyzer is connected”. 

2.2.1   Capture PD Packets 
Click Start on the tool bar or select Actions > Start. 

Figure 14. Capturing PD Packets on the EZ-PD™ Analyzer Utility 

 

The status bar indicates that the Analyzer is running. It also displays the total number of PD packets displayed on the GUI. 
The progress bar located at the bottom right corner turns green, whenever PD packets are received by the utility. The 
captured PD packets are displayed in the main panel as shown in Figure 15. Each of the PD packet displayed is assigned 
with a serial number (SL#). 

Figure 15. PD Packets Captured Using the Analyzer Utility 
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Table 1. Details of captured PD Packets 

Field Name Description 

SL# Message serial no. 

Status Overall status of the message 

SOP K-code marker used to delineate the start of the packet 

Message PD Message Type 

Msg Id Identifier for the message 

Data Role Current Data Role of the Port 

Power Role Current Power Role of the Port 

Obj Count Number of 32-bit data object(s) that follow the header 

Data 32-bit data object with header 

Start Time (us) Start time of PD message 

Duration (us) Duration of PD message 

Delta (us) Time difference between previous and current PD message 

Vbus (mV) Vbus voltage during the PD message capture 

 

Note: VBUS status (Voltage and Current) is displayed live at the right top corner of the GUI if the Protocol Analyzer 

hardware is connected to the system (PC). The typical accuracy of the VBUS current displayed is +/- 0.15 A and the 

VBUS voltage displayed is +/- 1%. 

2.2.2   View Packet Details 
Click a PD packet in USB Packet Message window to view its details in the side panel under the Details View tab. 

Figure 16. Details of the Selected PD Packet 

 

The Details View tab lists all the attributes of a selected PD packet. See Section 6 (Protocol Layer) of the USB PD 
Specification Revision 2.0, V1.2 to get more details about the type of PD messages (Control Messages and Data Messages) 
and their attributes. 

 

 

file:///C:/Users/nibk/Documents/USB%20Power%20Delivery%20Spec/USB%20PD%20v2.0_011317/USB_PD_R2_0%20V1.3%20-%2020170112.pdf
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2.2.3   Stop Packet Capture 

Click the Stop icon in the tool bar or select Actions > Stop. 

Figure 17. Stop Capturing PD Packets 

 

2.2.4   Save PD Packets 

 Click the Save icon in the tool bar or select File > Save. 

Figure 18. Save PD Packets 

 

The trace can be saved in *.ccgx3 file format: 

Figure 19. File Formats for PD Packets 

 

Note: *.ccgx3 file is a proprietary Cypress format. Files stored in this format can be opened using any XML editor. 
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2.2.5   Clear PD Packets 

Click the Clear icon in the tool bar or select Actions > Clear Data to clear all the captured PD Packets.  

Clearing the PD packets resets the serial number (SL#) and the PD packets which are captured subsequently will start with  
SL# 1. 

Figure 20. Clearing the Captured PD Packets 

 

To clear the captured packets, right-click on the main panel and select Clear Data: 

Figure 21. Clearing Captured PD Packets from the Main Panel 

 

Note: If PD packets are received at the time of invoking Clear Data, the PD packets are displayed with a continuous serial 
number even after clearing the existing PD packets. Click Clear Data again to clear them and to reset the serial number for 
the PD packets to be captured subsequently. 
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2.3   Working with PD Packets 

2.3.1   Open Saved PD Packet Files 

The saved PD Packet files (*.ccgx3) can be viewed even when the Protocol Analyzer hardware is not connected to the PC. 
Click the Open button on the tool bar (or select File > Open). Browse and select the saved file. 

Figure 22. Open Saved PD Packet Files 

2.3.2   Mark PD Packets 

The PD Packets displayed in the main panel can be marked to locate them quickly. 

Right-click on a packet and select Add Marker (or Add Marker in tool bar) . The marked packet gets highlighted in blue. 

Note: The blue highlight is not shown if a marked packet is in selected state. De-select the marked packet by right-clicking 
another packet or by clicking on the side panel to see the highlighting in blue. 

Figure 23. Adding Marker to PD Packets 
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Figure 24. Adding Marker to PD Packets from Toolbar 

 

2.3.3   Step Through Marked PD Packets 
Click the Next Marker button on the toolbar (or select Actions > Next Marker) to step through marked packets. 

Figure 25. Accessing Marked PD Packets from the Next Marker Icon in the Toolbar 

 

2.3.4   Remove Marker 
Select the marked message and click Remove Marker. 

Figure 26. Removing a Marker 
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2.3.5   Remove All Markers 
Click Remove All Marker. 

Figure 27. Removing All Markers 

 

 

2.3.6   Use Packet Filters 

Packets displayed in the main panel can be filtered based on certain parameters such as Status, SOP, Message, 

Msg ID, Obj Count, Data Role and Power Role as shown in Figure 28.  While capturing PD packets, all possible 

values are displayed in these filters. When capture is stopped, only the values present in the captured trace will be 

displayed. 

To filter data packets, enter the filter value in the appropriate field on the Data Filter bar. 

Figure 28. Setting up a Data Filter 
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2.3.7   Import 

Use the Import option to load the old tool data into current tool. It supports *.xlsx and *.csv format. 

Figure 29. Import 

 

2.3.8   Export 

Use the Export option to save the data in *.csv format. 

Figure 30. Export 

 

2.3.9   Preference 

There are two preference options: 

▪ Multiple device support: If the user machine is connected with multiple devices, you can choose the device. 

▪ Graph data enable/disable support: Enable or disable graph data loading using this option. 

Figure 31. Preference Menu 
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Figure 32. Preference Page 

  

2.4   Working with Themes 

2.4.1   Themes 

The Analyzer GUI has three different themes: default, blue, and gray. 

Figure 33. Theme Option in Settings 

  

 

2.5   Upgrade Firmware 
The Protocol Analyzer hardware comes with the latest firmware pre-installed during manufacturing. However, if a new 
firmware version is available, the analyzer can be updated manually using the Firmware update tool provided in the package. 

On the host PC, launch the EZ-PD Protocol Analyzer Utility using the steps provided in Section 2.1.1  . Ensure that the 
Protocol Analyzer hardware is connected. 

Start capture by selecting Actions > Start. If the analyzer has an old firmware, a Firmware Update dialog box appears as 
shown in Figure 34. Update the firmware of the analyzer using the Firmware Update tool 
(EZPD_Firmware_Update_Tool.exe) available at the following location: 

 <Install Directory>\EZ-PD Protocol Analyzer Utility\Firmware_Update_Tool.  

The firmware update tool is available only on Windows. 
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Figure 34. Firmware Update Dialog Box in Windows 

 

The GUI of the Firmware Update tool is as shown in Figure 35.  

Figure 35. GUI of Firmware Update Tool 

 

The firmware update tool can be used to: 

1.  Retrieve the current firmware version: 

a. Click Get Firmware version.  

b. Wait for the firmware version dialog box to appear as shown in Figure 36: 

Figure 36. Firmware Version Dialog Box 

 

 

2.  Update the CY4500 EZ-PD Protocol Analyzer firmware: 

a. Click Load File… and select the CY4500 firmware file in .cyacd format as shown in Figure 37. Click Open. 

The binary file provided with the utility is available at the following location <Install Directory>\EZ-PD 
Protocol Analyzer Utility\Firmware_Update_Tool. 
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Figure 37. Selecting the CY4500 Firmware File 

 

b. Click Program to initiate the firmware download process as shown in Figure 38. 

Figure 38. Initiating Firmware Download 

 

c. This starts the firmware download process. Click Exit when complete as shown in Figure 39. 

Figure 39. Completion of Firmware Download 

 

d. The steps to update the firmware are now complete. The CY4500 EZ-PD Protocol Analyzer hardware 
restarts with the new firmware used in step a and is ready to use. 
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3.   Troubleshooting Guide 

 
 

Problem Possible Cause Possible Solution 

When the Analyzer Utility is run on a 
virtual machine environment such as 
VMWare, there may be a noticeable 
delay (which can be in the range of 15 
seconds) to display the captured PD 
packets from the time ‘Start Capture’ is 
invoked on the utility. 

The CPU bandwidth allocated for the 
virtual machine platform may not be 
adequate. 

Modify the virtual machine platform settings to 
use multiple CPU cores to provide more CPU 
bandwidth. 

PD Packets are not getting displayed 
after connecting the Type-C device 
under test. 

The Type-C connector may have loose 
contacts, or the Type-C device is not 
inserted properly into the Protocol 
Analyzer hardware. 

Check the Type-C plug for any abnormality for 
loose contacts.  

Insert the Type-C device under test or cable fully 
inside the CY4500 Hardware. 

Unable to start PD capture.  Restart the EZ-PD Protocol Analyzer Utility tool. 

Unable to run the Protocol Analyzer 
Utility tool 

Version of Java installed may not be 
compatible 

Check the Java version installed in the system.  

Install Java 8 if any other version is installed in 
the system.  

If more than one version of Java is installed, 
make sure that Java 8 is used by default 
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