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1. Introduction

Thank you for your interest in Cypress’s CY3660 enCoRe™ V and enCoRe V Low Voltage (LV) kit.
enCoRe V is targeted for full-speed USB human interface device (HID) applications, such as wired
mouse or keyboard, and Full-Speed USB bridge for wireless HID applications. enCoRe V LV is
targeted for wireless HID applications, such as wireless mouse, wireless keyboard, remote
controller, and presenter tools. For debugging encore V and encore V LV, customers are requested
to purchase CY3215-DK.CY3215-DK is an in-circuit emulator (ICE) that works in conjunction with
the actual silicon to provide an accurate and efficient development system.

This CY3660 development kit includes hardware and software components designed to simplify your
engineering development effort and illustrate the capabilities of the following devices:

Getting Started chapter on page 8 describes the installation and configuration of the CY3660
enCoRe V and enCoRe V LV Development Kit. Kit Operation chapter on page 15 describes the kit
operation. Hardware chapter on page 19 describes the hardware operation. Code Examples chapter
on page 29 describes the code examples provided along with the kit. The Appendix chapter on
page 41 section provides the schematics, BOM, protocols, and references associated with the
CY3660 enCoRe V and enCoRe V LV Development Kit.

1.1 Kit Contents

The development kit includes:

■ Two enCoRe V and enCoRe V LV development boards

■ Two 2.4 GHz wireless modules using Cypress’s WirelessUSB™ LP radio

■ One LCD module for data display and prototyping

■ PSoC Designer software development tool with complete set of user modules

■ Four firmware examples with complete source code

■ Cypress’s MiniProg for programming the onboard on-chip debugger (OCD) chips

■ Complete documentation

■ All necessary cables, adapter, and power supplies

1.2 PSoC Designer

PSoC Designer is the integrated development environment (IDE) used to customize your PSoC
application. The latest PSoC Designer has many new features, bug fixes, and support for new PSoC

enCoRe V

CY7C6431x

Full-speed USB bridge for wireless HID applicationsCY7C64345

CY7C6435x

enCoRe V Low Voltage
CY7C60445 Wireless mouse, wireless keyboard, remote controller, 

and presenter toolsCY7C6045x
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devices. More information about the PSoC Designer is available in the PSoC Designer IDE Guide;
go to: <Install_directory>\Cypress\PSoC Designer\<version>\Documentation

1.3 PSoC Programmer

The latest PSoC Programmer offers the user a simple GUI that connects to programming hardware
to program and configure PSoC devices.

1.4 Additional Learning Resources

Visit http://www.cypress.com for additional learning resources in the form of data sheets, technical
reference manual, and application notes.

1.5 Document History

1.6 Documentation Conventions 

Revision
PDF Creation 

Date
Origin of 
Change

Description of Change

** 03/02/11 CSAI Initial version of kit guide

*A 04/05/2012 ELIN
Updated kit documents for CY3660 with the 
OOB review comments.

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text and source code:
C:\...cd\icc\

Italics
Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open
Represents menu paths:
File > Open > New Project

Bold
Displays commands, menu paths and icon names in procedures:
Click the File icon and then click Open.

Times New Roman
Displays an equation:
2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.

http://www.cypress.com
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2. Getting Started

This chapter describes the installation and configuration of the CY3660 enCoRe V and V LV kit.

2.1 Kit Installation

To install the kit software, follow these steps:

1. Insert the kit CD/DVD into the CD/DVD drive of your PC. The CD/DVD is designed to auto-run
and the kit installer startup screen appears

You can also download the latest kit installer from http://www.cypress.com/go/CY3660. Download
the kit installer ISO file and create an installer CD/DVD or extract the ISO using Ironware and
install the executable.

2. Click Install CY3660 enCoRe V/LV DVK to start the installation, as shown in Figure 2-1.

Figure 2-1.  Kit Installer Startup Screen 

Note If auto-run does not execute, double-click cyautorun.exe in the root directory of the CD/
DVD, as shown in Figure 2-2.

http://www.cypress.com/go/CY3660


CY3660 enCoRe V and enCoRe V LV Development Kit Guide, Doc. No. 001-41500 Rev. *A 9

Getting Started

Figure 2-2.  Root Directory of the CD/DVD

3. On the startup screen, click Next to start the installer.

4. The InstallShield Wizard screen appears. The default setup location is shown on the 
InstallShield Wizard screen. You can change the location using Change, as shown in Figure 2-3.

5. Click Next to launch the kit installer.

Figure 2-3.  InstallShield Wizard 

6. In the Product Installation Overview screen, select the installation type that best suits your 
requirement. The drop-down menu has three options - Typical, Complete, and Custom, as 
shown in Figure 2-4.

7. Click Next to start the installation.
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Figure 2-4.  Installation Type Options

8. When the installation begins, a list of packages appear on the Installation Page. A green check 
mark appears next to every package that is downloaded and installed, as shown in Figure 2-5.

9. Wait until all the packages are downloaded and installed successfully.

Figure 2-5.  Installation Page

10.Click Finish to complete the installation.



CY3660 enCoRe V and enCoRe V LV Development Kit Guide, Doc. No. 001-41500 Rev. *A 11

Getting Started

Figure 2-6.  Installation Completion Page

2.2 PSoC Designer
11.Click Start > All Programs > Cypress > PSoC Designer <ver.> > PSoC Designer <ver.>.

12.Click File > Create New Project to create new project; click File > Open Project/Workspace to 
work with an existing project.
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Figure 2-7.  PSoC Designer Interconnect View

13.To experiment with the code examples, go to Code Examples chapter on page 29.

Note For more details on PSoC Designer, see the PSoC Designer IDE Guide at: 
<Install_directory>\Cypress\PSoC Designer\<version>\Documentation.
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2.3 PSoC Programmer
1. Click Start > All Programs > Cypress > PSoC Programmer <ver.> > PSoC Programmer 

<ver.>.

2. Select the MiniProg from the port selection, as shown in Figure 2-8.

Figure 2-8.  PSoC Programmer Window

3. Click the File Load button from Programmer menu bar navigate and select hex file to load.

4. Use Program button to program the hex file on to the chip.

5. When programming is successful, Programming Succeeded appears in the Actions pane.

6. Close PSoC Programmer.

Note For more details on PSoC Programmer, go to Programmer user guide at: 
<Install_directory>\Cypress\Programmer\<version>\Documents.

2.4 Install Hardware

No hardware installation is required for this kit.
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3. Kit Operation

3.1 Default Jumper Setting

The following is the default jumper setting for the CY3660 enCoRe V DVK board.

■ J1, place a jumper

■ J2, place a jumper between VREG and VDD

■ J5, place a jumper between Pin 2 and 3.3 V

■ J12, place a jumper

■ J13, place a jumper

■ Leave other jumpers open

Figure 3-1.  CY3660 enCoRe V DVK Board
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3.2 Programming and Emulation Procedures

The following procedure provides a quick programming and emulation overview. 

Note: The PSoC MiniProg or the ICE-Cube is used for programming. The ICE-Cube is required for
emulation. The ICE-Cube is available in the PSoC development kit and can be ordered from
Cypress's online store (PSoC Development Kit, CY3215-DK).

3.2.1 Programming Steps

1. Launch "PSoC Programmer”. If the LP Radio Module is connected to P2, remove it before the 
next step to avoid 5 V being applied to the LP Radio Module. 

2. Connect the USB cable to the PSoC MiniProg and to the PC.

3. Connect the PSoC MiniProg to the 5-pin ISSP header on the CY3660 enCoRe V DVK board.

Figure 3-2.  PSoC MiniProg

4. In PSoC Programmer, click File >Load to load the desired binary (hex) file.

5. Select the MiniProg port.

6. For Programming Mode, select Power Cycle. Ensure the AC adapter is removed from P1, and 
the USB cable is unplugged from P9.

7. From the Device Family menu, select 64300.

8. From the Device menu, select CY7C64300.

9. Click Program. PSoC Programmer goes through programming and verification modes.

10.When programming is finished, remove the MiniProg from the CY3660 enCoRe V DVK board.

http://www.cypress.com/?rID=3411
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Figure 3-3.  PSoC Programmer

3.2.2 Debugging Using Emulator

The steps for emulation are as follows:

1. Launch the desired .SOC project file project from the PSoC Designer\Examples\CY7C64300 
\<example name>\[PSoC Project or application name\].

2. Connect one end of the blue CAT 5e cable to the ICE-Cube.

3. Connect the other end of the blue CAT 5e cable to the CY3660 enCoRe V DVK board.

4. Select Config > Generate Application, or click the Generate Application icon.

5. Select Build > Build, press [F7], or select the above icon.

6. Configure the debug port setting. Select Project > Settings >Debugger then select USB as the 
ICE connected to port.

7. Select Build > Start Debug, press [CTL] + [F5], or select the Start Debug icon.

8. Select Debug > Connect, or select the Connect icon.

9. Select Debug > Download to Emulator, or select the Download to Emulator icon.

10.Select Debug > Go, press [F5], or select the Go icon.

Figure 3-4.  PSoC Designer’s Toolbar
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4. Hardware

4.1 System Block Diagram

The CY3660 enCoRe V and enCoRe V LV DVK has the following sections:

■  Power supply system 

■  enCoRe V Chip

■  ISSP Connector

■  I2C Connector

■  Mini B USB Connector

■  Power LED

■  LEDs and Push Buttons

■  Reset Switch

■  Debug Port

■  LCD Interface

■  Potentiometer

■  LP Radio interface

■  Bread board Area

■  Voltage Regulator

Figure 4-1.  System Block Diagram
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4.2 Functional Description

The following figure shows the different functional blocks on the CY3660 enCoRe V and LV Develop-
ment board.

Figure 4-2.  Functional Blocks of CY3660 enCoRe V / LV Development Board

4.2.1 Power Supply System

The power supply system on this board is versatile. It takes input supply from the following sources:

■ 12 V DC input

■ USB power from communications section

■ Power from ISSP header

■ Power from I2C header

■ Power from debug port - RJ45
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Figure 4-3.  Power Supply System Block Diagram

4.2.1.1 Power Supply Jumper Settings

The following is the default jumper setting for the CY3660 board.

■ J1, place a jumper

■ J2, place a jumper between VREG and VDD

■ J5, place a jumper between pin 2 and 3.3.

■ J12, place a jumper

■ J13, place a jumper

■ Leave other jumpers open
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4.2.2 enCoRe V Chip

Cypress's enCoRe V Full-Speed USB peripheral microcontrollers (MCUs) and enCoRe V LV (low
voltage) wireless MCUs are highly-integrated families with up to 32 KB of flash memory, three 16-bit
timers, and up to 36 general purpose I/Os (GPIOs) to accommodate enhanced multimedia features
in human interface devices (HIDs). The families are supported by the CY3660 enCoRe V / LV devel-
opment kit, which shortens the design time of laser mice, gaming controllers and keyboards, wire-
less dongles, remote controls, mobile handset accessories, and point-of-sales devices.

The in-system reprogrammable enCoRe V and enCoRe V LV MCUs provide design flexibility with a
10-bit ADC, flash memory with EEPROM emulation, and small form-factor packages. The enCoRe V
devices also include eight USB endpoints. The enCoRe V LV family operates in the full range of
1.7 V to 3.6 V, with low power consumption for prolonged battery life in wireless applications, espe-
cially when paired with Cypress's low-power WirelessUSB™ LP 2.4-GHz radio. All enCoRe MCUs
include Cypress's patented crystal-less oscillator and integrated pull-up resistor to reduce compo-
nent count and BOM cost.
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4.2.2.1 Pin Description of CY8C20066A-24LTXI

Pin No. Name Description Connected to

1 NC No connection

2 P2[7] Digital I/O P11

3 P2[5] Digital I/O, crystal out (Xout) P11

4 P2[3] Digital I/O, crystal in (Xin) P11

5 P2[1] Digital I/O P11

6 P4[3] Digital I/O P14

7 P4[1] Digital I/O P14

8 P3[7] Digital I/O P12

9 P3[5] Digital I/O P12

10 P3[3] Digital I/O P12

11 P3[1] Digital I/O P12

12 P1[7] Digital I/O, I2C SCL, SPI SS P8

13 P1[5] Digital I/O, I2C SDA, SPI MISO P8

14 NC No connection

15 NC No connection

16 P1[3] Digital I/O, SPI CLK P8

17 P1[1][5, 6] Digital I/O, ISSP CLK, I2C SCL, SPI MOSI P8

18 VSS Supply ground

19 D+ USB P9

20 D– USB P9

21 VDD Supply voltage

22 P1[0][5, 6] Digital I/O, ISSP DATA, I2C SDA, SPI CLK P8

23 P1[2] Digital I/O P8

24 P1[4] Digital I/O, optional external clock input (EXTCLK) P8

25 P1[6] Digital I/O P8

26 Ext Reset Active high external reset with internal pull down

27 P3[0] Digital I/O P12

28 P3[2] Digital I/O P12

29 P3[4] Digital I/O P12

30 P3[6] Digital I/O P12

31 P4[0] Digital I/O P14

32 P4[2] Digital I/O P14

33 P2[0] Digital I/O P11

34 P2[2] Digital I/O P11

35 P2[4] Digital I/O P11

36 P2[6] Digital I/O P11

37 P0[0] Digital I/O P7

38 P0[2] Digital I/O P7

39 P0[4] Digital I/O P7

40 P0[6] Digital I/O P7



24 CY3660 enCoRe V and enCoRe V LV Development Kit Guide, Doc. No. 001-41500 Rev. *A

Hardware

4.2.3 ISSP Connector

In-system serial programmer (ISSP) is used to program the device using the MiniProg programmer
device and the USB cable. This interface is faster and the ISSP/I2C programming is done through
the 5-pin connector.

The pin mapping for the ISSP connector is shown in the following figure.

4.2.4 I2C Connector

CY3660 enCoRe V and LV development board is provided with an I2C connector.

41 VDD Supply voltage

42 NC No connection

43 NC No connection

44 P0[7] Digital I/O P7

45 P0[5] Digital I/O P7

46 P0[3] Digital I/O P7

47 VSS Supply ground

48 P0[1] Digital I/O P7

VSS Ensure the center pad is connected to ground

Pin No. Name Description Connected to



CY3660 enCoRe V and enCoRe V LV Development Kit Guide, Doc. No. 001-41500 Rev. *A 25

Hardware

4.2.5 Mini B USB Connector

The USB Mini B Connector is a mini port that communicates between the PC and the board. It is
also used to power up the controller, supplying 5 V voltage. Protection diode D5 is present so that
the 5 V from the board does not flow to the USB connector. CY3660 DK is mainly used for HID appli-
cations, USB is used to interface the device.

4.2.6 Power LED

The power LED D2 (Red) is used to indicate the power status of the board.
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4.2.7 LEDs and Push Buttons

These buttons are provided to supply input to the board.

4.2.8 Reset Switch

This switch resets enCoRe V back to its original state. 
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4.2.9 Debug Port

The ICE-Cube debugger allows to debug and view the content of specific memory locations. The
ICE-Cube debugger can be connected to the RJ45 connector on the board to connect to the on-chip
debugger (OCD) device to enable debugging.

4.2.10 LCD Interface

The LCD interface connector is used to connect an LCD. It is a two-line 16-character LCD. The con-
trast of the LCD can be varied using the LCD contrast potentiometer.

4.2.11 Potentiometer

This potentiometer is used for varying the voltage to the ADC input.
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4.2.12 LP Radio Interface

This interface is used to plug the WirelessUSB LP radio module.

4.2.13 Bread Board Area

This area on the board is used for prototyping.

4.2.14 Voltage Regulator

The CY3660 enCoRe V and enCoRe V LV DVK board has a voltage regulator; a 50-K potentiometer
is used to vary the output from the IC U1. VREG can be varied from 1.63 V to 3.66 V using this
potentiometer. Connect a jumper between pins 1 and 2 of J5 to use this regulated power VREG.
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5. Code Examples 

5.1 Code Example 1: HID Mouse

5.1.1 Project Description

This project demonstrates the basic functionality of a USB HID Mouse. A complete USB HID
descriptor is provided, which allows enumerations on any USB host that supports a HID device.

5.1.2 Hardware Connections

1. Wire up the S1 button. On the CY3660 enCoRe V DVK board, attach a wire from P0_0 on P7 to 
S1on P10.

2. Place a jumper on J12.

3. Place a jumper between VDD and VREG on J2.

4. J5 is used to select the fixed 3.3 V VREG or Adjustable VREG from 3.66 V to 1.63 V. In the 
beginning, it is suggested to use fixed 3.3 V VREG.

5. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 enCoRe V DVK board.

6. Connect the A side of the USB A/Mini-B cable to the PC.

Figure 5-1.  Board Details

J2

J5

J1

P7

J12

S1

Pin S1 
of P10
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5.1.3 Project Flowchart

5.1.4 Verify Output

The HID_Example enumerates in the Device Manager as a HID-compliant device. It transmits
mouse down and mouse movement commands to the PC over the USB interrupt pipe. Press button
S1 on the DVK board to toggle the drawing in Paint. The word ‘USB’ is drawn when the S1 button is
pressed. Press the S1 button again to stop drawing. When using any of the enCoRe V examples
provided, a USB analyzer can be used to inspect the USB transactions.
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5.2 Code Example 2: Bulk Loop

5.2.1 Project Description

The BULK_Example shows the simplicity of accessing SRAM directly from the enCoRe V USB SIE.
This example uses the BulkLoop application to send and receive data over the Bulk IN and OUT
endpoints.

5.2.2 Hardware Connections

Program the CY3660 enCoRe V DVK board with the hex file located at <installed direc-
tory>\Cypress\CY3660 enCoRe V DVK\<ver>\Firmware\BULK_Example\BULK_FW\. 

1. Select Program > Program Part in PSoC Designer

2. Place a jumper on J12.

3. Place a jumper between VDD and VREG on J2.

4. J5 is used to select the fixed 3.3 V VREG or Adjustable VREG from 3.66 V to 1.63 V. In the begin-
ning, it is suggested to use fixed 3.3 V VREG.

5. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 enCoRe V DVK board.

6. Connect the A side of the USB A/Mini-B cable to the PC.

7. After connecting USB cable to PC, Windows Hardware wizard pops up.In Win XP(32/64) OS. 
Select “Yes, this time only” and click Next. In Windows Vista/7 machine choose “Browse My 
computer for driver software”

8. Choose “Install from a list or specific location” and click Next.Then choose “Don’t search. I 
will choose the driver to install” and click Next.Select “USB Controllers” from the list of 
devices.In the next window select Click Have Disk.

9. To select the driver matching VID/PID in the BULK_FW.hex select the cyusb3660dvk.inf file 
located at <Installed_Directory>\Cypress\CY3660 enCoRe V DVK\ <version>\Drivers. In Win-
dows Vista/7 machines browse directly after step-6 to matching Driver information file as men-
tioned below. User need to select the cyusb3660dvk.inf and cyusb.sys file combination relevant 
to Windows OS version to which the USB cable is connected. Following are paths:

a. WinXP-32-bit:wxp\x86

b. WinXP-64-bit:wxp\x64

c. WinVista-32-bit:wlh-vista\x86

d. WinVista-64-bit:wlh-vista\x64

e. Win7-32-bit:wlh-win7\x86

f. Win7-64-bit:wlh-win7\x64

10.Open Device Manager by typing “devmgmt.msc” in Windows-->Start Button-->Run. Expand the 
list of USB controllers and observe enCoRe V DVK enumerated and listed as “Cypress enCoRe 
V LV DVK Bulk Example(3.4.5.000)”.

11.The cyusb3660dvk.inf and cyusb.sys, and cyusb3660dvk.cat are signed driver packages for all 6 
Windows OS platforms-WinXP(32/64),Win Vista(32/64) and Win-7(32/64).Any modification to the 
cyusb3660dvk.inf file would result in Invalid driver signature. The supplied package should be 
used without modification to validate only the examples provided with the kit.

12..The cyusb3660dvk.inf(italic) contains Bulk examples VID/PID-0x04B4/0x07B3.To modify the 
.INF during development reboot PC and press F8.Select “Disable Driver signature 
enforcement”.This will enable loading of unsigned driver packages in Windows PC.This modifi-
cation will not propogate till next reboot.Windows Hardware certification program is designed to 
certify USB drivers for custom designed hardware based on Cypress Encore V IC. The VID/PID 
combination used in BULK_Example firmware and driver package(cyusb3660dvk.inf and 
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cyusb.sys) should be modified before submission to Microsoft.Refer to “Windows Hardware 
Certification” for more details.
Note: If the driver matching sequence (selecting cyusb3660dvk.inf and cyusb.sys of anyone of 
examples-Bulk Example and ISOC Example is performed earlier then the remaining example's 
step 6-9 can be avoided as the cyusb3660dvk.inf file contains VID/PID entries of both these firm-
ware examples.

Figure 5-2.  Board Details
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http://msdn.microsoft.com/en-us/windows/hardware/gg463010
http://msdn.microsoft.com/en-us/windows/hardware/gg463010
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5.2.3 Project Flowchart

5.2.4 Verify Output

■ Launch the BulkLoop.exe application located at <installed directory>:\Cypress\CY3660 enCoRe 
V DVK\1.0\Examples\BULK_Example\PC_Host_App\BulkLoop.exe 

■ Using the BulkLoop.exe application provided, data can be transferred to and from the CY3660 
enCoRe V DVK board.
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5.3 Code Example 3: ISOC

5.3.1 Project Description

The ISOC_Example shows how to create an alternate interface for isochronous applications. This
example uses the Streamer application to send data over the ISOC IN Endpoint.

5.3.2 Hardware Connections

Program the CY3660 enCoRe VDVK board with the hex file located at <installed direc-
tory>\Cypress\CY3660 enCoRe V DVK\<ver>\Firmware\ISOC_Example\ISOC_FW\. 

1. Select Program > Program Part in PSoC Designer

2. Place a jumper on J12.

3. Place a jumper between VDD and VREG on J2.

4. J5 is used to select the fixed 3.3 V VREG or Adjustable VREG from 3.66 V to 1.63 V. In the 
beginning, it is suggested to use fixed 3.3 V VREG.

5. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 enCoRe VDVK board.

6. Connect the A side of the USB A/Mini-B cable to the PC. 

7. After connecting USB cable to PC, Windows Hardware wizard pops up .In Win XP(32/64) OS 
select "Yes, this time only" and click Next.In Windows Vista/7 machine choose "Browse My 
computer for driver software".

8. Choose “Install from a list or specific location” and click Next. Then choose “Don’t search. I 
will choose the driver to install” and click Next.Select "USB Controllers" from the list of 
devices.In the next window select Click “Have Disk”.

9. To select the driver matching VID/PID in the ISOC_FW.hex select the cyusb3660dvk.inf file 
located at <Installed_Directory>\Cypress\CY3660 enCoRe V DVK\<version>\Drivers. In Win-
dows Vista/7 machines browse directly after step-6 to matching Driver information file as 
mentioned below. User need to select the cyusb3660dvk.inf and cyusb.sys file combination 
relevant to Windows OS version to which the USB cable is connected. Following are paths:

a. WinXP-32-bit:wxp\x86

b. WinXP-64-bit:wxp\x64

c. WinVista-32-bit:wlh-vista\x86

d. WinVista-64-bit:wlh-vista\x64

e. Win7-32-bit:wlh-ws\x86

f. Win7-64-bit:wlh-ws\x64

10.Open Device Manager by typing “devmgmt.msc” in Windows-->Start Button-->Run. Expand the 
list of USB controllers and observe enCoRe V DVK enumerated and listed as “Cypress enCoRe 
V LV DVK ISOC Example (3.4.5.000)”.

11.  The cyusb3660dvk.inf and cyusb.sys, and cyusb3660dvk.cat are signed driver packages for all 6 
Windows OS platforms-WinXP(32/64),Win Vista(32/64) and Win-7(32/64).Any modification to the 
cyusb3660dvk.inf file would result in Invalid driver signature. The supplied package should be 
used without modification to validate only the examples provided with the kit.

12. The cyusb3660dvk.inf(italic) contains ISOC examples VID/PID-0x04B4/0x07B4.To modify the 
.INF during development reboot PC and press F8 .Select “Disable Driver signature 
enforcement”.This will enable loading of unsigned driver packages in Windows PC. This 
modification will not propogate till next reboot.Windows Hardware certification program is 
designed to certify USB drivers for custom designed hardware based on Cypress Encore V IC. 
The VID/PID combination used in ISOC_Example firmware and driver package(cyusb3660dvk.inf 
and cyusb.sys) should be modified before submission to Microsoft. Refer to "Windows Hardware 

http://msdn.microsoft.com/en-us/windows/hardware/gg463010
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Certification" for more details.
Note: If the driver matching sequence (selecting cyusb3660dvk.inf and cyusb.sys of anyone of 
examples-Bulk Example and ISOC Example is performed earlier then the remaining example's 
step 6-9 can be avoided as the cyusb3660dvk.inf file contains VID/PID entries of both these firm-
ware examples.

Figure 5-3.  Board Details
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http://msdn.microsoft.com/en-us/windows/hardware/gg463010
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5.3.3 Project Flowchart

5.3.4 Verify Output

■ Launch the Streamer application located at <installed directory>:\Cypress\CY3660 enCoRe V 
DVK\1.0\Examples\ISOC_Example\PC_Host_App\Streamer.exe.

■ The ISOC_Example demonstrates the correct behavior of an USB isochronous device by enu-
merating with a default interface that consumes no bandwidth. Then, when data is ready to be 
streamed to or from the USB device, the host application selects the alternate interface with the 
ischronous endpoint descriptor. Using the Streamer application provided, isochronous data can 
be streamed from the CY3660 DVK board.
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5.4 Code Example 4: Wireless USB

5.4.1 Project Description

The WUSB_Example demonstrates the functionality of a WirelessUSB HID keyboard. Two
development boards with LP radio modules are used for this example. One board is used as a
bridge, which enumerates on the PC as a bus-powered USB composite device supporting keyboard
and mouse. The other board is used as a keyboard, which simulates a simple keyboard with three
keys (Num Lock key, Caps Lock key, and Scroll Lock key) and three LEDs (Num Lock LED, Caps
Lock LED, and Scroll Lock LED).

5.4.2 Hardware Connections

5.4.2.1 Wireless USB Bridge 

Program the CY3660 enCoRe V DVK board with the hex file located at <installed direc-
tory>\Cypress\CY3660 enCoRe V DVK\<ver>\Firmware\WUSB_Example\enCoReV_dvk_bridge.

1. Select Program > Program Part in PSoC Designer.

2. Attach the WirelessUSB LP Radio module to P2.

3. Wire the S1 button as a bind button. On the CY3660 DVK board, attach a wire from P0_2 on P7 
to S1on P10.

4. Wire LED1 and LED2. On the CY3660 DVK board, attach wires from P0_0 on P7 to LED1 on P10 
and from P0_1 on P7 to LED2 on P10 separately.

5. Place a jumper on J1 and another jumper on J12.

6. Place a jumper between VDD and VREG on J2.

7. J5 is used to select the fixed 3.3 V VREG or Adjustable VREG from 3.66 V to 1.63 V. In the begin-
ning, it is suggested to use fixed 3.3 V VREG.

8. Connect the mini-B side of the USB A/Mini-B cable to the CY3660 enCoRe V DVK board.

9. Connect the A side of the USB A/Mini-B cable to the PC.
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Figure 5-4.  Board Details

5.4.2.2 Wireless USB Keyboard

Program the CY3660 enCoRe V DVK board with the hex file located at <installed direc-
tory>\Cypress\CY3660 DVK\<ver>\Firmware\WUSB_Example\enCoReV_dvk_keyboard\. 

1. Select the Program > Program Part in PSoC Designer.

2. Attach the WirelessUSB LP Radio module to P2.

3. Wire the S5 button as a bind button. On the CY3660 DVK board, attach a wire from P0_6 on P7 
to S5 on P10.

4. Wire S1 button S1 as a Num Lock key, S2 button as a Caps Lock key, and S3 button as a Scroll 
Lock Key. On the CY3660 DVK board, attach wires from P0_3 on P7 to S1 on P10, from P0_4 on 
P7 to S2 on P10, and from P0_5 on P7 to S3 on P10 separately.

5. Wire LED1 as a Num Lock LED, LED2 as a Caps Lock LED, and LED3 as a Scroll Lock LED. On 
the CY3660 DVK board, attach wires from P0_0 on P7 to LED1 on P10, from P0_1 on P7 to 
LED2 on P10, and from P0_2 on P7 to LED3 on P10 separately

6. Place a jumper on J1.

7. Place a jumper between VDD and VREG on J2.

8. J5 is used to select the fixed 3.3 V VREG or Adjustable VREG from 3.66 V to 1.63 V. In the 
beginning, it is suggested to use fixed 3.3 V VREG.

9. Connect AC adapter to P1.
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Figure 5-5.  Board Details

5.4.3 Project Flowchart

5.4.3.1 Wireless USB Bridge
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5.4.3.2 Wireless USB Keyboard

5.4.4 Verify Output

Results for Bind

After the bridge is enumerated and the LEDs are off, press the bind button S1 on the bridge and the
bind button S5 on the keyboard to complete the 'binding' process. While in the bind mode, the LED2
on the bridge blinks until the bind button is pushed on the keyboard. The bridge LED2 stops blinking
to indicate the keyboard is now ready for normal operation. Note that the bridge LED2 also stops
blinking after 20 seconds timeout without receiving any bind request from the keyboard.

Results for Key Pressing

Press a button on the keyboard that represent Num Lock key (S1), Caps Lock key (S2), or Scroll
Lock key (S3). The keystroke data is sent through the air to the bridge, which transfers this data to
the PC. After receiving the data from the bridge, the PC processes the Num, Caps, and Scroll Lock
data and returns the LED information to the bridge and then the keyboard. Finally, the keyboard
OCD chip turns on/off the corresponding LEDs.
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A.1 Schematic
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A.2 Schematic - LP Radio
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PCB: PDC - 9274
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The power supply decoupling shown for VBAT0
is a recommended cost effective
configuration:
C6=No Load    R1=1ohm    C7=10uF ceramic.
For this configuration, it is required that
C18 (100uF 10V electrolytic, Panasonic
EEU-FC1A101S or equivalent) be installed on
the LP EVK Base Board when batteries are
used on the EVK board to power the radio.

An alternate decoupling configuration is
the following:
C6=47uF ceramic    R1=0ohm    C7=.047uF.
For this configuration, it is not required
to load C18 on the LP EVK Base Board.

For reference design part numbers, please
refer to the Bill of Materials file
121-27404.xls.

VBAT is the supply
from the AAA batteries
or the linear regulator
on the EVK Base Board.

VCC is the supply
to the MCU
on the EVK Base Board.

REF-13314 *B

LP RADIO MODULE PMU

B

1 1Thursday, March 30, 2006

Title

Size Document Number Rev

Date: Sheet of

CYPRESS SEMICONDUCTOR  © 2005

XOUT

MISO
nSSnSS

MOSI MOSI
SCK SCK

IRQ

XOUT
IRQ

RST

MISO
RST

VBAT VCC

VBAT

VBAT

VCC VBAT

VCC

U1
CYRF6936

36

4
8

19

16

202

25
27

26

29

34

28

3 7

5

13

6

37

1

24

39
40

41

35

9
14

10

11

12
15
17
18

21

30

22

33
23
31
32

38

NC15

NC2
V

B
A

T2
RESV

V
C

C
3

NC9NC1

SCK
MOSI

IRQ

XOUT

RST

MISO

V
C

C
1

V
C

C
2

NC3

RFn

V
B

A
T1

L/D

XTAL

SS

NC16
V

R
E

G

E
-P

A
D

V
D

D

NC4
NC5

RFbias

RFp

G
N

D
1

NC6
NC7
NC8

NC10

PACTL

NC11

V
IO

NC12
NC13
NC14

V
B

A
T0

J1

10 Pin Header

1
3
5
7
9

2
4
6
8
10

TP4

IND0603

L1
22 nH

TP2

TV1

0805

R1

1  1%

TP1

L3

10 uH

04
02

C11

0.047 uFd

0402

R2

47

1210

C6

No Load

04
02

C5

0.47 uFd

0805

C12

10 uFd 6.3V

0402

C17

0.1 uFd

04
02

C16

0.047 uFd

0402

C8

1 uFd 6.3V

04
02

C1

15 pFd

Y1

12 MHz Crystal

ANT1
WIGGLE 32

1 2

04
02

C3

2.0 pFd

0805

C7

10 uFd 6.3V

04
02

C15

0.047 uFd

SOT23
D1

BAT400D

2 1TP3

0402

C4

1.5 pFd

IND0402

L2
1.8 nH

04
02

C10

0.047 uFd
0402

C13

0.047 uFd

TV2

04
02

C9

0.047 uFd



CY3660 enCoRe V and enCoRe V LV Development Kit Guide, Doc. No. 001-41500 Rev. *A 43

A.3 Board Layout

Gerber files are located at <installed directory>\Cypress\CY3660 enCoRe V
DVK\<ver>\Hardware

A.3.1 Top View
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A.3.2 Bottom View
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A.4 BOM

Table A-1.  Bill of Materials

Item Qty. Reference Description Manufacturer Mfr Part Number

1 4 C1,C2,C7,C8 CAP 10UF 16V CERAMIC X7R 0603 Kemet C0603C104J4RACTU

2 3 C3,C4,C6 CAP 10UF 16V CERAMIC X5R 1210 Panasonic - ECG ECJ-4YB1C106K

3 1 C5 CAP 560PF 50V CERAMIC NPO 0603 Panasonic - ECG ECJ-1VC1H561J

4 1 C9 CAP 330PF 50V CERAMIC NPO 0603 Kemet C0603C331J5GACTU

5 3 D1,D3,D4 DIODE SCHOTTKY 0.5A 20V SOD-123 Fairchild Semiconductor MBR0520L

6 1 D2 LED HI EFF RED CLEAR 1206 SMD
Chicago Miniature Lamp, 
Inc

CMD15-21VRC/TR8

7 2 D5,D6 LED GREEN CLEAR 1206 SMD
Chicago Miniature Lamp, 
Inc

CMD15-21VGC/TR8

8 2 D7,D8 LED YELLOW CLEAR 1206 SMD
CML Innovative Technolo-
gies Inc

CMD15-21VYC/TR8

9 6 J1,J7,J8,J10,J12,J13 CONN HEADER VERT 2POS .100 30AU AMP Division of TYCO 1-87215-0

10 2 J5,J2
CONN HEADR BRKWAY .100 03POS 
STR

Tyco Electronics/Amp 9-146280-0-03

11 1 J3
CONN HEADR BRKWAY .100 01POS 
STR

Tyco Electronics/Amp 9-146280-0-01

12 3 J4,J6,J9 CONN HDR BRKWAY .100 20POS VERT Tyco Electronics/Amp 9-146256-0-10

13 1 J11
CONN HEADER 5POS 0.1 VERT 
KEYED

Molex 22-23-2051

14 1 J14 CONN HEADER 16POS .100" STR TIN
Molex/Waldom Electronics 
Corp

90131-0128

15 1 P1
CONN 2.1MM PWRJACK RT ANGLE 
PCB

Switchcraft Inc. RAPC722

16 1 P2 CONN RCPT .100 DUAL STR 10POS 3M 929852-01-05-RA

17 1 P3
CONN REC .100 14POS for LCM-
S01602DTR/A-3

3M 929850-01-14-RA

18 2 P14,P4 CONN RECP 4POS STR AU PCB Samtec SSQ-104-21-G-S

19 2 P5,P6 RECEPTACLE .100 SNGL STR 3POS 3M Electronics 929850-01-03-RA

20 4 P7,P8,P11,P12 CONN RECT 8POS .100" VERT 3M 929850-01-08-RA

21 1 P9 CONN USB MINI B SMT RIGHT ANGLE TYCO 1734035-2

22 1 P10 RECEPTACLE .100 SNGL STR 12POS 3M 929850-01-12-RA

23 1 P13 CONN MOD JACK 8-8 RT/A PCB 50AU AMP 5558343-1

24 10
R1,R23,R24,R25,R26,R27
, R28,R29,R30,R32

RES 1.0K OHM 1/8W 5% 0805 SMD  Rohm MCR10EZHJ102

25 1 R2
RES CHIP 20.0K OHM 1/16W 1% 0603 
SMD

Yageo Corporation RC0603FR-0720KL

26 2 R3,R31 10K OHM THUMBWH CERM ST POT Bourns Inc. 3352E-1-103-LF

27 1 R4
RES CHIP 10.0K OHM 1/16W 1% 0603 
SMD

Yageo Corporation RC0603FR-0710KL

28 1 R5 50K OHM POTENTIOMETER TOP ADJ Bourns Inc. 3214W-1-503E

29 1 R6
RES CHIP 1.50K OHM 1/16W 1% 0603 
SMD

Yageo Corporation RC0603FR-071K5L

30 2 R7,R8 RES 2.7K OHM 1/16W 5% 0603 SMD Panasonic - ECG ERJ-3GEYJ272V

31 7
R9,R10,R14,R15,R16,R17
, R18

RES ZERO OHM 1/16W 5% 0603 SMD Panasonic - ECG ERJ-3GEY0R00V

32 2 R13,R12 RES 22 OHM 1/10W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ220V

33 4 R19,R20,R21,R22 RES 56 OHM 1/10W 5% 0603 SMD Panasonic - ECG ERJ-3GEYJ560V

34 6 S1,S2,S3,S4,S5,S6 LT SWITCH 6MM 160GF H=2.5MM SMD Panasonic - ECG EVQ-QWS02W

35 3 TP4,TP7,TP8
TEST POINT 43 HOLE 65 PLATED 
WHITE

Keystone Electronics 5002
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A.5 BOM - LP Radio

Table A-2.  BOM - LP Radio

36 4 TP10,TP11,TP12,TP13
TEST POINT 43 HOLE 65 PLATED 
BLACK

Keystone Electronics 5001

37 1 U1 IC ADJ REGULATOR LDO 500MA SO8 Linear Technology LT1763CS8#PBF

38 1 U2 IC Encore V QFN 48 Cypress Semiconductor CY7C64300

39 4
"SEE ASSEMBLY DRAW-
ING"

foot pad, .50W X.23H, square WHITE 3M SJ5518

40 1 "SEE ASSEMBLY NOTES"
SOLDERLESS BREADBOARD 3.25 x 
2.125 400 POINTS

Jameco Valuepro WBU-301-R

41 1 PCB Printed Circuit Board Cypress Semiconductor PDCR-9412 Rev2

42 1 LABEL1 Serial Number

43 1 LABEL2 PCA LABEL 121R-41200 Rev2

DO NOT INSTALL

44 116 TV1-TV116 TEST VIA 36 HOLE 20 PLATED NA NA

45 1 U4 PROTO AREA 56-pin 25mil pitch NA NA

46 1 U5 PROTO AREA 60-pin 50mil pitch NA NA

47 12

TP1,TP2,TP3,TP5,TP6,TP
9, 
TP14,TP15,TP16,TP17,TP
18, TP19

TEST POINT 43 HOLE 65 PLATED NA NA

Item Qty Reference Description Manufacturer Mfr Part Number 

1 1 ANT1 
2.5GHZ H-STUB WIGGLE ANTENNA 
FOR 32MIL PCB 

NA NA 

2 1 C1 CAP 15PF 50V CERAMIC NPO 0402 Panasonic ECJ-0EC1H150J 

3 1 C3 CAP 2.0 PF 50V CERAMIC NPO 0402 Kemet C0402C209C5GACTU 

4 1 C4 
CAP 1.5PF 50V CERAMIC NPO 0402 
SMD 

PANASONIC ECJ-0EC1H1R5C 

5 1 C5 CAP 0.47 uF 50V CERAMIC X5R 0402 Murata GRM155R60J474KE19D 

6 2 C12,C7 CAP CERAMIC 10UF 6.3V X5R 0805 Kemet C0805C106K9PACTU 

7 1 C8 CAP 1 uF 6.3V CERAMIC X5R 0402 Panasonic ECJ-0EB0J105M 

8 6 C9,C10,C11,C13,C15,C16 CAP 0.047 uF 50V CERAMIC X5R 0402 AVX 0402YD473KAT2A 

9 1 C17 CAP 0.1 uF 50V CERAMIC X5R 0402 Kemet C0402C104K8PACTU 

10 1 D1 DIODE SCHOTTKY 0.5A 40V SOT23 DIODES INC BAT400D-7-F 

11 1 J1 CONN HDR VERT 10POS .100 GOLD Molex/GC/Waldom Inc. 10-89-1101 

12 1 L1 INDUCTOR 22NH 2% FIXED 0603 SMD Panasonic - ECG ELJ-RE22NGF2 

13 1 L2 
INDUCTOR 1.8NH +-.3NH FIXED 0402 
SMD 

Panasonic - ECG ELJ-RF1N8DF 

14 1 L3 COIL 10UH 1100MA CHOKE 0805 Newark 30K5421 

15 1 R1 RES 1.00 OHM 1/8W 1% 0805 SMD Yageo 9C08052A1R00FKHFT 

16 1 R2 RES 47 OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ470X 

17 1 U1 IC, LP 2.4 GHz RADIO SoC QFN-40 Cypress Semiconductor CYRF6936 Rev A5 

18 1 Y1 CRYSTAL 12.00MHZ HC49 SMD eCERRA GF-1200008 

19 1 PCB PRINTED CIRCUIT BOARD Cypress Semiconductor PDC-9274 *A 

20 1 LABEL1 Serial Number XXXXXX 

21 1 LABEL2 PCA # 121-27404 ** 

Item Qty. Reference Description Manufacturer Mfr Part Number
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