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1. Introduction
Thank you for your interest in the CY3280-24x94 Universal CapSense® Controller (UCC) Kit. This kit
is designed to easily prototype and debug the 24x94 CapSense family designs with predefined
control circuitry and plug-in hardware. The kit includes programming hardware and an I2USB bridge
for tuning and data acquisition. This module connects to any CY3280 Universal CapSense Module
board.

This document describes the CY3280-24x94 UCC kit and demonstrates the code examples
provided with the kit.  

1.1 Kit Contents
The CY3280-24x94 UCC kit contains:
■ CY3280-24x94 Universal CapSense Controller board
■ CY3240-I2USB Bridge Board
■ CY3217 PSoC MiniProg1 Programmer
■ USB A to Mini-B Cable
■ CY3280-24x94 Universal CapSense Controller Kit CD

❐ PSoC Designer installation file
❐ PSoC Programmer installation file
❐ Bridge Control Panel installation file (packaged along with PSoC Programmer)
❐ Code examples
❐ Hardware files
❐ Kit guide
❐ Quick start guide
❐ Release notes

■ Chip Samples - CY8C24094-24LTXI

Universal CapSense Module boards are available for purchase separately or as part of the combina-
tion kits. Visit http://www.cypress.com/shop for more information. Inspect the contents of the kit. If
any of the parts are missing, contact your nearest Cypress sales office for further assistance.

1.1.1 Prerequisites
The following are required for the functioning of the kit:
■ CY3280 Universal CapSense Module board or user custom board similar to CY3280 module 

boards
■ 12 V DC adapter (optional)
■ CY3215-DK (optional, required for debugging the program in PSoC Designer)
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Introduction
1.1.2 CY3217-MiniProg1
The PSoC  MiniProg 1 gives you the ability to program PSoC parts quickly and easily. It is small,
compact, and connects to your PC using the provided USB A to Mini-B cable. During prototyping, the
MiniProg can be used as an in-system serial programmer (ISSP) to program PSoC devices on your
PCB. When the MiniProg is connected, you can use the PSoC Programmer software to program.
PSoC Programmer is a free software, which can either be launched from PSoC Designer or run as a
standalone program.

1.1.3 CY3240-I2USB Bridge Board
The I2USB Bridge allows testing, tuning, and debugging hardware and software of a PSoC applica-
tion by bridging the USB port to I2C. Populated with the CY8C24894 PSoC device, the I2USB
Bridge can be connected through the ISSP pins on the controller board.

1.1.4 CY3280 Universal CapSense Module Board
The CY3280 Universal CapSense Module board is available for purchase separately or as part of
the combination kits. The CY3280-24x94 UCC can be connected to CY3280-SLM, CY3280-SRM,
CY3280-BMM, and CY3280-BSM CapSense boards.

1.2 PSoC Designer
PSoC Designer<version> is the integrated development environment (IDE) used to customize your
PSoC application. The latest PSoC Designer has many new features, bug fixes, and support for new
PSoC devices. More information about PSoC Designer is available in the PSoC Designer IDE Guide
at <Installed_directory>\Cypress\PSoC Designer\<version>\Documentation.

1.3 PSoC Programmer
PSoC Programmer offers you a simple GUI that connects to programming hardware to program and
configure PSoC devices.

1.4 Bridge Control Panel
The Bridge Control Panel (BCP) GUI is used with CY3240-I2USB Bridge Board to enable communi-
cation with I2C slave devices; here, it is used with CY3280-24x94 UCC. This software is used to
configure I2C devices and to acquire and process data received from I2C slave devices. The BCP
helps to optimize, debug, and tune the target devices.

1.5 Additional Learning Resources
Visit http://www.cypress.com for additional learning resources in the form of datasheets, technical
reference manual, and application notes.
■ CY8C24094/794/894/994 CapSense Applications – http://www.cypress.com/?rID=3371

This is the PSoC CY8C24094 datasheet that contains pin descriptions and other specifications of 
the PSoC CY8C24094 

■ CY3280-24x94 Universal CapSense Controller Board layouts: 
http://www.cypress.com/?rID=3481 

■ CY3280-24x94 Universal CapSense Controller Schematics – http://www.cypress.com/?rID=3481  
■ Layout Guidelines in Getting Started with CapSense (Chapter 3): 

http://www.cypress.com/?rID=48787
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Introduction
The layout guidelines section in Getting started with CapSense describes layout guidelines for 
CapSense applications with regard to PCB layout, overlay thickness, material selection and 
chassis design. 

■ CY3240 USB-I2C Bridge Guide – http://www.cypress.com/?rID=3421 
■ CY3280-SLM Linear Slider Module Kit – http://www.cypress.com/go/CY3280-SLM
■ CY3280-SRM Radial Slider Module Kit – http://www.cypress.com/go/CY3280-SRM 
■ CY3280-BSM Simple Button Module Kit – http://www.cypress.com/go/CY3280-BSM 
■ CY3280-BMM Matrix Button Module Kit – http://www.cypress.com/go/CY3280-BMM 
■ MiniProg Users Guide and Code Examples – http://www.cypress.com/?rID=37459 
■ PSoC Designer Training – http://www.cypress.com/go/psocdesigner-training

This is a web-based course that provides an overview of PSoC and its design tools. 

1.6 Document History

Revision
PDF Creation

        Date
Origin of 

           Change
Description of Change

           ** 06/22/2011 SSHH Initial version of kit guide

*A 10/28/2011 SASH

Added “My First Code Example” section. 
Updated InstallShield Wizard step. Added note 
about CY8C24094 UCC board’s OCD support in 
the PSoC Designer section. Added note on Mini-
Prog to PC connection in the PSoC Programmer 
section. Updated CY3280-24x94 kit CD location. 
Removed I2USB Bridge connection to controller 
image. Updated file names and locations in 
Bridge Control Panel section.Changed 
Cy8C24094-LFXI to CY8C24094-LTXI. 
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Introduction
1.7 Document Conventions
Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, User entered text, and source code:
C:\ ...cd\icc\

Italics
Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed,Bold]
Displays keyboard commands in procedures:
[Enter] or [Ctrl][C]

File > Open
Represents menu paths:
File > Open >New Project

Bold
Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman
Displays an equation:
2 + 2 = 4

Text in gray boxes Describes cautions or uniwue functionality of the product.
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2. Getting Started
This chapter describes the installation and configuration of the CY3280-24x94 UCC Kit.

2.1 Kit Installation
To install the kit software, follow these steps:
1. Insert the kit CD in the CD drive of your PC. The CD is designed to auto-run and the kit installer 

startup screen appears. 
Download the latest kit installer from http://www.cypress.com/go/CY3280-24x94. Download the 
kit installer ISO file and create an installer CD or extract the ISO using Ironware and install the 
executable.

2. Click Install CY3280-24x94 to start the installation.

Figure 2-1.  Kit Installation
CY3280-24x94 Universal CapSense® Controller Kit Guide, Document No. 001-70137 Rev. *A 9
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Getting Started
Note If auto-run does not execute, double-click cyautorun.exe in the root directory of the CD.

Figure 2-2.  CD Root Directory.

3. The InstallShield Wizard screen appears. On this screen, choose the folder location to install the 
setup files. You can change the location of the folder for the setup files using Change, as shown 
in Figure 2-3.

4. Click Next to launch the kit installer.

Figure 2-3.  InstallShield Wizard
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Getting Started
5. In the Product Installation Overview screen, select the installation type that best suits your 
requirement. The drop-down menu has three options – Typical, Complete, and Custom (see 
Figure 2-4).

6. Click Next to start the installation.

Figure 2-4.  Installation Type Options
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Getting Started
7. When the installation begins, a list of packages appear on the Installation Page. A green check 
mark appears next to every package that is downloaded and installed.

8. Wait until all the packages are downloaded and installed successfully.

Figure 2-5.  Installation Page

9. Click Finish to complete the installation.

Figure 2-6.  Installation Completion Page
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Getting Started
After software installation, verify your setup by opening PSoC Programmer with the MiniProg
attached to PC. Open Bridge Control Panel with the I2USB bridge attached to the PC to verify
driver installation.

2.2 PSoC Designer
1. Click Start > All Programs > Cypress > PSoC Designer <version> > PSoC Designer 

<version>.
2. Click File > New Project to create a new project; click File > Open Project/Workspace to work 

with an existing project.

Figure 2-7.  PSoC Designer Interconnect View

3. To experiment with code examples, refer to the Code Examples chapter on page 35. 

Notes
■ For more details on PSoC Designer, see the PSoC Designer IDE Guide at

<Install_directory>\Cypress\PSoC Designer\<version>\Documentation.

■ The device CY8C24094 on the Universal CapSense Controller board supports On-Chip-Debug 
(OCD) and can emulate any device among the 24x94 family. Any device in the 24x94 family can 
be selected in the device selection window for new PSoC Designer projects.
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Getting Started
2.3 PSoC Programmer
1. Click Start > All Programs > Cypress > PSoC Programmer <version> > PSoC Programmer 

<version>.
2. Connect MiniProg to the PC using a USB A to Mini-B cable.
3. Select the MiniProg from the port selection.

Figure 2-8.  PSoC Programmer Window

4. Click the File Load button from the Programmer menu bar; navigate and select the hex file to 
load.

5. Use Program button to program the hex file on to the chip.
6. When programming is successful, Programming Succeeded appears in the Actions pane.
7. Close PSoC Programmer.

Note For more details on PSoC Programmer, go to the Programmer user guide at:

<Install_directory>\Cypress\Programmer\<version>\Documents.
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Getting Started
2.4 Bridge Control Panel
1. Click Start > All Programs > Cypress > Bridge Control Panel <version>> Bridge Control 

Panel <version>
2. Select 5.0 V from the Power Setting box (see Figure 2-9).
3. Select the device to be connected from the port window.
4. Click the Variable Settings option from the Chart menu; click Load, and navigate to and open 

the *.ini file.
5. Select File > Open; navigate to and open the *.iic file. The *.iic file contents appear on the 

Editor pane of the Bridge Control Panel.

Figure 2-9.  Selecting the Bridge 

Note For more details on the BCP, view the help topics from the Bridge Control Panel Menu bar.

2.5 Install Hardware
This kit does not require any hardware installation.
CY3280-24x94 Universal CapSense® Controller Kit Guide, Document No. 001-70137 Rev. *A 15
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3. Kit Operation
3.1 Introduction
The CY3280-24x94 UCC connects to any CY3280 Universal CapSense Module board. This kit
requires PSoC Designer for development, PSoC Programmer for programming, and Bridge Control
Panel to test and tune the CapSense parameters.

3.2 Hardware Requirement
■ CY3280-24x94 UCC board (PSoC Device ID: CY8C24094-24LTXI)
■ CY3280-SLM (linear slider module) board
■ CY3217-MiniProg1
■ CY3240-I2USB Bridge Board
■ USB A to Mini-B cable 

3.3 CapSense Module Board Connection
The CapSense Module Board can be connected to the controller through Port P2 of the controller
and J1 of the CY3280-SLM Universal CapSense linear slider module.

Figure 3-1.  Connecting CapSense Module Board to Universal CapSense Controller

On the CY3280-24x94 UCC board, place shunts on pins 1 to 2 of J4 (XRES select). On the CY3280-
SLM Universal CapSense Linear Slider Module, place a shunt on pins 2 and 3 of J2.
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Kit Operation
3.4 Programming Device
The CY3280-24x94 UCC is programmed using a MiniProg1 provided with the kit.

Figure 3-2.  MiniProg 1 Connected to Controller

1. Connect the CY3280-24x94 ISSP connector (J3) to your computer using the PSoC MiniProg 1 
and a USB cable (A to Mini B). Use PSoC Programmer for programming.

2. Connect pin 2 of J1 with a jumper to pin 3 to allow power to be supplied by the MiniProg1.
3. LED D1 on the CY3280-24x94 UCC is ON when the board is powered from a 12 V DC supply, 

USB, 9 V battery, PSoC MiniProg, I2USB Bridge, or VADJ. LED D2 lights up once the board is 
powered by any of the power sources (12 V DC supply, USB, 9 V battery, PSoC MiniProg, 
I2USBBridge, ICE Cube, or VADJ).

4. Program the CY3280_24x94_Project1.hex file from the kit CD or from the location 
<Install_directory>\Cypress\CY3280-24x94\<version>\Firmware\ 
CY3280_24x94_Project1\CY3280_24x94_Project1.hex on to the CY3280-24x94 UCC 
board using MiniProg1 in the Power Cycle Mode. While programming is in progress, the Target 
Power LED on the MiniProg 1 is ON (see Figure 3-2). 

5. When Programming Succeeded appears in the Actions pane, detach the MiniProg 1 and con-
nect an I2USB Bridge to ISSP connector.
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Kit Operation
3.5 Bridge Control Panel
The I2USB Bridge is used to get the CapSense parameters from the controller board. You can view
these parameters using the BCP software. Follow these steps to use BCP with the CY3280-24x94
UCC board:
1. Open Bridge Control Panel from Start > All Programs > Cypress > Bridge Control Panel

<version> > Bridge Control Panel<version>.
2. Select the device to be connected from the port selection window.
3. Select Variable Settings option from the Chart menu. Load the .ini file, by clicking the Load but-

ton. The CY3280_SLM_Project1.ini file is the variable setting file, available in the kit CD or at the 
following location: <Installed_directory>\Cypress\CY3280-24x94\<version>\Firmware\ 
USB-I2CBridgeSoftwareConfig.

4. Load the CY3280_SLM_Project1.iic file for iic commands that can be sent to the board. The .iic 
file is the configuration setting file, available in the kit CD or at the following location:
<Installed_directory>\Cypress\CY3280-24x94\<version>\Firmware\
USB-I2CBridgeSoftwareConfig.

5. Go to File > Open File > CY3280_SLM_Project1.iic to select the file for iic commands.
6. Select +5 V in the Power Settings box.
7. Click Toggle Power to power the I2USB Bridge; the red LED D1 glows. 
8. Send the commands in the Editor pane to the controller board.

Note PSoC Designer and PSoC Programmer must be closed before opening Bridge Control Panel.
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Kit Operation
Figure 3-3.  Bridge Control Panel Editor View

9. Click Send to send commands to the controller board; click Repeat to get parameters continu-
ously from the controller.

10.Touch a button or slider. Each touch lights up the associated LED on the module board, repre-
senting where your finger is on the slider.

Figure 3-4.  LED Glows on Touching Sensor SLD1

First 
command line

Second
command
line
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Kit Operation
11.Click Chart to switch to Chart view and see the respective waveforms of CapSense parameters.

Figure 3-5.  Bridge Control Panel Chart View

Note In this figure, the brown line represents the axis; the blue line indicates RawCount, and the
green line indicates the Baseline.
12.View the required parameters by selecting or clearing the check boxes to the right of the Chart 

view.
13.Click Stop to stop scanning.
14.Click Table to view the values of the demonstration board variables.
CY3280-24x94 Universal CapSense® Controller Kit Guide, Document No. 001-70137 Rev. *A 21



Kit Operation
Figure 3-6.  Bridge Control Panel Table View
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4. Hardware
4.1 System Block Diagram
The CY3280-24x94 UCC board has the following sections:
■ PSoC CY8C24094-24LTXI
■ Power supply system
■ USB Mini B connector
■ CapSense module connector
■ ISSP/I2C connector
■ ICE-Cube debug connector
■ VADJ variable regulator control
■ LEDs
■ Reset switch
■ CMOD

Figure 4-1.  System Block Diagram
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Hardware
4.2 Functional Description
The CY3280-24x94 UCC includes PSoC CY8C24094-24LTXI, ISSP/I2C connector, CapSense Mod-
ule connector, CapSense plus Module Connector, Mini B USB connector, DC Supply jack, and ICE-
Cube debug connector. The following figure shows the different functional blocks on the CY3280-
24x94 UCC board.

Figure 4-2.  CY3280-24x94 UCC Functional Blocks
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Hardware
4.2.1 PSoC CY8C24094-24LTXI
The PSoC CY8C24094 is initially factory programmed as a CapSense controller with the control cir-
cuitry to work with the CY3280-24x94 UCC kit. The PSoC CY8C24094 along with CSD technology
demonstrates the use of CapSense buttons and linear sliders. The module board connected to the
CY3280-24x94 Universal CapSense Controller has sensors and LEDs.

The CapSense module board is connected to PSoC through Port P2. The list of pins connected to
different ports is shown in Table 4-1.

PSoC CY8C24094 is programmed through ISSP using a MiniProg and the data acquisition and out-
put checking is done using I2USB Bridge. 

Figure 4-3.  Schematic View of PSoC CY8C24094 24LTXI
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Hardware
Table 4-1.  Pin Description of CY8C24094-24LTXI

Pin Number Name Description Connect to
1 P4[7] GPIO P3

2 P4[5] Vbus in USB Connector J6

3 P4[3] GPIO P3

4 P4[1] GPIO P3

5 OCDE OCD mode direction pin P1

6 OCDO OCD mode direction pin P1

7 Vss Ground Connection

8 P3[7] GPIO P3

9 P3[5] GPIO P3

10 P3[3] CapSense P2

11 P3[1] Rb (bleed Resistor) P2

12 P5[7] GPIO P3

13 P5[5] GPIO P3

14 P5[3] GPIO P3

15 P5[1] GPIO P3

16 P1[7] I2C Serial Clock (SCL) P2

17 P1[5] I2C Serial Data (SDA) P2

18 P1[3] CapSense P2

19 P1[1] I2C SCL, ISSP Clock P2,P3,J2,J3

20 Vss Ground Connection

21 D+ USB D+ J6

22 D- USB D- J6

23 Vdd Supply Voltage

24 P7[7] GPIO P3

25 P7[6] GPIO P3

26 P7[5] GPIO P3

27 P7[4] GPIO P3

28 P7[3] GPIO P3

29 P7[2] GPIO P3

30 P7[1] GPIO P3

31 P7[0] GPIO P3

32 P1[0] I2C SDA, ISSP Data P2,P3,J2,J3

33 P1[2] GPOI,LED4 P2

34 P1[4] CapSense P2
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35 P1[6] CapSense P2

36 P5[0] GPIO P3

37 P5[2] GPIO P3

38 P5[4] GPIO P3

39 P5[6] GPIO P3

40 P3[0] CapSense P2

41 P3[2] CapSense P2

42 P3[4] GPIO P3

43 P3[6] GPIO P3

44 HCLK OCD high speed clock output P1

45 CCLK OCD CPU clock output P1

46 XRES Active high external reset with internal 
pull down J4

47 P4[0] GPIO P3

48 P4[2] GPIO P3

49 P4[4] GPIO P3

50 P4[6] GPIO P3

51 P2[0] CapSense P2

52 P2[2] CapSense P2

53 P2[4] CapSense P2

54 P2[6] CapSense P2

55 P0[0] GPIO P2

56 P0[2] CapSense P2

57 P0[4] CapSense P2

58 P0[6] CapSense P2

59 Vdd Supply Voltage

60 Vss Ground Connection

61 P0[7] Shield Electrode P2

62 P0[5] Integrating Input

63 P0[3] GPIO,LED3 P2

64 P0[1] GPIO,LED2 P2

65 P2[7] GPIO,LED1 P2

66 P2[5] GPIO,LED0 P2

67 P2[3] CapSense P2

68 P2[1] CapSense P2

Table 4-1.  Pin Description of CY8C24094-24LTXI (continued)

Pin Number Name Description Connect to
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4.2.2 Power Supply System
The power supply system on this board is versatile; it takes input supply from the following sources:
■ 12 V DC supply using connector J5
■ 9 V battery connector using connectors BH1 and BH2
■ USB power (5 V) from communications section using connector J6
■ Power from MiniProg and I2USB Bridge connected at J3
■ Power from ICE Cube connected at P1

The board power domain is split into:
■ Vin rail: This is the rail where the input of the on-board regulators is connected. This domain is 

powered by the power sources (12 V DC supply and 9 V battery terminal) through protection 
diodes.

■ 5 V rail: This is the output of the 5 V regulator IC U5 and also from the devices such as MiniProg 
or I2USB Bridge. The rail is a fixed 5 V output regardless of any jumper settings. The voltage in 
this rail can be less than 5 V only when the board is powered by the USB power.

■ VADJ rail: This is the output of the variable voltage regulator control. The following block diagram 
shows the structure of the power system on the board.

■ VCC rail: This is the VDD rail of CY8C24094 device. This is supplied either from a 5 V rail, VADJ 
rail, or ICE Cube debugger. The following block diagram shows the structure of the power system 
on the board.

Figure 4-4.  Power Supply System Structure
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Figure 4-5.  Schematic View of the Power Supply System Structure

4.2.2.1 Power Supply Jumper Setting

The jumper settings for each power setting are as follows:
1. To allow power to be supplied by the MiniProg, I2USB Bridge either connect pin 2 and pin 3 of J1 

with a jumper or connect pin 2 and pin 1 of J1 with a jumper.
2. To allow power from the 12 V DC supply, 9 V battery terminal, or Mini B USB connector, connect 

pin 2 and 3 of J1 with a jumper.
3. To allow power from the variable regulator control (VADJ), connect the pin 1 and 2 of J1 with a 

jumper
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4.2.3 USB Mini B Connector
The USB Mini B connector is a mini port used to communicate between the PC and the board and to
power up the controller, supplying a voltage of 5 V. Protection diode D3 ensures that the 5 V from the
board does not flow to the USB connector.

Figure 4-6.  Schematic View of the USB Mini B Port

4.2.4 CapSense Module Connector
The CY3280-24x94 has an expansion port, P2. It is designed to connect CapSense module boards.
The CY3280-24x94 controller board can be used with any of the Universal CapSense module
boards. Universal CapSense module boards can be interfaced to the CY3280-24x94 controller
through the 44-pin receptacle connector P2. The pin mapping for the port P2 is shown in the follow-
ing figure. 

Figure 4-7.  Schematic View of Port P2
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4.2.5 CPM Connector (CapSense Plus Module Connector)
The CY3280-24x94 has an expansion port, P3. This port is designed to connect CY3280-CPM1
(CapSense Plus Module) to demonstrate CapSense Plus features of the CY8C24094 device. The
pin mapping for the port P3 is shown in the following figure.

Figure 4-8.  Schematic View of Port P3

4.2.6 ISSP/I2C Connector
In-System Serial Programmer (ISSP) is used to program the device using the MiniProg programmer
device and the USB cable. Plug in the MiniProg device to the ISSP Header J3. The ISSP connector
is also used to connect the I2USB Bridge to communicate between the PC and the controller board.
XRES/INT of the ISSP/I2C header can be either connected to XRES of CY8C24094 by shorting Pin1
and Pin 2 of J4 using a jumper or it can be connected to P1[5] of CY8C24094 device by shorting Pin
2 and Pin 3 of J4 using a jumper. Refer to Power Supply Jumper Setting on page 29. The pin map-
ping for the ISSP connector is shown in the following figure.

Figure 4-9.  Schematic View of the ISSP Connector

4.2.7 ICE-Cube Debug Connector
The ICE-CUBE Debugger allows users to debug and view the content of specific memory locations.
The ICE-Cube debugger can be connected to the CY3280-24x94 controller through port P1. The fol-
lowing figure shows the schematic view of the ICE-CUBE debug connector.
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Figure 4-10.  Schematic View of the ICE CUBE Connector

4.2.8 VADJ Variable Regulator Control
The CY3280-24x94 controller has a variable regulator control used to vary input voltage using the
voltage regulator IC U3. The input for the variable regulator control is the output of the 5 V Regulator.
VADJ is used to demonstrate CapSense at several voltages. Vout can be varied by using the digital
potentiometer U3. 

Figure 4-11.  Schematic View of the VADJ Regulator

HCLK

CCLK

OCDO

OCDE

XRES

VCC

ICE

0402

C12

0.1 uFd0402

C12

0.1 uFd

04
02

R
73

1K

04
02

R
73

1K

0
4
0
2

R90

1K

0
4
0
2

R90

1K

04
02

R
72

1K

04
02

R
72

1K

04
02

R
76

1K

04
02

R
76

1K0603

C5

330 pFd0603

C5

330 pFd

1
2

P1

RJ45 Right Angle

P1

RJ45 Right Angle

1
2
3
4
5
6
7
8

04
02

R
74

1K

04
02

R
74

1K
RegAdj

5V Vadj

+3216 C6
10 uFd 16v

+3216 C6
10 uFd 16v

SOT-223

U3
LP3875ES-ADJ TO263-5
SOT-223

U3
LP3875ES-ADJ TO263-5

nSD1

VIN2 VOUT 4

ADJ 5

G
N

D
3 0402

C7

0.01 uFd0402

C7

0.01 uFd

0402

R81 8.87K 1%

0402

R81 8.87K 1%

+3216 C8
10 uFd 16v

+3216 C8
10 uFd 16v

0
8
0
5

R82

NO LOAD

0
8
0
5

R82

NO LOAD

1
2

32 CY3280-24x94 Universal CapSense® Controller Kit Guide, Document No. 001-70137 Rev. *A



Hardware
4.2.9 LEDs
The LEDs are used to show the status of the controller board. LED D1 lights up on connecting power
supply from 12 V DC supply, USB, 9 V battery, PSoC MiniProg, I2USB Bridge, or VADJ. LED D2
lights up once the board is powered by any of the power sources (12 V DC supply, USB, 9 V battery,
PSoC MiniProg, I2USB Bridge, ICE Cube, or VADJ).

Figure 4-12.  Schematic View of the LEDs D1 and D2

4.2.10 CMOD
CMOD is the test point provided on the UCC for accessibility of charge and discharge waveforms of
the measured capacitance.It is the test point for modulating capacitance C3. This test point may
increase the noise sensitivity by acting as an antenna.

4.2.11 Rb
Rb is the bleed resistor connected to P3 [1] provided on UCC. This is one of the external compo-
nents required for capacitive sensing on CY8C24094 24LTXI.
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5. Code Examples
All code examples are available in the Firmware folder of the kit CD or at the following location:
<Install_directory>\Cypress\CY3280-24x94\<version>\Firmware\

5.1 My First Code Example

5.1.1 Project Description
This project demonstrates the use of the CapSense buttons and linear slider on the CY3280-SLM
board using CSD technology and CY8C24x94. The EzI2C user module is used to transfer
CapSense parameters related to a sensor from the board to the PC for monitoring. 

This  project  scans  five  CapSense  buttons and a 10-segment slider using the CSD user module.
There are five LEDs on board, which illuminate when a CapSense button or slider is touched. The
EzI2C user module is used to provide a register-based I2C slave communications protocol. The sta-
tus of CapSense sensors (both button and slider) and their parameters are updated in the I2C regis-
ter. This register can be accessed by any I2C master, similar to the I2USB Bridge.

The application starts by executing boot.asm. The boot.asm does the hardware initialization and
invokes the 'main' function. The main function initializes the EzI2C Slave user module and
CapSense user module. After initialization, the main function enters a loop, which does the following:
■ Scans all sensors
■ Reads the sensor ID sent by the I2C master
■ Stores CapSense data in the I2C registers
■ Updates the LED status for the On/Off sensors

The following user modules are used in this project:
■ CSD: The CSD provides capacitance sensing using the switched capacitor technique with a 

sigma-delta modulator to convert the sensed switching capacitor current to digital code.
■ EzI2Cs: The EzI2Cs user module implements an I2C register-based slave device.This user mod-

ule does not require any digital or analog PSoC blocks. It is used to transfer all CapSense param-
eters related to a sensor to the PC for monitoring.
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5.1.2 FlowChart

Start

Enable Global 
Interrupts. Clear 

all LED’s

Set RAM buffer

Start I2C, CSD user modules.
Initialise Baseline  and set 

finger threshold

Scan all sensors and update 
baseline of each sensor

Store RawCount, Baseline, Difference 
count, Sensor Mask into I2C buffer for all 

sensors

Is any Capsense 
button active?

Store active button number in 
I2C buffer

Store 0xFF as default active 
button data in I2C buffer

Yes

No

Get finger position on slider

Is finger present 
on slider?

Store finger position on slider 
in I2C buffer

Store 0x00 as default slider 
status data in I2C buffer

Yes

No

Turn ON Led based on active 
sensor number
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5.1.3 Creating My First PSoC 1 Project
1. Open PSoC Designer.
2. To create a new project, click File > New Project. The New Project window opens.
3. In the New Project window, select the Chip-level icon. Name the project 

Example_My_First_PSoC_Project.
4. For Location, click Browse and navigate to the directory in which you want to create the project.

Figure 5-1.  New Project Window

5. Click OK. The Select Project Type window opens.
6. In this window under Select Target Device, click View Catalog.

Figure 5-2.  Select Project Type Window
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7. The Device Catalog window opens. Click on the USB tab, and scroll down to the CY8C24794, 
CY8C24894, CY8C24994 section. 

8. For this project click CY8C24794-24LTXI and then click Select.

Figure 5-3.  Device Catalogue Window

9. Under Generate 'Main' File Using: select C, and then click OK.
10.By default, the project opens in chip view.
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Figure 5-4.  Default View

11.Now, place and configure the modules required for this design. Connect the modules together 
and to the pins of the PSoC. In the User Modules window, expand the Cap Sensors folder. In 
this folder right click on CSD and select Place. 

Figure 5-5.  User Modules Window - CSD Select
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12.A window to choose the CSD configuration opens. Choose Select CSD with PRS16 as Clock 
Source configuration and click OK.

Figure 5-6.  CSD Configuration
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13.The CSD user module gets placed.

Figure 5-7.  CSD User Module Placement

14.Configure the CSD_1 properties as shown in Figure 5-8.

Figure 5-8.  CSD User Module Properties
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15.To select  the CSD  Wizard  option,  right click  on  CSD  user module  to  assign  pins  to  the  
sensors.

Figure 5-9.  Open CSD Wizard
42 CY3280-24x94 Universal CapSense® Controller Kit Guide, Document No. 001-70137 Rev. *A



Code Examples
Figure 5-10.  CSD Wizard Window
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16.Configure the Global Settings in the CSD Wizard window.

Figure 5-11.  Global Settings - CSD Wizard

17.Click on the slider in the CSD Wizard to view the Sensor Settings. Configure the sensor set-
tings.

Figure 5-12.  Sensors Settings - CSD Wizard

18.To assign the sensor on a particular pin, click and drag from the sensor block to the required pin 
in the Pin Assignment window. Drag and drop SW0 to pin P1 [6]. The assignment of the sensor 
pins can be done in either Chip Pin Assignment View (Figure 5-13) or Table Pin Assignment 
View (Figure 5-14).
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Figure 5-13.  Assigning Sensors to Pins - Chip Pin Assignment View

Figure 5-14.  Assigning Sensors to Pins - Table Pin Assignment View
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19.The following screenshot shows the CSD Wizard window after a sensor is assigned.

Figure 5-15.  Sensor Assigned

20.Next, assign all the sensors according to Table 5-1.
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Table 5-1.  Sensor Assignment

Figure 5-16.  All Sensors Assigned - Table Pin Assignment View

Sensor Port Pin
SW0 P1[6]
SW1 P1[3]
SW2 P3[3]
SW3 P2[1]
SW4 P2[3]
S1(0) P1[4]
S1(1) P0[6]
S1(2) P0[4]
S1(3) P0[2]
S1(4) P2[6]
S1(5) P2[4]
S1(6) P2[2]
S1(7) P2[0]
S1(8) P3[2]
S1(9) P3[0]
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Figure 5-17.  All Sensors Assigned - Chip Pin Assignment View

21.Click OK to exit the CSD wizard and return to main screen.
22.In the User Modules window, expand the Digital Comm folder, select EzI2Cs, right click, and 

place an EzI2Cs in the design. 

Figure 5-18.  User Module Window - EzI2Cs Select
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23.The EzI2Cs user module does not require a digital block for placement because it requires only 
two port pins (SCL and SDA), either P[1]0-P[1]1 or P[1]5-P[7]1.

24.Configure the properties of EzI2Cs_1 as shown in Figure 5-19.

Figure 5-19.  EzI2Cs User Module Properties

26.Configure the port pin P2[5] in the Pinout window.

Figure 5-20.   P2[5] Port Pin Properties
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27.Configure the properties of P2[7], P0[1], P0[3], and P1[2] as shown in the following figures.

Figure 5-21.  P2[7] Port Pin Properties

Figure 5-22.  P0[1] Port Pin Properties

Figure 5-23.  P0[3] Port Pin Properties

Figure 5-24.  P1[2] Port Pin Properties
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28.Configure the Global Resources window as shown in Figure 5-25.

Figure 5-25.  Global Resources Window

29.Open the existing main.c file within Workspace Explorer. Replace the existing main.c content 
with the content of the embedded Example_My_First_Example_Project_Main.c file (see 
Figure 5-17), which is attached in this PDF document.

Figure 5-26.  Workspace Explorer Window
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30.Add a new file to the project by clicking File > New File.

Figure 5-27.  Adding a New File to Project

31.Select a .C file type and name the file ‘display’.

Figure 5-28.  File Types
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32.Create 2 .h file types and name them main.h and display.h respectively.

Figure 5-29.  New Files in Project

33.Copy the content of the embedded display.c, display.h, and main.h files, that are attached with 
this PDF document, to the respective files in the project.

34.To build the project, go to Build > Generate/Build 'Example_My_First_PSoC_Project' Project.
35.Connect the CY3280-24X94 board to the PC through a MiniProg1. 

Figure 5-30.  Connecting MiniProg1 to the Board
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36.The board can be programmed either through the PSoC Designer IDE or by launching PSoC 
Programmer. To program the board using PSoC Programmer, refer to Section 3.4. To program 
the board through PSoC Designer follow these steps.

37.Click on Program > Program Part

Note While programming the board through PSoC Designer, close any open instance of PSoC Pro-
grammer.

Figure 5-31.  Program Part Window

38.In the Program Part window, ensure the following: 
a. In the Port Selection drop down box, select MiniProg1/xxxxxxxxxxx and make certain it is 

‘Connected'
b. Set Acquire Mode to Power Cycle
c. Set Verification to Off
d. Set Power settings to 5.0 V

39.Click on the Program button (see Figure 5-31) to start programming the board.

Note Ensure that the shorting jumper is placed on pin 2 of J1 and pin 1 of J7.

Toggle Power
Button

Program Button
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40.The board programming starts and you can observe the status on the progress bar.

Figure 5-32.  Programming Status

41.When programming is successful, you get the 'Operation Succeeded!' message.

Figure 5-33.  ‘Operation Succeeded!' Message

5.1.4 Verify Output
1. Connect a linear slider module (SLM) on connector P2 of the board.
2. Disconnect the MiniProg1 from the header J3 and connect a USB-I2C bridge board in its place.
3. Connect a USB cable from the USB-I2C bridge board to a free USB port on a PC.
4. Open Bridge Control Panel by clicking on Start > Programs > Cypress > Bridge Control 

Panel <version> > Bridge Control Panel <version>. Ensure that the PSoc Designer and PSoC 
Programmer are closed before opening the bridge control panel.

5. Select the Variable Settings option from the Chart menu, click Load, navigate to open the 
CY3280_SLM_Project1.ini file from the CD or from the following kit install location:  
<Install_directory>\Cypress\CY3280-24x94\<version>\Firmware\
USB-I2CBridgeSoftwareConfig and click OK.

6. Click Open File from the File menu; navigate to and open the CY3280_SLM_Project1.iic file from 
the CD or from the kit install location  <Install_directory>\Cypress\CY3280-24x94\<ver-
sion>\Firmware\USB-I2CBridgeSoftwareConfig and click OK.

7. Select +5 V in the power settings box. Click Toggle Power to power the I2USB Bridge, LED (red) 
D1 glows. 
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Figure 5-34.  Linear Slider Module and USB-I2C Bridge connected to the Capsense Controller Board

First 
command line
Second 
command line
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8. On the CapSense slider board, touch the button with your finger. Each button touch lights up the 
associated LED on the module board.

9. Touch the linear slider with your finger. The associated LED on the module board lights up, repre-
senting where you finger is on the slider.

10.The CapSense parameters such as RawCount, Baseline, Difference Count, and Mask Info (refer 
to the CSD User module datasheet for a more detailed explanation of each parameter) for a par-
ticular sensor can be seen on the Bridge Control Panel. The current active button number and 
finger position on the slider are also outputted on the Bridge Control Panel.

11.The syntax of the first command line is as follows:

12.The first command writes to the Universal CapSense Controller (UCC) board, the sensor number 
for which the monitoring is required.

13.The second command line reads the CapsSense parameters from the UCC board.
14.Change the sensor ID for which parameter monitoring is required and click Send to write the sen-

sor ID to the UCC board. 

Figure 5-35.   Command Line View

15.Click on the second command line and then click Repeat to read I2C data received from the UCC 
board.

16.Switch to the Chart tab to view the respective waveforms of CapSense parameters (see 
Figure 5-36). Click on the check box to view only the required parameters.

W 05 0 1 p

Write command Slave Id Address 
Offset

Sensor 
number Stop

(constant) (constant) (In hexadecimal,  Valid 
range: 0x1 – 0xF)
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Figure 5-36.  Bridge Control Panel Chart View - Only RawCount and Baseline Output during a
Finger Press

17.The various parameter values being received by the UCC can be seen in the Table tab in the 
Bridge Control Panel.

Note The table gets populated with the received data only after the Stop  button is pressed.
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Figure 5-37.  Bridge Control Panel Table View
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5.2 CY3280_24x94_Project1

5.2.1 Project Description
This project demonstrates the use of the CapSense buttons and linear slider on the CY3280-SLM
board using CSD technology and CY8C24x94A. The EzI2Cs user module is used to transfer
CapSense parameters related to a sensor to the PC for monitoring. This project is implemented in
the chip level design in PSoC Designer 5.1.

This project scans five CapSense buttons and a 10-segment slider using the CSD user module.
There are five LEDs on board, which illuminate when a CapSense button or slider is touched. The
EzI2Cs user module is used to provide a register-based I2C slave communications protocol. The
status of CapSense sensors (both button and slider) and their parameters are updated in the I2C
register, which can be accessed by any I2C master, similar to the I2USB Bridge.

The application starts by executing boot.asm. The boot.asm does the hardware initialization and
invokes the 'main' function. The main function initializes the EzI2Cs Slave user module and
CapSense user module. After initialization, the main function enters into a loop, which does the fol-
lowing:
■ Scans all sensors
■ Reads the sensor ID sent by the I2C master
■ Stores CapSense data in the I2C registers
■ Updates the LED status for the On/Off sensors

The following user modules are used in this project:
■ CSD: The CSD provides capacitance sensing using the switched capacitor technique with a 

sigma delta modulator to convert the sensed switching capacitor current to digital code.
■ EzI2Cs: The EzI2Cs user module implements an I2C register based slave device.This user mod-

ule does not require any digital or analog PSoC blocks. It is used to transfer all CapSense param-
eters related to a sensor to the PC for monitoring. 
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5.2.2 Device Configurations

Figure 5-38.  Device Configuration for CY3280_24x94_Project1
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5.2.3 Firmware Architecture

Start

Enable Global 
Interrupts. Clear 

all LED’s

Set RAM buffer

Start I2C, CSD user modules.
Initialise Baseline  and set 

finger threshold

Scan all sensors and update 
baseline of each sensor

Store RawCount of all sensors in I2C 
buffer

Is any Capsense 
button active?

Store active button number in 
I2C buffer

Store 0xFF as default active 
button data in I2C buffer

Yes

No

Get finger position on slider

Is finger present 
on slider?

Store finger position on slider 
in I2C buffer

Store 0x00 as default slider 
status in I2C buffer

Yes

No

Turn ON Led based on active 
sensor number
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5.2.4 Verify Output
Load CY3280_SLM_Project1.iic file from the Bridge Control Panel, as explained in Bridge Control
Panel on page 17. This file is available in the following location: 
<Install_directory>\Cypress\CY3280-24x94\<version>\Firmware\
USB-I2CBridgeSoftwareConfig

1. Touch one or more buttons; the associated LEDs light up.
2. Touch the linear slider; the associated LEDs light up.
3. Touch the linear slider and buttons simultaneously. The associated LEDs light up corresponding 

to the buttons and the sliders being pressed.
4. In the first command line, change the sensor ID for which parameter monitoring is required and 

click Send to write the sensor ID to the Universal CapSense Controller board. See Figure 5-39 
(w 05 0 1 p, where 05 is the I2C slave address, 0 is the address pointer, and 1 is the sensor ID). 
See Table 5-2 for a complete list of sensor IDs.

5. Click on the second command line and then click Repeat to read I2C data received from the Uni-
versal CapSense Controller board.

6. Switch to the Chart tab to view the respective wave forms of CapSense parameters; see 
Figure 5-40.

Note The character 'w' in Figure 5-2 defines the start of "write data" command. The character 'p'
generates stop condition on the I2C bus and character 'r' defines the start of "read data" command.

Figure 5-39.  Command Line View
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Table 5-2.  Sensor Details

Firmware Labels Sensor Name Sensor ID(HEX)

CSDSW0 BTN0 0
CSDSW1 BTN1 1
CSDSW2 BTN2 2
CSDSW3 BTN3 3
CSDSW4 BTN4 4
CSDSW5 SLD0 5
CSDSW6 SLD1 6

CSDSW7 SLD2 7

CSDSW8 SLD3 8

CSDSW9 SLD4 9

CSDSW10 SLD5 A

CSDSW11 SLD6 B

CSDSW12 SLD7 C
CSDSW13 SLD8 D
CSDSW14 SLD9 E
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Figure 5-40.  Bridge Control Panel Chart View

Note In the figure, the brown line represents the axis, the blue line indicates RawCount, and the
green line indicates the Baseline.
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5.3 CY3280_24x94_Project2

5.3.1 Project Description
This project demonstrates the use of CapSense Buttons and linear sliders using CSD technology
and CY8C24x94. The EzI2Cs user module is used to transfer the raw count of CapSense parame-
ters related to all the sensors to PC for monitoring. This project is implemented in chip level design in
PSoC Designer 5.1.

This project scans five CapSense buttons and a 10-segment slider using the CSD user module.
There are five LEDs on board, which illuminate when a CapSense button or slider is touched. The
EzI2Cs user module is used to provide a register-based I2C slave communications protocol. The
status of CapSense sensors (both button and slider) and their parameters are updated in the I2C
register, which can be accessed by any I2C master, similar to the I2USB Bridge.

The application starts by executing boot.asm. The boot.asm does the hardware initialization and
invokes the 'main' function. The main function initializes the EzI2Cs slave and CapSense user mod-
ules. After initialization, the main function enters into a loop, which does the following:
■ Scans all sensors
■ Reads the sensor ID sent by the I2C master
■ Stores CapSense data in the I2C registers
■ Updates the LED status for the On/Off sensors

The following user modules are used in this project:
■ CSD: The CSD provides capacitance sensing using the switched capacitor technique with a 

sigma delta modulator to convert the sensed switching capacitor current to digital code.
■ EzI2Cs: The EzI2Cs user module implements an I2C register based slave device.This user mod-

ule does not require any digital or analog PSoC blocks. It is used to transfer all CapSense param-
eters related to a sensor to the PC for monitoring.
66 CY3280-24x94 Universal CapSense® Controller Kit Guide, Document No. 001-70137 Rev. *A



Code Examples
5.3.2 Device Configurations

Figure 5-41.  Device Configuration for CY3280_24x94_Project2
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5.3.3 Firmware Architecture
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5.3.4 Verify Output
Load CY3280_SLM_Project2.iic file from the Bridge Control Panel as explained in Bridge Control
Panel on page 17. This file is available in the following location: 
<Installed_directory>\Cypress\CY3280-24x94\<version>\Firmware\
USB-I2CBridgeSoftwareConfig

1. Touch one or more buttons; the associated LEDs light up.
2. Touch the linear slider; the associated LEDs light up.
3. Touch the linear slider and buttons simultaneously. The associated LEDs light up corresponding 

to the buttons and the sliders being pressed.
4. Click on the command line and then click Repeat to read I2C data received from the Universal 

CapSense Controller board.
5. Switch to the Chart tab to view the respective waveforms of CapSense parameters. See 

Figure 5-43.

Note The character 'r' in Figure 5-42 defines the start of "read data" command.

Figure 5-42.  Command Line View
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Figure 5-43.  Bridge Control Panel Chart View

Note The brown line in the figure represents the axis.
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A. Appendix
A.1 Schematic
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Appendix
A.2 Board Layout

A.2.1 PDCR-9434 (Top)
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Appendix
A.2.2 PDCR-9434 Layer 2
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Appendix
A.2.3 PDCR-9434 Layer 3
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Appendix
A.2.4 PDCR-9434 Bottom
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Appendix
A.2.5 PDCR-9434 Primary Layer
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Appendix
A.2.6 PDCR-9434 Secondary Layer
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Appendix
A.3 Bill of Materials
Item Qty Reference Part Manufacturer Manuf. Part# ROHS Sub 

OK?

1 1 24x94 PCB Rev02 Cypress 
Semiconductor PDCR-99434 Rev02 Y N

2 2 C1,C2 CAP CER 10UF 16V X5R 0805
Murata 
Electronics North 
America

GRM21BR61C106KE15L Y Y

3 1 C3 CAP 0.01UF 50V CERAMIC X7R 0805 Panasonic - ECG ECJ-2VB1H103K Y Y

4 1 C5 CAP 330PF 100V CERAMIC X7R 0603 Panasonic - ECG ECJ-1VB2A331K Y Y

5 4 C6,C8,C9,C10 CAP 10UF 16V TANTALUM 10% 3216 AVX TAJA106K016R Y Y

6 2 C7,C11 CAP 10000PF 16V CERAMIC 0402 SMD Panasonic - ECG ECJ-0EB1C103K Y Y

7 1 C12 CAP .1UF 16V CERAMIC Y5V 0402 Panasonic - ECG ECJ-0EF1C104Z Y Y

8 2 D1,D2 LED RED Clear 0805 SMD LITE-ON Inc LTST-C170CKT Y Y

9 4 D3,D4,D5,D6 DIODE SCHOTTKY 0.5A 20V SOD-123 Fairchild 
Semiconductor MBR0520L Y Y

10 2 J1,J4 CONN HEADER VERT 3POS .100 30AU AMP Division of 
TYCO 87220-3 Y Y

11 1 J3 CONN HEADER 5POS 0.1 VERT KEYED Molex 22-23-2051 Y Y

12 1 J5 CONN 2.1MM PWRJACK RT ANGLE 
PCB Switchcraft RAPC722X Y Y

13 1 J6 CONN USB MINI AB SMT RIGHT 
ANGLE TYCO 1734035-2 Y Y

14 1 P1 CONN RJ45 8-8 MOD JACK UNSHIELD 
RIGHT ANGLE

AMP Division of 
TYCO 5557785-1 Y N

15 2 P2,P3 CONN FMALE 44POS DL .1" R/A GOLD Sullins 
Electronics Corp. PPPC222LJBN-RC Y N

16 51

R1,R2,R3,R6,R9,R1
0,R11,R12,R14,R16,
R17,R18,R19,R22,R
23,R24,R25,R26,R2
7,R28,R29,R30,R31,
R32,R33,R34,R35,R
36,R37,R38,R39,R4
0,R41,R42,R43,R44,
R45,R46,R48,R49,R
50,R51,R52,R54,R5
5,R60,R63,R65,R66,
R68,R70

RES 560 OHM 1/16W 5% 0402 SMD Yageo 
Corporation RC0402JR-07560RL Y Y

17 4 R4,R7,R53 RES 100 OHM 1/16W 5% 0402 SMD Rohm MCR01MZPJ101 Y Y

18 R47 RES 1.5k OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ152X Y Y

19 1 R13 RES 7.5K OHM 1/8W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ752V Y Y

20 4 R56,R62,R64,R67 RES 47 OHM 1/16W 5% 0402 SMD    Panasonic - ECG ERJ-2GEJ470X Y Y

21 2 R57,R58 RES 56k OHM 1/16W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ563V Y Y

22 2 R69,R71 RES 24 OHM 1/16W 5% 0603 SMD Panasonic - ECG ERJ-3GEYJ240V Y Y

23 4 R72,R73,R74,R76 RES 1.0K OHM 1/16W 5% 0402 SMD Yageo 
Corporation RC0402JR-071KL Y Y

24 2 R77,R78 RES 1K OHM 1/10W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ102V Y Y

25 1 R81 RES 8.87K OHM 1/16W 1% 0402 SMD Panasonic - ECG ERJ-2RKF8871X Y Y

26 4 R83,R84,R85,R86 RES ZERO OHM 1/16W  0402 SMD Panasonic - ECG ERJ-2GE0R00X Y Y

27 2 R87,R89 RES 100K OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GEJ104X Y Y

28 1 R90 RES 1.0K OHM 1/16W 5% 0402 SMD Phycomp USA Inc 9C1A04021001JLHF3 Y Y

29 1 TP2 TEST POINT 43 HOLE 65 PLATED 
ORANGE

Keystone
 Electronics 5003 Y Y

30 5 TP1,TP4,TP6,TP10,
TP12 TEST POINT 43 HOLE 65 PLATED RED Keystone 

Electronics 5000 Y Y

31 3 TP7,TP14,TP15 TEST POINT 43 HOLE 65 PLATED 
BLACK

Keystone 
Electronics 5001 Y Y

32 1 U1 IC, 68 QFN PSoC MIXED-SIGNAL 
ARRAY OCD

Cypress 
Semiconductor CY8C24094-24LTXI Y N
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33 1 U3 IC REG LDO 1.5A ADJ VOLT TO263-5 National 
Semiconductor LP3875ES-ADJ/NOPB Y N

34 1 U4 IC DGTL POT SPI 10K 10-MSOP Analog Devices 
Inc AD5161BRMZ10 Y N

35 1 U5 IC REG 5.0V 800MA LDO SOT-223 National 
Semiconductor LM1117MPX-5.0 Y Y

Do Not Populate

36 2 R82,R88 RES NO LOAD 0805 SMD NA NA Y Y

37 1 R75 RES 1.37K OHM 1/8W 5% 0805 SMD Panasonic - ECG ERJ-6ENF1371V Y Y

38 1 R79 POT 5K CARBON LAYDOWN (103) Panasonic - ECG EVN-D8AA03B53 Y Y

39 1 R80 RES 1.07K OHM 1/8W 5% 0805 SMD Panasonic - ECG ERJ-6ENF1071V Y Y

40 1 R21 RES CHIP 0.0 OHM 1/10W 5% 0805 
SMD Panasonic-ECG ERJ-6GEY0R00V Y Y

41 1 J2 CONN HEADER VERT 6POS .100 TIN Molex/Waldom 
Electronics 22-28-4060 Y Y

42 4 TP3,TP5,TP9,TP11 TEST POINT 43 HOLE 65 PLATED RED Keystone Elec-
tronics 5000 Y Y

43 1 TP13 TEST POINT 43 HOLE 65 PLATED 
BLACK

Keystone Elec-
tronics 5001 Y Y

44 1 U2 IC DGTL POT SPI 50K 10-MSOP Analog Devices 
Inc AD5161BRMZ50 Y N

45 1 C4 CAPACITOR 1.0UF/16V TEH SER SMD Panasonic - ECG ECS-H1CY105R Y Y

46 1 BH1 BATTERY HOLDER 9V Female PC MT Keystone 
Electronics 594 Y Y

47 1 BH2 BATTERY HOLDER 9V Male PC MT Keystone 
Electronics 593 Y Y

48 1 P4 CONN REC .100 14POS for LCM-
S01602DTR/A-3 3M Electronics 929850-01-14-10 Y Y

49 2 R59,R61 RES 56k OHM 1/16W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ563V Y Y

50 4 R5,R8,R15,R20 RES 560 OHM 1/16W 5% 0402 SMD Panasonic - ECG ERJ-2GE0R00X Y Y

51 1 TP8 TEST PAD 30 SMT (Copper) NA NA Y Y

Special Jumper Installation Instructions

52 1 Install jumper across pins 2 and 3 of J1 Sullins 
Electronics Corp. STC02SYAN Y Y

53 2 Install jumper across pins 1 and 2 of J4 Sullins 
Electronics Corp. STC02SYAN Y Y

Install On Bottom of PCB As Close To Corners As Possible

54 4 n/a BUMPER CLEAR.370X.19" CYLINDER Richco Plastic Co RBS-35 Y Y

Item Qty Reference Part Manufacturer Manuf. Part# ROHS Sub 
OK?
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