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OneEye_UART_Oscilloscope_1

for KIT_AURIX_TC397_TFT
Oscilloscope over UART using OneEye

Please read the Important Notice and Warnings at the end of this document



Scope of work

Demonstrate how to implement the OneEye oscilloscope over the 

UART (USB) interface

After configuring the OneEye UART interface, a OneEye oscilloscope is 

created. The signals are updated and sampled every millisecond. OneEye is 

used to visualize the signal values.



Introduction

› OneEye is a GUI that enables the creation of interactive Graphical User Interface. Graphical 

elements can be drag from a toolbox and drop onto the GUI. The behavior of the created 

GUI can be customized. Different communication interfaces like UART, Ethernet, CAN, DAS 

can be used to interact with the embedded system

› SyncProtocol / ProtocolBB is a synchronous protocol that enables data streaming between 

the target microcontroller and OneEye. It enables to open multiple communication channels, 

provide packet acknowledge and packet checksum. Data are transported within a message 

with a message ID and a message payload. See the OneEye help for more information.

› Note: It is recommended to go through some of the basic tutorials listed in the help 

embedded in OneEye (Menu: Help -> OneEye help). This enables a quicker ramp-up in the 

OneEye concept and ensures a nice journey with OneEye



Hardware setup

This code example has been 

developed for the board 

KIT_A2G_TC397_5V_TFT.

The board should be connected to the 

PC through the USB port 1
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Configuration overview

In this configuration an oscilloscope running on the microcontroller is connected to the COM port. 

In OneEye, two signals bb.in and bb.out are used to connect the COM port data stream to the BB protocol. 

The BB protocol is configured to open a channel reserved for the oscilloscope. This channel connects to the 

oscilloscope with the oscilloscope.in and oscilloscope.out signals.
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Implementation - AURIX

Enabling the OneEye library

The OneEye library must be enabled by adding the following line to Ifx_Cfg.h:
#define IFX_OE_AL_USE_AURIX_ILLD

Configuring the OneEye Oscilloscope

A OneEye oscilloscope (Ifx_Oe_Osci) is an object that enable data sampling and provide triggering functionality. 

The OneEye oscilloscope communication interface (Ifx_Oe_OsciBb) enables streaming of data and control of the 
oscilloscope using the BB protocol (Ifx_Oe_SyncProtocol).  
The OneEye oscilloscope is initialized with initOscilloscope() / Ifx_Oe_Osci_init(). 

The autoAddChannels parameter enables to automatically add channels for each created oscilloscope signal. 
The sample period (samplePeriod) is set to 1ms and provides OneEye information about sample timing. 
The triggerMode is set to automatic, note that this value can be changed from the OneEye oscilloscope interface 
later.
The ifx_oe_osci.h file can be found in the Libraries\OneEye directory.

Adding signals to the oscilloscope

Oscilloscope signals are mainly pointers that the oscilloscope can use for data sampling. The signals are added using 
Ifx_Oe_Osci_addSignal(). The function takes as parameter the signal name displayed by the oscilloscope, with an 
optional unit string in parenthesis, the signal type which informs the oscilloscope how to read the pointer value and a 
source pointer to the data. The last parameter corresponds to the q format used in case of fix point data, or 0 if not 
used. 
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Starting the oscilloscope

The oscilloscope is started with the function Ifx_Oe_Osci_start().

Configuring the signal generator

A signal generator is used to provide the user with some value to read / write. The signal generator does 

nothing more than incrementing two signals, signalA and signalB, stored in the structure g_signalGenerator

up to a maximum value before resetting them. 

The initialization of the signal generator is done with initSignalGenerator().

Running the signal generator and the oscilloscope

The signal generator is executed in the background loop every 1ms with processSignalGenerator(). To 

ensure the timing, a deadline variable is periodically updated with Ifx_Oe_Time_add() to obtain the 1ms 

period.  

The oscilloscope runs in the same background loop with sampleOscilloscope() / Ifx_Oe_Osci_step(). This 

function handles the triggering and sampling of data. 

Note: the call to Ifx_Oe_Osci_step() can be moved to an interrupt service routine if required by the 

application use case.



› After code compilation, flash the device using the Flash button to ensure that the 

program is running on the device

› For this training, the OneEye application is required for visualizing the values. OneEye can 

be opened inside the AURIX™ Development Studio using the following icon:

Run and Test

› Clicking the OneEye

icon automatically 

opens the OneEye

configuration for the 

active project. If no 

configuration exists, it 

is created by AURIX™ 

Development Studio
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Implementation - OneEye

In this training, the OneEye configuration is provided inside the Libraries folder. The following steps are 

needed to configure the oscilloscope from a brand-new configuration.

Setup OneEye for editing

Select the OneEye menu “Options -> Edit mode” (if not already checked) to enable the edit mode.

Select the OneEye menu “View -> Browser box”, “View -> Property box” , “View -> Tool box” (if not 

already checked) to display the browser, property box and tool box. Note that the box can be moved around. 



Implementation - OneEye

Removing the default DAS interface

When the OneEye configuration is created by ADS, it is already setup with a DAS interface. 

Select the interface in the Browser box        and delete it with “right click and remove” as it is not required in 

this example.
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Implementation - OneEye

Configuring the UART interface: Signal creation

The first step is to create 2 signals to connect the received and transmit data over the UART.

Create a signal group and set its name property to bb. 
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Add two signals of type char into the bb group, name them in and out, and set their title property to 

respectively BB in and BB out.



Implementation - OneEye

Configuring the UART interface: COM port

Right click in an empty area of the Browser box, and select Add child -> Interface. Then right click on the 

created interface and select Add child -> com. Select the com item and set its device property to the COM 

port connected to the AURIX board. Set the baudrate property to 115200 and click connect.

The COM port is now opened and ready for communication.



Implementation - OneEye

Configuring the UART interface: Transmit stream

Right click on the interface in the Browser box, and select Add child -> dataMessageHandler. Then right 

click on the created dataMessageHandler and select Add child -> message to create a message item. 

Configure the message with the id=0xFE, interval=0.001, send-on-new-data checked, dir=tx, stream 

checked.
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Right click on the message, and select Add child -> field. 

Configure the field with name=bb.out, bit-pos=0, buffer=512.

Now, data will be transmitted over the UART each time the bb.out signal is written with some data.



Implementation - OneEye

Configuring the UART interface: Receive stream

Right click on the dataMessageHandler and select Add child -> message to create a second message item. 

Configure the message with the id=0xFF, interval=-1, dir=rx, stream checked.



Implementation - OneEye

Right click on the message, and select Add child -> field. 

Configure the field with name=bb.in, bit-pos=0.

Now each time data are received over the UART, the bb.in signal will be updated.



Implementation - OneEye

Configuring the UART interface: Push button

Drag and drop a pushButton widget from the toolbox onto the layout, configure it with title=Setup Serial 

Interface, on-click={show.connection.ui}.

Clicking the button now shows the COM port configuration window.



Implementation - OneEye

Configuring the BB protocol

Right click in an empty area of the Browser box, and select Add child -> protocolEngine. Then right click on 

the created protocolEngine and select Add child -> protocol-core-bb. Connect the BB protocol stream to 

the bb.in and bb.out signals by setting respectively the data-in and data-out properties. Set the name

property to BB-core. And set the timeout to 2000 ms so that frames are dropped after 2 seconds in case the 

microcontroller is not answering.
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Configuring the Oscilloscope: signals creation

Create a signal group and set its name property to oscilloscope. 
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Add two signals of type char into the oscilloscope group, name them in and out, and set their title property 

to respectively Oscilloscope in and Oscilloscope out.



Implementation - OneEye

Create the oscilloscope widget

Drag and drop an oscilloscope widget from the toolbox onto the layout, set the oscilloscope properties data-

in and data-out to respectively oscilloscope.in and oscilloscope.out. Set the protocol-type property to 

ProtocolBB. Set the unit-x property to s.
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Connect the oscilloscope widget to the BB protocol

Right click on the protocol-core-bb and select Add child -> target. Select the target item and set local-port 

and remote-port to 3 to match the AURIX settings, set signal-in=oscilloscope.out, signal-

out=oscilloscope.in, forward=checked.
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Test the oscilloscope

The oscilloscope Control tab provides configuration for the trigger and information about the oscilloscope state 

(armed, triggered, uploading). 

Click on the Control button       and the Refresh State button to retrieve the oscilloscope settings (channels, 

timings, …).
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Implementation - OneEye

Test the oscilloscope

In the oscilloscope Channel tab, click on the Channel button        and check the visible check box for both 

CH0: Signal A and CH1: Signal B to display the two channels.

Set the Unit per div Y to 200 for both CH0: Signal A and CH1: Signal B.

Select the Pen color red for CH0: Signal A and blue for CH1: Signal B.
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Implementation - OneEye

Test the oscilloscope

Click on the Control button        , check the run button        , the values for signalA and signalB should be 

updating in the oscilloscope.

Set the Time/Div value to Zoom All to 

configure the horizontal scale to use the full 

screen of the oscilloscope window.

The Buffer depth configures the 

oscilloscope buffer depth, here 512 points 

are used to fill the buffer. This value can be 

changed within the limit set by the software.

The Sampling interval provides the 

information whether to sample at each 

interval (1) or not (>1) to the oscilloscope.
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Implementation - OneEye

Advanced options

Advanced configuration can be added to the file Ifx_Cfg.h or ifx_oe_cfg.h to tune the oscilloscope 

capabilities, this includes:

› IFX_CFG_OE_OSCI_MAX_NUM_OF_SIGNALS: the maximum number of signals that can be declared 

by the user

› IFX_CFG_OE_OSCI_MAX_NUM_OF_CHANNELS: the maximum number of channels that can be 

buffered

› IFX_CFG_OE_OSCI_NUM_OF_SAMPLES: the maximum number of sample per channel

Note: the memory used by the oscilloscope is mainly defined by 

IFX_CFG_OE_OSCI_MAX_NUM_OF_CHANNELS * IFX_CFG_OE_OSCI_NUM_OF_SAMPLES * 4

Default values for the above mentioned macros are provided in ifx_oe_oscicfg.h under Library/OneEye.



References

› More code examples can be found on the GIT repository:

› https://github.com/Infineon/AURIX_code_examples

› For additional trainings, visit our webpage:

› https://www.infineon.com/aurix-expert-training

› AURIX™ Development Studio is available online:

› https://www.infineon.com/aurixdevelopmentstudio

› Use the „Import...“ function to get access to more code examples.

› For questions and support, use the AURIX™ Forum:

› https://www.infineonforums.com/forums/13-Aurix-Forum

https://github.com/Infineon/AURIX_code_examples
https://www.infineon.com/aurix-expert-training
https://www.infineon.com/aurixdevelopmentstudio
https://www.infineonforums.com/forums/13-Aurix-Forum


IMPORTANT NOTICE
The information given in this document shall in no
event be regarded as a guarantee of conditions or
characteristics (“Beschaffenheitsgarantie”) .

With respect to any examples, hints or any typical
values stated herein and/or any information
regarding the application of the product, Infineon
Technologies hereby disclaims any and all
warranties and liabilities of any kind, including
without limitation warranties of non-infringement
of intellectual property rights of any third party.

In addition, any information given in this
document is subject to customer’s compliance
with its obligations stated in this document and
any applicable legal requirements, norms and
standards concerning customer’s products and
any use of the product of Infineon Technologies in
customer’s applications.

The data contained in this document is exclusively
intended for technically trained staff. It is the
responsibility of customer’s technical
departments to evaluate the suitability of the
product for the intended application and the
completeness of the product information given in
this document with respect to such application.

For further information on the product,
technology, delivery terms and conditions and
prices please contact your nearest Infineon
Technologies office (www.infineon.com).
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Due to technical requirements products may
contain dangerous substances. For information
on the types in question please contact your
nearest Infineon Technologies office.

Except as otherwise explicitly approved by
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signed by authorized representatives of Infineon
Technologies, Infineon Technologies’ products
may not be used in any applications where a
failure of the product or any consequences of the
use thereof can reasonably be expected to result
in personal injury.
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