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Scope and purpose 

This application note introduces you to PSoCԊ 4, an Arm® Cortex®-M0/M0+ based programmable system-on-
chip. It helps you explore the PSoCԊ 4 architecture and development tools and shows you how to create your 
first project using 03I#Ԋ #L?;NIL and -I>OM4IIF<IRԊ, the development tools for PSoCԊ 4. This application 
note also guides you to more resources to accelerate in-depth learning about PSoCԊ 4. 

Intended audience 

This application note is intended for engineers new to PSoCԊ and ModusToolboxԊ, and those with experience 
in working with embedded microcontrollers. 

Associated part family  

All PSoCԊ 4 parts 

Software version 

PSoCԊ Creator 4.3 SP2 or higher, ModusToolboxԊ 2.3 or higher 

More code examples? We heard you. 

To access an ever-growing list of hundreds of PSoCԊ code examples, please visit our code examples web page. 

You can also explore the video training library here. 
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1 )HNLI>O=NCIH 

PSoCԊ 4 is a true programmable embedded system-on-chip, integrating custom analog and digital peripheral 

functions, memory, and an Arm® Cortex®-M0 or Cortex®-M0+ microcontroller on a single chip. This type of 
system is different from most mixed-signal embedded systems, which use a combination of a microcontroller 
unit (MCU) and external analog and digital peripherals. Such systems typically require many integrated circuits 
in addition to the MCU, such as opamps, ADCs, and Application-specific Integrated Circuit (ASICs). 

PSoCԊ 4 provides a low-cost alternative to the combination of MCU and external ICs. In addition to reducing 
overall system cost, the programmable analog and digital subsystems allow great flexibility, in-field tuning of 

the design, and speedy time to market. 

The capacitive touch-sensing feature in PSoCԊ 4, known as CAPSENSEԊ, offers unprecedented signal-to-noise 

ratio; best-in-class waterproofing; and a wide variety of sensor types such as buttons, sliders, trackpads, and 
proximity sensors. PSoCԊ 4 offers a best-in-class current consumption of 150 nA while retaining SRAM, 
programmable logic, and the ability to wake up from an interrupt. PSoCԊ 4 consumes only 20 nA while 
maintaining wakeup capability in its non-retention power mode. The PSoCԊ 4 family of devices also contain 

PSoCԊ 4 Bluetooth® LE, which integrates a Bluetooth® Low Energy radio system. For more details on PSoCԊ 4 
Bluetooth® LE, see AN91267.  

Using this document 

The next few pages describe PSoCԊ 4 and the advantages of designing with PSoCԊ, ModusToolboxԊ, and 
03I#Ԋ #L?;NIL. Or, you can jump right in and quickly build a simple design in -I>OM4IIF<IRԊ ӝ go to My first 

03I#Ԋ 4 design using -I>OM4IIF<IRԊ in 03I#Ԋ #L?;NIL ӝ go to My first 03I#Ԋ 4 design using 03I#Ԋ 
Creator. 

http://www.cypress.com/documentation/application-notes/an91267-getting-started-psoc-4-ble
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2 03I#Ԋ L?MIOL=?M 

The wealth of data available here can help you select the right PSoCԊ device, and quickly and effectively 
integrate the device into your design. The following is an abbreviated list for PSoCԊ 4: 

¶ Overview: PSoCԊ portfolio , PSoCԊ roadmap 

¶ Product selectors:  PSoCԊ 4. In addition, PSoCԊ Creator includes a device selection tool.  

¶ Datasheets describe and provide electrical specifications for each family. 

¶ Application notes cover a broad range of topics, from basic to advanced level, and include the following: 

ī AN88619: PSoCԊ 4 hardware design considerations 

ī AN73854: Introduction to bootloaders 

ī AN89610: Arm® Cortex® code optimization 

ī AN86233: PSoCԊ 4 low-power modes and power reduction techniques 

ī AN57821: Mixed-signal circuit board layout 

ī AN89056: PSoCԊ 4 - IEC 60730 class B and IEC 61508 SIL Safety Software Library 

ī AN64846: Getting started with CAPSENSEԊ 

ī AN85951: PSoCԊ 4 and PSoCԊ 6 MCU CAPSENSEԊ design guide 

¶ Code examples demonstrate product features and usage ӝ see 03I#Ԋ #L?;NIL Code examples and 
-I>OM4IIF<IRԊ Code example. 

¶ Technical reference manuals (TRMs): Provide detailed descriptions of the architecture and registers in 
each 03I#Ԋ 4 device family. 

¶ 03I#Ԋ 4 programming specification  provides the information necessary to program PSoCԊ 4 nonvolatile 
memory. 

¶ Development tools: 

ī CY8CKIT-040, CY8CKIT-041, CY8CKIT-042, CY8CKIT-044, CY8CKIT-046, CY8CKIT-042-BLE, CY8CKIT-

045S, and CY8CKIT-041S-MAX PSoCԊ 4 pioneer kits are easy-to-use and inexpensive development 

platforms. These include connectors for Arduino-compatible shields and Digilent® 0GI>Ԋ >;OABN?L 
cards. 

ī CY8CKIT-043, CY8CKIT-145, CY8CKIT-147 and CY8CKIT-149 are very low-cost prototyping platforms for 
sampling PSoCԊ 4 devices. 

ī The MiniProg3 or MiniProg4 kit provides and interface for flash programming and debug. 

ī Integrated Development Environment (IDE): There are two development platforms that you can use for 

application development with PSoC Ԋ4 ӝ ModusToolboxԊ and PSoCԊ Creator 

ī PSoCԊ 4 CAD libraries provide footprint and schematic support for common tools. IBIS models are also 

available. 

¶ Training videos are available on a wide range of topics including the PSoCԊ 4 101 series 

¶ Cypress developer community  enables connection with fellow 03I#Ԋ developers around the world, 24 

hours a day, 7 days a week, and hosts a dedicated PSoCԊ 4 MCU community 

2.1 &CLGQ;L?Ӯ;JJFC=;NCIH >?P?FIJG?HN 

There are two development platforms that you can use for application development with PSoCԊ 4: 

¶ ModusToolboxԊ: ModusToolboxԊ software includes configuration tools, low-level drivers, middleware 

libraries, and operating system support, as well as other packages that enable you to create MCU and 

wireless applications. It also includes the optional Eclipse IDE. 

http://www.cypress.com/
http://www.cypress.com/psoc
http://www.cypress.com/product-roadmaps/cypress-platform-psoc-solutions-roadmap
http://www.cypress.com/products/psoc-4
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Atechnical_documents&f%5B1%5D=resource_meta_type%3A575&f%5B2%5D=field_related_products%3A1297
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Atechnical_documents&f%5B1%5D=resource_meta_type%3A574&f%5B2%5D=field_related_products%3A1297
https://www.cypress.com/documentation/application-notes/an88619-psoc-4-hardware-design-considerations
https://www.cypress.com/documentation/application-notes/an73854-psoc-introduction-bootloaders
https://www.cypress.com/documentation/application-notes/an89610-psoc-4-and-psoc-5lp-arm-cortex-code-optimization
https://www.cypress.com/documentation/application-notes/an86233-psoc-4-low-power-modes-and-power-reduction-techniques
https://www.cypress.com/documentation/application-notes/an57821-psocr-3-psoc-4-and-psoc-5lp-mixed-signal-circuit-board
https://www.cypress.com/documentation/application-notes/an89056-psoc-4-iec-60730-class-b-and-iec-61508-sil-safety-software
https://www.cypress.com/documentation/application-notes/an64846-getting-started-capsense
https://www.cypress.com/documentation/application-notes/an85951-psoc-4-and-psoc-6-mcu-capsense-design-guide
https://www.cypress.com/search/all/code%20example?sort_by=search_api_relevance&f%5B0%5D=meta_type%3Asoftware_tools&f%5B1%5D=software_tools_meta_type%3A579&f%5B2%5D=field_related_products%3A1297
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=117&id=4749&applicationID=0&l=0
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Atechnical_documents&f%5B1%5D=field_related_products%3A1297&f%5B2%5D=resource_meta_type%3A108321
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=110&id=4749&applicationID=0&l=0
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-040-psoc-4000-pioneer-development-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-041-psoc-4-s-series-pioneer-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-psoc-4-pioneer-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-044-psoc-4-m-series-pioneer-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-046-psoc-4-l-series-pioneer-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/psoc-4500s-pioneer-kit-cy8ckit-045s
https://www.cypress.com/documentation/development-kitsboards/psoc-4500s-pioneer-kit-cy8ckit-045s
https://www.cypress.com/documentation/development-kitsboards/psoc-4100s-max-pioneer-kit-cy8ckit-041s-max
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-043-psoc-4-m-series-prototyping-kit
http://www.cypress.com/CY8CKIT-145
http://www.cypress.com/CY8CKIT-147
http://www.cypress.com/CY8CKIT-149
http://www.cypress.com/go/cy8ckit-002
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-005-miniprog4-program-and-debug-kit
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Atechnical_documents&f%5B1%5D=field_related_products%3A1297&f%5B2%5D=resource_meta_type%3A1400
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Asoftware_tools&f%5B1%5D=software_tools_meta_type%3A580&f%5B2%5D=field_related_products%3A1297
https://www.cypress.com/training/free-online-video-training-and-tutorials-cypress
https://www.cypress.com/training/psoc-101-video-tutorial-series-how-use-arm-cortex-m0-based-psoc-4
https://community.cypress.com/welcome
https://community.cypress.com/community/product-forums/MCU/psoc-4
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-I>OM4IIF<IRԊ supports stand-alone device and middleware configurators that can be launched from the 
Eclipse IDE. Use the configurators to set the configuration of different blocks in the device and generate 

code that can be used in firmware development. MI>OM4IIF<IRԊ supports all 03I#Ԋ 6 MCU and the latest 
PSoCԊ 4 MCU devices. Table 1 lists the supported PSoCԊ 4 devices. It is recommended that you use 

-I>OM4IIF<IRԊ for all application development for supported PSoCԊ 4 devices. See -I>OM4IIF<IRԊ 
resources for more information. 

Table 1 List of PSoCԊ 4 devices supported in -I>OM4IIF<IRԊ 

Devices1 -I>OM4IIF<IRԊ 03I#Ԋ #L?;NIL 

PSoCԊ 4000S, PSoCԊ 4100S, 
PSoCԊ 4100S Plus, PSoCԊ 4100S 

Plus 256K 

Yes Yes 

PSoCԊ 4100S Max Yes No 

All other PSoCԊ 4 devices No Yes 

The libraries and enablement software are available on GitHub.  

-I>OM4IIF<IRԊ tools and resources can also be used in the command line. See Running ModusToolboxԊ 

from the command line for detailed documentation. 

¶ 03I#Ԋ #L?;NIL: PSoCԊ Creator is a free Windows-based IDE. It enables concurrent hardware and firmware 

design of PSoCԊ 3, PSoCԊ 4, PSoCԊ 5LP, and PSoCԊ 6 MCU systems. Applications are created using 
schematic capture and over 150 pre-verified, production-ready peripheral Components. 

  

                                                                    
1 See 03I#Ԋ 4 feature set @IL =IGJF?N? 03I#Ԋ Ҕ JILN@IFCIӆ 

https://github.com/Infineon
http://www.cypress.com/ModusToolboxCommandLine
http://www.cypress.com/ModusToolboxCommandLine
http://www.cypress.com/psoccreator/?source=an79953
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2.2 #BIIMCHA ;H )$% 

Figure 1 helps you choose an appropriate IDE. 
 

Use PSoC Creator

Is device 
supported in 

ModusToolbox?

New PSoC 4 user

Use ModusToolbox

Is device 
supported only in 
ModusToolbox?

Do you need 
UDB-based Component in 

your Design?

Are you inclined towards using a 
Graphical Editor for Design Entry 

and Code Generation?

Recommended to use 
ModusToolbox

Yes

Yes

Yes

Yes

No

No

No

No

Do you need Linux or MacOS
 support or use third-party IDEs such 
as Visual Studio Code, IAR, or Arm 

MDK?

No

Yes

 

Figure 1 Choosing an IDE 
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2.2.1 7BS =BIIM? -I>OM4IIF<IRԊӍ 

¶ Comprehensive: It has the resources you need. 

¶ Flexible: You can use the resources in your own workflow. 

¶ Atomic: You can get just the resources you want. 

¶ A large collection of code repositories on GitHub, including:  

ī Board Support Packages (BSPs) aligned with Infineon kits 

ī Low-level resources, including a Hardware Abstraction Layer (HAL) and Peripheral Driver Library (PDL) 

ī Middleware enabling industry-leading features such as CAPSENSEԊ 

ī An extensive set of thoroughly tested code example applications 

¶ Supported across Windows, Linux, and macOS platforms.  

¶ IDE-neutral and supports third-party IDEs, including Visual Studio Code, Arm® MDK (µVision), and IAR 

Embedded Workbench.  

¶ Choose -I>OM4IIF<IRԊ if you have prior experience with Eclipse-based tools and want to take advantage of 
the power and extensibility of the optional Eclipse-based IDE for -I>OM4IIF<IRԊ. 

2.3 -I>OM4IIF<IRԊ L?MIOL=?M 

-I>OM4IIF<IRԊ is a set of tools and software that enables an immersive development experience for creating 
converged MCU and wireless systems, and enables you to integrate Infineon devices into your existing 

development methodology. 

Eclipse IDE for -I>OM4IIF<IRԊ is a multi-platform development environment that supports application 
configuration and development. -I>OM4IIF<IRԊ installer includes the design configurators and tools, and the 

build system infrastructure. The build system infrastructure includes the new project creation wizard that can 

be run independent of the Eclipse IDE, the make infrastructure, and other tools. 

2.3.1 03I#Ԋ Ҕ MI@NQ;L? L?MIOL=?M 

-I>OM4IIF<IRԊ also includes Infineon-provided software resources delivered via GitHub. These include: 

¶ BSP ӝ BSP is the layer of firmware containing board-specific drivers and other functions. The BSP is a set of 

libraries that provide APIs to initialize the board and provide access to board-level peripherals. It includes 

low-level resources such as the PDL library for PSoCԊ 4, and has macros for board peripherals. Custom BSPs 
can be created to enable support for end-application boards. See the ModusToolboxԊ Library Manager 

user guide for more information. 

¶ HAL ӝ The HAL provides a high-level interface to configure and use hardware blocks on Infineon MCUs. It is a 

generic interface that can be used across multiple product families. The focus on ease-of-use and portability 

means that the HAL does not expose all low-level peripheral functionalities. HAL wraps the low-level drivers 

(like PSoCԊ 4 PDL) and provides a high-level interface to the MCU. The interface is abstracted to work on any 
MCU. This helps you write application firmware independent of the target MCU. 

¶ The HAL can be combined with platform-specific libraries (such as PSoCԊ 4 PDL) within a single application. 

You can leverage the HAL's simpler and more generic interface for most of an application, even if one 
portion requires finer-grained control. 

¶ PSoCԊ 4 PDL ӝ The PDL integrates device header files, startup code, and peripheral drivers into a single 
package. PDL supports the PSoCԊ 4 device family. The drivers abstract the hardware functions into a set of 
easy-to-use APIs. These are fully documented in the PDL API Reference.  

https://github.com/Infineon
https://github.com/Infineon
https://www.cypress.com/file/520271/download
https://www.cypress.com/file/520271/download
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¶ PDL reduces the need to understand register usage and bit structures, thus easing software development for 
the extensive set of peripherals in the PSoCԊ 4 series. You configure the driver for your application, and then 

use API calls to initialize and use the peripheral. 

¶ Extensive middleware libraries that provides specific capabilities to an application. The available 

middle ware spans across connectivity (Bluetooth®, AWS IoT, Bluetooth® LE, Secure Sockets) to 03I#Ԋ-
specific functionality (CAPSENSEԊ).The middleware is delivered as libraries via GitHub repositories. 

¶ Utilities, Makefiles, scripts, and other configuration software. 

2.3.2 #IH@CAOL;NILM 

-I>OM4IIF<IRԊ provides graphical applications called Configurators that make it easier to configure a 
hardware block. For example, instead of having to search through the documentation to configure a serial 

communication block (SCB) as a UART with a desired configuration, open the appropriate Configurator and set 
the baud rate, parity, and stop bits. Upon saving the hardware configuration, the tool generates the "C" code to 

initi alize the hardware with the desired configuration. 

Configurators are independent of each other, but they can be used together to provide flexible configuration 

options. They can be used as a stand-alone, in conjunction with other tools, or launched from the Eclipse IDE. 
Configurators are used for: 

¶ Setting options and generating code to configure drivers 

¶ Setting up connections such as pins and clocks for a peripheral 

¶ Setting options and generating code to configure middleware 

For PSoCԊ 4 applications, the available Configurators include: 

¶ Device Configurator: Sets up the system (platform) functions and the basic peripherals (for example, UART, 
Timer, PWM). 

¶ CAPSENSEԊ Configurator and Tuner: Configures CAPSENSEԊ and generates the required code. 

¶ Smart I/O Configurator:  Configures the Smart I/O. 

Each of these Configurators create their own files (for example, design.cycapsense for CAPSENSEԊ). The 

configurator files (design.modus or design.cycapsense) are usually provided with the BSP. When an application 
is created based on a BSP, the files are copied into the application. You can also create custom device 

configurator files for an application and override the files provided by the BSP. See -I>OM4IIF<IRԊ help for 
more details. 

2.3.3 3I@NQ;L? >?P?FIJG?HN @IL 03I#Ԋ Ҕ 

Significant source code and tools are provided to enable software development for PSoCԊ 4 devices. You can 

use the tools to specify how you want to configure the hardware, generate code that you can use in your 
firmware, and include various middleware libraries, such as CAPSENSEԊ, for additional functionality This 

source code makes it easier to develop firmware for supported devices. It helps you to quickly customize and 

build firmware without the need to understand the register set. 

In the -I>OM4IIF<IRԊ environment, you can use configurators to configure either the device or a middleware 

library, like the CAPSENSEԊ functionality.  

The driver code is delivered as the mtb-pdl-cat2 library. Middleware is delivered as separate libraries for each 
feature/function.  

If you are working at the register-level, regardless of whether you use Eclipse IDE, a third-party IDE, or the 
command line, see the driver source code from the PDL. PDL includes all device-specific header files and 

https://github.com/Infineon/modustoolbox-software
https://github.com/Infineon/modustoolbox-software
https://github.com/cypresssemiconductorco
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startup code you need for your project. It also serves as a reference for each driver. PDL is provided as source 
code, so you can see how it accesses the hardware at the register level. 

Some devices do not support particular peripherals. PDL is a superset of all drivers for any supported device. 
This superset design means that: 

¶ All API elements needed to initialize, configure, and use a peripheral are available. 

¶ PDL is useful across various PSoCԊ 4 devices, regardless of available peripherals. 

¶ PDL includes error checking to make sure that the targeted peripheral is present on the selected device. 

This enables the code to maintain compatibility across the PSoCԊ 4 device family as long as the peripherals are 
available. A device header file specifies the peripherals that are available for a device. If your code attempts to 
use an unsupported peripheral, you will get an error during compilation. Before writing the code, see the device 

datasheet to check if the peripheral is supported.  

Figure 2 shows that with the Eclipse IDE for ModuM4IIF<IRԊ you can: 

1. Use Project Creator (File > New > ModusToolbox Application) to create a new application for your BSP 
(kit). 

2. Configure peripherals and middleware libraries using configuration tools. 

3. Add, update, or remove libraries and BSPs easily and quickly using the Library Manager. 

4. Optionally, develop code in an Eclipse-based IDE. 
 

1

2

Configure peripherals

Create a starter 
example for 

your BSP

3 Add libraries

4 Use an Eclipse IDE 
(optional)

 

Figure 2 Eclipse IDE for -I>OM4IIF<IRԊ resources and middleware  
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2.3.4 #I>? ?R;GJF? 

The Project Creator tool is used with the -I>OM4IIF<IRԊ software to create applications based on BSPs and 
code examples. Project Creator is provided as a graphical user interface (GUI) and a command-line interface 

(CLI) to create applications, which can be used in any software environment  

1. Open the Project Creator tool.  

Follow the menu File > New > ModusToolbox Application.  
 

 

Figure 3 Opening project  creator tool 

2. Select a target PSoCԊ 4 development kit. 

In the Choose Board Support Package (BSP) dialog, select your kit from the list.  
 

  

Figure 4 Choosing target hardware 
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3. Select an application.  

The Select Application  dialog lists the Application applicable for the selected BSP. Select the required 
application and click Create. The selected application will be created. 

 

  

Figure 5 Selecting an application  

2.3.5 -I>OM4IIF<IRԊ B?FJ 

ModusToolboxԊ user guide provides a high-level overview of the -I>OM4IIF<IRԊ software. 

Download the latest version of -I>OM4IIF<IRԊ and install it. Launch Eclipse IDE for -I>OM4IIF<IRԊ and 
navigate to Help > ModusToolbox General Documentation: 

¶ User Guide: Covers the aspects of building, programming and debugging applications. It also covers various 

aspects of the tools installed along with the IDE 

¶ ModusToolbox Documentation Index: Provides brief descriptions and links to various documentation 
included in the -I>OM4IIF<IRԊ software. 

Release Notes: Describes features for the corresponding release of -I>OM4IIF<IRԊ, and lists the known 
issues, workarounds, and design impacts that you should be aware of. For documentation on Eclipse IDE for 
-I>OM4IIF<IRԊ, navigate to Help > Eclipse IDE for ModusToolbox Documentation: 

¶ Quick Start Guide: Provides the basics for using Eclipse IDE for -I>OM4IIF<IRԊ. 

¶ User Guide: Describes how to create applications, and build, program, and debug them using Eclipse IDE 

¶ Eclipse IDE Survival Guide: Provides answers to the common issues that might occur while using an Eclipse 

IDE. Most questions are related to Eclipse IDE and not -I>OM4IIF<IRԊ.  

https://www.cypress.com/file/492951/download
http://www.cypress.com/modustoolbox
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2.4 03I#Ԋ #L?;NIL 

PSoCԊ Creator is an IDE that enables concurrent hardware and firmware editing, compiling and debugging of 
PSoCԊ systems. As Figure 6 shows, with 03I#Ԋ #L?;NIL, you can: 

1. Drag and drop Components to build your hardware system design.  

2. Co-design your application firmware with the PSoCԊ hardware. 

3. Configure Components with config tools. 

4. Explore the library of more than 100 Components. 

5. Review Component datasheets. 
 

1

2

3

4

5

 

Figure 6 Features of 03I#Ԋ #L?;NIL features 

2.4.1 #I>? ?R;GJF?M 

03I#Ԋ #L?;NIL includes a large number of code example projects. These projects are available from the 03I#Ԋ 
Creator Start Page, as shown in Figure 7. 

https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide


  

Application Note 13 of 61 001-79953 Rev.*U  

  2021-07-08 

'?NNCHA MN;LN?> QCNB 03I#Ԋ 4 
  

03I#Ԋ L?MIOL=?M 

  

 

 

Figure 7 Code examples in 03I#Ԋ #L?;NIL 

Example projects can speed up your design process by starting you off with a complete design, instead of a 

blank page. The example projects also show how 03I#Ԋ #L?;NIL Components can be used for various 

applications. Code examples and datasheets are included, as shown in Figure 8. 

In the Find Example Project dialog, shown in Figure 8, you can: 

a) Filter examples based on architecture or device family, that is, 03I#Ԋ 3, 03I#Ԋ 4, 03I#Ԋ 5LP or 03I#Ԋ 6 
MCU, category, or keyword.  

b) Select from the filtered list of examples.  

c) Review the datasheet for the selection (in the Documentation tab) 

d) Review the code example for the selection. You can copy the code from this window and paste in your 

project, which can help speed up code development. Alternatively, you can create a new project (and a 
new workspace if needed) based on the selection. This can speed up your design process by starting you 

off with a complete, basic design. You can then adapt that design to your application. 
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A

B

C D

 

Figure 8 Code example projects with sample code 

2.4.2 03I#Ԋ #L?;NIL B?FJ 

Visit the 03I#Ԋ #L?;NIL home page to download the latest version of 03I#Ԋ #L?;NIL. Then, launch 03I#Ԋ 

Creator and navigate to the following items: 

¶ Quick Start Guide: Choose Help > Documentation  > Quick Start Guide. This guide gives you the basics for 

developing 03I#Ԋ #L?;NIL projects. 

¶ Simple Component example projects: Choose File > Open > Example projects. These example projects 

demonstrate how to configure and use 03I#Ԋ #L?;NIL Components. 

¶ System Reference Guide: Choose Help > System Reference > System Reference Guide. This guide lists 

and describes the system functions provided by 03I#Ԋ #L?;NIL. 

¶ Component datasheets: Right-click a Component and select Open Datasheet. Visit the 03I#Ԋ 4 
Component datasheets page for a list of all 03I#Ԋ 4 Component datasheets. 

¶ 03I#Ԋ #L?;NIL t raining videos: These videos provide step-by-step instructions on how to get started with 
03I#Ԋ #L?;NIL. 

¶ Document Manager: 03I#Ԋ #L?;NIL provides a document manager to help you to easily find and review 
document resources. To open the document manager, choose the menu item Help > Document Manager. 

2.5 4?=BHC=;F MOJJILN 

If you have any questions, our technical support team is happy to assist you. You can create a support request 
on the Technical support  page. The support team monitors and responds to your questions, issues, and bug 
reports posted on the GitHub repositories. 

You can also use the following support resources if you need quick assistance. 

¶ Self-help 

¶ Local sales office locations 

http://www.cypress.com/?id=2494&source=an79953
http://www.cypress.com/?id=4749&rtID=377
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=377&id=4749&source=an79953
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=377&id=4749&source=an79953
http://www.cypress.com/video-library/PSoC-Software
https://www.cypress.com/support
https://github.com/Infineon
https://www.cypress.com/support
http://www.cypress.com/?id=1062
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3 03I#Ԋ Ҕ @?;NOL? M?N 

03I#Ԋ 4 has an extensive set of features, which include a CPU and memory subsystem, a digital subsystem, an 
analog subsystem, and system resources, as shown in Figure 9. The following sections give brief descriptions of 
each feature. For more information, see the 03I#Ԋ 4 family device datasheets, technical reference manuals 

(TRMs), and application notes listed in PSoCԊ resources. 
 

 Peripherals

CPU Subsystem

System Interconnect (Single Layer AHB)

PSoC 4100S 

Max

IO
S

S
 G

P
IO

 (
1
3

x
 p

o
rt

s
)

 
 

 

I/O Subsystem

Peripheral Interconnect (MMIO)PCLK

FLASH

384 KB

Read Accelerator

SPCIF

32-bit

AHB-Lite

Up to 84x GPIOs
Deep Sleep
Active/Sleep

Power Modes

Digital DFT

Test

Analog DFT

System Resources

Lite

Power

Clock

Reset

Clock Control

IMO

Sleep Control

REFPOR

Reset Control

TestMode Entry

WIC

XRES

WDT
ILO

PWRSYS

 
8
x
 T

C
P

W
M

W
C

O

2
x
 L

P
 C

o
m

p
a
ra

to
r

 
 

SAR ADC

(12-bit)

x1

1x CTBm
2x Opamp

Programmable

Analog

SARMUX

High Speed I/O Matrix and 3x Smart I/O

SWD/TC, MTB

NVIC, IRQMUX, MPU

Cortex

M0+

48 MHz
FAST MUL

L
C

D

2
x
 C

a
p

S
e

n
s
e

E
X

C
O

 (
w

 P
L
L

)
 

C
A

N
 F

D

DataWire/

DMA

Initiator/MMIO

C
R

Y
P

T
O

(A
E

S
, 

S
H

A
, 

T
R

N
G

, 
P

R
N

G
, 

C
R

C
)

I2
S

 M
a

s
te

r 
T

X

5
x
 S

C
B

-I
2
C

/S
P

I/
U

A
R

T

ROM

8 KB

ROM Controller

SRAM

32 KB

SRAM Controller

 

Figure 9 03I#Ԋ 4 architecture  (03I#Ԋ 4100S Max) 

The 03I#Ԋ 4 portfolio consists of several families of Arm® CM0 and CM0+ microcontrollers. Most devices in the 

portfolio has CAPSENSEԊ technology for capacitive-sensing applications. Other key features of the 03I#Ԋ 4 
portfolio include a customizable analog front end through programmable analog blocks and wired and wireless 
connectivity options such as USB, Controller Area Network (CAN), and Bluetooth® LE. These unique features 

make 03I#Ԋ Ҕ NB? CH>OMNLSӒM GIMN @F?RC<F? ;H> M=;F;<F? FIQ-power mixed-signal architecture. The 03I#Ԋ 4 
devices are classified as different families, as shown in Table 2, based on different features. 

Table 2 03I#Ԋ 4 families 

Classification Family Features Details 

Entry level 03I#Ԋ 4000 family CAPSENSEԊ Table 3 

Intelligent analog 03I#Ԋ 4100 family CAPSENSEԊ + Programmable Analog Table 4 
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Classification Family Features Details 

Programmable digital 03I#Ԋ 4200 family CAPSENSEԊ + Programmable Analog + 

Programmable Digital Blocks 

Table 5 

Application specific 03I#Ԋ 4500 family CAPSENSEԊ + Motor Control Table 6 

03I#Ԋ 4700 family CAPSENSEԊ + Inductive Sensing 

Analog coprocessor2 03I#Ԋ 4A00 family CAPSENSEԊ + Programmable Analog Blocks AN211293 

Note: In Table 3 and Table 4, the columns highlighted in green indicate the family is supported in 

-I>OM4IIF<IRɫ. 

Table 3 03I#Ԋ 4000 family features 

Features 03I#Ԋ 4000 03I#Ԋ 4000S 

CPU 16-MHz Cortex®-M0  48-MHz Cortex®-M0+  

Flash memory 16 KB 32 KB 

SRAM 2 KB 4 KB 

GPIOs 20 36 

CAPSENSEԊ 16 sensors 35 sensors 

Single-slope ADC (10-bit 46-ksps) None 1 

Comparators 1 CSD comparator with a fixed 

threshold (1.2 V) 

Two low-power comparators with 

wakeup feature 

IDACs3 One 7-bit and one 8-bit Two 7-bits 

Smart I/O ports None 2 

Power supply range 1.71 V to 5.5 V 1.71 V to 5.5 V 

Low-power modes Deep Sleep at 2.5 µA Deep Sleep at 2.5 µA 

Segment LCD drive None 4 COM segment LCD drive 

Serial communication One I2C Two SCBs with programmable I2C, 

SPI, or UART 

Timer Counter Pulse-Width 

Modulator (TCPWM) 

1 5 

Clocks  Internal main oscillator 

(IMO) 

24 MHz/32 MHz  

 

24 MHz to 48 MHz  

 

Internal low-speed 

oscillator (ILO) 

32-kHz internal ILO 40 kHz 

 

Watch crystal oscillator 

(WCO) 

None 32-kHZ 

Power supply monitoring Power-on reset (POR) 

Brown-out detection (BOD) 

POR, BOD 

Supported kit CY8CKIT-040 pioneer kit  CY8CKIT-041 pioneer kit  

Supported IDE 03I#Ԋ #L?;NIL 03I#Ԋ #L?;NIL, -I>OM4IIF<IRԊ 

                                                                    
2 See AN211293 @IL A?NNCHA MN;LN?> QCNB 03I#Ԋ Ҕ ;H;FIA =IJLI=?MMIL @;GCFS >?PC=?Mӆ 

3 IDACs are available only when CAPS%.3%Ԋ is not in use. See the respective PSoCԊ 4 architecture TRM for more details. 

https://www.cypress.com/documentation/application-notes/an211293-getting-started-psoc-analog-coprocessor
http://www.cypress.com/CY8CKIT-040&source=an79953
http://www.cypress.com/CY8CKIT-041
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/documentation/application-notes/an211293-getting-started-psoc-analog-coprocessor
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Table 4 03I#Ԋ 4100 family features 

Features 03I#Ԋ 4100 03I#Ԋ 4100S 03I#Ԋ 4100S 

Plus 

03I#Ԋ 4100S 

Plus 256K 

03I#Ԋ 4100PS 03I#Ԋ 4100M 03I#Ԋ 4100 BL4 03I#Ԋ 4100S 

Max 

CPU 24-MHz 

Cortex®-M0 

48-MHz 

Cortex®-M0+ 

48-MHz 

Cortex®-M0+ 

48-MHz 

Cortex®-M0+ 

48-MHz 

Cortex®-M0+ 

24-MHz 

Cortex®-M0 

24-MHz 

Cortex®-M0 

48-MHz 

Cortex®-M0+ 

DMA N/A N/A 8 channels 8 channels 8 channels 8 channels 8 channels 16 channels 

Flash memory 32 KB 64 KB 128 KB 256 KB 32 KB 128 KB 256 KB 384 KB 

SRAM 4 KB 8 KB 16 KB 32 KB 4 KB 16 KB 32 kB 32 KB 

GPIOs 36 36 54 54 38 55 36 84 

CAPSENSEԊ 1 channel, 

35 sensors 

1 channel, 35 

sensors 

1 channel, 53 

sensors 

1 channel, 53 

sensors 

1 channel, 33 

sensors 

2 channels, 54 

sensors 

1 channel, 35 

sensors 

2 channels, 80 
sensors (32 

control mux) 

12-bit SAR ADC 

with sequencer 

806-KSPS 1-MSPS  1-MSPS 1-MSPS 1-MSPS 806-KSPS 806-KSPS 1-MSPS 

Opamps 

(programmable)  

2 2 2 2 4/PGA 4 2 2 

Programmable 

Voltage 

Reference 

(PVref) 

None None None None Four channels None None None 

Voltage DAC 

(VDAC) 

None None None None Two 13-bit 

VDAC 

None None None 

Comparators 
(low power with 

wakeup feature) 

2 2 2 2 2 2 2 2 

IDACs5 One 7-bit 

and one 8-

bit 

Two 7-bits Two 7-bits Two 7-bits Two 7-bits Two 7-bits 

and two 8-

bits 

One 7-bit and 

one 8-bit 

None 

Smart I/O ports None 2 3 2 1 None None 3 

                                                                    
4 See AN91267 for getting MN;LN?> QCNB 03I#Ԋ 4 Bluetooth® LE Family devices. 

5 IDACs are available only when CAPS%.3%Ԋ is not in use. See the respective PSoCԊ 4 architecture TRM more details. 

https://www.cypress.com/documentation/application-notes/an91267-getting-started-psoc-4-ble


  

 

 

G
e

ttin
g

 s
ta

rt?
>
 
Q
C
N
B
 
0
3
I
#
Ԋ

 4
 

  0
3
I
#
Ԋ
 
Ҕ
 
@
?
;
N
O
L
?
 
M
?
N

 

  

A
p

p
lica

tio
n

 N
o

te 
1
8 o

f 6
1 

0
0
1-7

9
9
5

3
 R

e
v.*U  

 
 

2
0
2
1-0

7-0
8 

Features 03I#Ԋ 4100 03I#Ԋ 4100S 03I#Ԋ 4100S 

Plus 

03I#Ԋ 4100S 

Plus 256K 

03I#Ԋ 4100PS 03I#Ԋ 4100M 03I#Ԋ 4100 BL4 03I#Ԋ 4100S 

Max 

Power supply 

range 

1.71 V to 

5.5 V 

1.71 V to 5.5 V 1.71 V to 

5.5 V 

1.71 V to 

5.5 V 

1.71 V to 5.5 V 1.71 V to 5.5 V 1.71 V to 5.5 V 1.71 V to 5.5 V 

Low-
power 

modes 

Deep 

sleep 

1.3 µA 2.5 µA 2.5 µA 2.5 µA 2.5 µA 1.35 µA 2.5 µA 2.5 µA 

Hibern

ate 

150 nA NA NA NA NA 150 nA NA NA 

Stop 20 nA NA NA NA NA 35 nA NA NA 

Segment LCD 

drive 

4 COM 4 COM 4 COM 4 COM 4 COM 4 COM 4 COM 4 COM 

SCBs with 
programmable 

I2C, SPI, or UART 

2 3 5 5 3 4 2 5 

TCPWM 4 5 8 8 8 8 4 8 

CAN None None 1 None None None None 1 

BLE None None None None None None 4.1/4.2 None 

Clocks IMO 3 MHz to 

24 MHz 

24 MHz to  

48 MHz 

24 MHz to  

48 MHz 

24 MHz to  

48 MHz 

24 MHz to  

48 MHz 

3 MHz to 48 

MHz 

24 MHz to  

48 MHz 

24 MHz to  

48 MHz 

ILO 32 kHz 40 kHz 40 kHz 40 kHz 40 kHz 32 kHz 40 kHz 40 kHz 

WCO Nil 32 kHZ 32 kHZ 32 kHZ 32 kHZ 32 kHZ 32 kHZ 32 kHZ 

Power supply 

monitoring 

POR, BOD, 
Low-

voltage 

detection 

(LVD) 

POR, BOD POR, BOD POR, BOD POR, BOD POR, BOD, 

LVD 

POR, BOD, LVD POR, BOD 

Supported kit CY8CKIT-

049 
prototypin

g kit  

CY8CKIT-041 

pioneer kit  

CY8CKIT-

149 
prototy ping 

kit  

-- CY8CKIT-147 

prototyping 

kit  

CY8CKIT-044 

pioneer kit  

CY8CKIT-042 

BLE pioneer 

kit  

CY8CKIT-041S-

MAX pioneer 

kit  

http://www.cypress.com/?rID=92146&source=an79953
http://www.cypress.com/?rID=92146&source=an79953
http://www.cypress.com/?rID=92146&source=an79953
http://www.cypress.com/?rID=92146&source=an79953
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-041-41xx-psoc-4100s-capsense-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-041-41xx-psoc-4100s-capsense-pioneer-kit
http://www.cypress.com/cy8ckit-149
http://www.cypress.com/cy8ckit-149
http://www.cypress.com/cy8ckit-149
http://www.cypress.com/cy8ckit-149
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-147-psoc-4100ps-prototyping-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-147-psoc-4100ps-prototyping-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-147-psoc-4100ps-prototyping-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-044-psoc-4-m-series-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-044-psoc-4-m-series-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/psoc-4100s-max-pioneer-kit-cy8ckit-041s-max
https://www.cypress.com/documentation/development-kitsboards/psoc-4100s-max-pioneer-kit-cy8ckit-041s-max
https://www.cypress.com/documentation/development-kitsboards/psoc-4100s-max-pioneer-kit-cy8ckit-041s-max
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Features 03I#Ԋ 4100 03I#Ԋ 4100S 03I#Ԋ 4100S 

Plus 

03I#Ԋ 4100S 

Plus 256K 

03I#Ԋ 4100PS 03I#Ԋ 4100M 03I#Ԋ 4100 BL4 03I#Ԋ 4100S 

Max 

Supported IDE 03I#Ԋ 

Creator 

03I#Ԋ #L?;NIL, 

ModusToolbox

Ԋ 

03I#Ԋ 

Creator, 
ModusToolb

oxԊ 

03I#Ԋ 

Creator, 
ModusToolb

IRԊ 

PSI#Ԋ 

Creator 

03I#Ԋ 

Creator 

03I#Ԋ #L?;NIL ModusToolbox

Ԋ 

 

https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/modustoolbox-software-environment
https://www.cypress.com/products/modustoolbox-software-environment
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Table 5 03I#Ԋ 4200 family features 

Features 03I#Ԋ 4200 03I#Ԋ 4200DS 03I#Ԋ 4200M 03I#Ԋ 4200L 03I#Ԋ 4200 

BL6 

CM0 CPU 48 MHz 

Cortex®-M0 

48 MHz 

Cortex®-M0 

48 MHz 

Cortex®-M0 

48 MHz 

Cortex®-M0 

48 MHz 

Cortex®-M0 

DMA None 8 channels 8 channels 32 channels None 

Flash memory 32 KB 64 KB 128 KB 256 KB 256 KB 

SRAM 4 KB 8 KB 16 KB 32 KB 32 KB 

GPIOs 36 21 55 96  36 

CAPSENSEԊ 1 channel, 35 

sensors 

None 2 channels, 

54 sensors 

2 channels, 

94 sensors 

1 channel, 35 

sensors 

ADC (12-bit, 1-MSPS SAR 

ADC with sequencer) 

1 None 1 1 1 

Opamps (programmable)  2 None 2 4 2 

Comparators (low power 

with wakeup feature) 

2 2 2 2 2 

IDACs7 One 7-bits 

and one 8-bit 
None Two 7-bits 

and two 8-

bits 

Two 7-bits 
and two 8-

bits 

One 7-bit 

and one 8-bit 

Programmable logic blocks 

(UDBs) 

4 4 4 8 4 

Smart I/O ports None 1 None None None 

Power supply range 1.71 V to 

5.5 V 

1.71 V to 5.5 V 1.71 V to 5.5 V 1.71 V to 

5.5 V 

1.71 V to 

5.5 V 

Low-power 

modes 

Deep Sleep 1.3 µA 2 µA 1.3 µA 1.3 µA 1.5 µA 

Hibernate 150 nA NA 150 nA 150 nA 150 nA 

Stop 20 nA NA 20 nA 20 nA 20 nA 

Segment LCD drive 4 COM None 4 COM 8 COM 4 COM 

SCBs with programmable 

I2C, SPI, or UART 

2 3 4 4 2 

TCPWM 4 4 8 8 4 

CAN None None 2 2 None 

BLE None None None None 4.1/4.2 

USB Full Speed Device 

Controller (USB) 

None None None Yes None 

Clocks  IMO 3 MHz to  

48 MHz 

3 MHz to  

48 MHz 

3 MHz to  

48 MHz 

3 MHz to  

48 MHz 

3 MHz to  

48 MHz 

ILO 32 kHz 40 kHz 32 kHz 32 kHz 32 kHz 

WCO None None 32 kHz 32 kHz 32 kHz 

                                                                    
6 See AN91267 for A?NNCHA MN;LN?> QCNB 03I#Ԋ 4 Bluetooth® LE family devices. 

7 IDACs are available only when CAPS%.3%Ԋ is not in use. See the respective PSoCԊ 4 architecture TRM for more details. 

https://www.cypress.com/documentation/application-notes/an91267-getting-started-psoc-4-ble
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Features 03I#Ԋ 4200 03I#Ԋ 4200DS 03I#Ԋ 4200M 03I#Ԋ 4200L 03I#Ԋ 4200 

BL6 

External 

crystal 
oscillator 

(ECO) 

None None 4 MHz to  

33 MHz 

None None 

Power supply monitoring POR, BOD, 

LVD 

POR, BOD POR, BOD, 

LVD 

POR, BOD, 

LVD 

POR, BOD, 

LVD 

Supported kit CY8CKIT-
042 pioneer 

kit   

CY8CKIT-146 
prototyping 

kit  

CY8CKIT-044 

pioneer kit  

CY8CKIT-
046 pioneer 

kit  

CY8CKIT-
042 

Bluetooth® 

LE pioneer 

kit  

Supported IDE 03I#Ԋ 

Creator 

03I#Ԋ 

Creator 

03I#Ԋ 

Creator 

03I#Ԋ 

Creator 

03I#Ԋ 

Creator 

Table 6 03I#Ԋ 4500 and 03I#Ԋ 4700 family features 

Features 03I#Ԋ 4500S 03I#Ԋ 4700S 

CM0+ CPU 48 MHz Cortex®-M0+ 48 MHz Cortex®-M0+ 

DMA 8 channels None 

Flash memory 256 KB 32 KB 

SRAM 32 KB 4 KB 

GPIOs 53 36 

CAPSENSEԊ 1 channel, 52 sensors 1 channel, 35 sensors 

MagSense None 1 channel 

ADC Two 12-bits, 1-MSPS SAR ADCs 

with sequencer 

10-bit, 16.8-ksps Single slope ADC 

Opamps (programmable)  4 None 

Comparators (low power with 

wakeup feature) 

2 2 

IDACs8 Two 7-bits Two 7-bits 

Smart I/O ports 2 2 

Power supply range 1.71 V to 5.5 V 1.71 V to 5.5 V 

Low-power 

modes 

Deep Sleep 1.3 µA 2.5 µA 

Hibernate 150 nA NA 

Stop 20 nA NA 

Segment LCD drive 4 COM 8 COM 

SCBs with programmable I2C, SPI, or 

UART 

5 2 

TCPWM 8 5 

Motor Control Acceleration (MCA) 2 None 

                                                                    
8 IDACs are available only when CAPS%.3%Ԋ is not in use. See the respective PSoCԊ 4 architecture TRM for more details. 

http://www.cypress.com/CY8CKIT-042
http://www.cypress.com/CY8CKIT-042
http://www.cypress.com/CY8CKIT-042
https://www.cypress.com/documentation/development-kitsboards/psoc-4-cy8ckit-146-4xxx-prototyping-kits
https://www.cypress.com/documentation/development-kitsboards/psoc-4-cy8ckit-146-4xxx-prototyping-kits
https://www.cypress.com/documentation/development-kitsboards/psoc-4-cy8ckit-146-4xxx-prototyping-kits
http://www.cypress.com/CY8CKIT-044
http://www.cypress.com/CY8CKIT-044
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-046-psoc-4-l-series-pioneer-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-046-psoc-4-l-series-pioneer-kit
http://www.cypress.com/documentation/development-kitsboards/cy8ckit-046-psoc-4-l-series-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-042-ble-bluetooth-low-energy-ble-pioneer-kit
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
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Features 03I#Ԋ 4500S 03I#Ԋ 4700S 

Clocks  IMO 24 MHz to 48 MHz 24 MHz to 48 MHz 

ILO 40 kHz 40 kHz 

WCO 32 kHz 32 kHz 

ECO 4 MHz to 33 MHz None 

Power supply monitoring POR, BOD POR, BOD 

Supported kit CY8CKIT-045S pioneer kit  CY8CKIT-148 evaluation kit  

Supported IDE 03I#Ԋ #L?;NIL 03I#Ԋ #L?;NIL 

https://www.cypress.com/documentation/development-kitsboards/psoc-4500s-pioneer-kit-cy8ckit-045s
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-148-psoc-4700s-inductive-sensing-evaluation-kit
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
https://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
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4 03I#Ԋ CM GIL? NB;H ;H -#5 

Figure 10 shows that a typical MCU contains a CPU (such as 8051 or an Arm® Cortex®) with a set of peripheral 
functions such as ADCs, DACs, UARTs, SPIs, and general I/O, ;FF FCHE?> NI NB? #05ӒM L?ACMN?L CHN?L@;=?ӆ Within the 
MCU, the CPU CM NB? ӓB?;LNӔ I@ NB? >?PC=? ӝ the CPU manages everything from setup to data movement to 

timing. Without the CPU, the MCU cannot function. 

Figure 11 shows that 03I#Ԋ is quite different. With 03I#Ԋ, the CPU, analog, digital, and I/O are equally 
important resources in a programmable system. )N CM NB? MSMN?GɇM CHN?L=IHH?=N ;H> JLIAL;GG;<CFCNS NB;N CM NB? 

heart of 03I#ɫ ɒ not the CPU. The peripheral analog and digital are interconnected with a highly configurable 
matrix of signal and data bus meshing that allows you to create custom designs that meet your application 
requirements. You can program 03I#ɫ to emulate an MCU, but you cannot program an MCU to emulate PSoCɫ. 
 

 

Figure 10 Block diagram of a typical MCU 
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Figure 11 03I#Ԋ block diagram 

A typical MCU requires CPU firmware to process state machines, use a timer for timing, and drive an output pin. 
Thus, the functional path is almost always through the CPU. However, with 03I#Ԋ, asynchronous parallel 
processing is possible. You can configure a 03I#Ԋ to have elements that operate independently from the CPU. 

The projects included with this application note demonstrate this concept. The 03I#Ԋ is configured to make an 
LED blink without writing any code for the CPU. 
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4.1 4B? =IH=?JN I@ 03I#Ԋ #L?;NIL #IGJIH?HNM 

One other important thing about 03I#Ԋ is the availability of 03I#Ԋ #L?;NIL IDE. In 03I#Ԋ #L?;NIL, different 
03I#Ԋ resources are organized as graphical elements called Components, which can be dragged and dropped 

onto a schematic to quickly build designs. Every peripheral in 03I#Ԋ is available as a pre-validated 03I#Ԋ 
Creator Component ӝ PWM Component, ADC Component, DAC Component, CAPSENSEԊ Component, UART 
Component and so on. The availability of pre-validated Components in the 03I#Ԋ #L?;NIL significantly reduces 
the development time. It also allows you to quickly make changes in the design using graphical options. 

For example, configuring a PWM to blink an LED in a typical microcontroller involves the following: 

1. Locate the registers corresponding to the PWM block. 

2. Calculate the values to be written to the PWM registers based on the required PWM period and duty cycle. 

3. Write many lines of code to configure the PWM registers, set the pin drive mode, and to connect the PWM 
output to the pin. Many MCUs do not offer alternate pins to connect to the internal blocks. 

To implement the same functionality in 03I#Ԋ is a trivial exercise, as you will find out later in this application 
note. Later, if you need to reconfigure the same PWM block to a Timer, you do not need anything more than a 
few mouse clicks in 03I#Ԋ #L?;NILӆ 

The 03I#Ԋ also has programmable digital blocks known as Universal Digital Blocks (UDBs). 03I#Ԋ #L?;NIL also 
provides several Components made of UDBs such as UART, SPI, I2S, Timer, PWM, Counter, Digital Gates (AND, 

OR, NOT, XOR, and so on), and many more. You can even create your own custom state machines and digital 
logic using the UDBs in 03I#Ԋ #L?;NIL. The method to create your own custom 03I#Ԋ #L?;NIL Components is 
provided in the PSoCԊ Creator Component author guide.  

 

 

http://www.cypress.com/documentation/component-datasheets/psoc-creator-component-author-guide
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5 -S @CLMN 03I#Ԋ Ҕ >?MCAH OMCHA -I>OM4IIF<IRԊ 

This section: 

¶ Demonstrates how 03I#Ԋ can be programmed to do more than a traditional MCU.  

¶ Shows how to build a simple 03I#Ԋ application and program it into a development kit. 

¶ Provides detailed steps to use Eclipse IDE for -I>OM4IIF<IRԊ. 

However, -I>OM4IIF<IRԊ software is IDE-neutral. The steps in this section use the Eclipse IDE for 

-I>OM4IIF<IRԊ to launch the Project Creator. The resulting project is automatically imported into the IDE.  

Note that you can use Project Creator, Library Manager, and any Configurator as stand-alone tools on Linux, 

macOS, or Windows. These tools create or modify files in your application folder. From the command line, you 

can then export that application to the supported third-party IDEs, like VS Code, IAR Embedded Workbench, or 

Keil mVision. It is not mandatory to use Eclipse IDE. For more details, see Exporting to IDEs in the 
-I>OM4IIF<IRԊ user guide. 

5.1 "?@IL? SIO <?ACH 

5.1.1 (;P? SIO CHMN;FF?> -I>OM4IIF<IRԊӍ 

Download and install -I>OM4IIF<IRԊ from the -I>OM4IIF<IRԊ home page. After installing the software, see 
the Quick Start Guide and User Guide in -I>OM4IIF<IRԊ IDE to get an overview of the software. 

5.1.2 $I SIO B;P? ; >?P?FIJG?HN ECN IL JLININSJCHA ECNӍ 

Testing this design requires one of the kits listed in Table 7, which has an integrated programmer.  

Table 7 List of 03I#Ԋ 4 pioneer kits , prototyping kits,  and supported devices 

Kit name Kit type Supported device family  Part number 

CY8CKIT-145 Prototyping kit 03I#Ԋ 4000S CY8C4045AZI-S413 

CY8CKIT-041-41XX Pioneer kit 03I#Ԋ 4100S CY8C4146AZI-S433 

CY8CKIT-149 Prototyping kit 03I#Ԋ 4100S Plus CY8C4147AZI-S475 

CY8CKIT-041S-Max Pioneer kit 03I#Ԋ 4100S Max CY8C4149AZI-S598 

5.2 5MCHA NB?M? CHMNLO=NCIHM 

These instructions are grouped into several sections. Each section explains a phase of the application 

development workflow. The major sections are: 

¶ Part 1: Creating a new application  

¶ Part 2: Viewing and modifying the design 

¶ Part 3: Writing firmware  

¶ Part 4: Building the application  

¶ Part 5: Programming the device 

¶ Part 6: Testing your design 
 

This design is developed for the kits listed in Table 7. You can test this example by selecting the appropriate kit 

while creating the application. 

https://www.cypress.com/products/modustoolbox
https://www.cypress.com/ModusToolboxUserGuide
https://www.cypress.com/products/modustoolbox-software-environment
http://www.cypress.com/cy8ckit-145
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-041-41xx-psoc-4100s-capsense-pioneer-kit
http://www.cypress.com/cy8ckit-149
https://www.cypress.com/documentation/development-kitsboards/psoc-4100s-max-pioneer-kit-cy8ckit-041s-max
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5.3 !<ION NB? >?MCAH 

This design uses the CM0+ CPU of 03I#Ԋ 4 to execute two tasks: UART communication and LED control. The 
#-ҐỬ #05 OM?M NB? 5!24 NI JLCHN ӓ(?FFI 7ILF>Ӕ G?MM;A? NI NB? M?LC;F JILN MNL?;G ;H> MN;Lts blinking the user 

LED on the kit. 

5.4 0;LN ґӈ #L?;NCHA ; H?Q ;JJFC=;NCIH 

This section provides the step-by-MN?J JLI=?MM NI =L?;N? ; H?Q ;JJFC=;NCIHӆ 4B? ӑEmpty PSoC4 AppӒ starter 
application is used to guide you through the design development stages and programming. 

If you are familiar with developing projects with -I>OM4IIF<IRԊӇ SIO =;H OM? NB? ӑHello WorldӒ MN;LN?L 
application directly; see Code example for details. This starter application is a complete design, with the 

firmware written for the supported kits. You can go through the instructions and observe how the steps are 
implemented in the code example.  

Even if you start from the scratch and follow the instructions in this application note, you can use the code 
example as a reference.  

Launch -I>OM4IIF<IRԊ to get started. Note that -I>OM4IIF<IRԊ will need access to the internet to 
successfully clone the starter application onto your machine. 

5.4.1 3?F?=N ; H?Q QILEMJ;=? 

When launched, -I>OM4IIF<IRԊ displays a dialog, where you can choose a directory for the workspace. The 
workspace directory is used to store workspace preferences and development artifacts. Click Browse and 
choose an existing empty directory, alternatively you can type a directory name along with the complete path, 

and -I>OM4IIF<IRԊ will create the directory. 
 

 

Figure 12 Selecting workspace directory  

5.4.2 #L?;N? ; H?Q -I>OM4IIF<IRԊ ;JJFC=;NCIH 

a) Click New Application in the Start  group of the Quick Panel. 

b) Alternatively, choose File > New > ModusToolbox Application. 

The -I>OM4IIF<IRԊ IDE application window appears. 
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Figure 13 Create a new ModusToolboxԊ IDE application  

5.4.3 3?F?=N ; N;LA?N 03I#Ԋ Ҕ >?P?FIJG?HN ECN 

-I>OM4IIF<IRԊ speeds up the development process by providing BSPs that set various workspace/project 

options for the development kit specified in the new application dialog. 

a) In the Choose Board Support Package (BSP) dialog, choose the Kit Name, for example, CY8CKIT-041S-MAX. 

b) Click Next. 
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Figure 14 Choose target hardware 

c) In the Select Application  dialog, select the Empty PSoC4 App template application.  

d) In the New Application Name field, type a name for the application, such as Hello_World. You can also 

retain the default name. 

e) Click Create. -I>OM4IIF<IRԊ will create the application project. 
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Figure 15 Choosing starter application  

You have successfully created a new -I>OM4IIF<IRԊ application for a 03I#Ԋ 4.  

The BSP uses the device listed in Table 7 based on the selected kit. 

If you are using custom hardware based on 03I#Ԋ 4, or a different 03I#Ԋ 4 part number, see the 
ModusTool<IRԊ user guide. The guide is also available in the ide_2.2>docs folder of the -I>OM4IIF<IRԊ 

installation directory. 

5.5 0;LN Ғӈ 6C?QCHA ;H> GI>C@SCHA NB? >?MCAH 

5.5.1 0LID?=N MNLO=NOL? 

Figure 16 shows the -I>OM4IIF<IRԊ project explorer displaying the structure of the application project. 

In the -I>OM4IIF<IRԊ IDE, a 03I#Ԋ 4 application consists of a project to develop code for the CM0+ CPU. 

a) The project folder consists of various subfolders, each denoting a specific aspect of the project. 

b) The build folder contains all artifacts resulting from the make build of the project. The output files are 
organized by target BSPs. 

c) The libs folder has libraries that are local to the application. By default, the BSP for the created application 

is local and available in this folder. This allows you to change the BSP for a given application without 

worrying that the changes will propagate to other applications. 






























































