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There are several ways to reduce the amount of flash
(ROM) used in a PSoC Designer project. This can
sometimes allow you to use a smaller PSoC device, which
reduces cost.
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The ImageCraft compiler Standard version is included with
PSoC Designer. You can also buy the Pro version, which
offers more optimization, on the ImageCraft website. The
code snippets included in this application note can be
used with both compilers. The examples shown were
compiled with the Standard version; the additional
optimizations that can be obtained using the Pro version
are also covered.
To use the techniques explained in this document, you
should know how to develop and build PSoC Designer
projects and have a basic knowledge of C programming.
Refer to AN75320 to get started with PSoC 1.
While developing a PSoC Designer project, if you want to
find out how much ROM space it is using, look at the
Build tab in the Output status window, as shown in Figure
1. The code space used in this example is 543 bytes.
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Figure 1. PSoC Designer Build Message Showing ROM
and RAM Usage

Figure 3. Relocatable Start Code Address Selection

The following sections discuss project-level optimization
settings, followed by some coding guidelines.

Project-Level Optimization
Several PSoC Designer code optimization settings are
available at Project > Settings.

The address you place in the text box is based on the size
of the boot code, which you can find in the map file (.mp),
as shown in Figure 4.
Figure 4. Map File in PSoC Designer

Setting 1: Relocatable Code Start Address
When a PSoC Designer project is built, the ImageCraft
compiler converts the C files into assembly files. The
assembler then converts them into relocatable object files.
Finally, the linker combines the relocatable object files to
produce the executable .hex file.
In addition to your code, the .hex file includes autogenerated initialization code (boot code). This is followed
by a set of NOP instructions that act to reserve some flash
bytes for possible expansion of boot code. See Figure 2.
You can save flash by forcing your code to be located
immediately after the boot code.
Figure 2. Flash Map for PSoC Designer Project
Start
0x0000

BOOT
End
NOP
NOP

The map file shows the start and end addresses of
different areas of code, as shown in Figure 5. The boot
code is in area “TOP,” and your code is in area “lit.” You
can set the Relocatable code start address in Figure 3
to the end address of the “TOP” area to use the flash
space most efficiently. For example, the default setting is
0x190 (start of “lit” area). If you change it to 0x151 (end of
“TOP” area), you can gain 63 (0x190 – 0x151 = 0x3F)
more bytes in ROM.

Start

PROGRAM
CODE
End

PSoC Designer lets you specify the start address of your
portion of the code by choosing Project > Settings. In the
window that pops up, select “Linker,” as shown in Figure
3.
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Figure 7. Configuration Initialization Selection

Figure 5. “lit” and “TOP” Area in .mp File

Figure 8. Code Difference Between Loop and Direct Write

If the relocatable code start address is set to a value less
than the end of “TOP,” an error message is displayed. For
example, if the value is set to 0x150 and the boot code
ends at 0x151, then an error will be displayed, as Figure 6
shows.
Figure 6. Error When Relocatable Code Address Is Less
Than Boot Code Size

Setting 2: Configuration Initialization
Another option for code optimization is controlling how
PSoC registers are initialized at startup. Register values
can be set using two methods: Loop or Direct write, as
shown in Figure 7. This option is available by choosing
Project > Settings and then selecting “Chip Editor” in the
window that appears.

In Figure 8 you can see that for each register write, the
Direct write method uses one more byte (MOV reg[expr],
expr = 3 bytes) than the Loop method uses (addr, value =
2 bytes). But the Loop method also includes the table
read function, which uses 94 bytes. Therefore, if there are
more than 94 registers to be loaded (this is usually the
case in all but the simplest PSoC Designer projects), the
Loop selection uses less flash. The number of registers
initialized using the configuration table shown in Figure 8
depends on the number of resources (user modules) used
in the design. The greater the number, the more registers
will be initialized. So, if the design includes many user
modules to save flash and you are willing to sacrifice
some time at startup, use the Loop method. But if you do
not have many user modules in the design or desire a
faster device startup, select the Direct write method.

With the Loop method, a table with register addresses
and values is created, and a function writes the values in
the table to the respective addresses. With the Direct
write method, register writes are done directly, with one
MOV instruction for each register.
The selected method is coded in the auto-generated file
PSOCConfigTBL.asm. The code for the two methods is
shown in Figure 8.
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Setting 3: Sublimation and Condensation
Sublimation
and
condensation
are
compression
techniques provided by the ImageCraft Standard version.
These can be set by choosing Project > Settings and
then selecting “Compiler” in the pop-up window, as shown
in Figure 9.

If all functions in all user module APIs are used in a
project, then a “no dead symbol found” message is
displayed, as Figure 12 shows.
Figure 12. Sublimation with “no dead symbol found”
Message

Figure 9. Sublimation and Condensation Selection

Sublimation
When you select the Sublimation option, the compiler
deletes the unused functions in the user module APIs
(interface code), which saves space.
For example, you can place a PGA and a PWM user
module in a project and call only the “Start” function for
both user modules. As shown in Figure 10 and Figure 11,
you can save 142 bytes of flash by eliminating the other
unused functions in those user module APIs.
Figure 10. ROM Usage Without Sublimation

Condensation
When you select the Condensation option, a function is
formed for segments of code that are repeated in a
project, and each instance of that code is replaced with a
function call. In the simple example shown in Code 1, the
same code is repeated three times in various locations of
the project. When condensation is enabled, a single
instance of the code is converted into a function, and
wherever the instance occurs, it is replaced by a function
call to that function, as shown in Figure 13. All such
created functions/procedures are placed at the end of the
code and below the label “<created procedures>,” as
shown in Figure 13. As you can see, the created
procedure for Code 1 starts at the label “<created
procedures>”; therefore, wherever the instance is used, it
is replaced with a call to the label “<created procedures>.”
The functions at location “0520” and “052B” below
“<created procedures>” are other duplicate codes in the
project that are converted to callable functions.
Code 1
/* Instance one */
shadowRegs[PORT_2] |= 0x01;
PRT2DR = shadowRegs[PORT_2];

Figure 11. ROM Usage with Sublimation

/* Instance two */
shadowRegs[PORT_2] |= 0x01;
PRT2DR = shadowRegs[PORT_2];
/* Instance three */
shadowRegs[PORT_2] |= 0x01;
PRT2DR = shadowRegs[PORT_2];

www.cypress.com
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Figure 14. “text” Area in .mp File

Figure 13. Condensation for Code 1 in .lst File

Figure 15. Condensation When “text” Area Is Less Than
256 Bytes

Figure 16. Condensation When No Duplicate Code
Is Found

With the Condensation option, you can save a
considerable amount of ROM space, as Figure 17 shows.
To apply condensation to the code, the code in the “text”
area (located in the .mp file, as shown in Figure 14) should
be more than 256 bytes. If the “text” area is less than 256
bytes, the message “program code in ‘text’ area too small
for worthwhile code compression” is displayed (Figure 15).
If no instances of duplicate code are found for
condensation, the message “no worthwhile duplicate
found” is displayed (Figure 16).

Figure 17. Condensation on Code 1 (Code 1 is part of a
bigger project whose text area is more than 256 bytes.)

Note The information displayed in Figure 15, Figure 16,
and Figure 17 is for different codes to emulate different
scenarios during code condensation.
Note Though condensation reduces ROM space
considerably, it replaces duplicate codes with function
calls, thus adding delay to the program execution.
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Setting 4: Treat const as ROM Versus Treat
const as RAM
This option (see Figure 9) reduces RAM use by leaving
constants in flash (ROM); it does not significantly reduce
flash use. Use the Treat const as ROM option for most
projects. The Treat const as RAM option is mainly used
for backward compatibility with previous versions of the
ImageCraft compiler.

ImageCraft Pro Compiler Options
In addition to the optimization options that the ImageCraft
Standard compiler offers, ImageCraft Pro includes a few
other options, as Figure 18 shows.
Figure 18. ImageCraft Pro Compiler Options

Tips and Guidelines
Several coding techniques can make your firmware more
efficient. These methods work with PSoC Designer
projects and PSoC 1, and they can be applied to similar
8-bit processors, IDEs, and compilers, such as PSoC 3
and PSoC Creator™.

Guideline 1: Avoiding Function Calls in
Interrupt Service Routines
When compiling C code for an interrupt service routine
(ISR), the ImageCraft compiler pushes onto the stack all of
the virtual registers (registers used by the compiler to
store temporary values) that will be used by the ISR. If the
ISR code includes a function call, the compiler cannot tell
which registers will be modified by the called function. The
ImageCraft C compiler uses up to 15 virtual registers to
store temporary data on the stack.
In PSoC chips with RAM greater than 256 bytes, 4 page
pointers are also stored and restored along with the
15 virtual registers. The example in Code 2 does not
require any virtual registers to be saved by the compiler
(Figure 19). The same functionality, when implemented
using a function call, as shown in Code 3, uses an
additional 15 virtual registers, as shown in Figure 20. Each
register requires the following additional overhead code:
MOV [2 bytes] + PUSH [1 byte] + POP [1 byte] + MOV
[2 bytes] for a total of 6 bytes per register. Code 3 uses an
additional 90 bytes and involves a delayed or longer ISR
execution because of the many MOV/PUSH instructions.
Code 2

The Sublimation and Condensation options offered in
ImageCraft Standard are the same as the Eliminate
unused user module APIs and Enable code
compression options in ImageCraft Pro respectively.
ImageCraft Pro also offers an option to Eliminate user
unused functions, which is very useful when your project
is huge and user unused functions are difficult to spot. A
simple scenario would be a project revision; unused APIs
tend to remain in the code, consuming ROM space. When
this option is enabled, the compiler will make sure that
unused APIs are not placed in the code and the ROM
space is available for other uses.

BYTE bVar1;
#pragma interrupt_handler
SleepTimerHandler;
void SleepTimerHandler(void)
{
bVar1 = 1;
}

One more option available in ImageCraft Pro is Optimize
for speed. When this option is enabled, the code is
compiled for faster execution. ROM usage may increase
or decrease, depending on where optimization has been
applied. For instance, smaller loops in code are expanded
to sequential instructions, increasing ROM usage.
Redundant assignments or move operations are removed,
reducing ROM usage.

www.cypress.com
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Figure 19. Code Generated for ISR Without Function Call
(Code 2)

Figure 20. Code Generated for ISR with Function Call
(Code 3)

Code 3
BYTE bVar1;
void TestFunc()
{
bVar1 = 1;
}
#pragma interrupt_handler
SleepTimerHandler;
void SleepTimerHandler(void)
{
TestFunc();
}

www.cypress.com
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Guideline 2: Limiting Math Functions

Figure 21. ROM Usage for Code 4

In many cases, a C compiler implements simple math
calculations with inline assembler code. However, for
complex calculations, the compiler may instead add one or
more math library functions to your code. This may not be
immediately obvious. Depending on the operation and
variable type, even a simple C operator such as “+,” “-,”
“*,” “/,” “%,” “>,” and “<” may require a library function to
implement.
Although they are very efficient and useful, library
functions can occupy a lot of code space, which you may
not anticipate. In many cases, you can avoid overusing
library functions by carefully managing the data types and
operations in your code.
When a program uses integer arithmetic, math library
functions are added, depending on the size and type of
the variables used (8-, 16- or 32-bit; signed or unsigned).
Details about the byte usage of different functions are
located in the Libraries User Guide at Help >
Documentation > Designer Specific Documents.

Code 5
unsigned int iTest1, iTest2;
void main(void)
{
iTest1 = (iTest2 << 1) + iTest2;
}
Figure 22. ROM Usage for Code 5

The base arithmetic functions (that is, functions that are
always used) include integer addition, subtraction, and
shift. When other operations, such as multiplication, are
used, code for those operations is also included.
S h i f t a n d Ad d I n s t e a d o f M u l t i p l y o r D i vi d e
Tricks like bit shift and add, instead of a multiply or divide
for unsigned integers, save code space. In unsigned
integers, a single bitwise shift right is equivalent to division
by 2, and shift left is equivalent to multiplication by 2. By
using shift and add, as shown in the Code 5, you can
avoid including multiplication and division library functions.
In the following two snippets of code, which give the same
result, the Code 4 implementation uses 55 bytes more
than Code 5, as shown in Figure 21 and Figure 22. This
difference is due to the addition of a “__mul16” function
to the code.
Code 4
unsigned int iTest1, iTest2;
void main(void)
{
iTest1 = iTest2 *3;
}

A vo i d P o w er F u n c t i o n s
Power functions also add math library functions. Power
operations can be reduced to multiply or divide operations,
for example, 42 = 4 × 4. As explained in the previous
section, a multiply or divide can then be implemented
using shift and add. Thus, you can save code space in
programs that have limited power functions by reducing
the implementation to shift and add where possible.
A vo i d F l o a t i n g - P o i n t M a t h
Floating-point math with 8-bit processors almost always
requires library functions. In addition to the function for the
basic math operation, utility functions for rounding,
normalization, and checking special conditions may also
be added to the code. Refer to the Arithmetic Libraries
User Guide for more information about floating-point
libraries. To give you an estimate, the code space required
for the floating-point functions follows (also available in the
Arithmetic Libraries User Guide).
Comparison (*_fpcmp) = 109–125 bytes
Addition (*_fpadd) = 461–478 bytes
Subtraction (*_fpsub) = 468–485 bytes
Multiplication (*_fpmul) = 406–558 bytes
Division (*_fpdiv) = 432–449 bytes

www.cypress.com
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The floating-point math functions use the integer math
libraries as the base. This means that the integer math
libraries are also required when using floating-point math.
Instead of using floating-point math, the variables can be
scaled to use integer math directly in cases where the
range of the variable is known.

Figure 24. ROM Usage for Code 7

For example, in the following two pieces of code, the
range of the variable is known to be two digits after the
decimal. Thus, if you multiply all of the floating-point
numbers by 100, you can use integer math instead of
floating-point math. In the example, the integer-math
method in Code 7 uses 761 bytes less than the floatingpoint equivalent in Code 6, as shown in Figure 23 and
Figure 24.
Code 6
int iTest2, iTest3;
float fTest1;
void main(void)
{
fTest1 = iTest2 * 2.42;
if(fTest1 > 7.5)
{
iTest3 = 2;
}
else
{
iTest3 = 1;
}
}
Figure 23. ROM Usage for Code 6

Use a Lookup Table Instead of Calculation
Sometimes it may be more efficient to use a lookup table
(LUT) instead of doing calculations. There are multiple
tradeoffs, such as speed, accuracy, and code space. The
choice is based on the type of application.
For example, the project given in AN2017 – PSoC 1
Temperature Measurement with Thermistor offers an
option for the floating-point and LUT method
implementation. The use of a LUT in place of floating-point
math in this project saves 4187 bytes of memory (3779
bytes for the lookup table and 7966 bytes for the floatingpoint equation), but accuracy is the tradeoff.
Maintain Consistency in Data Type
When choosing a data type for a variable, choose the
smallest data type required for the function. For example,
choose BYTE instead of int if the maximum value of the
variable is not greater than 256. Similarly, choose
unsigned variables instead of signed variables, as
applicable. For example, consider Code 4 if the variables
“iTest1” and “iTest2” do not exceed 255 in the program.
Then you can declare them as “unsigned char” instead of
“unsigned int,” as shown in Code 8. The ROM usage is
shown in Figure 25. Code 8 consumes 84 bytes less than
Code 4.
Code 8

Code 7
int iTest1, iTest2, iTest3;
void main(void)
{
iTest1 = iTest2 * 242;
if(iTest1 > 750)
{
iTest3 = 2;
}
else
{
iTest3 = 1;
}
}

www.cypress.com

unsigned char cTest1, cTest2;
void main(void)
{
cTest1 = cTest2 *3;
}
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Code 9

Figure 25. ROM Usage for Code 8

typedef struct
{
int iData;
BYTE bData;
}sData;
typedef struct
{
sData myArray[10];
}sArray;
sArray myTest;
sData* myPtr;
When you know the positive and negative range of a
signed variable, you can offset the variable to bring it to
positive values and thus use unsigned math functions.
Similarly, if the variable is expected to have a value
between –10 and +10, offset the variable by 10, so that
the code 0 corresponds to –10, and 20 corresponds to
+10.

void main(void)
{
myPtr = myTest.myArray;
myPtr->iData = 100;
}
Figure 26. ROM Usage for Code 9

Maintain consistency in the data type used, because
typecasting is expensive in terms of code space. If you
absolutely need to use typecasting in the program,
typecast the variables to use the same math libraries to
save code space for the math libraries.

Guideline 3: Using Array Indexing Versus
Pointer
In the array-indexing method, ImageCraft directly
accesses each address using the index. No computation
is needed because the address remains constant. In the
case of pointer accessing, each access is based on the
pointer, which is a variable. Thus, the compiler must
perform more computation to get the address.
When the access method is used repeatedly, the
difference in the type of access leads to a significant
variation in memory use.
For example, consider the following two code examples.
Code 9 uses 25 bytes more than Code 10, as shown in
Figure 26 and Figure 27. So a careful observation of the
type of access method used (array indexing versus
pointer) is important for code optimization. There are
numerous variations in the type of access and variable
types. The key is to make sure the address is a constant,
in which case the compiler directly replaces the address.
When the address must be calculated during run time, the
compiler uses more code space. In general, the “->”
operator is expensive in terms of code space.

www.cypress.com

Code 10
typedef struct
{
int iData;
BYTE bData;
}sData;
typedef struct
{
sData myArray[10];
}sArray;
sArray myTest;
sData* myPtr;
void main(void)
{
myTest.myArray[1].iData = 100;
}

Document No. 001-60486 Rev. *E

10

®

PSoC 1 M8C ImageCraft C Code Optimization
nt

Figure 28. ROM Usage for Code 11

Figure 27. ROM Usage for Code 10

Code 12

Guideline 4: Using Switch Statement Versus
If-Else Statement
For case decisions, you can use either a switch statement
or an if-else statement. The difference between the two is
that the switch statement always does a 16-bit
comparison, whereas the if-else statement bases its
comparison on the variable type. In the case of a singlebyte variable (BYTE), the ImageCraft compiler produces
more efficient code using an if-else construct compared to
a switch construct. This is because an 8-bit comparison
needs less code space than a 16-bit comparison.
The switch statement uses 9 additional bytes, plus 5 bytes
for each case. For example, a four-case switch statement
with a default clause, as shown in Code 11, uses (9 + 4 ×
4)
=
25
more
bytes
than
the
equivalent
Code 12, as shown in Figure 28 and Figure 29.
Code 11
BYTE bTest1, bTest2;
void main(void)
{
switch(bTest1)
{
case 4:
{
bTest2 =
break;
}
case 3:
{
bTest2 =
break;
}
case 2:
{
bTest2 =
break;
}
default:
{
bTest2 =
}
}
}

www.cypress.com

BYTE bTest1, bTest2;
void main(void)
{
if(bTest1 == 4)
{
bTest2=1;
}
else if(bTest1 == 3)
{
bTest2 = 2;
}
else if(bTest1 ==2)
{
bTest2 = 3;
}
else
{
bTest2=4;
}
}
Figure 29. ROM Usage for Code 12

1;

2;

3;

When the case decision is for a 2-byte variable (WORD),
the resulting code size is nearly identical for either
implementation.

4;
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Guideline 5: Writing Part of Code in
Assembler

Guideline 6: Manipulating Bits in PSoC 1

Writing a program in assembler avoids compiler
interpretations and allows complete user optimization.
Though writing an entire program in assembler is tedious
and cumbersome, converting only part of the code to
assembly language can optimize the code size and
performance. Consider Code 11 with assignment to the
“bTest2” variable in assembly, as Code 13 shows. Code
13 consumes 12 bytes less than Code 11, as Figure 30
shows.
Code 13
BYTE bTest1, bTest2;
void main(void)
{
switch(bTest1)
{
case 4:
{
asm("MOV
break;
}
case 3:
{
asm("MOV
break;
}
case 2:
{
asm("MOV
break;
}
default:
{
asm("MOV
}
}
}

No data type is defined for “bit” variables in PSoC 1. To
manipulate bit/bits of a variable, a mask can be used with
logical operators or by direct assignment to the variable.
The mask can be a constant based on the manipulation
requirement. Code 14 and Code 15 show how to
manipulate bits in a variable.
Code 14
BYTE bTest1, bTest2, bTest3;
void main(void)
{

/* To set first, sixth and eighth bit
of the variable */
bTest1 = (0xA1);
/* To clear the second and
seventh bits the variable */
bTest2 = bTest2 & (0xBD);

[_bTest2], 0x1");

the

/* To invert the second, fifth and
eighth bits in the variable */
bTest3 = bTest3 ^ (0x92);
[_bTest2], 0x2");

}

[_bTest2], 0x3");

If a variable has more than one bit definition and one or
more bits must be manipulated without affecting other bits
in the variable, then use the logical operators to
manipulate the bits. These operations use XOR, AND, and
OR instructions. The corresponding .asm code for Code
14 is generated in the <projectname>.lst file (Workspace
> Output Files) as follows.

[_bTest2], 0x4");

Figure 30. ROM Usage for Code 13

/* To set first, sixth and eighth bit
of the variable */
bTest1 = bTest1 | (0xA1);
__text_start|_main|_main:
62 D0 00 MOV
REG[0xD0],0x0
2E 03 A1 OR
[bTest1],0xA1
/* To clear the second and the
seventh bits the variable */
bTest2 = bTest2 & (0xBD);
62 D0 00 MOV
REG[0xD0],0x0
26 02 BD AND
[bTest2],0xBD
/* To invert the second, fifth and
eighth bits in the variable */
bTest3 = bTest3 ^ (0x92);
62 D0 00 MOV
REG[0xD0],0x0
51 04
MOV
A,[bTest3]
31 92
XOR
A,0x92
53 04
MOV
[bTest3],A
address: 8F FF
JMP
address

www.cypress.com
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Note The instruction MOV REG[0xD0],0x0 sets the
RAM
page
number
of
the
global
variable
“bTest1/bTest2/bTest3.”
If the size of a variable is a single bit or if all the bits
defined in the variable are being assigned/manipulated
simultaneously, then use direct assignment to manipulate
them, as shown in Code 15. This uses the MOV
instruction, which is one cycle faster than the XOR, AND,
and OR instructions.
Note To find out how many cycles an instruction takes to
execute, refer to the Assembly Language User Guide,
Appendix A5, “Instruction Set Summary,” in PSoC
Designer at Help > Documentation > Compiler and
Programming Documents.

Guideline 7: Calculating C Code Flash
Usage and Execution Time
When code memory usage and program execution time
are a concern, knowing the flash usage of a function or a
piece of code and its execution time can be useful in
manually optimizing the code.
To find out the code size of a function, refer to the
<projectname>.mp file in Workspace > Output Files. The
.mp file provides details on code memory usage by code
areas and the functions/constants defined in the areas. It
also provides details on RAM usage by RAM areas and
the address of global variables defined in those areas, as
shown in Figure 31.
Figure 31. Address and Memory Details in .mp File

Code 15
BYTE bTest1, bTest2;
void main(void)
{

/* To clear the first and the second
bits and set the third bit of a three
bits variable */
bTest1 = 0x04;
/* To invert the variable */
bTest2 = ~ (bTest2);
}
The corresponding .asm code follows:
BYTE bTest1, bTest2;
void main(void)
{
/* To clear the first and the second
bits and set the third bit of a three
bits variable */
bTest1 = 0x04;
__text_start|_main|_main:
62 D0 00 MOV
REG[0xD0],0x0
55 02 04 MOV
[bTest1],0x4
/* To invert the variable */
bTest2 = ~ (bTest2);
62 D0 00 MOV
REG[0xD0],0x0
}
51 03
73
53 03
address:

MOV
A,[bTest2]
CPL
A
MOV
[bTest2],A
8F FF
JMP
address

Note Instruction MOV REG[0xD0],0x0 sets the RAM
page number of the variable “bTest1/bTest2.”

www.cypress.com

Note Refer to the C Language Compiler User Guide,
section 6.9, and the Assembly language User Guide,
section 5.1, for details on the code/RAM areas.
To find out the code size of a function, search for the
function name in the .mp file. If you have not placed the
function in a custom area, by default all the user-defined
functions are placed in the “text” code area (Figure 32).
Figure 32 shows the start addresses of “main,” “function1,”
and “function2” defined in Code 16. To find out the code
size of “main,” subtract the address of the following
function (“function1” in this case) from the address of
“main.” The size of “main” is 55 bytes (0x034E – 0x0317 =
0x0037), “function1” is 9 bytes (0x0357 – 0x034E =
0x0009) and “function2” is 9 bytes (0x0360 – 0x0357 =
0x0009).
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Code 16

while (1)
{
}
address: 8X XX

int bTest;
void main(void)
{
bTest = ++bTest;
}

JMP

address

The JMP instruction takes five CPU cycles for execution. If
the CPU clock is 24 MHz, then the execution of the JMP
instruction takes:

void function1(int a)
{
a++;
return;
}

1

5 × 24 µ𝑠 = 0.208 µ𝑠

At this rate, the CPU executes approximately one (JMP)
instruction per 0.208 µS = (1/0.208) = 4.8 million
instructions per second.

void function2(int b)
{
b--;
return;
}

Example 2:
Consider an example for simple addition as follows.

Figure 32. Flash Calculation Using .mp File

void main(void)
{
BYTE bTest1, bTest2;
while(1)
{
bTest1 = bTest1 + bTest2;
}
}
The corresponding .asm code follows.

To calculate the code execution time, you need to know
the execution time of individual instructions. To find out the
execution time of individual instructions, refer to the
Assembly Language User Guide, Appendix A5,
“Instruction Set Summary,” in PSoC Designer at Help >
Documentation > Compiler and Programming
Documents. The “CPU clock cycles” column of the table
provides the number of CPU clocks required to execute
the instruction. Multiply that value with the CPU clock
period to find out the execution period of an instruction.
The following examples illustrate the calculation of
execution time with different codes.

BYTE bTest1, bTest2;
while(1)
{
bTest1 = bTest1 + bTest2;
address1: 52 01
MOV
A,[X+1]
address2: 05 00
ADD
[X+0],A
}
address3: 8X XX
JMP
address1
The execution of the previous code takes a total
(MOV) + 8 (ADD) + 5 (JMP) = 19 clock cycles. This
average 19/3 = 6.33 cycles per instruction. If the
clock is 24 MHz, then the execution of the entire
takes:

Example 1: Take an empty “while (1)” loop as follows.

19

24,000,000

void main(void)

of 6
is on
CPU
code

𝑠 = 0.792 µ𝑠

At this rate, the CPU executes one instruction per 0.792/3
= 0.264 µS or (1/0.264) = 3.79 million instructions per
second.

{
while (1)
{
}
}
The corresponding .asm code for the empty “while (1)”
loop generated in the <projectname>.lst file follows.

www.cypress.com
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Conclusion

About the Author

These guidelines can help you optimize your code. Some
of them are specific to the ImageCraft compiler, and some
are general. Following these suggestions during and after
firmware development helps optimize the code space. All
the code snippets and snapshots have been tested and
captured for the CY8C28xxx device and ImageCraft
Standard compiler version 7.0.5. The results will be similar
for other PSoC 1 devices as well.

Name:

Archana Yarlagadda

Title:

Applications Engineer

Background:

Applications Engineer at Cypress with
focus on PSoC

Besides following these guidelines, when working with a
smaller flash-size device, a good practice is to watch the
code size increase during project development. Whenever
there is a huge increase in the code space, look at the
map file (Figure 4) to see if any unexpected functions are
being used by the latest part of the code. Knowing the
exact part of the code that causes the flash increase
makes it easier to optimize your code.

Contact:

Masters in Analog VLSI from University
of Tennessee, Knoxville
msur@cypress.com

For further details on compiler and project optimization
options, refer to the ImageCraft C Compiler Guide and the
ImageCraft Assembly Language Guide.
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