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About this document 

Scope and purpose 

This document explains how to set up and use the XMC7000 Evaluation Kit, which mounts the XMC7200D-
E272K8384 device. This document also describes debugging with single-core and multi-core applications in the 

ModusToolbox™ environment. 

Intended audience 

This document is intended for anyone using XMC7000 family XMC7100/7200 series MCUs. 

Associated part family 

XMC7000 family XMC7100/XMC7200 series of  XMC™ Industrial microcontrollers.  

http://www.infineon.com/
https://www.infineon.com/cms/en/product/microcontroller/32-bit-industrial-microcontroller-based-on-arm-cortex-m/
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1 Getting started 

This section explains the hardware setup. Table 1 lists the prerequisites for the setup. 

Table 1 Prerequisites 

Quantity Description Remarks 

1 KIT_XMC72_EVK XMC7200 Evaluation Kit 

1 Micro USB cable For power and communication 

1 PC With USB port 

1 ModusToolbox 3.1 Downloaded from the web 

- Firmware  Pre-installed XMC7000 out-of-the-box (OOB) 

application 
  

1.1 Connection setup 

Connect the USB cable from the PC to the Evaluation Kit. The PC powers the evalution kit via the USB cable  

(5 V). Check if the KitProg3 status LED (D5) and the power LED (D6) are turned ON. 
 

 

Figure 1 Connection between PC and Evaluation Kit 
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1.2 Power up 

When powered ON, the device will start executing the pre-installed out-of-the-box (OOB) firmware, which is 
indicated by the blinking user LEDs (LED1, LED2, and LED3 are controlled by core Arm® Cortex®-M7 (CM7_0)).  

Note: To indicate that the evaluation kit is powered ON and the USB controller is starting in the correct mode, the 
amber-colored status D5 must be permanently ON. But, D5 does not indicate a successful USB driver 
installation.  

 

 

Figure 2 User LEDs of evaluation kit 

1.3 Installing kit driver 

Install the ModusToolbox™ or CYPRESS™ Programmer before using the kit with KitProg3. Any required driver is 
installed by the tools that use KitProg3. There is no separate installer for KitProg3. 

To get the latest version of KitProg3 delivered with the Firmware Loader is available at the GitHub repository. 

The Firmware Loader does not install any drivers, but it can be used to upgrade (or downgrade) the KitProg 
firmware on the kit. See KitProg3 user guide [4] for more details on installation and to upgrade. 

When you plug in the kit, a message is displayed that the drivers are installed depending upon your 
circumstances and the host operating system. KitProg3 enumerates as a root USB Composite Device with 

subordinate CMSIS-DAP, Bridge, and USB-UART interfaces. 

Confirm that the Evaluation Kit is recognized as a KitProg3 device on Windows (open Device Manager, follow 

the menu path View > Devices by container) as shown in Figure 3. This completes the hardware setup. 

https://github.com/Infineon/Firmware-loader
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Figure 3 Viewing KitProg3 driver in Device Manager 

Note: Do not press SW3. Pressing SW3 changes the mode of the USB controller. This is necessary only for upgrading 

the USB driver firmware and other activities. For more details, see the KitProg3 user guide [4]. 

For more information related to the Evaluation Kit, see the KIT_XMC72_EVK XMC7200 evaluation kit guide. 

https://www.infineon.com/dgdl/Infineon-KIT_XMC72_EVK_XMC7200_evaluation_kit_guide-UserManual-v04_00-EN.pdf?fileId=8ac78c8c8412f8d301842e60eada7b73
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2 ModusToolbox™ set up 

This section explains how to launch ModusToolbox™ and create the hello world application and multi-core 
application which is used to demonstrate debug process with the KIT_XMC72_EVK XMC7200 Evaluation Kit. 

2.1 Launch ModusToolbox™ 

See the instructions in the ModusToolbox™ tools package installation Guide to download and install 

ModusToolbox™ software. 

In v3.1.0, the ModusToolbox™ tools package includes a new tool called the Dashboard. The Dashboard provides 
links to various sources of documentation and training materials. It also contains two starting points: create a 

new application and create/edit a BSP.  

See Dashboard User Guide for more information about the dashboard. 

To launch the Dashboard, create a new application for the IDE of your choice, such as VS Code, IAR, Eclipse or 
µVision.  

Note: This document will use Eclipse IDE to demonstrate how to debug single-core and multi-core 
applications. See the ModusToolbox™ tools package User Guide to debug in other IDE. 

On Windows, launch the Dashboard immediately after installing the ModusToolbox™ tools package by leaving 

the check box enabled on the final step of the installation process. 

For all OS, launch the Dashboard by running its executable as applicable for the operating system (for example, 
select it using the Windows Start menu or use the Finder in macOS). By default, the executable is installed here: 

<install_dir>/ModusToolbox/tools_<version>/dashboard/ 

Note: If the software is not installed in the default location, you will need to set an environment variable. 

See the ModusToolbox™ tools package installation Guide for more details. 

On the Dashboard window, in the right pane, in the Target IDE drop-down list, select Eclipse IDE for 

ModusToolbox™, and click Launch Eclipse IDE for ModusToolbox™. 

https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.1_a_Tools_Package_Installation_Guide-GettingStarted-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a14ece234e39
https://www.infineon.com/dgdl/Infineon-ModusToolbox_Dashboard_3.1_User_Guide-UserManual-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a18bb78b4e6c&redirId=248313
https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.1_a_Tools_Package_User_Guide-GettingStarted-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a14ed50b4e45
https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.1_a_Tools_Package_Installation_Guide-GettingStarted-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a14ece234e39
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Figure 4 Open the Dashboard 

When launching the Eclipse IDE, it provides an option to select the workspace location on your machine. This 

location is used by the IDE for creating and storing the files as part of application creation for a particular 
platform. The default workspace location is a folder called "mtw" in your home directory. You may add 

additional folders under the "mtw" folder or to choose any other location for each workspace. 

For more details about Eclipse, see the Eclipse documentation and the Eclipse survival Guide. 

  

https://community.infineon.com/docs/DOC-15617
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2.2 Create an application 

2.2.1 Choose Board Support Package 

To choose Board Support Package, do the following: 

• Click the New Application link in the Eclipse IDE Quick Panel. 

 

Figure 5 New application 

• Select File > New > ModusToolbox™ Application. 

 

Figure 6 New application in the file 

These commands launch the Project Creator tool, which provides several applications for use with different 

development kits, and the kits change over time.  Select KIT_XMC72_EVK Kit. 
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Figure 7  Choose KIT_XMC72_EVK BSP 

For more details to use the tool, see the Project Creator user guide. 

2.2.2 Select application 

On the Choose Board Support Package (BSP) – Project Creator 2.10 window, click Next > to open the Select 

Application page.  

This page lists the various applications available for the selected kit. As you choose an application, a 

description displays on the right. To select multiple applications for the selected BSP enable the check box next 
to the applicable applications. 

 

https://www.infineon.com/dgdl/Infineon-ModusToolbox_Project_Creator_2.10_User_Guide-UserManual-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a18bfd654e84
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Figure 8 Select application 

For this example: 

• Select the check box next to the "Hello World" application and "Multicore Empty APP" application. 

• If desired, type a name for the application under New Application Name, and type a BSP name under New 

BSP Name. Do not use spaces in the application and BSP name. In this case, use the default "Hello_World" 
and "Multicore_Empty_App" as the application name, “APP_KIT_XMC72_EVK” as the BSP name. 

Note: Use the Browse for Application button to select other examples to download from the web or 
received from a colleague. In the Open dialog, select only examples that are supported by the BSP 
chosen for this application. Then, the example will be shown in the dialog with all the other 
applications. See ModosToolbox IDE User Guide for import application/code example details. 

2.2.3 Create application 

Click Create to begin the project creation process. 

 

Figure 9 Create application 

https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.1_Eclipse_IDE_User_Guide-UserManual-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a18b5cc24e4c
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When complete, the Project Creator tool closes automatically. After several moments, the application opens 
with the Hello_World and Multicore_Empty_App in Project Explorer, and the README.md file opens in the file 

viewer. 

 

Figure 10 Application created in IDE 
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3 Download and debug with Evaluation Kit 

There are two types of applications created in the Create an application chapter: 

• Single core application (Hello_World): This application contains the pre-built CM0+ image, and the main 
application function runs on the CM7_0 core. The pre-built CM0P image only starts the CM7 cores and puts 
CM0+ core into Deep Sleep mode.   

For more detail on the pre-built CM0+ image, see the CAT1 Cortex M0+ prebuilt images. 

• Multi-core application (Multicore_Empty_App): This application contains the CM0+ project, CM7_0 project, 

and CM7_1 project.  

CM0+ and CM7 does the normal code execution, but from an architectural point, only CM7 is considered the 
application core (CM7 cores for primary processing and CM0+ core for peripheral and security processing). 

After a reset, the default core is always the CM0+ core. To enable the CM7 core, CM0+ must call 
Cy_SysEnableCM7().  

The following sections show how to debug the single application and multi-core application in the 
ModusToolbox™ IDE: 

3.1 Debugging with single core application 

1. Build the application:  

 

Figure 11 Build the single application 

a) Select the Hello_World project in the Project Explorer window and click on the Build Application 
shortcut under the Hello_World group in the Quick Panel. It selects the Debug build configuration and 
compiles/links all projects that constitute the application. 

https://github.com/Infineon/cat1cm0p
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b) The Console view lists the results of the build operation, shown in Figure 11. 

If the Hello_World project is selected, select the Build Project from the Project menu or the right-click menu, 
as shown in Figure 12 . 

 

Figure 12 Build the single application in Project menu 

If you encounter errors, revisit previous steps to ensure that you accomplished all the required tasks. 

Note: The command line interface (CLI) is used to build the application. See the “Using the command-line” section 
in the ModusToolbox™ User Guide. This document is located in the /ide_<version>/docs/ folder in the 

ModusToolbox™ installation. 

2. Debug the application: 

The XMC7200 Evaluation Kit has a KitProg3 onboard programmer/debugger. It supports Cortex® 

microcontroller software interface standard - Debug Access Port (CMSIS-DAP). See the KitProg3 User Guide [4] 
for more details.  

The ModusToolbox™ software uses the OpenOCD protocol to program and debug applications on XMC7000 
MCU devices. For the ModusToolbox™ software to identify the device on the kit, the kit runs the KitProg3. 

In the Quick Panel, click the Hello_World Debug (KitProg3) link under Launches. 

https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.1_a_Tools_Package_User_Guide-GettingStarted-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a14ed50b4e45
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Figure 13 Launch the single application debug 

If needed, the IDE builds the application, and messages display in the Console. If the build is successful, the IDE 
switches to debug mode automatically, as shown in Figure 15.  

To open the disassembly window, please click Window > Show View > Disassembly. 

 

Figure 14 Show the disassembly window 
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Figure 15 Debug the single application with CM7_0 core in Eclipse IDE 

3. Click the Resume icon or press the F8 to start execution. LED1 should start blinking. 

Note: The function keys in the Debug window: Resume (F8), Step Into (F5), Step Over (F6), Terminate (Ctrl+F2).  

 

 

Figure 16 Blinking LED1 
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3.2 Debugging with multi-core application 

1. Build the multi-core application 

a) In the Project Explorer window, click the Multicore_Empty_App project. 

b) Click on the Build Application shortcut under the Multicore_Empty_App group in the Quick Panel. It 

selects the Debug build configuration and compiles/links all projects that constitute the application. 

c) The Console view lists the results of the build operation, shown in Figure 17. 

 

Figure 17 Build the multi-core application 

If the Multicore_Empty_App is selected, also select Build Project from the Project menu or the right-click 
menu. 

Note: Use the command line interface (CLI) to build the application. See the “Using the command-line” section in 
the ModusToolbox™ user guide. This document is located in the /ide_<version>/docs/ folder in the 

ModusToolbox™ installation. 

2. In the Quick Panel, click the Multicore_Empty_App Debug MultiCore (KitProg3) link under Launches. 

https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.1_a_Tools_Package_User_Guide-GettingStarted-v01_00-EN.pdf?fileId=8ac78c8c88704c7a0188a14ed50b4e45
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Figure 18 Launch the multi-core application debug 

This will automatically program the CM0P, CM7_0, and CM7_1 code into the flash region of respective cores; 

then, the IDE switches to debug mode automatically, shown in Figure 19. 

 

Figure 19  Downloading and debugging 
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The CM0P debug session is started and halted at the beginning of the main () function, CM7_0 and CM7_1 
debug session started, and CPU is not yet started in the above figure. 

3. Place a breakpoint in the cybsp_init()API in the mian.c of CM7_0 core,  you can also place another 
breakpoint in main.c of CM7_1 core. CM7_0 core and CM7_1 core will start executing after being enabled by 
CM0+ core. You can debug three cores simultaneously.  

Note: To place a breakpoint at the target instruction, click the white space between the editor window (left pane). 

 

Figure 20 Multi-core debug window 

4. Click the Resume icon or press the F8 in the CM0P project to start execution.  

After executing Cy_SysEnableCM7(CORE_CM7_0, CY_CORTEX_M7_0_APPL_ADDR) and 

Cy_SysEnableCM7(CORE_CM7_1, CY_CORTEX_M7_1_APPL_ADDR), CM7_0 core and CM7_1 core is 

enabled and the execution haltes at the very beginning of CM7's main () function. 

Click the Resume icon or press the F8 in the CM7_0 and CM7_1 project, the execution reaches the breakpoint in 
the CM7_0 project and CM7_1 project, continue to debug the code from CM7 cores. 
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Figure 21  Debugging with CM0+ and CM7 cores 
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4 Troubleshooting 

This section explains possible issues and the workarounds. 

4.1 Connection troubleshooting 

Error: Evaluation Kit is not detected on the target system.  

• Connect the USB cable that comes with the Evaluation Kit. Other USB cables may not connect data lines 

• Make sure LED D5 is ON (CMSIS-DAP mode). If not, press SW3 to change the KitProg3 device mode 

• If LED D5 is ON (CMSIS-DAP mode), change the KitProg3 device mode by pressing SW3. Now the LED3 should 
be blinking smoothly. Next try to reconnect the debug session. Then, wether this works or not, stop the 

debug session again and switch the KitProg3 device mode to LED D5 is always ON (CMSIS-DAP mode) 

4.2 Driver troubleshooting 

Error: Driver is not detected on the target system, or “KitProg3” is not visible. 

For more information on the supported driver, see the KitProg3 User Guide [4]. 

4.3 Debugger troubleshooting  

Error: While programming the XMC7000 device, the CMSIS-DAP device is not found.  

Check the USB cable connection and the state of LED3 (LED should be ON for CMSIS-DAP mode). 

4.4 Key points 

The pre-built CM0+ image should be disabled with the multi-core application; add the 
XMC7xDUAL_CM0P_SLEEP to DISABLE_COMPONENTS for XMC7xxxD device in the project CM7_0 Makefile. 

. 



  
 

 

Application note 21 002-35616 Rev. *A 

  2023-09-21 

 

Debug XMC7000 MCU in ModusToolbox™ environment 

References 

 

References 

The following are the XMC7000 family series datasheets and reference manuals. Contact Technical Support to 

obtain these documents. 

[1] Device datasheets 

− XMC7100 Datasheet 32-bit Arm® Cortex®-M7 Microcontroller XMC7000 family 

− XMC7200 Datasheet 32-bit Arm® Cortex®-M7 Microcontroller XMC7000 family 

[2] Reference manuals 

− XMC7000 MCU family architecture reference manual (RM)  

− XMC7100 registers reference manual (RM) 

− XMC7200 registers reference manual (RM) 

[3] Application notes 

− AN234334 – Getting started with XMC7000 MCU on ModusToolbox™ software 

[4] User guide 

− KitPro3 user guide  

− KIT_XMC72_EVK XMC7200 Evaluation Kit Guide 

https://www.infineon.com/support
https://www.infineon.com/dgdl/Infineon-XMC-7100-Datasheet-DataSheet-v01_00-EN.pdf?fileId=8ac78c8c8412f8d30184443160ae4415
https://www.infineon.com/dgdl/Infineon-XMC-7100-Datasheet-DataSheet-v01_00-EN.pdf?fileId=8ac78c8c8412f8d30184443160ae4415
https://www.infineon.com/dgdl/Infineon-XMC7000_MCU_FAMILY_ARCHITECTURE_TECHNICAL_REFERENCE_MANUAL-UserManual-v03_00-EN.pdf?fileId=8ac78c8c850f4bee01859d6b36155cad
https://www.infineon.com/dgdl/Infineon-XMC7100_Technical-reference-manual-UserManual-v01_00-EN.pdf?fileId=8ac78c8c8412f8d301842e7c624e7bcc
https://www.infineon.com/dgdl/Infineon-XMC7200_Technical-reference-manual-UserManual-v01_00-EN.pdf?fileId=8ac78c8c8412f8d301842e7c69b57bdd
https://www.infineon.com/dgdl/Infineon-AN234334_Getting_started_with_XMC7000_MCU_on_ModusToolbox_software-ApplicationNotes-v01_00-EN.pdf?fileId=8ac78c8c8412f8d301842d32c5765bfd
https://www.infineon.com/dgdl/Infineon-AN234334_Getting_started_with_XMC7000_MCU_on_ModusToolbox_software-ApplicationNotes-v01_00-EN.pdf?fileId=8ac78c8c8412f8d301842d32c5765bfd
https://www.infineon.com/dgdl/Infineon-KitProg3_User_Guide-UserManual-v01_00-EN.pdf?fileId=8ac78c8c7d0d8da4017d0f01221f1853&utm_source=cypress&utm_medium=referral&utm_campaign=202110_globe_en_all_integration-dev_kit
https://www.infineon.com/dgdl/Infineon-KitProg3_User_Guide-UserManual-v01_00-EN.pdf?fileId=8ac78c8c7d0d8da4017d0f01221f1853&utm_source=cypress&utm_medium=referral&utm_campaign=202110_globe_en_all_integration-dev_kit
https://www.infineon.com/dgdl/Infineon-KIT_XMC72_EVK_XMC7200_evaluation_kit_guide-UserManual-v04_00-EN.pdf?fileId=8ac78c8c8412f8d301842e60eada7b73


 

Application note 22 002-35616 Rev. *A 

  2023-09-21 

 

 

 

Debug XMC7000 MCU in ModusToolbox™ environment 
 

Revision history  

Revision history 

Document 

revision 

Date Description of changes 

** 2022-07-25 Initial release 

*A 2023-09-21 Updated content with the latest release of ModusToolbox™ 3.1 



 

 

 

 

 Important notice Warnings 

Edition 2023-09-21 

Published by 

 

Infineon Technologies AG 

81726 Munich, Germany 

 

© 2023 Infineon Technologies AG. 

All Rights Reserved. 
 

Do you have a question about this 

document? 

Email: erratum@infineon.com 

 

Document reference 

002-35616 Rev. *A 

The information contained in this application note 
is given as a hint for the implementation of the 
product only and shall in no event be regarded as a 
description or warranty of a certain functionality, 
condition or quality of the product. Before 
implementation of the product, the recipient of this 
application note must verify any function and other 
technical information given herein in the real 
application. Infineon Technologies hereby 
disclaims any and all warranties and liabilities of 
any kind (including without limitation warranties of 
non-infringement of intellectual property rights of 
any third party) with respect to any and all 
information given in this application note.  
 
The data contained in this document is exclusively 
intended for technically trained staff. It is the 
responsibility of customer’s technical departments 
to evaluate the suitability of the product for the 
intended application and the completeness of the 
product information given in this document with 
respect to such application. 

Due to technical requirements products may contain 
dangerous substances. For information on the types 
in question please contact your nearest Infineon 
Technologies office. 
 
Except as otherwise explicitly approved by Infineon 
Technologies in a written document signed by 
authorized representatives of Infineon Technologies, 
Infineon Technologies’ products may not be used in 
any applications where a failure of the product or any 
consequences of the use thereof can reasonably be 
expected to result in personal injury. 

Trademarks 
All referenced product or service names and trademarks are the property of their respective owners. 

Disclaim er  

mailto:erratum@infineon.com

	About this document
	Table of contents
	1 Getting started
	1.1 Connection setup
	1.2 Power up
	1.3 Installing kit driver

	2 ModusToolbox™ set up
	2.1 Launch ModusToolbox™
	2.2 Create an application
	2.2.1 Choose Board Support Package
	2.2.2 Select application
	2.2.3 Create application


	3 Download and debug with Evaluation Kit
	3.1 Debugging with single core application
	3.2 Debugging with multi-core application

	4 Troubleshooting
	4.1 Connection troubleshooting
	4.2 Driver troubleshooting
	4.3 Debugger troubleshooting
	4.4 Key points

	References
	Revision history
	Disclaimer

