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本書 (AN221499) は、USB Type-C EZ-PD™ CMG1 コントローラーをご紹介します。CMG1 のアーキテクチャ概要と、その

機能およびアプリケーションについて説明し、コンフィギュレーション ツールとして製造検証キット (MTK) について詳しく説明

します。また、本文ではパッシブ 電子的捺印付きケーブル アセンブリ (EMCA) ケーブルの設計を素早く立ち上げるために役

立つ他の設計リソースも紹介します。  
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1 はじめに 
EZ-PD™ CMG1 は、USB Type-C およびパワー デリバリー (PD) 規格に準拠した電子的捺印付き Type-C パッシブ ケーブ

ル アプリケーション専用の USB Type-C EMCA コントローラーです。EZ-PD CMG1 は、各 VCONN ピンに RA終端抵抗を 
持ち、VCONN および CC の両ピンに VBUS 短絡保護回路を備えた Type-C トランシーバを内蔵しています。また CMG1 は、

ベンダー固有、デバイス固有およびケーブル固有コンフィギュレーション データ用の 40 バイトの不揮発性ラッチ (NVL) を 
備えています。EZ-PD CMG1 はケーブルに 1 個あるいは 2 個の e-Marker チップを備えたパッシブ EMCA 向けの製品です。 

CMG1 デバイスでサポートされる各種 EMCA 実装のアプリケーション図は、CMG1 データシートを参照してください。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&keywords=ez-pd%20config
http://www.cypress.com/documentation/application-notes/an210403-hardware-design-guidelines-dual-role-port-applications
http://www.cypress.com/documentation/application-notes/an200210-getting-started-ez-pdtm-ccg3
http://www.cypress.com/documentation/application-notes/an218179-getting-started-ez-pdtm-ccg3pa
http://www.cypress.com/cmg1ds
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1.1 EZ-PD CMG1 の特長 
 Type-C および USB-PD に対応 

 USB PD3.0 仕様および USB Type-C 仕様 Ver. 1.3 に準拠 (VCONN 最小動作電圧が 3V に改訂されたことにも 
対応) 

 Type-C コネクタにおける VBUS ピンとの誤った短絡防止のため、CC、VCONN1 および VCONN2 ピンに高電圧 
保護機能を備える 

 ベンダー固有、デバイス固有、およびケーブル固有のコンフィギュレーション データを保存するための Type-C 
インターフェースを介してプログラムできる 40 バイト NVL 

 VCONN1 および VCONN2 に終端抵抗 RA 

 消費電力削減のため、RAを弱めることに対応 

 1 個または 2 個のコントローラーを実装した電子的捺印付きパッシブ ケーブルに対応 

 クロックおよび発振器 

 内蔵発振器により外部クロックが不要 

 電源 

 動作電圧 2.7V～5.5V でスリープ時電流 1mA 

 システム レベル ESD 保護 

 コンフィギュレーション チャネル (CC)、VCONN1、VCONN2 の各ピンでサポート 

 IEC61000-4-2 レベル 4C に基づいた±8kV 接触放電および±15kV エアギャップ放電 

 パッケージ 

 9 ボール WLCSP 

 産業用温度範囲に対応 (-40°C～+85°C)       

http://www.cypress.com/
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1.2 CMG1 ブロック図 
図 1 に、CMG1 アーキテクチャのブロック図を示します。詳細は CMG1 データシートを参照してください。  

図 1. CMG1 アーキテクチャ ブロック図 
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1.3 事前準備 
ここでは CMG1 デバイス入門のために必要なハードウェアとソフトウェアを示します。  

1.3.1 ハードウェア  

 CY4532 EZ-PD CCG3PA 評価キット (EVK) からの電源ボード 

 Windows7 またはそれ以降の OS 搭載の PC、および 1 個以上の Type-A USB ポート  

 CMG1 ベースのパッシブ EMCA ケーブル 

 10 ポート USB 3.0 スーパースピード ハブ (複数の CMG1 ベース パッシブ EMCA ケーブルを設定／テストする場合 
のみ必要) 

1.3.2 ソフトウェア  

 CMG1 製造検証キット (MTK) ユーティリティを含む EZ-PD コンフィギュレーション ユーティリティ (バージョン 1.1 ベータ

版またはそれ以降) 

http://www.cypress.com/
http://www.cypress.com/cmg1ds
http://www.cypress.com/cy4532
https://www.amazon.com/Plugable-10-Port-Adapter-Flip-Up-Charging/dp/B00JEPIOOQ?th=1
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
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1.4 CMG1 設計フロー 
ここでは、CMG1 ベース パッシブ EMCA ケーブル アプリケーションの開発からテストまでの標準的な設計フローについて 
説明します。また、このアプリケーション ノートに記載されている各ハードウェアおよびソフトウェアリソースが、どのように設計

フローの中で使用されているかについても説明します。図 2 は、CMG1 デバイスを使用するパッシブ EMCA ケーブルを製造

するための標準的な設計フローを示します。 

図 2. CMG1 設計フロー 
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設計フローのハードウェア開発フェーズを開始する前に、CMG1 ベースのケーブル アプリケーション (1 チップ/ケーブル 
または 2 チップ/ケーブル) を選択し、基準設計を参照してください。 

ハードウェア フローは、最終アプリケーションに基づいて回路図を構築し、パドルカードを設計し、次のフェーズに備えて 
いくつかのプロトタイプを準備します。回路図は、サイプレスの CMG1 ウェブページで利用可能なリファレンスデザインを基に

することもできます。 

CY4532 EZ-PD CCG3PA 評価キット (EVK)の電源ボードを使用し、コンフィギュレーションとテスト フェーズを開始します。

EZ-PD コンフィギュレーション ユーティリティは、EMCA ケーブルの CMG1 デバイス用のコンフィギュレーション ファイル 
(.cyacd) を作成するために使用されます (例えば、電源データ オブジェクト (PDO) とベンダーID の更新)。  

コンフィギュレーション ファイルが作成された後、EZ_PD コンフィギュレーション ユーティリティに含まれる CMG1 MTK 
ユーティリティは、設計されたケーブルのコンフィギュレーション (つまりプログラミング) およびテストのために使用されます。 
この MTK ユーティリティでは、最大 10 本のケーブルをコンフィギュレーションし、テストすることができます。CMG1 MTK 
ユーティリティの詳細は「EZ-PD Configuration Utility User Manual」の第 4 章を参照してください。  

ハードウェア、コンフィギュレーションおよびテストのフローが完了することで、設計されたシステムの量産準備は完了です。  

1.5 CMG1 リソース 
表 1 に、CMG1 デバイスを使用したエンド アプリケーションの設計に役立つウェブ リソースを示します。 

表 1. CMG1 設計リソース 

カテゴリ  利用可能なリソース 

データシート CMG1 データシート 

ハードウェア CY4532 EZ-PD CCG3PA EVK – CY4532 CCG3PA EVK 電源ボードに関する文書と設計ファイルが

含まれる 

ホスト PC ソフトウェア  
コンフィギュレーションおよび 
テスト ツール 

EZ-PD コンフィギュレーション ユーティリティ 1.1 ベータ版またはそれ以降 (CMG1 ベース パッシブ

EMCA ケーブルのコンフィギュレーションとテストに役立つ GUI ベースの Windows アプリケーション)。
CMG1 製造検証キット (MTK) ユーティリティを実行するために使用 

リファレンス デザイン CMG1 ベースのリファレンス デザイン 

2 CMG1 ハードウェア詳細 
ここでは、CMG1 ベース パッシブ EMCA ケーブルの設定およびテストに使用するハードウェアについて説明します。また、

CMG1 MTK セットアップの重要なコンポーネントである CY4532 EZ-PD CCG3PA EVK 電源ボードについても詳しく説明 
します。 

2.1 CY4532 EZ-PD CCG3PA EVK 
CY4532 EZ-PD CCG3PA EVK は、モバイル電源アダプタ、PC 電源アダプタ、電源バンク、車載充電器、および主に Type-
C インターフェース経由で充電を行うその他のデバイスをサポートします。Type-C コネクタを内蔵する USB ホスト システムの

評価向けのキットです。EVK の使用事例の詳細は、CY4532 EZ-PD CCG3PA EVK User Guide を参照してください。 

CY4532 EZ-PD CCG3PA EVK は、電源ボードとメイン ボードで構成されます。CCG3PA デバイスは、CCG3PA デバイス

の Type-C ポート機能を有効にするために、電源ボードに接続されるメイン ボード上に搭載されています。図 3 に、CY4532 
EZ-PD CCG3PA EVK アーキテクチャのブロック図を示します。CMG1 MTK テストのセットアップにおいて、ここでは

CY4532 EZ-PD CCG3PA EVK の電源ボードのみが対象であり、CY4532 EZ-PD CCG3PA EVK のメイン ボードについて

説明しません。  

http://www.cypress.com/
http://www.cypress.com/cmg1
http://www.cypress.com/cy4532
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/file/183686/download
http://www.cypress.com/cmg1ds
http://www.cypress.com/cy4532
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/products/usb-type-c-and-power-delivery#tabs-0-bottom_side-6
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図 3. CY4532 EZ-PD CCG3PA EVK アーキテクチャ ブロック図 

24 Pin Debug Connector

M
iniP

rog 3

CCG3PA

Battery 
Charger

BUCK
BOOST

Type-A 
Current 
Sense

5V 
LDO

5V 
Regulator

USB-
SERIAL

24 Pin Connector 
Interface to Power Board

Micro USB 
Receptacle

Battery Input 
Terminal

Screw Connector 
for DC Load

Screw Connector 
for VBus

12V DC Jack

Switch Type-A 
Receptacle

Type-C 
Receptacle

CCG4I2C CC

Type-C 
Receptacle

 
CY4532 EZ-PD CCG3PA EVK のメイン ボードは、CCG3PA デバイス、Type-C および Type-A ポートとデバッグ ヘッダで

構成されます。また電源ボードは以下で構成されます。  

 DC 入力端子 

 バッテリ入力端子 

 マイクロ USB インターフェース 

 ホスト PC から、CC ラインを介して USB シリアルと CCG4 デバイスを経由して (電源ボードの Type-C レセプタクル

に接続された) Type-C デバイスへの接続が可能 

 ファームウェアのダウンロード／アップグレードのために、ホスト PC からメイン ボードの CCG3PA デバイスへの接続

が可能 

 DC 入力端子とバッテリ入力端子が未使用の場合、ボードに電源を供給 

 Type-C ポート (CMG1 ベース パッシブ EMCA ケーブルをコンフィギュレーションおよびテスト用に接続するため) 

 レギュレータ (バッテリ充電対応と Type-C インターフェースの電力供給のため) (本アプリケーションでは未使用) 
  

http://www.cypress.com/
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2.2 CMG1 製造検証キット (MTK) のハードウェア設定 
ここでは、CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストで、CMG1 MTK ユーティリティを正常に 
実行するために必要なハードウェア接続について説明します。図 4 と図 5 に、必要な接続を示します。  

図 4 に示すように、EZ-PD コンフィギュレーション ユーティリティを実行している PC は、Type-A－Type-B マイクロ B USB 
ケーブルを使用し、CY4532 EZ-PD CCG3PA EVK の電源ボードに接続されます。CMG1 ベース パッシブ EMCA ケーブル

は、CY4532 EZ-PD CCG3PA EVK 電源ボードの Type-C レセプタクルに接続されています。  

CMG1 MTK ユーティリティは、EZ-PD コンフィギュレーション ユーティリティに含まれています。最大 10 本の CMG1 ベース 
パッシブ EMCA ケーブルを並行して、設定およびテストできます。CMG1 ベース パッシブ EMCA ケーブルを一度に複数設定

してテストする場合、図 5 に示すようにスーパースピード ハブ (推奨ハブについてはここをクリック) を接続してください。  

図 4. EZ-PD コンフィギュレーション ユーティリティを実行するシステム レベル設定 
(シングル CMG1 ベース パッシブ EMCA ケーブルの場合) 

Host PC Runnin  
EZ-PD Configurat  

Utilit

  
 

 

  

  

 
 

http://www.cypress.com/
https://www.amazon.com/Plugable-10-Port-Adapter-Flip-Up-Charging/dp/B00JEPIOOQ?th=1
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図 5. EZ-PD コンフィギュレーション ユーティリティを実行するシステム レベル設定 
(複数の CMG1 ベース パッシブ EMCA ケーブルの場合) 
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EZ-PD コンフィギュレーション ユーティリティと付属 EZ-PD CMG1 MTK ユーティリティの概要は、CMG1 MTK ユーティリティ

の節で説明します。  

 

http://www.cypress.com/


 

EZ-PD CMG1 入門 
 

www.cypress.com 文書番号: 002-23979 Rev. ** 9 

3 CMG1 ベース アプリケーションに固有なコンフィギュレーションとテストのためのソフト

ウェア ツール 
ここでは、CMG1 ベース EMCA ケーブルのコンフィギュレーション／テストのための EZ-PD コンフィギュレーション ユーティリ

ティと付属 CMG1 MTK ユーティリティの使用方法の概要を示します。CMG1 デバイスには、コンフィギュレーション データを

格納するために使用される 40 バイトの NVL があります。ファームウェア開発が不要なため、CMG1 デバイスは PSoC 
Creator™や PSoC Programmer などのサイプレス ツールに対応していません。 

3.1 EZ-PD コンフィギュレーション ユーティリティと CMG1 MTK ユーティリティ 
EZ-PD コンフィギュレーション ユーティリティは、CCGx デバイスの内部フラッシュ メモリのコンフィギュレーション テーブル 
領域に格納するパラメーターを設定する Windows アプリケーションです。バージョン 1.1 ベータ版 (またはそれ以降) では、

CMG1 MTK ユーティリティも統合してサポートします。ベンダー固有およびケーブル固有のパラメーターは EZ-PD コンフィ 
ギュレーション ユーティリティを使用して設定できます。パラメーターが設定されると、CMG1 MTK ユーティリティは CMG1 
ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストに使用されます。CMG1 MTK ユーティリティには、CY4532 
EZ-PD CCG3PA EVK の電源ボードにある CCG4 デバイス用の CMG1 MTK 固有のファームウェア ソリューションが付属 
しています。図 6 に、CMG1 ベース パッシブ EMCA ケーブルで CMG1 MTK ユーティリティがどのように通信するかを示す 
ブロック図を示します。 

図 6. CMG1 MTK ユーティリティ ブロック図 

CY4532 EZ-PD CCG3PA EVK
Power Board

Host PC Running 
EZ-PD CMG1 MTK 

    
   

 

  
  

   
  

 

 

CCG4 デバイス ベースの CMG1 MTK 固有ファームウェアは、EZ-PD コンフィギュレーション ユーティリティが MTK ベース 
ファームウェアを実行するためのユニークなアプリケーション ID を実装します。それにより、MTK 設定開始コマンドを 
受け取ると、CMG1 MTK ユーティリティは接続された CMG1 ベース パッシブ EMCA ケーブルを検出できます。  

http://www.cypress.com/
http://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
http://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
http://www.cypress.com/products/psoc-programming-solutions
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サイプレスのウェブサイトから、CMG1 MTK ユーティリティを含む EZ-PD コンフィギュレーション ユーティリティをダウンロード

してインストールできます。インストール後、Windows スタートメニューからユーティリティを起動します (起動手順: All 
Programs > Cypress > EZ-PD Configuration Utility > EZ-PD Configuration Utility)。図 7 に、ユーティリティの初期

画面を示します。 

図 7. EZ-PD コンフィギュレーション ユーティリティ開始ページ 

 

以下は EZ-PD コンフィギュレーション ユーティリティの一部として提供される CMG1 MTK ユーティリティの主な機能です。 

1. CMG1 ベース EMCA ケーブルのコンフィギュレーションが可能ケーブル コンフィギュレーション情報を xml ファイル形式

で保存可能 

2. CMG1 ベース EMCA ケーブルのテストが可能 

3. 最大 10 本の CMG1 ベース EMCA ケーブルを検出および通信。接続された CMG1 ベース パッシブ EMCA ケーブルは

独立して並列に設定およびテスト可能 

4. テストの開始および終了に関するオプション機能 

5. それぞれ接続された CMG1 ベース EMCA ケーブルの状態の報告機能 

6. 統合されたテスト報告機能 

7. 10 秒以内で 10 本の CMG1 ベース EMCA ケーブルを並行してテスト可能 

CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストの詳細は EZ-PD Configuration Utility User 
Manual を参照してください。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/file/183686/download
http://www.cypress.com/file/183686/download
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4 CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストの例  
ここでは、CMG1 MTK ユーティリティおよび関連するハードウェアを含む EZ-PD コンフィギュレーション ユーティリティを使用

し、CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストの簡単な例を示します。  

一般的に、CMG1 MTK ユーティリティを使用する CMG1 ベース EMCA ケーブルのコンフィギュレーションとテストのプロセス

は、以下の 4 つのステップに要約されます。  

1. CY4532 EZ-PD CCG3PA EVK の電源ボードの CCG4 デバイスのファームウェアを更新し、MTK テスターID を設定 
します。このステップは、CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイスを設定するために 1 回行う必要

があります。 

2. CMG1 ベース パッシブ EMCA ケーブルを必要なハードウェア (CY4532 EZ-PD CCG3PA EVK 電源ボード) と EZ-PD
コンフィギュレーション ユーティリティを実行している PC に接続します。 

3. EZ-PD コンフィギュレーション ユーティリティを使用し、接続された CMG1 ベース パッシブ EMCA ケーブルのコンフィ 
ギュレーション ファイル (.cyacd 形式) を作成し、保存します。 

4. CMG1 MTK ユーティリティを使用し、接続された CMG1 ベース パッシブ EMCA ケーブルをコンフィギュレーションし、 
テストします。 

以降では、各ステップの詳細を説明します。 

4.1 CY4532 EZ-PD CCG3PA EVK の CCG4 デバイスのファームウェア更新と MTK テスターID の設定 
ここでは、CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイスのファームウェアを更新するステップについて説明

します。この CCG4 デバイスのファームウェア更新により、ホスト PC で実行する EZ-PD コンフィギュレーション ユーティリティ

が CY4532 電源ボードに接続された CMG1 ベース パッシブ EMCA ケーブルと正常に通信できるようになります (図 6 を 
参照してください)。また、ここでは CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイスへのユニークな MTK 
テスターID の設定についても説明します。一度に複数の CMG1 ベースのパッシブ EMCA ケーブルで MTK テスト設定を 
実行するために複数の CY4532 EZ-PD CCG3PA EVK 電源ボードが接続されている場合、MTK テスターID の設定により、

各 MTK ハードウェアを一意に識別できます。 

4.1.1 CCG4 デバイスのファームウェア更新  
CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイスのファームウェアを更新するために以下のステップを実施して

ください。 

1. CMG1 MTK ユーティリティを含む「EZ-PD Configuration Utility」の最新バージョンをダウンロードし、インストールします。 

2. CY4532 EZ-PD CCG3PA EVK で、電源ボードから CCG3PA メイン ボードを慎重に取り外します。  

3. CY4532 EZ-PD CCG3PA EVK 電源ボードのジャンパ J6、J7、J9 のシャント抵抗を取り外します。表 2 に示すように 
ジャンパ設定を行います。 

表 2. CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイス ファームウェア更新のためのジャンパ設定 

ジャンパ ヘッダ 状態 

J6 開放 

J7 開放 

J9 開放 

J14 該当なし (電源 LED には DC 入力端子から電源

が供給されている場合のみ供給される) 

 
4. 入力電源選択スイッチ SW1 の位置は、電源がホスト PC からマイクロ B USB ケーブル経由で供給されるため、 

関係ありません。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools


 

EZ-PD CMG1 入門 
 

www.cypress.com 文書番号: 002-23979 Rev. ** 12 

5. 図 8 に示すように、USB Type-A－マイクロ B ケーブルをホスト PC から電源ボードのコネクタ J12 に接続します。 

図 8. CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイス ファームウェア更新 

 
 

6. 図 9 に示すように、Start > All Programs > Cypress > EZ-PD Configuration Utility > EZ-PD Configuration 
Utility から EZ-PD コンフィギュレーション ユーティリティを起動します。 

図 9. EZ-PD コンフィギュレーション ユーティリティ 

 

USB Type-A to Micro-B cable 
connected to J12 on the 
CY4532 EVK Power Board

PC/Laptop running 
EZ-PD Configuration 
Utility

http://www.cypress.com/
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7. 図 10 に示すように、CCG4 デバイスのファームウェアを更新するために、Tools > Firmware Update を選択します。 
詳細は EZ-PD Configuration Utility ウェブページ、または EZ-PD コンフィギュレーション ユーティリティの Help > User 
Manual でユーティリティのユーザー マニュアルを参照してください。  

図 10. EZ-PD コンフィギュレーション ユーティリティを使用するファームウェア更新 

 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools
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8. ポップアップ ウィンドウで、CCG4 デバイスを更新するファームウェア ファイルの場所を指定します。ステップ 1 で選択 
したフォルダがデフォルトの場所 (C:\Program Files (x86)\Cypress)である場合、必要なファームウェアはローカル  
ディレクトリ(C:\Program Files (x86)\Cypress\EZ-PD Configuration Utility\Firmware\MTK)にあります。  

図 11 に示すように、「Select Target」で「NOTEBOOK」を選択し、「Firmware path 1」のテキスト フィールドの横にある

「Browse」をクリックし、EZ-PD コンフィギュレーション ユーティリティがインストールされているローカル ディレクトリを 
開きます。CYPD4126-40LQXI_mtk_1.cyacd ファイルをダブルクリックして選択します。同様に、「Firmware path 2」の
CYPD4126-40LQXI_mtk_2.cyacd ファイルを選択します。  

注意事項: CCG4 デバイスのプログラミングには 2 つの.cyacd ファイルが必要です。これは CCG4 デバイス フラッシュ

が 2 つの 64kB バンクにまとめられており、それぞれにファームウェアのコピーが別々に保存されているためです。 

図 11. EZ-PD コンフィギュレーション ユーティリティを使用する CCG4 デバイスのファームウェア更新 

 

9. 「Use bootloader to flash」オプションを選択します。すべての設定が正しいことを確認した後、「Program」を 
クリックします。  

http://www.cypress.com/
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「Program」のクリックで、ファームウェア更新プロセスが開始します。図 12 に示すように、ユーティリティの下部にあるス

テータス バーは進行状況を表示します。このファームウェア更新プロセスは、完了までに最大 6 分かかります。CCG4 デ

バイスのフラッシュの第 1 バンクが最初に更新され、その後に第 2 バンクが更新されます。 

注意事項: ファームウェア更新中に、CY4532 EZ-PD CCG3PA EVK 電源ボードを取り外さないでください。 
図 12. ファームウェア更新プロセスを示すステータス バー 

 

10. ファームウェア更新プロセスが正常に完了すると、図 13 に示す「Flash updated successfully」メッセージのウィンドウが

表示されます。OK をクリックしてください。 

図 13. ファームウェア更新プロセスの完了 

 

11. 以上で CCG4 デバイスのファームウェア更新プロセスが完了です。CY4532 EZ-PD CCG3PA EVK 電源ボードの 
コネクタ J12 からマイクロ B USB ケーブルを抜き差しして電源を再投入します。MTK テスターID を設定するために、 
EZ-PD コンフィギュレーション ユーティリティ ウィンドウを閉じないでください。 

http://www.cypress.com/
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4.1.2 CY4532 EZ-PD CCG3PA EVK の CCG4 デバイス用の MTK テスター ID の設定  
CCG4 デバイスのファームウェアが更新された後、CCG4 デバイスのユーザー パラメーターに MTK テスターID を設定し、 
複数の CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテスト動作を実施する際に各 MTK ハードウェアを

一意に識別できるようにします。CCG4 デバイスに MTK テスターID を設定するには、以下のステップで行います。 

1. 前節から続けて、図 14 に示すように File > Read from Device を選択し、CCG4 デバイスのコンフィギュレーション  
パラメーターを読み出します。 

図 14. CCG4 デバイスのコンフィギュレーション パラメーターの読出し 

  

2. 「Read From Device」ポップアップ ウィンドウで、CCG4 デバイスのアプリケーション タイプが MTK に更新されている 
ことを確認します。図 15 に示すように「Select Target」から MTK を選択し、「Use bootloader to read」のオプションを

選択します。すべての設定が正しいことを確認した後、「Read」をクリックします。  

図 15. CCG4 デバイスのコンフィギュレーション パラメーターの読出し 

 

http://www.cypress.com/
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3. 既存コンフィギュレーション パラメーターが読み込まれ、EZ-PD コンフィギュレーション ユーティリティの左パネルの

CCGx Configuration の下に表示されます。デバイス コンフィギュレーションパラメーターは、「Device Parameters」、
「Port Parameters」および「User Parameters」に分割されます。図 16 に示すように、左のパネルの下までスクロールし、

「User Parameters」を選択します。 

図 16. CCG4 デバイスのユーザー パラメーター読出し 

 
4. User Parameters グループには、合計 8 つの 4 バイトのパラメーターが表示され、各パラメーターのデフォルト値は

0x00000000 に設定されています。「Parameter 1」は、MTK テスターID に関係します。図 16 でハイライトされている

「Parameter 1」の値を所望のテスター ID 値で更新します。コンフィギュレーションとテストで同時に使用される 
各 CY4532 EZ-PD CCG3PA EVK 電源ボードにユニークな値を使用してください。 

http://www.cypress.com/
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5. 図 17 に示すように、File > Save As をクリックし、ローカル ディレクトリを開き、CCG4 デバイスの変更されたコンフィ 
ギュレーション パラメーターを保存します。変更されたコンフィギュレーション パラメーターは xml ファイルとして 
保存されます。デフォルトで、.cyacd と.c ファイルも同じ場所に保存されます。 

図 17. CCG4 デバイスの変更されたコンフィギュレーション パラメーターの保存 

 

http://www.cypress.com/
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6. 次に、CCG4 デバイスで保存されたパラメーターを更新します。これを行うためには図 18 に示すように、Tools > 
Configure Device をクリックします。ポップアップ メッセージで「Do you want to save the current configuration?」が 
表示された場合、前のステップで変更したパラメーターを保存していない、または保存した後にコンフィギュレーション  
パラメーターが変更されたことを意味します。このメッセージ ボックスでは「Yes」をクリックし、変更されたパラメーターを

保存します。  
図 18. 変更されたパラメーターでの CCG4 デバイスの設定 

 

http://www.cypress.com/
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7. 図 19 に示すように、「Configure Device」ポップアップ ウィンドウでターゲット デバイスを選択し、コンフィギュレーション 
ファイル パスを指定します。図 19 に示すように、「Select Target」で「MTK」を選択します。Configuration File テキスト 
フィールドの横にある Browse をクリックし、.cyacd ファイルが以前に保存されたローカル ディレクトリを開きます。その

ファイルを選択し、ダブルクリックします。Use bootloader to flash オプションにチェックがないことを確認します。すべて

の設定が正しいことを確認した後、「Program」をクリックします。 

図 19. EZ-PD コンフィギュレーション ユーティリティを使用する CCG4 デバイスの設定 

 
「Program」をクリックすると、デバイス設定プロセスが開始されます。ユーティリティの下部にあるステータス バーは進行

状況を表示します。 
注意事項: デバイス設定中に、CY4532 EZ-PD CCG3PA EVK 電源ボードを取り外さないでください。 

8. 図 13 に示すように、デバイス設定プロセスが完了すると、「Flash updated successfully」メッセージ ウィンドウが 
表示されます。OK をクリックしてください。 

9. これで、CCG4 デバイス コンフィギュレーションの更新は完了です。CY4532 EZ-PD CCG3PA EVK 電源ボードの 
コネクタ J12 からマイクロ B USB ケーブルを抜き差しして、電源ボードに電源を再投入します。前述のステップ 1～3 を

繰り返して、CCG4 デバイスのコンフィギュレーション パラメーターを読み出します。「User Parameters」の「Parameter 
1」の値が、前のステップ 4 で設定した MTK テスターID の値であることを確認します。  

10. 以上で CY4532 EZ-PD CCG3PA EVK 電源ボードの CCG4 デバイスの MTK テスターID 値の設定が完了しました。 
必要があれば、上記ステップを繰り返し、他の MTK ハードウェアの MTK テスターID 値を設定します。EZ-PD コンフィ 
ギュレーション ユーティリティを終了します。現在のコンフィギュレーションを保存する確認メッセージが表示された場合、

No をクリックしてください。 

4.2 CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストのためのシステム レベル設定 
ここでは、CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストに必要なハードウェアとソフトウェアの 
設定手順について説明します。  

1. 前節で CMG1 MTK ユーティリティをサポートする EZ-PD コンフィギュレーション ユーティリティを最新バージョンに更新

していない場合、最新バージョンをダウンロードし、インストールします。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools
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2. CCG3PA メインボードが電源ボードに取り付けられている場合、慎重に取り外します。CY4532 EZ-PD CCG3PA EVK
電源ボードのジャンパ設定を、図 20 を元に確認してください。 

図 20. CY4532 EZ-PD CCG3PA EVK 電源ボードのジャンパ設定 

 
3. CY4532 EZ-PD CCG3PA EVK の CCG4 デバイスは、このステップの前で、既に MTK ユーティリティをサポートする 

ファームウェアに更新されているものとします。ファームウェアがまだ更新されていない、または CY4532 EZ-PD 
CCG3PA EVK 電源ボードの CCG4 デバイスに現在どのファームウェアが取り込まれているかが不明な場合、前節の 
ステップに従ってください。 

SW1 Input Power Selection Switch
(DC Input Position)

J12. USB Micro-B 
Receptacle (Connect to PC 
Running CMG1 MTK Utility)

J13. USB Type-C Receptacle
(Connect to CMG1 based 
Passive EMCA Cable

J6 Mode Selection Jumper
(1-2 Shorted)

J7 Mode Selection Jumper
(1-2 Shorted)

J9 Mode Selection Jumper
(1-2 Shorted)

J14: Power LED Jumper 
(Shorted)

http://www.cypress.com/
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4. この例では、1 本の CMG1 ベース EMCA ケーブルのコンフィギュレーションとテストを行います。図 21 に示すように  
(前の図 4 と同じ)、CMG1 ベース パッシブ EMCA ケーブルを CY4532 EZ-PD CCG3PA EVK 電源ボードに接続します。 

図 21. EZ-PD コンフィギュレーション ユーティリティを実行するシステム レベル設定 
(シングル CMG1 ベース パッシブ EMCA ケーブルの場合) 

Host PC Runnin  
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これで、1 つの CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテスト用のシステムレベル設定が 
完了しました。複数の CMG1 ベース パッシブ EMCA ケーブルの場合、図 5 に示すように設定を行ってください。  

4.3 EZ-PD コンフィギュレーション ユーティリティを使用したコンフィギュレーション ファイル (.cyacd 
フォーマット) の作成と保存 
ここでは、CMG1 MTK ユーティリティを含む EZ-PD コンフィギュレーション ユーティリティを使用する CMG1 ベース パッシブ

EMCA ケーブル用のコンフィギュレーション ファイル (.cyacd フォーマット) の作成方法を説明します。前節でのシステム  
レベルの設定は、この節の開始時点では完了しているものとします。 

1. CY4532 EZ-PD CCG3PA EVK の CCG4 デバイスのファームウェア更新および CMG1 ベース パッシブ EMCA 
ケーブルのコンフィギュレーションとテストのシステム レベル設定が完了していることを確認してください。 

2. Start > All Programs > Cypress > EZ-PD Configuration Utility > EZ-PD Configuration Utility からコンフィギュ

レーション ユーティリティを起動します。 
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3. File > New をクリックします。ポップアップ ウィンドウの Device Type に CCGx デバイスが表示されます。「Device 
Type」のドロップダウン リストから CMG1 を選択します。その後、アプリケーション タイプとして Passive Cable を選択

します。ポップアップ ウィンドウの選択が図 22 のようになっていることを確認した後、「Create Project」をクリックします。 

図 22. EZ-PD コンフィギュレーション ユーティリティの新しいプロジェクト作成 

 

http://www.cypress.com/


 

EZ-PD CMG1 入門 
 

www.cypress.com 文書番号: 002-23979 Rev. ** 24 

「Create Project」をクリックすると、新しいプロジェクトが作成され、図 23 に示すようにユーティリティの左側パネルの

CCGx Configuration ツリーに表示されます。EZ-PD コンフィギュレーション ユーティリティのメイン ウィンドウの 
右パネルに新しいタブ「CMG1: Passive Cable 」が開きます。プロジェクト タイトルは、EZ-PD コンフィギュレーション  
ユーティリティ ウィンドウの右下にもハイライトされます。 
図 23. EZ-PD コンフィギュレーション ユーティリティでの新しい CMG1 パッシブ ケーブル プロジェクト作成 
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4. CMG1 パッシブ ケーブルのパラメーターは、「Device parameters」と「Port parameters」に分類されます。左パネルで

「Device Parameters」を選択します。図 24 は、EZ-PD Configuration Utility ウィンドウの表示例です。  
図 24. CMG1 パッシブ ケーブル プロジェクト用のデバイス パラメーター設定 

 
図 24 に示すように、「Device Parameters」で「Manufacturer Info」、「USB Vendor ID」、「USB Product ID」、

「Configuration table major version」、「SVID available」、「Lock configuration」、「PD3.0 enable」などがあり、 
各パラメータの横にあるドロップダウン メニューを使用して、設定することができます。CMG1 ベース パッシブ EMCA 
ケーブルを最終的に製造するために、コンフィギュレーション ファイルを作成するケーブル メーカーでは、「Lock 
Configuration」パラメーターを「Yes」に設定する必要があります。「Lock Configuration」機能を有効にする場合、 
コンフィギュレーションとテストが完了した後にすべてのコンフィギュレーション パラメーターが凍結され、これらの CMG1
ベース パッシブ EMCA ケーブルは将来再コンフィギュレーション／テストすることができなくなります。CMG1 ベース

EMCA パッシブ ケーブルのパラメーターを必要に応じて変更します。 
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5. 次に左側パネルで、Port 0 > Discover Identity の下にある Cable VDO をクリックします。図 25 は、EZ-PD コンフィ 
ギュレーション ユーティリティ ウィンドウの表示例です。右側パネルでは、ケーブル固有のベンダー定義オブジェクト 
(VDO) の関連パラメーターを設定します。「Cable hardware version」と「Cable firmware version」、「Cable type」 
(Type-C to Type-A／Type-B／Type-C)、「Connector type」 (プラグまたはレセプタクル)、「Cable termination type」 
などのパラメーターは、各パラメーターの横にあるドロップダウン メニューを使用して設定できます。  

図 25. CMG1 パッシブ ケーブル プロジェクトの Cable VDO の設定 
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6. 必要なパラメーター設定を行った後、新しく作成したプロジェクトを保存します。File > Save As をクリックし、図 26 に 
示すように設定済のプロジェクトを保存するローカル ディレクトリをブラウズします。更新されたコンフィギュレーション  
パラメーターは xml ファイルとして保存されます。デフォルトで、.cyacd と.c ファイルも同じ場所に保存されます。  

図 26. CMG1 パッシブ ケーブル プロジェクトのコンフィギュレーション保存 

 
以上で、CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーション ファイルの作成は完了です。 
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4.4 EZ-PD コンフィギュレーション ユーティリティにある MTK を使用した CMG1 ベース パッシブ EMCA
ケーブルのコンフィギュレーションとテスト 
次のステップは、EZ-PD コンフィギュレーション ユーティリティを使用し、製造検証キットに接続された CMG1 ベース パッシブ

EMCA ケーブルをコンフィギュレーションおよびテストします。「EZ-PD コンフィギュレーション ユーティリティを使用したコンフィ

ギュレーション ファイル (.cyacd フォーマット) の作成と保存」の節のステップに続けて、これらのステップに従ってください。 

1. 前節で説明したステップを継続する場合、図 27 に示すように、メニュー項目 Tools > Manufacturing Test Kit Tab を

選択します。EZ-PD コンフィギュレーション ユーティリティを再起動する場合、File > Open をクリックし、ローカル  
ディレクトリをブラウズして以前に保存した xml フォーマットの CMG1 ベース パッシブ EMCA ケーブル コンフィギュレー

ション ファイルを取り込みます。このファイルを開くと、図 27 に示すようにメニュー項目 Tools > Manufacturing Test 
Kit Tab を選択します。 

図 27. EZ-PD コンフィギュレーション ユーティリティの Manufacturing Test Kit Tab 
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これにより、EZ-PD コンフィギュレーション ユーティリティのメイン ウィンドウに新しい「Manufacturing Test Kit」タブが

開き、図 28 に示すウィンドウになります。このタブを使用して、CMG1 ベース パッシブ EMCA ケーブルのコンフィ 
ギュレーションとテストができます。 

図 28. EZ-PD コンフィギュレーション ユーティリティの Manufacturing Test Kit タブ 

 
図 28 にハイライトされているように、このタブへの入力ファイルは、.cyacd フォーマットの CMG1 ベース パッシブ EMCA
ケーブルのコンフィギュレーション ファイルです。接続された CMG1 ベース パッシブ EMCA ケーブルのコンフィギュ 
レーションは、Start または Stop を使用して開始または停止できます。また、Refresh を使用し、接続された CMG1 
ベース パッシブ EMCA ケーブルのリストを更新できます。 

Settings オプションから、接続されたケーブルをコンフィギュレーションする、または単にそれらをテストする、が選択 
できます。このオプションでは障害検出時にすでに実行中のテストを停止する機能も提供します。  

このウィンドウでは、製造検証キットに接続された CMG1 ベース  パッシブ EMCA ケーブルの一覧が 
表示されます。これには、接続された MTK ハードウェアのシリアル番号、接続された MTK ハードウェアのテスターID、

接続された CMG1 ベース パッシブ EMCA ケーブルのケーブル ID、その現在の状態 (合格／不合格／コンフィギュ 
レーション中／テスト中)、対応する LED の色が表示されます。また、すでにテスト済みの CMG1 ベース パッシブ EMCA
ケーブルの報告を作成する Open Report オプションもあります。Open report をクリックすると、EZ-PD コンフィギュ 
レーション ユーティリティによって保存された各テスト完了のログと報告を表示します。 

EZ-PD コンフィギュレーション ユーティリティの下方のメッセージ ウィンドウはコンフィギュレーションまたはテストの進行

状態を示します。 

2. 「Configuration cyacd path」テキスト フィールドの横にある Browse をクリックし、.cyacd フォーマットのコンフィギュ 
レーション ファイルが保存されているローカル ディレクトリをブラウズします。 

3. 所望の「Settings」オプションを選択し、CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションおよび／または

テストを行います。「Start」をクリックします。 

http://www.cypress.com/


 

EZ-PD CMG1 入門 
 

www.cypress.com 文書番号: 002-23979 Rev. ** 30 

Start をクリックすると、EZ-PD コンフィギュレーション ユーティリティは Settings で選択されたステップを実行し、MTK
に接続された CMG1 ベース パッシブ EMCA ケーブルをコンフィギュレーションおよび／またはテストします。コンフィ 
ギュレーションとテストが完了すると、MTK テストを実行する EZ-PD コンフィギュレーション ユーティリティのウィンドウは、

図 29 に示すウィンドウになります。複数の CMG1 ベース パッシブ EMCA ケーブルが接続されている場合、それらも 
同じウィンドウに表示され、MTK テストを実行する EZ-PD コンフィギュレーション ユーティリティのウィンドウは図 30 に

示すウィンドウになります。 

図 29. シングル CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストの完了 

 
図 30. 複数の CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストの完了 
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4. 表示ウィンドウのテーブルに結果が表示されると、接続された CMG1 ベース パッシブ EMCA ケーブルのコンフィギュ 
レーションとテストが完了します。ここで、以下に示す 2 つのオプションがあります。 
オプション 1: 既に開いている Manufacturing Test Kit タブのボタンをクリック、およびいずれかの設定を変更をせずに、

すでに設定している CMG1 ベース パッシブ EMCA ケーブルを外し、次のコンフィギュレーション、テストまたはその両方

を必要とする CMG1 ベース パッシブ EMCA ケーブルを接続します。このオプションは、EZ-PD コンフィギュレーション  
ユーティリティで何も変更することなく、複数の CMG1 ベース パッシブ EMCA ケーブルを順番にコンフィギュレーションし、

テストできます。また、コンフィギュレーションとテストを終了したばかりの CMG1 ベース パッシブ EMCA ケーブルが 
取り外されるのを待っている間、CMG1 MTK ユーティリティは待機状態になります。つまり、設定されたケーブルが 
取り外され、新しいケーブルが接続されるのを待ちます。この機能は、CY432 EZ-PD CCG3PA EVK 電源ボードの数が

限られ、コンフィギュレーションおよびテストする CMG1 ベース パッシブ EMCA ケーブルが複数ある場合に便利です。 
オプション 2: 「Stop をクリックし、コンフィギュレーションとテスト プロセスを終了します。CMG1 ベース パッシブ EMCA
ケーブルを 1 本だけコンフィギュレーションとテストする場合、このオプションを選択してください。  

5. オプション 1 を選んだ場合、CMG1 ベース パッシブ EMCA ケーブルのコンフィギュレーションとテストが完了すると、

Stop をクリックし、プロセスを終了します。  
6. 必要に応じて、メッセージ ウィンドウを表示し、接続された CMG1 ベース パッシブ EMCA ケーブルのコンフィギュ 

レーションとテストの進行状況を確認します。右上の Close をクリックし、Manufacturing Test Kit タブを閉じます。 
7. CMG1 MTK ユーティリティの詳細は「EZ-PD Configuration Utility」のウェブページの「EZ-PD Configuration Utility 

User Manual」の 4 章を参照してください。または、EZ-PD コンフィギュレーション ユーティリティで Help > User Manual
を選択して、このユーザー マニュアルにアクセスすることもできます。 
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