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Getting Started with EZ-PD CMG1 

Author: Vihang Trivedi 

Associated Part Family: CYPD270x 

Associated Software: EZ-PDTM Configuration Utility 

Related Application Notes: AN210403, AN200210, AN218179  
 

AN221499 introduces the USB Type-C EZ-PD™ CMG1 controller. It provides a brief overview of the CMG1 

architecture, its features and applications and covers the Manufacturing Test Kit (MTK) in detail as a configuration tool. 

This document also references other design resources to help you ramp up quickly with your passive Electronic Marked 

Cable Assembly (EMCA) cable designs.  
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1 Introduction 

EZ-PD CMG1 is a dedicated USB Type-C EMCA controller that complies with the USB Type-C and Power Delivery 

(PD) standards for Electronically Marked Type-C passive cable applications. EZ-PD CMG1 integrates a complete Type-

C transceiver including the RA termination resistors on the VCONN pins and VBUS short circuit protection on both 

VCONN and CC pins. CMG1 also includes 40-bytes of Non-Volatile Latch (NVL) for configuration of vendor-, device-, 

and cable-specific configuration data. EZ-PD CMG1 is targeted for passive EMCA implementations with either one or 

two e-marker chips on the cable. 

See the CMG1 datasheet for application diagrams of various EMCA implementations supported by CMG1 devices. 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&keywords=ez-pd%20config
http://www.cypress.com/documentation/application-notes/an210403-hardware-design-guidelines-dual-role-port-applications
http://www.cypress.com/documentation/application-notes/an200210-getting-started-ez-pdtm-ccg3
http://www.cypress.com/documentation/application-notes/an218179-getting-started-ez-pdtm-ccg3pa
http://www.cypress.com/cmg1ds
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1.1 EZ-PD CMG1 Features 

▪ Type-C Support and USB-PD Support 

 Supports USB PD3.0 specification and USB Type-C specification version 1.3 (including support for the revised 

minimum VCONN operating voltage of 3 V) 

 Integrated high-voltage protection on CC, VCONN1, and VCONN2 pins to protect against accidental shorts to 

the VBUS pin on the Type-C connector 

 40-byte NVL programmable over Type-C interface for storing vendor-, device-, and cable-specific configuration 

data 

 Termination resistor RA on VCONN1 and VCONN2 

 Supports RA weakening to reduce power consumption 

 Supports electronically marked passive cable implementations with one or two controllers 

▪ Clocks and Oscillators 

 Integrated oscillator eliminates the need for an external clock 

▪ Power 

 2.7 V to 5.5 V operation with 1 mA sleep current 

▪ System-Level ESD Protection 

 On Configuration Channel (CC), VCONN1, and VCONN2 pins 

 ± 8-kV Contact Discharge and ± 15-kV Air Gap Discharge based on IEC61000-4-2 level 4C 

▪ Packages 

 9-ball WLCSP 

 Supports industrial temperature range (-40° C to + 85° C)       

http://www.cypress.com/
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1.2 CMG1 Block Diagram 

Figure 1 shows a block diagram of the CMG1 architecture. For more details, see the CMG1 datasheet.  

Figure 1. CMG1 Architecture Block Diagram 

VBUS-to-CC

Short Protection

CMG1: Type-C Passive EMCA Controller

System Resources

VBUS-to-VCONN1

Short Protection,

RA

USB PD 

Subsystem

EMCA Protocol 

Engine

VBUS-to-VCONN2

Short Protection,

RA

USB Type-C Physical 

Layer

40-byte Storage for 

Configuration

Storage

VREF

IREF

Reset

Oscillator

 

1.3 Prerequisites 

This section lists the hardware and software required to get started with CMG1 devices.  

1.3.1  Hardware  

▪ Power Board from the CY4532 EZ-PD CCG3PA Evaluation Kit (EVK)  

▪ PC with Windows 7 or later and at least one Type-A USB port  

▪ CMG1 based Passive EMCA cables 

▪ 10-Port USB 3.0 SuperSpeed Hub (optional; required only for configuring/testing multiple CMG1 based passive 

EMCA cables) 

1.3.2  Software 

▪ EZ-PD Configuration Utility (version 1.1 Beta or later) which includes the CMG1 Manufacturing Test Kit (MTK) 

Utility 

http://www.cypress.com/
http://www.cypress.com/cmg1ds
http://www.cypress.com/cy4532
https://www.amazon.com/Plugable-10-Port-Adapter-Flip-Up-Charging/dp/B00JEPIOOQ?th=1
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
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1.4 CMG1 Design Flow 

This section describes a typical design flow that cable manufacturers would go through during the development and 

testing of CMG1 based passive EMCA cable applications. It also covers how each of the hardware and software 

resources described in this application note are used through the design flow. Figure 2 shows a typical design flow for 

manufacturing passive EMCA cables using CMG1 devices. 

Figure 2. CMG1 Design Flow 
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Once the CMG1 based cable application (1-chip/cable or 2-chip/cable) is determined and reference designs have been 

reviewed, you can start the hardware development phase of the design flow. 

The hardware flow includes building schematics based on the end application and doing the paddle card design to get 

a few prototypes ready for the next phase. The schematics can be based on the reference designs available on Cypress’ 

CMG1 webpage. 

You can start the configuration and testing phase using the CY4532 EZ-PD CCG3PA Evaluation Kit’s (EVK) Power 

Board. The EZ-PD Configuration Utility is used to create a configuration file (.cyacd) for the CMG1 device of the EMCA 

cables (for example, updating Power Data Objects (PDOs) and Vendor IDs).  

Once a configuration has been created, the CMG1 MTK Utility included in the EZ_PD Configuration Utility is used for 

configuring (that is, programming) and testing the designed cables. Up to 10 cables can be configured and tested 

simultaneously using the MKT Utility. More information on the CMG1 MTK Utility can be found in Chapter 4 of the EZ-

PD Configuration Utility User Manual.  

Once the hardware and configuration and test flows are completed, the existing system design is ready for mass 

production.  

1.5 CMG1 Resources 

Table 1 lists the web resources available to help you design end applications using CMG1 devices. 

Table 1. CMG1 Design Resources 

Category  Available Resources 

Datasheet CMG1 Datasheet 

Hardware 
CY4532 EZ-PD CCG3PA EVK – Contains documentation and design files of the CY4532 CCG3PA 
EVK Power Board 

Host PC Software 
Configuration and Test Tool 

EZ-PD Configuration Utility 1.1 Beta or later (GUI-based Windows application to help you configure 
and test CMG1 based passive EMCA cables) for running the CMG1 Manufacturing Test Kit (MTK) 
Utility 

Reference Designs CMG1 based Reference Designs 

2 CMG1 Hardware Details 

This section discusses the hardware to be used for configuring and testing CMG1 based passive EMCA cables. The 

CY4532 EZ-PD CCG3PA EVK’s Power Board is a key component of the CMG1 MTK setup and is discussed in detail 

in this section. 

2.1 CY4532 EZ-PD CCG3PA EVK 

The CY4532 EZ-PD CCG3PA EVK supports mobile power adapters, PC power adapters, power banks, car chargers, 

and other applications that primarily charge other devices via a Type-C interface. The kit is intended as an evaluation 

vehicle for USB Host systems that house a Type-C connector. Refer to the CY4532 EZ-PD CCG3PA EVK User Guide 

for in-depth information about EVK use cases. 

The CY4532 EZ-PD CCG3PA EVK consists of a Power Board and a Main Board. The CCG3PA device is mounted on 

the main board, which is connected to the power board to enable the CCG3PA device’s Type-C port functionality. 

Figure 3 shows a block diagram of the CY4532 EZ-PD CCG3PA EVK architecture. For CMG1 MTK test setup, the 

CY4532 EZ-PD CCG3PA EVK’s Main Board is not discussed further in this section and only the CY4532 EZ-PD 

CCG3PA EVK’s Power Board is covered.  

http://www.cypress.com/
http://www.cypress.com/cmg1
http://www.cypress.com/cy4532
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/file/183686/download
http://www.cypress.com/file/183686/download
http://www.cypress.com/cmg1ds
http://www.cypress.com/cy4532
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/products/usb-type-c-and-power-delivery#tabs-0-bottom_side-6
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Figure 3. CY4532 EZ-PD CCG3PA EVK Architecture Block Diagram 
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While the CY4532 EZ-PD CCG3PA EVK’s Main Board consists of the CCG3PA device, Type-C, and Type-A ports and 

a debug header, the Power Board consists of the following:  

▪ DC Input Terminal 

▪ Battery Input Terminal 

▪ Micro-USB interface for: 

 Providing a connection from a host PC to Type-C devices (connected to the Type-C Receptacle of the Power 

Board) via the USB-Serial and CCG4 devices over the CC line 

 Providing a connection from a host PC to the CCG3PA device on the Main Board for downloading/upgrading 

firmware 

 Powering the board when the DC Input Terminal and Battery Input Terminal are not used 

▪ Type-C port (to connect CMG1 based passive EMCA cables for configuration and testing) 

▪ Regulators (to support battery charging and provide power for the Type-C interface) (not used in this application) 

  

http://www.cypress.com/
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2.2 CMG1 Manufacturing Test Kit (MKT) Hardware Setup 

This section describes the hardware connections that are required for successfully running the CMG1 MTK Utility to 

configure and test CMG1 based passive EMCA cables. Figure 4 and Figure 5 show the necessary connections.  

As shown in Figure 4, a PC running the EZ-PD Configuration Utility is connected to a CY4532 EZ-PD CCG3PA EVK’s 

Power Board using a Type-A to Type-B micro-B USB cable. The CMG1 based passive EMCA cable is connected to 

the Type-C receptacle of the CY4532 EZ-PD CCG3PA EVK’s Power Board.  

The CMG1 MTK Utility is included with the EZ-PD Configuration Utility. It can configure and test up to 10 CMG1 based 

passive EMCA cables in parallel. In the case where it is required to configure and test more than 1 CMG1 based passive 

EMCA cable at once, a SuperSpeed hub (click here for a recommended hub) must be connected as shown in  

Figure 5.  

Figure 4. System Level Setup for Running the EZ-PD Configuration Utility (Single CMG1 Based Passive EMCA Cable) 
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http://www.cypress.com/
https://www.amazon.com/Plugable-10-Port-Adapter-Flip-Up-Charging/dp/B00JEPIOOQ?th=1
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Figure 5. System Level Setup for Running the EZ-PD Configuration Utility (Multiple CMG1 Based Passive EMCA Cables) 
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An overview of the EZ-PD Configuration Utility and its included EZ-PD CMG1 MTK Utility is provided in the CMG1 MTK 

Utility section.  

 

http://www.cypress.com/
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3 Software Tool for CMG1 Based Application Specific Configuration and 
Testing 

This section provides an overview of using the EZ-PD Configuration Utility and the included CMG1 MTK Utility with 

CMG1 based EMCA cables. CMG1 devices contain only 40 bytes of NVL which is used for storing configuration data. 

Since there is no firmware development necessary, CMG1 devices are not supported in any other Cypress tools such 

as PSoC Creator™ or PSoC Programmer. 

3.1 EZ-PD Configuration Utility and CMG1 MTK Utility 

The EZ-PD Configuration Utility is a Windows application that configures parameters stored in the configuration table 

areas of the internal flash memory of a CCGx device. Version 1.1 Beta (or later) also integrates and supports the CMG1 

MTK Utility. Vendor specific and cable specific parameters can be set using the EZ-PD Configuration Utility. Once 

parameters are set, the CMG1 MTK Utility is used for configuration and testing of CMG1 based passive EMCA cables. 

The CMG1 MTK Utility is accompanied with a CMG1 MTK specific firmware solution which is intended for the CCG4 

device present on the CY4532 EZ-PD CCG3PA EVK’s Power Board. A high-level block diagram of how the CMG1 

MTK Utility communicates with the CMG1 based passive EMCA cable is shown in Figure 6. 

Figure 6. CMG1 MTK Utility Block Diagram 
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The CCG4 device based CMG1 MTK specific firmware implements a unique application ID for the EZ-PD Configuration 

Utility to run the MTK based firmware. It allows the CMG1 MTK Utility to detect connected CMG1 based passive EMCA 

cables once it receives MTK configuring initiation commands.  

http://www.cypress.com/
http://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
http://www.cypress.com/products/psoc-programming-solutions
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You can download and install the EZ-PD Configuration Utility containing the CMG1 MTK Utility from the Cypress 

website. After installation, launch the utility from the following location in the Windows Start Menu: All Programs > 

Cypress > EZ-PD Configuration Utility > EZ-PD Configuration Utility. Figure 7 shows the initial view of the utility. 

Figure 7. EZ-PD Configuration Utility Start Page 

 

 

The following are the key features of the CMG1 MTK Utility supplied as a part of EZ-PD Configuration Utility: 

1. Allows configuration of CMG1 based EMCA cables. Cable configuration information can be saved in the form of 

an xml file 

2. Allows testing of CMG1 based EMCA cables 

3. Detects and communicates with up to 10 CMG1 based EMCA cables. It can configure and test the attached CMG1 

based passive EMCA cables independently in parallel 

4. Provides options to start and stop tests 

5. Reports status of individually connected CMG1 based EMCA cables 

6. Provides a consolidated test report 

7. Conducts testing of 10 CMG1 based EMCA cables in parallel within a time frame of 10 seconds 

See Chapter 4 of the EZ-PD Configuration Utility User Manual for more details on how to configure and test CMG1 

based passive EMCA cables. 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/file/183686/download
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4 Example Showing Configuration and Test of a CMG1 Based Passive EMCA 
Cable  

This section provides a simple example of how to use the EZ-PD Configuration Utility including the CMG1 MTK Utility 

and the associated hardware to configure and test a CMG1 based passive EMCA cable.  

From a top-level perspective, the process of configuring and testing CMG1 based EMCA cables using the CMG1 MTK 

Utility can be summarized in four steps:  

1. Update the firmware of the CCG4 device on the CY4532 EZ-PD CCG3PA EVK’s Power Board and configure an 

MTK Tester ID. This step only needs to be done once to configure the CCG4 device on the CY4532 EZ-PD 

CCG3PA EVK’s Power Board. 

2. Connect the CMG1 based passive EMCA cable with the necessary hardware (CY4532 EZ-PD CCG3PA EVK 

Power Board) and a PC running the EZ-PD Configuration Utility. 

3. Create and save a configuration file (.cyacd format) for the connected CMG1 based passive EMCA cable using 

the EZ-PD Configuration Utility. 

4. Configure and test the connected CMG1 based passive EMCA cable using the CMG1 MTK Utility. 

The following sections explain the steps detail. 

4.1 Update Firmware of CCG4 Device on CY4532 EZ-PD CCG3PA EVK and Configure MTK 
Tester ID 

This section describes the steps to update the firmware of the CCG4 device on the CY4532 EZ-PD CCG3PA EVK’s 

Power Board. This firmware update of CCG4 device enables the EZ-PD Configuration Utility running on the host PC to 

successfully communicate with a CMG1 based passive EMCA cable connected to the CY4532 Power Board(s) (as 

covered in Figure 6 earlier). This section also covers setting up a unique MTK Tester ID for the CCG4 device on CY4532 

EZ-PD CCG3PA EVK’s Power Board. The MTK Tester ID configuration helps identify each MTK hardware uniquely 

when more than one CY4532 EZ-PD CCG3PA EVK Power Boards are connected for running the MTK Test setup on 

multiple CMG1 based passive EMCA cables at a time. 

4.1.1  Updating the Firmware of  the CCG4 Device  

Follow these steps to update the firmware of the CCG4 device on the CY4532 EZ-PD CCG3PA EVK’s Power Board: 

1. Download and install the latest version of the EZ-PD Configuration Utility that supports the CMG1 MTK Utility. 

2. On the CY4532 EZ-PD CCG3PA EVK, carefully unmount the CCG3PA main board from the power board.  

3. Remove the shunts on Jumpers J6, J7, and J9 of the CY4532 EZ-PD CCG3PA EVK Power Board. Your jumper 

settings should look like the jumper settings listed in Table 2. 

Table 2. Jumper Settings for Updating Firmware of CCG4 Device on CY4532 EZ-PD CCG3PA EVK Power Board 

Jumper Header Status 

J6 Open 

J7 Open 

J9 Open 

J14 
NA (The Power LED is powered only when 
power is provided via the DC Input terminal) 

 

4. The position of the Input Power Selection Switch SW1 does not matter since power will be provided by the host 

PC over the micro-B USB cable. 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools
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5. Connect a USB Type-A to Micro-B cable from a host PC to connector J12 on the Power Board as shown in 

Figure 8. 

Figure 8. Updating the Firmware of the CCG4 Device on the CY4532 EZ-PD CCG3PA EVK Power Board 

 

 

6. Launch the EZ-PD Configuration Utility as shown in Figure 9 from: Start > All Programs > Cypress > EZ-PD 

Configuration Utility > EZ-PD Configuration Utility. 

Figure 9. EZ-PD Configuration Utility 
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7. Select Tools > Firmware Update to update the firmware of the CCG4 device as shown in Figure 10. For more 

details, see the Utility’s User Manual available on the EZ-PD Configuration Utility webpage. You can also click 

Help > User Manual in the EZ-PD Configuration Utility to access this user manual. 

Figure 10. Firmware Update Using EZ-PD Configuration Utility 

 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools
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8. In the new window that pops up, provide the file location of the firmware that needs to be programmed in the CCG4 

device. If the folder selected in step 1 was the default location of C:\Program Files (x86)\Cypress, then the required 

firmware is in the following local directory: C:\Program Files (x86)\Cypress\EZ-PD Configuration 

Utility\Firmware\MTK.  

Select NOTEBOOK from the target list shown in Figure 11, and then click Browse next to the Firmware path 1 

text field and browse to the local directory where EZ-PD Configuration Utility was installed. Double-click  the 

CYPD4126-40LQXI_mtk_1.cyacd file to select it. Similarly, select the CYPD4126-40LQXI_mtk_2.cyacd file for 

Firmware path 2.  

Note: Two .cyacd files are required for programming the CCG4 device because the CCG4 device flash is organized 

in two 64-kB banks each with a separate copy of the firmware. 

Figure 11. Updating CCG4 Device’s Firmware Using EZ-PD Configuration Utility 

 

9. Select the option Use bootloader to flash. Click Program after ensuring that all settings are correct.  

http://www.cypress.com/
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Upon clicking Program, the firmware update process starts. The status bar at the bottom of the utility shows the 

progress as shown in Figure 12. This firmware update process can take up to six minutes to complete. The flash 

of the CCG4 device’s first flash bank is updated first, and is followed by an update of the second bank. 

Warning: Do not disconnect the CY4532 EZ-PD CCG3PA EVK’s Power Board while the firmware update is in 

progress.  

Figure 12. Status Bar Showing Firmware Update Progress 

 

10. Upon successful completion of the firmware update process, a window with the message “Flash updated 

successfully” is displayed as shown in Figure 13. Click OK. 

Figure 13. Completion of Firmware Update Process 

 

11. The firmware update process of the CCG4 device is now complete. Recycle power to the CY4532 EZ-PD CCG3PA 

EVK’s Power Board by disconnecting and reconnecting the Micro-B USB cable from connector J12 of the power 

board. Do not close the EZ-PD Configuration Utility window to allow setting up of the MTK Tester ID. 

http://www.cypress.com/
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4.1.2  Configuring the MTK Tester ID for the CCG4 Device on the CY4532 EZ-PD CCG3PA EVK 

Once the CCG4 device’s firmware is updated, the MTK Tester ID needs to be set in the user parameters of the CCG4 

device to help identify each MTK hardware uniquely when multiple configuration and test operations of CMG1 based 

passive EMCA cables is in progress. Follow these steps to configure the MTK Tester ID in the CCG4 device: 

1. As a continuation from the previous section, select File > Read from Device to read the CCG4 device’s 

configuration parameters as shown in Figure 14. 

Figure 14. Read Configuration Parameters of CCG4 Device 

  

2. In the Read From Device pop-up window, observe that the application type of the CCG4 device is updated to MTK. 

Select MTK from the target list as shown in Figure 15, and select the option Use bootloader to read. Click Read 

after ensuring all settings are correct.  

Figure 15. Reading CCG4 Device’s Configuration Parameters 
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3. The existing configuration parameters will now be read and displayed in the EZ-PD Configuration Utility under 

CCGx Configuration in the left panel. Device configuration parameters are sub-classified into Device Parameters, 

Port Parameters, and User Parameters. As shown in Figure 16, scroll down to the bottom of the left panel and 

select User Parameters. 

Figure 16. Reading User Parameters of CCG4 Device 

 

4. There is a total of eight 4-byte parameters listed under the User Parameters group with the default value of each 

set to 0x00000000. Parameter 1 pertains to the MTK Tester ID. Update the value of Parameter 1 highlighted in 

Figure 16 with the desired Tester ID value. Any value can be used if it is unique for all CY4532 EZ-PD CCG3PA 

EVK Power Boards that will be used simultaneously for configuration and testing. 
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5. Click File > Save As and browse to a local directory to save the modified configuration parameters of the CCG4 

device as shown in Figure 17. The modified configuration parameters are saved as an xml file. By default, the 

.cyacd and the .c files will also be saved at the same location. 

Figure 17. Saving Modified Configuration Parameters of CCG4 Device 

 

http://www.cypress.com/


 

Getting Started with EZ-PD CMG1 
 

www.cypress.com Document No. 002-21499 Rev. ** 19 

6. Next, update the saved parameters in the CCG4 device. To do that, click Tools > Configure Device as shown in 

Figure 18. If a pop-up message “Do you want to save the current configuration?” appears, it means that you did 

not save the modified parameters in the previous step or you have modified the configuration parameters after 

saving them initially. Click Yes on the message box if it appears and save the modified parameters.  

Figure 18. Configuring CCG4 Device with the Modified Parameters 
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7. In the Configure Device pop-up window, select the target device to be configured and provide the configuration file 

path needs to be provided as shown in Figure 19. Select MTK from the target list as shown in Figure 19. Click 

Browse next to the Configuration File text field and browse to the local directory where the .cyacd file was saved 

earlier. Double-click the file to select it. Ensure that the option Use bootloader to flash is unchecked. Click 

Program after ensuring that all settings are correct. 

Figure 19. Configuring CCG4 Device Using EZ-PD Configuration Utility 

 

Upon clicking Program, the process of configuring the device starts. The status bar at the bottom of the utility 

shows the progress. 

Warning: Do not disconnect CY4532 EZ-PD CCG3PA EVK Power Board while the configuration of the device is 

in progress. 

8. Once the process of configuring the device is completed, a window with the message “Flash updated successfully” 

is displayed as shown in Figure 13 earlier. Click OK. 

9. This completes the configuration update of the CCG4 device. Recycle power to the CY4532 EZ-PD CCG3PA 

EVK’s Power Board by disconnecting and reconnecting the Micro-B USB cable from connector J12 of the power 

board. Repeat steps 1 to 3 described earlier in this section to read the CCG4 device’s configuration parameters. 

Verify that the value of Parameter 1 under User Parameters is set to the desired MTK Tester ID value set in step 

4 earlier.  

10. This completes setting up of the MTK Tester ID value in the CCG4 device on the CY4532 EZ-PD CCG3PA EVK 

Power Board. Repeat the above steps for setting up the MTK Tester ID value for other MTK hardware if required. 

Close the EZ-PD Configuration Utility and click No when prompted to save the current configuration. 

4.2 System Level Setup for Configuration and Test of a CMG1 Based Passive EMCA Cable 

This section describes the steps to setup the hardware and software needed for configuring and testing CMG1 based 

passive EMCA cables.  

1. Download and install the latest version of the  EZ-PD Configuration Utility that supports CMG1 MTK Utility if not 

done already in the previous section. 
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2. If already mounted, carefully unmount the CCG3PA main board from the power board. Ensure that the jumper 

settings on the CY4532 EZ-PD CCG3PA EVK Power Board are as shown in Figure 20. 

Figure 20. CY4532 EZ-PD CCG3PA EVK Power Board Jumper Settings 

 

3. It is assumed that the CCG4 device of the CY4532 EZ-PD CCG3PA EVK is already updated with the firmware that 

supports the MTK Utility prior to this step. Follow steps in the previous sections if firmware is not yet updated or if 

you are unsure which firmware is currently loaded in the CCG4 device of the CY4532 EZ-PD CCG3PA EVK Power 

Board. 

4. In this example, you will configure and test one CMG1 based EMCA cable. Connect the CMG1 based passive 

EMCA cable to the CY4532 EZ-PD CCG3PA EVK Power Board as shown in Figure 4 earlier and repeated in 

Figure 21. 

Figure 21. System Level Setup for Running the EZ-PD Configuration Utility (Single CMG1 based Passive EMCA Cable) 
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The system level setup for configuring and testing one CMG1 based passive EMCA cable is now complete. For multiple 

CMG1 based passive EMCA cables, your setup up should look like the setup shown in Figure 5.  

4.3 Create and Save a Configuration File (.cyacd format) Using the EZ-PD Configuration 
Utility 

This section guides you through creating a configuration file in .cyacd format for the CMG1 based passive EMCA 

cable/s using the EZ-PD Configuration Utility supporting the CMG1 MTK Utility. The system level setup that was 

completed in the previous sections will be used as a starting point for this section. 

1. Ensure that system level setup as described in Update Firmware of CCG4 Device on CY4532 EZ-PD CCG3PA 

EVK and System Level Setup for Configuration and Test of a CMG1 Based Passive EMCA Cable is completed. 

2. Launch the EZ-PD Configuration Utility from: Start > All Programs > Cypress > EZ-PD Configuration Utility > 

EZ-PD Configuration Utility. 

3. Click File > New. In the new pop-up window, the Device Type lists the CCGx devices. Select the CMG1 from the 

Device Type the drop-down list. Once selected, select Passive Cable as the application type. Click Create 

Project after ensuring that your selections in the pop-up window look like the window shown in Figure 22. 

Figure 22. Creating New Project in EZ-PD Configuration Utility 
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Upon clicking Create Project, the new project is created and is displayed in the utility in a tree under CCGx 

Configuration in the left panel as shown in Figure 23. A new tab CMG1: Passive Cable opens in the right panel 

of main window of the EZ-PD Configuration Utility. The project title is also highlighted in the bottom right hand side 

of EZ-PD Configuration Utility window. 

Figure 23. Creating New CMG1 Passive Cable Project in the EZ-PD Configuration Utility 
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4. The CMG1 passive cable parameters are classified under Device parameters and Port parameters. Select Device 

Parameters in the left panel. The EZ-PD Configuration Utility window will look like the window shown in Figure 24.  

Figure 24. Setting Device Parameters for a CMG1 Passive Cable Project 

 

As shown in Figure 24, several parameters like the Manufacturer Info, USB Vendor ID, Product ID, Configuration 

table major version, SVID available, Lock configuration, and PD3.0 enable can be set under the Device 

Parameters selection using the drop-down menu next to each parameter. For cable manufacturers who are 

creating a configuration file for final production of CMG1 based passive EMCA cables, it is important to note that 

the Lock Configuration parameter should be set to Yes. Enabling the lock configuration feature freezes all the 

configuration parameters once the steps for configuration and test are complete and those CMG1 based passive 

EMCA cables cannot be re-configured/tested in the future. Make the desired changes to the parameters for your 

CMG1 based EMCA passive cable. 
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5. Next, in the left panel, click Cable VDO under Port 0 > Discover Identity. The EZ-PD Configuration Utility window 

will look like the window shown in Figure 25. In right side panel, you can configure Vendor Defined Object (VDO) 

related parameters specific to the cable. Parameters like cable hardware and firmware versions, cable type (Type-

C to Type-A/Type-B/Type-C), connector type (plug or receptacle), cable termination, and so on can be set using 

the drop-down menu next to each parameter.  

Figure 25. Setting Cable VDO of CMG1 Passive Cable Project 
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6. After setting the configurations of the desired parameters, save the newly created project. Click on File > Save As 

and browse to a local directory to save the configured project as shown in Figure 26. The updated configuration 

parameters are saved as an xml file. By default, the .cyacd and the .c files will also be saved at the same location.  

Figure 26. Saving Configuration of CMG1 Passive Cable Project 

 

This completes the creation process of the configuration file for a CMG1 based passive EMCA cable. 
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4.4 Configure and Test a CMG1 based Passive EMCA Cable Using the MTK inside the EZ-PD 
Configuration Utility 

The next step is to use the EZ-PD Configuration Utility to configure and test the CMG1 based passive EMCA cable 

connected to the Manufacturing Test Kit setup. Follow these steps in continuation with the steps in the Create and Save 

a Configuration File (.cyacd format) Using the EZ-PD Configuration Utility section. 

1. If you are continuing from the steps described in previous section, select the menu item Tools > Manufacturing 

Test Kit Tab as shown in Figure 27. If you are re-launching the EZ-PD Configuration Utility, click File > Open and 

browse to the local directory to load the previously saved CMG1 based passive EMCA cable configuration file in 

xml format. Once opened, select the menu item Tools > Manufacturing Test Kit Tab as shown in Figure 27. 

Figure 27. Opening the Manufacturing Test Kit Tab in EZ-PD Configuration Utility 
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This opens a new Manufacturing Test Kit tab in the main window of the EZ-PD Configuration Utility which will 

look like the window shown in Figure 28. CMG1 based passive EMCA cables can be configured and tested using 

this tab. 

Figure 28. View of Manufacturing Test Kit Tab in the EZ-PD Configuration Utility 

 

As highlighted in Figure 28, the input file to this tab is the configuration file of the CMG1 based passive EMCA 

cable in .cyacd format. You can start or stop configuration of the connected CMG1 based passive EMCA cables 

using Start or Stop. You can also refresh the list of CMG1 based passive EMCA cables connected using Refresh. 

From the Settings options, you can select whether to configure the connected cable/s or to just test them. The 

field also provides the ability to stop an already running test upon detection of failure.  

In the display window, a table listing CMG1 based passive EMCA cables connected to the Manufacturing Test Kit 

setup is shown. It lists the Serial Number of the connected MTK hardware, Tester ID of the connected MTK 

hardware, Cable ID of the connected CMG1 based passive EMCA cable, its current status 

(Pass/Fail/Configuring/Testing), and corresponding LED color and Open report to open the report of an already 

tested CMG1 based passive EMCA cable. You can click Open report to view the logs and reports of each 

completed test that are saved by the EZ-PD Configuration Utility. 

A message window in the lower half of the EZ-PD Configuration Utility displays progress of the configuration or 

the test activities. 

2. Click Browse next to the Configuration cyacd path text field and browse to the local directory where your saved 

configuration file in .cyacd format is located. 

3. Select the options under Settings for the desired action to Configure and Test the CMG1 based passive EMCA 

cable. Click Start. 
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Upon clicking Start, the EZ-PD Configuration Utility will execute the steps selected in the Settings fields to 

configure and/or test the CMG1 based passive EMCA cable connected to the MTK setup. Once configuration and 

testing is completed, the EZ-PD Configuration Utility window running the MTK test will look like the window shown 

in Figure 29. If multiple CMG1 based passive EMCA cables have been connected, they will also be listed in the 

display window and the EZ-PD Configuration Utility window running the MTK test will look like the window shown 

in Figure 30. 

Figure 29. Completion of Configuration & Testing of a Single CMG1 based Passive EMCA cable 

 

Figure 30. Completion of Configuration and Testing of Multiple CMG1 based Passive EMCA Cables 
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4. Once the table in the display window is populated with results, the configuration and testing activity of the 

connected CMG1 based passive EMCA cable is complete. You have two options at this point: 

Option 1: Without clicking any button or changing any setting on the Manufacturing Test Kit tab that is already 

open, detach the already configured CMG1 based passive EMCA cable and connect the next CMG1 based passive 

EMCA cable that needs to be configured, tested, or both. This option allows configuring and testing of multiple 

CMG1 based passive EMCA cables in series without modifying anything on the EZ-PD Configuration Utility. Also, 

while the CMG1 based passive EMCA cable that has just finished configuring and testing is waiting to be detached, 

the CMG1 MTK Utility enters a wait state, that is, waiting for the configured cable to be detached and new cable 

to be attached. This feature is beneficial if you have limited number of CY432 EZ-PD CCG3PA EVK Power Boards 

and several CMG1 based passive EMCA cables to configure and test. 

Option 2: Click Stop to end the configure and test process. This is for a scenario where you need to just configure 

and test a single CMG1 based passive EMCA cable.  

5. If you prefer Option 1, once the desired set of CMG1 based passive EMCA cables are configured and tested, click 

Stop to end the process.  

6. If required, view the Message window to observe progress of the completed configuration and test of the connected 

CMG1 based passive EMCA cables. Click Close at top right corner to close the Manufacturing Test Kit tab. 

7. See Chapter 4 of the EZ-PD Configuration Utility User Manual on the EZ-PD Configuration Utility webpage to learn 

more about the CMG1 MTK Utility. You can also select menu item Help > User Manual in the EZ-PD Configuration 

Utility to access this user manual. 
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