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作者： Vihang Trivedi 

相关器件系列：CYPD270x 

相关软件：EZ-PDTM 配置工具 

相关的应用笔记：AN210403、AN200210、AN218179  
 

AN221499 介绍了 USB Type-C EZ-PD™ CMG1 控制器。它简要介绍 CMG1 架构及它的功能和应用，同时也将制造测

试工具包（MTK）作为配置工具进行了详细描述。本文档还参考了其他设计资源，以帮您快速设计无源电子标记电缆

组件（EMCA）电缆。  
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1 简介 

EZ-PD CMG1 是一个专用的 USB Type-C EMCA 控制器。它符合 USB Type-C 和电源供应（PD）标准，并适用于电子

标记 Type-C 无源线缆应用。EZ-PD CMG1 集成了一个完整的 Type-C 收发器，包括 VCONN 引脚上的 RA终端电阻以

及 VCONN 和 CC 引脚上的 VBUS 短路保护。CMG1 还包含 40 字节的非易失性锁存器（NVL），用于配置供应商、器

件和线缆特定的配置数据。EZ-PD CMG1 适用于无源 EMCA 实现，电缆上带有一个或两个电子标记芯片。 

有关 CMG1 器件支持的各种 EMCA 执行的应用框图，请参阅 CMG1 数据手册。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&keywords=ez-pd%20config
http://www.cypress.com/documentation/application-notes/an210403-hardware-design-guidelines-dual-role-port-applications
http://www.cypress.com/documentation/application-notes/an200210-getting-started-ez-pdtm-ccg3
http://www.cypress.com/documentation/application-notes/an218179-getting-started-ez-pdtm-ccg3pa
http://www.cypress.com/cmg1ds
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1.1 EZ-PD CMG1 性能 

▪ 支持 Type-C 和 USB-PD 

 支持 USB PD3.0 规范和 USB Type-C 规范版本 1.3（包括修订后最小工作电压为 3 V 的 VCONN） 

 集成高压保护的 CC、VCONN1 和 VCONN2，用于防止对 Type-C 连接器上 VBUS 引脚的意外短路 

 通过 Type-C 接口可编程的 40 字节非易失性锁存器，用于存储供应商、器件和线缆特定配置数据 

 VCONN1 和 VCONN2 上的终端电阻 RA 

 支持 RA弱化，从而降低功耗 

 支持需要一个或两个控制器的电子标记无源线缆 

▪ 时钟和振荡器 

 集成振荡器，这样便不再需要外部时钟 

▪ 电源 

 工作电压范围为 2.7 V 到 5.5 V，睡眠电流为 1 mA 

▪ 系统级 ESD 保护 

 位于配置通道（CC）、VCONN1 和 VCONN2 引脚 

 根据 IEC61000-4-2 的 4C 级标准，接触放电为±8 kV，且气隙放电为±15 kV。 

▪ 封装 

 9 ball WLCSP 

 支持工业级温度范围（-40 °C 到+85 °C）       

http://www.cypress.com/
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1.2 CMG1 框图 

图 1 显示了 CMG1 架构的框图。更多详细信息，请参阅 CMG1 数据手册。  

图 1. CMG1 架构框图 
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1.3 先决条件 

本节列出了 CMG1 器件入门要求使用的各种硬件和软件。  

1.3.1  硬件  

▪ CY4532 EZ-PD CCG3PA 评估套件（EVK） 的电源板 

▪ 带有 Windows 7 或更高版本的 PC 以及至少一个 Type-A USB 端口  

▪ 基于 CMG1 的无源 EMCA 线缆 

▪ 10 个端口的 USB 3.0 超速集线器 （选配，仅要求同时配置/测试基于 CMG1 的多个无线 EMCA 线缆时需要） 

1.3.2  软件  

▪ 带有 CMG1 制造测试套件（MTK）工具的 EZ-PD 配置工具（版本 1.1 Beta 或更高） 

http://www.cypress.com/
http://www.cypress.com/cmg1ds
http://www.cypress.com/cy4532
https://www.amazon.com/Plugable-10-Port-Adapter-Flip-Up-Charging/dp/B00JEPIOOQ?th=1
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
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1.4 CMG1 的设计流程 

本节介绍了在基于 CMG1 无源 EMCA 线缆的应用开发和测试期间，线缆制造商将经历的典型设计流程。它还介绍了如

何将本应用笔记中所描述的每个硬件和软件资源使用于整个设计流程。图 2 显示的是通过使用 CMG1 器件来制造无源

EMCA 线缆的典型设计流程。 

图 2. CMG1 的设计流程 
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http://www.cypress.com/
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一旦确定了基于 CMG1 的线缆应用（1 个芯片/电缆或 2 各芯片/电缆）并检查了参考的设计，您就可以开始设计流程的

硬件开发阶段。 

硬件流程包括构建基于最终应用的原理图，以及设计 paddle 卡，以便为下一阶段准备好一些原型。可以根据赛普拉斯

CMG1 网页提供的参考设计来构建原理图。 

您可以使用 CY4532 EZ-PD CCG3PA 评估套件（EVK）电源板来开始配置和测试阶段。通过 EZ-PD 配置工具可以为

EMCA 线缆的 CMG1 器件创建配置文件（.cyacd），例如，更新电源数据对象（PDO）和供应商 ID。  

配置创建后，EZ_PD 配置工具中包含的 CMG1 MTK 工具将被用于配置（即编程）和测试所设计的线缆。使用 MKT 工

具可以同时配置和测试多达 10 条线缆。更多有关 CMG1 MTK 工具的信息，请参阅 EZ-PD 配置工具用户手册中的第四

章节。  

硬件和配置以及测试流程完成后，现有的系统设计可就绪用于大规模生产。  

1.5 CMG1 资源 

表 1 列出了有助于通过 CMG1 设计最终应用的 web 可用资源。 

表 1. CMG1 设计资源 

类别  可用资源 

数据手册 CMG1 数据手册 

硬件 CY4532 EZ-PD CCG3PA EVK — 包含 CY4532 CCG3PA EVK 电源板的相关文档和设计文件 

主机 PC 软件配置和测试工具 
EZ-PD 配置工具 1.1 Beta 或更高版本（基于 GUI Windows 应用有助于配置和测试基于 CMG1 的无

源 EMCA 线缆）用于运行 CMG1 制造测试套件（MTK）工具 

参考设计 基于 CMG1 的参考设计 

2 CMG1 硬件的详细内容 

本节对用于配置和测试基于CMG1的无源EMCA线缆的硬件进行讨论。CY4532 EZ-PD CCG3PA EVK电源板是CMG1 

MTK 安装包的关键组件。本节中将对它进行详细的讨论。 

2.1 CY4532 EZ-PD CCG3PA EVK 

CY4532 EZ-PD CCG3PA EVK 支持移动电源适配器、PC 电源适配器、移动电源、车载充电器以及其他主要通过

Type-C 接口为其他设备充电的应用。该套件适用于 Type-C 连接器的 USB 主机系统评估工具。有关 EVK 用例的深入

信息，请参阅“CY4532 EZ-PD CCG3PA EVK 用户指南”。 

CY4532 EZ-PD CCG3PA EVK 由一个电源板和一个主板组成。CCG3PA 被安装在主卡上，该主卡与电源板相连，用于

评估 CCG3PA 器件的 Type-C 端口功能。图 3 显示了 CY4532 EZ-PD CCG3PA EVK 架构的框图。对于 CMG1 MTK 测

试安装时，本节将没有进一步介绍 CY4532 EZ-PD CCG3PA EVK 的主板，而仅详细描述 CY4532 EZ-PD CCG3PA 

EVK 电源板。  

http://www.cypress.com/
http://www.cypress.com/cmg1
http://www.cypress.com/cy4532
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/file/183686/download
http://www.cypress.com/cmg1ds
http://www.cypress.com/cy4532
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/products/usb-type-c-and-power-delivery#tabs-0-bottom_side-6
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图 3. CY4532 EZ-PD CCG3PA EVK 架构框图 
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CY4532 EZ-PD CCG3PA EVK 主板由 CCG3PA 器件、Type-C 和 Type-A 端口以及一个调试插座组成，而该套件的电

源板的组成成分如下：  

▪ 直流输入终端 

▪ 电池输入终端 

▪ Micro-USB 接口，用于： 

 通过 USB-Serial 连接 CCG4器件的 CC线可以将一个主机 PC与 Type-C设备连接（连接到电源板的 Type-C插

座） 

 可以将主机 PC 连接到主板上的 CCG3PA 器件，用以下载/升级固件 

 不使用直流输入终端和电池输入终端时，可为主板供电 

▪ Type-C 端口（以连接用于配置和测试的基于 CMG1 无源 EMCA 线缆） 

▪ 电压调节器（支持电池充电以及为 Type-C 接口供电）（不使用于该应用中） 

  

http://www.cypress.com/
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2.2 CMG1 制造测试套件（MTK）的硬件安装 

本节描述了在运行 CMG1 MTK 工具来配置和测试基于 CMG1 无源 EMCA 线缆时所需要的硬件连接。图 4 和图 5 显示

了所需要的连接。  

如图 4 所示，通过使用 Type-A 到 Type-B micro-B USB 线缆可以将运行 EZ-PD 配置工具的 PC 连接到 CY4532 EZ-PD 

CCG3PA EVK 电源板。基于 CMG1 的无源 EMCA 线缆被连接到 CY4532 EZ-PD CCG3PA EVK 电源板的 Type-C 插

座。  

CMG1 MTK 工具包含在 EZ-PD 配置工具中。它可以并行实现配置和测试多达 10 个基于 CMG1 无源 EMCA 线缆。如果

需要一次配置和测试多个基于 CMG1 的无源 EMCA 线缆，则必须与一个超速集线器连接（点击此处查看推荐集线器），

如图 5 所示。  

图 4. 运行 EZ-PD 配置工具的系统级设置（单个基于 CMG1 的无源 EMCA 线缆） 
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http://www.cypress.com/
https://www.amazon.com/Plugable-10-Port-Adapter-Flip-Up-Charging/dp/B00JEPIOOQ?th=1
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图 5. 运行 EZ-PD 配置工具的系统级设置（多个基于 CMG1 的无源 EMCA 线缆） 
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CMG1 MTK 工具部分将对 EZ-PD 配置工具以及其包含的 EZ-PD CMG1 MTK 工具进行了概述。  

 

http://www.cypress.com/
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3 基于 CMG1 的应用特定配置和测试软件工具 

本节介绍了使用 EZ-PD 配置工具和附带的 CMG1 MTK 工具以及基于 CMG1 的 EMCA 线缆的概述。CMG1 器件仅包含

40 个字节的 NVL，用于存储配置数据。由于不需要固件开发，所以其他赛普拉斯工具（例如 PSoC Creator™或 PSoC 

Programmer）不支持 CMG1 器件。 

3.1 EZ-PD 配置工具和 CMG1 MTK 工具 

EZ-PD 配置工具是一个 Windows 应用，用于配置存储在 CCG4 器件 Flash 存储器中配置表区域的参数。版本 1.1 Beta

（或更高版本）还集成和支持 CMG1 MTK工具。通过 EZ-PD配置工具可以设置供应商和线缆特定的参数。各参数被设

置好后，CMG1 MTK 工具将被用于配置和测试基于 CMG1 的无源 EMCA 线缆。CMG1 MTK 工具附带的 CMG1 MTK

特定固件解决方案适用于 CY4532 EZ-PD CCG3PA EVK 电源板上的 CCG4 器件。CMG1 MTK 工具与基于 CMG1 的无

源 EMCA 线缆通信的详细框图如图 6 所示。 

图 6. CMG1 MTK 工具框图 
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基于 CCG4 器件的 CMG1 MTK 特定固件将执行 EZ-PD 配置工具的唯一应用 ID，以运行基于 MTK 的固件。它允许

CMG1 MTK 工具在收到 MTK 配置启动命令后检测基于 CMG1 的无源 EMCA 线缆。  

http://www.cypress.com/
http://www.cypress.com/products/psoc-creator-integrated-design-environment-ide
http://www.cypress.com/products/psoc-programming-solutions
http://www.cypress.com/products/psoc-programming-solutions
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您可以从赛普拉斯网页上下载和安装附带 MG1 MTK 工具的 EZ-PD 配置工具。安装成功后，通过 Windows Start Menu

中的以下路径：All Programs > Cypress > EZ-PD Configuration Utility > EZ-PD Configuration Utility，可以启动

该工具。图 7 显示的是工具的初始窗口。 

图 7. EZ-PD 配置工具起始页 

 

 

以下是作为 EZ-PD 配置工具附带的 CMG1 MTK 工具的主要功能： 

1. 允许配置基于 CMG1 EMCA 线缆。可以将线缆配置信息存储在 xml 格式文件中 

2. 允许测试基于 CMG1 的 EMCA 线缆 

3. 可以对多达 10 个基于 CMG1 的 EMCA 线缆进行检测和通讯，它可以独立和并行地实现配置和测试多达 10 个基于

CMG1 无源 EMCA 线缆。 

4. 提供测试启动和停止选项 

5. 报告基于 CMG1 EMCA 线缆的单独连接状态 

6. 提供综合测试报告 

7. 可在 10 秒的时间范围内并行测试 10 条基于 CMG1 的 EMCA 电缆 

有关如何配置和测试基于 CMG1 的无源 EMCA 线缆的更多详细信息，请参阅 EZ-PD 配置工具用户手册的第 4 章。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility
http://www.cypress.com/file/183686/download
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4 显示基于 CMG1 的无源 EMCA 线缆的配置和测试的示例  

本节提供了一个简单示例，说明如何使用EZ-PD配置工具中的CMG1 MTK工具和相关的硬件来配置和测试基于CMG1

的无源 EMCA 线缆。  

从顶层角度来看，使用 CMG1 MTK 工具来配置和测试基于 CMG1 的 EMCA 线缆的过程可以概括为四个步骤：  

1. 更新 CY4532 EZ-PD CCG3PA EVK 电源板上的 CCG4 器件的固件并配置 MTK 测试器 ID。这一步是在 CY4532 

EZ-PD CCG3PA EVK 的电源板上配置 CCG4 器件，只要一次操作即可，。 

2. 将基于 CMG1 的无源 EMCA 线缆与必要的硬件（CY4532 EZ-PD CCG3PA EVK 电源板）和运行 EZ-PD 配置工具

的 PC 连接。 

3. 通过使用 EZ-PD 配置工具为已连接的基于 CMG1 无源 EMCA 线缆创建并保存配置文件（.cyacd 格式）。 

4. 使用 CMG1 MTK 工具来配置和测试已连接的基于 CMG1 无源 EMCA 线缆。 

下面各章节详细介绍了各个步骤。 

4.1 更新 CY4532 EZ-PD CCG3PA EVK 上的 CCG4 器件并配置 MTK 测试器 ID 

本节介绍了更新 CY4532 EZ-PD CCG3PA EVK 电源板上的 CCG4 器件固件的步骤。CCG4 器件更新的固件使在主机

PC 上运行的 EZ-PD 配置工具能够与连接到 CY4532 电源板的基于 CMG1 无源 EMCA 线缆成功通信（如图 6 所述）。

本节还介绍为 CY4532 EZ-PD CCG3PA EVK 电源板上的 CCG4 器件设置一个唯一的 MTK 测试器 ID。当多个 CY4532 

EZ-PD CCG3PA EVK 电源板被连接起来以便一次运行多个基于 CMG1 的无源 EMCA 电缆上的 MTK 测试设置时，MTK

测试器 ID 的配置将有助于识别独特的每个 MTK 硬件。 

4.1.1  更新 CCG4 器件的固件  

下面步骤介绍的是更新 CY4532 EZ-PD CCG3PA EVK 电源板上的 CCG4 器件固件。 

1. 下载并安装支持 CMG1 MTK 固件的 EZ-PD 配置工具的最新版本。 

2. 在 CY4532 EZ-PD CCG3PA EVK 电源板上，小心地卸下 CCG3PA 主面板。  

3. 在 CY4532 EZ-PD CCG3PA EVK 电源板上拨出 J6、J7 和 J9 跳线跳线帽，您的跳线器设置应如表 2 列出的跳线器

设置。 

表 2. 用于更新 CY4532 EZ-PD CCG3PA EVK 电源板上的 CCG4 器件固件 

跳线器插座 状态 

J6 开路 

J7 开路 

J9 开路 

J14 
不可用（仅在通过直流输入终端提供电源时

才能为电源 LED 供电） 

 

4. 输入电源选择开关 SW1 的位置并不重要，因为主机 PC 将通过 micro-B USB 线缆提供电源。 

http://www.cypress.com/
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5. 将主机 PC 的 USB Type-A 转 Micro-B 线缆连接到电源板的连接器 J12 如图 8 所示。 

图 8. 在 CY4532 EZ-PD CCG3PA EVK 上更新 CCG4 器件的固件 

 

 

6. 通过图 9 所示的路径：Start > All Programs > Cypress > EZ-PD Configuration Utility > EZ-PD Configuration 

Utility，可以启动 EZ-PD 配置工具。 

图 9. EZ-PD 配置工具 

 

USB Type-A to Micro-B cable 
connected to J12 on the 
CY4532 EVK Power Board

PC/Laptop running 
EZ-PD Configuration 
Utility

http://www.cypress.com/
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7. 依次选择 Tools > Firmware Update，从而更新 CCG4 器件的固件，如图 10 所示。更多详细信息，请参考 EZ-PD

配置工具网页上提供的工具用户指南。您也可以在 EZ-PD 配置工具中依次选择 Help > User Manual 来访问该用户

手册。 

图 10. 使用 EZ-PD 配置工具更新固件 

 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools
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8. 在弹出的新窗口中，可以找到 CCG4 器件中所需编程的固件的文件位置。如果在步骤 1 中选择的文件夹是如下默

认路径 C:\Program Files (x86)\Cypress，则所需的固件位于以下本地目录中：C:\Program Files (x86)\Cypress\EZ-

PD Configuration Utility\Firmware\MTK。  

从图 11 中显示的目标列表中选择 NOTEBOOK，然后单击 Firmware path 1 文本字段旁边的 Browse，以浏览到

EZ-PD 配置工具所安装的本地目录。双击选择 CYPD4126-40LQXI_mtk_1.cyacd 文件。相同，选择 CYPD4126-

40LQXI_mtk_2.cyacd 文件用于 Firmware path 2。  

注意： 编程 CCG4 器件需要两个.cyacd 文件，因为 CCG4 器件闪存包含两个 64 kB 闪存组，每一组有一个单独的

固件副本。 

图 11. 使用 EZ-PD 配置工具更新 CCG4 器件固件 

 

9. 选择 Use bootloader to flash 选项。确保所有设置正确后，单击 Program。  

http://www.cypress.com/
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点击 Program时，将启动固件更新过程。工具底部的状态栏将显示进度情况，如图 12所示。固件更新过程可能需

要最多 6 分钟。CCG4 器件的第一个闪存组会先更新，然后将更新第二个闪存组。 

警告：固件更新过程中，请勿将 CY4532 EZ-PD CCG3PA EVK 电源板拔出。 

图 12. 状态栏显示了固件更新过程 

 

10. 固件更新程序成功完成后，将出现带有“Flash updated successfully”信息的窗口，如图 13 所示。点击 OK。 

图 13. 固件更新过程完成 

 

11. CCG4 器件的固件更新过程已完成。通过从电源板的连接器 J12 断开并重新连接 Micro-B USB 线缆，对 CY4532 

EZ-PD CCG3PA EVK 电源板进行重启。请勿关闭 EZ-PD 配置工具窗口，以执行设置 MTK Tester ID。 

http://www.cypress.com/


 

EZ-PD CMG1 入门手册 
 

www.cypress.com 文档编号：002-23980 版本*A 16 

4.1.2  在 CY4532 EZ-PD CCG3PA EVK 上配置 CCG4 器件的 MTK Tester ID  

更新了 CCG4 器件的固件后，需要在 CCG4 器件的用户参数中设置 MTK Tester ID。这样将有助于在对基于 CMG1 的

无源 EMCA 线缆进行配置和测试操作时，可以识别每个独特的 MTK 硬件。请按照下列步骤来配置 CCG4 器件的 MTK 

Tester ID： 

1. 接下来，依次选择 File > Read from Device，以读取 CCG4 器件的配置参数，如图 14 所示。 

图 14. 读取 CCG4 器件的配置参数 

  

2. 在 Read From Deviced 的弹出窗口中，请注意 CCG4 器件的应用类型已更新为 MTK。在图 15 所列出的目标列表

中选择 MTK，然后选择 Use bootloader to read 项。确保所有设置正确后，单击 Read。  

图 15. 读取 CCG4 器件的现有配置参数 

 

http://www.cypress.com/
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3. 现在，现有的配置参数将被读取并在 EZ-PD 配置工具左侧面板的 CCGx Configuration 下显示。器件配置参数被

分为器件参数、端口参数和用户参数等三类。如图 16 所示，向下滚到左侧底部并选择 User Parameters。 

图 16. 读取 CCG4 器件的用户参数 

 

4. User Parameters 组中列出了共八个 4 字节参数，每个参数的默认值为 0x00000000。Parameter 1 表示 MTK 

Tester ID。将图 16 中所加亮显示的 Parameter 1 更新为所需的 Tester ID 值。被同时使用于配置和测试的所有

CY4532 EZ-PD CCG3PA EVK 电源板都可以使用任何值，只要这个值是唯一用于这些电源板的。 

http://www.cypress.com/
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5. 通过依次选择 File > Save As，浏览到一个用于以保存 CCG4 器件已修改的配置参数的本地目录，如图 17。所修

改的配置参数将被保存为 XML 格式的文件。默认情况下，“.cyacd”文件和“.c”文件也被保存在相同位置。 

图 17. 保存 CCG4 器件所修改的配置参数 
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6. 接下来，更新 CCG4 器件中的保存参数。要实现该操作，依次选择 Tools > Configure Device，如图 18 所示。如

果出现信息“Do you want to save the current configuration?”，则意味着您没有保存上一步修改的参数，或者在

最初保存配置参数后修改了配置参数。在显示信息框上点击 Yes 并保存已修改的参数。  

图 18. 使用已修改的参数配置 CCG4 器件 
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7. 在弹出的 Configure Device 窗口中，选择需要配置的目标器件并提供需要提供的配置文件路径，如图 19 所示。从

图 19 所列出的目标列表中选择 MTK。点击 Configuration File 文本字段旁边的 Browse 按钮，浏览到先前保

存 .cyacd 文件的本地目录。双击选择该文件。请确保取消选择 Use bootloader to flash 选项。确保所有设置正确

后，单击 Program。 

图 19. 使用 EZ-PD 配置工具配置 CCG4 器件 

 

点击 Program 后将启动器件配置过程。工具底部的状态栏显示了进度情况。 

警告：器件配置过程中，请勿将 CY4532 EZ-PD CCG3PA EVK 电源板拔出。 

8. 器件的配置过程完成后，包含“Flash updated successfully”信息的窗口将出现，如前面图 13 所示。点击 OK。 

9. 这时，CCG4 器件的配置更新已经完成了。通过从电源板的连接器 J12 断开并重新连接 Micro-B USB 线缆，对

CY4532 EZ-PD CCG3PA EVK 电源板进行重启。重复本节前面介绍的步骤 1 至步骤 3，以读取 CCG4 器件的配置

参数。请确保 User Parameters 下的 Parameter1 值已被设置为步骤 4 中所设置的所需 MTK Tester ID 值。  

10. 这操作完成了在 CY4532 EZ-PD CCG3PA EVK 电源板上设置 CCG4 器件的 MTK Tester ID。如果需要，重复上述

步骤为其他 MTK 硬件设置 MTK Tester ID 值。要保存当前配置时，关闭 EZ-PD 配置工具并点击 No。 

4.2 基于 CMG1 的无源 EMCA 线缆的配置和测试的系统级设置 

本节描述了配置和测试基于 CMG1 的无源 EMCA 线缆时所需的硬件和软件的各设置步骤。  

1. 下载并安装支持 CMG1 MTK 固件的 EZ-PD 配置工具的最新版本（如果尚未在前一节中实现该操作）。 

http://www.cypress.com/
http://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility?source=search&cat=software_tools


 

EZ-PD CMG1 入门手册 
 

www.cypress.com 文档编号：002-23980 版本*A 21 

2. 如果已经安装了，则请从电源板上仔细地卸下 CCG3PA 主面板。请确保 CY4532 EZ-PD CCG3PA EVK 电源板上

的插座设置如图 20 所示。 

图 20. CY4532 EZ-PD CCG3PA EVK 电源板插座设置 

 

3. 假设在此步骤之前，CY4532 EZ-PD CCG3PA EVK 的 CCG4 器件已经更新了支持 MTK 工具的固件。如果固件尚

未更新，或者您不确定 CY4532 EZ-PD CCG3PA EVK 电源板的 CCG4 器件当前加载了哪个固件，请按照前几节

中的步骤操作。 

4. 在本示例中，您将配置和测试一个基于 CMG1 的 EMCA 线缆。将基于 CMG1 的无源 EMCA 线缆连接到 CY4532 

EZ-PD CCG3PA EVK 电源板，如前面的图 4 所示，并在图 21 重复。 

图 21. 运行 EZ-PD 配置工具的系统级设置（单个基于 CMG1 的无源 EMCA 线缆） 

Host PC Running 

EZ-PD Configuration 

Utility

CMG1 based 

Passive 

EMCA Cable

Micro USB Cable

Type-C InterfaceHost PC

 

SW1 Input Power Selection Switch
(DC Input Position)

J12. USB Micro-B 
Receptacle (Connect to PC 
Running CMG1 MTK Utility)

J13. USB Type-C Receptacle
(Connect to CMG1 based 
Passive EMCA Cable

J6 Mode Selection Jumper
(1-2 Shorted)

J7 Mode Selection Jumper
(1-2 Shorted)

J9 Mode Selection Jumper
(1-2 Shorted)

J14: Power LED Jumper 
(Shorted)
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用于配置和测试一个基于 CMG1 的无源 EMCA 线缆的系统级设置现已完成。对多个基于 CMG1 的无源 EMCA 线缆的

设置应如图 5 所示。  

4.3 通过使用 EZ-PD 配置工具创建并保存配置文件（.cyacd 格式） 

本节将指导您通过使用支持 CMG1 MTK 工具的 EZ-PD 配置工具为基于 CMG1 的无源 EMCA 线缆创建.cyacd 格式的配

置文件。前面几节中完成的系统级设置将作为本节的起点。 

1. 确保按照更新 CY4532 EZ-PD CCG3PA EVK 上的 CCG4 器件进行系统级设置，同时，基于 CMG1 的无源 EMCA

线缆的配置和测试的系统级设置已完成。 

2. 通过下面路径启动 EZ-PD 配置工具：Start > All Programs > Cypress > EZ-PD Configuration Utility > EZ-PD 

Configuration Utility。 

3. 依次点击 File > New。在新弹出的窗口中，Device Type（器件类型）将列出 CCGx 器件。从 Device Type 下拉

列表中选择 CMG1。然后，选择 Passive Cable（无源线缆）为应用类型。确保您的选择如图 22 所示后，点击

Create Project（创建项目）。 

图 22. 在 EZ-PD 配置工具中创建新项目 
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点击 Create Project 后，新项目将被创建并在左侧窗口 CCGx Configuration 项下的工具中显示，如图 23 所示。

CMG1: Passive Cable 新选项卡将显示在 EZ-PD 配置工具主窗口的右侧。项目名称也在 EZ-PD 配置工具窗口的

右下角突出显示。 

图 23. 在 EZ-PD 配置工具中创建新的 CMG1 Passive Cable 项目 
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4. CMG1 无源电缆参数被分为器件参数和端口参数。在左侧面板中选择 Device Parameters（器件参数）。EZ-PD

配置工具的窗口将如图 24 所示。  

图 24. 设置 CMG1 无源线缆项目的器件参数 

 

如图 24 所示，可以在 Device Parameters 项下设置一些参数如 Manufacturer Info（制造商信息）、USB Vendor 

ID（USB 供应商 ID）、Product ID（产品 ID）、Configuration table major version（配置表主要版本）, SVID 

available（可用的 SVID）、Lock configuration（锁定配置）以及 PD3.0 enable（使能 PD3.0）（选择每个参数旁

边的下拉菜单）。对于正在为CMG1无源EMCA线缆的最终生产创建配置文件的线缆制造商，请必须注意将 Lock 

Configuration 参数应设置为 Yes。各配置和测试步骤完成后，启用锁定配置功能将冻结所有配置参数，并且将来

无法重新配置/测试那些基于CMG1的无源EMCA线缆。对您的基于CMG1 EMCA无源线的参数进行所需的更改。 

http://www.cypress.com/


 

EZ-PD CMG1 入门手册 
 

www.cypress.com 文档编号：002-23980 版本*A 25 

5. 接下来，在左侧面板，在 Port 0 > Discover Identity 下点击 Cable VDO。EZ-PD 配置工具的窗口将如图 25 的窗

口所示。在右侧面板中，您可以配置与供应商定义对象（VDO）相关的线缆参数。通过每个参数旁边的下拉菜单，

可以对这些参数（如线缆硬件和软件版本、线缆类型（如 Type-C to Type-A/Type-B/Type-C）、连接器类型（插头

或插座）、线缆终端）等等进行设置。  

图 25. 设置 CMG1 Passive Cable 项目的线缆 VDO 
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6. 设置完所需的参数后，保存新创建的项目。通过依次选择 File > Save As，浏览到一个本地目录，以保存已配置的

项目，如图 26 所示。所更新的配置参数将被保存为 XML 格式的文件。默认情况下，“.cyacd”文件和“.c”文件

也被保存在相同位置。  

图 26. 保存 CMG1 Passive Cable 项目的配置 

 

该操作将完成基于 CMG1 的无源 EMCA 线缆的配置文件的创建过程。 
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4.4 使用 EZ-PD 配置工具来配置和测试基于 CMG1 无源 EMCA 线缆。 

下一步是使用 EZ-PD配置工具来配置和测试连接到制造测试套件设置的基于 CMG1 的无源 EMCA线缆。执行通过使用

EZ-PD 配置工具创建并保存配置文件（.cyacd 格式）节所描述的各步骤后，请继续按照下面步骤进行操作。 

1. 执行先前节描述的各步骤后，依次选择 Tools > Manufacturing Test Kit Tab，如图 27 所示。如果要重新启动 EZ-

PD 配置工具，请单击 File > Open 并浏览到一个用于加载先前保存基于 CMG1 的无源 EMCA 线缆的配置文件

（xml 格式）的本地目录。打开之后，依次选择菜单 Tools > Manufacturing Test Kit Tab，如图 27 所示。 

图 27. 打开 EZ-PD 配置工具中的 Manufacturing Test Kit 卡 
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这样，将在 EZ-PD 配置工具的主窗口中打开 Manufacturing Test Kit 卡，如图 28 所示。通过该选项卡可以配置

和测试基于 CMG1 的无源 EMCA 线缆。 

图 28. 查看 EZ-PD 配置工具中的 Manufacturing Test Kit 卡 

 

如图 28所突出显示，该选项卡的输入文件是基于 CMG1的无源 EMCA线缆的配置文件（其格式是.cyacd）。通过 

Start 或 Stop 按键，您可以开始或停止对所连接的基于 CMG1 无源 EMCA 线缆的配置操作。同时，通过 Refresh

按键可以刷新所连接的基于 CMG1 无源 EMCA 线缆的列表。 

从 Settings 的各选项，您可以对所连接的线缆选择进行配置或者测试操作。该字段还提供了在检测到故障时停止

已运行测试的能力。  

弹出的窗口将显示列出连接到 Manufacturing Test Kit 设置的基于 CMG1 无源 EMCA 电缆的列表。该列表列出了连

接 MTK 硬件的序列号，连接 MTK 硬件的 Tester ID，连接的基于 CMG1 无源 EMCA 线缆的 Cable ID，其当前的

状态（通过/失败/配置/测试）以及相应的 LED 颜色和 Open report 以打开已测试的基于 CMG1 无源 EMCA 线缆的

报告。通过点击 Open report，您可以查看保存在 EZ-PD 配置工具中每个完成测试的日志和记录。 

EZ-PD 配置工具下半部分的消息窗口显示配置或测试活动的进度。 

2. 点击 Configuration cyacd path 文本字段旁边的 Browse 按钮，浏览到保存 .cyacd 文件的本地目录。 

3. 在 Settings 下面选择所需的选项，以对基于 CMG1 无源 EMCA 进行配置和测试。点击 Start 按键。 
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点击 Start 后，EZ-PD 配置工具将执行 Settings 字段中选择的步骤，以配置和/或测试连接到 MTK 设置的基于

CMG1 无源 EMCA 线缆。配置和测试完成后，运行 MTK 测试的 EZ-PD 配置工具窗口将如图 29 所示。如果多个基

于 CMG1 的无源 EMCA 线缆被连接，那么它们也被列出在显示窗口中，这时，运行 MTK 测试的 EZ-PD 配置工具

窗口将如图 30 所示。 

图 29. 完成配置和测试单个基于 CMG1 的无源 EMCA 线缆 

 

图 30. 完成配置和测试多个基于 CMG1 的无源 EMCA 线缆 
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4. 一旦显示窗口中的列表填充了结果，连接的基于 CMG1 无源 EMCA 线缆的配置和测试操作就完成了。这时，你有

两个选择： 

选项 1：如果没有单击任何按钮或更改已打开的 Manufacturing Test Kit 选项卡上的任何设置，请分离已配置的基

于 CMG1 无源 EMCA 线缆，并连接需要配置、测试或两者的下一个基于 CMG1 无源 EMCA 线缆。该选项允许连

续配置和测试多个基于 CMG1 的无源 EMCA线缆而不需要修改 EZ-PD配置工具中的任何内容。另外，在完成配置

和测试的基于 CMG1 无源 EMCA 线缆等待分离时，CMG1 MTK 工具将进入等待状态，即等待已配置的线缆被分

离，以及新线缆被连接。如果您所需配置和测试的 CY432 EZ-PD CCG3PA EVK 电源板和基于 CMG1 无源 EMCA

线缆的数量有限，则此功能非常有用。 

选项 2：点击 Stop 以停止配置和测试过程该选项适用于需要配置和测试单个基于 CMG1 的无源 EMCA 线缆的情

况。  

5. 如果您更喜欢选项 1，则在配置和测试所需的基于 CMG1的无源 EMCA线缆组之后，请单击 Stop 以结束该过程。  

6. 如果需要，可以通过 Message窗口来查看配置和测试已连接的基于 CMG1无源 EMCA线缆的完成进度。点击右上

角的 Close 按键以关闭 Manufacturing Test Kit 选项卡。 

7. 有关 CMG1 MTK 工具的更多信息，请参阅 EZ-PD 配置工具网页上 EZ-PD 配置工具用户手册中的第 4 章。您也可

以在 EZ-PD 配置工具中依次选择 Help > User Manual 来访问该用户手册。 
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销售、解决方案以及法律信息 

全球销售和设计支持 

赛普拉斯公司拥有一个由办事处、解决方案中心、原厂代表和经销商组成的全球性网络。如欲查找离您最近的办事

处，请访问赛普拉斯所在地。 
 

产品 

Arm® Cortex®微控制器 cypress.com/arm 

汽车级产品 cypress.com/automotive 

时钟与缓冲器 cypress.com/clocks 

接口 cypress.com/interface 

物联网 cypress.com/iot 

存储器 cypress.com/memory 

微控制器 cypress.com/mcu 

PSoC cypress.com/psoc 

电源管理 IC cypress.com/pmic 

触摸感应 cypress.com/touch 

USB控制器 cypress.com/usb 

无线连接 cypress.com/wireless 

 

PSoC®解决方案 

PSoC 1 | PSoC 3 | PSoC 4 | PSoC 5LP | PSoC 6 MCU 

赛普拉斯开发者社区 

社区 | 项目 | 视频 | 博客 | 培训 | 组件 

技术支持 

cypress.com/support

此处引用的所有其它商标或注册商标都归其各自所有者所有。 
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