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The following document contains information on Cypress products. The document has the series
name, product name, and ordering part numbering with the prefix “MB”. However, Cypress will
offer these products to new and existing customers with the series name, product nhame, and
ordering part number with the prefix “CY”.

How to Check the Ordering Part Number

1. Goto www.cypress.com/pcn.

2. Enter the keyword (for example, ordering part number) in the SEARCH PCNS field and click
Apply.

3. Click the corresponding title from the search results.

4. Download the Affected Parts List file, which has details of all changes

For More Information
Please contact your local sales office for additional information about Cypress products and
solutions.

About Cypress

Cypress is the leader in advanced embedded system solutions for the world's most innovative
automotive, industrial, smart home appliances, consumer electronics and medical products.
Cypress' microcontrollers, analog ICs, wireless and USB-based connectivity solutions and reliable,
high-performance memories help engineers design differentiated products and get them to market
first. Cypress is committed to providing customers with the best support and development
resources on the planet enabling them to disrupt markets by creating new product categories in
record time. To learn more, go to www.cypress.com.
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AN205381
F2MC-8L/16LX/FR, MB9xxxx, Softune Workbench Automatic Debugger Start

This application note describes the steps necessary to setup the Softune Workbench Development Environment to

automatically start the selected debugger at start-up of the Softune Workbench and to load a specified target .abs-file.
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1 Introduction

This application note describes the steps necessary to setup the Softune Workbench Development Environment to
automatically start the selected debugger at start-up of the Softune Workbench and to load a specified target .abs-file.

The Softune Workbench Development Environment (from here on only called Softune Workbench of SWB) is to be
used to control a debugger. Debugging can be done using

m Code Simulator

®  Monitor Debugger

®  Emulator Debugger using ICE

Automatic start of debugging at start of the SWB might be used for example in the field of automatic testing of complete
applications or when one wants to use a software development environment other than Softune Workbench but still
wants to be able to debug the software for example using emulator debugging via ICE (In Circuit Emulator).
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2.1.1

Preparation of the SWB

The steps shown in this chapter show how to setup a dummy Softune Workbench project together with a corresponding
Softune Workbench workspace containing the aforementioned project. This SWB project/workspace can be used for
debugging when for example the tool chain for building the application software is different from the Softune
Workbench.

Of course, the steps after creating a new Softune Workbench project/workspace can surely be applied to an existing
Softune Workbench project/workspace if one wants to have the current Softune Workbench project/workspace to be
re-opened automatically at start of the Softune Workbench (even without automatic start of the debugger).

Creating a new Softune Workbench Project and Workspace and adjust Workspace
settings

In the following it is assumed that the Softune Workbench (together with necessary drivers if needed) is already
installed.

The directory of the target .abs-file (generated from within a different Softune Workbench project or generated by
another tool chain using the Softune Workbench language tools) is C:\my application project\ABS (choose
this path corresponding to your needs). The name of your application software target .abs file is assumed to be
my application.abs.

Create SWB Project/Workspace and select .abs-file to be used

To create anew SWB projectiworkspace from scratch use File ->New->Workspace/Projectfile after start-up of the
Softune Workbench IDE. This will display the dialog windows as shown in

WWW.CYpress.com Document No. 002-05381 Rev.*B 2
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. Fill in the needed information (selection of Chip, Target MCU, Project Name, Target File Name and Project Directory).
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Figure 1. Dialog for creating Softune Workbench Project/Workspace
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Please choose Project Name and Project Directory corresponding to your needs. Please choose Target Filename
corresponding to the name of the .asb-File to be used with this SWB Project/Workspace.

This will create (if not already existing) a directory/file structure like:
C:\my_swb_project -|

| Debug -|

| |  my swb project.sup

| | ABS

| | LST

| | OBJ

| |  OPT

| my swb project.dat
| my swb project.prj
| my swb project.wsp

The .prj-file contains the settings of the project and the .wsp-file contains the settings of the workspace. These two files
are normal text files which might also be generated by using a script tool and which of course can also be
edited/changed by using a normal text editor.

Since the current directory of the target .abs-file is set by default to C:\my_swb_project\debug\abs\my_application.abs
this has to be adapted to the real path to the .abs-file

(C:\my application project\ABS\my application.abs in this example). Please use the dialog shown by
selecting Project -> Setup Project ... -> General from the Softune Workbench menu within the my_swb_project
project (as shown inFigure 2) to set the path information accordingly.
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Figure 2. Dialog to change the Path to the application .abs-file to be used within my_swb_project
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Adjust SWB Project/Workspace settings for re-opening at SWB start

The Softune Workbench can be configured to re-open automatically at start-up the workspace that was used when the
Softune Workbench was closed. This feature is enabled by checking the option “Open the last workspace at starting”
in the dialog shown when selecting Setup -> Development... -> Workspace from the Softune Workbench Menu.

2.1.2
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Figure 3: Dialog opened via Setup -> Development... (selecting Workspace-Tab).
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2.1.3 Adjust SWB Project/Workspace settings for automatic debugger start at SWB start

A Softune Workbench workspace can be configured to start the debugger using the last selected .sup-file when the
workspace was opened by the Softune Workbench. To select this configuration one has to open the according
configuration dialog via the Softune Workbench menu Project -> Setup Workspace and check the option “Start
Debugger” under “Debug when workspace is open” (please refer to
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Figure 4).

2.1.4 Setup Debug Environment
When creating the new Softune Workbench Project/Workspace “my_swb_project” a default debug environment
my_swb_project.sup was created (please refer to the “debug”-folder in the project view of the Softune Workbench).
The settings of this .sup-file have to be adjusted to the corresponding debugger tool (simulator or emulator debugger)
and the behaviour of the debugger tool at debugger start has to be setup following the instructions in dialog opened
when right-klicking the my_swb_project.sup and selecting the menu option “Change...” (please refer to Figure 5).
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Figure 4: Workspace configuration dialog having "Start Debugger" at Workspace opening option selected.
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Figure 5: Start Dialog for selecting and setting up the debugger tool for my_swb_project.sup (please follow the instructions
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After finishing the necessary configuration steps the Softune Workbench has to be closed without closing the current
Softune Workbench Workspace (my_ swb_project in this example). One has to agree to the corresponding dialog to
save the done changes to the current Softune Workbench Workspace.

3 Calling the Softune Workbench

file.

In the following it is shown how to call the Softune Workbench (automatically starting the debugger and loading the target .abs-
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3.1 Calling the Softune Workbench from the DOS command line

The Softune Workbench can be called from the command line using the following command (assuming for this example
the FR Softune Workbench V6 was installed to the directory C:\Softune6 on the PC).

C:\Softune\fs9lls.exe

When the preparation steps in chapter 2 have been followed appropriately the Softune Workbench will start and
automatically load the last used Workspace (my_swb_project in this example) and finally proceed with starting the
debugger tool as selected inmy _swb_project. sup.

Application Notes related to Softune Workbench and/or Debugging/Emulation for further reading:

®  AN205222 - FR Family MB2198-01 Emulator System Getting Started Guide

® AN204828 - F2MC-16FX Family, Emulating and Debugging with Softune and MB2198-01
® AN205205 - FR Family MB91460, SWB Monitor Debugger

AN205224 - How to use Customize Build for Softune WB
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4 How to Change Debugger Environment (e.g. changing automatic testing)

To run different test procedures for example in automatic application test one might want to change the procedure files called.
The following shows which part of the .sup-file defines the procedure files called by the debugger.

4.1 Debug Environment and Debug Support Information File

The Softune Workbench basically has two files containing information about the debugging environment. First which
debugger environment to be called (information stored in the .prj-project file) and second (when the debugger
environment is selected) the settings for a given debugger environment (debug support information .sup-file).

These files are text files which can be manipulated by general text file editors. If one needs to have different debugger
environments or if one wants to change test procedures (e.g. different tests for automatic application test using
debugger) these files can be changed prior to the start of the Softune Workbench for example by running a script
manipulating the corresponding files.

4.1.1 Selecting the Debug Environment

The .prj-project file contains the information about the list of available .sup-files [DebState-xyz] (xyz is the used SWB
project configuration) and the selected actual debug environment (.sup-file) (Current) which will be used when the
debugger is started:

[DebState-STANDALONE]

SupCount=6
Supfile-0=STANDALONE\Simulator.sup
Supfile-1=STANDALONE\MB2198-01-USB.sup
Supfile-2=STANDALONE\MB2198-01-COM1.sup
Supfile-3=STANDALONE\MB2198-01-LAN.sup
Supfile-4=STANDALONE\Mondeb_57K6_com1.sup
Supfile-5=STANDALONE\Mondeb_57K6_com2.sup
Current=MB2198-01-USB.sup

AliasFile=

CPURunMode=

WWW.CYpress.com Document No. 002-05381 Rev.*B 10
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4.1.2 Changing the Command Procedure Files

Besides other information the Debug Support Information .sup-file contains information about the command batch files
to be executed

m At debugger start
m  Before loading of .abs-file
m  After loading of .abs-file

The following shows a part of an .sup-file executing no command batch file once at debugger start and
/PRC/set_ROMs.prc before downloading .abs-file and in addition /PRC/set RESET.prc after download of .abs-
file (the path is relative to the position of the .prj-file of the corresponding Softune Workbench project):

[Target]

Before Batch File=PRC\set_ ROMS.prc
After Batch File=PRC\set_RESET.prc

[Start]
Batch File=

--END -
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