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© 赛普拉斯半导体公司，2014。本文档所包含的信息可能会随时更改，恕不另行通知。除赛普拉斯产品的内嵌电路

之外，赛普拉斯半导体公司不对任何其他电路的使用承担任何责任。也不会根据专利权或其他权利以明示或暗示的

方式授予任何许可。除非与赛普拉斯签订明确的书面协议，否则赛普拉斯产品不保证能用于或适用于医疗、生命支

持、救生、关键控制或安全应用领域。此外，对于合理预计会发生运行异常和故障并对用户造成严重伤害的生命支

持系统，赛普拉斯将不批准将其产品用作此类系统的关键组件。若将赛普拉斯产品用于生命支持系统，则表示制造

商将承担因此类使用而招致的所有风险，并确保赛普拉斯免于因此而受到任何指控。  

 

所有源代码（软件和/或固件）均归赛普拉斯半导体公司（赛普拉斯）所有，并受全球专利法规（美国和美国以外的

专利法规）、美国版权法以及国际条约规定的保护和约束。赛普拉斯据此向获许可者授予适用于个人的、非独占

性、不可转让的许可，用以复制、使用、修改、创建赛普拉斯源代码的派生作品、编译赛普拉斯源代码和派生作

品，并且其目的只能是创建自定义软件和/或固件，以支持获许可者仅将其获得的产品依照适用协议规定的方式与赛

普拉斯集成电路配合使用。除上述指定的用途外，未经赛普拉斯的明确书面许可，不得对此类源代码进行任何复

制、修改、转换、编译或演示。  

 

免责声明：赛普拉斯不针对该材料提供任何类型的明示或暗示保证，包括（但不仅限于）针对特定用途的适销性和

适用性的暗示保证。赛普拉斯保留在不另行通知的情况下对此处所述材料进行更改的权利。赛普拉斯不对此处所述

之任何产品或电路的应用或使用承担任何责任。对于合理预计可能发生运转异常和故障，并对用户造成严重伤害的

生命支持系统，赛普拉斯不授权将其产品用作此类系统的关键组件。若将赛普拉斯产品用于生命支持系统，则表示

制造商将承担因此类使用而导致的所有风险，并确保赛普拉斯免于因此而受到任何指控。  

 

产品使用可能受适用的赛普拉斯软件许可协议限制。  
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1 简介 

1.1 欢迎 

EZ-Click提供了用于赛普拉斯器件的简单图形配置选项，因而能够尽可能缩短您产品的上市时间。通过

EZ-Click，您可以快速配置 CapSense Express器件。  

 无代码开发 

 制作原型的时间更短 

 上市时间更快 

1.2 入门 

要想开始您的项目，请按照下面的步骤进行操作： 

1. 创建新项目：点击 New Project （新项目），然后使用 Product Selector（产品选择器）对话框

来选择各种项目选项。 

2. 选择目标器件：点击 Select Target Device （选择目标器件） ，使用 Select（选择）对话框选择

要连接到您 PC的器件。 

3. 设置参数： 使用各个配置选项卡来定义器件功能并进行测试。要想查看指导内容，请使用 Design 

Toolbox（设计工具箱） 。 

4. 生成配置文件：点击 Generate Config File（生成配置文件） ，以便生成器件的配置文件。 

5. 编程器件：点击 Apply Current Config（应用当前配置） ，按照您的设置内容编程器件。 

1.3 帮助主题 

通过本帮助文档中下述各节内容，了解有关使用 EZ-Click的更多信息： 

 基本 EZ-Click任务 

 EZ-Click框架 

 开头页面 

 CapSense传感器配置 

 全局配置 
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 可视化配置 

 CapSense输出 

 系统诊断 

 支持 

1.4 文档修订记录 

文档标题：EZ-Click 2.0用户指南 

文档编号：001-92013 

修订版 日期 更改说明 

** 4/7/2014 本文档版本号为 Rev**，译自英文版001-90407 Rev**。 
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2 基本的 EZ-Click任务 

 创建新项目 

 打开现有的项目 

 选择 I2C目标 

 生成配置文件 

 编程目标器件 

 复位 

 保存项目 

 打印项目 

 退出工具 
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2.1 创建新项目 

要想创建新项目，可以使用 Product Selector对话框来指定各种特性和符合您设计的滤波器器件。 

 

2.1.1 打开 Device Selector： 

选择 New Project对话框中的 Device Selector 。 

 

从 File菜单中打开 New Project对话框，或在 EZ-Click主窗口中按下[Ctrl] + [N]。 

您还可以点击 Start Page上的 New Project 链接实现所需操作。 

2.1.2 使用 Device Selector： 

1. 在 Device filters下，选择设计中使用的滑条、按键、LED等的数量。 

由于您选择了多种滤波器，所以对话框右侧中可用的器件数量会降低。 

2. 选择完滤波器后，双击器件型号，或选中它，然后点击 New EZ-Click Project。 
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注意：根据所选器件，显示的按键将在下面两个按键之间切换： 

 New EZ-Click Project（新 EZ-Click项目）—  创建包含所选器件的新 EZ-Click项目。 

 Go to product webpage （转到产品网页）—  启动网页浏览器，以浏览包含所选器件的产品页

面。 

2.2 打开现有的项目 

要想打开现有的 EZ-Click 项目，请使用 Open Project（打开项目）对话框来查找和选择需要打开的项目。 

 

2.2.1 打开对话框： 

请从 File菜单中选择 Open Project...，或在 EZ-Click主窗口中按下[Ctrl] + [O]组合键。 

您还可以通过点击 Start Page上的 Browse链接实现。 

注意：您还可以通过使用 File > Recent Projects 菜单项来查看和选择现有的项目。 

2.2.2 使用对话框： 

浏览并选择相应的“*.cprj”文件，然后点击 Open。 
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2.3 选择 I2C目标 

使用 Select I2C Target对话框，选择符合您项目的赛普拉斯器件。 

 

根据所连接至电脑的套件或器件，可供选择的 Ports和 Devices会有所不同。当前套件包括：

CY8CKIT-002、CY3280-MBR2以及 CY3280-MBR3。 

2.3.1 打开对话框： 

创建新项目或打开现有的项目后，从 Configuration菜单中或从工具栏上选择 Select Target Device。 

2.3.2 使用对话框： 

请选择一个端口和一个器件。接下来，选择 Power和 I2C Speed中的选项，然后点击 OK。 

2.4 配置项目 

配置一个项目需要使用不同 EZ-Click选项卡上的各个设置。根据所选器件的不同，选项卡也不一样： 

 CapSense传感器配置 

 全局配置 

 可视化配置 

 CapSense输出 

 系统诊断 
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2.5 生成配置文件 

请依次选择 Configuration> Generate Config File，以便生成设计的配置文件。在项目目录中创建了三

个新文件。每个文件中以不同格式显示了相同的信息；可以使用其中任何一个配置器件。 

 *.iic — 该 I2C配置文件可用于 Bridge Control Panel，以便将设置应用于目标器件。 

 *.hex — 这个兼容于 Intel 的十六进制文件可以通过 I2C 编程器使用进行更新器件存储器的可配置区。 

 *.h — 该 C语言头文件包括在嵌入式器件内，它可通过 I2C对目标器件进行通信。 

2.6 编程目标器件 

依次选择 Configuration > Apply Current Config，使用当前配置（*.iic）文件编程器件。 

2.7 复位 

通过该特性，可以对所选选项卡的配置进行复位，或同时复位所有选项卡的配置。 

 依次选择 Configuration > Reset Tab，将当前选项卡中的参数复位为默认值。 

 依次选择 Configuration > Reset All Tabs，将所有选项卡中的参数复位为默认值。 

2.8 保存项目 

依次选择 File > Save Project，以保存当前项目。 

如果您尚未保存项目却尝试关闭它，该工具将提示您保存项目。 

您也可以通过依次选择 File > Save Project As...来创建项目的副本。 

2.9 打印项目 

依次选择 File > Print，以便打印当前屏幕。  

点击 File > Print Preview，可以预览当前屏幕。  

2.10 退出工具 

依次选择 File > Exit或点击右上角的按钮关闭工具。 
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3 EZ-Click框架 

基本 EZ-Click工具框架包含用于创建和配置项目的各种选项卡，如下面所示： 

 开头页面 

 CapSense传感器配置 

 全局配置 

 可视化配置 

 CapSense输出 

 系统诊断 
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3.1 开头页面 

通过 EZ-Click开头页面可以快速查看工具的使用方法，以及创建新项目和打开现有项目的链接。 

 

 

3.2 CapSense传感器配置 

CapSense sensor configuration选项卡提供了有关 CapSense传感器的所有设置内容，包括按键、滑

条以及接近传感器。   

注意：有些器件不支持所有类型的传感器。所以，并不是选项卡上的所有选项均可用于每一个器件。 

 

3.2.1 通用选项 

 Number of sliders（滑条数量） — 采用了适用的器件时，通过该参数可以指定您项目中滑条的数

量。如果指定一个或多个滑条，将显示一个 Sliders页面，供您设置各种选项。请查看滑条选项。 
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 Number of proximity sensors（接近传感器数量） — 采用了适用的器件时，通过该参数可以指定

项目中接近传感器的数量。如果指定一个或多个传感器，将显示一个 Proximity Sensors 页面，供您

设置各种选项。请查看接近传感器选项。 

 IIR filter（IIR滤波器） — 通过该参数，可以使能或禁用无限脉冲响应（IIR）滤波器。更多信息，

请参考器件数据手册。 

 Median filter（中值滤波器） — 通过该参数，可以使能或禁用中值滤波器。更多信息，请参考器件

数据手册。 

 Automatic threshold（自动阈值） — 通过该参数，可以动态设置各个阈值，如手指阈值和噪声阈

值，这些阈值取决于系统噪声。如果使能该参数，各个按键的手指阈值参数将保持为禁用状态；但

滑条和传感器的手指阈值始终被设置。请查看手指阈值。 

 Advanced low-pass filter（高级低通滤波器） — 通过该参数，可以使能或禁用高级低通滤波器，

并能够指定 IIR输入权重。该参数用于接近传感器。更多信息，请参考器件数据手册。 

 Scan period（扫描周期） — 使用该参数来设置扫描周期（单位为毫秒）。扫描周期指的是由器件执

行连续传感器扫描之间的时长。  

扫描周期取决于设计中所使用的传感器的数量。当使能传感器时，若需要可自动缩短扫描周期，这

样可以确保在有效的时间内扫描所有传感器。请注意，如果减少传感器的数量，该工具将不会自动

增大扫描周期。这是因为存在传感器精度与功率消耗之间的权衡问题，因此该问题让用户来决定。 

当器件通电时，将快速扫描传感器，因此扫描周期被缩短。这是特定应用可配置的最小扫描周期。

一段时间后（对于空闲状态，即为未触摸按键时），器件将增大扫描周期，以降低功耗。在空闲状态

下触摸了按键时，下一个触摸中的扫描周期再次降低。 

 

扫描过程所消耗的功率较高，因此响应越快，功耗也越大。根据经验法则，要想得到更快的响应或

更低的功耗，需要分别将扫描周期延迟设置为低值或高值。 

对于更多的按键，最小扫描周期延迟值会更高。通过点击滑条来设置扫描周期。 

3.2.2 滑条选项 

 

 Sensor（传感器） — 输入传感器名称。 

 Segments（段信号）— 选择段信号的数量。 

 Pins（引脚） — 显示的是引脚的只读字段。 

 Type（类型） — 选择滑条类型：线性或放射状。 

 Sensitivity（灵敏度） — 灵敏度用来衡量在给定输入变化量时的输出变化量。您可以逐个设置滑条、

传感器和按键的灵敏度。该参数允许您设置打开一个按键时要求的最小手指容值。UI中的不同传感

器，其灵敏度也各异。例如，电源按键的灵敏度可以低于 UI中其他按键的灵敏度。默认选项为高。 
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 Finger Threshold（手指阈值） — 如果禁用了自动阈值性能，可以使用该参数来选择每个滑条、传

感器或按键的相应值。基于手指阈值参数，将计算其他所有阈值（噪声阈值、负向噪声阈值，等等）。

只有传感器输出高于手指阈值时，才会认为按键被触摸。 

 

CapSense算法将传感器电容转换为数字计数，称作原始计数。原始计数被解析为传感器的“触摸”

和“无触摸”两种状态。原始计数的数值是传感器电容的数字表示，它随着电容的增加而增加。基

准参考电平是指无触摸时原始计数电平的平均值。在传感器上无手指触摸时，将连续更新该参考电

平。 

在空闲状态（无触摸）下，输出信号（原始计数）只有内部噪声组件。发生按键触摸时，原始计数

将上升。因此，两个原始计数之间存在差值。此时，将手指阈值设置为差值的 80%，以便正常识别

触摸。该值为介于 50到 245间的十进制值，用于每个按键。默认值为 50。 

 Resolution（分辨率） — 选择合适的分辨率的值。 

3.2.3 接近传感器选项 

 

 Pin（引脚） — 选择传感器使用的引脚。 

 Sensor（传感器） — 输入传感器名称。 

 Resolution（分辨率） — 控制用于检测和跟踪接近测量的位数。 

 Proximity threshold（接近阈值） — 选择相应值。 

 +ve Threshold（正向阈值） — 选择相应的正向接近阈值。 

 -ve Threshold（负向阈值） — 选择相应的负向接近阈值。 

 Sensitivity（灵敏度） — 选择相应值。 

 Finger Threshold（手指阈值） — 请查阅手指阈值。 

 Wakeup Sensor（唤醒传感器） — 对于 CY8CMBR3xxx器件，通过该选项可以使能或禁用器件上

“Look-for-Proximity”（寻找接近）的状态。当人体不接近时，该状态允许进入超低功耗。检测到

接近时，控制器将进入“Look-for-Touch”（寻找触摸）状态。更多有关信息，请参见器件数据手册

。 
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 Initial/Subsequent Response Time（初始/后续响应时间）— 响应时间指的是被器件视为有效传感

器触摸的最小传感器触摸时间。通过去抖动值，可以计算响应时间。如果一个输出要求快速响应，

则去抖动时间要短。 

3.2.4 按键选项 

 

 Enable（使能） — 使能相应按键。 

 Pin（引脚） — 该只读字段显示了与按键相应的引脚名称。 

 Sensor（传感器） — 输入按键名称。 

 Sensitivity（灵敏度） — 选择相应值。 

 Finger Threshold（手指阈值） — 请查阅手指阈值。 

 FSS —当禁用 Flanking Sensor Suppression（侧翼按键抑制，FSS）时，只允许一个传感器的状态

为“ON”。同时触摸多个传感器时，只有第一个被触摸的传感器被报告为“ON”状态，直到这几

个传感器被释放为止。如果各个按键彼此靠近，或始终只有一个按键为状态“ON”，则要求使用该

性能。 

 

要使能 FSS性能，选择相应按键的选框。默认情况下，所有按键的 FSS性能被禁止。 

 Initial/Subsequent Response Time（初始/后续响应时间）— 请查阅初始/后续响应时间。 

3.2.5 错误、警报和注意信息 

本部分显示了项目中的各个错误、警报以及注意内容。 

 错误信息指示处理项目前，至少有一个必须解决的问题。 

 警报信息提示有可能发生问题的异常条件。 

 注意信息指示已发生的状况的系统信息。当前，系统尚未生成注意信息。 

3.3 全局配置 

Global configuration选项卡提供了所有非传感器器件配置设置。使用 CapSense sensor 

configuration （Capsense传感器配置）选项卡来设置传感器配置。 



EZ-Click 框架  

18 EZ-Click 2.0 User Guide，文档编号：001-92013修订版** 

注意： 有些器件不支持所有设置。所以，并不是选项卡上的所有选项均可用于每一个器件。 

 

3.3.1 通用选项 

 Auto-reset period（自动复位周期） — 该时间段决定一个按键处于“ON”状态的最大时间。如果

任何不同于手指的其他导电物体（例如，金属物体）接触按键，需要使用该性能来降低功耗。 

 

当在较长时间内按住 CS0时，自动复位超时后不会驱动 GPO0，如下图所示。这样可以降低功耗。 

可以将自动复位器件设置为 5秒或 20秒。使能该特性后，如果传感器在超过所配置的时间内仍处在

“ON”状态，传感器状态将被复位。禁用了该特性后，传感器将不被复位。  

 Proximity auto-reset（接近感应自动复位） —请选择合适的数值。 

 I2C Address（I2C地址）—通过 I2C配置器件。可在 0至 127（十进制）范围内选择 I2C从设备的

地址。从设备的默认地址为 55（十进制）。 

 Optimization（优化）— 从下拉菜单中选择两个选项中的某一个 Power consumption 或 

Response time。通过优化选项，您可以选择优化的响应时间或优化的功耗。 

 LED duration（LED时长）— 该项适用于“Use LED Duration”特性。请选择合适的数值。 

 State timeout（状态超时）—  该值指的是器件切换到低功耗前的时间（有关功耗模式的实名，请参

阅器件数据手册。）请选择合适的值。 

 Enable EMC noise immunity（使能 EMC抗噪声能力）—该特性可以提高器件对外部辐射和传导

噪声的抗噪声能力。同时，还可以降低噪声辐射。  

 Enable shield（使能屏蔽）— 使能或禁用屏蔽引脚，用以提高接近感应和防水功能。 

 Enable water tolerance（使能耐水性）—该项用来使能“保护”传感器。该传感器被激活时，会

阻止激活其他传感器。 

 Enable GPIO host control（使能 GPIO主机控制）—使能该项后，I2C主控可以控制 GPO（GPO

不再由按键控制）。 

 GPO drive mode（GPO 驱动模式）—请选择合适的数值，用以将该项设置为“强驱动”或“开漏”

（仅驱动低电平）。 

 GPO logic level（GPO逻辑电平）—请选择合适的值，用以返转 GPO值。 
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 Host interrupt pin（主机中断引脚）—请选择合适的值，用以在传感器的状态发生变化时激活信号。 

 Buzzer（蜂鸣器）— 给器件提供了蜂鸣器选项，用以在某个按键被触摸时，蜂鸣器发出蜂鸣声。蜂

鸣器根据已给的脉冲宽度调制器(PWM)信号运行，该信号由脉冲的频率和时长决定。使用蜂鸣器特

性时，可通过音频来确认按键被触摸。使能蜂鸣器时，蜂鸣器配置参数（如引脚数、频率输出时长、

引脚闲置状态）均被使能。默认情况下，这些特性被禁用。 

 Type（类型）：蜂鸣器可在 单个引脚或 双引脚模式下运行。在 单个引脚模式下，通过一个引脚

传输 PWM信号，同时，蜂鸣器的其他引脚与正极或负极的电源短接。在 双引脚模式下，两个

非重叠的 PWM 信号通过两个引脚发送给蜂鸣器。可从下拉菜单选择蜂鸣器的类型。默认情况下，

它被设置为 单个引脚。 

 Pin（引脚）： None（无）、HI/BUZ、 CS5/SH/BUZ。根据选用的器件不同，该值也不一样。 

 Frequency（频率）：通过该项，可以选择蜂鸣器的频率(kHz)。可用的选项分别为：1、1.14、

1.33、1.6、2、2.67和 4。默认值为 4。 

 On time（开启时间）：该时间的单位为毫秒。其范围值取决于器件。通过点击向上和向下箭头，

可以设置蜂鸣器的开启时间（毫秒）。也可以在文本框中输入需要的值。  

 Idle state（闲置状态）：通过选择下拉菜单中的“High”或“Low”，可以设置蜂鸣器的闲置状

态。该操作也选择了蜂鸣器单个引脚模式的闲置状态。可将该状态设置为 High (VDD)或 Low 

(Gnd)。默认状态为“Low”。 

 Duration（时长）：请选择合适的值。 

 Supply voltage（V）（电源电压）— 根据器件的工作电压，选择用来设置工作电压选择存储器

（DEVICE_CFG3）的值。 

注意：对于 MBR3器件，如果应用某个配置，但在该配置中此值被修改，那么，EZ-Click会断开与

器件连接。这样，进行编程时，会报告发生故障。这是因为不能验证更改的内容是否已生效。该状

况是可预期的。因此，当使用新的设置编程器件时，您必须重新配置电路板，以处理新的电压配置。

相关具体的要求，请参考器件数据手册。 

 Debounce（去抖动）— 根据器件，可将该值设置在 1至 255的范围内。去抖动特性指定要触摸传

感器的最小时间，以产生输出触发。根据不同情况，该时间也不一样。例如，电源按键可能有较长

的去抖动时间，用以阻止器件发生错误的电源切换（通电或关电）。如果要求对输出进行快速响应，

则按键应该有较短的去抖动时间。 

 HCG — 有两个可用的通用数字输出（GPO），其逻辑状态由主机控制。如果不使用蜂鸣器，则能使

用更多的主机控制 GPO（HCG）（使用 BuzzerOut0和 BuzzerOut1引脚）。  

 

根据蜂鸣器配置，下表显示的是可用的主机控制 GPO引脚的最大数量。  

蜂鸣器类型 可用的主机控制GPO的最大数量 

禁用 4 

单个引脚 3 

双引脚 2 
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3.3.2 LED Options 

 

 Enable（使能） — 使能相应按键。 

 Name（名称）—输入 LED的名称。 

 Pin（引脚） — 该只读字段显示的是与 LED相应的引脚名称。 

 Sensor（传感器） — 输入按键名称。 

 Active duty cycle （激活占空比）选择 LED激活时的 PWM占空比。 

 Inactive duty cycle （未激活占空比）—选择 LED未激活时的 PWM占空比。 

EZ-Click将占空比值转换成寄存器的值，具体如下： 

     Selected% * 15 = RegisterValue 

  

例如： 

     100% * 15 = 15 

      20% * 15 = 3 

  

 Use LED Duration（使用 LED时长）—使能或禁用该选项。 

 Toggle（切换）— 使能或禁用该选项。使能该特性后，触摸一次传感器时，传感器将持续其“ON”

状态，并不会自动转换为“OFF”的状态。下一次触摸该传感器，它才会转换为“OFF”状态。这

样，每次触摸按键，输出都会被切换。在需要满足下面各条件的应用中，将使用该特性：触摸按键

后，需要保持按键的“ON”或“OFF”状态。例如，每当触摸某个按键，需要切换器件的电源按键。 

 Host control（主机控制）— 使能或禁用该项。 

  

3.3.3 错误、警报和备注信息 

请查看 错误、警报和备注信息。 
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3.4 Visual Configuration（可视化配置） 

通过 Visual configuration 选项卡配置可视反馈效果（如上电时 LED的效果），以及按键被触摸时

LED的效果。 

注意： 目前，该选项卡仅在 CY8CMBR2xxx器件中可用。 

 

3.4.1 通用选项 

3.4.1.1 LED Configuration（LED配置） 

 LED on time（LED开启时间）—使能了 LED开启时间特性后，不再触摸按键后，在预定义配置的

时间内 LED仍然发光。如果仅在较短的时间段内触摸了按键，通过该特性可以确定按键被按下的情

况。可在“LED ON time”框中设置该时间，它的有效范围为 0至 2000 ms，步长为 20 ms。所输

入的值将被自动纠正到最接近的有效时间段。默认情况下，“LED ON time”项被禁用，且时间段被

设置为 0。 

 Analog voltage output（模拟电压输出）— 该参数决定是否能够将输出引脚作为开漏切换使用。如

果使能了该特性，输出引脚可作为模拟输出电压使用。如果禁用该特性，则不能将输出引脚作为模

拟输出电压。默认情况下，此选项被禁用。 

 LED standby brightness（LED待机高亮度）—定义了未按下相应按键时 LED的亮度级别。可用

的选项分别为 0%、20%、30%或 50%。 

3.4.1.2 LED State Periods（LED状态周期） 

 Period1 - Period4用于上电 LED效果和按键控制 LED效果的 4个不同参数的 LED周期（单位为毫

秒）。可在文本框中输入所需要的数值，其有效范围为 0至 2000毫秒，步长为 20毫秒。所输入的

值将被自动纠正到最接近的有效时间段。默认值为 0。 
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3.4.2 LED Effects at Power On（上电时的 LED效果） 

 

 LED effects mode（LED效果模式）— 可用的选项包括 Disabled（禁用）、Concurrent（同时）

和 Sequential（顺序）。默认情况下，此选项被禁用。上电时，可在进行初始化前查看特定 LED的

效果。通过单独指定每个 LED的参数，可以定义其相应的效果。 

 表格 — 上电时和/或触摸按键时所有 LED均有已经定义的效果。所有 LED被分为四组，每组三个

（第一组除外）。对于每一组，可通过设置不同的参数来获得不同的效果。可单独对前四个参数进行

配置，并将每个参数指定为四个可用时间段中的某一个。 

 Ramp up Time（上升时间）： LED从低亮度状态变化到高亮度状态所需的时间。 

 High Time（高亮度时间）： LED处于高亮度状态的时长。 

 Ramp down Time（下降时间）：LED从高亮度状态切换到低亮度状态所需的时间。 

 Low Time（低亮度时间）： LED处于低亮度状态的时长。 

 High brightness（高亮度）： LED处于高亮度状态时，该参数设置高亮度的级别。 

 Low brightness（低亮度）： LED处在低亮度状态时，该参数设置低亮度的级别。 

 LED Effect Repeat Rate（LED效果重复率）： 指定释放按键后 LED效果重复的次数。 

3.4.3 LED Effects on Button Touch（按键触摸的 LED效果） 

 

 On button touch（触摸按键时）—使能或禁用 触摸按键时 LED的效果。默认情况下，此选项被禁

用。可将 LED的参数设置为不同的值。触摸按键时 LED的效果有两类：呼吸或无呼吸。 
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 Last button LED effect（最后按键的 LED效果）— 该参数确定在所有 GPO上维持 LED的渐褪效

果还是仅在最后一次按下按键或释放按键时维持 LED的渐褪效果。如果使能该特性，仅在最后一次

按下按键或释放按键时会产生 LED 渐褪效果。如果禁用该特性，根据设置，每当按下或释放按键时，

LED都会产生渐褪效果。默认情况下，此选项被禁用。 

 表格— 该表格与 LED Effects at Power On （上电时的 LED效果）选项卡下的表格相同，但该表内

多加了一行，即 Breathing effect（呼吸效果）。上电时和/或触摸按键时的所有 LED均有已定义的

效果。所有 LED被分为四组，每组三个（第一组除外）。对于每一组，可通过设置不同的参数来获得

不同的效果。可单独对前四个参数进行配置，并将每个参数指定为四个可用时间段中的某一个。 

 Breathing effects（呼吸效果）（按键触摸）：在该模式下，直到按键被触摸前，LED的已定义

效果将被重复。释放按键时，LED将根据所设置的次数重复已定义的效果。 

3.4.4 错误、警报和备注信息 

请查看错误、警报和备注信息。 
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3.5 CapSense Output（CapSense输出） 

该选项卡提供了一个图形输出。可使用特殊按键与多个参数（使用特定按键的输出视图）或特殊参数与

多个按键（使用特定参数的输出视图）的形式来显示输出。 

输出以图形方式显示，其中，水平轴表示时间（单位为毫秒或秒钟），垂直轴表示所选择的参数。 

通过使用位置滑条，可获取初始时间到当前时间的特定时间间隔的输出。通过移动该滑条的位置，可以

查看开始采集数据时的数据。使用“播放”和“停止”等按键来运行或停止输出。 

 

3.5.1 通用选项 

 Select View（选择视图）—该项用于选择“Button Output”或“Parameter output”。 

 Displayed samples（显示采样）— 用于控制在图形中显示的采样数量。 

 Sample period (ms)（采样周期）—用于控制 EZ-Click采集数据的速度。 

3.5.2 按键输出选项 

 Button（按键）— 选择特定按键，且通过下拉菜单监控器相应的输出。可选择 Button0至 Button9

范围内的任意按键。默认情况下，并未选择任何按键，因此特定按键的输出被禁用。 

 Finger Threshold（手指阈值）— 通过设置手指阈值，可在图形中评估器件的性能。只在禁用了器

件的 automatic threshold（自动阈值）计算时，该特性才会有效。如果自动阈值计算已被禁用，则
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手指阈值的默认设置为 50。为获取器件的良好响应和抗噪声能力，应该将该阈值设置为接近于差值

的 80%。 

 Button Status（按键状态）— 该字段显示按键的 ON/OFF状态。如果尚未选定任何按键，该状态

字段将为空白。 

 CP — 该字段显示选定按键的寄生电容（CP） 。只在该容值处于 5 至 41 pF范围内，按键才能运行。

如果尚未选定任何按键，则该字段将为空白。 

 Graph （图形）— 可用的选项如下： 

 Raw count vs. base line （原始计数与基准线）— 选中该项时，图形将以不同的颜色显示选定

按键的原始计数和基准线的值。更多有关原始计数和基准线的信息，请参阅“手指阈值”一节。 

 Difference count and finger threshold（差值和手指阈值）— 选中该项时，图形将以不同颜

色显示选定按键的差值和手指阈值。为实现良好的设计，应该将手指阈值设置为差值的 80%。

否则，可能要重新设计系统。 

 Signal to Noise ratio（信噪比）— 信噪比（SNR）用于区分有触摸状态和无触模状态。信号指

的是手指放在传感器上时传感器响应的变化。当计算 SNR时，噪声是指没有手指触摸时传感器

响应的峰-峰值变化（内部噪声）。手指触摸传感器表面时也会产生噪声，但该噪声包含了内部

噪声和手指引起的噪声。手指引起的噪声可能会影响传感器的性能，但从定义来看，它不是信噪

比计算的一部分。信号强度需要远远超过噪声强度才能实现可靠的 CapSense性能。下图通过

真实的传感器数据显示了一个信号和噪声的示例。在该示例中，信号值为 135，噪声值为 27。

这样，SNR为 135:27，即 5:1。选中该项时，图形将显示选定按键的 SNR。横轴表示采样，纵

轴表示 SNR。为获取耐用的设计，应该将信噪比设置为大于 5:1。 

注意： 对于 MBR3器件，EZ-Click会计算信噪比。该操作要求进行大量的采样，以产生适当的

噪声范围。为得到该范围，在按键被按下前，工具至少要收集 1000个数据采样。 

 Advanced low pass filter（高级低通过滤波器） — 该项仅适用于 MBR3器件的接近传感

器。 选中该项时，图形将显示选定传感器的平均滤波接近感应的原始计数。 

3.5.3 参数输出选项 

 Parameter select（参数选择）— 选择需要通过下拉菜单监控的相应参数。各个参数包括：原始计

数、差值和信噪比。  

 Buttons select（按键选择）—用于选择按键。针对每个按键，通过复选框可显示相应的输出。可选

择 Button0至 Button9范围内任意的按键。并可选择多个按键。因此，您可以只对所需的按键进行监

控。 

 Parameter graph（参数图形）— 输出图形将选定按键的所选参数显示为线图。横轴表示采样，纵

轴表示所选的参数。使用不同的颜色绘制各个按键的输出。因此，可使用图形对比不同按键的参数。 
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3.6 System Diagnostics （系统诊断） 

要想在生产线中测试器件的功能，请使用 System diagnostics选项卡。您可以检查器件的 SNR和每个

按键的状态。此外，通过该特性，可以进行失败模式和效果分析（FMEA），从而可以查看器件的 FMEA

结果。使用该选项卡，可以测试器件的故障。  

 

3.6.1 测试配置选项 

 Test mode（测试模式） —用于选择“Production”或“Prototype”。  

 Power on self test（上电时自测）— 根据使用目的，使能或禁用该字段。 

 Calibrated CP （已校准的 CP）—该参数为只读参数，并用于生产过程。使用该字段查看或设置寄

生电容(CP)容差。 

 Calibrated SNR（已校准的信噪比）—该参数为只读参数，并用于生产过程。通过该字段查看或设

置已校准的信噪比。您应该选择特殊目的所要求的最小信噪比，从而设置判断按键是通过还是失败

的标准。可从下拉菜单中的 3至 10范围内选择最小的信噪比值。默认情况下，该值被设置为 5，并

且推荐的最小信噪比为 5:1。 

 Calculate SNR for（计算下面传感器的信噪比）—选择将要计算信噪比的传感器（仅适用于 MBR3

器件）。EZ-Click 将计算信噪比。该计算操作要求大量的 I2C 通信量，并且每次只能计算一个传感器。

通过该项，可以选择用于计算信噪比的传感器。 

 Start/Stop（启动/停止）— 点击 Start按键进入测试模式，并点击 Stop按键退出该模式。 
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3.6.2 表格 

按下“Start”按键后，该表有效。由于激励不同的传感器，因此该表中将显示不同的信息。 

 Sensor（传感器）— 显示传感器的名称。 

 Status （状态）— 状态栏中显示的是按键的状态。如果按键被按下，状态为“ON”，否则，状态

为“OFF”。被使能的行数等于选定的行数。 

 SNR （信噪比）— 显示每个按键的实际 SNR，并根据所需的最小 SNR，该工具还显示了按键是通

过还是失败。若所读取的相应 SNR超过或等于所需的最小 SNR，将显示“Pass”状态，若 SNR小

于所需的最小 SNR，则显示“Fail”状态。 

 CP — 显示传感器的寄生电容（CP） 。 

 System Diagnostics Result （系统诊断结果）系统诊断栏显示了每个按键是否通过 FMEA的状况。

如果按键满足所有的 FMEA，工具将以绿色显示“Pass”状态。否则，将显示失败代码。如果某个

按键不满足 FMEA，将指定其相应的失败代码。下面介绍的是不同的失败代码列表。 

 CMOD不在范围内 

 按键对地短接 

 按键与 VDD短接 

 按键与按键短接 

 CP不在范围内 

3.6.3 按键 

该选项卡下的可用按键包括： 

 Load （加载）—通过该按键，可得到文件浏览器，用以打开先前导出的系统诊断日志。 

 Export （导出）— 通过该按键，可以获取保存文件对话，用以将所收集的系统诊断数据保存到

CSV文件内。可在其他工具中打开该文件。 

 Reset （复位）— 使用该按键清除当前收集的系统诊断信息，并再次启动操作。 

3.6.4 图表 

测试完成并按下“Stop”按键后，将显示这些图表。 

 Number of tests （测试次数）— 显示的是进行测试的次数。 

 用于显示或隐藏图表的选框 — 

 CP图表 

 SNR图表 

 故障条件图表 
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4 菜单与工具栏 

EZ-Click包括下面的菜单和工具栏： 

 文件菜单 

 配置菜单 

 帮助菜单 

 工具栏 

4.1 文件菜单 

EZ-Click File 菜单包括下面各条指令： 

 

 New Project（新项目）— 打开 Product Selector（产品选择

器）对话框，以创建新项目。请参阅 Creating a new project

（创建新项目）。 

 Open Project（打开项目）— 打开 Open Project（打开项目

）对话框，以选择并打开现有的项目。请参阅 Opening an 

existing project（打开现有的项目）。 

 Save Project （保存项目）— 将项目中的所有更改保存到当

前的项目文件内。请参阅 Saving a project（保存项目）。 

 Save Project As（保存项目为）— 打开 Save As（保存为）

对话框，以用别的名称保存当前项目。请参阅 Saving a 

project（保存项目）。 

 Print（打印）— 将当前的选项卡视图打印为屏幕图像。请查

阅 Printing the project（打印项目）。 

 Print Preview （打印预览）— 在 Print Preview窗口中将当

前选项卡视图显示为屏幕图形。请查阅 Printing the project  

（打印项目）。 

 Recent Projects（最近项目）— 查看并选择先前存有的不同

项目。 

 Exit（退出）— 退出 EZ-Click程序。请查看 Exiting the tool

（退出工具）。 
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4.2 配置菜单 

EZ-Click Configuration 菜单包括下面各指令： 

 

 Select Target Device（选择目标器件）— 打开

Select I2C Target（选择 I2C目标）对话框，以选

择合适的赛普拉斯器件。请查阅 Select I2C 

Target（选择 I2C目标）。 

 Disconnect Target（与目标断连）— 将 EZ-

Click与所连接的器件断连。 

 Software Reset（软件复位）— 向所连接的器件

发送一个复位指令，从而使器件从新的状态开始

运行。自动进行该复位操作，并且该操作是

Apply Current Config指令的一部分。 

 Open Design Toolbox（打开设计工具框）— 打

开 Design Toolbox xls文件。Design Toolbox提

供了通用布局指南、布局估计器、Cp和功耗值估

计器以及带实际数据的设计可行性。更多信息，

请参考该文件。 

 Generate Config File（生成配置文件）— 生成

配置(*.iic)文件，用来编程器件。 

 Apply Current Config（应用当前配置）— 编程

器件。 

 Open System Diagnostics Log – （打开系统诊

断日志）— 打开包含不同诊断数据的

<project_name>.csv文件。这些数据表示最后一

次编程器件的时间和日期。 

 Reset Tab（复位选项卡）将当前的选项卡复位为

默认设置。请参阅 Reset（复位）。 

 Reset All Tabs（复位所有选项卡）— 将所有的

选项卡复位为默认设置。请参阅 Reset（复位）。 

  

4.3 帮助菜单 

EZ-Click Help （帮助）菜单包括下面指令： 

 

 Help Topics（帮助主题）— 打开帮助文件。 

 Documentation >  

 Release Notes（发布说明）— 打开 EZ Click发布说明 
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 User Guide（用户指南）— 打开 EZ Click用户指南 

 About（相关信息）— 打开 EZ-Click About框，以查看有关版本和插

件的信息。 

  

4.4 工具栏 

 

通过工具栏，可以快速访问最常用的功能，包括： 

指令 快捷方式 说明 另外，请查看 

新项目 Ctrl + N 打开 Device Selector（器件选择器）对话框，以创建新项目。 创建新项目 

打开项目 Ctrl + O 打开用以选择现有项目的对话框。 打开现有的项目 

保存项目 Ctrl + S 保存当前的项目。 保存项目 

打印 Ctrl + P 打印当前选择的选项卡。 打印项目 

打开设计工具框 Ctrl + T 打开包含设置 CapSense项目指南的电子表格文件。   

生成配置文件 Ctrl + G 将当前的项目信息保存到一个配置文件内。该文件可被编程到器件

内。 

生成配置文件 

应用当前配置 Ctrl + L 使用当前配置文件编程器件。 编程目标器件 

打开系统诊断日志 Ctrl + D 打开显示了最后一次系统诊断的日志信息的文件。   

选择目标器件   打开 Select I2C Target对话框，以选择器件。 选择 I2C目标 

软件复位  向所连接的器件发送一个复位指令，以使器件从新的状态开始运

行。自动进行该复位操作，并且该操作是 Apply Current Config

指令的一部分。 
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5 支持 

请访问 http://www.cypress.com/support 网站，获取在线技术支持。资源包括： 

 培训研讨会 

 讨论论坛 

 应用手册 

 开发者社区 

 知识库 

 技术支持。 

您也可以在 http://www.cypress.com/support/网站上查看并参与各个 PSoC器件主题的讨论线程。 

使用赛普拉斯支持服务前，请确认您系统上所安装的 EZ-Click版本。依次选择 Help > About，确定工具

版本。 

赛普拉斯提供免费升级 EZ-Click和版本改进。可通过赛普拉斯更新管理器进行升级。赛普拉斯更新管理

器查找所有赛普拉斯产品的更新。 
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