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About this document 

Scope and purpose 

This document explains the hardware features and serves as a user manual for the EVAL_XDPP1100_Q040_DB 
daughterboard, designed by Infineon Technologies. XDPP1100-Q040 belongs to Infineon’s XDP™ digital power 

controller family, optimized to provide a high level of performance and design flexibility to DC-DC converters. 
This controller is designed to achieve high efficiency, system control, and cost savings for applications such as 

telecom, servers, data centers, and computing isolated DC-DC solutions. The daughterboard is used as a test 
and firmware (FW) development tool. 

Intended audience 

Power supply design engineers, system engineers, and embedded power designers. 

Evaluation Board 

This board is to be used during the design-in process for evaluating, configuring, and programming the device. 

Note: PCB and auxiliary circuits are NOT optimized for final customer design.  

http://www.infineon.com/
https://www.infineon.com/cms/en/product/power/dc-dc-converters/digital-power-controllers/xdpp1100-q040/
https://www.infineon.com/cms/en/product/power/dc-dc-converters/digital-power-controllers/
https://www.infineon.com/cms/en/product/power/dc-dc-converters/digital-power-controllers/
https://www.infineon.com/cms/en/applications/information-communication-technology/telecommunication-infrastructure/dc-dc/
https://www.infineon.com/cms/en/applications/information-communication-technology/hyperscale-computing/48v-power-distribution/
https://www.infineon.com/cms/en/applications/information-communication-technology/hyperscale-computing/48v-power-distribution/
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Important notice  

Important notice 

“Evaluation Boards and Reference Boards” shall mean products embedded on a printed circuit board (PCB) for 

demonstration and/or evaluation purposes, which include, without limitation, demonstration, reference and 
evaluation boards, kits and design (collectively referred to as “Reference Board”).  

 
Environmental conditions have been considered in the design of the Evaluation Boards and Reference Boards 
provided by Infineon Technologies. The design of the Evaluation Boards and Reference Boards has been tested 
by Infineon Technologies only as described in this document. The design is not qualified in terms of safety 

requirements, manufacturing and operation over the entire operating temperature range or lifetime. 
 

The Evaluation Boards and Reference Boards provided by Infineon Technologies are subject to functional 
testing only under typical load conditions. Evaluation Boards and Reference Boards are not subject to the same 

procedures as regular products regarding returned material analysis (RMA), process change notification (PCN) 
and product discontinuation (PD). 
 

Evaluation Boards and Reference Boards are not commercialized products, and are solely intended for 

evaluation and testing purposes. In particular, they shall not be used for reliability testing or production. The 

Evaluation Boards and Reference Boards may therefore not comply with CE or similar standards (including but 

not limited to the EMC Directive 2004/EC/108 and the EMC Act) and may not fulfill other requirements of the 
country in which they are operated by the customer. The customer shall ensure that all Evaluation Boards and 
Reference Boards will be handled in a way which is compliant with the relevant requirements and standards of 

the country in which they are operated. 
 

The Evaluation Boards and Reference Boards as well as the information provided in this document are 

addressed only to qualified and skilled technical staff, for laboratory usage, and shall be used and managed 
according to the terms and conditions set forth in this document and in other related documentation supplied 

with the respective Evaluation Board or Reference Board.  
 
It is the responsibility of the customer’s technical departments to evaluate the suitability of the Evaluation 
Boards and Reference Boards for the intended application, and to evaluate the completeness and correctness 

of the information provided in this document with respect to such application. 
 
The customer is obliged to ensure that the use of the Evaluation Boards and Reference Boards does not cause 
any harm to persons or third party property.  
The Evaluation Boards and Reference Boards and any information in this document is provided "as is" and 

Infineon Technologies disclaims any warranties, express or implied, including but not limited to warranties of 

non-infringement of third party rights and implied warranties of fitness for any purpose, or for merchantability.  

 
Infineon Technologies shall not be responsible for any damages resulting from the use of the Evaluation Boards 

and Reference Boards and/or from any information provided in this document. The customer is obliged to 
defend, indemnify and hold Infineon Technologies harmless from and against any claims or damages arising 
out of or resulting from any use thereof. 

 
Infineon Technologies reserves the right to modify this document and/or any information provided herein at 

any time without further notice. 
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Safety precautions 

Note: Please note the following warnings regarding the hazards associated with development systems. 

Table 1 Safety precautions 

 

Caution: The evaluation or reference board contains parts and assemblies sensitive to 
electrostatic discharge (ESD). Electrostatic control precautions are required when 
installing, testing, servicing or repairing the assembly. Component damage may result 
if ESD control procedures are not followed. If you are not familiar with electrostatic 

control procedures, refer to the applicable ESD protection handbooks and guidelines. 
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General description 

1 General description 

The EVAL_XDPP1100_Q040_DB daughterboard is used for testing and programming the 40-pin version of the 
XDPP1100 VQFN 6 mm x 6 mm controller. An onboard I2C connector allows you to interface with the XDPP1100 

controller through Infineon’s XDPP1100 graphical user interface (GUI) and a USB-to-I2C dongle. You can 
download the XDPP1100 GUI and the drivers for the UBS007A1 dongle from the Infineon Development Center.  

The daughterboard can be used as a standalone FW development tool, or used with a power board (e.g., 
EVAL_600W_FBFB_XDPP) as a complete evaluation kit. This document describes the standalone version of the 

daughterboard.  

The daughterboard uses board-to-board connectors (QTE-020-01-L-D-A) to interface the control signals from 

the daughterboard to a power board with compatible connectors (QSE-020-01-L-D-A) to establish a plug-in 
mechanism. This plug-in mechanism provides flexibility for evaluating XDPP1100 with any of its supported 
topologies. 

The board also provides the capability to use an IC socket (40QHRB50Y01G) for easy replacement of the 
XDPP1100-Q040 device instead of soldering the device onto the PCB. The IC socket is not mounted on the board 

and needs to be purchased separately. 

1.1 Daughterboard overview 

The daughterboard shown in Figure 1 consists of the control circuitry such as analog filters for processing the 

feedback signals from the power board, PWM outputs, digital inputs and outputs, I2C connector, Arm® Cortex® 

JTAG/SWD debug port, LED indicators, and the XDPP1100-Q040 controller. It can be powered using external 3.3 

V or 3.3 V supply from the power board. The board-to-board rectangular header connectors are located on the 

bottom side of the PCB, as shown in Figure 2. 
 

3.25 in. 

82.55 mm 

 
 

 

 

Figure 1 XDPP1100-Q040 daughterboard 
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Figure 2 Bottom side of the daughterboard 

1.2 Jumper settings 

Table 2 Daughterboard jumper settings 

Jumper Description Functionality 

J23 External 3.3 V This header is for the external 3.3 V supply to bias the daughterboard. If 
external 3.3 V is selected using J24, connect an external power supply 

capable of 3.3 V and 0.1 A at this jumper 

J24 3.3 V selector This jumper is used to select between external 3.3 V and 3.3 V supply 

from the auxiliary supply of the power board. By default, external 3.3 V 

supply is selected, i.e., pins 1 and 2 are shorted  

J27  3.3 V jumper This jumper is used to connect and disconnect the 3.3 V supply to VDD 

of the IC. By default, this is always populated 

J28 SMBALERT jumper  This jumper connects the pull-up resistor to the SMBALERT pin  

J29 EN jumper This jumper allows the use of the enable switch (SW1) to control the EN 

pin of the XDPP1100 device 

1.3 Test points 

The EVAL_XDPP1100_Q040_DB daughterboard consists of test points for all of the XDPP1100 pins to allow 
measurement or monitoring of signals. These test points consist of analog signals, digital signals, and PWM 

signals. Figure 3 shows the physical location of the various test points on the daughterboard. 

Connector P1 Connector P2 
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Figure 3 EVAL_XDPP1100_Q040_DB test points 

1.4 LED indications 

Table 3 shows the purpose and list of the available LEDs on the daughterboard, and Figure 4 shows the location 

of these LEDs.  

Table 3 LED indicators on the daughterboard 

LED Color Indications 

PWRGD (DS1)  Red This LED indicates the health of the loop 0 output voltage based on the 
thresholds configured through PMBus commands. During first-time 3.3 V power 

up, this is on because it is pulled up to 3.3 V 

 

Once the converter is enabled, the status of this LED is determined by the level 
of the output voltage and the polarity of the POWER_GOOD pin. The default 

logic is active LOW, but can be modified to active HIGH by modifying the GPIO 

polarity (set to 2) in the PMBus command FW_CONFIG_PMBUS 

 

When the configuration is programmed to active HIGH: 

• If the output voltage is greater than POWER_GOOD_ON: LED is on 

• If the output voltage is less than POWER_GOOD_OFF: LED is off 

EN (DS2)  Green This LED indicates the logic level of the enable pin for loop 0. The LED is on 

when the EN pin is HIGH 

Analog test points 

PWM test points 

Digital test points 
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LED Color Indications 

BPWRGD (DS3) Red This LED indicates the health of the loop 1 output voltage based on the 
thresholds configured through PMBus commands. During first-time 3.3 V 
power-up, this is on because it is pulled up to 3.3 V. Once the converter is 

enabled, the status of this LED is determined by the level of the output voltage 
and the polarity of the POWER_GOOD pin  

 

The default logic is active LOW, but can be modified to active HIGH by 
modifying the GPIO polarity (set to 2) in the PMBus command 
FW_CONFIG_PMBUS 

 

When the configuration is programmed to active HIGH: 

• If the output voltage is greater than POWER_GOOD_ON: LED is on 

• If the output voltage is less than POWER_GOOD_OFF: LED is off 

BEN (DS4)  Green This LED indicates the logic level of the enable pin for loop 1. The LED is on 

when the EN pin is HIGH 

SMBALERT (DS5) Yellow SMBALERT indicator. To enable the SMBALERT LED, short J28  

Fault 1 (DS6) Red Not used  

Fault 2 (DS7) Red Not used  
 

 

Figure 4 LED indicators  
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Getting started 

2 Getting started  

2.1 Required equipment  

• DC power supply that can provide 3.3 V and 100 mA current 

• PC with Microsoft Windows 10 (32-bit or 64-bit) 

• Oscilloscope with 500 MHz or above bandwidth (optional) 

• Infineon USB-to-I2C dongle USB007 Rev A1 or B 

2.2 XDPP1100 GUI tool 

Infineon provides a complimentary GUI tool that allows you to configure and evaluate the XDPP1100-Q040 

controller. The tool has the following key features: 

• Step-by-step design tools to configure the XDPP1100 device 

• Fault status messages 

• Telemetry reporting of VOUT, IOUT, VIN, PIN and temperature 

• Save and load design files 

• Allows storing configuration of PMBus and I2C registers into both the RAM and one-time programmable 
(OTP) memory 

• Allows storing of FW patch into both the RAM and OTP memory 

• Linear11 format calculator tool 

The following sections describe the requirements and procedure to operate and install Infineon’s GUI. 

2.3 XDPP1100 GUI installation 

Installing the XDPP1100 GUI is the first step toward evaluating the XDPP1100. Do not connect the USB-to-I2C 

dongle before the installation process is complete.  

1. Download the XDPP1100 GUI tool from the Infineon Development Center 

Refer to the XDP1100 GUI installation guide for any additional information about GUI installation or 

troubleshooting issues related to dongle connection  

https://softwaretools.infineon.com/welcome
https://www.infineon.com/dgdl/Infineon-DCDC_XDP_GUI_installation_guide-ApplicationNotes-v01_00-EN.pdf?fileId=5546d46277921c320177a5d925ad2a19
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Power-up procedure 

3 Power-up procedure 

This section describes the power-up sequence for evaluating the XDPP1100-Q040 controller after installing the  

XDPP1100 GUI. 

1. Connect an external 3.3 V DC power supply at J23 as shown below 
 

    

Figure 5 External 3.3 V connection for the daughterboard 

2. Connect one end of the USB007 dongle at J26 as shown below by matching the color of the dongle wires to 
the signal names. Connect the other end to the USB port of the PC. 

− The blue wire of the USB007A1 dongle can be used for EN control. Connect it to J29 pin2 for controlling 

the EN pin through GUI. If left floating, controlling the EN pin through GUI is not possible 

− Connect the blue wire of the USB007B dongle to 3.3 V to bias the isolated dongle. When using the 

USB007B dongle, controlling the EN pin can be done by the onboard switch SW1 with jumper J29 shorted 
 

 

   

Figure 6 USB-to-I2C dongle connection 
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Power-up procedure 

3. Turn on the 3.3 V power supply. If the USB dongle is connected and the dongle driver is installed properly, 
the USB icon at the bottom left corner will turn green. The USB hardware (HW) model and dongle FW 

version are displayed in the information bar at the bottom. If required, update the dongle firmware using 
the icon as shown below 

 

 

Figure 7 XDPP1100 GUI 

4. Use the Auto Populate shortcut button to scan the device that is connected on the I2C bus.  

If the XDPP1100 device is properly biased, the GUI tool identifies the device part number and its address 

offset, which allows you to add the device to the design. The GUI will read the stored program from the IC to 

the GUI tool. If the XDPP1100 device is not pre-programmed (blank IC when it leaves the factory), the 

registers and PMBus command have the default values (most of them are zeroes) 
 

 

Figure 8 Auto-populating device parameters 

5. Use the GUI design tool to program the device per application requirements (Figure 9).  

All configurations are in the RAM, which is a volatile memory that can be used during the evaluation phase 

to try different configuration settings without limitation. The XDPP1100 device has 32 KB RAM of which 10 
KB is reserved for the user. It is recommended to use the 10 KB RAM to verify patch and configuration. You 

 Update dongle firmware 
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Power-up procedure 

should save only the final configuration to the device’s non-volatile memory, which is one-time 
programmable (OTP). The XDPP1100 device has 64 KB available OTP space for FW patch and configuration 

 

 

Figure 9 GUI design tool 

6. Select File > Save Board Design (or, click the Save icon) to save the configuration to a design file (.pcd) that 
has the register and PMBus configuration 

 

 

Figure 10 Save configuration to design file 

7. Select File > Open Board Design to reload the design file to the device shown in Figure 11 to open the .pcd 
file. The GUI tool will show a pop-up window (Figure 12). Click Write to Device 0x10 to write the program 

into the RAM of the device 
 

 

Figure 11 Open design file 



  

User guide 13 V 1.0 

  2025-03-10 

 

EVAL_XDPP1100_Q040_DB user manual 
XDPP1100-Q040 daughterboard 

  

Power-up procedure 

 

Figure 12 Write to device operation  

For more information about the GUI tool, refer to Help in the top-left corner for additional documentation or 
refer to the XDPP1100_GUI_User_Guide.pdf file in the path C:\XDPP1100\XDPP1100_GUI. 

3.1 Force I2C connection 

The auto-populate option can add a device by detecting the product ID. The I2C communication is 
automatically set up after auto-populating. In some cases, you may need to configure a device with an 
unmatched product ID. In this case, select Options > Force i2c/PMBus OK to force-enable the I2C 

communication (Figure 13). 

 

Figure 13 Force I2C/PMBus connection 
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Power-up procedure 

3.2 Telemetry Update  

The Status tab in the GUI tool shows all the status commands such as STATUS_WORD and STATUS_VOUT.  

Do one of the following: 

• Click the Read status button to see the updated status 

• Select Options > Enable Telemetry Update to have the status and telemetry information automatically 

updated every second 
 

 

Figure 14 Enable Telemetry Update 
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Power-up procedure 

3.3 Floating meter 

The GUI tool offers a floating meter to monitor the key status of the converter such as input voltage, output 
voltage, input current, output current, input power, and temperature. 

Select Options > Show Floating Status to turn on the floating meter. Once turned on, the information will be 
shown in a pop-up window, which stays on the screen even when the GUI main window is minimized. 
 

 

Figure 15 Show Floating Status 
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Schematic and bill of materials 

4 Schematic and bill of materials 

4.1 Schematic 
 

 

Figure 16 XDPP1100_Q040 daughterboard schematic 

4.2 Bill of materials 

Table 4 BOM for daughterboard 

Item Qty. Ref. Manufacturer Part number 

1 1 BRD1  P100069 E 

2 3 C1, C2, C21 TDK C1608X7R1E105K 

3 4 C3, C4, C22, C23 TDK C1608X7R1H103K080 

4 15 C5, C6, C7, C8, C9, C10, C11, C12, C13, C14, C15, 

C16, C17, C19, C20 

TDK C1608C0G2A101K 

5 4 DS1, DS3, DS6, DS7 Würth 150060RS75000 

6 2 DS2, DS4 Würth 150060GS75000 

7 1 DS5 Würth 150060YS75000 

8 14 J1, J2, J3, J4, J5, J10, J11, J12, J13, J14, J15, 

J27, J28, J29 

Würth 613 002 111 21 

9 1 J6 Samtec FTSH-105-01-L-DV-K 

10 1 J8 Würth 613 012 111 21 

11 2 J22, J24 Würth 613 003 111 21 

12 1 J23 TE Connect 640456-2 

13 1 J25 Würth 613 008 111 21 
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Schematic and bill of materials 

Item Qty. Ref. Manufacturer Part number 

14 1 J26 Würth 613 004 111 21 

15 2 M1, M2 Keystone 8833 

16 2 P1, P2 Samtec QTE-020-01-L-D-A 

17 15 R1, R2, R3, R4, R13, R14, R15, R16, R17, R18, 

R19, R22, R23, R24, R25 

Panasonic ERJ-6ENF1000V 

18 2 R5, R7 Panasonic ERJ-6ENF4702V 

19 3 R6, R8, R9 Panasonic ERJ-6GEY0R00V 

20 12 R11, R12, R26, R27, R28, R29, R30, R31, R32, 

R44, R46, R47 

Panasonic ERJ-6ENF1001V 

21 2 R20, R21 Panasonic ERJ-6ENF2001V 

22 1 R33 Panasonic ERJ-6RQF1R0V 

23 13 R34, R35, R36, R37, R38, R39, R40, R41, R48, 

R49, R50, R51, R52 
Panasonic ERJ-6ENF1002V 

24 5 R42, R43, R45, R10, C18  Not used 

25 2 SW1, SW2 C&K GT11MCBE 

26 5 TP1, TP2, TP3, TP4, TP5 CINCH CON 129-0701-202 

27 5 TP6, TP7, TP8, TP9, TP10 Keystone 5020 

28 1 U1 Infineon XDPP1100-Q040 
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