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ModusToolbox™ Programmer version 5.6

About this document
A newer version of this document may be available on the web here.
Scope and purpose

ModusToolbox™ Programmer is a stand-alone, cross-platform, flash programmer tool that provides a graphical
user interface to Program, Erase, Verify, and Read the flash of the target device. It is delivered with the
ModusToolbox™ Programming tools package, and it supports HEX, SREC, ELF, HCD and BIN programming file
formats.
Intended audience

This document helps you learn how to use the ModusToolbox™ Programmer GUI to perform various operations
on devices.
Document conventions

Convention Explanation
Bold Emphasizes heading levels, column headings, menus and sub-menus

Italics Denotes file names and paths.

Monospace Denotes APIs, functions, interrupt handlers, events, data types, error handlers, file/folder
names, directories, command line inputs, code snippets

File > New Indicates that a cascading sub-menu opens when you select a menu item

Abbreviations and definitions

The following define the abbreviations and terms used in this document:

Term Description
CMSIS Arm® Cortex® Microcontroller Software Interface Standard.

CMSIS-DAP CMSIS Debug Access Port.

OpenOCD The Open On-Chip Debugger is the debugger tool that provides on-chip programming
support. This tool acts as a backend of the ModusToolbox™ Programmer application.

Data File The data file for programming in the hex or binary format

DP The Debug Port register of the Arm Cortex CPU. Used for programming and debugging,
along with the corresponding SWD-address bit selections.

Flash kernel/loader The firmware file loaded into the MCU's RAM. Sometimes referred to as RAM program,
Flash kernel, Flash loader.

GDB GNU Project Debugger – GNU.org.

JTAG Joint Test Action Group. Specifies the use of a dedicated debug port while implementing
a serial communication interface for low-overhead access without requiring direct
external access to the system address and data buses.

MCU Microcontroller Unit.

PSOC™ A family of microcontroller integrated circuits. These chips include a CPU core and
mixed-signal arrays of configurable integrated analog and digital peripherals.

Region Logical areas within the target device the programmer operates on.

SWD Serial Wire Debug interface.

QSPI Quad Serial Peripheral Interface. A name used for SPI external memory interfaces
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Reference documents

Refer to the Infineon programming solutions website for more information as needed.
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1 Overview
ModusToolbox™ Programmer supports the following features:
• Programming Infineon MCUs' internal and external memories

- PSOC™ 6 MCUs, including corresponding starter kits and evaluation boards
- PSOC™ 4 MCUs, including corresponding starter kits and evaluation boards
- PMG1, PAG2S and WLC1 MCUs, including corresponding evaluation boards
- EZ-PD™ CCG7S and CCG7D MCUs, CCG2, CCG3PA, CCG3PA2, CCG4, CCG6, CCG8
- XMC7xxx, XMC5xxx, CYT4BB/BF, CYT2Bx, CYT3Bx/CYT3DL
- PSOC™ Control C3
- PSOC™ Edge E84

• AIROC™ Wi-Fi/Bluetooth® platforms (CYW4390x, CYW4343W, CYW20829, CYW208xx, CYW55513 and others),
including corresponding starter kits and evaluation boards

• Connectivity devices via support of development boards
• Windows, Ubuntu and macOS
• Programming external memory devices using PSOC™ 6 external memory interfaces (EBI / QSPI)
• Programming external memory of AIROC™ Wi-Fi devices
• KitProg3 and MiniProg4 hardware
• SEGGER J-Link Base and J-Link Ultra hardware
• OpenOCD via machine interface (MI) to 3rd party debug hardware
• Cross-platform CyBridge library – I2C, SPI, UART communications and USB devices detection
• KitProg3 firmware update
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2 Installing ModusToolbox™ Programmer
ModusToolbox™ Programmer is delivered as part of the ModusToolbox™ Programming tools package. A link is
available to download/install from the IDC webpage here:
https://softwaretools.infineon.com/tools/com.ifx.tb.tool.modustoolboxprogtools
For installation details, see section 3 of the ModusToolbox™ Programming tools release notes.
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3 Getting started

3.1 Run ModusToolbox™ Programmer
To run the ModusToolbox™ Programmer GUI application, navigate to the ModusToolbox™ Programming tools
install location, open the mtb-programmer folder, and run the executable. The GUI opens and looks similar to
this:

In this case, no kit or device is connected, and a message displays asking you to connect a device.

3.2 Select device
1. Connect the device to the host computer. Select the hardware programmer in the Programmer drop-

down.

2. Select the kit name in the Board drop down.
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ModusToolbox™ Programmer displays information under Probe Settings.

3.3 Load programming file
1. Click Open.
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2. On the Open Programming File dialog, navigate to the location of the HEX, SREC, ELF, or BIN file to load,
select it, and click Open.

3.4 Connect device
1. If the device is not powered, the status message "Not Powered" is displayed in the Status Bar. Click

Power to power up the device.
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2. Click Connect. ModusToolbox™ Programmer communicates with the device and displays various
messages in the Log. Then, a message in the Status Bar indicates that it is connected.

3.5 Program device
Click Program. ModusToolbox™ Programmer downloads the program file onto the device and displays
messages in the Log.
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3.6 Save log file
Right-click in the Log section and select Save As.

Note: You can also select the Select All command to select the text, then copy and paste the text to the file
you selected.
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4 GUI description
ModusToolbox™ Programmer contains menus and toolbar commands to perform actions. This chapter
describes the various GUI elements.

4.1 Menus

4.1.1 File
The File menu contains the following commands:
• Open (Ctrl+O) – Opens the programming file.
• Connect/Disconnect (Alt+Q) – Connects and disconnects the selected device.
• Program (Alt+G) – Programs the selected device with the selected file.
• Erase (Alt+E) – Erases the selected device.
• Read (Alt+R) – Reads flash of the selected device into a HEX or SREC file.
• Verify (Alt+Y) – Verifies that the selected device is programmed correctly.
• Recent Files – Lists up to five recently loaded programming files.
• Exit (Alt+F4) – Closes the ModusToolbox™ Programmer application.
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4.1.2 View
The View menu contains the Settings check box. Select it to view the Settings section of the window; unselect
it to hide the Settings section. See Settings.

4.1.3 Options
The Options menu contains the following commands:

4.1.3.1 Programmer Options (Alt+T)
Opens the Programmer Options dialog to set the Upgrade Firmware mode and other options.

• Upgrade Firmware mode:
- Automatically – The firmware is updated automatically when the tool opens.
- Show Pop-up – A dialog displays asking if you want to upgrade the firmware.
- Ignore – The firmware is not updated and no prompt displays.

• OpenOCD Telnet Port: This option specifies the port number of the OpenOCD telnet connection.
• Kill Mode: Use this option to enable/disable the transition into Kill mode for PSOC™ 4, PMG1, PAG2S, WLC1

and CCGx devices

4.1.3.2 Upgrade Firmware (Alt+U)
When this command is enabled, select it to upgrade the programmer firmware on the device.

4.1.4 Verify Regions
• The Verify Regions menu is available only if Verify Regions option is selected in Program Settings.
• Add Region – Adds a custom flash region to the Verify Regions list.
• Reload Regions – Resets the Verify Regions list to the default state corresponding to the flash map of the

target.
• Undo (Ctrl+Z) – Undo the last change in the Verify Regions list.
• Redo (Ctrl+Y) – Redo the last change in the Verify Regions list.
• Verify – Initiates the Verify device operation.

4.1.5 Help
The Help menu contains the following commands:
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• View Help (F1) – Opens this document.
• About ModusToolbox™ Programmer – Opens the About box.

4.2 Toolbar
The toolbar contains the Open, Connect, Erase, Program, Read, and Verify commands, which are also located
on the File menu. This area also contains the following:

4.2.1 Programmer, Board, and Device
Use these pull-down menus to select the specific device to use.

4.2.1.1 Programmer
This displays a list of all currently connected probes with a serial number or other identifier (for example, COM
port number) from which you can select the desired Programmer.

4.2.1.2 Board
The Board pull-down allows you to choose the appropriate Kit name for the selected Programmer.
• Under the Scanned Boards entry, there is a short list of best matched Kit names detected by the tool.
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• Under the Others entry, there is a list of all other Kit names available for the selected programmer device.
• When selecting the Custom board, the tool allows you to manually specify the particular target device

connected to a stand-alone programmer (such as MiniProg4) or a KitProg3 with modifiable MCU module.
Custom board is only available for KitProg3, MiniProg4 and JLink programmers.

4.2.1.3 Device
This displays a list of all supported target devices. It is enabled only if you select Custom for the Board option.

4.2.1.4 Auto-completion
Board and Device pull-downs support auto-completion.
Start typing the name of the Kit in the Board pull-down and the tool will suggest corresponding board names.
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Start typing the device’s part number in the Device pull-down and the tool will suggest corresponding target
devices.

4.2.2 Power

Use the Power  button to power on and off the selected device.

4.2.3 Connect

Use the Connect  button to connect to and disconnect from the selected device.

4.2.4 Settings
The Settings section of the tool allows you to update the program and probe/target settings as follows:

4.2.4.1 Program Settings
• File – Use this to select the programming file to perform actions on or with.
• Offset – This is an optional offset parameter; it can be an integer or hexadecimal value. The relocation

offset is added to the base address for each section in the image when the image is programmed. This
option is visible only if a binary or elf file is selected for programming operations.

• Reset Chip – Use this to reset the chip after the Program operation completes. This option resets the target
chip and runs the programmed firmware on it.
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• Verify Regions – Use this option to define flash regions used during device verification. This allows to
verify user defined flash regions of the PSOC™ MCU. This option does not change behavior of the Program
operation. See Verify custom flash regions for details.

• External Memory – Enables/disables the programming of external memory in the target device. For PSOC™

6x MCUs, this option enables programming of the QSPI regions. This is also used for programming external
memory of AIROC™ Wi-Fi devices.

• Program Security Data – Allows programming security regions if the target device supports this capability.
For example, for PSOC™ 61 PSOC™ 62, and PSOC™ 63 MCUs, this option enables programming the eFuse
region.

• Target AP – Allows you to select the target access port (DAP) that will be used for programming. Possible
values include: CM0, CM4, and SYS_AP. This option is available only for PSOC™ 64 MCUs.

• Flash Size Limit – Limits the size of application flash available for programming operations. This option is
available only for PSOC™ 64 MCUs.

• Programming Mode – Use this option to define programming mode for PMG1 devices. The mode options
include:
- Reset: This programming mode enables acquisition of the target device in the Test mode.
- PowerCycle: In this mode, the programmer cycles power to acquire the device.

• Flashloader – Use this option to select the patched QSPI CMSIS flashloader file (in FLM format). This
flashloader is used for external flash programming.
Note: To be able to program custom external flash you should also provide the appropriate QSPI

configuration file (qspi_config.cfg), generated by the ModusToolbox™ QSPI Configurator tool. This
file should be located in the same directory as the patched flashloader file.

• Debug Certificate – Use this option to specify the location of the debug certificate binary file. The debug
certificate is used for programming AIROC™ CYW20829 targets in Secure lifecycle mode.

• ECC Config – Use this option to enable or disable the ECC error reporting. This option is only applicable for
read flash operations of some MCUs.

• Chip Protection – Use this option to apply Chip Protected or Kill mode for PSOC™ 4, PMG1, PAG2S, WLC1
and CCGx devices.

• RRAM Offset – Use this option to modify the offset for RRAM memory (flash bank) for PSOC™ Edge E84 EPC4
devices. The minimal allowed RRAM offset value is 0xA000.

4.2.4.2 Probe Settings
The Probe settings allow you to configure the programming and target device before you connect to it. These
settings are available when ModusToolbox™ Programmer is not connected to the device.
• Interface – To select the hardware (debug) interface for communication with the target device. The

possible values include: SWD and JTAG if supported by the device.
• JTAG Chain – To select the interested target device in the JTAG chain. This option is only available for

probes supporting JTAG interface. See Program PSOC™ 6/Control C3/Edge E84 MCU in JTAG chain for
details.

• Voltage (V) –To select the power supply voltage of the target device in Volts. This option is available only if
the selected probe has the power control capability.

• Clock (KHz) – To select the frequency of the hardware interface in KHz. This option is available only if the
selected probe supports configurable frequencies.
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• Reset Type – Specifies the type of the Reset Chip operation. The possible values include: Soft and XRES:
- Soft is a software reset type that sends the system reset request to the ARM core.
- XRES is a hardware reset type that toggles the XRES hardware line.

• Sflash Restrictions – Specifies the Sflash programming behavior. This option is available only for PSOC™

61/62/63, XMC7xxx/XMC5xxx, FX3G2, CYT3Bx/CYT3DL, CYT4Bx, CYT4DNJ, and CYT2Bx MCUs. The possible
values include:
- Erase/Program of Sflash is prohibited.
- Erase and Program of USER/TOC/KEY is allowed.
- Erase of USER/TOC/KEY and Program of USER/TOC/KEY/NAR is allowed.
- Erase and Program of entire Sflash is allowed.
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5 Programming operations
This chapter covers the various programming operations you can perform using the ModusToolbox™

Programmer tool.
• Erase device
• Program device
• Program device and Reset Chip
• Program binary file with Offset
• Program External Memory
• Program PSOC™ 6/Control C3/Edge E84 MCU in JTAG chain
• Verify device
• Verify device with External Memory
• Verify custom flash regions
• Read device
• Program eFuse region of PSOC™ 6/TRAVEO™ T2G/XMC7xxx/XMC5xxx MCU
• Program chip-protected/Kill Mode for PSOC™ 4 MCU
• Program secure AIROC™ CYW20829 MCU
• Program QSPI memory with patched flashloader
• Program AIROC™ CYW955513EVK-01 and CYW9M2BASE-43012BT boards

5.1 Erase device
1. Connect to the device (see Connect device).
2. Click the Erase button.
ModusToolbox™ Programmer erases the device and displays various messages in the Log. Then, a message in
the Status Bar indicates that the device was erased successfully or that an error occurred.

5.2 Program device
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Select the programming file as described in Load programming file section.
3. Connect to the device (see Connect device).
4. Click the Program button.
ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that device was programmed successfully or that an error occurred.
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5.3 Program device and Reset Chip
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Select the programming file as described in the Load programming file section.
3. Connect to the device (see Connect device).
4. Select the Reset Chip check box under Program Settings.
5. Click the Program button.
ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that the device was programmed successfully or that an error occurred.

The target device is reset and running.

5.4 Program binary file with Offset
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
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2. Select the binary programming file as described in the Load programming file section.
3. Connect to the device (see Connect device).
4. Enter the desired address in the Offset field under Program Settings.
5. Click the Program button.
ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that the device was programmed successfully or that an error occurred.

Note: Offset options is available only for binary programming files.

5.5 Program External Memory
1. Attach and select a device that supports external memory (for example, CY8CKIT-062-WiFi-BT with QSPI

support).
2. Select the External Memory option under Program Settings.

3. Select the programming file as described in the Load programming file section. The programming file
should contain external memory region(s) and correct QSPI configuration data.

4. Select Erase/Program USER/TOC/KEY allowed option under Probe Settings > Sflash Restrictions.
This is only needed for PSOC™ 6 devices.

5. Connect to the device (see Connect device).
6. Click the Program button.
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ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that the device was programmed successfully or that an error occurred.

5.6 Program PSOC™ 6/Control C3/Edge E84 MCU in JTAG chain
1. Connect the host computer to a MiniProg4 or J-Link probe attached to several MCU targets in the JTAG

chain.
The following hardware configuration is used in this example:

The sample JTAG chain configuration contains six serially-connected PSOC™ MCU targets.
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2. Select the MiniProg4 probe and target device in the Programmer, Board, and Device drop-downs, and
ModusToolbox™ Programmer will display information under Probe Settings. Ensure the JTAG chain is
powered.

3. Select the JTAG interface in the Interface drop-down.

ModusToolbox™ Programmer queries the JTAG chain and displays detected devices under the JTAG
Chain option in Probe Settings. The list of devices in the chain contains target names for supported
devices and ID codes for those which are not supported.

4. Select the desired target device in the list by clicking the radio button next to the target name.
5. Select the programming file as described in the Load programming file section.
6. Click Connect. ModusToolbox™ Programmer communicates with the device and displays various

messages in the Log. Then, a message in the Status Bar indicates that it is connected.
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7. Click the Program button.
ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that the device was programmed successfully or that an error occurred.

5.7 Verify device
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Select the programming file as described in the Load programming file section.
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3. Connect to the device (see Connect device).
4. Click the Verify button.
ModusToolbox™ Programmer performs the Verify device operation and displays various messages in the Log.
Then, a message in the Status Bar indicates that the device was verified successfully or that an error occurred.

5.8 Verify device with External Memory
1. Connect the device that supports external memory (for example, CY8CKIT-062-WiFi-BT with QSPI

support) to the host computer and select it in the Programmer, Board, and Device drop-downs.
2. Select the programming file as described in the Load programming file section. The programming file

should have external memory region(s).
3. Select the External Memory option under Program Settings.
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4. Connect to the device (see Connect device).
5. Click the Verify button.
ModusToolbox™ Programmer verifies the device and displays various messages in the Log. Then, a message in
the Status Bar indicates that the device was verified successfully or that an error occurred.
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5.9 Verify custom flash regions
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Select the programming file as described in the Load programming file section.
3. Connect to the device (see Connect device).
4. Expand Verify Regions option in Program Settings to see the list of flash regions available for verification.

By default, only supported by target device regions are displayed:
• application
• AUXflash
• Sflash
• eFuse
• QSPI
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5. Right-click on Verify Regions or any region entry to open the context menu.

6. To add a custom flash region, select Add Region. Select the added list entry, and enter the correct values
for start and end addresses of the region.

7. To remove any region in the list, right-click the desired region entry and select Remove Region.
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8. To revert any previous change, select Undo.
9. When finished with the list of regions, start device verification by clicking the Verify button on the

toolbar.

You can also select Verify on the context menu.

ModusToolbox™ Programmer GUI user guide

5  Programming operations

user guide 29 002-25230 Rev.*P
2025-09-24



ModusToolbox™ Programmer verifies only the regions specified in the Verify Regions list. Then, a
message in the Status Bar indicates that the device was verified successfully or that an error occurred.

10. To reset the Verify Regions list to its default state select Reload Regions from the context menu. This
action will remove all custom regions and load default regions corresponding to the flash map.

5.10 Read device
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Connect to the device (see Connect device).
3. Click the Read button.
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4. On the Read Device to File dialog, navigate to the location of the HEX or SREC file to be saved, enter the
file name, select the file type in the Save as type drop-down, and click Save.

Note: Under Ubuntu Linux, specify the full file name with an extension (e.g. kp3-dev.srec); otherwise, the file
will be saved in HEX format.

ModusToolbox™ Programmer performs the Read device operation and displays various messages in the Log.
Then, a message in the Status Bar indicates that the device was read successfully or that an error occurred.
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Note: Read Device feature is not available for the boards based on WICED-Bluetooth hardware
programmers.

5.11 Program eFuse region of PSOC™ 6/TRAVEO™ T2G/XMC7xxx/XMC5xxx
MCU

1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-
downs.

2. Select the programming file as described in the Load programming file section. The programming file
should contain valid eFuse data region (at address 0x90700000).

3. Select the Program Security Data check box under Program Settings.
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4. Connect to the device (see Connect device).
5. Click the Program button.
ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that the device was programmed successfully or that an error occurred.
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If some eFuse bits have been already programmed before, a warning message "The efuse bit at address xx has
been already blown" appears in Log.

5.12 Program chip-protected/Kill Mode for PSOC™ 4 MCU
The chip-level protection mechanism restricts access of the programmer application to silicon resources. In this
mode, access to flash, SRAM, and most of the registers in the PSOC™ 4, PMG1, PAG2s, and CCGx are disabled.

ModusToolbox™ Programmer GUI user guide

5  Programming operations

user guide 34 002-25230 Rev.*P
2025-09-24



Switch to Protected mode

If you try to connect ModusToolbox™ Programmer to a chip-protected PSOC™ 4/CCGx device, a warning message
indicates that the device is in protected mode. The only available operation is Erase device in this case.

Use the Erase button to clear chip protection and move target to the open state.
To program the Kill Mode into a PSOC™ 4 /CCGx device, go to Options -> Programmer Options and enable it in
the PSOC 4 Kill Mode drop-down.

When trying to program a HEX file that applies Kill Mode via the special region 0x90600000, confirm this
operation by clicking Yes in the dialog.
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After programming is completed, the message in the Log indicates that the device was transferred to Kill Mode
successfully (or that an error occurred).

5.12.1 Switch to Protected mode
This operation temporarily disables access to chip's resources. Use the Erase button to clear chip protection
and move the target to the open state.
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Select the Chip Protection pull-down and select Protected mode.

A warning message asking for confirmation is displays.

3. Click Yes to apply Protected mode for your PSOC™ 4, PMG1, PAG2S and CCGx.
When the operation completes, the log is appended with a message, and the device is disconnected from the
programmer automatically.
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5.12.2 Switch to Kill mode

Attention: Be aware that after applying Kill mode your device will be permanently locked from any external
debugger or programmer software. This operation is not reversible.

1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-
downs.

2. To use Kill mode, go to Options > Programmer Options and enable it in PSOC 4 Kill Mode drop-down.

3. Connect to the device (see Connect Device).
4. Click the Chip Protection pull-down and select Kill mode.

A warning message asking for confirmation is displays.

5. Click Yes to apply Kill mode for your PSOC 4, PMG1, PAG2S and CCGx.
When the operation completes, the log is appended with a message, and the device is disconnected from the
programmer automatically.

5.13 Program secure AIROC™ CYW20829 MCU
You can program the flash of an AIROC™ CYW20829 device in Secure lifecycle mode only by providing a valid
debug certificate file.
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
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2. Select the programming file as described in the Load programming file section.
3. Click on the Debug Certificate option under Program Settings and select the certificate file in the

dialog.
The path will display under Settings.

4. Connect to the device (see Connect device).
5. Click the Program button.

5.14 Program QSPI memory with patched flashloader
This feature is supported by AIROC™ CYW20829 devices, as well as PSOC™ Edge E84, XMC7100/7200 and CYT4Bx
MCUs. It allows you to specify the patched flashloader file in FLM format along with the appropriate QSPI
configuration. Patched flashloaders contain data about how your external memory is configured.
1. Connect the device to the host computer and select it in the Programmer, Board, and Device drop-

downs.
2. Select the programming file as described in the Load programming file section.
3. Select the External Memory option under Program Settings (if supported).
4. Click on the Flashloader option under Program Settings and select the patched flashloader (FLM) file in

the dialog.
The path will display under Settings.
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5. Connect to the device (see Connect device).
6. Click the Program button.

Note: To be able to program custom QSPI memory, you should also provide the appropriate QSPI
configuration file (qspi_config.cfg) generated by the ModusToolbox™ QSPI Configurator tool. This file
should be placed in the same directory as the patched flashloader file; it is located and read by
ModusToolbox™ Programmer automatically.
Refer to the QSPI Configurator user guide for more information about patching flashloaders.

5.15 Program AIROC™ CYW955513EVK-01 and CYW9M2BASE-43012BT
boards

1. Connect the device to the host computer and perform recover device procedure as described in How to
recover AIROC™ Bluetooth® devices on failure.

2. Click the Programmer pull-down and select 'WICED Bluetooth-PortXX' programmer.
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Note: The CYW9M2BASE-43012BT board should be switched to Dual UART mode first, otherwise the
WICED Bluetooth programmer will be unavailable in the Board pull-down menu. To do this,
press the hardware 'Mode' button on the Kit, hold it for 3 seconds, then release it.

3. Open the Board pull-down and select the appropriate board name (e.g., CYW955513EVK-01)
4. Select the programming file as described in the Load programming file section.
5. Connect to the device (see Connect device).
6. Click the Program button.
ModusToolbox™ Programmer programs the device and displays various messages in the Log. Then, a message
in the Status Bar indicates that the device was programmed successfully or that an error occurred.

ModusToolbox™ Programmer GUI user guide

5  Programming operations

user guide 40 002-25230 Rev.*P
2025-09-24



6 Troubleshooting

6.1 Limitations
• ModusToolbox™ Programmer does not support RAM programming, you can program only the flash

memory of a target device, except for devices that support only RAM such as CYW9M2BASE-43012BT and
CYW955513EVK-01 kits.

• Programming devices in DAPLink mode is not supported. You have to switch your device into CMSIS-DAP
BULK mode by pressing the mode selection button.

6.2 How to recover AIROC™ Bluetooth® devices on failure
If the program operation for an AIROC™ Bluetooth® device fails, it is possible the memory on the board has been
corrupted by a previously loaded application, or the application used a custom baud rate that the download
process does not detect.
To recover from this, it may be necessary to reset the board to factory defaults, as follows:
1. Press and hold the Recovery button (SW1).
2. Press the Reset button (SW2).
3. Release the Reset button (SW2).
4. Release the Recovery button (SW1).

6.3 Incorrect PSOC™ 6 device names (MPN) in JTAG chain
Some PSOC™ 6 target devices may be displayed with incorrect part numbers in the JTAG chain. This issue shows
only those PSOC™ 6 targets having incorrect value written to JTAG IDCode register.
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You can ignore this inconsistency in device names if you see the warning "Selected device does not match the
physical target device" after clicking Connect button.
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7 Upgrading firmware
The ModusToolbox™ Programmer application allows you to upgrade KitProg2, KitProg3, and MiniProg4 device
firmware.

7.1 Upgrade KitProg2 firmware
The following upgrade process is based on the CY8CKIT-062-WIFI-BT hardware.
1. Run the ModusToolbox™ Programmer application.
2. Go to Options > Programmer Options and select the Show Pop-Up value for the Upgrade Firmware

option.

3. Click OK to apply the changes.
4. Connect the device with the KitProg2 firmware to the host PC. Ensure that the KitProg2 device is in

Native KP2 mode.
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5. If LED2 is off, press the SW3 (Mode Select) button and hold it for about 1 second. When LED2 is on, the
device is ready for upgrading the firmware.

A warning dialog displays with the "Firmware is Out of Date" message.

6. Click the Upgrade Firmware button to start the upgrade process.
After the upgrade process completes, the message "Firmware of 'KitProg2-xx' upgraded successfully" displays
in the Log view. The KitProg2-xx programmer disappears from the Programmer drop-down. The Board drop-
down is populated with the names of the supported KitProg3 Kits.
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7.2 Upgrade KitProg3 on kit or MiniProg4 firmware
Follow this process to upgrade KitProg3 on a kit or MiniProg4 firmware:
1. Run the ModusToolbox™ Programmer application.
2. As needed, go to Options > Programmer Options and select the Show Pop-Up value for the Upgrade

Firmware option.
3. Connect the KitProg3/MiniProg4 device to the host PC. A warning dialog with the "Firmware is Out of

Date" message displays.

4. Click the Upgrade Firmware button to start the upgrade process.
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After the upgrade process completes, the message "Firmware of 'KitProg3-xx' upgraded successfully" or
"Firmware of 'MiniProg4 xx' upgraded successfully" displays in the Log view.
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