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ModusToolbox™ Setup program version 1.5.0

About this document
A newer version of this document may be available on the web here.
Scope and purpose

This guide provides instructions for installing ModusToolbox™ software, which is a set of tools that enable you
to integrate our devices into your existing development methodology. The guide focuses on the ModusToolbox™

Setup program to install the various packages required. Refer to the tools package release notes for details
about what is included in that package. Refer to earlier revisions of this guide for instructions to install previous
versions of ModusToolbox™ tools packages.
References

• ModusToolbox™ Software website
• Refer to the tools package quick start guide for brief instructions to start working with the tools.
• You can also refer to the ModusToolbox™ training available on GitHub.
• Refer to the tools package user guide for detailed descriptions and instructions for all the tools included

with the tools package.  
• Refer to the Dashboard user guide for instructions for using that tool. 

User guide Please read the sections "Important notice" and "Warnings" at the end of this document 002-22556 Rev. AD
www.infineon.com 2025-10-01

https://www.infineon.com/ModusToolboxInstallguide
https://www.infineon.com/ModusToolboxReleaseNotes
https://www.infineon.com/cms/en/design-support/tools/sdk/modustoolbox-software/
https://www.Infineon.com/ModusToolboxQSG
https://github.com/Infineon/training-modustoolbox
https://www.Infineon.com/ModusToolboxUserguide
https://www.infineon.com/ModusToolboxDashboard
https://www.infineon.com


Table of contents

About this document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Table of contents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

1 Installation instructions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
1.1 General information . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
1.2 Installing with Setup program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.3 Installing in non-default user home directory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
1.4 Advanced installation instructions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
1.5 Run the Dashboard (optional) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

2 Setup program GUI description . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
2.1 Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
2.2 Main toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16
2.3 Packages view . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
2.4 Log panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
2.5 Preferences dialog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

3 Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.1 How to collect logs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.2 Unable to login with Infineon Developer account . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.3 Unable to download packages (network or lack of access issues) . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
3.4 Infineon Launcher Service doesn’t function properly . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
3.5 Infineon Launcher Service is not installed/was partially removed . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
3.6 ModusToolbox™ Setup program is stuck downloading or installing a program . . . . . . . . . . . . . . . . 21
3.7 Network issues . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
3.8 Expired SSL certificate for “softwaretools.infineon.com” site . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Revision history . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .24

Disclaimer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

ModusToolbox™ software installation guide

Table of contents

User guide 2 002-22556 Rev. AD
2025-10-01



1 Installation instructions
This chapter focuses on installation instructions and related information.
• General information
• Installing with Setup program
• Installing in non-default user home directory
• Advanced installation instructions
• Run the Dashboard (optional)

1.1 General information
Since the 3.2 release of ModusToolbox™ software, the Setup program provides the easiest method to install the
various packages and packs you need to create, build, and debug applications for various Infineon devices. It
also helps you manage all these pieces, learn about new packages and install them, and keep them up to date.
• During initial installation, it allows you to select the pieces of ModusToolbox™ software that interest you.

This includes platform tools, patches, packs and programming tools.
• During development, it gives you an easy way to track versions and update/install/uninstall content as

needed.
• If you attempt to create an application or add a library that requires content not currently installed, the

associated tools (including Project Creator and Library Manager) will inform you of the required packages.
This section covers a few general aspects of installing ModusToolbox™ software.

1.1.1 System requirements
The ModusToolbox™ tools package consumes approximately 2 GB of disk space. Like most modern software, it
requires both free disk space and memory to run effectively. We recommend a system configuration with a
PassMark CPU score > 2000 (cpubenchmark.net), at least 25 GB of free disk space, and 8 GB of RAM. The product
will operate with fewer resources; however, performance may be degraded.
ModusToolbox™ software is supported on the following 64-bit operating systems:

Host OS Supported Recommended

Windows 10 *, 11 11

macOS Ventura, Sonoma, and Sequoia (Intel processors and Arm® processors
via Rosetta)

Sequoia

Linux Ubuntu 22.04 LTS, 24.04 LTS, 25.04 24.04 LTS

Note: ModusToolbox™ software is not supported on 32-bit operating systems.

* The following older versions of Windows 10 are not supported. If you encounter an issue, contact technical
support.
• Windows Server 2016
• Windows 10 Enterprise LTSB 1607
• Windows 10 1607
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1.1.2 Prerequisites
The ModusToolbox™ Setup program depends on the Infineon Developer Center Launcher Service. This service is
automatically installed by the ModusToolbox™ Setup installer.
On Ubuntu Linux, the Setup program depends on the “sudo” and “apt” utilities to perform the automated
installation of the ModusToolbox™ packages. Additionally, the “gnome-terminal” application is used to perform
the interactive uninstallation of the packages and self-update of the tool. These are standard tools provided in
Linux.
On macOS, the Setup program depends on the “sudo” and “Installer” utilities to perform the automated
installation of the packages. Additionally, “osascript” utility is used to perform the uninstallation. These utilities
are provided as part of default macOS installation.

1.1.3 Internet access
In order to use the ModusToolbox™ Setup program installer, you will need access to the Infineon website to
download it: https://softwaretools.infineon.com/tools/com.ifx.tb.tool.modustoolboxsetup
If you do not have access, work with your IT department to download on your machine or have the software
placed on a local server or a thumb drive. See also Installing with firewall or lack of web access later in this
document.

1.1.4 Spaces or illegal characters in home directory
Because the ModusToolbox™ build system is based on GCC make, you cannot have spaces or illegal characters
in your home directory name. Various commands will fail. If you have such a home directory, you need to follow
instructions described in Installing in non-default user home directory.

1.1.5 Python
Several types of ModusToolbox™ applications require Python such as those including MCUBoot, CySecureTools,
and OPTIGA™ Trust M. Python is not included in the ModusToolbox™ tools package. Refer to KBA239118 for
information about downloading and installing Python.

1.1.6 SEGGER J-Link
If you plan to use the SEGGER J-link debugger, you must download and install the appropriate software pack
for your OS. It is not included with the ModusToolbox™ tools package. Use version 6.98 or later. For Linux, if you
install this using the tar.gz file, make sure you install J-Link in a common location. Otherwise, you must
configure the Eclipse IDE to specify the location, as follows:
Window > Preferences > MCU > Global SEGGER J-Link Path
• Executable: JLinkGDBServerCLExe
• Folder: <J-Link_extracted_location>
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1.2 Installing with Setup program
The easiest way to install ModusToolbox™ software is to use the ModusToolbox™ Setup program. After you install
it, you need to launch Setup program to view and select various ModusToolbox™ packages to install. As
packages are updated to new versions over time, you can then use the Setup program to update your system,
and the Setup program will even check to update itself. This section contains the following steps:
• Downloading the Setup program
• Installing the Setup program
• Launching the Setup program
• Installing the minimum required software packages
• Installing packs

Note: The Setup program version is separate from the versions of the tools packages and various other
packages. Each different program and package will likely be updated at different times instead of all
at the same time.

1.2.1 Downloading the Setup program
The Setup program is available from the Infineon website: https://softwaretools.infineon.com/tools/
com.ifx.tb.tool.modustoolboxsetup

Select your operating system and click the Download button.

Note: In some cases, you may see an Install via Launcher button. If so, ignore it and use the Download
option.
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1.2.2 Installing the Setup program
When the download completes, follow the instructions for your operating system.

macOS

On macOS, launch the installer and follow the wizard. The default is to install for all users in Applications.

Linux

On Linux, open a terminal and run sudo apt install <package-name>.deb. The Debian package doesn’t provide
a user option and installs for all users in /opt/Tools.

Note: If you see a message similar to this:
"N: Download is performed unsandboxed as root as file '/home/{username}/Downloads/
ModusToolboxSetupInstaller_1.X.Y.Z_linux_x64.deb' couldn't be accessed by user '_apt'. -
pkgAcquire::Run (13: Permission denied)",
Simply disregard it, as this message is not an error, but a notice informing you that 'apt' tool accesses
the package file under the "root" user instead of "_apt" user having restricted rights. This does not
affect the installation process of the tool.

Windows

On Windows, launch the installer, and select Install for me only (recommended) in most cases.
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1.2.3 Launching the Setup program

Initial installation

On the final screen of the installer, there will be an option to launch the Setup program and to open the release
notes. If you select the options, they will open automatically when you click Finish. If you choose to launch the
Setup program later, you can do so as applicable for your operating system.
If you do not have any ModusToolbox™ tools package installed, the Setup program opens showing you two
options:
• Default – Selects all the newest minimum required packages.
• Custom – Allows you to select the packages you want.

Subsequent uses

After you have installed a ModusToolbox™ tools package, the Setup program will open showing you what is
installed, as well as any other packages that are available. Refer to the Setup program GUI description section
for more details.
Also after installing, you can also launch the Setup program from the Dashboard, as well as from various tools
such as Project Creator or Library Manager if they prompt you when your application does not have a required
asset.
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1.2.4 Installing the minimum required software packages
To install the minimum required software:
1. Click the Default option if it is available. This will select the latest versions of these packages

automatically (as shown in Step 3):
• Eclipse, unless the Setup program detects that VS Code is installed. If so, Eclipse is not selected.
• GCC
• Tools package
• Edge Protect Security Suite
• Programming tools

2. If the Default option is not available, or if you want to choose other the packages using the Custom
option, select the ModusToolbox™ Tools package version you want to install. This will also select the
dependencies as described in Step 1.

Note: Earlier releases of the ModusToolbox™ tools package included Eclipse and GCC. They are now
separate installable packages.

3. Click Next >.
This screen shows the packages that will be installed, with links to the release notes, license, and custom
installation options for each package. We recommend using the default installation options. See Choose
the customize installation option if you need to install in a non-default location.

ModusToolbox™ software installation guide

1  Installation instructions

User guide 8 002-22556 Rev. AD
2025-10-01



4. Select the I agree to the licenses … check box and click Start.
The Setup program will download and install the selected packages.

Note: Installing Programming tools and some other packages may require an Administrator user
name and password to proceed.
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Note: Clicking the Cancel button will not affect install operations that have already started; only
pending install operations will be stopped.

5. When all packages are installed, the Setup program shows options to run various tools. Click Run for the
tools you wish to start.

6. Click Finish to return to the select packages window, or click File > Exit to close the Setup program.

1.2.5 Installing IDEs
You can use the Setup program to install the Eclipse IDE as a separate package. Just select it from the list.
You can also use the Setup program to download Microsoft Visual Studio Code to install it separately. Click on
the "Download MS VS Code" link. In the opened browser window, download the installation package suitable
for your system and install it manually following platform-specific guides on https://code.visualstudio.com/
docs/setup/setup-overview. On Ubuntu Linux, the recommended packages are "deb" or "snap". On macOS,
download and extract the .zip archive content and drag "Visual Studio Code.app" to the Applications folder.
After the installation is complete, return to the ModusToolbox™ Setup window and click the Refresh button to
update the UI.
Once either IDE is installed, the Setup program provides a button to launch it.
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1.2.6 Installing packs
After installing the minimum required software packages, you are ready to begin developing your application
using the ModusToolbox™ ecosystem. Our devices and software support multiple technologies. Review these
webpages to learn more. You can use the Setup program to install additional packs as needed.
• Machine Learning
• Connectivity
• Industrial
• Security
Refer also to the tools package user guide for a complete description of the ModusToolbox™ ecosystem,
information about the build system, manifest, and BSPs, as well as instructions about how to get started
creating and building an application.
There are two kinds of packs:
• Technology packs - long term packs that provide extended technology software and tools as noted above.
• Early access packs - short term packs to provide selected customers access to newer devices and

technology that is still being developed.

1.2.6.1 Installing technology packs
To install a particular technology pack, you can just select it in the Setup program. There are no special
requirements to install and use these types of packs, other than having the base tools package and
dependencies already installed.

1.2.6.2 Installing early access packs
To install an early access pack, you must be given access. This may include signing a non-disclosure agreement
(NDA). Once you have permission, you will be able to see available early access packs when you log in to the
Setup program. Then, you can select it and download/install it the same as any pack or package.
In order to use an early access pack, you must enable it using the Settings tool. Refer to the Settings tool user
guide for details about that tool.

1.3 Installing in non-default user home directory
If your default user home directory contains spaces or illegal characters, or if you need to install for all users,
the Customization dialog prevents you from installing into that directory or warns you about needing to set the
CY_TOOLS_PATHS variable.
If possible, create a new user account and user home directory that doesn’t contain spaces or illegal characters.
Then, you can just use the default process for that account. If you cannot create a new user home directory,
then you must perform some extra manual installation steps.
The same is true if you install for all users in a non-default user home directory.

1.3.1 Choose the customize installation option
If your default installation directory contains spaces or illegal characters, or if you want to install the
ModusToolbox™ tools package in a non-default location, select the Customize installation option on the verify
page:
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This opens the Customization Installation dialog to change the scope of the install (all users or current user)
and the installation path. If you specify a non-default location, a message displays as a reminder to set the
CY_TOOLS_PATHS environment variable. You will also have to specify a few other variable when the installer
completes.

Specify an alternate installation path that does not include spaces. For example:
C:\Infineon\ModusToolbox
Any path without spaces or illegal characters will work.

1.3.2 Create directories
When installing in a non-default location, you should create a couple directories. You can choose any path as
long as it doesn’t contain spaces. :
1. Create a hidden "dot" directory named ".modustoolbox" for variable locations described later in this

section. For example:
C:\MyPath\.modustoolbox

2. Also, create a directory to store your workspaces. For example:
C:\MyPath\mtb-projects

1.3.3 Create variable to specify the path to Tools
Because you are installing ModusToolbox™ into a non-default location, you need to specify the path to your
"tools" directory using an Environment Variable. Open the Environment Variables dialog, and create a new
System or User Variable, depending on your installation type (current user or all users). For example:

CY_TOOLS_PATHS = C:/MyPath/ModusToolbox/tools_3.4

Note: Use a Windows-style path (not Cygwin-style, like /cygdrive/c/). Also, use forward slashes.
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1.3.4 Create variable to specify the global path
You also need to specify the global path using an Environment Variable. Open the Environment Variables
dialog, and create a new System or User Variable, depending on your installation type (current user or all
users). For example:

CY_GETLIBS_GLOBAL_PATH = C:/MyPath/.modustoolbox/global

Note: Use a Windows-style path (not Cygwin-style, like /cygdrive/c/). Also, use forward slashes.

1.3.5 Specify the custom path to use for Local Content Storage
If you use Local Content Storage (LCS) to enable work without access to the Internet, set this variable to specify
where the content will be stored. For example:

MTB_LOCAL_CONTENT_PATH = C:/MyPath/.modustoolbox/lcs

1.4 Advanced installation instructions
These sections contain additional instructions for various cases.

1.4.1 Installing with previous versions
The ModusToolbox™ tools package installs alongside previous versions of the software (version 3.2, 3.0, 2.4, 2.3,
etc.); therefore, all versions can be used independently. However, be aware that various programs including the
Eclipse IDE and the build system will detect and use the most current version of the "tools" directory by default.
For example, if you have both versions 3.4 and 3.3 installed, and if you launch the Project Creator from the
Eclipse IDE for version 3.3, it will open the version from the "tools_3.4" directory instead of the "tools_3.3"
directory.
To control this behavior, use the environment variable CY_TOOLS_PATHS as described in the "Product Versioning"
section in the tools package user guide. This variable applies to all versions of the ModusToolbox™ tools
package, so you will have to update it as you work with different versions. You can add this variable as an
environment variable for all applications, or add it to a specific application only in the Makefile.

1.4.2 Installing with firewall or lack of web access
After the ModusToolbox™ software is installed, you will need access to the web to create applications, which
download libraries from GitHub.com. If your site is behind a firewall, you can set up proxy information using the
Project Creator tool. If GitHub.com is blocked for your site, you can use the Manifest DB Settings to point to a
mirror or custom site. Refer to the Project Creator user guide for more information.
If you have no access to the web at all, you can use the Local Content Storage (LCS) Manager feature to create a
copy of the database on your system. You will need one-time web access to set it up. Refer to the LCS Manager
CLI user guide for more information.

1.4.3 Installing without the Setup program (offline installation)
ModusToolbox™ software consists of many packages and packs that can be downloaded and installed
individually. In some cases, you may not want to use the Setup program to install the ModusToolbox™ software.
We refer to this as "offline installation." You need to download and install the packages you want, or install
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them with the Infineon Developer Center (IDC) locally or on the web. Just be aware that some ModusToolbox™

packages have dependencies on others. So, you’ll have to install dependencies as well.
For detailed instructions about how to install without the Setup program, refer to https://
community.infineon.com/t5/Knowledge-Base-Articles/Installing-ModusToolbox-software-without-the-Setup-
program/ta-p/945668.
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1.5 Run the Dashboard (optional)
The ModusToolbox™ tools package includes an optional Dashboard tool. To run the Dashboard select the option
on the final page of the Setup program after installation has complete. You can also run the Dashboard as
follows:
• Windows: Select the "dashboard" item from the Windows Start menu.
• Linux: Navigate to /<install-path>/ModusToolbox/tools_<version>/dashboard and run the executable.
• macOS: Run the "dashboard" app.

The Dashboard provides links to various sources of documentation and training materials. It also contains
starting points: create a new application, create/edit a BSP, install or launch the ModusToolbox™ Setup
program. For more details, refer to the Dashboard user guide.
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2 Setup program GUI description
The main GUI window of the ModusToolbox™ Setup program contains the following elements:
• Main menu
• Main toolbar
• Packages view
• Log panel

2.1 Menus
The main application menu consists of multiple menu item groups as defined below.

2.1.1 File
The File menu consists of the following menu items:

Menu item Description

Login / Logout The login function provides access to installable packages from the IDC.
The login is the same as the IDC login. If you don't already have an account, you can
create one at https://community.infineon.com.

Refresh Checks the server for any updates and refreshes the Setup program.

Preferences Opens the Preferences dialog.

Exit Exits the ModusToolbox™ Setup program.

2.1.2 Help
The Help menu consists of the following menu items:
• View Help – Opens this document.
• Check for updates – Manually checks to see if there are any updates to the Setup program itself. The

tool can be configured to check for updates on startup. If updates are available, the ModusToolbox™ Setup
Installer package is downloaded and executed once the program is closed.

• About – Opens the About box for version information, with links to open https://www.infineon.com, the
current session log file, and the Infineon Developer Center Launcher Service log file.

2.2 Main toolbar
The main toolbar consists of Login, Logout and Preferences buttons. While Login is visible, Logout is not.
When you are logged in, your email address is displayed along with the Logout button.
The Preferences button opens the Preferences dialog. The Refresh button initiates a refresh of the list of
available packages.
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2.3 Packages view
The Setup program gathers package data from the IDC online and local tools registry, and then displays all
installed and available packages along with version information. For the purposes of this document, a package
includes ModusToolbox™ platform tools, patches, packs, programming tools, and other tools such as the
Memory Analyzer. The Setup program displays a list of the available packages, grouped by two categories:
• Base Installation, IDEs, and Toolchain Packages: This includes the ModusToolbox™ tools packages,

Eclipse, VS Code, and GCC..
• Additional Packages: This includes all other packages relevant to the ModusToolbox™ ecosystem,

including programming tools, technology packs, early access packs, and auxiliary tools.

Some of the packages require you to be logged in to download and install, while ModusToolbox™ platform
tools, programming tools, and ModusToolbox™ Machine Learning Pack, Visual Studio Code do not.
As you select various packages, the description on the right describes the action to take next.

2.4 Log panel
The log panel area displays the information messages relevant for you. Examples of events that produce
messages to the panel view:
• Logged in/logged out
• Completed/failed downloading the tool data from the online tool registry
• Package was selected/deselected in the tool selection view
• Dependent package version was changed (to satisfy the updated tool dependency constraints)
• Tool configuration (installation mode, target directory was changed)
• Tool download started/finished
• Tool installation/uninstallation started/finished
See How to collect logs in the troubleshooting section.
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2.5 Preferences dialog
You can open the Preferences dialog from the main menu or main toolbar button.

The following settings are available:
• Update site URL: The address of the IDC Online Tools registry. Usually there is no need to customize this

address to a non-default URL.
• Logs Directory: The path to the directory where log files are stored. By default, this is the system

temporary directory.
Note: After choosing a directory for logs, the program will create a "ModusToolboxSetup" sub-folder

there where log files are kept.

• Check for updates on start: disable this option to prevent the program from automatically checking for an
update at each start.

Use the Restore Defaults button to revert the options back to their default values.
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3 Troubleshooting

3.1 How to collect logs
If any errors occur when running the program, ModusToolbox™ Setup and Infineon Developer Center Launcher /
Launcher Service, logs may be invaluable for resolving possible issues. To collect the ModusToolbox™ Setup
current-session log, go to Help > About > Log(s). Logs from previous sessions can be found as follows:

OS Log directory path

Windows
(Current User)

%USERPROFILE%/AppData/Local/Temp/ModusToolboxSetup

Linux™ $HOME/tmp/ModusToolboxSetup

macOS /private/var/folders/[some tmp folder]/ModusToolboxSetup

Note: Since logs are stored in a temporarily location, they will be deleted on MacOS and Linux™ on reboot. To
prevent deletion, you can change the directory where logs are stored in the Preferences dialog.

If Infineon Developer Center is installed, the logs can be accessed via the Help > Contact us > Generate
Support Document option. If only the Infineon Developer Center Launcher Service is installed, logs can be
found as follows:
Go to Help > About > Log(s) and click on the “IDC Launcher Service Log(s)” link to open logs in the text editor
window, or find the logs file directly in:

OS Log directory path

Windows
(Current User)

%USERPROFILE%/AppData/Local/Infineon_Technologies_AG/Launcher-Service/resources/
logs

Linux™ $HOME/.local/share/ Infineon_Technologies_AG/Launcher-Service/resources/logs

macOS $HOME/Library/Application Support/ Infineon_Technologies_AG/Launcher-Service/resources/
logs

3.2 Unable to login with Infineon Developer account
Open https://community.infineon.com/ in the browser and create an account. Then, use the Login button to
open the login form and enter the login and password.

3.3 Unable to download packages (network or lack of access issues)
If there are network issues, but still you have access to the web, download the interested package(s) from the
IDC web page https://softwaretools.infineon.com/tools/, and install manually.
• On Windows run the package installer executable and follow installation instructions. Installers for

Windows usually provide options to install for current user or for all users of the same computer along
with possibility to select a custom installation path.

• On Linux navigate to the location of the *.deb file in the terminal and type the following command:

$ sudo apt install ./<package name>_<version>.deb

• On macOS double-click the downloaded *.pkg file and follow the installation wizard.
Alternatively, start the ModusToolbox™ Setup program on a different PC with a network connection, install the
required packages, and copy the installer(s) from the package download directory to your PC.
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Location of the download directory:

OS Download directory path

Windows %USERPROFILE%\AppData\Local\Infineon_Technologies_AG\Infineon-Toolbox\Tools

Linux™ $HOME/.local/share/Infineon_Technologies_AG/Infineon-Toolbox/Tools

macOS $HOME/Library/Application Support/Infineon_Technologies_AG/Infineon-Toolbox/Tools

If you are trying to install (purchasable) software, but don't have access to it, you will see an error message
similar to this:

Then, you can click on a link in the message, and request access to the interested software.

3.4 Infineon Launcher Service doesn’t function properly
If there are issues with the Launcher Service such as:
• An error during login stating “Error: Failed to Login: Failed to Discover Launcher service port”
• Issues with login to myInfineon account or issues during software installation process
• An error stating "Failed to check for the ModusToolbox™ Setup update: 'Failed to discover Launcher Service

port'"
• An error stating "Download package failed: Failed to discover Launcher Service port"
1. Close the ModusToolbox™ Setup program.

2. Close the Launcher Service using the system tray icon ( ).
3. Delete the launch.conf file from the resource folder.

Windows %USERPROFILE%\AppData\Local\Infineon_Technologies_AG\Launcher-
Service\resources\launcher.conf

Linux $HOME/.local/share/Infineon_Technologies_AG/Launcher-Service/resources/
launcher.conf

macOS $HOME/Library/Application\ Support/Infineon_Technologies_AG/Launcher-
Service/resources/launcher.conf

4. Start the ModusToolbox™ Setup program again, which will start a new instance of the Launcher Service.
If after steps above the Infineon Launcher Service still doesn't function correctly, check availability of the
service on the machine and manually restart the service:

Windows %USERPROFILE%/Infineon/LauncherService/idc-launcher-service.exe

Linux /opt/LauncherService/idc-launcher-service

macOS /Library/Infineon/LauncherService/idc-launcher-service.app

To restart the service manually:
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1. Close the Launcher Service using the system tray icon.
2. Go to the folder where the Launcher Service executable is installed.

• On Windows command prompt, execute this command:

start /B idc-launcher-service

• On Linux, execute this command:

idc-launcher-service &

• On macOS, execute this command:

open -a idc-launcher-service &

3.5 Infineon Launcher Service is not installed/was partially removed
Close the running processes of the ModusToolbox™ Setup program and re-install ModusToolbox™ Setup.
On Windows, if the Infineon Launcher Service was partially removed (uninstallation wasn’t done via Apps &
Features menu or via unins000.exe ), the Windows Registry might still hold entry for the service. To fix this issue,
delete the entry for the service:
1. Open the Registry Editor.
2. Under HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall, find the

{7FE3184F-6527-44F2-9F92-B2B8D4D0935E}_is1 entry, right-click on the entry and select Delete.
3. Reinstall ModusToolbox™ Setup program.
On Linux, if the Infineon Launcher Service was partially removed it may still be registered in the dpkg database.
To fix the issue run the following command from the terminal:

$ sudo apt remove idc-launcher-service

3.6 ModusToolbox™ Setup program is stuck downloading or installing a
program

1. Close the running processes of the ModusToolbox™ Setup program and Infineon Launcher Service using
the Task Manager.

2. Start the ModusToolbox™ Setup program again.
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3.7 Network issues
ModusToolbox™ Setup program requires a working internet connection. The program doesn’t work in cases
where access to the infineon.com servers are blocked by a firewall or proxy.
The following list of networking resources must be accessible on the machine for the Setup program to function
properly:
• redirectURL = "http://localhost:45210/infineon-toolbox/oidc/callback"
• authURL = "https://sso.infineon.com/as/authorization.oauth2"
• authPortNumber = ":45210"
• callbackURI = "/infineon-toolbox/oidc/callback"
• redirectTokenURL = "https://sso.infineon.com/as/token.oauth2"
• deviceAuthorizationURL = "https://sso.infineon.com/as/device_authz.oauth2"
• revokeURL = "https://sso.infineon.com/as/revoke_token.oauth2"
• toolsRepo = "https://softwaretools.infineon.com"
• updateToolsURL (REST endpoint) = "https://softwaretools.infineon.com/api/v1/tools/"

3.8 Expired SSL certificate for “softwaretools.infineon.com” site
The list of available for download tools is not displayed by ModusToolbox™ Setup in this case. The program
displays “Failed to fetch tools information …” error in the Log panel, and “SslHandshakeFailedError” is
reported by debug logs available in Help > About > Log(s).
ModusToolbox™ Setup program requires HTTPS access to https://softwaretools.infineon.com site.
ModusToolbox™ Setup uses the standard system SSL certificate storage on your PC.
To solve the issue, you will need to update the required SSL certificate manually on macOS and Ubuntu
systems:

On macOS:

1. Open web browser and go to https://www.ssl.com/repository site. This is the worldwide certification
authority company (International Trust Services Provider).

2. Download the latest SSL.com Root CA Certificate - "SSL.com TLS RSA Root CA 2022" in PEM format (the
first one under “SSL.com Root and Intermediate Certificates” section).

3. Open “Applications/Utilities/Keychain Access” in Finder.
4. Select "System" entry on the left panel and click on "Certificates" tab.
5. Drag and drop the downloaded "SSL.com TLS RSA Root CA 2022.pem" file to 'Certificates' window.
6. Double click on "SSL.com TLS RSA Root CA 2022" name in the list of certificates. Then open the 'Trust'

entry and select "Always Trust" in 'When using this certificate' drop down:

7. Close Keychain Access and check if ModusToolbox™ Setup is working.
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On Linux:

Update the standard “CA-Certificates” Ubuntu package with the command:

$ sudo apt install -y ca-certificates
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