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ModusToolbox™ Setup program version 1.7.0

About this document
A newer version of this document may be available on the web here.
Scope and purpose

This guide provides instructions for installing ModusToolbox™ software, which is a set of tools that enable you
to integrate our devices into your existing development methodology. The guide focuses on the ModusToolbox™

Setup program to install the various packages required. Refer to the tools package release notes for details
about what is included in that package. Refer to earlier revisions of this guide for instructions to install previous
versions of ModusToolbox™ tools packages.
References

• ModusToolbox™ Software website
• Refer to the tools package quick start guide for brief instructions to start working with the tools.
• You can also refer to the ModusToolbox™ training available on GitHub.
• Refer to the tools package user guide for detailed descriptions and instructions for all the tools included

with the tools package.
• Refer to the Dashboard user guide for instructions for using that tool.
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1 General information
Since the 3.2 release of ModusToolbox™ software, the Setup program provides the easiest method to install the
various packages and packs you need to create, build, and debug applications for various Infineon devices. It
also helps you manage all these pieces, learn about new packages and install them, and keep them up to date.
• During initial installation, it allows you to select the pieces of ModusToolbox™ software that interest you.

This includes platform tools, patches, packs and programming tools.
• During development, it gives you an easy way to track versions and update/install/uninstall content as

needed.
• If you attempt to create an application or add a library that requires content not currently installed, the

associated tools (including Project Creator and Library Manager) will inform you of the required packages.
This section covers a few general aspects of installing ModusToolbox™ software.

1.1 System requirements
The ModusToolbox™ tools package consumes approximately 2 GB of disk space. Like most modern software, it
requires both free disk space and memory to run effectively. We recommend a system configuration with a
PassMark CPU score > 2000 (cpubenchmark.net), at least 25 GB of free disk space, and 8 GB of RAM. The product
will operate with fewer resources; however, performance may be degraded.
ModusToolbox™ software is supported on the following 64-bit operating systems:

Host OS Supported Recommended (full
testing)

Windows 11 11

macOS (Intel®

processor)
Not supported Not supported

macOS (Arm®

processor)
Sonoma, Sequoia, and Tahoe (Native ARM) Tahoe

Linux Ubuntu 22.04 LTS, 24.04 LTS, 25.04 24.04 LTS

Note: ModusToolbox™ software is not supported on 32-bit operating systems.
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1.2 Prerequisites
The ModusToolbox™ Setup program depends on the Infineon Developer Center Launcher Service. This service is
automatically installed by the ModusToolbox™ Setup installer.
On Ubuntu Linux, the Setup program depends on the “sudo” and “apt” utilities to perform the automated
installation of the ModusToolbox™ packages. Additionally, the “gnome-terminal” application is used to perform
the interactive uninstallation of the packages and self-update of the tool. These are standard tools provided in
Linux.
On macOS, the Setup program depends on the “sudo” and “Installer” utilities to perform the automated
installation of the packages. Additionally, “osascript” utility is used to perform the uninstallation. These utilities
are provided as part of default macOS installation.

1.3 Internet access
In order to use the ModusToolbox™ Setup program installer, you will need access to the Infineon website to
download it: https://softwaretools.infineon.com/tools/com.ifx.tb.tool.modustoolboxsetup
If you do not have access, work with your IT department to download on your machine or have the software
placed on a local server or a thumb drive. Refer also to the "Installing with firewall or lack of web access"
section in the Advanced ModusToolbox™ installation instructions.

1.4 Spaces or illegal characters in home directory
Because the ModusToolbox™ build system is based on GCC make, you cannot have spaces or illegal characters
in your home directory name. Various commands will fail. If you have such a home directory, you need to follow
instructions described in Installing using non-silent option.

1.5 Python
Several types of ModusToolbox™ applications require Python such as those including MCUBoot, CySecureTools,
and OPTIGA™ Trust M. Python is not included in the ModusToolbox™ tools package. Refer to KBA239118 for
information about downloading and installing Python.

1.6 SEGGER J-Link
If you plan to use the SEGGER J-link debugger, you must download and install the appropriate software pack
for your OS. It is not included with the ModusToolbox™ tools package. Use version 6.98 or later. For Linux, if you
install this using the tar.gz file, make sure you install J-Link in a common location. Otherwise, you must
configure the Eclipse IDE to specify the location, as follows:
Window > Preferences > MCU > Global SEGGER J-Link Path
• Executable: JLinkGDBServerCLExe
• Folder: <J-Link_extracted_location>
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2 Installation instructions
The easiest way to install ModusToolbox™ software is to use the ModusToolbox™ Setup program. After you install
it, you need to launch Setup program to view and select various ModusToolbox™ packages to install. As
packages are updated to new versions over time, you can then use the Setup program to update your system,
and the Setup program will even check to update itself. This section contains the following steps:
• Downloading the Setup program
• Installing the Setup program
• Launching the Setup program
• Installing the minimum required software packages
• Installing packs

Note: The Setup program version is separate from the versions of the tools packages and various other
packages. Each different program and package will likely be updated at different times instead of all
at the same time.

2.1 Downloading the Setup program
The Setup program is available from the Infineon website: https://softwaretools.infineon.com/tools/
com.ifx.tb.tool.modustoolboxsetup

Select your operating system and click the Download button.

Note: In some cases, you may see an Install via Launcher button. If so, ignore it and use the Download
option.
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2.2 Installing the Setup program
When the download completes, follow the instructions for your operating system.

macOS

On macOS, launch the installer and follow the wizard. The default is to install for all users in Applications.

Linux

On Linux, open a terminal and run sudo apt install <package-name>.deb. The Debian package doesn’t provide
a user option and installs for all users in /opt/Tools.

Note: If you see a message similar to this:
"N: Download is performed unsandboxed as root as file '/home/{username}/Downloads/
ModusToolboxSetupInstaller_1.X.Y.Z_linux_x64.deb' couldn't be accessed by user '_apt'. -
pkgAcquire::Run (13: Permission denied)",
Simply disregard it, as this message is not an error, but a notice informing you that 'apt' tool accesses
the package file under the "root" user instead of "_apt" user having restricted rights. This does not
affect the installation process of the tool.

Windows

On Windows, launch the installer, and select Install for me only (recommended) in most cases.
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2.3 Launching the Setup program

Initial installation

On the final screen of the installer, there will be an option to launch the Setup program and to open the release
notes. If you select the options, they will open automatically when you click Finish. If you choose to launch the
Setup program later, you can do so as applicable for your operating system.
If you do not have any ModusToolbox™ tools package installed, the Setup program opens showing you two
options:
• Default – Selects all the newest minimum required packages.
• Custom – Allows you to select the packages you want.

Subsequent uses

After you have installed a ModusToolbox™ tools package, the Setup program will open showing you what is
installed, as well as any other packages that are available. Refer to the Setup program GUI description section
for more details.
Also after installing, you can also launch the Setup program from the Dashboard, as well as from various tools
such as Project Creator or Library Manager if they prompt you when your application does not have a required
asset.
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2.4 Installing the minimum required software packages
To install the minimum required software:
1. Click the Default option if it is available. This will select the latest versions of these packages

automatically (as shown in Step 3):
• Eclipse, unless the Setup program detects that VS Code is installed. If so, Eclipse is not selected.
• GCC
• Tools package
• Edge Protect Security Suite
• Programming tools

2. If the Default option is not available, or if you want to choose other the packages using the Custom
option, select the tools package version you want to install. This will also select the dependencies as
described in Step 1.

Note: Earlier releases of the ModusToolbox™ tools package included Eclipse and GCC. They are now
separate installable packages.

3. Click Next >.
This screen shows the packages that will be installed, with links to the release notes and license for each
package. We recommend using the default installation option. See Installing using non-silent option if
you need to install in a non-default location.
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4. Select the I agree to the licenses … check box and click Start.

The Setup program will download and install the selected packages.

Note: Installing Programming tools and some other packages may require an Administrator user
name and password to proceed.
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Note: On Windows, if you need to install the tools package in a non-default location, see Installing
using non-silent option.

Note: Clicking the Cancel button will not affect install operations that have already started; only
pending install operations will be stopped.

5. When all packages are installed, the Setup program shows options to run various tools. Click Run for the
tools you wish to start.
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6. Click Back to return to the select packages window. Finish or click File > Exit to close the Setup
program.

2.5 Installing IDEs
You can use the Setup program to install the Eclipse IDE as a separate package. Just select it from the list.
You can also use the Setup program to download Microsoft Visual Studio Code to install it separately. Click on
the Download MS VS Code link. In the opened browser window, download the installation package suitable for
your system and install it manually following platform-specific guides on https://code.visualstudio.com/docs/
setup/setup-overview. On Ubuntu Linux, the recommended packages are "deb" or "snap". On macOS,
download and extract the .zip archive content and drag "Visual Studio Code.app" to the Applications folder.
After the installation is complete, return to the ModusToolbox™ Setup window and click the Refresh button to
update the UI.
Once either IDE is installed, the Setup program provides a button to launch it.

2.6 Installing packs
After installing the minimum required software packages, you are ready to begin developing your application
using the ModusToolbox™ ecosystem. Our devices and software support multiple technologies. Review these
webpages to learn more. You can use the Setup program to install additional packs as needed.
• Machine Learning
• Connectivity
• Industrial
• Security
Refer also to the tools package user guide for a complete description of the ModusToolbox™ ecosystem,
information about the build system, manifest, and BSPs, as well as instructions about how to get started
creating and building an application.
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There are two kinds of packs:
• Technology packs - long term packs that provide extended technology software and tools as noted above.
• Early access packs - short term packs to provide selected customers access to newer devices and

technology that is still being developed.

2.6.1 Installing technology packs
To install a particular technology pack, you can just select it in the Setup program. There are no special
requirements to install and use these types of packs, other than having the base tools package and
dependencies already installed.

2.6.2 Installing early access packs
To install an early access pack, you must be given access. This may include signing a non-disclosure agreement
(NDA). Once you have permission, you will be able to see available early access packs when you log in to the
Setup program. Then, you can select it and download/install it the same as any pack or package.
In order to use an early access pack, you must enable it using the Settings tool. Refer to the Settings tool user
guide for details about that tool.
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2.7 Run the Dashboard (optional)
The ModusToolbox™ tools package includes an optional Dashboard tool. To run the Dashboard select the option
on the final page of the Setup program after installation has complete. You can also run the Dashboard as
follows:
• Windows: Select the "dashboard" item from the Windows Start menu.
• Linux: Navigate to /<install-path>/ModusToolbox/tools_<version>/dashboard and run the executable.
• macOS: Run the "dashboard" app.

The Dashboard provides links to various sources of documentation and training materials. It also contains
starting points: create a new application, create/edit a BSP, install or launch the ModusToolbox™ Setup
program. For more details, refer to the Dashboard user guide.
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3 Advanced installation instructions
See Advanced ModusToolbox™ installation instructions KBA for various advanced installation cases.

3.1 Installing using non-silent option
The base tools package installs in your home directory on Windows by default. If your user home directory
contains spaces or illegal characters, or if you need to install for all users, you will need to select the Non-silent
install option on the installer page of the Setup program.

If possible, create a new user account and user home directory that doesn’t contain spaces or illegal characters.
Then, you can just use the default process for that account. If you cannot create a new user home directory,
then you must perform some extra installation steps.
When the Setup program begins to install the tools package, it will revert to the package installer program.

We recommend to install for the current user, but if you need to install for all users, then Admin permission will
be required. Follow the instructions in this section to proceed.
Accept the license agreement and click Next.
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Choose the Custom Installation option, and click Next.

Review the user guide, release notes, and other information on Infineon.com, as needed, and click Next.
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On this next screen, specify the location to install the tools package.

Specify a path that does not include spaces. For example: C:\Infineon\ModusToolbox
Any path without spaces or illegal characters will work. The same is true if you install for all users in a non-
default user home directory.
Click Next and a notice like the following will display to confirm that you are installing in a non-default location:
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Click OK to proceed.

Specify the Start menu folder options, if needed, and click Next.

Select or deselect various install options and click Next.
Note: If you have never installed ModusToolbox™ software before, leave the Other tasks selected to ensure a

correct installation.
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Review the settings and click Install to begin the installation, or click Back to go back to previous pages to
make changes.
After installation is complete, review and follow the instructions in the following subsections as applicable.

3.1.1 Create directories
When installing in a non-default location, you should create a couple directories. You can choose any path as
long as it doesn’t contain spaces.
1. Create a hidden "dot" directory named ".modustoolbox" for variable locations described later in this

section. For example:
C:\MyPath\.modustoolbox

2. Also, create a directory to store your workspaces. For example:
C:\MyPath\mtb-projects

3.1.2 Create variable to specify the path to Tools
Because you are installing ModusToolbox™ into a non-default location, you need to specify the path to your
"tools" directory using an Environment Variable. Open the Environment Variables dialog, and create a new
System or User Variable, depending on your installation type (current user or all users). For example:

CY_TOOLS_PATHS = C:/MyPath/ModusToolbox/tools_[version]

Note: Use a Windows-style path (not Cygwin-style, like /cygdrive/c/). Also, use forward slashes.

3.1.3 Create variable to specify the global path
You also need to specify the global path using an Environment Variable. Open the Environment Variables
dialog, and create a new System or User Variable, depending on your installation type (current user or all
users). For example:

CY_GETLIBS_GLOBAL_PATH = C:/MyPath/.modustoolbox/global
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Note: Use a Windows-style path (not Cygwin-style, like /cygdrive/c/). Also, use forward slashes.

Note: You can set this value using the Settings program instead of using a environment variable.

3.1.4 Specify the custom path to use for Local Content Storage
If you use Local Content Storage (LCS) to enable work without access to the Internet, set this variable to specify
where the content will be stored. For example:

MTB_LOCAL_CONTENT_PATH = C:/MyPath/.modustoolbox/lcs

Note: Use a Windows-style path (not Cygwin-style, like /cygdrive/c/). Also, use forward slashes.

Note: You can set this value using the Settings program instead of using a environment variable.
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4 Setup program GUI description
The main GUI window of the ModusToolbox™ Setup program contains the following elements:
• Main menu
• Main toolbar
• Packages view
• Log panel

4.1 Menus
The main application menu consists of multiple menu item groups as defined below.

4.1.1 File
The File menu consists of the following menu items:

Menu item Description

Login / Logout The login function provides access to installable packages from the IDC.
The login is the same as the IDC login. If you don't already have an account, you can
create one at https://community.infineon.com.

Refresh Checks the server for any updates and refreshes the Setup program.

Show Downloads Opens a folder on disk to show the various downloaded executable files for the packages
that were selected.

Preferences Opens the Preferences dialog.

Exit Exits the ModusToolbox™ Setup program.

4.1.2 Help
The Help menu consists of the following menu items:
• View Help – Opens this document.
• Check for updates – Manually checks to see if there are any updates to the Setup program itself. The

tool can be configured to check for updates on startup. If updates are available, the ModusToolbox™ Setup
Installer package is downloaded and executed once the program is closed.

• About – Opens the About box for version information, with links to open https://www.infineon.com, the
current session log file, and the Infineon Developer Center Launcher Service log file.

4.2 Main toolbar
The main toolbar consists of the following:
• Login / Logout: While Login is visible, Logout is not. When you are logged in, your email address is

displayed along with the Logout button.
• Refresh: initiates a refresh of the list of available packages.
• Preferences: opens the Preferences dialog.
• User Guide: opens this document.
• New to ModusToolbox?: opens an introductory document for new users.
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4.3 Packages view
The Setup program gathers package data from the IDC online and local tools registry, and then displays all
installed and available packages along with version information. For the purposes of this document, a package
includes ModusToolbox™ platform tools, patches, packs, programming tools, and other tools such as the
Memory Analyzer. The Setup program displays a list of the available packages, grouped by two categories:
• Base Installation, IDEs, and Toolchain Packages: This includes the ModusToolbox™ tools packages,

Eclipse, VS Code, and GCC.
• Additional Packages: This includes all other packages relevant to the ModusToolbox™ ecosystem,

including programming tools, technology packs, early access packs, and auxiliary tools.

Some of the packages require you to be logged in to download and install, while others do not.
As you select various packages to install, the description on the right describes the action to take next. Installed
packages show the path installed, and also provide a tooltip showing the path.

4.4 Log panel
The log panel area displays the information messages relevant for you. Examples of events that produce
messages to the panel view:
• Logged in/logged out
• Completed/failed downloading the tool data from the online tool registry
• Package was selected/deselected in the tool selection view
• Dependent package version was changed (to satisfy the updated tool dependency constraints)
• Tool configuration (installation mode, target directory was changed)
• Tool download started/finished
• Tool installation/uninstallation started/finished
See How to collect logs in the troubleshooting section.
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4.5 Preferences dialog
You can open the Preferences dialog from the main menu or main toolbar button.

The following settings are available:
• Update site URL: The address of the IDC Online Tools registry. Usually there is no need to customize this

address to a non-default URL.
• Logs Directory: The path to the directory where log files are stored. By default, this is the system

temporary directory.
Note: After choosing a directory for logs, the program will create a "ModusToolboxSetup" sub-folder

there where log files are kept.

• Check for updates on start: disable this option to prevent the program from automatically checking for an
update at each start.

Use the Restore Defaults button to revert the options back to their default values.
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5 Troubleshooting
For help with various problems, see Troubleshooting ModusToolbox™ Setup program errors.

5.1 How to collect logs
If any errors occur when running the program, ModusToolbox™ Setup and Infineon Developer Center Launcher /
Launcher Service, logs may be invaluable for resolving possible issues. To collect the ModusToolbox™ Setup
current-session log, go to Help > About > Log(s). Logs from previous sessions can be found as follows:

OS Log directory path

Windows
(Current User)

%USERPROFILE%/AppData/Local/Temp/ModusToolboxSetup

Linux™ $HOME/tmp/ModusToolboxSetup

macOS /private/var/folders/[some tmp folder]/ModusToolboxSetup

Note: Since logs are stored in a temporarily location, they will be deleted on MacOS and Linux™ on reboot. To
prevent deletion, you can change the directory where logs are stored in the Preferences dialog.

If Infineon Developer Center is installed, the logs can be accessed via the Help > Contact us > Generate
Support Document option. If only the Infineon Developer Center Launcher Service is installed, logs can be
found as follows:
Go to Help > About > Log(s) and click on the “IDC Launcher Service Log(s)” link to open logs in the text editor
window, or find the logs file directly in:

OS Log directory path

Windows
(Current User)

%USERPROFILE%/AppData/Local/Infineon_Technologies_AG/Launcher-Service/resources/
logs

Linux™ $HOME/.local/share/ Infineon_Technologies_AG/Launcher-Service/resources/logs

macOS $HOME/Library/Application Support/ Infineon_Technologies_AG/Launcher-Service/resources/
logs
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