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About this document
A newer version of this document may be available on the web here.
Scope and purpose

ModusToolbox™ software is a set of tools that enable you to integrate our devices into your existing
development methodology. One of the tools is a multi-platform, Eclipse-based Integrated Development
Environment (IDE) that supports application configuration and development.
This document provides information about creating applications as well as building, programming, and
debugging them using Eclipse.
 
Document conventions

Convention Explanation
Bold Emphasizes heading levels, column headings, menus and sub-menus

Italics Denotes file names and paths

Monospace Denotes APIs, functions, interrupt handlers, events, data types, error handlers, file/folder
names, directories, command line inputs, code snippets

File > New Indicates that a cascading sub-menu opens when you select a menu item

 
Reference documents

Refer to the following documents for more information as needed:
• ModusToolbox™ software installation guide
• ModusToolbox™ tools package user guide
• Eclipse survival guide
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1 Getting started
This section provides a basic walkthrough for how to create a couple applications using Eclipse, selecting a BSP.
It also covers how to build and program them using Eclipse and basic launch configurations supplied for the
applications.
• Installing Eclipse
• Launch Eclipse
• Open Project Creator tool
• Create an application
• Build application
• Program application
• Export/share application
• Import application
• Search online for code examples
• Search online for libraries/BSPs
• Access training material

1.1 Installing Eclipse
Beginning with the ModusToolbox™ tools package version 3.4.0, Eclipse for ModusToolbox™ is no longer
included by default. Instead, it is a separate package that you can install via the ModusToolbox™ Setup
program.
The Setup program is located on our website here: https://softwaretools.infineon.com/tools/
com.ifx.tb.tool.modustoolboxsetup. It is used to install base packages and additional packages on Windows,
Linux, and macOS. Refer to the ModusToolbox™ software installation guide for specific instructions.

1.2 Launch Eclipse
Eclipse is installed in the following directory, by default:
C:\Users\<UserName>\Infineon\Tools\ModusToolboxEclipse

Note: If the software is not installed in the default location, you will need to set an environment variable.
Refer to the ModusToolbox™ software installation guide for details.

To launch Eclipse:
• On Windows, select Eclipse for ModusToolbox™ <version> item from the Start menu.
• For other operating systems, run the "modustoolbox" executable file.
• You can also launch Eclipse from the dashboard for all operating systems. For more information refer to the

dashboard user guide.
When launching Eclipse, it provides an option to select the workspace location on your machine. This location
is used by Eclipse for creating and storing the files as part of application creation for a particular platform. The
default workspace location is a folder called "mtw" in your home directory. You may add additional folders
under the "mtw" folder or to choose any other location for each workspace.
For more details about Eclipse, refer to Eclipse documentation, as well as the Eclipse survival guide.
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1.3 Open Project Creator tool
Click the New Application link in the Eclipse Quick Panel.

You can also select File > New > ModusToolbox™ Application.

These commands launch the Project Creator tool, which provides several applications for use with different
development kits. The kits available may change over time.

For more details about using this tool, refer to the Project Creator user guide.
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1.4 Create an application
This section provides a walkthrough for creating a ModusToolbox™ application.

1.4.1 Choose board support package
The Project Creator tool displays a list of boards, showing the Kit Name, MCU, and Connectivity Device (if
applicable). As you select each of the kits shown, the description for that kit displays on the right. Depending on
the settings for your system, you may see different categories, including PSOC™ 4, PSOC™ 6, and AIROC™

Bluetooth® BSPs. For this example, select the CY8CKIT-062-WIFI-BT kit.

1.4.2 Select application
Click Next > to open the Select Application page. This page lists various applications available for the selected
kit. As you select an application, a description displays on the right. You can select multiple applications for the
selected BSP by enabling the check box next to the applicable applications.

For this example:
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• Select the check box next to the "Hello World" application.
• If desired, type a name for the application and/or BSP. Do not use spaces.

1.4.3 Create application
Click Create to begin the application creation process.

Note: The application creation process performs a git clone operation, and downloads the selected
application from the GitHub website. Depending on the selected application, this process can take
several minutes.

When complete, the Project Creator tool closes automatically if there are no errors or warnings. If there are
warnings only, click Close and the application will open in Eclipse. In Eclipse, a message will display about
importing the project:

If there are errors, project creation will fail.
After several moments, the application opens with the Hello_World in the Project Explorer, and the README.md
file opens in the file viewer.

Eclipse for ModusToolbox™ user guide

1  Getting started

User guide 6 002-24375 Rev. *T
2025-09-12



Note: Many AIROC™ Bluetooth® applications contain multiple projects. For example, the BLE-20819EVB02
application contains projects for Bluetooth® Low Energy services such as anc, ans, bac, bas, beacon,
etc.

1.5 Build application
After loading an application, build it to generate the necessary files. Select a project. Then, in the Quick Panel,
click the Build Application link. The following images show the Quick Panel for a typical PSOC™ MCU
application and an AIROC™ Bluetooth® application.
Messages display in the Console, indicating whether the build was successful or not. For more details about
building applications and the various Consoles available, see the Build applications chapter.
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1.6 Program application
There are many more details about programming an application. This section only covers it briefly. For more
detailed information, see the Program and debug chapter.
In the Project Explorer, select the desired project. Then, in the Quick Panel, click the <app-name> Program
(KitProg3_MiniProg4) link for a PSOC™ MCU application, and <app-name> Program for an AIROC™ Bluetooth®

application.

1.7 Export/share application
There are several ways to share a ModusToolbox™ application. Refer to the ModusToolbox™ tools package user
guide in the "Version Control and sharing applications" chapter for more general details.
Using Eclipse, you can use the export function to essentially make a copy of your application that you can share
with a colleague. There are several ways to export using Eclipse. The option we recommend is to select the
application and then use File > Export > General > Archive File, which creates a ZIP file.

Keep in mind that a typical ModusToolbox™ application includes many libraries that are available on GitHub.
These get regenerated during the make getlibs command. Therefore, you can substantially reduce the size of
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your exported application by excluding the libraries. Plus, the exported mtb_shared folder might retain hard-
coded paths that would cause issues after importing the application.
For multi-core applications, Eclipse export function shows the core project folders along side the main
application folder. These project folders are included in that main application folder, so you should exclude
them from the export process as well.
On the Export dialog, select only the main application folder(s) to export. You may need to review your
application in Eclipse to determine which folders you should exclude. By default, subproject folders include an
extension after the application name.

Note: Ignore the extra project folders shown at the bottom of the window under the destination archive
files. They are a byproduct of Eclipse and unnecessary to the export process.

Click Browse… to navigate to the location to save the archive and provide a file name.
Click Finish to generate the archive file.

Note: Make sure build, libs, and mtb_shared are not selected to exclude them from the archive.

1.8 Import application
If you have a ModusToolbox™ application that you want to import into Eclipse, run the make getlibs command
before importing it into Eclipse.
Note: If the application is included in a ZIP file, you will need to extract it before running various commands.

Then, either use the Import Existing Application In-Place link on the Quick panel or open through the File >
Import ModusToolbox™ > Import Existing Application In-Place option.
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Note: This option does not copy or move the application location on disk; it only makes a reference for
Eclipse to the current application location.

On the next page, click the Browse… button, navigate to the application directory, and click Select Folder.

Click Finish to begin the import process. This will take a few moments, and then the application will display in
Eclipse Project Explorer.
If the Console displays a message, such as "Error creating Eclipse configurations," open the Library Manager
and click Update. This runs the make getlibs operation to generate the necessary files and libraries.

Note: There are various ways to import examples into Eclipse. If you prefer a different method, make sure
that all of the project files are copied into the workspace directory.

1.9 Search online for code examples
Infineon provides many code examples. These examples allow you to explore the capabilities provided by the
SDK, create applications based on them, examine the source code demonstrated in them, and read their
associated documentation. The Quick Panel provides a link to access online code examples. Click the Search
Online for Code Examples link. This opens a web browser to the GitHub repository to select and download the
appropriate examples.

Eclipse for ModusToolbox™ user guide

1  Getting started

User guide 10 002-24375 Rev. *T
2025-09-12



1.10 Search online for libraries/BSPs
Infineon also provides all the libraries and BSPs online at GitHub. The Quick Panel provides a link to access
these. Click the Search Online for Libraries and BSPs link. This opens a web browser to the GitHub repository
that shows the ModusToolbox™ software page.

1.11 Access training material
Infineon also provides training material at GitHub. The Quick Panel provides a link to access these. Click the
Training Material link. This opens a web browser to the GitHub repository that shows the ModusToolbox™

training page.

Eclipse for ModusToolbox™ user guide

1  Getting started

User guide 11 002-24375 Rev. *T
2025-09-12



Eclipse for ModusToolbox™ user guide

1  Getting started

User guide 12 002-24375 Rev. *T
2025-09-12



2 GUI description
The GUI is based on Eclipse. It uses several plugins, including the Eclipse C/C++ Development Tools (CDT)
plugin. For more information about Eclipse, refer to the Eclipse Workbench User Guide. We also provide a
document called the Eclipse survival guide, which provides tips and hints for how to use Eclipse.
The GUI contains Eclipse menus and toolbars, plus various panes such as the Project Explorer, Code Editor, and
Console. One difference from Eclipse is the "ModusToolbox™ Perspective." This perspective provides the "Quick
Panel," and adds tabs to the Project Explorer. "Perspective" is an Eclipse term for the initial set and layout of
views.

Note: If you switch to a different perspective, you can restore the ModusToolbox™ Perspective by clicking
the ModusToolbox™ icon button in the upper-right corner. You can also select Perspective > Open
Perspective from the Window menu. To restore the ModusToolbox™ Perspective to the original layout,
select Perspective > Reset Perspective from the Window menu.

The following describe different parts of the GUI:
• Menus and toolbars – Use the various menus and toolbars to access build/program/debug commands for

your application. Many of these are covered in the Eclipse Workbench User Guide. Note that some menu
and toolbar items have been removed from standard Eclipse. We recommend using the Quick Panel with
ModusToolbox™ version 3.2.

• Project Explorer – Use the Project Explorer to find and open files in your application. See Project Explorer
for more information.

• Quick Panel – Use this tab to access appropriate commands, based on what you select in the Project
Explorer.

• Code Editor – Use the Code Editor to edit various source files in your application.
• Console – Use these tools to review messages and access the integrated terminal.
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2.1 Project Explorer
In Eclipse, after creating an application, the Project Explorer contains one or more related project folders. The
following images show a PSOC™ MCU application and an AIROC™ Bluetooth® application.

Both types of applications contain a similar project structure. Each contains the main application source code,
and a Makefile. Note that PSOC™ MCU applications contain a libs directory, while AIROC™ Bluetooth®

applications have a wiced_btsdk project with shared SDK, BSPs, and libraries for all applications in a
workspace.

2.2 Quick Panel
As stated previously, the Quick Panel is part of the "ModusToolbox™ Perspective." It provides quick access to
commands and documentation based on what you have selected in the Project Explorer.

The Quick Panel contains links to various commands and documentation, organized as follows:
• Start – This contains the New Application link to create new applications, and links to find Code Examples,

Libraries, BSPs, and training material.
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• Selected <app-name> project – This contains different project-related links based on the project that is
selected in the Project Explorer, as well as the type of application. Links here include: Build and Clean the
application.

• Launches – This contains various Launch Configurations, based on the selected application project and
device, which can be used to program the device and launch the debugger. This area is only populated
if you have the top project in your application selected (<app-name>). For more information, see Launch
configurations.

• Tools – This contains links to the various tools available for the selected project. For more information, see
Use configurators and Use tools.

• Documentation – This may contain several documents in HTML format, which are included as part of the
chosen BSP.
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3 Configure applications
This chapter covers how to make various changes to your application. It includes:
• Modify code
• How-to set configuration options
• Use configurators
• Use tools
• Use integrated terminal
• Refresh Quick Panel
• Rename application
• Restore shared directory

3.1 Modify code
Most code examples work as they are, and there is no need to add or modify code in order to build or program
them. However, if you want to update and change an application to do something else, or if you are developing
your own application, open the appropriate file in the code editor.
• PSOC™ MCU: In the Project Explorer, double-click the main.c file.

Note: The "includes" in this example show "unresolved inclusions" because the files are located in the
mtb_shared folder. This and other issues with IntelliSense are resolved after a build.

• AIROC™ Bluetooth®: In the Project Explorer, expand the <app-name> project folder and double-click the
application <app-name>.c file.

As you type into the file, an asterisk (*) will appear in the file’s tab to indicate changes were made. The Save/
Save As commands will also become available to select.

Note: C/C++ Search is no longer supported by ModusToolbox™ Eclipse due to programmatic disabling of
indexing. You should disable C/C++ Search via the Search > Search > Customize menu. Other search
types are not affected.
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3.2 How-to set configuration options
Since a ModusToolbox™ application is based on the GNU-make system, most of the project configuration is
controlled by editing the Makefile. This section contains common configuration options that Eclipse users need
to be aware of. For more information about the ModusToolbox™ build system, see chapter five in the tools
package user guide.

3.2.1 Configuring Toolchains
ModusToolbox™ software provides GCC_ARM as the default toolchain to use with Eclipse. If you have a different
toolchain you prefer, update the makefile to point to the appropriate toolchain.

3.2.1.1 Using GCC_ARM
If you have both GCC 11 and GCC 14 installed, ModusToolbox™ software will use GCC 14 by default, and you do
not need to specify the path variable. However, if you want to use GCC 11 and GCC 14 is also installed, you must
specify the following path variable:

CY_COMPILER_GCC_ARM_DIR=[Path to GCC_ARM install]

3.2.1.2 Using ARM
To use ARM, specify the following variables:

TOOLCHAIN=ARM
CY_COMPILER_ARM_DIR=[Path to ARM install]

3.2.1.3 Using LLVM
To use LLVM, specify the following variables:

TOOLCHAIN=LLVM_ARM
CY_COMPILER_LLVM_ARM_DIR=[Path to LLVM install]

3.2.2 Specify debug and release configurations
Edit the project/application Makefile CONFIG parameter. Valid options are: Debug, Release, and Custom. If you
set the value to Custom, then also set the optimization flag in the CFLAGS variable.

Note: Do not use the global configuration Debug/Release menu items, and do not use the Project > Build
Configurations option. These are both ignored.

3.2.3 Exclude files/folders from build
By default, a ModusToolbox™ application includes a .cyignore file that specifies files and folders to exclude from
a build. You can add entries to this file. You can also edit the Makefile to add CYIGNORE make variables.
Do not use Resource Configurations > Exclude From Build... This will be ignored.
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3.2.4 Specify linker settings (including per-file linker settings)
Edit the project/application Makefile for these variables: CFLAGS, CXXFLAGS, ASFLAGS, LDFLAGS
There is no other way to specify linker settings in Eclipse.

3.2.5 Specify probe and generate launch configs
Most PSOC™-based kits use KitProg3/MiniProg4 as the default programmer/debugger, and they show those
configurations in the Quick Panel:

Switch to J-Link programmer/debugger

If you want to use SEGGER J-Link as the programmer/debugger, do the following to change configurations:
1. Open your ModusToolbox™ application's bsp.mk file, and type the following variable:

BSP_PROGRAM_INTERFACE=JLink

2. Also enter the following variable to specify the location of where J-Link will be installed:

MTB_JLINK_DIR=<path to J-Link>

3. Save the bsp.mk file.
4. Click Generate Launches for <project_name>.

When Eclipse refreshes, J-Link configurations will be shown.

Note: There is no other way to specify J-Link in Eclipse.

Switch back to KitProg3

If you want to switch back to KitProg3, delete the variables you entered above and regenerate the launch
configurations.

3.2.6 Configure search paths
Source files under the project root directory are automatically included into a build. Additional files/directories
can be added to the search path using the SEARCH make variable.
Do not add a source file to the project as a link (for example, by dragging and dropping a file into a project and
selecting Link to files). This will be ignored.

3.3 Use configurators
ModusToolbox™ software provides graphical applications called configurators that make it easier to configure a
hardware block. However, before you make changes to settings in configurators, you should first copy the
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configuration information to the application and override the BSP configuration or create a custom BSP. If you
make changes to a standard BSP library, it will cause the repo to become dirty. Additionally, if the BSP is in the
shared asset repository, changes will impact all applications that use the shared BSP. For more information,
refer to the ModusToolbox™ tools package user guide.
Each configurator provides a separate guide, available from the configurator's Help menu.

3.3.1 Launching configurators from Eclipse
To launch a configurator from Eclipse, right-click on the <app-name> project in the Project Explorer, select
ModusToolbox™, and then select the appropriate configurator.

Note: You can also launch available configurators from links in the Quick Panel.

Depending on the enabled resources in your application, there may be several configurators available to
launch.
• If you launch the Device Configurator from Eclipse, you are opening the project’s design.modus file, which

is responsible for holding all of the BSP configuration information. It contains the following:
- Selected device
- Resource parameters
- Constraints

• If you launch any of the other configurators from Eclipse, they will open using that configurator’s
configuration file (design.cycapsense, design.cyseglcd, etc.). These files are specific to the given resource,
and they may rely on configuration data from the design.modus file.

3.3.2 Launching configurators without Eclipse
To launch any Configurator without using Eclipse, refer to the applicable configurator guide for details about
configuration information. You may need to open a configuration file or create a new one.
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3.4 Use tools
In addition to the configurators, there are several tools, including Library Manager, BTSpy, ClientControl, and
Device Firmware Update (DFU) Host Tool. Many tools do not apply to all types of projects. So, the available
tools depend on the project/application you have selected in the Project Explorer.

3.4.1 Launching tools from Eclipse
To launch a tool from Eclipse, right-click on the <app-name> project in the Project Explorer, select
ModusToolbox™, and then select the appropriate tool.

Note: You can also launch available tools from links in the Quick Panel.

3.4.2 Library Manager
The Library Manager allows you to select which Board Support Package (BSP) and version should be used by
default when building a ModusToolbox™ application. It also allows you to add and remove libraries, as well as
change their versions.
For more information about how to use this tool, refer to the Library Manager user guide.

3.4.3 BTSpy and ClientControl
BTSpy is a trace utility that can be used in the AIROC™ Bluetooth® applications to view protocol and generic
trace messages from the embedded device. The tool listens on the UDP port 9876 and can receive specially
formatted message from another application on the same or different system.
BTSpy can be used in conjunction with ClientControl to receive, decode and display protocol application and
stack trace messages. ClientControl communicates with the embedded app to perform various functionalities,
tests, exercising features, etc.

3.4.4 DFU Host tool
The Device Firmware Update (DFU) Host tool is a stand-alone program used to communicate with a PSOC™ MCU
that has already been programmed with an application that includes device firmware update capability. For
more information, refer to the Device Firmware Update Host tool user guide.
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3.5 Use integrated terminal
Eclipse for ModusToolbox™ software includes an integrated terminal where you can enter various commands for
the selected project. To view the terminal, click the Terminal tab in the bottom pane. Then, select a project in
the Project Explorer to open a shell in the project directory.

Note: You can configure the terminal colors for the Workspace under Window > Preferences >Terminal.

3.5.1 Switch projects
When you switch projects, Eclipse creates additional tabs and automatically switches between them, so that a
shell in the current project directory is always in focus. To disable this automatic switching, deselect the Track
Current Project button in the terminal toolbar.
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3.5.2 Specify alternate shell
By default, the terminal uses your login shell on Linux and macOS, or the "modus-shell" Cygwin bash shell
provided with your ModusToolbox™ tools installation on Windows. You can specify a different shell from
Window > Preferences > ModusToolbox™ Tools.

3.5.3 Update local terminal settings
By default, the local terminal uses your User home directory as the Initial Working Directory. You can specify
different options from Window > Preferences > Local Terminal.

Note: Linux and macOS include additional settings for Shell Command and Arguments.
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3.5.4 Connect to remote machine/board
You can also connect to a remote machine or board via serial, telnet, or SSH by clicking the Open a Terminal
button in the terminal toolbar.

Use the Choose terminal pull-down menu to select the appropriate terminal.

3.6 Refresh Quick Panel
When you use tools external to Eclipse, such as the Library Manager or Device Configurator, it is likely that
Eclipse will not refresh to detect changes made in those other tools. Use this link to refresh Eclipse. You may
notice new documentation links or a new Active BSP in the Quick Panel as an indication that your application
has new libraries and/or components.

3.7 Rename application

3.7.1 Single-core application
Eclipse for ModusToolbox™ software uses the standard Eclipse rename functionality. That is, right-click on the
application and select Rename. If you use the rename feature, you will need to update your application’s
launch configurations. The easiest way to do this is to use the "Generate Launches…" link in the Quick Panel.
After renaming the application, select it in the Project Explorer and notice that there is only one item under
Launches. Click on the Generate Launches for… link. After a few moments, the generate process completes.
Click on the application again in the Project Explorer and notice that all the items are shown under Launches in
the Quick Panel.
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3.7.2 Multi-core application
To rename a multi-core application, you cannot use the standard Eclipse rename functionality. Follow these
steps instead:
1. Right-click on the affected project(s) and select Delete to remove from the Eclipse workspace.
2. On the dialog do not select "Delete project contents on disk". Click OK.

3. Go to the workspace location on disk and manually rename the relevant project directories.
4. When renaming a child project (e.g., proj_cm33_s) for a multi-core application, edit the application

Makefile. Look for MTB_PROJECTS=..., and update the list with the new child project names.
5. Open a Terminal (modus-shell in Windows) and run make eclipse.
6. Switch back to Eclipse and select Import Existing Application In-Place using the Quick Panel.

3.8 Restore shared directory
Various shared libraries imported from GitHub are located in a shared directory named mtb_shared (by default)
adjacent to your application directories. You can delete the mtb_shared directory at any time because it can be
recreated. You might do this when sharing the application, for example. The shared directory only contains files
that are already controlled and versioned, so you should not check it into a revision control system.
When using Eclipse, if you delete the shared library directory from disk and then regenerate it, the directory will
not be restored properly. This is because several files required by Eclipse are not restored as they were when
the application was created. To resolve this issue:
1. Regenerate the mtb_shared directory and assorted libraries on disk using make getlibs or the Library

Manager.
2. In Eclipse, delete the "mtb_shared" folder shown in the Project Explorer.

Note: Do NOT select the check box "Delete project contents on disk" (if you do, you will have to
regenerate it again).

3. Then, select File > Import > C/C++ > Existing Code as Makefile Project and click Next >.
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4. On the Import Existing Code page:

• Under Existing Code Location, click Browse…, navigate to the application's root directory, select
the "mtb_shared" folder, and click Select Folder.

• Under Toolchain for Indexer Settings, select ARM Cross GCC.
• Click Finish.

5. After the import completes, build the application.
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4 Build applications
This chapter covers various aspects of building applications. Building applications is not specifically required,
because building is performed as part of the Program and debug. However, if you are running Eclipse without
any hardware attached, you may wish to build your application to ensure all the code is correct.
• Build with Make
• Build with Eclipse
• Configuring Toolchains

4.1 Build with Make
You can build applications from the command line using Make. Refer to the ModusToolbox™ tools package user
guide (also located in the ~\ModusToolbox\docs_<version> directory) for more information.

4.2 Build with Eclipse
After loading an application, it is best to first build everything to generate the necessary files. Click on a project
in the Project Explorer. Then in the Quick Panel, click the "Build Application" link.

Building an application will typically allow IntelliSense to work better. It may also be useful to right-click on a
project and select Index > Rebuild to allow IntelliSense to find references.
Messages display in the Console, indicating whether the build was successful or not.

Note: Be aware that there are several Console views available.

You can access the different views using the Display Selected Console  button (or the pull-down arrow).
The Global Build Console is the only way to see all of the results in one place. If you just have the standard
Console open, it resets every time a new project in the application starts building. You won’t see any errors if
they are not on the final project that gets built.

Eclipse for ModusToolbox™ user guide

4  Build applications

User guide 26 002-24375 Rev. *T
2025-09-12

https://www.Infineon.com/ModusToolboxUserguide
https://www.Infineon.com/ModusToolboxUserguide


For subsequent updates, we recommend that you use the Build Application option from the Quick Panel.

Note: When the active build configuration is changed it affects only the selected project. The active build
configuration for any dependent projects is specified separately for each project. Therefore, if you
want to use the same configuration for all projects (for example, Debug or Release), it must be set for
each project. It is possible to select multiple projects at once from the Project Explorer and then select
the active configuration.
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5 Program and debug
Programming and debugging are native to your chosen development environment. Infineon devices are
supported in the major program and development solutions. Primarily, this means J-Link and OpenOCD. These
solutions provide for programming flash within a device and provide a GDB server for debugging.
This chapter covers various topics related to building and debugging, including:
• PSOC™ MCU programming/debugging

- Launch configurations
- Debug connection options
- KitProg Firmware Loader
- Supplying power with KitProg3_MiniProg4
- Power cycle programming mode with KitProg3_MiniProg4
- Switch to J-Link programmer/debugger
- Using JTAG interface in MiniProg4
- Changing programming interface SWD/JTAG
- Erasing external memory
- Programming eFuse
- Select specific CMSIS-DAP device
- Select Specific J-Link Device
- PSOC™ 4 flash security programming
- Debugging/programming for secure configuration devices

• AIROC™ Bluetooth® programming/debugging
- Program configuration
- Attach configurations
- Debug settings
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5.1 PSOC™ MCU programming/debugging

5.1.1 Launch configurations
The flow for programming and debugging is similar for all devices. Eclipse contains several Launch
Configurations that control various settings for programming the devices and launching the debugger.
Depending on the kit and type of applications you are using, there are various Launch Configurations available.
There are two sets of configurations: one for KitProg3_MiniProg4 (included on-board on most Infineon PSOC™ 6
and PSOC™ 4 based kits) and another for SEGGER J-Link.

Note: The KitProg3_MiniProg4 launch configuration also supports the MiniProg4, which you attach to
the kit via a 10-pin debug connection. See the MiniProg4 product page for details. The MiniProg3
is not supported. See also Supplying power with KitProg3_MiniProg4 later in this document for
configuration requirements.

The Debug/Attach Launch Configurations are shown in the Run/Debug Configurations dialog, similar to the
following.

In addition to the Debug and Attach Launch Configurations, Program/Erase configurations are available in the
External Tools Configurations dialog. You can open this dialog from the Run menu or by selecting the down
arrow next to the Run and Debug commands.
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These configurations include the application name and protocol, for example:
• Hello_World Program (KitProg3_MiniProg4)
• Hello_World Debug (JLink) For more information, see Debug connection options.

Note: KitProg3_MiniProg4 configurations may not work if a J-Link probe is attached to the kit.

When an application is created, the tool generates the following launch configurations for KitProg3 by default.
You can edit the Makefile to create configurations for J-Link instead. See Specify probe and generate launch
configs for further details. Some items display in the Quick Panel, and some are in the Run/Debug
Configurations or External Tools Configurations dialogs only.
• Attach: This launch configuration starts a debugging session attaching to a running target without

programming or reset.
• Debug: This launch configuration builds the associated project, programs the project-specific output file,

and then starts a debugging session.
• Erase Device: This launch configuration erases all internal memories.
• Erase All:If present, this launch configuration erases all internal and external memories.
• Program: This launch configuration builds the associated project, programs the project-specific output

file, and then runs the program.

5.1.2 Debug connection options
A typical PSOC™ 6 application created for Eclipse may have launch configurations set up for one of two probes:
Infineon KitProg3 (built into Infineon kits) or Segger J-Link.

Communication Firmware Debug Connection More Information

Infineon-provided KitProg3 OpenOCD via CMSIS-
DAP

https://www.infineon.com/cms/en/design-support/
tools/programming-testing/psoc-programming-
solutions/

SEGGER-provided J-Link DLL SEGGER J-Link SEGGER J-Link
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5.1.3 KitProg Firmware Loader
The PSOC™ MCU kits include onboard programmer/debug firmware, called KitProg. The CY8CPROTO-062-4343W
kit has KitProg3 by default. However, the CY8CKIT-062-BLE and CY8CKIT-062-WIFI-BT kits come with KitProg2
firmware installed, which does not work with the ModusToolbox™ software. You must update to KitProg3.
KitProg3 provides the CMSIS-DAP (Bulk) protocol by default, which is up to ~2.5 times faster than the CMSIS-
DAP (HID) protocol. Both modes can be used via OpenOCD.
To update it, use the ModusToolbox™ Programmer GUI or the fw-loader CLI tool. Both are provided with the
ModusToolbox™ Programming tools package available from the Setup program.
For more details about these tools, refer to the ModusToolbox™ Programmer GUI user guide or the Firmware
Loader user guide.

Note: On a Linux machine, you must run the udev_rules\install_rules.sh script before the first run of the
fw-loader.

5.1.4 Supplying power with KitProg3_MiniProg4
If using the KitProg3 connector on a kit, power is generally supplied by the host PC. When using a MiniProg4,
power is not supplied via the MiniProg4 by default. It is expected that the target MCU will be powered
externally. However, the MiniProg4 does provide the ability to supply power to the target MCU.
Note: Verify the voltage range supported by the target MCU, since it can be damaged by supplying

unsupported voltage. Make sure that your MCU is not powered externally before supplying power
via the KitProg3_MiniProg4 launch configuration. This supply is limited to approximately 200 mA, and
is protected against excess current draw. You can select 1.8 V, 2.5 V, 3.3 V, or 5 V.

5.1.4.1 Turning power supply on
To turn power supply on, edit the Debug/Attach Launch configurations:
1. Open the Launch Configuration to modify, and select the Debugger tab.
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2. In the Config options field, insert the following line (after -c "source [find interface/kitprog3.cfg]"):

-c "set ENABLE_POWER_SUPPLY <mV>"

Where <mV> defines target voltage in millivolts. For example:

3. Click Apply to save the change.
And for the Program/Erase Launch configurations:
1. Open the External Tools Configuration to modify in External Tools Configurations dialog.

2. In the Arguments field, add the following:

_MTB_RECIPE__OPENOCD_INTERFACE="source [find interface/kitprog3.cfg]; set ENABLE_POWER_SUPPLY 
<mV>;"

Where <mV>defines target voltage in millivolts. For example:
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5.1.5 Power cycle programming mode with KitProg3_MiniProg4

Note: This section is applicable to PSOC™ 6 and PSOC™ 4 only.

By default, Launch Configurations use Reset mode to program the device. However, Reset mode is not available
in all situations (for example, if the XRES pin is not available on the part's package). In these cases, Launch
Configurations use an alternative reset using software. However, using the software reset type is not sufficient
in some cases when access to the device's DAP is restricted (such as when set by security settings).
If there is no XRES pin available and DAP access is restricted, the only way to reset a part is to use Power Cycle
mode. Follow these instructions to add commands to the launch configuration and switch to Power Cycle
mode.

Note: Verify the voltage range supported by the target MCU, since it can be damaged by supplying
unsupported voltage. Make sure that your MCU is not powered externally before supplying power
via the KitProg3_MiniProg4.

To update Debug Launch configurations:
1. Open the Launch Configuration to modify and select the Debugger tab.
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2. In the Config options field, insert the following lines(after -c "source [find interface/
kitprog3.cfg]" ) :
• For PSOC™ 6:

-c "set ENABLE_POWER_SUPPLY <mV>"
-c "set ENABLE_ACQUIRE 2"

• For PSOC™ 4:

-c "set ENABLE_POWER_SUPPLY <mV>"
-c "set PSOC4_USE_ACQUIRE 2"

Where <mV> defines target voltage in millivolts. For example:

And for Program/Erase Launch configurations:
1. Open the External Tools Configuration to modify, then select the Main tab.
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2. In the Arguments field add the following:
• For PSOC™ 6:

_MTB_RECIPE__OPENOCD_INTERFACE="source [find interface/kitprog3.cfg]; set ENABLE_POWER_SUPPLY 
<mV>; set ENABLE_ACQUIRE 2;"

• For PSOC™ 4:

_MTB_RECIPE__OPENOCD_INTERFACE="source [find interface/kitprog3.cfg]; set ENABLE_POWER_SUPPLY 
<mV>; set PSOC4_USE_ACQUIRE 2;"

Where <mV> defines target voltage in millivolts. For example:
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5.1.6 Using JTAG interface in MiniProg4
The MiniProg4 can interact with the target via the SWD or JTAG protocol. By default, the SWD protocol will be
used.
In order to use JTAG, you need to add specific commands for the appropriate Debug Configuration. Under the
Debugger tab in the Config options field (after -c "source [find interface/kitprog3.cfg]"), insert the
following lines:
• -c "cmsis_dap_vid_pid 0x04B4 0xF151 0x04B4 0xF152"

• -c "transport select jtag"

5.1.7 Changing programming interface SWD/JTAG
Usually MCUs support programming/debugging via SWD and JTAG interfaces. The SWD interface is the default,
but you can switch to JTAG, and vice-versa.
To change target interface, update application’s bsp.mk by adding make variable as shown below (possible
values are ‘swd’ and ‘jtag’) and regenerate launch configurations:

MTB_PROBE_INTERFACE=swd

Note: There might be a difference in how the MCU functions depending on the selected debugging interface.
All known issues are documented in Release Notes.

5.1.7.1 Single-core projects

Kitprog3/MiniProg4

To change the target interface for KitProg3_MiniProg4, do the following:
1. Open the Debug Configurations dialog and select the required configuration.
2. Switch to the Debugger tab and find the "transport select ..." entry in Config options.
3. Set to the value to either 'swd' or 'jtag' as applicable.
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J-Link

For J-Link, there is a dedicated radio button in the Debug Configurations dialog, under the Debugger tab.
Select the applicable option:

5.1.7.2 Multi-core projects
There is a special case for multi-core debugging. This is usually launched via the 'Debug MultiCore'
configuration. To switch from one interface to another, the same interface must be set across all involved
configurations. The Debug Configurations dialog shows the list of configurations that are launched as a part of
multi-core debugging.
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5.1.8 Erasing external memory
To erase external memory use the Erase All configuration:

However, for PSOC™ 6 and PSOC™ 64 Secure Boot kits by default, erasing of external memory is turned off. To
turn it on, you must modify the "Erase" launch configuration options in the External Tools Configuration as
follows:
1. Open the External Tools Configuration to modify, and select the Main tab.

2. In the Arguments field add the following:

MTB_ERASE_EXT_MEM=1
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5.1.9 Programming eFuse
PSOC™ 6 MCUs contain electronic fuses (eFuses), which are one-time programmable. They store device specific
information, protection settings and customer data.
By default, eFuses are not programmed even if they are present in the programming file. To enable eFuse
programming, add the following command for the Program Configuration, under the Main tab in the
Arguments field (after -j8 program):

"_MTB_RECIPE__OPENOCD_TARGET=source [find target/$(_MTB_RECIPE__OPENOCD_DEVICE_CFG)]; psoc6 
allow_efuse_program on;"

Attention: Since blowing an eFuse is an irreversible process, Infineon recommends programming only in
mass production programming under controlled factory conditions and not prototyping stages.
Programming fuses requires the associated I/O supply to be at a specific level: the device VDDIO0
(or VDDIO if only one VDDIO is present in the package) supply should be set to 2.5 V (±5%).

 

5.1.10 Select specific CMSIS-DAP device
If there are two or more CMSIS-DAP devices connected to your computer, the first detected device will be used
by default. KitProg3 supports both CMSIS-DAP modes: HID and BULK. BULK devices are selected first, then HID
devices. You can specify a CMSIS-DAP device by:
• VID and PID of the USB device
• Serial Number of the USB device
• VID, PID, and Serial Number of the USB device
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There are two ways of specifying a CMSIS-DAP device:
• Add a specific command for the appropriate Debug Configuration, under the Debugger tab in the Config

options field (after -c "source [find interface/kitprog3.cfg]"

• Modify ModusToolbox™ application's bsp.mk by adding a MTB_PROBE_SERIAL variable, and regenerate launch
configurations

5.1.10.1 Selecting by VID and PID
Use OS-specific tools to determine the VID and PID of connected devices. For example, on Windows, use the
Device Manager. Use the "cmsis_dap_vid_pid" command to select a CMSIS-DAP device with a specific VID and
PID. If there are two or more devices with the same specified VID/PID pair, OpenOCD uses the first detected
device from the passed list.
• To specify KitProg3 in CMSIS-DAP BULK mode with VID = 0x04B4 and PID = 0xF155:

cmsis_dap_vid_pid 0x04B4 0xF155

• To specify KitProg3 in CMSIS-DAP HID mode with VID = 0x04B4 and PID = 0xF154:

cmsis_dap_vid_pid 0x04B4 0xF154

• To specify any (HID or BULK) connected KitProg3 device:

cmsis_dap_vid_pid 0x04B4 0xF154 0x04B4 0xF155

5.1.10.2 Selecting by serial number
There should not be more than one device with the same serial number. Use this method if you want to use
only one specific device. Use OS-specific tools to determine the Serial Number of connected devices. You can
also use the fw-loader utility with --device-list option. See PSOC™ 4 flash security programming.
Use the "cmsis_dap_serial" command to select a CMSIS-DAP device with a specific Serial Number.
• To specify a CMSIS-DAP device with Serial Number = 0B0B0F9701047400 via Debug Configuration the

following command is used:

-c "adapter serial 0B0B0F9701047400"

• Alternatively, update the application's bsp.mk by adding the variable below, and regenerate launch
configurations:

MTB_PROBE_SERIAL=0B0B0F9701047400
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5.1.10.3 Selecting by both VID/PID and serial number
You can use both commands together in any order directly in Debug Configuration. For example:

cmsis_dap_vid_pid 04B4 F155 cmsis_dap_serial 0B0B0F9701047400

When updating through an application's bsp.mk, add the variable below, and regenerate launch configurations:

MTB_PROBE_SERIAL=0B0B0F9701047400; cmsis_dap_vid_pid 04B4 F155;

5.1.11 Select Specific J-Link Device
If there are two or more J-Link devices connected to your computer, the first detected device is used by default.
You can select a specific J-link device by setting the serial number for the appropriate Debug Configuration,
under the Debugger tab:

Alternatively, update the application's bsp.mk by adding the variable below, and regenerate launch
configurations:

MTB_PROBE_SERIAL=0B0B0F9701047400

5.1.12 PSOC™ 4 flash security programming
PSOC™ 4 devices include a flexible flash-protection system that controls access to flash memory. This feature
secures proprietary code, but it can also be used to protect against inadvertent writes to the bootloader portion
of flash. Refer to the device’s Architecture Technical Reference Manual for details.
Flash consists of rows (64/128/256 bytes, depending on the PSOC™ 4 device). Each row of flash can have its
protection level independently set. You can assign one of two protection levels to each row, as shown in the
following table:

Protection Setting Allowed Not Allowed

Unprotected External read and write, Internal read and
write

–

Full Protection External read, Internal read External write, Internal write

To apply flash security, include the appropriate data in the application by creating an array of num_rows / 8
size, where num_rows is the actual number of flash rows on the device. Each byte of this array is responsible for
protection of 8 flash rows, and it sets one of two protection levels:
• 0 – unprotected
• 1 – full protection
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For example, to protect the first 25 rows and the last 5 out of 256 rows, include the following array in your
application:

CY_SECTION(".cyflashprotect") __USED
static const unsigned char flash_protect[0x20] =
{
  0xFF, 0xFF, 0xFF, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
0x00,
  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
};

To enable flash security, program the device with the updated code. If you wish to reprogram a protected
device, you must first erase it.

5.1.13 Debugging/programming for secure configuration devices
The BootROM on devices such as PSOC™ Control and PSOC™ Edge can temporarily disable access to the core's
Access Port(AP). This behavior is determined by the security policy during device provisioning. However, access
can be re-enabled using a debug certificate. If a debugger identifies that the AP is disabled, it will upload and
verify the debug certificate found in the "./packets/debug_token.bin" file within the current project folder.

5.1.13.1 Single-core Projects
By default, the debug certificate must be located in ./packets/debug_token.bin in the root of the project for both
OpenOCD and Segger J-Link.

OpenOCD

You can change the path and address of the debug certificate using the following command:

-c "set DEBUG_CERTIFICATE %PATH_TO_TOKEN%"
-c "set DEBUG_CERTIFICATE_ADDR %HEX_ADDRESS%"
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J-Link

Note: It is important to recognize that neither the name of the certificate file or its location can be changed.
The debug certificate must be located in the root of the project/application.

5.1.13.2 Multi-core Projects

OpenOCD

As with single-core projects, you can change the path and address of the debug certificate using the following
command:

-c "set DEBUG_CERTIFICATE %PATH_TO_TOKEN%"
-c "set DEBUG_CERTIFICATE_ADDR %HEX_ADDRESS%"

J-Link

Note: Always remember to locate ./packets/debug_token in the root of each application's core (sub-
project).
It is important to recognize that neither the name of the certificate file or its location can be changed.

5.1.13.3 Multi-core debug CM33 secure application booting from RRAM
When using multi-core debug CM33 secure applications booting from RRAM (for example
PSOC_Edge_RTC_periodic_wakeup), you must configure the launch configuration to add the SMIF IP enabling
commands.
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Add the following under the Startup tab under Run/Restart Commands:

For KitProg3/MiniProg4

monitor mww 0x54004054 0
monitor mww 0x54004050 4

For J-Link

monitor memU32 0x54004054=0
monitor memU32 0x54004050=4

5.2 AIROC™ Bluetooth® programming/debugging
AIROC™ Bluetooth® applications have different launch configurations than PSOC™ MCU applications. Bluetooth®

applications use External Tools configurations for programming the device, and Attach configurations for
attaching to the debugger. The Program launch configurations are available from the Quick Panel when you
select <app name> project. Each configuration is preceded by the application name.
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5.2.1 Program configuration
This launch configuration runs a script and programs the device's memories.
• <app-name> Program: Program is used to build and program embedded applications onto the target

device.

5.2.2 Attach configurations
The Attach configurations are used to attach to the debugger without first programming the device. They
include:
• <app-name> Attach_JLink
• <app-name> Attach_KitProg3_MiniProg4

5.2.3 Debug settings
AIROC™ Bluetooth® devices use the JTAG SWD interface on a kit for debug via OpenOCD or J-Link probe.
Typically, GPIOs need to be reprogrammed (via firmware) to enable SWD, so debug can't be performed directly
after a device reset. The debugger is usually attached to a running device and symbols only are loaded.
The CYW920819EVB-02 and CYBT-213043-MESH kits have additional requirements in order to launch Eclipse
debugger. In general, most debugging for these kits is done with logs and sniffers, since real time execution is
usually needed for the protocols to run properly.
Refer to the AIROC™ Hardware Debugging document for more details.
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