Controller Area Network (CAN): License of Robert Bosch GmbH

**We Listen to Your Comments**

Any information within this document that you feel is wrong, unclear or missing at all? Your feedback will help us to continuously improve the quality of this document. Please send your proposal (including a reference to this document) to:

mcdocu.comments@infineon.com
LEGAL DISCLAIMER

THE INFORMATION GIVEN IN THIS APPLICATION NOTE IS GIVEN AS A HINT FOR THE IMPLEMENTATION OF THE INFINEON TECHNOLOGIES COMPONENT ONLY AND SHALL NOT BE REGARDED AS ANY DESCRIPTION OR WARRANTY OF A CERTAIN FUNCTIONALITY, CONDITION OR QUALITY OF THE INFINEON TECHNOLOGIES COMPONENT. THE RECIPIENT OF THIS APPLICATION NOTE MUST VERIFY ANY FUNCTION DESCRIBED HEREIN IN THE REAL APPLICATION. INFINEON TECHNOLOGIES HEREBY DISCLAIMS ANY AND ALL WARRANTIES AND LIABILITIES OF ANY KIND (INCLUDING WITHOUT LIMITATION WARRANTIES OF NON-INFRINGEMENT OF INTELLECTUAL PROPERTY RIGHTS OF ANY THIRD PARTY) WITH RESPECT TO ANY AND ALL INFORMATION GIVEN IN THIS APPLICATION NOTE.

Information

For further information on technology, delivery terms and conditions and prices please contact your nearest Infineon Technologies Office (www.infineon.com).

Warnings

Due to technical requirements components may contain dangerous substances. For information on the types in question please contact your nearest Infineon Technologies Office.

Infineon Technologies Components may only be used in life-support devices or systems with the express written approval of Infineon Technologies, if a failure of such components can reasonably be expected to cause the failure of that life-support device or system, or to affect the safety or effectiveness of that device or system. Life support devices or systems are intended to be implanted in the human body, or to support and/or maintain and sustain and/or protect human life. If they fail, it is reasonable to assume that the health of the user or other persons may be endangered.
## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>Intro</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>Needed Material</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>6</td>
</tr>
<tr>
<td>Installing Tools</td>
<td></td>
</tr>
<tr>
<td>3.1</td>
<td>6</td>
</tr>
<tr>
<td>Installing the Tasking Tool Chain v2.2r1 demo.</td>
<td></td>
</tr>
<tr>
<td>3.2</td>
<td>7</td>
</tr>
<tr>
<td>Installing DAve v2.1.</td>
<td></td>
</tr>
<tr>
<td>3.3</td>
<td>7</td>
</tr>
<tr>
<td>Installing the TC1796 plug-in for DAve.</td>
<td></td>
</tr>
<tr>
<td>3.4</td>
<td>10</td>
</tr>
<tr>
<td>Installing MemTool v3.4.0.</td>
<td></td>
</tr>
<tr>
<td>3.5</td>
<td>10</td>
</tr>
<tr>
<td>Installing MTTY.</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>11</td>
</tr>
<tr>
<td>Configuring the TC1796 with Dave.</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>14</td>
</tr>
<tr>
<td>Creating a project with Tasking.</td>
<td></td>
</tr>
<tr>
<td>5.1</td>
<td>14</td>
</tr>
<tr>
<td>Creating a project</td>
<td></td>
</tr>
<tr>
<td>5.2</td>
<td>18</td>
</tr>
<tr>
<td>Setting the project options.</td>
<td></td>
</tr>
<tr>
<td>5.3</td>
<td>22</td>
</tr>
<tr>
<td>Writing code</td>
<td></td>
</tr>
<tr>
<td>5.4</td>
<td>23</td>
</tr>
<tr>
<td>Compiling and Building the project</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>24</td>
</tr>
<tr>
<td>Connecting the TriBoard.</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>26</td>
</tr>
<tr>
<td>Starting a DAS session.</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>28</td>
</tr>
<tr>
<td>Debugging an application with CrossView.</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>29</td>
</tr>
<tr>
<td>Conclusion</td>
<td></td>
</tr>
</tbody>
</table>
1 Introduction

Dear user,

This document will help you to install and configure the Software and Hardware tools necessary to operate the TC1796. At the end of the instructions described in this Quick Start, you will have a running environment that could be used as a starting point for further development or evaluation work.

This Quick Start goes step-by-step through the necessary procedures in order to:
- Install the demo version of Altium’s Tasking tool chain v2.2.r1 (compiler, assembler, linker, locator, and debugger).
- Install DAve, Infineon’s Digital Application Virtual Engineer and the plug-in specific to TC1796.
- Install MemTool v3.4.0 and MTTY.
- Configure the TriBoard and connect it to the PC.
- Generate automatic code with DAve.
- Create a simple program and compile it.
- Download this program to the TC1796 external RAM and run it.

This simple program consists in having an LED on the TriBoard driven directly by the TC1796. When running the program, one can see the LED blink.

Further examples, that demonstrate more in details the functionalities of the TC1796 Core and Peripherals, can be found in the Hands-On-Training included in the Starter Kit CD.

Please note that all the code examples given in the rest of this application note are aimed at demonstration purpose only. Code is neither optimized nor is its reliability guaranteed.

If you need more information, please contact your nearest Infineon sale’s office. Contact information is available on Infineon web site: www.infineon.com.

We wish you a lot of success with the TC1796!
2 Needed Material

To execute this Quick Start, it is necessary to have a PC equipped with a parallel port and one of the following operating system: Windows NT, Windows XP, Windows 2000, Windows 98. Power user’s rights (or administrator rights) are mandatory to install the programs.

In addition, an AC/DC converter (5.5V -60V) is needed (to supply the TriBoard).

In addition, the following hardware and software tools are required:

Note: All the items below are included in the TC1796 Starter Kit.
- One TriBoard evaluation board for TC1796 BC step.
- A CD-ROM containing the demo version of Tasking Tool Chain v2.2r1.
- A parallel cable.
- DAvE v2.1. and the plug-in .DIP file for TC1796 v2.3.
3 Installing Tools.

1. On your hard drive, create the following directories:
   - "C:\TC1796_SK"
   - "C:\TC1796_SK\QuickStart"
   - "C:\TC1796_SK\Tools"
   - "C:\TC1796_SK\Tools\MTTY"

3.1 Installing the Tasking Tool Chain v2.2r1 demo.

2. Insert the Tasking Demo CD-ROM from ALTIUM in your CD-ROM driver. Run the "setup.exe" file.

3. Select “Tasking Trial Version for TriCore VX-toolset v2.2r1” and press "Install". Follow the installation instructions.

Note: By default, the tool chain is installed in: "C:\Program Files\Tasking\dctc v2.2".

Note: The DAS servers are automatically installed in:
"C:\Program Files\DAS\DAS_v3.1_Edition_1.4v2.2".

Note: At the end of the installation procedure, reboot your computer and proceed with the next step.
3.2 Installing DAve v2.1.

4. If you are using the Starter Kit, insert the Starter Kit CD in your CD-ROM driver and run the file “D:\Tools\DAve\setup.exe”

Otherwise, insert a CD-ROM containing DAve and run setup.exe.

Follow the installation instructions in order to install DAve.

*Note: By default, DAve is installed in: “C:\Program Files\DAve”*

3.3 Installing the TC1796 plug-in for DAve.

5. Double-click on the DAve icon on your desktop:

6. In the menu bar, select: View → Setup Wizard.

7. In the pop-up window:
   - Select “installation”.
   - Press “Forward”.

![Setup Wizard Window](image-url)
8. In the next pop-up window:
   - Select “I want to install products from the DAvE’s web site”.
   - Press “Forward”.

9. In the next pop-up window:
   If you are using the Starter Kit CD, browse for “D:\Tools\DAvE\” and click “Forward”.
   Otherwise, browse for the location containing the DIP file for TC1796 and click “Forward”.

Apologies, but I cannot provide any more details without additional text. The image contains a screenshot of a setup wizard window, which shows the selection of installing products from the DAvE’s website.
10. In the next pop-up window:
   - Select “TC1796”.
   - Press “Forward”.

11. In the next pop-up window: Press “Install”.

The installation of DAvE is now finished. DAvE is now ready to work with the TC1796!
3.4 Installing MemTool v3.4.0.

12. If you are using the **Starter Kit CD**, run the following executable “D:\Tools\MemTool\ap1606034_MemTool_V3.exe”.

   Otherwise, browse for the location containing this file.

   Follow the installation instructions in order to install MemTool.

   *Note: By default, MemTool is installed in: “C:\Program Files\Memtool”.*

3.5 Installing MTTY.

13. If you are using the **Starter Kit CD**, you can find **MTTY.exe** in the following folder: “D:\Tools\MTTY\”.

   Copy MTTY.exe to the following directory in your hard drive:
   “C:\TC1796_SK\Tools\MTTY\”.

All the software tools are now installed. From the next section on, we will use them in order to program the TC1796.
4 Configuring the TC1796 with Dave.

In this section, it will be shown how to configure the TC1796 and how to generate automatically code.

14. Double-click on the DAvE icon on your desktop:

15. In the start-up dialog, click on: 'Create a New Project', or go to: File → New.
16. In the pop-up window, select **TC1796**, and click on ‘Create’

*Note: You may have more choices, if more plug-ins are already installed.*

![Pop-up window with TC1796 selected and 'Create' button highlighted]

17. The ‘Project Settings’ window opens automatically.

   In ‘General’, select **Tasking v2.0**.

![Project Settings window with Tasking v2.0 selected]
18. In ‘System Clock’, select:

- External Clock Frequency: 20MHz.
- Input divider PDIV: $fp = f_{osc} / 2 = 10,000$ MHz.
- Feedback divider (NDIV): $fvco = f_{osc} / P * 60 = 600,000$ MHz.
- Output divider (KDIV): $f_{cpu} = fvco / 4 = 150,000$ MHz.

19. Click on and save the file using the following path:

   “C:\TC1796_SK\QuickStart\QuickStart_example.dav”

20. Let now DAvE generate code for you, by clicking on:

   Note: DAvE opens a new window with the Project Documentation file. On the left hand side a browser window shows the generated files. You can take a look at the generated code or just find out in which file DAvE put the included functions. In general: if the included function is a macro it is included in the ‘.h’ file; if the included function is a function it is included in the ‘.c’ file.
Creating a project with Tasking.

In this section, it will be shown how to create a project with Tasking, to set-up compiler options and to compile the project in order to generate an .elf file that can be downloaded into the TC1796.

5.1 Creating a project

21. Open an EDE session by double-clicking on the icon on your desktop.

22. In the menu bar, select: File → New Project Space

23. In the dialog box:
   -Browse for: “C:\TC1796\SK\QuickStart\QuickStart_ps.psp”.
   -Click ‘OK’.
24. In the ‘Project Properties’ window, click on the ‘add new project’ icon.

![Project Properties window]

Note: You can access the ‘Project Properties’ window by selecting in the menu bar: Project ➔ Properties.

25. In the dialog box:
   - Browse for: "C:\TC1796_SK\QuickStart\QuickStart_example.pjt".
   - Click ‘OK’

![Add New Project to Project Space dialog]

The ‘Project Properties’ window gets updated.
26. In the 'Project Properties' window, click on the 'add existing files' icon.

27. In the dialog box, select:
   - "C:\TC1796_SK\QuickStart\main.h".
   - "C:\TC1796_SK\QuickStart\main.c".
   - Click 'Open'

   The 'Project Properties' window gets updated.

The project is now created. It and its assigned files appear in the browser window on the left of the main Tasking window.
5.2 Setting the project options.

29. In the menu bar, select **Project → Project Options**.

30. **Processor → Processor definition** : select **TC1796B**
31. **Processor** → **Bypasses**: tick ‘All Bypasses’.

32. **C Compiler** → **Preprocessing**: disable ‘automatic inclusion of .sfr files’.
33. **C Compiler → Optimization**: select ‘No optimization’.

34. **C Compiler → Allocation**: remove ‘Default __near allocation’.
Creating a project with Tasking.

35. **Linker** → **Script file** → **Internal Memory: CSRAM**:
   - Alloc: select **ON**.
   - Type: select **ROM**

36. **CrossView Pro** → **Execution Environment**:
   - Select: ‘TriBoard (TC1796B) via DAS’.
   - Click ‘OK’
37. In the main menu, go to Project → Save Options, and save the options at the following location: “C:\TC1796_SK\QuickStart\QuickStart_opt.opt”.

5.3 Writing code

38. In Tasking main window, in the browser on the left, open the file ‘Main.c’.

39. In ‘Main.c’, almost at the end of the file, the code below has to be inserted between the two comments:

```
int i, j;
// Define Port 1/Pin15 as general IO
P1_IOCRI2 = 0x80000000;
// endless loop
while(1) {
    // set led off
    P1_OUT = 0x00008000;
    // dummy operation
    for (i=0;i<1000000;i++)
        j=i;
    // set led on
    P1_OUT = 0x00000000;
    // dummy operation
    for (i=0;i<1000000;i++)
        j=i;
}
```
Creating a project with Tasking.

Note: DAvE doesn’t change code that is inserted in the ‘USER CODE’ sections if you let DAvE regenerate code. Therefore, whenever adding code to the generated code, write it into a ‘USER CODE’ section. If you want to change DAvE generated code or add code outside these ‘USER CODE’ sections you have to modify your changes after each time you let DAvE regenerate code.

5.4 Compiling and Building the project

40. In the menu bar, select: Build → Build, or click the icon. The program should be compiling with no error message. At the end of the building process, the file “quickstart_example.elf” is created.

Note: There may be some warning after the compilation. Just ignore them.
6 Connecting the TriBoard.

41. Connect the TriBoard to the PC via a parallel cable (a cable is supplied with the Starter Kit).

42. Connect a DC power supply (5.5V – 60V) to the TriBoard. Three LEDs should be on.

43. Verify that the jumper J501 is connected to position 1-2 (see picture below).

44. Configure the DIP switches so that: 1, 2, 4, 5, 6 are ON, the rest are OFF (see picture below).

45. Press the blue reset button (see picture below).
Figure 2  Hardware settings of the TriBoard.

Note: For more information on the TriBoard, please refer to the TriBoard Hardware Manual (contained in the Starter Kit CD).
Starting a DAS session.

46. Open file das_gui_deviceScanner.exe. This file is located by default in:
   “C:\Program Files\DAS\DAS_v3.1_Edition_1.4\clients”.
   The “DAS Device Scanner” window pops up.

47. Click on “Start DAS Server”.

A new window “DAS Server Control panel” pops up.
48. In this new window, click on “Installed Servers”.

A new window “Installed DAS servers” pops up.

49. In this new window, click on “Start” in order to start the JTAG via LPT server.

Now, if you look back at the “DAS Device Scanner” window, you can notice that TC1796B has been detected.
8  Debugging an application with CrossView.

50. In Tasking, start the CrossView debugger by clicking on the icon: ![icon]
CrossView opens automatically and download the application quickstart_example.elf.

51. In CrossView, click on the icon: ![icon] in order to run the application

The LED on Board is now blinking. The TC1796 executes the program successfully!!
9 Conclusion

In this document, the different steps to save a simple program in the on-board external RAM of the TC1796 have been described.

For more application hints on how to save code in other locations (internal Flash, internal SRAM) and how to operate the Core and peripherals of the TC1796, please refer to the Hands-On-Training included in the Starter Kit CD-ROM.