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Scope of work

Demonstrate how to implement the OneEye shell over the UART (USB)
Interface. A Shell is used to parse a command line and call the
corresponding command execution.

After configuring the OneEye UART interface, a OneEye shell is used to
Interpret and manage commands like "info" or "help".
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Introduction

» OneEye is a GUI that enables the creation of interactive Graphical User Interface. Graphical
elements can be drag from a toolbox and drop onto the GUI. The behavior of the created
GUI can be customized. Different communication interfaces like UART, Ethernet, CAN, DAS
can be used to interact with the embedded system

» SyncProtocol / ProtocolBB is a synchronous protocol that enables data streaming between
the target microcontroller and OneEye. It enables to open multiple communication channels,
provide packet acknowledge and packet checksum. Data are transported within a message
with a message ID and a message payload. See the OneEye help for more information.
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> Note: It is recommended to go through some of the basic tutorials listed in the help
embedded in OneEye (Menu: Help -> OneEye help). This enables a quicker ramp-up in the
OneEye concept and ensures a nice journey with OneEye
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Configuration overview

In this configuration a shell running on the microcontroller is connected to the COM port.

In OneEye, two signals bb.in and bb.out are used to connect the COM port data stream to the BB protocol.
The BB protocol is configured to open a channel reserved for the shell. This channel connects to the lineEdit
and textEdit with the console.in and console.out signals.
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Implementation - AURIX

Enabling the OneEye library

The OneEye library must be enabled by adding the following line to Ifx_Cfg.h:
#define IFX_OE_AL_USE_AURIX_ILLD

Configuring the UART communication

The UART communication is initialized with the function initUart(), which also initializes the BB protocol.

In the infinite while loop, the function processUart() executes the SyncProtocol.

Configuring the OneEye shell

A OneEye shell (Ifx_Oe_Shell) is an object that enables command line parsing and command execution.
The OneEye shell communication interface (Ifx_Oe_ShellBb) enables streaming of data using the BB
protocol (Ifx_Oe_SyncProtocol).

The OneEye shell is initialized with initShell() / Ifx_Oe_Shell_init().

The ifx_oe_shell.h file can be found in the Libraries\OneEye directory.

Running the shell

The shell is executed in the background loop by calling processShell() / Ifx_Oe_Shell _process().
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Run and Test

> After code compilation, flash the device using the Flash button @@ to ensure that the
program is running on the device

»  For this training, the OneEye application is required for visualizing the values. OneEye can
be opened inside the AURIX™ Development Studio using the following icon:

File Edit Source Refactor Navig'ﬂearch Project Debug Window Help
| )" E CKIE E E '.:} |:?:| #ﬁl - .) - | - ’l‘f::l l::_& {:j - -
|
v
Onekye — O x

> Clicking the OneEye

icon automatically
opens the OneEye
configuration for the
active project. If no
configuration exists, it
is created by AURIX™
Development Studio

OneEye Version 2.46.0
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Implementation - OneEye

In this training, the OneEye configuration is provided inside the Libraries folder. The following steps are
needed to configure the oscilloscope from a brand-new configuration.

Setup OneEye for editing

Select the OneEye menu “Options -> Edit mode” (if not already checked) to enable the edit mode.

Select the OneEye menu “View -> Browser box”, “View -> Property box”, “View -> Tool box” (if not already
checked) to display the browser, property box, and tool box. Note that the box can be moved around.

Tool box a8 x Property box B8 x

Elaarsauge
Check Box

Path QObject Title

configuration
debugBox

OneEye Version 2.46.0 1105, 670
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Implementation - OneEye

Removing the default DAS interface

When the OneEye configuration is created by ADS, it is already setup with a DAS interface.
Select the interface in the Browser box and delete it with “right click and remove” as it is not required in

this example.

OneEye - m} X
File Options View Help
Tool box T X Property box g %
~
H Plugin Com Port: DAS
pacatas plugin PCom_DASHDAS

server-host-address |localhost

Check Box
server-name UDAS
O connect
clockees f [eos ]
N

Combo Box
system-key {ADS}

@ Dial
i Graph
i Graph Channel

Goan &
< >
Browser box g X
All ~
Path Object Title  *
signals
ayo
|l interface interface.
DAS Interace.
configuration
W
AL
< >

OneEyeVersion 2.46.0 1105, 670
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Implementation - OneEye

Configuring the UART interface: Signal creation
The first step is to create two signals to connect the received and transmit data over the UART.

Create a signal group and set its name property to bb.

Onekye - O X
File Options View Help
Browser box e x| Property box g x
Al v "
Signal: group
Path Ohbject Title { name |bb |
layout offset
configuration sccess
model-update-value-enabled O
user-data I:I
send-get-request ]
on-updated I:I
include-path l:l
include-as-read-only
< > Enum values
Tool box Browser box Match events hd

OneEye Version 2.48.0 937, 465




(infineon

Implementation - OneEye

Add two signals of type char into the bb group, name them in and out, and set their title property to
respectively BB in and BB out.

Onekye - O X
File Options View Help
Browser box g X Property box g X
Al v "
Signal: char
Path Object Title pf name [in |
“ signals
h
“ bb group type char
offset
out char BBout
configuration model-update-value-enabled O
P title [BBin |

send-get-request ]

on-updated

Enum values

Match events

< >

Connections

Tool box Browser box

OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Configuring the UART interface: COM port
Right click in an empty area of the Browser box, and select Add child -> Interface. Then right click on the

created interface and select Add child -> com. Select the com item and set its device property to the COM
port connected to the AURIX board. Set the baudrate property to 115200 and click connect.

The COM port is now opened and ready for communication.

OneEye

File Options View Help

Browser box g X Property box g X

All w
Plugin Com Port: com

Path Object Title plugin PCom_Corezcom
“ signal
signats device COM17
bb group
layout »] baudrate 115200
~ interf, COM.COM1T
interface connedt

;ﬁam COM CORMIT
contiguration

< >

Tool box Browser box

OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Configuring the UART interface: Transmit stream

Right click on the interface in the Browser box, and select Add child -> dataMessageHandler. Then right
click on the created dataMessageHandler and select Add child -> message to create a message item.
Configure the message with the id=0xFE, interval=0.001, send-on-new-data checked, dir=tx, stream
checked.

OneEye

File Options View Help

Browser box g X Property box g X
All w
Message: message
Path Object Title id |oxFE |
> signal
S interval [0.001 |
layout P
v interface COM.COM1T send-on-new-data
v dataMessageHandler dir x -
¥ MESSaEE irn
field bb.out type extended hd
¥ message 0xFF
length 0
field bb.in T = | |
<
com COM.COM1T P stream |
configuration
£ >
Tool box Browser box
OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Right click on the message, and select Add child -> field.
Configure the field with name=bb.out, bit-pos=0, buffer=512.

Now, data will be transmitted over the UART each time the bb.out signal is written with some data.

Onekye

File Options View Help

Browser box JF X Property box 5 X
All ~
Message field:  field
Path Object Title name bb.out ]
> signal
signals Pl bit-pos |O |
layout
v interface COM.COM17 buffer |512 |
w
dataMessageHandler PR ket O
¥ Message OxFE
I field : oot
“ message 0xFF
field bb.in
com COM,CoM17
configuration
€ >
Toolbox  Browser box
OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Configuring the UART interface: Receive stream

Right click on the dataMessageHandler and select Add child -> message to create a second message item.
Configure the message with the id=0xFF, interval=-1, dir=rx, stream checked.

OneEye

File Options View Help

Browser box JF X Property box 5 X
All -
Message: message
Path Object Title id |oxFF |
y
signals interval |-1 |
layout >
v interface COM.COM1T send-on-new-data [
v dataMessageHandler dir |rx vl
¥ message 0xFE
field bb.out type |extended v
b e
mes.s..age i length |O |
field bb.in
com COM.COM1T PLstream |
configuration
£ >
Tool box Browser box
OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Right click on the message, and select Add child -> field.
Configure the field with name=Dbb.in, bit-pos=0.

Now each time data are received over the UART, the bb.in signal will be updated.

Onekye - O X
File Options View Help
Browser box g X Property box g X
Al v|
Message field:  field
Path Object Title name bh.in + -
: >
>
signals bit-pos |'U |
layout
v interface COM.COM17 buffer lo |
v dataMessageHandler buffer-as-pakeet 0
¥ message 0xFE
field bb.out
¥ Message 0xFF
I field : derbrsier
com COM,.COoM17
configuration
£ >
Tool box Browser box
OneEye Version 2.48.0 937, 465




Implementation - OneEye

Configuring the UART interface: Push button
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Drag and drop a pushButton widget from the toolbox onto the layout, configure it with title=Setup Serial

Interface, on-click={show.connection.ui}.

Communication interface setup ? X
Clicking the button now shows the COM port configuration window.
Plugin Com Port: com
plugin PCom_Caoretcom
OneEye
> device COM17
File Options View Help
baudrate 115200
Browser box g X Property bo
connect
All -
Plugin w
Close
- T [eex ]
signals .
Pr— L .
pushButten I = : up Se data-out I:I +
interface COM.COM17
configuration auto-connect I:I 2 -
title Setup Serial Interface
Setup Serial Interface user-data | |
enabled defing¢d-by-connection w
visible yES W
update-method on-new-data w
style-sheet
i = Pl on-click |{5how.connection.ui} |I v
Tool box Browser box < 2
OneEye Version 2.48.0 937,472




Implementation - OneEye

Configuring the BB protocol
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Right click in an empty area of the Browser box, and select Add child -> protocolEngine. Then right click on
the created protocolEngine and select Add child -> protocol-core-bb. Connect the BB protocol stream to
the bb.in and bb.out signals by setting respectively the data-in and data-out properties. Set the name
property to BB-core. And set the timeout to 2000 ms so that frames are dropped after 2 seconds in case the

microcontroller is not answering.

OneEye

File Options View Help

Browser box

All

Path
signals
layout
interface

Object Title

COM.COM1T
.BB-core

~ protocolEngine
Iprotocol—corebb =

configuration

€

Tool box Browser box

OneEye Version 2.48.0 937,472

Setup Serial Interface

Property box
Plugin protocol core; protocol-core-bb
name |BB—core
plugin PProtocol_Corenbb
»1 data-in |bb.in
data-out |bb.out
timeout |2000
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Implementation - OneEye

Configuring the Shell: signals creation

Create a signal group and set its name property to console.

Onekye - O x
File Options View Help
Browser box 5 X Property box 5 X
all v| ~
Signal: group
Path Object Title { name |console 1 |
~ cignal
signals — —
console  group
> bb group offset |Dxﬂ |
> layout -
> interface COM.COM17 access read-write v|
> protocolEn... .BB-core model-update-value-enabled |
configuration - title | |
Setup Serial Interface
user-data | |
send-get-request |
on-updated | |
include-path | |
include-as-read-only
Enum values
< >
Match events
I — W
Tool box Browser box
OneEyeVersion 2.48.0 1134 434
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Implementation - OneEye

Add two signals of type char into the console group, name them in and out, and set their title property to
respectively Console Rx and Console Tx. Set the access property of the in signal to read-only and the
access property of the out signal to write-only.

Onekye - O x
File Options View Help
Browser box g X Property box g X
Al v "
Signal: char
Path Object Title name lin | |
~ cignal
signals type char
¥ console  group
in char - Ll offset |Dxﬂ |
ou char Console Tx
S bh sroup ACCESS |reaad—c:anlg||r l V|
> layout model-update-value-enabled |
> interf COM.COM1T
(ntertace : title |ConsoleRx |
> protocolEn... .BBE-core Setup Serial Interface
configuration user-data | |
send-get-request |
on-updated | |
Enum values
Match events
< > Connections
n: Decoder: BB-core w
Tool box Browser box
OneEyeVersion 2.48.0 1134 434
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Implementation - OneEye

Create the Shell widgets

Drag and drop a textEdit widget from the toolbox onto the layout, set the textEdit properties auto-connect to
console.in. Set the update-method to all-on-new-data.

Onekye - O X
File Options View Help
Browser box g X | Setup Serial Interface | Property box g X
Al v|
Plugin widget: textEdit
Path Object id
> signal
signats data-in consolein +
~ layout
jalinte. data-out +
textEdit Console Rx N :
Y i —— TR Plauto-connect |c0n.=.ole.|n I| + | [ - 1
> protocolEngine  .BB-core title | |
configuration
Consale Rx user-data | |
enabled |defined—by—mnnectinn w |
visible |ye-s V|
::updatemethod |all—on—new-data V|l
style-sheet
£ >
Tool box Browser box
OneEye Version 2.48.0 1030, 465
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Drag and drop a lineEdit widget from the toolbox onto the layout, set the lineEdit properties auto-connect to
console.out. Check the capture-key property to enable each key stroke to be send.

Onekye

— O *
File Options View Help
Browser box & Setup Serial Interface Property box g X
All "
Plugin widget: lineEdit
Path Object Title id | |
5 s
signals data-in = -
v layout
pushBu... Setup Seriallnte... Setup Serialnte data-out console.out + -
textEdit  Console Rx e emm———
I lineEdit  Console Tx .I I ENERTHINEE! i =
]
» interface COM.COM17 title
> protocolEn... .BBE-core
configuration Console Rx user-data | |
enabled defined-by-connection ~
visible YES ~
: capture-key
format default ~
format-string |%1 |
format-field-width |0 |
< >
format-base |1ﬂ |
Tool box Browser box Console T format-fill-char | | >
OneEyeVersion 2.48.0 1134 434
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Implementation - OneEye

Connect the lineEdit and textEdit widget to the BB protocol

Right click on the protocol-core-bb and select Add child -> target. Select the target item and set local-port
and remote-port to 2 to match the AURIX settings, set signal-in=console.out, signal-out=console.in.

Onekye

- O *
File Options View Help
Browser box g X Setup Serial Interface Property box g X
All ~
Target: target
Path Object Tit local-port |2 |
5 i
y f;frzaults remote-port |2 |
> interface COM.COM17 signal-in |console.out |
¥ protocolEngine .BB-core _ -
~ protocol-core-bb signal-out |console.|n |
I target SignaE'..." : forward O
configuration send-parent-value ]
Console Rx
< >
Tool box Browser box Censole T
OneEyeVersion 2.48.0 1134 434
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Implementation - OneEye

Test the shell interface
Restart the AURIX software. The shell textbox should display the “Hello World !” text ‘

Enter “info” in the Console Tx lineEdit field ‘ and press ENTER, the microcontroller executes the
printShellinfo() function and should answer as below to acknowledge the command.

Save your configuration with CTRL+S.

Onetye - o «x Exit the edit mode with the OneEye

Fle Spoe DI B menu “Options -> Edit mode” to only
B by 5 b Setup Serial Interface Eiperhibui ) £

— s . see the GUI .

Plugin widget: lineEdit
Path 'I Shell>Hello world! I -
i lsignal: maife data-in <
ayou
> interface The shell command was called ! data-out onsole.out - OHEEYE - O X
~ protocolEngine " . .
v protocol-core-bh Shell> auto-connect + - File Options View Help
target -
configurail:-iin title | ‘ Setup Serial Interface
Console Rx user-data | ‘
enabled defined-by-connection ~
Shell>Hello world!
visible yes -
capture-key info
Console Rx
format default w
The shell command was called !
farmat-string |%1 ‘
Shell:>
format-field-width |0 ‘
< >
— format-baze |10 ‘ © “
I Console Ty
Toolbox  Browser box ' C""WleT"“ |I < 2
OneEye Version 2.48.0 890, 484 OneEye Version 2.48.0
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References

»  AURIX™ Development Studio is available online:
»  https://lwww.infineon.com/aurixdevelopmentstudio

%&%ﬂ > Use the ,Import..." function to get access to more code examples.

> More code examples can be found on the GIT repository:
»  https://github.com/Infineon/AURIX_code_examples

v

For additional trainings, visit our webpage:
https://www.infineon.com/aurix-expert-training

v

~

For questions and support, use the AURIX™ Forum:
https://www.infineonforums.com/forums/13-Aurix-Forum

v
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IMPORTANT NOTICE

The information given in this document shall in no
event be regarded as a guarantee of conditions or
characteristics (“Beschaffenheitsgarantie”).

With respect to any examples, hints or any typical
values stated herein and/or any information
regarding the application of the product, Infineon
Technologies hereby disclaims any and all
warranties and liabilities of any kind, including
without limitation warranties of non-infringement
of intellectual property rights of any third party.

In addition, any information given in this
document is subject to customer’s compliance
with its obligations stated in this document and
any applicable legal requirements, norms and
standards concerning customer’s products and
any use of the product of Infineon Technologies in
customer’s applications.

The data contained in this document is-exclusively
intended for technically trained staff. It is the
esponsibility of ustomer’s technical
departments to—evaluate the suitability of the
product for the intended application and the
completeness of the product information given in
this document with respect to such application.
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For further information on the product,
technology, delivery terms and conditions and
prices please “contact your nearest Infineon
Technologies office (www.infineon.com).

WARNINGS
Due to technical requirements products may
contain dangerous substances. For information
on the types in question please contact your
nearest Infineon Technologies office.

Except as otherwise explicitly “approved b
Infineon Technologies in a written\ document
signed by authorized representatives of\Infineon
Technologies, Infineon Teehnologies’ products
may not be used in—any applications where a
failure of the-product or any consequences of the
use thereof can reasonably be expected to result
n personalinjury.
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