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Scope of work

A Shell is used to parse a command line and call the corresponding
command execution. A OneEye pipe is used to interface OneEye with
the Shell through the DAS interface.

After configuring the OneEye DAS interface, the Shell from ILLDs is used to
Interpret and manage commands like "info" or "help". The example creates a
OneEye pipe and the corresponding DPipe that is used to interface the shell.
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OneEye is a GUI that enables the creation of interactive Graphical User Interface. Graphical
elements can be drag from a toolbox and drop onto the GUI. The behavior of the created
GUI can be customized. Different communication interfaces like UART, Ethernet, CAN, DAS
can be used to interact with the embedded system

The DAS (Device Access Server) can be used in line with Infineon Microcontroller Starter
Kits, Application Kits and DAP MiniWiggler to access the micro controller resources

Recommendation: It is recommended to go through some of the basic tutorials listed in
the help embedded in OneEye (Menu: Help -> OneEye help). This enables a quicker ramp-
up in the OneEye concept and ensure a nice journey with OneEye
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Hardware setup

This code example has been developed for the
board KIT_A2G_TC375 LITE.

The board should be connected to the PC
through the USB port ( 1
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Implementation - AURIX

Configuring the OneEye pipe

A OneEye pipe (Ifx_OneEyeDasPipe) is a special object that is recognized by OneEye and enables
streaming of data between OneEye and the microcontroller. The OneEye pipe is initialized with
Ifx_OneEyeDasPipe_init(). The size parameter passed for the configuration corresponds to the buffer
allocated for the data transmission, in this example 2 buffers of 512 bytes are allocated, one for TX and one
for the RX direction. The Ifx_OneEyeDasPipe.h file can be found in the Libraries\OneEye directory.
Configuring the DPipe

A DPipe is initialized with Ifx_OneEyeDasPipe_stdIfDPipelnit(). The DPipe enables access by the shell to
the OneEye Pipe.

Configuring the Shell

The shell is initialized with Ifx_Shell_init() passing a pointer to the previously initialized DPipe.

Running the Shell

The shell is executed in the background loop by calling Ifx_Shell_process().
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Run and Test

> After code compilation, flash the device using the Flash button @@ to ensure that the
program is running on the device

»  For this training, the OneEye application is required for visualizing the values. OneEye can
be opened inside the AURIX™ Development Studio using the following icon:

File Edit Source Refactor Navig’ﬂearch Project Debug Window Help
| )" E CKIE E E '.:} |:?:| #ﬁl - .) - | - ’l‘f::l l::_& {:j - -
|
v
Onekye — O x

> Clicking the OneEye

icon automatically
opens the OneEye
configuration for the
active project. If no
configuration exists, it
is created by AURIX™
Development Studio

OneEye Version 2.46.0
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Implementation - OneEye

In this training, the OneEye configuration is provided inside the Libraries folder. The following steps are
needed to configure the OneEye from a brand-new configuration.

Setup OneEye for editing

Select the OneEye menu “Options -> Edit mode” (if not already checked) to enable the edit mode.
Select the OneEye menu “View -> Browser box”, “View -> Property box” , “View -> Tool box” (if not
already checked) to display the browser, property box, and tool box.

Close the Welcome screen if it was shown.

File Options View Help

OneEye Version 2.46.0 1105,670
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Implementation - OneEye

Configuring the DAS interface

When the OneEye configuration is created by ADS, it is already setup with a DAS interface.
Select the DAS interface in the Browser box .

Notice the “system-key” {ADS} that enables the connection to the device in parallel with the ADS debugger.

OneEye - m} X
File Options View Help
Tool box T X Property box g X
~
H Plugin Com Port: DAS
e plugin PCom DAS:DAS
o server-host-address |localhost
Check Box >
server-name UDAS
O connect
Clock Gauge
frequency 3e=08
Combo Box
l system-key {ADS}

@ Dial
i Graph
i Graph Channe|

Goan &
< >
Browser box g X
All ~
Path Object Title  *

signals
layout

OneEyeVersion 2.46.0 1105, 670
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Create a debug box to get access to variables from the .elf file
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A debugBox item is already setup by default when ADS creates the OneEye configuration, preconfigured with

the project .elf file path.

Select the DAS interface in the Browser box :
Set the id property to “elf”, which enables to group variables into the signal tree later.

OneEye
File Options View Help

Tool box

H Bar Gauge
Check Box

O Clock Gauge

Combo Box

@ Dial
i Graph
, Graph Channel

=l

<

\ 4

Browser box

All

Object

interface interface.

Title

I debugBox :

<

OneEye Version 2.46.0 1059, 671

Property box

O x

a

*

Debugbox:

elf-path

watches

com-interface-id | das-itf

debugBox

L_KIT_TC37

5_LK.elf

title

I id el
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Implementation - OneEye

Open the debug box viewer and connect to the device

Select the OneEye menu “View -> Debug box viewer” (if not already checked) to display the debug box.
Select the debug box with the id “(elf)” if not yet selected by default.
Note that the debug box enables the selection of the .elf file to be used to get information about the variables.

The Filter field ‘ enables to filter variables by name. E.g. in this example, entering “g_" will filter for global
variables.

To enable the connection with the microcontroller and have read / write access to variables, check the “DAS
connection status” box '

(elf) ‘ >

e_aurix_examples_ads/workspace/OneEye_DAS_Shell_1_KIT_TC375_LK/Libraries/..\Debug\OneEye_DAS_Shell_1_KIT_TC375_LK.elf | |Load ELFfile | |Reload ELF file Clear
‘ DAS connection status: | Qrcle Time: (4008 ms
Filter: |g_

Mame Size | | Mame Value Address
g_oneEyeDasPipe &0 g_oneEyeDasPipe - OxT00005FC
g_shellCommands 48
E_cpusyncEvent 4 d
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Implementation - OneEye

Create signals for the Pipe

In the debug box, search for the g_oneEyeDasPipe‘ variable, right click on it and select “Create pipe for:
g_oneEyeDasPipe”. The watch should appear on the right side of the debug box‘ . Watches are

periodically polled for new values on the micro controller.
Two signals are also automatically created to access the pipe , one for the OneEye to microcontroller

direction (ToTarget), and one for the microcontroller to OneEye direction (FromTarget).

(elf)

e_aurix_examples_ads/workspace/OneEye_DAS_Shell_1_KIT_TC375_LK/Libraries/..\Debug\OneEye_DAS_Shell_1_KIT_TC375_LK.elf | |Load ELFfile | |Reload ELFfile Clear

DAS connection status: | Cycle Time: 0008 ms

o
Mame || Name Value Browser box n
EoneEyeDasPipe I g_oneEyeDasPipe I ‘
I

g_shellCommands
All w

E_cpusyncEvent 4

Path Object Title &

% signals ‘
¥ elf group

¥ g_oneEyeDasPipe Eroup
. . FromTarget char FromTarget
The created signals should appear in ey o e
the browser box under the “signals.elf” layout
interface interface.
grOUp configuration v
< Ambs D e N
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Implementation - OneEye

Create a text box to display the shell text

Drag and drop a textEdit item from the toolbox onto the layout, and set its data-in property to
elf.g_oneEyeDasPipe.FromTarget.

OneEye — O X

File Options View Help

Tool box g X Hello World ! Property box g X

A - ] ~
Signal Generator Channel: Radar Map (rando Enter 'help' to see the command

—¥— slider iior Plugin widget: textEdit

id
Spacer data-in elf.g_oneEyeDasPipe.FromTarget + -

Shell>
E data-out + -
Tab auto-connect | | + -
D title | |
Tab Page user-data | |
enabled defined-by-connection w
TextBrowser
visible yes ~
pdat ethod dat: “
Text Edit I
FromTarget style-sheet
= Tree\l'\ew
v
< >
Browser box (=
All w
Path Object Title
> signals
> layout
> interface interface.
configuration
debugBox
£ >

OneEye Version 2.46.0 1059, 685
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Implementation - OneEye

Create a line edit to enter key stroke to the shell

Drag and drop a lineEdit item from the toolbox onto the layout, and set its data-out property to
elf.g_oneEyeDasPipe.ToTarget. Check the capture-key property to enable each key stroke to be send.

OneEye — O X
File Options View Help
Tool box & X Hello World ! Property box g X
A A
Enter 'help' to see the command D Em— R
e list ! El Bet:
. |
data-in +
ImageBuffer Shells
| abel data-out elf.g_oneEyeDasPipe.ToTarget +
-m Line Edit auto-connect + -
? title | |
Logger user-data | |
E enabled defined-by-connection ~
Logger Channel Dl yes -
E\ s Icapture—ke_‘( I
- uxemux FromTarget
e farmat default w
~—— Named Pipe Client
8 format-strin %1
2 Named Pipe Server - = | |
. format-field-width |ﬂ |
£ >
format-base |10 |
Browser box g x
format-fill-char | |
All
¥ farmat-precision |—l |
Path Object fitle format-format E ~
> signals pdate-method data ~
> layout
> interface interface. style-sheet
configuration
debugBox
min |0 |
< >
ToTarget| max |0 | v

OneEye Version 2.46.0 1059, 685
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Implementation - OneEye

Test the shell interface

The shell textbox should display the “Hello World !” text ‘ if it is not the case, check that the “DAS
connection status” is checked in the debug box viewer.

Enter “info” in the ToTarget lineEdit field ‘ and press ENTER, the microcontroller will execute the
printShellinfo() function and should answer as below to acknowledge the command.

Save your configuration with CTRL+S.

File Options View Help
Property box 2 x

: Exit the edit mode with the OneEye
“ 7 ™| menu*options > Edit mode’ and

™ Label The shell command was called ! data-out + - CIOSG the “Debu bOX Viewer” tO Onl
Line Edit Shell> auto-connect I:l + - g y

= e ] see the GUI ‘

see the

command list !

$ E enabled defined-by-connection bt On EE}."E - O X
Logger Channel visible yes - y " >
= - File Options View Help
= e FromTarget format oot
. orma aul v ~ .
= Named PipeClient Hello World !

Named Pipe Server v
o ) formatfiedwidtn o | Enter 'help' to see the command list !
Browser box a x

2 formatprecfon FromTarget
; . Shell»info
Path Object Title format-format g ~
signals update-method  on-new-data ~ The shell command was called !
layout
interface interface. style-sheet
She B
configuration Shell>
debugBox
min L] ToTarget
<
TeTErget“ max o " -
OneEye Version 2.46.0

OneEyeVersion 2.46.0 1059,685
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References

@ »  AURIX™ Development Studio is available online:
@ @ »  https://lwww.infineon.com/aurixdevelopmentstudio
)

AURIX™

Use the ,/mport..." function to get access to more code examples.

> More code examples can be found on the GIT repository:
»  https://github.com/Infineon/AURIX_code_examples

v

For additional trainings, visit our webpage:
https://www.infineon.com/aurix-expert-training

v

~

For questions and support, use the AURIX™ Forum:
https://www.infineonforums.com/forums/13-Aurix-Forum

v
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IMPORTANT NOTICE

The information given in this document shall in no
event be regarded as a guarantee of conditions or
characteristics (“Beschaffenheitsgarantie”).

With respect to any examples, hints or any typical
values stated herein and/or any information
regarding the application of the product, Infineon
Technologies hereby disclaims any and all
warranties and liabilities of any kind, including
without limitation warranties of non-infringement
of intellectual property rights of any third party.

In addition, any information given in this
document is subject to customer’s compliance
with its obligations stated in this document and
any applicable legal requirements, norms and
standards concerning customer’s products and
any use of the product of Infineon Technologies in
customer’s applications.

The data contained in this document is-exclusively
intended for technically trained staff. It is the
esponsibility of ustomer’s technical
departments to—evaluate the suitability of the
product for the intended application and the
completeness of the product information given in
this document with respect to such application.
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For further information on the product,
technology, delivery terms and conditions and
prices please “contact your nearest Infineon
Technologies office (www.infineon.com).

WARNINGS
Due to technical requirements products may
contain dangerous substances. For information
on the types in question please contact your
nearest Infineon Technologies office.

Except as otherwise explicitly “approved b
Infineon Technologies in a written\ document
signed by authorized representatives of\Infineon
Technologies, Infineon Teehnologies’ products
may not be used in—any applications where a
failure of the-product or any consequences of the
use thereof can reasonably be expected to result
n personalinjury.
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