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About this document

Scope and purpose

The Secure Policy Configurator is used to open, create or change policy configuration files for the PSoC™ 64
"Secure Boot" MCU devices, also modify policy tools and provision devices.

Intended audience

This document helps application developers understand how to use the Secure Policy Configurator as part of
creating a ModusToolbox™ application.

Document conventions

Convention Explanation
Bold Emphasizes heading levels, column headings, menus and sub-menus
Italics Denotes file names and paths.

Denotes APIs, functions, interrupt handlers, events, data types, error handlers, file/folder names,

Courier New . . D .
directories, command line inputs, code snippets

File > New Indicates that a cascading sub-menu opens when you select a menu item

Abbreviations and definitions
The following define the abbreviations and terms used in this document:

e Application - One or more projects related to each other.
e Configurator - A GUI-based tool used to configure a resource.

e cysecuretools - Asetof Python scripts and policy templates to perform provisioning for the PSoC™ 64
devices.

e DAPLink - Arm Mbed DAPLink is an open-source software project that enables programming and debugging
application software running on Arm Cortex CPUs.

e Image, Single/Multi - Single-image and Multi-image types can be created to define how the CM0+ "secure"
co-processor and CM4 binaries are generated.

e Single-image mode - The default mode, in which the CMO0+ "secure" co-processor code binary is
attached to the beginning of the CM4 binary to form a single binary. Therefore, the CM0+ "secure" co-
processor and CM4 must be updated at the same time, as they require a single update binary.

e Multi-image mode - The CMO+ "secure" co-processor and CM4 binaries are updated individually with
two different update binaries.
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e JSON file - JavaScript Object Notation is a standard data-interchange file format that uses human-readable
text to transmit data objects and store them.

e JWT-JSON Web Token is an open, industry standard RFC 7519 method to securely represent claims
between two parties.

e Monotonic counter ID - The counter to prevent a rollback during the upgrade process. Indicates the
monotonic counter value associated with the image, which is booted. During a "secure" boot, this counter
value is compared to this image version code. During the upgrade process, this counter is incremented to
the value from the image header of the upgrade image.

e Policies - A collection of pre-defined (name, value) pairs that describe what is allowed and not allowed on
the device.

e Provisioning - The act of configuring a device with an authorized set of keys, certificates, credentials, and
firmware images. Once provisioned, the device can be accessed or modified only with the keys injected
adhering to the relevant policies. The act is executed in two steps:

e 1. Provisioning identity; the unique device secret (UDS) and the device public/private key pair.
Note: This occurs only once in a secure manufacturing environment.

e 2. Provisioning keys and policies.
e Reprovisioning - The act of reconfiguring a device with a new certificate.

e Public key certificate - The X.509 type certificate is a standard public key certificate used in many Internet
protocols, including TLS/SSL.

e Certificate - A message, digitally signed by a "Certificate Authority (CA)", linking a public key to the identity
of the certificate holder (can be a URL, name/address, ID/serial number).

e RMA (Return Merchandise Authorization) mode - The device transitions to this mode when the user wants
Cypress to perform failure analysis on the device, which means that any areas of the user’s flash that may
contain proprietary code or sensitive data will be erased automatically.

e Rollback Counter - A special counter accessed by "Secure Boot" code. This counter prevents downgrading
the device to an older version of its software that has been deprecated due to security.

e "Secure Boot" - A bootup process where the firmware being run by the chip is trusted by using strong
cryptographic schemes and an immutable RoT.

e SMIF - Serial Memory interface, hereinafter refers to the highspeed Quad-SPI interface on PSoC™ 6.
e SWD - Single Wire Debug, a two-wire debug port defined for Arm Cortex CPU’s.

Reference documents

Refer to the following documents for more information as needed:

e Eclipse IDE for ModusToolbox™ user guide

e APIlreference guides
e Device datasheets
e Device technical reference manuals

e "Secure Boot" SDK user guide

e KitProg3 user guide
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Overview

1 Overview

The Secure Policy Configurator is part of a collection of tools included with the ModusToolbox™ software. You
can use the Secure Policy Configurator to open, create or change policy configuration files for the PSoC™ 64
"Secure Boot" MCU devices, also modify policy tools and provision devices. For details, refer to the "Secure
Boot" SDK user guide. The Secure Policy Configurator provides easy execution of configuration without using
the command line and editing a policy file without editing the XML policy file.

File Edit View Execute Help

= |

| E % Probe: - 0
Keys Configuration Certificates

D Description Path
1 Device Private Key for key derivation

2 Device Private Key for signing (This is a copy of Key ID 1)

3 Cypress Public Key

4 HS5M Public Key WJfkeys/hsm_state,json

5 OEM Public Key ../keys/oem _state json

6 Custom Key 1

7 Custom Key 2

8 Custom Key3 /keys/USERAPP_CIMA4_KEY.json
9 Custom Key 4

10 Custom Key 5

" AES 256-bit Key derived from 128-bit UDS for key derivation (Reserved)

12 Group Encryption Key [keys/grp_priv_key.json
Notice List @® Log [=]E |
“+ Fix Description Location =
Ready
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2 Installation

The Secure Policy Configurator requires the cysecuretools program, which is installed on Windows systems
as a part of Python bundled with ModusToolbox™ 2.2 and later. For other operating systems, you can download
it from PyPI or here:

https://github.com/Infineon/cysecuretools

2.1 Configuring cysecuretools location

For Windows, cysecuretools isinstalled in the appropriate ModusToolbox™ tools_<version> directory as a
part of Python bundled with the software. The Secure Policy Configurator uses that installation by default.

For macOS and Linux, use one of the following ways:
e Addthe cysecuretools installation directory to the PATH environment variable.

e Select File > Settings and configure a custom path directory to the cysecuretools location.

For detailed cysecuretools installation instructions, refer to the "Secure Boot" SDK user guide.
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3 Quick start

The Quick Start section provides a simple workflow for how to use the Secure Policy Configurator.

3.1 Create an application

Follow instructions in the ModusToolbox™ user guide "Getting Started" chapter to create a new application for
the PSoC™ 64 "Secure Boot" kit.

3.2 Launch the Configurator

Launch the Secure Policy Configurator.

3.3 Create a policy file
To create a new policy file:
1. Select File > New to open the New Configuration dialog.

Note: Using the New command creates multiple policy files (single-image, multi-image, swap), any of
which can be selected for use with the project.

2. Next to the Project directory, click the Browse [ ... ] button and navigate to and select the application
directory, which contains the following by default:

e /path/keys - Keys used for code signing and provisioning.
e /path/packets - Provisioning packets.

e /path/policy - Copied project policy options

e /path/prebuilt - A stored prebuilt bootloader.

3. Inthe Target pull-down menu, select the appropriate device family or kit, and click OK.

4. Select File > Save in the main GUI to generate the user keys.

34 Provision a device
These are the minimum steps if you want to use the default policy settings:
1. Create or open an existing policy file.

2. Pluginthe kit using the kit’s USB cable and connect the host computer to the kit. KitProg3 is powered via
the USB cable.

3. The kit must be in DAPLink mode. Press the Mode button on the kit until the Status LED blinks fast. For
details, refer to the KitProg3 User Guide.

4. Click Refresh Probe List on the toolbar.

5. Select the device from the Probe list in the toolbar.
6. Select Execute > Run Entrance Exam.

7. Select Execute > Provision Device.

If the device is already provisioned, select Execute > Reprovision Device instead.
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Note: The device must be initially configured to be reprovisioned (check the Reprovisioning Options in
the Advanced tab) in order to be reprovisioned later.
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4 Launch the Secure Policy Configurator

The best way to launch the Secure Policy Configurator is within the context of an application using either the
make command or the Eclipse IDE. You can also open the configurator as a stand-alone tool. If you launch the
configurator as part of an application, it defaults to the application directory. If you launch the configurator as a
stand-alone tool, it defaults to the installation directory.

When launched, the Secure Policy Configurator attempts to open the default policy file from the /<path=>/policy
subdirectory. If the policy subdirectory and/or policy files do not exist, the configurator opens an empty
window with a message to create a new or open an existing configuration (policy) file.

File Edit View Execute Help

H < (M- Ly probe ~O

Create new or open existing configuration

Notice List & x| Log & x

Fix Description Location || Log file:

Ready

e Create a new policy file as described under Create a policyfile.

e Use the File > Open menu to locate and open an existing policy file.

4.1 make command

As described in the ModusToolbox™ user guide "Build System" chapter, you can run numerous make
commands in the application directory, such as launching the Secure Policy Configurator. After you have
created a ModusToolbox™ application, navigate to the application directory and type the following command
in the appropriate bash terminal window:

make secure-policy-configurator

This command opens the Secure Policy Configurator GUI for the specific application in which you are working.
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4.2 Eclipse IDE

To launch the Secure Policy Configurator from the Eclipse IDE, right-click on the project and select
ModusToolbox™ > Secure Policy Configurator. You can also open the Secure Policy Configurator by clicking
the link in the Eclipse IDE for ModusToolbox™ Quick Panel.

{5 Proj.. 52 4% Deb.. !MRegi. T Peri.. = B [¥] READMEmd [] README.md READI [ Quick.. 0= Varia.. &7 Expr. 9 Break. = O
SIR=SAVi R
S Emat Ao PSoC 64: "secure bli . o
o , Eclipse IDE for
Ga Into ModusToolbox™
This code example demonstrates the in
Open in New Window » Start
Show In Alt+Shift+W > 1 Toggle an IiE? p,er,‘o,q‘f:a,"sf using » Empty_App (APP_CYSCKIT-064B052-4343W)
[ ModusToalbox™ > Tools - B
» Launches
Show in Local Terminal ¥ BSP Assistant 1.0
B Copy - Device Firmware Update Host Tool 1.60 ~ 1225
Tt e Library Manager 2.0 BSP Assistant 1.0
3 Delete Delete BSP Configurators [ Device Firmware Update Host Tool 1.60
Source N CAPSENSE™ Configurater 5.0 (& Library Manager 2.0
Move.. CAPSENSE™ Tuner 3.0 « BSP Configurators (APP_CYBCKIT-064B0S2-4343W)
T = Device Configurator 4.0 )
QSPI Configurator 4.0 [ CAPSENSE™ Configurator 5.0
= 2y Import.. Segment LCD Configurator 1.50 (new configurator) [ CAPSENSE™ Tuner 5.0
i3 Eport.. Smart |/0 Configurator 4.0 [ Device Configurator 4.0
| Build Project Empty_App Library Configurators & QSPI Configurator 4.0
Clean Project Bluetooth® Configurator 2.60 (new configurator) : Segment LCD Configurater 1.50 (new configurater)
I Refresh F5 LIN Configurator 1.20 (new configurator) [ Smart /0 Configurator 40
Close Project Secure Policy Configurator 1.30

« Empty_App Library Configurators
& Bluetooth ® Configurator 2,60 {new configurater)
[ LIN Configurator 1.20 (new configurator)

I & Secure Policy Configurater 1.30 |

4.3 Executable (GUI)

You can launch the Secure Policy Configurator as a stand-alone tool by running its executable as appropriate
for your operating system (for example, double-click it or select it using the Windows Start menu). By default, it
is installed here:

<install_dir>/ModusToolbox/tools_<version>/secure-policy-configurator<version>

When launched this way, the Secure Policy Configurator opens without a policy configuration file, and the
default directory is where the configurator is installed. You can create a policy configuration file and save it in
the application directory in a subdirectory named "secure".
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5 GUI description

The Secure Policy Configurator GUI contains menus, tabs, and dialogs to configure "secure policy"
configuration files.

5.1 Menus

5.1.1 File

e New - Opens the New Configuration dialog, where you can create a new "secure policy" directory.
¢ Projectdirectory - The path to the folder where a project will be created.
o Target - A drop-down menu to choose a device or a device family to create a project.

e Open...-Opens an existing "secure policy" configuration file (.json).

e Save - Saves changes to the "secure policy" configuration file. This command generates a user key if it does
not exist already.

e Openin System Explorer - Opens your computer’s file explorer tool to the folder that contains the
*.modus file.

e Settings ... - Opens the Settings dialog, where you can choose either the default path to the
cysecuretools software or customize the path.

e Device and Policy - Opens the Device and Policy dialog, where you can change the target device.
e Recent Files - Shows recent files that you can open directly.

e Exit - Closes the configurator.

5.1.2 Edit

e Undo - Undoes the previous change.

e Redo - Redoes the last undone change.

5.1.3 View

e Advanced - Opens a dialog to edit additional "secure policy" configuration settings.
o Notice List, Log, Toolbar - Hide or show these options respectively.

e Reset View - Restores the GUI to the default view.

5.14 Execute

e Get Device Info - Provides a list of available device information in the Log window. This information
includes but is not limited to the following:
e Target
e Flashboot revision
e Silicon ID, Family, and revision
e ProbelD
e Run Entrance Exam - Must confirm that the device is genuine and blank.

¢ Run Entrance Exam and Erase User Flash - Confirms that the device is genuine and blank and erases the
user’s flash. The user is responsible for erasing any secret information.
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e Provision Device - Configures the device with an authorized set of keys, certificates, credentials, and
firmware images.

e Reprovision Device - Provides the device with a new certificate.

o Read Public Keys - Reads the selected key into the Log window. This drop-down menu displays the public
keys, which can be read from the device.

5.1.5 Help

o View Help - Opens this User Guide.

e About Secure Policy Configurator - Opens the About box for version information, with links to open
https://www.infineon.com and the current session log file.

5.2 Toolbar

The toolbar contains several commands also available from the menus.

_‘ﬁ E q,' Probe: > Q

e New - Creates a new “secure policy” directory.

e Open - Opens an existing policy file (.json).

e Save - Saves changes to the policy file. Generates a user key if it does not exist already.
e Undo - Undoes the previous change.

e Redo - Redoes the last undone change.

e Execute - Equivalent to the Execute menu.

e Probe - This is a drop-down menu of all the available probes currently connected to the PC. The user
may select any of the listed probes for the actions in the Execute menu. A note displays to remind the
user to switch the kit or programmer to DAPLink mode.

o Refresh Probe List - Searches for a kit or programmer currently attached to the PC and repopulates
the Probe list.

5.3 Tabs
The Secure Policy Configurator contains several tabs in which to update various settings.

o Keystab
e Configuration tabs

The Secure Policy Configurator operates in Single-image and Multi (two)-image modes, so different
tabs display depending on the selected policy file mode.

e Certificates tab

5.4 Notice List

The Notice List combines notices (errors, warnings, tasks, and any other information) from many places in your
design into a centralized list. If a notice shows a location, you can double-click the entry to navigate to the error
or warning. For details, refer to the description in the Device Configurator guide.
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5.5 Log

The log pane shows any errors or status. A log file collects the output of any executed script to the log pane. The
placement of this log file is consistent with other tools in the build system.

5.6 Keys tab

The Key tab provides a method to associate a Key ID with the appropriate key file.

= H % Probe: v \)

Keys | Configuration Certificates

D Description Path

Device Private Key for key derivation
Device Private Key for signing (This is a copy of Key 1D 1)

Cypress Public Key

1

2

3

4 H5M Public Key W[keys/hsm_state json
5 OEM Public Key fkeys/oem_state,json
6 Custom Key 1

7 Custom Key 2

8 Custom Key 3 ../keys/USERAPP_CMA4_KEY json
9 Custom Key 4

10 Custom Key 5

11 AES 256-bit Key derived from 128-bit UDS for key derivation (Reserved)

12 | Group Encryption Key Wkeysigrp_priv_key.json

5.6.1 ID

e 1,2,3,11 - These keys cannot be modified by the configurator. They are reserved for other purposes.

s 4,5,6,7,8,9,10,12 - The user keys whose entries can be modified. These keys can be loaded with keys
provided by the OEM. Key ID 8 is the default user application key.

5.6.2 Description

This field provides the Keys' assignments.

5.6.3 Path

The Browse [ ... ] button on the right - to select which key is associated with the Key ID and configure the path
to each key file.
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5.7 Configuration tabs
Depending on the selected device and policy file, you will see varying tabs for configuration.

5.7.1 Single-Image

If you open or create a single-image policy file, the Configuration tab displays as follows:

Keys Configuration Certificates

Boot Image (Primary Slot): Upgrade Image (Secondary Slot):
Start address: 0x 10000000 V| Upgrade enabled
Slot size (bytes): 0x68000 External memony: 0 - SMIF Disabled -
CM4 start address: 0x 10010000 Start address: 0x 10068000
Key signing 1D Key 8 - Slot size (bytes): 0x 68000
CM4 debug option: Allow by Certificate - Encrypt upgrade image
CM4 debug token key ID: | Key 3 = | eEp ey

®) Unique Device Key (1D 1)
Version Control: Group Encryption Key (ID 12)

Menotonic counter ID: |0 Encrypt key peer path: |../keys/dev_pub_key.pem

Rollback it lue: |0
ollback counter value: Protected SRAM:
Image version: 0.1
Address: 0%8020000

Start WDT in CM&: Size (bytes): | 0x 10000

WOT timeout (ms): |4000

5.7.2 Single-Image Swap mode

If you open or create a single-image policy file with the swap suffix, the tool adds a parameter called "Set
image OK."

Address: TxB0e0000
Start WDT in Ch&: Size (bytes): |0x10000

WOT timeout (ms): |4000

V| Set image OK

5.7.3 Multi-Image CM4 Configuration

For a multi-image policy file, there are two tabs: CM4 Configuration and CM0+ Configuration. The following
shows the CM4 Configuration tab settings:

Keys CM4 Configuration CMO+ Configuration Certificates

Boot Image (Primary Slot): Upgrade Image (Secondary Slot):
Start address: 0x10060000] v Upgrade enabled
Slot size (bytes): %30000 External memory: 0 - SMIF Disabled -
Key signing ID: Key 8 - Start address: 0x 10090000
CM4 debug option: Allow by Firmware - Slot size (bytes): 0%30000
CM4 debug token key ID: | Key 5 Encrypt upgrade image

Image encryption key ID:
Vs Gt ®) Unique Device Key (1D 1)

Menotonic counter ID: |2 Group Encryption Key (ID 12)

Rollback counter value: |0 Encrypt key peer path: |./keys/dev_pub_key.pem
Image version: 0.1
user guide 13 0of 25 002-31917 Rev. *E
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5.7.4 Multi-lmage CMO0+ Configuration

For a multi-image policy file, there are two tabs: CM4 Configuration and CM0+ Configuration The following
shows the CMO+ Configuration tab settings:

Keys CM4 Configuration CMD+ Configuration Certificates

Boot Image (Primary Slot): Upgrade Image (Secondary Slot):
Start address: 0: 10000000 V| Upgrade enabled
Slot size (bytes): 030000 External memory: 0 - SMIF Disabled
Key signing 1D: Key 8 - Start address: (10030000
CMO+ debug option: Enable - Slot size (bytes): 0x30000
CMO+ debug token key ID: | Key 5 Encrypt upgrade image

Image encryption key ID:

Version Control: ®) Unique Device Key (ID 1)

Monotonic counter ID: |11 Group Encryption Key (1D 12
Rollback counter value: |0 Encrypt key peer path: |../keys/dev_pub_key.pem
Image version: 0.1 Protected SRAM:

Start WDT in CM0+: Address: (x8020000

WDT timeout (ms): [4000 Size (bytes): |0x70000

5.7.5 Multi-lmage Swap mode

If you open or create a multi-image policy file with the swap suffix, the tool adds a parameter called "Set image
OK" to the CMO+ Configuration tab.

Start WOT in CM0+: Address: | 0xB0eDD0D
WDT timeout (ms): |4000 Size (bytes): 010000

V| Set image OK

5.8 Configuration parameters

The following describe the configuration parameters available in the Configuration tabs.

Note: Some of the parameters display only in the specified tab.

5.8.1 Boot image (Primary Slot)

The memory location to execute code.

5.8.1.1 Startaddress

The location of the boot image.

5.8.1.2 Slot size (bytes)

The size of the boot image.

5.8.1.3 CM4 start address (Configuration tab)

This is the location in which the CM4 portion of the image starts. In Single-image mode, the CM0+ binary is
combined with the user’s CM4 code binary.
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5.8.1.4 KeysigningID

The key ID to check the boot image signature. The user must select one of the Custom keys (6-10) in the Keys
tab prior to provisioning.

5.8.1.5 CM4 debug option (Configuration and CM4 tabs)

CMO+ debug option (CM0+ Configuration tab)
Determine how to debug the CM4/CMO0. The options:

e Enable - Always enabled.
e Disable - Always disabled.
e Allow by Firmware - The debug access port may be enabled by the firmware.

e Allow by Certificate - The debug access port may be enabled by the certificate.
5.8.1.6 CM4 debug token key ID (Configuration and CM4 Configuration tabs)

CMO+ debug token key ID (CM0+ Configuration tab)

The ID to the key to authenticate the debugger.

5.8.2 Version control

This box includes three options for firmware upgrade version control and rollback.

5.8.2.1 Monotonic counterID

Prevents a rollback during the upgrade process

5.8.2.2 Rollback counter value

The initial counter value.

5.8.2.3 Image version

The version of the image for the MCU Boot header.

5.8.3 Start WDT

This check box is available on the Single-image Configuration tab or the Multi-image CM0+ Configuration tab.
The watchdog timer is used to protect the device from freezing after updating with an incorrect CM4 or CMO+
image. If this check box is enabled, the timer is used to reset the device and revert to the previous image. This
setting applies to the entire application, and it is separate from the Start WDT setting on the Advanced dialog.

Note: This occurs only if Swap mode is enabled on a CYxx64xA device.

5.8.3.1 WDT timeout (ms)

The parameter to set the time (in milliseconds) after which the device resets automatically (if the watchdog
timer has not been reset previously by the firmware).
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5.8.3.2 Setimage OK (Swap mode only)

After a swap upgrade is completed, the new image updates the flash contents to mark itself "OK", so the
bootloader can choose to run it during the next boot. On a startup, the bootloader inspects the flash contents
to decide if swapping of the application images was completed.

Depending on the use case, the swap can also be made permanent directly (by setting the "image OK" flag
during the image signing). In this case, the bootloader will never attempt to revert the images on the next reset.

Note: In a multi-image case, the bootloader considers "image OK" flags of each image separately, so
both user applications must set the "image ok" flag in their own areas because they consider the
"image OK" flags of images separately.

5.8.4 Upgrade image (Secondary Slot)

The memory location to stage code for the CMO+ upgrade.

5.8.5 Upgrade enabled

If checked, firmware upgrades are allowed.

5.8.5.1 External memory
Specifies the SMIF ID (if any) to upgrade the image. The options:
e 0-SMIF Disabled

e Slave Select-1
e Slave Select-2
e Slave Select-3

e Slave Select-4

5.8.5.2 Start address

The location (Secondary/Slot 1) where the upgrade firmware is stored or staged prior to the bootloader
transferring it to the Primary Slot.

5.8.5.3 Slot size (bytes)

The size of the upgraded image.

5.8.6 Encrypt upgrade image

This check box determines if the upgrade image must be encrypted.

5.8.6.1 Image encryption key ID
Specifies the key to use the upgrade image encryption.

e Unique Device Key (ID 1)
e Group Encryption Key (ID 12)
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5.8.6.2 Encrypt peer key path

The path to the public key file for image encryption. The key is of the Elliptic Curve Digital Signature Algorithm
(ECDSA) type; the file is of the Privacy Enhanced Mail (PEM) format.

5.8.7 Protected SRAM (Configuration and CMO+tabs)

Indicates the memory region for the "secure" CM0+ CPU. The user must not change this from the default unless
the CM0+ code has been changed for a special case.

5.8.7.1 Address

The start address of the Protected SRAM location.

5.8.7.2 Size (bytes)

The size of the Protected SRAM region.

5.9 Certificates tab

The Certificate tab is used to create and add certificates.

Keys | Cenfiguration Certificates

Certificate Path

5.9.1 Add certificate

Clicking the Add Certificate button provides the user with the options to obtain a certificate.

Keys Configuration Certificates

-
.

I Add certificatel Certificate Path

5.9.1.1 Create new certificate

Keys = Configuration Certificates

i
i
| Create new certificate | Certificate Path
ertificate Pa
Lead existing certificate
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Choosing the "Create new certificate" option displays the Certificates window.

© The target must be provisioned before certificate creation,
Subject:

Country:

State:

Organization:

lssuer narme:

Root key path:

Device certificate path:

Encoding: PEM -

Create certificate

Providing a new public key certificate ensures the secure communication over the Internet. Certificate creation
will be skipped if a certificate file already exists.

Note: Certificate creation cannot be executed if the target device is not provisioned.

The user completes the following fields:

o Subject - The title for the certificate.

e Country - The name of the country where the certificate is issued.

e State - The name of the state where the certificate is issued.

e Organization - The name of the organization where the certificate is issued.

e Issuer name - The name of the person by whom the certificate is issued.

e Root key path - The path to the private key file.

e Device certificate path -The location to store the created certificate.

e Encoding - Displays the format of the certificate to be created - PEM or DER. The default is PEM.

Note: The Subject, Country, State, Organization, and Issuer name parameters must include only
alphanumeric symbols.

After completing the fields, click the Create certificate button to add a new entry to the certificates table.

5.9.1.2 Load existing certificate

Choosing the "Load existing certificate" option displays a file dialog box to allow the user to select an-existing
certificate file.

Keys = Configuration Certificates

L
i
Create new certificate Certificate Path
| Load existing certificate
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6 Advanced dialog

The Advanced dialog contains the parameters used for editing policy files. Two versions of the Advanced
dialog display depending on the selected policy file: for Overwrite and Swap upgrade modes. For Swap mode,
select a policy file with the swap suffix.

Overwrite mode Swap mode
SysAP Options: SysAP Options:
Permissions: | Enabled -
Permissions: | Enabled v

v Enable flash reads

v Enable flash reads ¥| Enable flash writes

| Enable flash writes

RMA Options:
RMA Options: RMA allowed: Allowed v
RMA token key ID: | Key 5 -
RMA allowed: Allowed v —— £,
Destroy flash region:
RMA token key ID: | Key 1 v Flash start address: | 0x10000000
Destroy flash region: Flash size (bytes):  |0x200

Flash start address: | 0% 10000000
Startup Options:

Flash size (bytes): (200
Startup clock: 50 MHz IMO + FLL (default) b

Debug listen window: | 20 ms v

Startup Options:

Bootloader Options:

Startup clock: 50 MHz IMO + FLL (default) v
. . Bootload de: | Deb b
Debug listen window: | 20 ms v e [ty
Signing key: Key 5
Bootloader Options: HEX file:
JWT file:
Bootloader mede: | Debug v e
Status partition:
Signing key: Key 5 Start address: 0x101CC000
HEX file: Size (bytes): %4000
e Scratch;
IWTfile e
Start address: 0x101C0000
Reprovisioning Options: Size (bytes): 0xC00D
¥ Enable reprovisioning of bootloader Reprovisioning Options:
¥ Enable reprovisioning of policies v Enable reprovisioning of bootloader

V| Enable reprovisioning of policies
Start WOT in CM0+ (bootloader):
| Start WOT in CMO+ (bootloader):

WOT timeout (ms): {4000

WOT timeout (ms): 4000

The following describe the configuration parameters available in the Advanced dialog.

Note: Some of them display only under operation in Swap mode (specified in the description).

6.1 SysAP Options

These options configure the system access port.
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6.1.1 Permissions

o Enabled -Always enabled. The default option - debugging of the CM4 application is always allowed.
o Disabled - Always disabled. Debugging of the CM4 application is never allowed.

e Allowed - Controlled by the firmware.

Note: Leaving the SysAP in production will create a security risk.

6.1.2 Enable flash reads

If checked, the SysAP can read the flash memory.

6.1.3 Enable flash writes

If checked, the SysAP can write the flash memory.

6.2 RMA Options

These options control if RMA is allowed, which key to use, and what memory to be erased.

6.2.1 RMA allowed

Enables or disables the RMA process.

e Enabled - Always enabled.
o Disabled - Always disabled.

e Allowed - Controlled by the firmware.

6.2.1.1 RMAtoken key ID

The IDs to the RMA certificate keys.

6.2.2 Destroy flash region

If there are secrets in the user’s flash, the Destroy Flash region option allows erasing the user’s secrets in flash
to prevent their disclosure.

Note: This option does not destroy the device; it only erases flash.
6.2.3 Flash start address
Configures the range of flash to be erased during the RMA process.

6.2.4 Flash size (bytes)

Configures the range of flash to be erased during the RMA process.
6.3 Startup Options

6.3.1 Startup clock

Configures the initial clock speed.

user guide 20 of 25 002-31917 Rev. *E
2022-09-29



o~ _.
ModusToolbox™ Secure Policy Configurator user guide ‘ |n f| neon

Advanced dialog

6.3.2 Debug listen window

Configures the amount of time the device waits for an SWD command during the startup.
6.4 Bootloader Options

6.4.1 Bootloader mode
Configures the debugging output.

o Debug - The bootloader produces debugging messages.
o Release - The bootloader does not produce debugging messages.

e Custom - This enables the user to build their own bootloader and provision it. This feature is not currently
supported.

6.4.2 Signing key
The private key to sign the bootloader certificate.

6.4.3 HEX file

The bootloader application/program file.

6.4.4 JWT file

The bootloader certificate file.

6.4.5 Status partition (Swap mode)

An extra flash area to store the Swap status for the upgrade and revert images.

6.4.6 Scratch area (Swap mode)

An extra flash area to store parts of images.

6.4.6.1 Startaddress

The start address of the Swap status area.

6.4.6.2 Size (bytes)

The size of the Swap status area.

6.5 Reprovisioning Options
e Enable reprovisioning of bootloader - Check this box to enable the bootloader reprovisioning. This
allows the OEM to update the bootloader at a later date (not only during development).

e Enable reprovisioning of policies - Check this box to enable the policy reprovisioning. This allows the
OEM to reprovision policies at a later date.
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6.6 Start WDT in CMO+ (bootloader)

This watchdog timer (WDT) is used to protect the device from freezing after updating with an incorrect CM0+
image. If this check box is enabled for the bootloader, the timer is used to reset the device and revert to the
previous image. This setting applies only to the bootloader, and it is separate from the Start WDT setting on
the Configuration tab.

6.6.1 WDT timeout (ms)

The parameter to define the time after which the device resets automatically (if the watchdog timer has not
been reset previously by the firmware).
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7 Version changes

This section lists and describes the changes for each version of this tool.

Version Change descriptions
1.0 New tool.
Fixed minor defects.
110 Updated the "Installation" section with ways to install CySecureTools for macOS and Linux.
120 Added Scratch area.
Changed the address format to uppercase.
Updated the "Quick start" section.
1.30 Changed the device library file from xml to props.json.
Updated the title from "Secure Policy" Configurator to Secure Policy Configurator.
user guide 230f25 002-31917 Rev. *E

2022-09-29



o _.
ModusToolbox™ Secure Policy Configurator user guide |n f| neon

Revision history

Revision history

Revision Date Description

*x 2020-12-17 New spec.

*A 2021-01-22 Updated the MPN name in section "Configuration Parameters" "Start WDT".

*B 2021-03-12 Updated to version 1.10.

*C 2021-09-21 Updated to version 1.20.

D 2022-01-31 Updateq thg Qu!ck start" section flow - changed the "secure" subdirectory for
the application directory.

*E 2022-09-29 Updated to version 1.30.
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